FreeImageAPI Namespace

[image]

FreeImage .NET Documentation
FreeImageAPI Namespace
Send Feedback

Classes

Class | Description
FreeImage | Static class importing functions from the FreeImage library and providing additional functions.
FreeImageBitmap | Encapsulates a FreeImage-bitmap.
FreeImageEngine | Class handling non-bitmap related functions.
MemoryArray<(Of <(T>)>) | Represents unmanaged memory, containing an array of a given structure.
Palette | Provides methods for working with the standard bitmap palette.
Scanline<(Of <(T>)>) | Provides methods for working with generic bitmap scanlines.

Structures

Structure | Description
BITMAP | The BITMAP structure defines the type, width, height, color format, and bit values of a bitmap.
BITMAPINFO | The BITMAPINFO structure defines the dimensions and color information for a DIB.
BITMAPINFOHEADER | This structure contains information about the dimensions and color format of a device-independent bitmap (DIB).
FI16RGB555 | The FI16RGB555 structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 5 bits and so, takes values in the range from 0 to 31.
FI16RGB565 | The FI16RGB565 structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 5 bits and so, takes values in the range from 0 to 31.
FI1BIT | The FI1BIT structure represents a single bit. It's value can be 0 or 1.
FI4BIT | The FI4BIT structure represents the half of a Byte. It's valuerange is between 0 and 15.
FIBITMAP | The FIBITMAP structure is a handle to a FreeImage bimtap.
FICOMPLEX | The FICOMPLEX structure describes a color consisting of a real and an imaginary part. Each part is using 4 bytes of data.
FIICCPROFILE | This Structure contains ICC-Profile data.
FIMEMORY | The FIMEMORY structure is a handle to an opened memory stream.
FIMETADATA | The FIMETADATA structure is an unique search handle for metadata search operations.
FIMULTIBITMAP | The FIMULTIBITMAP structure is a handle to a FreeImage multipaged bimtap.
FIRational | The FIRational structure represents a fraction via two Int32 instances which are interpreted as numerator and denominator.
FIRGB16 | The FIRGB16 structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 16 bits and so, takes values in the range from 0 to 65535.
FIRGBA16 | The FIRGBA16 structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 16 bits and so, takes values in the range from 0 to 65535.
FIRGBAF | The FIRGBAF structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 32 bits and takes values in the range from 0 to 1.
FIRGBF | The FIRGBF structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 32 bits and takes values in the range from 0 to 1.
FITAG | The FITAG structure is a handle to a FreeImage metadata tag.
FIURational | The FIURational structure represents a fraction via two UInt32 instances which are interpreted as numerator and denominator.
RGBQUAD | The RGBQUAD structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 8 bits and so, takes values in the range from 0 to 255.
RGBTRIPLE | The RGBTRIPLE structure describes a color consisting of relative intensities of red, green and blue value. Each single color component consumes 8 bits and so, takes values in the range from 0 to 255.

Delegates

Delegate | Description
OutputMessageFunction | Delegate for capturing FreeImage error messages.

Enumerations

Enumeration | Description
FREE_IMAGE_COLOR_CHANNEL | Color channels. Constants used in color manipulation routines.
FREE_IMAGE_COLOR_DEPTH | Enumeration used for color conversions. FREE_IMAGE_COLOR_DEPTH contains several colors to convert to. The default value 'FICD_AUTO'.
FREE_IMAGE_COLOR_OPTIONS | Constants used in color filling routines.
FREE_IMAGE_COLOR_TYPE | Image color types used in FreeImage.
FREE_IMAGE_COMPARE_FLAGS | List of combinable compare modes.
FREE_IMAGE_DITHER | Dithering algorithms. Constants used in FreeImage_Dither.
FREE_IMAGE_FILTER | Upsampling / downsampling filters. Constants used in FreeImage_Rescale.
FREE_IMAGE_FORMAT | I/O image format identifiers.
FREE_IMAGE_JPEG_OPERATION | Lossless JPEG transformations constants used in FreeImage_JPEGTransform.
FREE_IMAGE_LOAD_FLAGS | Flags used in load functions.
FREE_IMAGE_MDMODEL | Metadata models supported by FreeImage.
FREE_IMAGE_MDTYPE | Tag data type information (based on TIFF specifications) Note: RATIONALs are the ratio of two 32-bit integer values.
FREE_IMAGE_METADATA_COPY | Flags for copying data from a bitmap to another.
FREE_IMAGE_QUANTIZE | Color quantization algorithms. Constants used in FreeImage_ColorQuantize.
FREE_IMAGE_SAVE_FLAGS | Flags used in save functions.
FREE_IMAGE_TMO | Tone mapping operators. Constants used in FreeImage_ToneMapping.
FREE_IMAGE_TYPE | Image types used in FreeImage.
ICC_FLAGS | Flags for ICC profiles.
MD_SEARCH_FLAGS | List different search modes.
FreeImage - The productivity booster. FreeImage is licensed under the GNU General Public License (GPL) and the FreeImage Public License (FIPL).


BITMAP Structure

[image]

FreeImage .NET Documentation
BITMAP Structure
Members See Also Send Feedback
The BITMAP structure defines the type, width, height, color format, and bit values of a bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct BITMAP
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure BITMAP
Visual C++
[SerializableAttribute]
public value class BITMAP

Remarks

The bitmap formats currently used are monochrome and color. The monochrome bitmap uses a one-bit, one-plane format. Each scan is a multiple of 32 bits.

Scans are organized as follows for a monochrome bitmap of height n:

CopyC#
Scan 0
Scan 1
.
.
.
Scan n-2
Scan n-1

The pixels on a monochrome device are either black or white. If the corresponding bit in the bitmap is 1, the pixel is set to the foreground color; if the corresponding bit in the bitmap is zero, the pixel is set to the background color.

All devices that have the RC_BITBLT device capability support bitmaps. For more information, see GetDeviceCaps.

Each device has a unique color format. To transfer a bitmap from one device to another, use the GetDIBits and SetDIBits functions.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAP Members


BITMAP Members

[image] [image] [image]

FreeImage .NET Documentation
BITMAP Members
BITMAP Structure Fields See Also Send Feedback

The BITMAP type exposes the following members.

Fields

Name | Description
bmBits | Pointer to the location of the bit values for the bitmap. The bmBits member must be a long pointer to an array of character (1-byte) values.
bmBitsPixel | Specifies the number of bits required to indicate the color of a pixel.
bmHeight | Specifies the height, in pixels, of the bitmap. The height must be greater than zero.
bmPlanes | Specifies the count of color planes.
bmType | Specifies the bitmap type. This member must be zero.
bmWidth | Specifies the width, in pixels, of the bitmap. The width must be greater than zero.
bmWidthBytes | Specifies the number of bytes in each scan line. This value must be divisible by 2, because the system assumes that the bit values of a bitmap form an array that is word aligned.

See Also

BITMAP Structure


BITMAP Fields

[image] [image] [image]

FreeImage .NET Documentation
BITMAP Fields
BITMAP Structure See Also Send Feedback

The BITMAP type exposes the following members.

Fields

Name | Description
bmBits | Pointer to the location of the bit values for the bitmap. The bmBits member must be a long pointer to an array of character (1-byte) values.
bmBitsPixel | Specifies the number of bits required to indicate the color of a pixel.
bmHeight | Specifies the height, in pixels, of the bitmap. The height must be greater than zero.
bmPlanes | Specifies the count of color planes.
bmType | Specifies the bitmap type. This member must be zero.
bmWidth | Specifies the width, in pixels, of the bitmap. The width must be greater than zero.
bmWidthBytes | Specifies the number of bytes in each scan line. This value must be divisible by 2, because the system assumes that the bit values of a bitmap form an array that is word aligned.

See Also

BITMAP Structure


bmBits Field

[image]

FreeImage .NET Documentation
BITMAP..::.bmBits Field
BITMAP Structure See Also Send Feedback
Pointer to the location of the bit values for the bitmap. The bmBits member must be a long pointer to an array of character (1-byte) values.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IntPtr bmBits
Visual Basic (Declaration)
Public bmBits As IntPtr
Visual C++
public:
IntPtr bmBits

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAP Structure


bmBitsPixel Field

[image]

FreeImage .NET Documentation
BITMAP..::.bmBitsPixel Field
BITMAP Structure See Also Send Feedback
Specifies the number of bits required to indicate the color of a pixel.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort bmBitsPixel
Visual Basic (Declaration)
Public bmBitsPixel As UShort
Visual C++
public:
unsigned short bmBitsPixel

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAP Structure


bmHeight Field

[image]

FreeImage .NET Documentation
BITMAP..::.bmHeight Field
BITMAP Structure See Also Send Feedback
Specifies the height, in pixels, of the bitmap. The height must be greater than zero.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int bmHeight
Visual Basic (Declaration)
Public bmHeight As Integer
Visual C++
public:
int bmHeight

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAP Structure


bmPlanes Field

[image]

FreeImage .NET Documentation
BITMAP..::.bmPlanes Field
BITMAP Structure See Also Send Feedback
Specifies the count of color planes.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort bmPlanes
Visual Basic (Declaration)
Public bmPlanes As UShort
Visual C++
public:
unsigned short bmPlanes

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAP Structure


bmType Field

[image]

FreeImage .NET Documentation
BITMAP..::.bmType Field
BITMAP Structure See Also Send Feedback
Specifies the bitmap type. This member must be zero.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int bmType
Visual Basic (Declaration)
Public bmType As Integer
Visual C++
public:
int bmType

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAP Structure


bmWidth Field

[image]

FreeImage .NET Documentation
BITMAP..::.bmWidth Field
BITMAP Structure See Also Send Feedback
Specifies the width, in pixels, of the bitmap. The width must be greater than zero.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int bmWidth
Visual Basic (Declaration)
Public bmWidth As Integer
Visual C++
public:
int bmWidth

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAP Structure


bmWidthBytes Field

[image]

FreeImage .NET Documentation
BITMAP..::.bmWidthBytes Field
BITMAP Structure See Also Send Feedback
Specifies the number of bytes in each scan line. This value must be divisible by 2, because the system assumes that the bit values of a bitmap form an array that is word aligned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int bmWidthBytes
Visual Basic (Declaration)
Public bmWidthBytes As Integer
Visual C++
public:
int bmWidthBytes

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAP Structure


BITMAPINFO Structure

[image]

FreeImage .NET Documentation
BITMAPINFO Structure
Members See Also Send Feedback
The BITMAPINFO structure defines the dimensions and color information for a DIB.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct BITMAPINFO : IEquatable<BITMAPINFO>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure BITMAPINFO _
    Implements IEquatable(Of BITMAPINFO)
Visual C++
[SerializableAttribute]
public value class BITMAPINFO : IEquatable<BITMAPINFO>

Remarks

A DIB consists of two distinct parts: a BITMAPINFO structure describing the dimensions and colors of the bitmap, and an array of bytes defining the pixels of the bitmap. The bits in the array are packed together, but each scan line must be padded with zeroes to end on a LONG data-type boundary. If the height of the bitmap is positive, the bitmap is a bottom-up DIB and its origin is the lower-left corner. If the height is negative, the bitmap is a top-down DIB and its origin is the upper left corner.

A bitmap is packed when the bitmap array immediately follows the BITMAPINFO header. Packed bitmaps are referenced by a single pointer. For packed bitmaps, the biClrUsed member must be set to an even number when using the DIB_PAL_COLORS mode so that the DIB bitmap array starts on a DWORD boundary.

Note The bmiColors member should not contain palette indexes if the bitmap is to be stored in a file or transferred to another application.

Unless the application has exclusive use and control of the bitmap, the bitmap color table should contain explicit RGB values.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFO Members


BITMAPINFO Members

[image] [image] [image]

FreeImage .NET Documentation
BITMAPINFO Members
BITMAPINFO Structure Methods Fields See Also Send Feedback

The BITMAPINFO type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
GetHashCode | Returns a hash code for this BITMAPINFO structure. (Overrides ValueType..::.GetHashCode()()().)

Operators

Name | Description
Equality | Tests whether two specified BITMAPINFO structures are equivalent.
Inequality | Tests whether two specified BITMAPINFO structures are different.

Fields

Name | Description
bmiColors | The bmiColors member contains one of the following: An array of RGBQUAD. The elements of the array that make up the color table. An array of 16-bit unsigned integers that specifies indexes into the currently realized logical palette. This use of bmiColors is allowed for functions that use DIBs. When bmiColors elements contain indexes to a realized logical palette, they must also call the following bitmap functions: CreateDIBitmap CreateDIBPatternBrush CreateDIBSection The iUsage parameter of CreateDIBSection must be set to DIB_PAL_COLORS. The number of entries in the array depends on the values of the biBitCount and biClrUsed members of the BITMAPINFOHEADER structure. The colors in the bmiColors table appear in order of importance. For more information, see the Remarks section.
bmiHeader | Specifies a BITMAPINFOHEADER structure that contains information about the dimensions of color format.

See Also

BITMAPINFO Structure


BITMAPINFO Fields

[image] [image] [image]

FreeImage .NET Documentation
BITMAPINFO Fields
BITMAPINFO Structure See Also Send Feedback

The BITMAPINFO type exposes the following members.

Fields

Name | Description
bmiColors | The bmiColors member contains one of the following: An array of RGBQUAD. The elements of the array that make up the color table. An array of 16-bit unsigned integers that specifies indexes into the currently realized logical palette. This use of bmiColors is allowed for functions that use DIBs. When bmiColors elements contain indexes to a realized logical palette, they must also call the following bitmap functions: CreateDIBitmap CreateDIBPatternBrush CreateDIBSection The iUsage parameter of CreateDIBSection must be set to DIB_PAL_COLORS. The number of entries in the array depends on the values of the biBitCount and biClrUsed members of the BITMAPINFOHEADER structure. The colors in the bmiColors table appear in order of importance. For more information, see the Remarks section.
bmiHeader | Specifies a BITMAPINFOHEADER structure that contains information about the dimensions of color format.

See Also

BITMAPINFO Structure


bmiColors Field

[image]

FreeImage .NET Documentation
BITMAPINFO..::.bmiColors Field
BITMAPINFO Structure See Also Send Feedback
The bmiColors member contains one of the following: An array of RGBQUAD. The elements of the array that make up the color table. An array of 16-bit unsigned integers that specifies indexes into the currently realized logical palette. This use of bmiColors is allowed for functions that use DIBs. When bmiColors elements contain indexes to a realized logical palette, they must also call the following bitmap functions: CreateDIBitmap

CreateDIBPatternBrush

CreateDIBSection

The iUsage parameter of CreateDIBSection must be set to DIB_PAL_COLORS.

The number of entries in the array depends on the values of the biBitCount and biClrUsed members of the BITMAPINFOHEADER structure.

The colors in the bmiColors table appear in order of importance. For more information, see the Remarks section.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public RGBQUAD[] bmiColors
Visual Basic (Declaration)
Public bmiColors As RGBQUAD()
Visual C++
public:
array<RGBQUAD>^ bmiColors

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFO Structure


bmiHeader Field

[image]

FreeImage .NET Documentation
BITMAPINFO..::.bmiHeader Field
BITMAPINFO Structure See Also Send Feedback
Specifies a BITMAPINFOHEADER structure that contains information about the dimensions of color format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public BITMAPINFOHEADER bmiHeader
Visual Basic (Declaration)
Public bmiHeader As BITMAPINFOHEADER
Visual C++
public:
BITMAPINFOHEADER bmiHeader

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFO Structure


BITMAPINFO Methods

[image] [image] [image]

FreeImage .NET Documentation
BITMAPINFO Methods
BITMAPINFO Structure See Also Send Feedback

The BITMAPINFO type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
GetHashCode | Returns a hash code for this BITMAPINFO structure. (Overrides ValueType..::.GetHashCode()()().)

Operators

Name | Description
Equality | Tests whether two specified BITMAPINFO structures are equivalent.
Inequality | Tests whether two specified BITMAPINFO structures are different.

See Also

BITMAPINFO Structure


Equality Operator

[image]

FreeImage .NET Documentation
BITMAPINFO..::.Equality Operator
BITMAPINFO Structure See Also Send Feedback
Tests whether two specified BITMAPINFO structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    BITMAPINFO left,
    BITMAPINFO right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As BITMAPINFO, _
    right As BITMAPINFO _
) As Boolean
Visual C++
public:
static bool operator ==(
    BITMAPINFO left,
    BITMAPINFO right
)

Parameters

left
Type: FreeImageAPI..::.BITMAPINFO
The BITMAPINFO that is to the left of the equality operator.
right
Type: FreeImageAPI..::.BITMAPINFO
The BITMAPINFO that is to the right of the equality operator.

Return Value

true if the two BITMAPINFO structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFO Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
BITMAPINFO..::.Equals Method
BITMAPINFO Structure See Also Send Feedback

Overload List

Name | Description
Equals(BITMAPINFO) | Tests whether the specified BITMAPINFO structure is equivalent to this BITMAPINFO structure.
Equals(Object) | Tests whether the specified object is a BITMAPINFO structure and is equivalent to this BITMAPINFO structure. (Overrides ValueType..::.Equals(Object).)

See Also

BITMAPINFO Structure
BITMAPINFO Members


Equals Method (BITMAPINFO)

[image]

FreeImage .NET Documentation
BITMAPINFO..::.Equals Method (BITMAPINFO)
BITMAPINFO Structure See Also Send Feedback
Tests whether the specified BITMAPINFO structure is equivalent to this BITMAPINFO structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    BITMAPINFO other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As BITMAPINFO _
) As Boolean
Visual C++
public:
virtual bool Equals(
    BITMAPINFO other
) sealed

Parameters

other
Type: FreeImageAPI..::.BITMAPINFO
A BITMAPINFO structure to compare to this instance.

Return Value

true if obj is a BITMAPINFO structure equivalent to this BITMAPINFO structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFO Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
BITMAPINFO..::.Equals Method (Object)
BITMAPINFO Structure See Also Send Feedback
Tests whether the specified object is a BITMAPINFO structure and is equivalent to this BITMAPINFO structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a BITMAPINFO structure equivalent to this BITMAPINFO structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFO Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
BITMAPINFO..::.GetHashCode Method
BITMAPINFO Structure See Also Send Feedback
Returns a hash code for this BITMAPINFO structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this BITMAPINFO.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFO Structure


Inequality Operator

[image]

FreeImage .NET Documentation
BITMAPINFO..::.Inequality Operator
BITMAPINFO Structure See Also Send Feedback
Tests whether two specified BITMAPINFO structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    BITMAPINFO left,
    BITMAPINFO right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As BITMAPINFO, _
    right As BITMAPINFO _
) As Boolean
Visual C++
public:
static bool operator !=(
    BITMAPINFO left,
    BITMAPINFO right
)

Parameters

left
Type: FreeImageAPI..::.BITMAPINFO
The BITMAPINFO that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.BITMAPINFO
The BITMAPINFO that is to the right of the inequality operator.

Return Value

true if the two BITMAPINFO structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFO Structure


BITMAPINFOHEADER Structure

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER Structure
Members See Also Send Feedback
This structure contains information about the dimensions and color format of a device-independent bitmap (DIB).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct BITMAPINFOHEADER : IEquatable<BITMAPINFOHEADER>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure BITMAPINFOHEADER _
    Implements IEquatable(Of BITMAPINFOHEADER)
Visual C++
[SerializableAttribute]
public value class BITMAPINFOHEADER : IEquatable<BITMAPINFOHEADER>

Remarks

The BITMAPINFO structure combines the BITMAPINFOHEADER structure and a color table to provide a complete definition of the dimensions and colors of a DIB.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Members


BITMAPINFOHEADER Members

[image] [image] [image]

FreeImage .NET Documentation
BITMAPINFOHEADER Members
BITMAPINFOHEADER Structure Methods Fields See Also Send Feedback

The BITMAPINFOHEADER type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
GetHashCode | Returns a hash code for this BITMAPINFOHEADER structure. (Overrides ValueType..::.GetHashCode()()().)

Operators

Name | Description
Equality | Tests whether two specified BITMAPINFOHEADER structures are equivalent.
Inequality | Tests whether two specified BITMAPINFOHEADER structures are different.

Fields

Name Description
biBitCount
Specifies the number of bits per pixel.The biBitCount member of the BITMAPINFOHEADER structure determines the number of bits that define each pixel and the maximum number of colors in the bitmap. This member must be one of the following values.

Value | Meaning
0 | Windows 98/Me, Windows 2000/XP: The number of bits-per-pixel is specified or is implied by the JPEG or PNG format.
1 | The bitmap is monochrome, and the bmiColors member of BITMAPINFO contains two entries. Each bit in the bitmap array represents a pixel. If the bit is clear, the pixel is displayed with the color of the first entry in the bmiColors table; if the bit is set, the pixel has the color of the second entry in the table.
4 | The bitmap has a maximum of 16 colors, and the bmiColors member of BITMAPINFO contains up to 16 entries. Each pixel in the bitmap is represented by a 4-bit index into the color table. For example, if the first byte in the bitmap is 0x1F, the byte represents two pixels. The first pixel contains the color in the second table entry, and the second pixel contains the color in the sixteenth table entry.
8 | The bitmap has a maximum of 256 colors, and the bmiColors member of BITMAPINFO contains up to 256 entries. In this case, each byte in the array represents a single pixel.
16 The bitmap has a maximum of 2^16 colors. If the biCompression member of the BITMAPINFOHEADER is BI_RGB, the bmiColors member of BITMAPINFO is NULL. Each WORD in the bitmap array represents a single pixel. The relative intensities of red, green, and blue are represented with five bits for each color component. The value for blue is in the least significant five bits, followed by five bits each for green and red. The most significant bit is not used. The bmiColors color table is used for optimizing colors used on palette-based devices, and must contain the number of entries specified by the biClrUsed member of the BITMAPINFOHEADER.

If the biCompression member of the BITMAPINFOHEADER is BI_BITFIELDS, the bmiColors member contains three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. Each WORD in the bitmap array represents a single pixel.

Windows NT/Windows 2000/XP: When the biCompression member is BI_BITFIELDS, bits set in each DWORD mask must be contiguous and should not overlap the bits of another mask. All the bits in the pixel do not have to be used.

Windows 95/98/Me: When the biCompression member is BI_BITFIELDS, the system supports only the following 16bpp color masks: A 5-5-5 16-bit image, where the blue mask is 0x001F, the green mask is 0x03E0, and the red mask is 0x7C00; and a 5-6-5 16-bit image, where the blue mask is 0x001F, the green mask is 0x07E0, and the red mask is 0xF800.

24 | The bitmap has a maximum of 2^24 colors, and the bmiColors member of BITMAPINFO is NULL. Each 3-byte triplet in the bitmap array represents the relative intensities of blue, green, and red, respectively, for a pixel. The bmiColors color table is used for optimizing colors used on palette-based devices, and must contain the number of entries specified by the biClrUsed member of the BITMAPINFOHEADER.
32 The bitmap has a maximum of 2^32 colors. If the biCompression member of the BITMAPINFOHEADER is BI_RGB, the bmiColors member of BITMAPINFO is NULL. Each DWORD in the bitmap array represents the relative intensities of blue, green, and red, respectively, for a pixel. The high byte in each DWORD is not used. The bmiColors color table is used for optimizing colors used on palette-based devices, and must contain the number of entries specified by the biClrUsed member of the BITMAPINFOHEADER.

If the biCompression member of the BITMAPINFOHEADER is BI_BITFIELDS, the bmiColors member contains three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. Each DWORD in the bitmap array represents a single pixel.

Windows NT/ 2000: When the biCompression member is BI_BITFIELDS, bits set in each DWORD mask must be contiguous and should not overlap the bits of another mask. All the bits in the pixel do not need to be used.

Windows 95/98/Me: When the biCompression member is BI_BITFIELDS, the system supports only the following 32-bpp color mask: The blue mask is 0x000000FF, the green mask is 0x0000FF00, and the red mask is 0x00FF0000.

biClrImportant
Specifies the number of color indexes that are required for displaying the bitmap. If this value is zero, all colors are required.
biClrUsed
Specifies the number of color indexes in the color table that are actually used by the bitmap. If this value is zero, the bitmap uses the maximum number of colors corresponding to the value of the biBitCount member for the compression mode specified by biCompression.

If iClrUsed is nonzero and the biBitCount member is less than 16, the biClrUsed member specifies the actual number of colors the graphics engine or device driver accesses. If biBitCount is 16 or greater, the biClrUsed member specifies the size of the color table used to optimize performance of the system color palettes. If biBitCount equals 16 or 32, the optimal color palette starts immediately following the three DWORD masks.

When the bitmap array immediately follows the BITMAPINFO structure, it is a packed bitmap. Packed bitmaps are referenced by a single pointer. Packed bitmaps require that the biClrUsed member must be either zero or the actual size of the color table.

biCompression
Specifies the type of compression for a compressed bottom-up bitmap (top-down DIBs cannot be compressed).
Value | Meaning
BI_RGB | An uncompressed format.
BI_RLE8 | A run-length encoded (RLE) format for bitmaps with 8 bpp. The compression format is a 2-byte format consisting of a count byte followed by a byte containing a color index.
BI_RLE4 | An RLE format for bitmaps with 4 bpp. The compression format is a 2-byte format consisting of a count byte followed by two word-length color indexes.
BI_BITFIELDS | Specifies that the bitmap is not compressed and that the color table consists of three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. This is valid when used with 16- and 32-bpp bitmaps.
BI_JPEG | Windows 98/Me, Windows 2000/XP: Indicates that the image is a JPEG image.
BI_PNG | Windows 98/Me, Windows 2000/XP: Indicates that the image is a PNG image.
biHeight
Specifies the height of the bitmap, in pixels. If biHeight is positive, the bitmap is a bottom-up DIB and its origin is the lower-left corner. If biHeight is negative, the bitmap is a top-down DIB and its origin is the upper-left corner.

If biHeight is negative, indicating a top-down DIB, biCompression must be either BI_RGB or BI_BITFIELDS. Top-down DIBs cannot be compressed.

Windows 98/Me, Windows 2000/XP: If biCompression is BI_JPEG or BI_PNG, the biHeight member specifies the height of the decompressed JPEG or PNG image file, respectively.

biPlanes
Specifies the number of planes for the target device. This value must be set to 1.
biSize
Specifies the size of the structure, in bytes.
biSizeImage
Specifies the size, in bytes, of the image. This may be set to zero for BI_RGB bitmaps.

Windows 98/Me, Windows 2000/XP: If biCompression is BI_JPEG or BI_PNG, biSizeImage indicates the size of the JPEG or PNG image buffer, respectively.

biWidth
Specifies the width of the bitmap, in pixels.

Windows 98/Me, Windows 2000/XP: If biCompression is BI_JPEG or BI_PNG, the biWidth member specifies the width of the decompressed JPEG or PNG image file, respectively.

biXPelsPerMeter
Specifies the horizontal resolution, in pixels-per-meter, of the target device for the bitmap. An application can use this value to select a bitmap from a resource group that best matches the characteristics of the current device.
biYPelsPerMeter
Specifies the vertical resolution, in pixels-per-meter, of the target device for the bitmap.

See Also

BITMAPINFOHEADER Structure


BITMAPINFOHEADER Fields

[image] [image] [image]

FreeImage .NET Documentation
BITMAPINFOHEADER Fields
BITMAPINFOHEADER Structure See Also Send Feedback

The BITMAPINFOHEADER type exposes the following members.

Fields

Name Description
biBitCount
Specifies the number of bits per pixel.The biBitCount member of the BITMAPINFOHEADER structure determines the number of bits that define each pixel and the maximum number of colors in the bitmap. This member must be one of the following values.

Value | Meaning
0 | Windows 98/Me, Windows 2000/XP: The number of bits-per-pixel is specified or is implied by the JPEG or PNG format.
1 | The bitmap is monochrome, and the bmiColors member of BITMAPINFO contains two entries. Each bit in the bitmap array represents a pixel. If the bit is clear, the pixel is displayed with the color of the first entry in the bmiColors table; if the bit is set, the pixel has the color of the second entry in the table.
4 | The bitmap has a maximum of 16 colors, and the bmiColors member of BITMAPINFO contains up to 16 entries. Each pixel in the bitmap is represented by a 4-bit index into the color table. For example, if the first byte in the bitmap is 0x1F, the byte represents two pixels. The first pixel contains the color in the second table entry, and the second pixel contains the color in the sixteenth table entry.
8 | The bitmap has a maximum of 256 colors, and the bmiColors member of BITMAPINFO contains up to 256 entries. In this case, each byte in the array represents a single pixel.
16 The bitmap has a maximum of 2^16 colors. If the biCompression member of the BITMAPINFOHEADER is BI_RGB, the bmiColors member of BITMAPINFO is NULL. Each WORD in the bitmap array represents a single pixel. The relative intensities of red, green, and blue are represented with five bits for each color component. The value for blue is in the least significant five bits, followed by five bits each for green and red. The most significant bit is not used. The bmiColors color table is used for optimizing colors used on palette-based devices, and must contain the number of entries specified by the biClrUsed member of the BITMAPINFOHEADER.

If the biCompression member of the BITMAPINFOHEADER is BI_BITFIELDS, the bmiColors member contains three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. Each WORD in the bitmap array represents a single pixel.

Windows NT/Windows 2000/XP: When the biCompression member is BI_BITFIELDS, bits set in each DWORD mask must be contiguous and should not overlap the bits of another mask. All the bits in the pixel do not have to be used.

Windows 95/98/Me: When the biCompression member is BI_BITFIELDS, the system supports only the following 16bpp color masks: A 5-5-5 16-bit image, where the blue mask is 0x001F, the green mask is 0x03E0, and the red mask is 0x7C00; and a 5-6-5 16-bit image, where the blue mask is 0x001F, the green mask is 0x07E0, and the red mask is 0xF800.

24 | The bitmap has a maximum of 2^24 colors, and the bmiColors member of BITMAPINFO is NULL. Each 3-byte triplet in the bitmap array represents the relative intensities of blue, green, and red, respectively, for a pixel. The bmiColors color table is used for optimizing colors used on palette-based devices, and must contain the number of entries specified by the biClrUsed member of the BITMAPINFOHEADER.
32 The bitmap has a maximum of 2^32 colors. If the biCompression member of the BITMAPINFOHEADER is BI_RGB, the bmiColors member of BITMAPINFO is NULL. Each DWORD in the bitmap array represents the relative intensities of blue, green, and red, respectively, for a pixel. The high byte in each DWORD is not used. The bmiColors color table is used for optimizing colors used on palette-based devices, and must contain the number of entries specified by the biClrUsed member of the BITMAPINFOHEADER.

If the biCompression member of the BITMAPINFOHEADER is BI_BITFIELDS, the bmiColors member contains three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. Each DWORD in the bitmap array represents a single pixel.

Windows NT/ 2000: When the biCompression member is BI_BITFIELDS, bits set in each DWORD mask must be contiguous and should not overlap the bits of another mask. All the bits in the pixel do not need to be used.

Windows 95/98/Me: When the biCompression member is BI_BITFIELDS, the system supports only the following 32-bpp color mask: The blue mask is 0x000000FF, the green mask is 0x0000FF00, and the red mask is 0x00FF0000.

biClrImportant
Specifies the number of color indexes that are required for displaying the bitmap. If this value is zero, all colors are required.
biClrUsed
Specifies the number of color indexes in the color table that are actually used by the bitmap. If this value is zero, the bitmap uses the maximum number of colors corresponding to the value of the biBitCount member for the compression mode specified by biCompression.

If iClrUsed is nonzero and the biBitCount member is less than 16, the biClrUsed member specifies the actual number of colors the graphics engine or device driver accesses. If biBitCount is 16 or greater, the biClrUsed member specifies the size of the color table used to optimize performance of the system color palettes. If biBitCount equals 16 or 32, the optimal color palette starts immediately following the three DWORD masks.

When the bitmap array immediately follows the BITMAPINFO structure, it is a packed bitmap. Packed bitmaps are referenced by a single pointer. Packed bitmaps require that the biClrUsed member must be either zero or the actual size of the color table.

biCompression
Specifies the type of compression for a compressed bottom-up bitmap (top-down DIBs cannot be compressed).
Value | Meaning
BI_RGB | An uncompressed format.
BI_RLE8 | A run-length encoded (RLE) format for bitmaps with 8 bpp. The compression format is a 2-byte format consisting of a count byte followed by a byte containing a color index.
BI_RLE4 | An RLE format for bitmaps with 4 bpp. The compression format is a 2-byte format consisting of a count byte followed by two word-length color indexes.
BI_BITFIELDS | Specifies that the bitmap is not compressed and that the color table consists of three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. This is valid when used with 16- and 32-bpp bitmaps.
BI_JPEG | Windows 98/Me, Windows 2000/XP: Indicates that the image is a JPEG image.
BI_PNG | Windows 98/Me, Windows 2000/XP: Indicates that the image is a PNG image.
biHeight
Specifies the height of the bitmap, in pixels. If biHeight is positive, the bitmap is a bottom-up DIB and its origin is the lower-left corner. If biHeight is negative, the bitmap is a top-down DIB and its origin is the upper-left corner.

If biHeight is negative, indicating a top-down DIB, biCompression must be either BI_RGB or BI_BITFIELDS. Top-down DIBs cannot be compressed.

Windows 98/Me, Windows 2000/XP: If biCompression is BI_JPEG or BI_PNG, the biHeight member specifies the height of the decompressed JPEG or PNG image file, respectively.

biPlanes
Specifies the number of planes for the target device. This value must be set to 1.
biSize
Specifies the size of the structure, in bytes.
biSizeImage
Specifies the size, in bytes, of the image. This may be set to zero for BI_RGB bitmaps.

Windows 98/Me, Windows 2000/XP: If biCompression is BI_JPEG or BI_PNG, biSizeImage indicates the size of the JPEG or PNG image buffer, respectively.

biWidth
Specifies the width of the bitmap, in pixels.

Windows 98/Me, Windows 2000/XP: If biCompression is BI_JPEG or BI_PNG, the biWidth member specifies the width of the decompressed JPEG or PNG image file, respectively.

biXPelsPerMeter
Specifies the horizontal resolution, in pixels-per-meter, of the target device for the bitmap. An application can use this value to select a bitmap from a resource group that best matches the characteristics of the current device.
biYPelsPerMeter
Specifies the vertical resolution, in pixels-per-meter, of the target device for the bitmap.

See Also

BITMAPINFOHEADER Structure


biBitCount Field

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.biBitCount Field
BITMAPINFOHEADER Structure See Also Send Feedback
Specifies the number of bits per pixel.The biBitCount member of the BITMAPINFOHEADER structure determines the number of bits that define each pixel and the maximum number of colors in the bitmap. This member must be one of the following values.

Value | Meaning
0 | Windows 98/Me, Windows 2000/XP: The number of bits-per-pixel is specified or is implied by the JPEG or PNG format.
1 | The bitmap is monochrome, and the bmiColors member of BITMAPINFO contains two entries. Each bit in the bitmap array represents a pixel. If the bit is clear, the pixel is displayed with the color of the first entry in the bmiColors table; if the bit is set, the pixel has the color of the second entry in the table.
4 | The bitmap has a maximum of 16 colors, and the bmiColors member of BITMAPINFO contains up to 16 entries. Each pixel in the bitmap is represented by a 4-bit index into the color table. For example, if the first byte in the bitmap is 0x1F, the byte represents two pixels. The first pixel contains the color in the second table entry, and the second pixel contains the color in the sixteenth table entry.
8 | The bitmap has a maximum of 256 colors, and the bmiColors member of BITMAPINFO contains up to 256 entries. In this case, each byte in the array represents a single pixel.
16 The bitmap has a maximum of 2^16 colors. If the biCompression member of the BITMAPINFOHEADER is BI_RGB, the bmiColors member of BITMAPINFO is NULL. Each WORD in the bitmap array represents a single pixel. The relative intensities of red, green, and blue are represented with five bits for each color component. The value for blue is in the least significant five bits, followed by five bits each for green and red. The most significant bit is not used. The bmiColors color table is used for optimizing colors used on palette-based devices, and must contain the number of entries specified by the biClrUsed member of the BITMAPINFOHEADER.

If the biCompression member of the BITMAPINFOHEADER is BI_BITFIELDS, the bmiColors member contains three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. Each WORD in the bitmap array represents a single pixel.

Windows NT/Windows 2000/XP: When the biCompression member is BI_BITFIELDS, bits set in each DWORD mask must be contiguous and should not overlap the bits of another mask. All the bits in the pixel do not have to be used.

Windows 95/98/Me: When the biCompression member is BI_BITFIELDS, the system supports only the following 16bpp color masks: A 5-5-5 16-bit image, where the blue mask is 0x001F, the green mask is 0x03E0, and the red mask is 0x7C00; and a 5-6-5 16-bit image, where the blue mask is 0x001F, the green mask is 0x07E0, and the red mask is 0xF800.

24 | The bitmap has a maximum of 2^24 colors, and the bmiColors member of BITMAPINFO is NULL. Each 3-byte triplet in the bitmap array represents the relative intensities of blue, green, and red, respectively, for a pixel. The bmiColors color table is used for optimizing colors used on palette-based devices, and must contain the number of entries specified by the biClrUsed member of the BITMAPINFOHEADER.
32 The bitmap has a maximum of 2^32 colors. If the biCompression member of the BITMAPINFOHEADER is BI_RGB, the bmiColors member of BITMAPINFO is NULL. Each DWORD in the bitmap array represents the relative intensities of blue, green, and red, respectively, for a pixel. The high byte in each DWORD is not used. The bmiColors color table is used for optimizing colors used on palette-based devices, and must contain the number of entries specified by the biClrUsed member of the BITMAPINFOHEADER.

If the biCompression member of the BITMAPINFOHEADER is BI_BITFIELDS, the bmiColors member contains three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. Each DWORD in the bitmap array represents a single pixel.

Windows NT/ 2000: When the biCompression member is BI_BITFIELDS, bits set in each DWORD mask must be contiguous and should not overlap the bits of another mask. All the bits in the pixel do not need to be used.

Windows 95/98/Me: When the biCompression member is BI_BITFIELDS, the system supports only the following 32-bpp color mask: The blue mask is 0x000000FF, the green mask is 0x0000FF00, and the red mask is 0x00FF0000.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort biBitCount
Visual Basic (Declaration)
Public biBitCount As UShort
Visual C++
public:
unsigned short biBitCount

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


biClrImportant Field

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.biClrImportant Field
BITMAPINFOHEADER Structure See Also Send Feedback
Specifies the number of color indexes that are required for displaying the bitmap. If this value is zero, all colors are required.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint biClrImportant
Visual Basic (Declaration)
Public biClrImportant As UInteger
Visual C++
public:
unsigned int biClrImportant

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


biClrUsed Field

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.biClrUsed Field
BITMAPINFOHEADER Structure See Also Send Feedback
Specifies the number of color indexes in the color table that are actually used by the bitmap. If this value is zero, the bitmap uses the maximum number of colors corresponding to the value of the biBitCount member for the compression mode specified by biCompression.

If iClrUsed is nonzero and the biBitCount member is less than 16, the biClrUsed member specifies the actual number of colors the graphics engine or device driver accesses. If biBitCount is 16 or greater, the biClrUsed member specifies the size of the color table used to optimize performance of the system color palettes. If biBitCount equals 16 or 32, the optimal color palette starts immediately following the three DWORD masks.

When the bitmap array immediately follows the BITMAPINFO structure, it is a packed bitmap. Packed bitmaps are referenced by a single pointer. Packed bitmaps require that the biClrUsed member must be either zero or the actual size of the color table.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint biClrUsed
Visual Basic (Declaration)
Public biClrUsed As UInteger
Visual C++
public:
unsigned int biClrUsed

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


biCompression Field

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.biCompression Field
BITMAPINFOHEADER Structure See Also Send Feedback
Specifies the type of compression for a compressed bottom-up bitmap (top-down DIBs cannot be compressed).
Value | Meaning
BI_RGB | An uncompressed format.
BI_RLE8 | A run-length encoded (RLE) format for bitmaps with 8 bpp. The compression format is a 2-byte format consisting of a count byte followed by a byte containing a color index.
BI_RLE4 | An RLE format for bitmaps with 4 bpp. The compression format is a 2-byte format consisting of a count byte followed by two word-length color indexes.
BI_BITFIELDS | Specifies that the bitmap is not compressed and that the color table consists of three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. This is valid when used with 16- and 32-bpp bitmaps.
BI_JPEG | Windows 98/Me, Windows 2000/XP: Indicates that the image is a JPEG image.
BI_PNG | Windows 98/Me, Windows 2000/XP: Indicates that the image is a PNG image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint biCompression
Visual Basic (Declaration)
Public biCompression As UInteger
Visual C++
public:
unsigned int biCompression

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


biHeight Field

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.biHeight Field
BITMAPINFOHEADER Structure See Also Send Feedback
Specifies the height of the bitmap, in pixels. If biHeight is positive, the bitmap is a bottom-up DIB and its origin is the lower-left corner. If biHeight is negative, the bitmap is a top-down DIB and its origin is the upper-left corner.

If biHeight is negative, indicating a top-down DIB, biCompression must be either BI_RGB or BI_BITFIELDS. Top-down DIBs cannot be compressed.

Windows 98/Me, Windows 2000/XP: If biCompression is BI_JPEG or BI_PNG, the biHeight member specifies the height of the decompressed JPEG or PNG image file, respectively.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int biHeight
Visual Basic (Declaration)
Public biHeight As Integer
Visual C++
public:
int biHeight

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


biPlanes Field

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.biPlanes Field
BITMAPINFOHEADER Structure See Also Send Feedback
Specifies the number of planes for the target device. This value must be set to 1.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort biPlanes
Visual Basic (Declaration)
Public biPlanes As UShort
Visual C++
public:
unsigned short biPlanes

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


biSize Field

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.biSize Field
BITMAPINFOHEADER Structure See Also Send Feedback
Specifies the size of the structure, in bytes.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint biSize
Visual Basic (Declaration)
Public biSize As UInteger
Visual C++
public:
unsigned int biSize

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


biSizeImage Field

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.biSizeImage Field
BITMAPINFOHEADER Structure See Also Send Feedback
Specifies the size, in bytes, of the image. This may be set to zero for BI_RGB bitmaps.

Windows 98/Me, Windows 2000/XP: If biCompression is BI_JPEG or BI_PNG, biSizeImage indicates the size of the JPEG or PNG image buffer, respectively.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint biSizeImage
Visual Basic (Declaration)
Public biSizeImage As UInteger
Visual C++
public:
unsigned int biSizeImage

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


biWidth Field

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.biWidth Field
BITMAPINFOHEADER Structure See Also Send Feedback
Specifies the width of the bitmap, in pixels.

Windows 98/Me, Windows 2000/XP: If biCompression is BI_JPEG or BI_PNG, the biWidth member specifies the width of the decompressed JPEG or PNG image file, respectively.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int biWidth
Visual Basic (Declaration)
Public biWidth As Integer
Visual C++
public:
int biWidth

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


biXPelsPerMeter Field

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.biXPelsPerMeter Field
BITMAPINFOHEADER Structure See Also Send Feedback
Specifies the horizontal resolution, in pixels-per-meter, of the target device for the bitmap. An application can use this value to select a bitmap from a resource group that best matches the characteristics of the current device.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int biXPelsPerMeter
Visual Basic (Declaration)
Public biXPelsPerMeter As Integer
Visual C++
public:
int biXPelsPerMeter

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


biYPelsPerMeter Field

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.biYPelsPerMeter Field
BITMAPINFOHEADER Structure See Also Send Feedback
Specifies the vertical resolution, in pixels-per-meter, of the target device for the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int biYPelsPerMeter
Visual Basic (Declaration)
Public biYPelsPerMeter As Integer
Visual C++
public:
int biYPelsPerMeter

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


BITMAPINFOHEADER Methods

[image] [image] [image]

FreeImage .NET Documentation
BITMAPINFOHEADER Methods
BITMAPINFOHEADER Structure See Also Send Feedback

The BITMAPINFOHEADER type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
GetHashCode | Returns a hash code for this BITMAPINFOHEADER structure. (Overrides ValueType..::.GetHashCode()()().)

Operators

Name | Description
Equality | Tests whether two specified BITMAPINFOHEADER structures are equivalent.
Inequality | Tests whether two specified BITMAPINFOHEADER structures are different.

See Also

BITMAPINFOHEADER Structure


Equality Operator

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.Equality Operator
BITMAPINFOHEADER Structure See Also Send Feedback
Tests whether two specified BITMAPINFOHEADER structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    BITMAPINFOHEADER left,
    BITMAPINFOHEADER right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As BITMAPINFOHEADER, _
    right As BITMAPINFOHEADER _
) As Boolean
Visual C++
public:
static bool operator ==(
    BITMAPINFOHEADER left,
    BITMAPINFOHEADER right
)

Parameters

left
Type: FreeImageAPI..::.BITMAPINFOHEADER
The BITMAPINFOHEADER that is to the left of the equality operator.
right
Type: FreeImageAPI..::.BITMAPINFOHEADER
The BITMAPINFOHEADER that is to the right of the equality operator.

Return Value

true if the two BITMAPINFOHEADER structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.Equals Method
BITMAPINFOHEADER Structure See Also Send Feedback

Overload List

Name | Description
Equals(BITMAPINFOHEADER) | Tests whether the specified BITMAPINFOHEADER structure is equivalent to this BITMAPINFOHEADER structure.
Equals(Object) | Tests whether the specified object is a BITMAPINFOHEADER structure and is equivalent to this BITMAPINFOHEADER structure. (Overrides ValueType..::.Equals(Object).)

See Also

BITMAPINFOHEADER Structure
BITMAPINFOHEADER Members


Equals Method (BITMAPINFOHEADER)

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.Equals Method (BITMAPINFOHEADER)
BITMAPINFOHEADER Structure See Also Send Feedback
Tests whether the specified BITMAPINFOHEADER structure is equivalent to this BITMAPINFOHEADER structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    BITMAPINFOHEADER other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As BITMAPINFOHEADER _
) As Boolean
Visual C++
public:
virtual bool Equals(
    BITMAPINFOHEADER other
) sealed

Parameters

other
Type: FreeImageAPI..::.BITMAPINFOHEADER
A BITMAPINFOHEADER structure to compare to this instance.

Return Value

true if obj is a BITMAPINFOHEADER structure equivalent to this BITMAPINFOHEADER structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.Equals Method (Object)
BITMAPINFOHEADER Structure See Also Send Feedback
Tests whether the specified object is a BITMAPINFOHEADER structure and is equivalent to this BITMAPINFOHEADER structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a BITMAPINFOHEADER structure equivalent to this BITMAPINFOHEADER structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.GetHashCode Method
BITMAPINFOHEADER Structure See Also Send Feedback
Returns a hash code for this BITMAPINFOHEADER structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this BITMAPINFOHEADER.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


Inequality Operator

[image]

FreeImage .NET Documentation
BITMAPINFOHEADER..::.Inequality Operator
BITMAPINFOHEADER Structure See Also Send Feedback
Tests whether two specified BITMAPINFOHEADER structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    BITMAPINFOHEADER left,
    BITMAPINFOHEADER right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As BITMAPINFOHEADER, _
    right As BITMAPINFOHEADER _
) As Boolean
Visual C++
public:
static bool operator !=(
    BITMAPINFOHEADER left,
    BITMAPINFOHEADER right
)

Parameters

left
Type: FreeImageAPI..::.BITMAPINFOHEADER
The BITMAPINFOHEADER that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.BITMAPINFOHEADER
The BITMAPINFOHEADER that is to the right of the inequality operator.

Return Value

true if the two BITMAPINFOHEADER structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

BITMAPINFOHEADER Structure


FI16RGB555 Structure

[image]

FreeImage .NET Documentation
FI16RGB555 Structure
Members Example See Also Send Feedback
The FI16RGB555 structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 5 bits and so, takes values in the range from 0 to 31.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FI16RGB555 : IComparable,
    IComparable<FI16RGB555>, IEquatable<FI16RGB555>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FI16RGB555 _
    Implements IComparable, IComparable(Of FI16RGB555),  _
    IEquatable(Of FI16RGB555)
Visual C++
[SerializableAttribute]
public value class FI16RGB555 : IComparable,
    IComparable<FI16RGB555>, IEquatable<FI16RGB555>

Remarks

For easy integration of the underlying structure into the .NET framework, the FI16RGB555 structure implements implicit conversion operators to convert the represented color to and from the Color type. This makes the Color type a real replacement for the FI16RGB555 structure and my be used in all situations which require an FI16RGB555 type.

Examples

The following code example demonstrates the various conversions between the FI16RGB555 structure and the Color structure.
CopyC#
FI16RGB555 fi16rgb;
// Initialize the structure using a native .NET Color structure.
fi16rgb = new FI16RGB555(Color.Indigo);
// Initialize the structure using the implicit operator.
fi16rgb = Color.DarkSeaGreen;
// Convert the FI16RGB555 instance into a native .NET Color
// using its implicit operator.
Color color = fi16rgb;
// Using the structure's Color property for converting it
// into a native .NET Color.
Color another = fi16rgb.Color;

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Members


FI16RGB555 Members

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB555 Members
FI16RGB555 Structure Constructors Methods Properties See Also Send Feedback

The FI16RGB555 type exposes the following members.

Constructors

Name | Description
FI16RGB555 | Initializes a new instance based on the specified Color.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FI16RGB555 structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FI16RGB555 object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FI16RGB555 structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FI16RGB555 structures are different.

Properties

Name | Description
Blue | Gets or sets the blue color component.
Color | Gets or sets the Color of the structure.
Green | Gets or sets the green color component.
Red | Gets or sets the red color component.

See Also

FI16RGB555 Structure


FI16RGB555 Constructor

[image]

FreeImage .NET Documentation
FI16RGB555 Constructor
FI16RGB555 Structure See Also Send Feedback
Initializes a new instance based on the specified Color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FI16RGB555(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
FI16RGB555(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Color to initialize with.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure


FI16RGB555 Methods

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB555 Methods
FI16RGB555 Structure See Also Send Feedback

The FI16RGB555 type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FI16RGB555 structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FI16RGB555 object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FI16RGB555 structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FI16RGB555 structures are different.

See Also

FI16RGB555 Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB555..::.CompareTo Method
FI16RGB555 Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FI16RGB555) | Compares this instance with a specified FI16RGB555 object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FI16RGB555 Structure
FI16RGB555 Members


CompareTo Method (FI16RGB555)

[image]

FreeImage .NET Documentation
FI16RGB555..::.CompareTo Method (FI16RGB555)
FI16RGB555 Structure See Also Send Feedback
Compares this instance with a specified FI16RGB555 object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FI16RGB555 other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FI16RGB555 _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FI16RGB555 other
) sealed

Parameters

other
Type: FreeImageAPI..::.FI16RGB555
A FI16RGB555 to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FI16RGB555..::.CompareTo Method (Object)
FI16RGB555 Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FI16RGB555.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FI16RGB555..::.Equality Operator
FI16RGB555 Structure See Also Send Feedback
Tests whether two specified FI16RGB555 structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FI16RGB555 left,
    FI16RGB555 right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FI16RGB555, _
    right As FI16RGB555 _
) As Boolean
Visual C++
public:
static bool operator ==(
    FI16RGB555 left,
    FI16RGB555 right
)

Parameters

left
Type: FreeImageAPI..::.FI16RGB555
The FI16RGB555 that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FI16RGB555
The FI16RGB555 that is to the right of the equality operator.

Return Value

true if the two FI16RGB555 structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB555..::.Equals Method
FI16RGB555 Structure See Also Send Feedback

Overload List

Name | Description
Equals(FI16RGB555) | Tests whether the specified FI16RGB555 structure is equivalent to this FI16RGB555 structure.
Equals(Object) | Tests whether the specified object is a FI16RGB555 structure and is equivalent to this FI16RGB555 structure. (Overrides ValueType..::.Equals(Object).)

See Also

FI16RGB555 Structure
FI16RGB555 Members


Equals Method (FI16RGB555)

[image]

FreeImage .NET Documentation
FI16RGB555..::.Equals Method (FI16RGB555)
FI16RGB555 Structure See Also Send Feedback
Tests whether the specified FI16RGB555 structure is equivalent to this FI16RGB555 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FI16RGB555 other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FI16RGB555 _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FI16RGB555 other
) sealed

Parameters

other
Type: FreeImageAPI..::.FI16RGB555
A FI16RGB555 structure to compare to this instance.

Return Value

true if obj is a FI16RGB555 structure equivalent to this FI16RGB555 structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FI16RGB555..::.Equals Method (Object)
FI16RGB555 Structure See Also Send Feedback
Tests whether the specified object is a FI16RGB555 structure and is equivalent to this FI16RGB555 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a FI16RGB555 structure equivalent to this FI16RGB555 structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FI16RGB555..::.GetHashCode Method
FI16RGB555 Structure See Also Send Feedback
Returns a hash code for this FI16RGB555 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FI16RGB555.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB555..::.Implicit Method
FI16RGB555 Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FI16RGB555) | Converts the value of a FI16RGB555 structure to a Color structure.
Implicit(Color) | Converts the value of a Color structure to a FI16RGB555 structure.

See Also

FI16RGB555 Structure
FI16RGB555 Members


Implicit Operator

[image]

FreeImage .NET Documentation
FI16RGB555..::.Implicit Operator
FI16RGB555 Structure See Also Send Feedback
Converts the value of a FI16RGB555 structure to a Color structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator Color (
    FI16RGB555 value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FI16RGB555 _
) As Color
Visual C++
static implicit operator Color (
    FI16RGB555 value
)

Parameters

value
Type: FreeImageAPI..::.FI16RGB555
A FI16RGB555 structure.

Return Value

A new instance of Color initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FI16RGB555..::.Implicit Operator
FI16RGB555 Structure See Also Send Feedback
Converts the value of a Color structure to a FI16RGB555 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FI16RGB555 (
    Color value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Color _
) As FI16RGB555
Visual C++
static implicit operator FI16RGB555 (
    Color value
)

Parameters

value
Type: System.Drawing..::.Color
A Color structure.

Return Value

A new instance of FI16RGB555 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FI16RGB555..::.Inequality Operator
FI16RGB555 Structure See Also Send Feedback
Tests whether two specified FI16RGB555 structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FI16RGB555 left,
    FI16RGB555 right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FI16RGB555, _
    right As FI16RGB555 _
) As Boolean
Visual C++
public:
static bool operator !=(
    FI16RGB555 left,
    FI16RGB555 right
)

Parameters

left
Type: FreeImageAPI..::.FI16RGB555
The FI16RGB555 that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FI16RGB555
The FI16RGB555 that is to the right of the inequality operator.

Return Value

true if the two FI16RGB555 structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure


ToString Method

[image]

FreeImage .NET Documentation
FI16RGB555..::.ToString Method
FI16RGB555 Structure See Also Send Feedback
Converts the numeric value of the FI16RGB555 object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure


FI16RGB555 Properties

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB555 Properties
FI16RGB555 Structure See Also Send Feedback

The FI16RGB555 type exposes the following members.

Properties

Name | Description
Blue | Gets or sets the blue color component.
Color | Gets or sets the Color of the structure.
Green | Gets or sets the green color component.
Red | Gets or sets the red color component.

See Also

FI16RGB555 Structure


Blue Property

[image]

FreeImage .NET Documentation
FI16RGB555..::.Blue Property
FI16RGB555 Structure See Also Send Feedback
Gets or sets the blue color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte Blue { get; set; }
Visual Basic (Declaration)
Public Property Blue As Byte
Visual C++
public:
property unsigned char Blue {
    unsigned char get ();
    void set (unsigned char value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure


Color Property

[image]

FreeImage .NET Documentation
FI16RGB555..::.Color Property
FI16RGB555 Structure See Also Send Feedback
Gets or sets the Color of the structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure


Green Property

[image]

FreeImage .NET Documentation
FI16RGB555..::.Green Property
FI16RGB555 Structure See Also Send Feedback
Gets or sets the green color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte Green { get; set; }
Visual Basic (Declaration)
Public Property Green As Byte
Visual C++
public:
property unsigned char Green {
    unsigned char get ();
    void set (unsigned char value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure


Red Property

[image]

FreeImage .NET Documentation
FI16RGB555..::.Red Property
FI16RGB555 Structure See Also Send Feedback
Gets or sets the red color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte Red { get; set; }
Visual Basic (Declaration)
Public Property Red As Byte
Visual C++
public:
property unsigned char Red {
    unsigned char get ();
    void set (unsigned char value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB555 Structure


FI16RGB565 Structure

[image]

FreeImage .NET Documentation
FI16RGB565 Structure
Members Example See Also Send Feedback
The FI16RGB565 structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 5 bits and so, takes values in the range from 0 to 31.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FI16RGB565 : IComparable,
    IComparable<FI16RGB565>, IEquatable<FI16RGB565>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FI16RGB565 _
    Implements IComparable, IComparable(Of FI16RGB565),  _
    IEquatable(Of FI16RGB565)
Visual C++
[SerializableAttribute]
public value class FI16RGB565 : IComparable,
    IComparable<FI16RGB565>, IEquatable<FI16RGB565>

Remarks

For easy integration of the underlying structure into the .NET framework, the FI16RGB565 structure implements implicit conversion operators to convert the represented color to and from the Color type. This makes the Color type a real replacement for the FI16RGB565 structure and my be used in all situations which require an FI16RGB565 type.

Examples

The following code example demonstrates the various conversions between the FI16RGB565 structure and the Color structure.
CopyC#
FI16RGB565 fi16rgb;
// Initialize the structure using a native .NET Color structure.
fi16rgb = new FI16RGB565(Color.Indigo);
// Initialize the structure using the implicit operator.
fi16rgb = Color.DarkSeaGreen;
// Convert the FI16RGB565 instance into a native .NET Color
// using its implicit operator.
Color color = fi16rgb;
// Using the structure's Color property for converting it
// into a native .NET Color.
Color another = fi16rgb.Color;

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Members


FI16RGB565 Members

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB565 Members
FI16RGB565 Structure Constructors Methods Properties See Also Send Feedback

The FI16RGB565 type exposes the following members.

Constructors

Name | Description
FI16RGB565 | Initializes a new instance based on the specified Color.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FI16RGB565 structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FI16RGB565 object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FI16RGB565 structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FI16RGB565 structures are different.

Properties

Name | Description
Blue | Gets or sets the blue color component.
Color | Gets or sets the Color of the structure.
Green | Gets or sets the green color component.
Red | Gets or sets the red color component.

See Also

FI16RGB565 Structure


FI16RGB565 Constructor

[image]

FreeImage .NET Documentation
FI16RGB565 Constructor
FI16RGB565 Structure See Also Send Feedback
Initializes a new instance based on the specified Color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FI16RGB565(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
FI16RGB565(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Color to initialize with.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure


FI16RGB565 Methods

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB565 Methods
FI16RGB565 Structure See Also Send Feedback

The FI16RGB565 type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FI16RGB565 structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FI16RGB565 object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FI16RGB565 structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FI16RGB565 structures are different.

See Also

FI16RGB565 Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB565..::.CompareTo Method
FI16RGB565 Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FI16RGB565) | Compares this instance with a specified FI16RGB565 object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FI16RGB565 Structure
FI16RGB565 Members


CompareTo Method (FI16RGB565)

[image]

FreeImage .NET Documentation
FI16RGB565..::.CompareTo Method (FI16RGB565)
FI16RGB565 Structure See Also Send Feedback
Compares this instance with a specified FI16RGB565 object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FI16RGB565 other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FI16RGB565 _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FI16RGB565 other
) sealed

Parameters

other
Type: FreeImageAPI..::.FI16RGB565
A FI16RGB565 to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FI16RGB565..::.CompareTo Method (Object)
FI16RGB565 Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FI16RGB565.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FI16RGB565..::.Equality Operator
FI16RGB565 Structure See Also Send Feedback
Tests whether two specified FI16RGB565 structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FI16RGB565 left,
    FI16RGB565 right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FI16RGB565, _
    right As FI16RGB565 _
) As Boolean
Visual C++
public:
static bool operator ==(
    FI16RGB565 left,
    FI16RGB565 right
)

Parameters

left
Type: FreeImageAPI..::.FI16RGB565
The FI16RGB565 that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FI16RGB565
The FI16RGB565 that is to the right of the equality operator.

Return Value

true if the two FI16RGB565 structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB565..::.Equals Method
FI16RGB565 Structure See Also Send Feedback

Overload List

Name | Description
Equals(FI16RGB565) | Tests whether the specified FI16RGB565 structure is equivalent to this FI16RGB565 structure.
Equals(Object) | Tests whether the specified object is a FI16RGB565 structure and is equivalent to this FI16RGB565 structure. (Overrides ValueType..::.Equals(Object).)

See Also

FI16RGB565 Structure
FI16RGB565 Members


Equals Method (FI16RGB565)

[image]

FreeImage .NET Documentation
FI16RGB565..::.Equals Method (FI16RGB565)
FI16RGB565 Structure See Also Send Feedback
Tests whether the specified FI16RGB565 structure is equivalent to this FI16RGB565 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FI16RGB565 other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FI16RGB565 _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FI16RGB565 other
) sealed

Parameters

other
Type: FreeImageAPI..::.FI16RGB565
A FI16RGB565 structure to compare to this instance.

Return Value

true if obj is a FI16RGB565 structure equivalent to this FI16RGB565 structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FI16RGB565..::.Equals Method (Object)
FI16RGB565 Structure See Also Send Feedback
Tests whether the specified object is a FI16RGB565 structure and is equivalent to this FI16RGB565 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a FI16RGB565 structure equivalent to this FI16RGB565 structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FI16RGB565..::.GetHashCode Method
FI16RGB565 Structure See Also Send Feedback
Returns a hash code for this FI16RGB565 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FI16RGB565.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB565..::.Implicit Method
FI16RGB565 Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FI16RGB565) | Converts the value of a FI16RGB565 structure to a Color structure.
Implicit(Color) | Converts the value of a Color structure to a FI16RGB565 structure.

See Also

FI16RGB565 Structure
FI16RGB565 Members


Implicit Operator

[image]

FreeImage .NET Documentation
FI16RGB565..::.Implicit Operator
FI16RGB565 Structure See Also Send Feedback
Converts the value of a FI16RGB565 structure to a Color structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator Color (
    FI16RGB565 value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FI16RGB565 _
) As Color
Visual C++
static implicit operator Color (
    FI16RGB565 value
)

Parameters

value
Type: FreeImageAPI..::.FI16RGB565
A FI16RGB565 structure.

Return Value

A new instance of Color initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FI16RGB565..::.Implicit Operator
FI16RGB565 Structure See Also Send Feedback
Converts the value of a Color structure to a FI16RGB565 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FI16RGB565 (
    Color value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Color _
) As FI16RGB565
Visual C++
static implicit operator FI16RGB565 (
    Color value
)

Parameters

value
Type: System.Drawing..::.Color
A Color structure.

Return Value

A new instance of FI16RGB565 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FI16RGB565..::.Inequality Operator
FI16RGB565 Structure See Also Send Feedback
Tests whether two specified FI16RGB565 structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FI16RGB565 left,
    FI16RGB565 right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FI16RGB565, _
    right As FI16RGB565 _
) As Boolean
Visual C++
public:
static bool operator !=(
    FI16RGB565 left,
    FI16RGB565 right
)

Parameters

left
Type: FreeImageAPI..::.FI16RGB565
The FI16RGB565 that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FI16RGB565
The FI16RGB565 that is to the right of the inequality operator.

Return Value

true if the two FI16RGB565 structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure


ToString Method

[image]

FreeImage .NET Documentation
FI16RGB565..::.ToString Method
FI16RGB565 Structure See Also Send Feedback
Converts the numeric value of the FI16RGB565 object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure


FI16RGB565 Properties

[image] [image] [image]

FreeImage .NET Documentation
FI16RGB565 Properties
FI16RGB565 Structure See Also Send Feedback

The FI16RGB565 type exposes the following members.

Properties

Name | Description
Blue | Gets or sets the blue color component.
Color | Gets or sets the Color of the structure.
Green | Gets or sets the green color component.
Red | Gets or sets the red color component.

See Also

FI16RGB565 Structure


Blue Property

[image]

FreeImage .NET Documentation
FI16RGB565..::.Blue Property
FI16RGB565 Structure See Also Send Feedback
Gets or sets the blue color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte Blue { get; set; }
Visual Basic (Declaration)
Public Property Blue As Byte
Visual C++
public:
property unsigned char Blue {
    unsigned char get ();
    void set (unsigned char value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure


Color Property

[image]

FreeImage .NET Documentation
FI16RGB565..::.Color Property
FI16RGB565 Structure See Also Send Feedback
Gets or sets the Color of the structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure


Green Property

[image]

FreeImage .NET Documentation
FI16RGB565..::.Green Property
FI16RGB565 Structure See Also Send Feedback
Gets or sets the green color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte Green { get; set; }
Visual Basic (Declaration)
Public Property Green As Byte
Visual C++
public:
property unsigned char Green {
    unsigned char get ();
    void set (unsigned char value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure


Red Property

[image]

FreeImage .NET Documentation
FI16RGB565..::.Red Property
FI16RGB565 Structure See Also Send Feedback
Gets or sets the red color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte Red { get; set; }
Visual Basic (Declaration)
Public Property Red As Byte
Visual C++
public:
property unsigned char Red {
    unsigned char get ();
    void set (unsigned char value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI16RGB565 Structure


FI1BIT Structure

[image]

FreeImage .NET Documentation
FI1BIT Structure
Members See Also Send Feedback
The FI1BIT structure represents a single bit. It's value can be 0 or 1.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FI1BIT
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FI1BIT
Visual C++
[SerializableAttribute]
public value class FI1BIT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI1BIT Members


FI1BIT Members

[image] [image] [image]

FreeImage .NET Documentation
FI1BIT Members
FI1BIT Structure Methods Fields See Also Send Feedback

The FI1BIT type exposes the following members.

Methods

Name | Description
ToString | Converts the numeric value of the FI1BIT object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Implicit | Overloaded.

Fields

Name | Description
MaxValue | Represents the largest possible value of FI1BIT. This field is constant.
MinValue | Represents the smallest possible value of FI1BIT. This field is constant.

See Also

FI1BIT Structure


FI1BIT Fields

[image] [image] [image]

FreeImage .NET Documentation
FI1BIT Fields
FI1BIT Structure See Also Send Feedback

The FI1BIT type exposes the following members.

Fields

Name | Description
MaxValue | Represents the largest possible value of FI1BIT. This field is constant.
MinValue | Represents the smallest possible value of FI1BIT. This field is constant.

See Also

FI1BIT Structure


MaxValue Field

[image]

FreeImage .NET Documentation
FI1BIT..::.MaxValue Field
FI1BIT Structure See Also Send Feedback
Represents the largest possible value of FI1BIT. This field is constant.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const byte MaxValue
Visual Basic (Declaration)
Public Const MaxValue As Byte
Visual C++
public:
literal unsigned char MaxValue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI1BIT Structure


MinValue Field

[image]

FreeImage .NET Documentation
FI1BIT..::.MinValue Field
FI1BIT Structure See Also Send Feedback
Represents the smallest possible value of FI1BIT. This field is constant.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const byte MinValue
Visual Basic (Declaration)
Public Const MinValue As Byte
Visual C++
public:
literal unsigned char MinValue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI1BIT Structure


FI1BIT Methods

[image] [image] [image]

FreeImage .NET Documentation
FI1BIT Methods
FI1BIT Structure See Also Send Feedback

The FI1BIT type exposes the following members.

Methods

Name | Description
ToString | Converts the numeric value of the FI1BIT object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Implicit | Overloaded.

See Also

FI1BIT Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FI1BIT..::.Implicit Method
FI1BIT Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FI1BIT) | Converts the value of a FI1BIT structure to a Byte structure.
Implicit(Byte) | Converts the value of a Byte structure to a FI1BIT structure.

See Also

FI1BIT Structure
FI1BIT Members


Implicit Operator

[image]

FreeImage .NET Documentation
FI1BIT..::.Implicit Operator
FI1BIT Structure See Also Send Feedback
Converts the value of a FI1BIT structure to a Byte structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator byte (
    FI1BIT value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FI1BIT _
) As Byte
Visual C++
static implicit operator unsigned char (
    FI1BIT value
)

Parameters

value
Type: FreeImageAPI..::.FI1BIT
A FI1BIT structure.

Return Value

A new instance of FI1BIT initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI1BIT Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FI1BIT..::.Implicit Operator
FI1BIT Structure See Also Send Feedback
Converts the value of a Byte structure to a FI1BIT structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FI1BIT (
    byte value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Byte _
) As FI1BIT
Visual C++
static implicit operator FI1BIT (
    unsigned char value
)

Parameters

value
Type: System..::.Byte
A Byte structure.

Return Value

A new instance of FI1BIT initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI1BIT Structure
Implicit Overload


ToString Method

[image]

FreeImage .NET Documentation
FI1BIT..::.ToString Method
FI1BIT Structure See Also Send Feedback
Converts the numeric value of the FI1BIT object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI1BIT Structure


FI4BIT Structure

[image]

FreeImage .NET Documentation
FI4BIT Structure
Members See Also Send Feedback
The FI4BIT structure represents the half of a Byte. It's valuerange is between 0 and 15.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FI4BIT
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FI4BIT
Visual C++
[SerializableAttribute]
public value class FI4BIT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI4BIT Members


FI4BIT Members

[image] [image] [image]

FreeImage .NET Documentation
FI4BIT Members
FI4BIT Structure Methods Fields See Also Send Feedback

The FI4BIT type exposes the following members.

Methods

Name | Description
ToString | Converts the numeric value of the FI4BIT object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Implicit | Overloaded.

Fields

Name | Description
MaxValue | Represents the largest possible value of FI4BIT. This field is constant.
MinValue | Represents the smallest possible value of FI4BIT. This field is constant.

See Also

FI4BIT Structure


FI4BIT Fields

[image] [image] [image]

FreeImage .NET Documentation
FI4BIT Fields
FI4BIT Structure See Also Send Feedback

The FI4BIT type exposes the following members.

Fields

Name | Description
MaxValue | Represents the largest possible value of FI4BIT. This field is constant.
MinValue | Represents the smallest possible value of FI4BIT. This field is constant.

See Also

FI4BIT Structure


MaxValue Field

[image]

FreeImage .NET Documentation
FI4BIT..::.MaxValue Field
FI4BIT Structure See Also Send Feedback
Represents the largest possible value of FI4BIT. This field is constant.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const byte MaxValue
Visual Basic (Declaration)
Public Const MaxValue As Byte
Visual C++
public:
literal unsigned char MaxValue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI4BIT Structure


MinValue Field

[image]

FreeImage .NET Documentation
FI4BIT..::.MinValue Field
FI4BIT Structure See Also Send Feedback
Represents the smallest possible value of FI4BIT. This field is constant.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const byte MinValue
Visual Basic (Declaration)
Public Const MinValue As Byte
Visual C++
public:
literal unsigned char MinValue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI4BIT Structure


FI4BIT Methods

[image] [image] [image]

FreeImage .NET Documentation
FI4BIT Methods
FI4BIT Structure See Also Send Feedback

The FI4BIT type exposes the following members.

Methods

Name | Description
ToString | Converts the numeric value of the FI4BIT object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Implicit | Overloaded.

See Also

FI4BIT Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FI4BIT..::.Implicit Method
FI4BIT Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FI4BIT) | Converts the value of a FI4BIT structure to a Byte structure.
Implicit(Byte) | Converts the value of a Byte structure to a FI4BIT structure.

See Also

FI4BIT Structure
FI4BIT Members


Implicit Operator

[image]

FreeImage .NET Documentation
FI4BIT..::.Implicit Operator
FI4BIT Structure See Also Send Feedback
Converts the value of a FI4BIT structure to a Byte structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator byte (
    FI4BIT value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FI4BIT _
) As Byte
Visual C++
static implicit operator unsigned char (
    FI4BIT value
)

Parameters

value
Type: FreeImageAPI..::.FI4BIT
A FI4BIT structure.

Return Value

A new instance of FI4BIT initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI4BIT Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FI4BIT..::.Implicit Operator
FI4BIT Structure See Also Send Feedback
Converts the value of a Byte structure to a FI4BIT structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FI4BIT (
    byte value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Byte _
) As FI4BIT
Visual C++
static implicit operator FI4BIT (
    unsigned char value
)

Parameters

value
Type: System..::.Byte
A Byte structure.

Return Value

A new instance of FI4BIT initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI4BIT Structure
Implicit Overload


ToString Method

[image]

FreeImage .NET Documentation
FI4BIT..::.ToString Method
FI4BIT Structure See Also Send Feedback
Converts the numeric value of the FI4BIT object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FI4BIT Structure


FIBITMAP Structure

[image]

FreeImage .NET Documentation
FIBITMAP Structure
Members See Also Send Feedback
The FIBITMAP structure is a handle to a FreeImage bimtap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FIBITMAP : IComparable, IComparable<FIBITMAP>,
    IEquatable<FIBITMAP>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FIBITMAP _
    Implements IComparable, IComparable(Of FIBITMAP),  _
    IEquatable(Of FIBITMAP)
Visual C++
[SerializableAttribute]
public value class FIBITMAP : IComparable,
    IComparable<FIBITMAP>, IEquatable<FIBITMAP>

Remarks

The handle represented by a FIBITBAP structure provides access to either a singlepage bitmap or exactly one page of a multipage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Members


FIBITMAP Members

[image] [image] [image]

FreeImage .NET Documentation
FIBITMAP Members
FIBITMAP Structure Constructors Methods Fields Properties See Also Send Feedback

The FIBITMAP type exposes the following members.

Constructors

Name | Description
FIBITMAP | Overloaded.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIBITMAP structure. (Overrides ValueType..::.GetHashCode()()().)
SetNull | Sets the handle to null.
ToString | Converts the numeric value of the FIBITMAP object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIBITMAP structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIBITMAP structures are different.

Fields

Name | Description
Zero | A read-only field that represents a handle that has been initialized to zero.

Properties

Name | Description
IsNull | Gets whether the handle is a null or not.

See Also

FIBITMAP Structure


FIBITMAP Constructor

[image] [image] [image]

FreeImage .NET Documentation
FIBITMAP Constructor
FIBITMAP Structure See Also Send Feedback

Overload List

Name | Description
FIBITMAP(Int32) | Initializes a new instance of the FIBITMAP structure to the value indicated by a specified pointer to a native FIBITMAP structure.
FIBITMAP(IntPtr) | Initializes a new instance of the FIBITMAP structure to the value indicated by a specified pointer to a native FIBITMAP structure.

See Also

FIBITMAP Structure
FIBITMAP Members


FIBITMAP Constructor (Int32)

[image]

FreeImage .NET Documentation
FIBITMAP Constructor (Int32)
FIBITMAP Structure See Also Send Feedback
Initializes a new instance of the FIBITMAP structure to the value indicated by a specified pointer to a native FIBITMAP structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIBITMAP(
    int ptr
)
Visual Basic (Declaration)
Public Sub New ( _
    ptr As Integer _
)
Visual C++
public:
FIBITMAP(
    int ptr
)

Parameters

ptr
Type: System..::.Int32
A pointer to a native FIBITMAP structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIBITMAP Structure
FIBITMAP Overload


FIBITMAP Constructor (IntPtr)

[image]

FreeImage .NET Documentation
FIBITMAP Constructor (IntPtr)
FIBITMAP Structure See Also Send Feedback
Initializes a new instance of the FIBITMAP structure to the value indicated by a specified pointer to a native FIBITMAP structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIBITMAP(
    IntPtr ptr
)
Visual Basic (Declaration)
Public Sub New ( _
    ptr As IntPtr _
)
Visual C++
public:
FIBITMAP(
    IntPtr ptr
)

Parameters

ptr
Type: System..::.IntPtr
A pointer to a native FIBITMAP structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIBITMAP Structure
FIBITMAP Overload


FIBITMAP Fields

[image] [image] [image]

FreeImage .NET Documentation
FIBITMAP Fields
FIBITMAP Structure See Also Send Feedback

The FIBITMAP type exposes the following members.

Fields

Name | Description
Zero | A read-only field that represents a handle that has been initialized to zero.

See Also

FIBITMAP Structure


Zero Field

[image]

FreeImage .NET Documentation
FIBITMAP..::.Zero Field
FIBITMAP Structure See Also Send Feedback
A read-only field that represents a handle that has been initialized to zero.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FIBITMAP Zero
Visual Basic (Declaration)
Public Shared ReadOnly Zero As FIBITMAP
Visual C++
public:
static initonly FIBITMAP Zero

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Structure


FIBITMAP Methods

[image] [image] [image]

FreeImage .NET Documentation
FIBITMAP Methods
FIBITMAP Structure See Also Send Feedback

The FIBITMAP type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIBITMAP structure. (Overrides ValueType..::.GetHashCode()()().)
SetNull | Sets the handle to null.
ToString | Converts the numeric value of the FIBITMAP object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIBITMAP structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIBITMAP structures are different.

See Also

FIBITMAP Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FIBITMAP..::.CompareTo Method
FIBITMAP Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FIBITMAP) | Compares this instance with a specified FIBITMAP object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FIBITMAP Structure
FIBITMAP Members


CompareTo Method (FIBITMAP)

[image]

FreeImage .NET Documentation
FIBITMAP..::.CompareTo Method (FIBITMAP)
FIBITMAP Structure See Also Send Feedback
Compares this instance with a specified FIBITMAP object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FIBITMAP other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FIBITMAP _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FIBITMAP other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIBITMAP
A FIBITMAP to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FIBITMAP..::.CompareTo Method (Object)
FIBITMAP Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FIBITMAP.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FIBITMAP..::.Equality Operator
FIBITMAP Structure See Also Send Feedback
Tests whether two specified FIBITMAP structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FIBITMAP left,
    FIBITMAP right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FIBITMAP, _
    right As FIBITMAP _
) As Boolean
Visual C++
public:
static bool operator ==(
    FIBITMAP left,
    FIBITMAP right
)

Parameters

left
Type: FreeImageAPI..::.FIBITMAP
The FIBITMAP that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FIBITMAP
The FIBITMAP that is to the right of the equality operator.

Return Value

true if the two FIBITMAP structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FIBITMAP..::.Equals Method
FIBITMAP Structure See Also Send Feedback

Overload List

Name | Description
Equals(FIBITMAP) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides ValueType..::.Equals(Object).)

See Also

FIBITMAP Structure
FIBITMAP Members


Equals Method (FIBITMAP)

[image]

FreeImage .NET Documentation
FIBITMAP..::.Equals Method (FIBITMAP)
FIBITMAP Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FIBITMAP other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FIBITMAP _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FIBITMAP other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIBITMAP
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FIBITMAP..::.Equals Method (Object)
FIBITMAP Structure See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FIBITMAP..::.GetHashCode Method
FIBITMAP Structure See Also Send Feedback
Returns a hash code for this FIBITMAP structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FIBITMAP.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIBITMAP..::.Implicit Method
FIBITMAP Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FIBITMAP) | Converts the FIBITMAP structure specified in handle to an IntPtr.
Implicit(FIBITMAP) | Converts the FIBITMAP structure specified in handle to a 32-bit value.
Implicit(Int32) | Converts the pointer specified in ptr to a FIBITMAP structure.
Implicit(IntPtr) | Converts the pointer specified in ptr to a FIBITMAP structure.

See Also

FIBITMAP Structure
FIBITMAP Members


Implicit Operator

[image]

FreeImage .NET Documentation
FIBITMAP..::.Implicit Operator
FIBITMAP Structure See Also Send Feedback
Converts the FIBITMAP structure specified in handle to an IntPtr.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator IntPtr (
    FIBITMAP handle
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    handle As FIBITMAP _
) As IntPtr
Visual C++
static implicit operator IntPtr (
    FIBITMAP handle
)

Parameters

handle
Type: FreeImageAPI..::.FIBITMAP
A FIBITMAP structure to be converted into an IntPtr.

Return Value

An IntPtr initialized with the pointer of the FIBITMAP structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIBITMAP Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIBITMAP..::.Implicit Operator
FIBITMAP Structure See Also Send Feedback
Converts the FIBITMAP structure specified in handle to a 32-bit value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator int (
    FIBITMAP handle
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    handle As FIBITMAP _
) As Integer
Visual C++
static implicit operator int (
    FIBITMAP handle
)

Parameters

handle
Type: FreeImageAPI..::.FIBITMAP
A FIBITMAP structure to be converted into a 32-bit value.

Return Value

A 32-bit value initialized with the pointer of the FIBITMAP structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIBITMAP Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIBITMAP..::.Implicit Operator
FIBITMAP Structure See Also Send Feedback
Converts the pointer specified in ptr to a FIBITMAP structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIBITMAP (
    int ptr
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    ptr As Integer _
) As FIBITMAP
Visual C++
static implicit operator FIBITMAP (
    int ptr
)

Parameters

ptr
Type: System..::.Int32
A 32-bit value to be converted into a FIBITMAP structure.

Return Value

A FIBITMAP structure initialized with the specified pointer.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIBITMAP Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIBITMAP..::.Implicit Operator
FIBITMAP Structure See Also Send Feedback
Converts the pointer specified in ptr to a FIBITMAP structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIBITMAP (
    IntPtr ptr
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    ptr As IntPtr _
) As FIBITMAP
Visual C++
static implicit operator FIBITMAP (
    IntPtr ptr
)

Parameters

ptr
Type: System..::.IntPtr
A 32-bit value to be converted into a FIBITMAP structure.

Return Value

A FIBITMAP structure initialized with the specified pointer.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIBITMAP Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FIBITMAP..::.Inequality Operator
FIBITMAP Structure See Also Send Feedback
Tests whether two specified FIBITMAP structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FIBITMAP left,
    FIBITMAP right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FIBITMAP, _
    right As FIBITMAP _
) As Boolean
Visual C++
public:
static bool operator !=(
    FIBITMAP left,
    FIBITMAP right
)

Parameters

left
Type: FreeImageAPI..::.FIBITMAP
The FIBITMAP that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FIBITMAP
The FIBITMAP that is to the right of the inequality operator.

Return Value

true if the two FIBITMAP structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Structure


SetNull Method

[image]

FreeImage .NET Documentation
FIBITMAP..::.SetNull Method
FIBITMAP Structure See Also Send Feedback
Sets the handle to null.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SetNull()
Visual Basic (Declaration)
Public Sub SetNull
Visual C++
public:
void SetNull()

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Structure


ToString Method

[image]

FreeImage .NET Documentation
FIBITMAP..::.ToString Method
FIBITMAP Structure See Also Send Feedback
Converts the numeric value of the FIBITMAP object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Structure


FIBITMAP Properties

[image] [image] [image]

FreeImage .NET Documentation
FIBITMAP Properties
FIBITMAP Structure See Also Send Feedback

The FIBITMAP type exposes the following members.

Properties

Name | Description
IsNull | Gets whether the handle is a null or not.

See Also

FIBITMAP Structure


IsNull Property

[image]

FreeImage .NET Documentation
FIBITMAP..::.IsNull Property
FIBITMAP Structure See Also Send Feedback
Gets whether the handle is a null or not.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsNull { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
Visual C++
public:
property bool IsNull {
    bool get ();
}

Field Value

true if this FIBITMAP handle is a null; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIBITMAP Structure


FICOMPLEX Structure

[image]

FreeImage .NET Documentation
FICOMPLEX Structure
Members See Also Send Feedback
The FICOMPLEX structure describes a color consisting of a real and an imaginary part. Each part is using 4 bytes of data.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FICOMPLEX : IComparable, IComparable<FICOMPLEX>,
    IEquatable<FICOMPLEX>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FICOMPLEX _
    Implements IComparable, IComparable(Of FICOMPLEX),  _
    IEquatable(Of FICOMPLEX)
Visual C++
[SerializableAttribute]
public value class FICOMPLEX : IComparable,
    IComparable<FICOMPLEX>, IEquatable<FICOMPLEX>

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FICOMPLEX Members


FICOMPLEX Members

[image] [image] [image]

FreeImage .NET Documentation
FICOMPLEX Members
FICOMPLEX Structure Methods Fields See Also Send Feedback

The FICOMPLEX type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FICOMPLEX structure. (Overrides ValueType..::.GetHashCode()()().)

Operators

Name | Description
Equality | Tests whether two specified FICOMPLEX structures are equivalent.
Inequality | Tests whether two specified FICOMPLEX structures are different.

Fields

Name | Description
imag | Imaginary part of the color.
real | Real part of the color.

See Also

FICOMPLEX Structure


FICOMPLEX Fields

[image] [image] [image]

FreeImage .NET Documentation
FICOMPLEX Fields
FICOMPLEX Structure See Also Send Feedback

The FICOMPLEX type exposes the following members.

Fields

Name | Description
imag | Imaginary part of the color.
real | Real part of the color.

See Also

FICOMPLEX Structure


imag Field

[image]

FreeImage .NET Documentation
FICOMPLEX..::.imag Field
FICOMPLEX Structure See Also Send Feedback
Imaginary part of the color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public double imag
Visual Basic (Declaration)
Public imag As Double
Visual C++
public:
double imag

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FICOMPLEX Structure


real Field

[image]

FreeImage .NET Documentation
FICOMPLEX..::.real Field
FICOMPLEX Structure See Also Send Feedback
Real part of the color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public double real
Visual Basic (Declaration)
Public real As Double
Visual C++
public:
double real

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FICOMPLEX Structure


FICOMPLEX Methods

[image] [image] [image]

FreeImage .NET Documentation
FICOMPLEX Methods
FICOMPLEX Structure See Also Send Feedback

The FICOMPLEX type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FICOMPLEX structure. (Overrides ValueType..::.GetHashCode()()().)

Operators

Name | Description
Equality | Tests whether two specified FICOMPLEX structures are equivalent.
Inequality | Tests whether two specified FICOMPLEX structures are different.

See Also

FICOMPLEX Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FICOMPLEX..::.CompareTo Method
FICOMPLEX Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FICOMPLEX) | Compares this instance with a specified FICOMPLEX object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FICOMPLEX Structure
FICOMPLEX Members


CompareTo Method (FICOMPLEX)

[image]

FreeImage .NET Documentation
FICOMPLEX..::.CompareTo Method (FICOMPLEX)
FICOMPLEX Structure See Also Send Feedback
Compares this instance with a specified FICOMPLEX object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FICOMPLEX other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FICOMPLEX _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FICOMPLEX other
) sealed

Parameters

other
Type: FreeImageAPI..::.FICOMPLEX
A FICOMPLEX to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FICOMPLEX Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FICOMPLEX..::.CompareTo Method (Object)
FICOMPLEX Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FICOMPLEX.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FICOMPLEX Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FICOMPLEX..::.Equality Operator
FICOMPLEX Structure See Also Send Feedback
Tests whether two specified FICOMPLEX structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FICOMPLEX left,
    FICOMPLEX right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FICOMPLEX, _
    right As FICOMPLEX _
) As Boolean
Visual C++
public:
static bool operator ==(
    FICOMPLEX left,
    FICOMPLEX right
)

Parameters

left
Type: FreeImageAPI..::.FICOMPLEX
The FICOMPLEX that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FICOMPLEX
The FICOMPLEX that is to the right of the equality operator.

Return Value

true if the two FICOMPLEX structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FICOMPLEX Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FICOMPLEX..::.Equals Method
FICOMPLEX Structure See Also Send Feedback

Overload List

Name | Description
Equals(FICOMPLEX) | Tests whether the specified FICOMPLEX structure is equivalent to this FICOMPLEX structure.
Equals(Object) | Tests whether the specified object is a FICOMPLEX structure and is equivalent to this FICOMPLEX structure. (Overrides ValueType..::.Equals(Object).)

See Also

FICOMPLEX Structure
FICOMPLEX Members


Equals Method (FICOMPLEX)

[image]

FreeImage .NET Documentation
FICOMPLEX..::.Equals Method (FICOMPLEX)
FICOMPLEX Structure See Also Send Feedback
Tests whether the specified FICOMPLEX structure is equivalent to this FICOMPLEX structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FICOMPLEX other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FICOMPLEX _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FICOMPLEX other
) sealed

Parameters

other
Type: FreeImageAPI..::.FICOMPLEX
A FICOMPLEX structure to compare to this instance.

Return Value

true if obj is a FICOMPLEX structure equivalent to this FICOMPLEX structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FICOMPLEX Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FICOMPLEX..::.Equals Method (Object)
FICOMPLEX Structure See Also Send Feedback
Tests whether the specified object is a FICOMPLEX structure and is equivalent to this FICOMPLEX structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a FICOMPLEX structure equivalent to this FICOMPLEX structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FICOMPLEX Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FICOMPLEX..::.GetHashCode Method
FICOMPLEX Structure See Also Send Feedback
Returns a hash code for this FICOMPLEX structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FICOMPLEX.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FICOMPLEX Structure


Inequality Operator

[image]

FreeImage .NET Documentation
FICOMPLEX..::.Inequality Operator
FICOMPLEX Structure See Also Send Feedback
Tests whether two specified FICOMPLEX structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FICOMPLEX left,
    FICOMPLEX right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FICOMPLEX, _
    right As FICOMPLEX _
) As Boolean
Visual C++
public:
static bool operator !=(
    FICOMPLEX left,
    FICOMPLEX right
)

Parameters

left
Type: FreeImageAPI..::.FICOMPLEX
The FICOMPLEX that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FICOMPLEX
The FICOMPLEX that is to the right of the inequality operator.

Return Value

true if the two FICOMPLEX structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FICOMPLEX Structure


FIICCPROFILE Structure

[image]

FreeImage .NET Documentation
FIICCPROFILE Structure
Members See Also Send Feedback
This Structure contains ICC-Profile data.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FIICCPROFILE
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FIICCPROFILE
Visual C++
[SerializableAttribute]
public value class FIICCPROFILE

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIICCPROFILE Members


FIICCPROFILE Members

[image] [image] [image]

FreeImage .NET Documentation
FIICCPROFILE Members
FIICCPROFILE Structure Constructors Properties See Also Send Feedback

The FIICCPROFILE type exposes the following members.

Constructors

Name | Description
FIICCPROFILE | Overloaded.

Properties

Name | Description
Data | Copy of the ICC-Profiles data.
DataPointer | Points to a block of contiguous memory containing the profile.
Flags | Info flag of the profile.
IsCMYK | Indicates whether the profile is CMYK.
Size | Profile's size measured in bytes.

See Also

FIICCPROFILE Structure


FIICCPROFILE Constructor

[image] [image] [image]

FreeImage .NET Documentation
FIICCPROFILE Constructor
FIICCPROFILE Structure See Also Send Feedback

Overload List

Name | Description
FIICCPROFILE(FIBITMAP, array<Byte>[]()[]) | Creates a new ICC-Profile for dib.
FIICCPROFILE(FIBITMAP, array<Byte>[]()[], Int32) | Creates a new ICC-Profile for dib.

See Also

FIICCPROFILE Structure
FIICCPROFILE Members


FIICCPROFILE Constructor (FIBITMAP, Byte[])

[image]

FreeImage .NET Documentation
FIICCPROFILE Constructor (FIBITMAP, array<Byte>[]()[])
FIICCPROFILE Structure See Also Send Feedback
Creates a new ICC-Profile for dib.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIICCPROFILE(
    FIBITMAP dib,
    byte[] data
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP, _
    data As Byte() _
)
Visual C++
public:
FIICCPROFILE(
    FIBITMAP dib,
    array<unsigned char>^ data
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
data
Type: array< System..::.Byte >[]()[]
The ICC-Profile data.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIICCPROFILE Structure
FIICCPROFILE Overload


FIICCPROFILE Constructor (FIBITMAP, Byte[], Int32)

[image]

FreeImage .NET Documentation
FIICCPROFILE Constructor (FIBITMAP, array<Byte>[]()[], Int32)
FIICCPROFILE Structure See Also Send Feedback
Creates a new ICC-Profile for dib.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIICCPROFILE(
    FIBITMAP dib,
    byte[] data,
    int size
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP, _
    data As Byte(), _
    size As Integer _
)
Visual C++
public:
FIICCPROFILE(
    FIBITMAP dib,
    array<unsigned char>^ data,
    int size
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
data
Type: array< System..::.Byte >[]()[]
The ICC-Profile data.
size
Type: System..::.Int32
Number of bytes to use from data.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIICCPROFILE Structure
FIICCPROFILE Overload


FIICCPROFILE Properties

[image] [image] [image]

FreeImage .NET Documentation
FIICCPROFILE Properties
FIICCPROFILE Structure See Also Send Feedback

The FIICCPROFILE type exposes the following members.

Properties

Name | Description
Data | Copy of the ICC-Profiles data.
DataPointer | Points to a block of contiguous memory containing the profile.
Flags | Info flag of the profile.
IsCMYK | Indicates whether the profile is CMYK.
Size | Profile's size measured in bytes.

See Also

FIICCPROFILE Structure


Data Property

[image]

FreeImage .NET Documentation
FIICCPROFILE..::.Data Property
FIICCPROFILE Structure See Also Send Feedback
Copy of the ICC-Profiles data.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As Byte()
Visual C++
public:
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIICCPROFILE Structure


DataPointer Property

[image]

FreeImage .NET Documentation
FIICCPROFILE..::.DataPointer Property
FIICCPROFILE Structure See Also Send Feedback
Points to a block of contiguous memory containing the profile.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IntPtr DataPointer { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataPointer As IntPtr
Visual C++
public:
property IntPtr DataPointer {
    IntPtr get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIICCPROFILE Structure


Flags Property

[image]

FreeImage .NET Documentation
FIICCPROFILE..::.Flags Property
FIICCPROFILE Structure See Also Send Feedback
Info flag of the profile.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ICC_FLAGS Flags { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flags As ICC_FLAGS
Visual C++
public:
property ICC_FLAGS Flags {
    ICC_FLAGS get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIICCPROFILE Structure


IsCMYK Property

[image]

FreeImage .NET Documentation
FIICCPROFILE..::.IsCMYK Property
FIICCPROFILE Structure See Also Send Feedback
Indicates whether the profile is CMYK.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsCMYK { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCMYK As Boolean
Visual C++
public:
property bool IsCMYK {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIICCPROFILE Structure


Size Property

[image]

FreeImage .NET Documentation
FIICCPROFILE..::.Size Property
FIICCPROFILE Structure See Also Send Feedback
Profile's size measured in bytes.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As UInteger
Visual C++
public:
property unsigned int Size {
    unsigned int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIICCPROFILE Structure


FIMEMORY Structure

[image]

FreeImage .NET Documentation
FIMEMORY Structure
Members See Also Send Feedback
The FIMEMORY structure is a handle to an opened memory stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FIMEMORY : IComparable, IComparable<FIMEMORY>,
    IEquatable<FIMEMORY>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FIMEMORY _
    Implements IComparable, IComparable(Of FIMEMORY),  _
    IEquatable(Of FIMEMORY)
Visual C++
[SerializableAttribute]
public value class FIMEMORY : IComparable,
    IComparable<FIMEMORY>, IEquatable<FIMEMORY>

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Members


FIMEMORY Members

[image] [image] [image]

FreeImage .NET Documentation
FIMEMORY Members
FIMEMORY Structure Constructors Methods Fields Properties See Also Send Feedback

The FIMEMORY type exposes the following members.

Constructors

Name | Description
FIMEMORY | Overloaded.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIMEMORY structure. (Overrides ValueType..::.GetHashCode()()().)
SetNull | Sets the handle to null.
ToString | Converts the numeric value of the FIMEMORY object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIMEMORY structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIMEMORY structures are different.

Fields

Name | Description
Zero | A read-only field that represents a handle that has been initialized to zero.

Properties

Name | Description
IsNull | Gets whether the pointer is a null pointer or not.

See Also

FIMEMORY Structure


FIMEMORY Constructor

[image] [image] [image]

FreeImage .NET Documentation
FIMEMORY Constructor
FIMEMORY Structure See Also Send Feedback

Overload List

Name | Description
FIMEMORY(Int32) | Initializes a new instance of the FIMEMORY structure to the value indicated by a specified pointer to a native FIMEMORY structure.
FIMEMORY(IntPtr) | Initializes a new instance of the FIMEMORY structure to the value indicated by a specified pointer to a native FIMEMORY structure.

See Also

FIMEMORY Structure
FIMEMORY Members


FIMEMORY Constructor (Int32)

[image]

FreeImage .NET Documentation
FIMEMORY Constructor (Int32)
FIMEMORY Structure See Also Send Feedback
Initializes a new instance of the FIMEMORY structure to the value indicated by a specified pointer to a native FIMEMORY structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIMEMORY(
    int ptr
)
Visual Basic (Declaration)
Public Sub New ( _
    ptr As Integer _
)
Visual C++
public:
FIMEMORY(
    int ptr
)

Parameters

ptr
Type: System..::.Int32
A pointer to a native FIMEMORY structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMEMORY Structure
FIMEMORY Overload


FIMEMORY Constructor (IntPtr)

[image]

FreeImage .NET Documentation
FIMEMORY Constructor (IntPtr)
FIMEMORY Structure See Also Send Feedback
Initializes a new instance of the FIMEMORY structure to the value indicated by a specified pointer to a native FIMEMORY structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIMEMORY(
    IntPtr ptr
)
Visual Basic (Declaration)
Public Sub New ( _
    ptr As IntPtr _
)
Visual C++
public:
FIMEMORY(
    IntPtr ptr
)

Parameters

ptr
Type: System..::.IntPtr
A pointer to a native FIMEMORY structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMEMORY Structure
FIMEMORY Overload


FIMEMORY Fields

[image] [image] [image]

FreeImage .NET Documentation
FIMEMORY Fields
FIMEMORY Structure See Also Send Feedback

The FIMEMORY type exposes the following members.

Fields

Name | Description
Zero | A read-only field that represents a handle that has been initialized to zero.

See Also

FIMEMORY Structure


Zero Field

[image]

FreeImage .NET Documentation
FIMEMORY..::.Zero Field
FIMEMORY Structure See Also Send Feedback
A read-only field that represents a handle that has been initialized to zero.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FIMEMORY Zero
Visual Basic (Declaration)
Public Shared ReadOnly Zero As FIMEMORY
Visual C++
public:
static initonly FIMEMORY Zero

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Structure


FIMEMORY Methods

[image] [image] [image]

FreeImage .NET Documentation
FIMEMORY Methods
FIMEMORY Structure See Also Send Feedback

The FIMEMORY type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIMEMORY structure. (Overrides ValueType..::.GetHashCode()()().)
SetNull | Sets the handle to null.
ToString | Converts the numeric value of the FIMEMORY object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIMEMORY structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIMEMORY structures are different.

See Also

FIMEMORY Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FIMEMORY..::.CompareTo Method
FIMEMORY Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FIMEMORY) | Compares this instance with a specified FIMEMORY object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FIMEMORY Structure
FIMEMORY Members


CompareTo Method (FIMEMORY)

[image]

FreeImage .NET Documentation
FIMEMORY..::.CompareTo Method (FIMEMORY)
FIMEMORY Structure See Also Send Feedback
Compares this instance with a specified FIMEMORY object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FIMEMORY other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FIMEMORY _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FIMEMORY other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIMEMORY
A FIMEMORY to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FIMEMORY..::.CompareTo Method (Object)
FIMEMORY Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FIMEMORY.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FIMEMORY..::.Equality Operator
FIMEMORY Structure See Also Send Feedback
Tests whether two specified FIMEMORY structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FIMEMORY left,
    FIMEMORY right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FIMEMORY, _
    right As FIMEMORY _
) As Boolean
Visual C++
public:
static bool operator ==(
    FIMEMORY left,
    FIMEMORY right
)

Parameters

left
Type: FreeImageAPI..::.FIMEMORY
The FIMEMORY that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FIMEMORY
The FIMEMORY that is to the right of the equality operator.

Return Value

true if the two FIMEMORY structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FIMEMORY..::.Equals Method
FIMEMORY Structure See Also Send Feedback

Overload List

Name | Description
Equals(FIMEMORY) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides ValueType..::.Equals(Object).)

See Also

FIMEMORY Structure
FIMEMORY Members


Equals Method (FIMEMORY)

[image]

FreeImage .NET Documentation
FIMEMORY..::.Equals Method (FIMEMORY)
FIMEMORY Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FIMEMORY other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FIMEMORY _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FIMEMORY other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIMEMORY
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FIMEMORY..::.Equals Method (Object)
FIMEMORY Structure See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FIMEMORY..::.GetHashCode Method
FIMEMORY Structure See Also Send Feedback
Returns a hash code for this FIMEMORY structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FIMEMORY.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIMEMORY..::.Implicit Method
FIMEMORY Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FIMEMORY) | Converts the FIMEMORY structure specified in handle to an IntPtr.
Implicit(FIMEMORY) | Converts the FIMEMORY structure specified in handle to a 32-bit value.
Implicit(Int32) | Converts the pointer specified in ptr to a FIMEMORY structure.
Implicit(IntPtr) | Converts the pointer specified in ptr to a FIMEMORY structure.

See Also

FIMEMORY Structure
FIMEMORY Members


Implicit Operator

[image]

FreeImage .NET Documentation
FIMEMORY..::.Implicit Operator
FIMEMORY Structure See Also Send Feedback
Converts the FIMEMORY structure specified in handle to an IntPtr.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator IntPtr (
    FIMEMORY handle
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    handle As FIMEMORY _
) As IntPtr
Visual C++
static implicit operator IntPtr (
    FIMEMORY handle
)

Parameters

handle
Type: FreeImageAPI..::.FIMEMORY
A FIMEMORY structure to be converted into an IntPtr.

Return Value

An IntPtr initialized with the pointer of the FIMEMORY structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMEMORY Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIMEMORY..::.Implicit Operator
FIMEMORY Structure See Also Send Feedback
Converts the FIMEMORY structure specified in handle to a 32-bit value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator int (
    FIMEMORY handle
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    handle As FIMEMORY _
) As Integer
Visual C++
static implicit operator int (
    FIMEMORY handle
)

Parameters

handle
Type: FreeImageAPI..::.FIMEMORY
A FIMEMORY structure to be converted into a 32-bit value.

Return Value

A 32-bit value initialized with the pointer of the FIMEMORY structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMEMORY Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIMEMORY..::.Implicit Operator
FIMEMORY Structure See Also Send Feedback
Converts the pointer specified in ptr to a FIMEMORY structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIMEMORY (
    int ptr
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    ptr As Integer _
) As FIMEMORY
Visual C++
static implicit operator FIMEMORY (
    int ptr
)

Parameters

ptr
Type: System..::.Int32
A 32-bit value to be converted into a FIMEMORY structure.

Return Value

A FIMEMORY structure initialized with the specified pointer.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMEMORY Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIMEMORY..::.Implicit Operator
FIMEMORY Structure See Also Send Feedback
Converts the pointer specified in ptr to a FIMEMORY structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIMEMORY (
    IntPtr ptr
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    ptr As IntPtr _
) As FIMEMORY
Visual C++
static implicit operator FIMEMORY (
    IntPtr ptr
)

Parameters

ptr
Type: System..::.IntPtr
A 32-bit value to be converted into a FIMEMORY structure.

Return Value

A FIMEMORY structure initialized with the specified pointer.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMEMORY Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FIMEMORY..::.Inequality Operator
FIMEMORY Structure See Also Send Feedback
Tests whether two specified FIMEMORY structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FIMEMORY left,
    FIMEMORY right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FIMEMORY, _
    right As FIMEMORY _
) As Boolean
Visual C++
public:
static bool operator !=(
    FIMEMORY left,
    FIMEMORY right
)

Parameters

left
Type: FreeImageAPI..::.FIMEMORY
The FIMEMORY that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FIMEMORY
The FIMEMORY that is to the right of the inequality operator.

Return Value

true if the two FIMEMORY structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Structure


SetNull Method

[image]

FreeImage .NET Documentation
FIMEMORY..::.SetNull Method
FIMEMORY Structure See Also Send Feedback
Sets the handle to null.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SetNull()
Visual Basic (Declaration)
Public Sub SetNull
Visual C++
public:
void SetNull()

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Structure


ToString Method

[image]

FreeImage .NET Documentation
FIMEMORY..::.ToString Method
FIMEMORY Structure See Also Send Feedback
Converts the numeric value of the FIMEMORY object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Structure


FIMEMORY Properties

[image] [image] [image]

FreeImage .NET Documentation
FIMEMORY Properties
FIMEMORY Structure See Also Send Feedback

The FIMEMORY type exposes the following members.

Properties

Name | Description
IsNull | Gets whether the pointer is a null pointer or not.

See Also

FIMEMORY Structure


IsNull Property

[image]

FreeImage .NET Documentation
FIMEMORY..::.IsNull Property
FIMEMORY Structure See Also Send Feedback
Gets whether the pointer is a null pointer or not.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsNull { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
Visual C++
public:
property bool IsNull {
    bool get ();
}

Field Value

true if this FIMEMORY is a null pointer; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMEMORY Structure


FIMETADATA Structure

[image]

FreeImage .NET Documentation
FIMETADATA Structure
Members See Also Send Feedback
The FIMETADATA structure is an unique search handle for metadata search operations.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FIMETADATA : IComparable,
    IComparable<FIMETADATA>, IEquatable<FIMETADATA>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FIMETADATA _
    Implements IComparable, IComparable(Of FIMETADATA),  _
    IEquatable(Of FIMETADATA)
Visual C++
[SerializableAttribute]
public value class FIMETADATA : IComparable,
    IComparable<FIMETADATA>, IEquatable<FIMETADATA>

Remarks

The FIMETADATA structure is usually returned by the FindFirstMetadata(FREE_IMAGE_MDMODEL, FIBITMAP, FITAG%) function and then used on subsequent calls to FindNextMetadata(FIMETADATA, FITAG%). When the FIMETADATA handle is no longer used, it needs to be freed by the FindCloseMetadata(FIMETADATA) function.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Members


FIMETADATA Members

[image] [image] [image]

FreeImage .NET Documentation
FIMETADATA Members
FIMETADATA Structure Constructors Methods Fields Properties See Also Send Feedback

The FIMETADATA type exposes the following members.

Constructors

Name | Description
FIMETADATA | Overloaded.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIMETADATA structure. (Overrides ValueType..::.GetHashCode()()().)
SetNull | Sets the handle to null.
ToString | Converts the numeric value of the FIMETADATA object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIMETADATA structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIMETADATA structures are different.

Fields

Name | Description
Zero | A read-only field that represents a handle that has been initialized to zero.

Properties

Name | Description
IsNull | Gets whether the pointer is a null pointer or not.

See Also

FIMETADATA Structure


FIMETADATA Constructor

[image] [image] [image]

FreeImage .NET Documentation
FIMETADATA Constructor
FIMETADATA Structure See Also Send Feedback

Overload List

Name | Description
FIMETADATA(Int32) | Initializes a new instance of the FIMETADATA structure to the value indicated by a specified pointer to a native FIMETADATA structure.
FIMETADATA(IntPtr) | Initializes a new instance of the FIMETADATA structure to the value indicated by a specified pointer to a native FIMETADATA structure.

See Also

FIMETADATA Structure
FIMETADATA Members


FIMETADATA Constructor (Int32)

[image]

FreeImage .NET Documentation
FIMETADATA Constructor (Int32)
FIMETADATA Structure See Also Send Feedback
Initializes a new instance of the FIMETADATA structure to the value indicated by a specified pointer to a native FIMETADATA structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIMETADATA(
    int ptr
)
Visual Basic (Declaration)
Public Sub New ( _
    ptr As Integer _
)
Visual C++
public:
FIMETADATA(
    int ptr
)

Parameters

ptr
Type: System..::.Int32
A pointer to a native FIMETADATA structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMETADATA Structure
FIMETADATA Overload


FIMETADATA Constructor (IntPtr)

[image]

FreeImage .NET Documentation
FIMETADATA Constructor (IntPtr)
FIMETADATA Structure See Also Send Feedback
Initializes a new instance of the FIMETADATA structure to the value indicated by a specified pointer to a native FIMETADATA structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIMETADATA(
    IntPtr ptr
)
Visual Basic (Declaration)
Public Sub New ( _
    ptr As IntPtr _
)
Visual C++
public:
FIMETADATA(
    IntPtr ptr
)

Parameters

ptr
Type: System..::.IntPtr
A pointer to a native FIMETADATA structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMETADATA Structure
FIMETADATA Overload


FIMETADATA Fields

[image] [image] [image]

FreeImage .NET Documentation
FIMETADATA Fields
FIMETADATA Structure See Also Send Feedback

The FIMETADATA type exposes the following members.

Fields

Name | Description
Zero | A read-only field that represents a handle that has been initialized to zero.

See Also

FIMETADATA Structure


Zero Field

[image]

FreeImage .NET Documentation
FIMETADATA..::.Zero Field
FIMETADATA Structure See Also Send Feedback
A read-only field that represents a handle that has been initialized to zero.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FIMETADATA Zero
Visual Basic (Declaration)
Public Shared ReadOnly Zero As FIMETADATA
Visual C++
public:
static initonly FIMETADATA Zero

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Structure


FIMETADATA Methods

[image] [image] [image]

FreeImage .NET Documentation
FIMETADATA Methods
FIMETADATA Structure See Also Send Feedback

The FIMETADATA type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIMETADATA structure. (Overrides ValueType..::.GetHashCode()()().)
SetNull | Sets the handle to null.
ToString | Converts the numeric value of the FIMETADATA object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIMETADATA structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIMETADATA structures are different.

See Also

FIMETADATA Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FIMETADATA..::.CompareTo Method
FIMETADATA Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FIMETADATA) | Compares this instance with a specified FIMETADATA object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FIMETADATA Structure
FIMETADATA Members


CompareTo Method (FIMETADATA)

[image]

FreeImage .NET Documentation
FIMETADATA..::.CompareTo Method (FIMETADATA)
FIMETADATA Structure See Also Send Feedback
Compares this instance with a specified FIMETADATA object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FIMETADATA other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FIMETADATA _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FIMETADATA other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIMETADATA
A FIMETADATA to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FIMETADATA..::.CompareTo Method (Object)
FIMETADATA Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FIMETADATA.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FIMETADATA..::.Equality Operator
FIMETADATA Structure See Also Send Feedback
Tests whether two specified FIMETADATA structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FIMETADATA left,
    FIMETADATA right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FIMETADATA, _
    right As FIMETADATA _
) As Boolean
Visual C++
public:
static bool operator ==(
    FIMETADATA left,
    FIMETADATA right
)

Parameters

left
Type: FreeImageAPI..::.FIMETADATA
The FIMETADATA that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FIMETADATA
The FIMETADATA that is to the right of the equality operator.

Return Value

true if the two FIMETADATA structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FIMETADATA..::.Equals Method
FIMETADATA Structure See Also Send Feedback

Overload List

Name | Description
Equals(FIMETADATA) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides ValueType..::.Equals(Object).)

See Also

FIMETADATA Structure
FIMETADATA Members


Equals Method (FIMETADATA)

[image]

FreeImage .NET Documentation
FIMETADATA..::.Equals Method (FIMETADATA)
FIMETADATA Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FIMETADATA other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FIMETADATA _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FIMETADATA other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIMETADATA
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FIMETADATA..::.Equals Method (Object)
FIMETADATA Structure See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FIMETADATA..::.GetHashCode Method
FIMETADATA Structure See Also Send Feedback
Returns a hash code for this FIMETADATA structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FIMETADATA.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIMETADATA..::.Implicit Method
FIMETADATA Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FIMETADATA) | Converts the FIMETADATA structure specified in handle to an IntPtr.
Implicit(FIMETADATA) | Converts the FIMETADATA structure specified in handle to a 32-bit value.
Implicit(Int32) | Converts the pointer specified in ptr to a FIMETADATA structure.
Implicit(IntPtr) | Converts the pointer specified in ptr to a FIMETADATA structure.

See Also

FIMETADATA Structure
FIMETADATA Members


Implicit Operator

[image]

FreeImage .NET Documentation
FIMETADATA..::.Implicit Operator
FIMETADATA Structure See Also Send Feedback
Converts the FIMETADATA structure specified in handle to an IntPtr.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator IntPtr (
    FIMETADATA handle
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    handle As FIMETADATA _
) As IntPtr
Visual C++
static implicit operator IntPtr (
    FIMETADATA handle
)

Parameters

handle
Type: FreeImageAPI..::.FIMETADATA
A FIMETADATA structure to be converted into an IntPtr.

Return Value

An IntPtr initialized with the pointer of the FIMETADATA structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMETADATA Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIMETADATA..::.Implicit Operator
FIMETADATA Structure See Also Send Feedback
Converts the FIMETADATA structure specified in handle to a 32-bit value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator int (
    FIMETADATA handle
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    handle As FIMETADATA _
) As Integer
Visual C++
static implicit operator int (
    FIMETADATA handle
)

Parameters

handle
Type: FreeImageAPI..::.FIMETADATA
A FIMETADATA structure to be converted into a 32-bit value.

Return Value

A 32-bit value initialized with the pointer of the FIMETADATA structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMETADATA Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIMETADATA..::.Implicit Operator
FIMETADATA Structure See Also Send Feedback
Converts the pointer specified in ptr to a FIMETADATA structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIMETADATA (
    int ptr
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    ptr As Integer _
) As FIMETADATA
Visual C++
static implicit operator FIMETADATA (
    int ptr
)

Parameters

ptr
Type: System..::.Int32
A 32-bit value to be converted into a FIMETADATA structure.

Return Value

A FIMETADATA structure initialized with the specified pointer.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMETADATA Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIMETADATA..::.Implicit Operator
FIMETADATA Structure See Also Send Feedback
Converts the pointer specified in ptr to a FIMETADATA structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIMETADATA (
    IntPtr ptr
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    ptr As IntPtr _
) As FIMETADATA
Visual C++
static implicit operator FIMETADATA (
    IntPtr ptr
)

Parameters

ptr
Type: System..::.IntPtr
A 32-bit value to be converted into a FIMETADATA structure.

Return Value

A FIMETADATA structure initialized with the specified pointer.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMETADATA Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FIMETADATA..::.Inequality Operator
FIMETADATA Structure See Also Send Feedback
Tests whether two specified FIMETADATA structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FIMETADATA left,
    FIMETADATA right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FIMETADATA, _
    right As FIMETADATA _
) As Boolean
Visual C++
public:
static bool operator !=(
    FIMETADATA left,
    FIMETADATA right
)

Parameters

left
Type: FreeImageAPI..::.FIMETADATA
The FIMETADATA that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FIMETADATA
The FIMETADATA that is to the right of the inequality operator.

Return Value

true if the two FIMETADATA structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Structure


SetNull Method

[image]

FreeImage .NET Documentation
FIMETADATA..::.SetNull Method
FIMETADATA Structure See Also Send Feedback
Sets the handle to null.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SetNull()
Visual Basic (Declaration)
Public Sub SetNull
Visual C++
public:
void SetNull()

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Structure


ToString Method

[image]

FreeImage .NET Documentation
FIMETADATA..::.ToString Method
FIMETADATA Structure See Also Send Feedback
Converts the numeric value of the FIMETADATA object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Structure


FIMETADATA Properties

[image] [image] [image]

FreeImage .NET Documentation
FIMETADATA Properties
FIMETADATA Structure See Also Send Feedback

The FIMETADATA type exposes the following members.

Properties

Name | Description
IsNull | Gets whether the pointer is a null pointer or not.

See Also

FIMETADATA Structure


IsNull Property

[image]

FreeImage .NET Documentation
FIMETADATA..::.IsNull Property
FIMETADATA Structure See Also Send Feedback
Gets whether the pointer is a null pointer or not.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsNull { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
Visual C++
public:
property bool IsNull {
    bool get ();
}

Field Value

true if this FIMETADATA is a null pointer; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMETADATA Structure


FIMULTIBITMAP Structure

[image]

FreeImage .NET Documentation
FIMULTIBITMAP Structure
Members See Also Send Feedback
The FIMULTIBITMAP structure is a handle to a FreeImage multipaged bimtap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FIMULTIBITMAP : IComparable,
    IComparable<FIMULTIBITMAP>, IEquatable<FIMULTIBITMAP>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FIMULTIBITMAP _
    Implements IComparable, IComparable(Of FIMULTIBITMAP),  _
    IEquatable(Of FIMULTIBITMAP)
Visual C++
[SerializableAttribute]
public value class FIMULTIBITMAP : IComparable,
    IComparable<FIMULTIBITMAP>, IEquatable<FIMULTIBITMAP>

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Members


FIMULTIBITMAP Members

[image] [image] [image]

FreeImage .NET Documentation
FIMULTIBITMAP Members
FIMULTIBITMAP Structure Constructors Methods Fields Properties See Also Send Feedback

The FIMULTIBITMAP type exposes the following members.

Constructors

Name | Description
FIMULTIBITMAP | Overloaded.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIMULTIBITMAP structure. (Overrides ValueType..::.GetHashCode()()().)
SetNull | Sets the handle to null.
ToString | Converts the numeric value of the FIMULTIBITMAP object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIMULTIBITMAP structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIMULTIBITMAP structures are different.

Fields

Name | Description
Zero | A read-only field that represents a handle that has been initialized to zero.

Properties

Name | Description
IsNull | Gets whether the handle is a null or not.

See Also

FIMULTIBITMAP Structure


FIMULTIBITMAP Constructor

[image] [image] [image]

FreeImage .NET Documentation
FIMULTIBITMAP Constructor
FIMULTIBITMAP Structure See Also Send Feedback

Overload List

Name | Description
FIMULTIBITMAP(Int32) | Initializes a new instance of the FIMULTIBITMAP structure to the value indicated by a specified pointer to a native FIMULTIBITMAP structure.
FIMULTIBITMAP(IntPtr) | Initializes a new instance of the FIMULTIBITMAP structure to the value indicated by a specified pointer to a native FIMULTIBITMAP structure.

See Also

FIMULTIBITMAP Structure
FIMULTIBITMAP Members


FIMULTIBITMAP Constructor (Int32)

[image]

FreeImage .NET Documentation
FIMULTIBITMAP Constructor (Int32)
FIMULTIBITMAP Structure See Also Send Feedback
Initializes a new instance of the FIMULTIBITMAP structure to the value indicated by a specified pointer to a native FIMULTIBITMAP structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIMULTIBITMAP(
    int ptr
)
Visual Basic (Declaration)
Public Sub New ( _
    ptr As Integer _
)
Visual C++
public:
FIMULTIBITMAP(
    int ptr
)

Parameters

ptr
Type: System..::.Int32
A pointer to a native FIMULTIBITMAP structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMULTIBITMAP Structure
FIMULTIBITMAP Overload


FIMULTIBITMAP Constructor (IntPtr)

[image]

FreeImage .NET Documentation
FIMULTIBITMAP Constructor (IntPtr)
FIMULTIBITMAP Structure See Also Send Feedback
Initializes a new instance of the FIMULTIBITMAP structure to the value indicated by a specified pointer to a native FIMULTIBITMAP structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIMULTIBITMAP(
    IntPtr ptr
)
Visual Basic (Declaration)
Public Sub New ( _
    ptr As IntPtr _
)
Visual C++
public:
FIMULTIBITMAP(
    IntPtr ptr
)

Parameters

ptr
Type: System..::.IntPtr
A pointer to a native FIMULTIBITMAP structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMULTIBITMAP Structure
FIMULTIBITMAP Overload


FIMULTIBITMAP Fields

[image] [image] [image]

FreeImage .NET Documentation
FIMULTIBITMAP Fields
FIMULTIBITMAP Structure See Also Send Feedback

The FIMULTIBITMAP type exposes the following members.

Fields

Name | Description
Zero | A read-only field that represents a handle that has been initialized to zero.

See Also

FIMULTIBITMAP Structure


Zero Field

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.Zero Field
FIMULTIBITMAP Structure See Also Send Feedback
A read-only field that represents a handle that has been initialized to zero.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FIMULTIBITMAP Zero
Visual Basic (Declaration)
Public Shared ReadOnly Zero As FIMULTIBITMAP
Visual C++
public:
static initonly FIMULTIBITMAP Zero

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Structure


FIMULTIBITMAP Methods

[image] [image] [image]

FreeImage .NET Documentation
FIMULTIBITMAP Methods
FIMULTIBITMAP Structure See Also Send Feedback

The FIMULTIBITMAP type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIMULTIBITMAP structure. (Overrides ValueType..::.GetHashCode()()().)
SetNull | Sets the handle to null.
ToString | Converts the numeric value of the FIMULTIBITMAP object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIMULTIBITMAP structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIMULTIBITMAP structures are different.

See Also

FIMULTIBITMAP Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.CompareTo Method
FIMULTIBITMAP Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FIMULTIBITMAP) | Compares this instance with a specified FIMULTIBITMAP object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FIMULTIBITMAP Structure
FIMULTIBITMAP Members


CompareTo Method (FIMULTIBITMAP)

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.CompareTo Method (FIMULTIBITMAP)
FIMULTIBITMAP Structure See Also Send Feedback
Compares this instance with a specified FIMULTIBITMAP object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FIMULTIBITMAP other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FIMULTIBITMAP _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FIMULTIBITMAP other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIMULTIBITMAP
A FIMULTIBITMAP to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.CompareTo Method (Object)
FIMULTIBITMAP Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FIMULTIBITMAP.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.Equality Operator
FIMULTIBITMAP Structure See Also Send Feedback
Tests whether two specified FIMULTIBITMAP structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FIMULTIBITMAP left,
    FIMULTIBITMAP right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FIMULTIBITMAP, _
    right As FIMULTIBITMAP _
) As Boolean
Visual C++
public:
static bool operator ==(
    FIMULTIBITMAP left,
    FIMULTIBITMAP right
)

Parameters

left
Type: FreeImageAPI..::.FIMULTIBITMAP
The FIMULTIBITMAP that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FIMULTIBITMAP
The FIMULTIBITMAP that is to the right of the equality operator.

Return Value

true if the two FIMULTIBITMAP structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.Equals Method
FIMULTIBITMAP Structure See Also Send Feedback

Overload List

Name | Description
Equals(FIMULTIBITMAP) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides ValueType..::.Equals(Object).)

See Also

FIMULTIBITMAP Structure
FIMULTIBITMAP Members


Equals Method (FIMULTIBITMAP)

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.Equals Method (FIMULTIBITMAP)
FIMULTIBITMAP Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FIMULTIBITMAP other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FIMULTIBITMAP _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FIMULTIBITMAP other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIMULTIBITMAP
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.Equals Method (Object)
FIMULTIBITMAP Structure See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.GetHashCode Method
FIMULTIBITMAP Structure See Also Send Feedback
Returns a hash code for this FIMULTIBITMAP structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FIMULTIBITMAP.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.Implicit Method
FIMULTIBITMAP Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FIMULTIBITMAP) | Converts the FIMULTIBITMAP structure specified in handle to an IntPtr.
Implicit(FIMULTIBITMAP) | Converts the FIMULTIBITMAP structure specified in handle to a 32-bit value.
Implicit(Int32) | Converts the pointer specified in ptr to a FIMULTIBITMAP structure.
Implicit(IntPtr) | Converts the pointer specified in ptr to a FIMULTIBITMAP structure.

See Also

FIMULTIBITMAP Structure
FIMULTIBITMAP Members


Implicit Operator

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.Implicit Operator
FIMULTIBITMAP Structure See Also Send Feedback
Converts the FIMULTIBITMAP structure specified in handle to an IntPtr.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator IntPtr (
    FIMULTIBITMAP handle
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    handle As FIMULTIBITMAP _
) As IntPtr
Visual C++
static implicit operator IntPtr (
    FIMULTIBITMAP handle
)

Parameters

handle
Type: FreeImageAPI..::.FIMULTIBITMAP
A FIMULTIBITMAP structure to be converted into an IntPtr.

Return Value

An IntPtr initialized with the pointer of the FIMULTIBITMAP structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMULTIBITMAP Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.Implicit Operator
FIMULTIBITMAP Structure See Also Send Feedback
Converts the FIMULTIBITMAP structure specified in handle to a 32-bit value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator int (
    FIMULTIBITMAP handle
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    handle As FIMULTIBITMAP _
) As Integer
Visual C++
static implicit operator int (
    FIMULTIBITMAP handle
)

Parameters

handle
Type: FreeImageAPI..::.FIMULTIBITMAP
A FIMULTIBITMAP structure to be converted into a 32-bit value.

Return Value

A 32-bit value initialized with the pointer of the FIMULTIBITMAP structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMULTIBITMAP Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.Implicit Operator
FIMULTIBITMAP Structure See Also Send Feedback
Converts the pointer specified in ptr to a FIMULTIBITMAP structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIMULTIBITMAP (
    int ptr
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    ptr As Integer _
) As FIMULTIBITMAP
Visual C++
static implicit operator FIMULTIBITMAP (
    int ptr
)

Parameters

ptr
Type: System..::.Int32
A 32-bit value to be converted into a FIMULTIBITMAP structure.

Return Value

A FIMULTIBITMAP structure initialized with the specified pointer.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMULTIBITMAP Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.Implicit Operator
FIMULTIBITMAP Structure See Also Send Feedback
Converts the pointer specified in ptr to a FIMULTIBITMAP structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIMULTIBITMAP (
    IntPtr ptr
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    ptr As IntPtr _
) As FIMULTIBITMAP
Visual C++
static implicit operator FIMULTIBITMAP (
    IntPtr ptr
)

Parameters

ptr
Type: System..::.IntPtr
A 32-bit value to be converted into a FIMULTIBITMAP structure.

Return Value

A FIMULTIBITMAP structure initialized with the specified pointer.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIMULTIBITMAP Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.Inequality Operator
FIMULTIBITMAP Structure See Also Send Feedback
Tests whether two specified FIMULTIBITMAP structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FIMULTIBITMAP left,
    FIMULTIBITMAP right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FIMULTIBITMAP, _
    right As FIMULTIBITMAP _
) As Boolean
Visual C++
public:
static bool operator !=(
    FIMULTIBITMAP left,
    FIMULTIBITMAP right
)

Parameters

left
Type: FreeImageAPI..::.FIMULTIBITMAP
The FIMULTIBITMAP that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FIMULTIBITMAP
The FIMULTIBITMAP that is to the right of the inequality operator.

Return Value

true if the two FIMULTIBITMAP structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Structure


SetNull Method

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.SetNull Method
FIMULTIBITMAP Structure See Also Send Feedback
Sets the handle to null.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SetNull()
Visual Basic (Declaration)
Public Sub SetNull
Visual C++
public:
void SetNull()

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Structure


ToString Method

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.ToString Method
FIMULTIBITMAP Structure See Also Send Feedback
Converts the numeric value of the FIMULTIBITMAP object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Structure


FIMULTIBITMAP Properties

[image] [image] [image]

FreeImage .NET Documentation
FIMULTIBITMAP Properties
FIMULTIBITMAP Structure See Also Send Feedback

The FIMULTIBITMAP type exposes the following members.

Properties

Name | Description
IsNull | Gets whether the handle is a null or not.

See Also

FIMULTIBITMAP Structure


IsNull Property

[image]

FreeImage .NET Documentation
FIMULTIBITMAP..::.IsNull Property
FIMULTIBITMAP Structure See Also Send Feedback
Gets whether the handle is a null or not.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsNull { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
Visual C++
public:
property bool IsNull {
    bool get ();
}

Field Value

true if this FIMULTIBITMAP handle is a null; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIMULTIBITMAP Structure


FIRational Structure

[image]

FreeImage .NET Documentation
FIRational Structure
Members See Also Send Feedback
The FIRational structure represents a fraction via two Int32 instances which are interpreted as numerator and denominator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FIRational : IConvertible,
    IComparable, IFormattable, IComparable<FIRational>, IEquatable<FIRational>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FIRational _
    Implements IConvertible, IComparable, IFormattable, IComparable(Of FIRational),  _
    IEquatable(Of FIRational)
Visual C++
[SerializableAttribute]
public value class FIRational : IConvertible,
    IComparable, IFormattable, IComparable<FIRational>, IEquatable<FIRational>

Remarks

The structure tries to approximate the value of FIRational(Decimal) when creating a new instance by using a better algorithm than FreeImage does.

The structure implements the following operators: +, -, ++, --, ==, != , >, >==, <, <== and ~ (which switches nominator and denomiator).

The structure can be converted into all .NET standard types either implicit or explicit.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Members


FIRational Members

[image] [image] [image]

FreeImage .NET Documentation
FIRational Members
FIRational Structure Constructors Methods Fields Properties See Also Send Feedback

The FIRational type exposes the following members.

Constructors

Name | Description
FIRational | Overloaded.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIRational structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Overloaded.
Truncate | Returns the truncated value of the fraction.

Operators

Name | Description
Addition | Standard implementation of the operator.
Decrement | Standard implementation of the operator.
Division | Standard implementation of the operator.
Equality | Standard implementation of the operator.
Explicit | Overloaded.
GreaterThan | Standard implementation of the operator.
GreaterThanOrEqual | Standard implementation of the operator.
Implicit | Overloaded.
Increment | Standard implementation of the operator.
Inequality | Standard implementation of the operator.
LessThan | Standard implementation of the operator.
LessThanOrEqual | Standard implementation of the operator.
Modulus | Standard implementation of the operator.
Multiply | Standard implementation of the operator.
OnesComplement | Returns the reciprocal value of this instance.
Subtraction | Standard implementation of the operator.
UnaryNegation | Standard implementation of the operator.
UnaryPlus | Standard implementation of the operator.

Fields

Name | Description
Epsilon | Represents the smallest positive FIRational value greater than zero. This field is constant.
MaxValue | Represents the largest possible value of FIRational. This field is constant.
MinValue | Represents the smallest possible value of FIRational. This field is constant.

Properties

Name | Description
Denominator | The denominator of the fraction.
IsInteger | Returns whether the fraction is representing an integer value.
Numerator | The numerator of the fraction.

See Also

FIRational Structure


FIRational Constructor

[image] [image] [image]

FreeImage .NET Documentation
FIRational Constructor
FIRational Structure See Also Send Feedback

Overload List

Name | Description
FIRational(FIRational) | Initializes a new instance based on the specified parameters.
FIRational(FITAG) | Initializes a new instance based on the specified parameters.
FIRational(Decimal) | Initializes a new instance based on the specified parameters.
FIRational(Int32, Int32) | Initializes a new instance based on the specified parameters.

See Also

FIRational Structure
FIRational Members


FIRational Constructor (FIRational)

[image]

FreeImage .NET Documentation
FIRational Constructor (FIRational)
FIRational Structure See Also Send Feedback
Initializes a new instance based on the specified parameters.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIRational(
    FIRational r
)
Visual Basic (Declaration)
Public Sub New ( _
    r As FIRational _
)
Visual C++
public:
FIRational(
    FIRational r
)

Parameters

r
Type: FreeImageAPI..::.FIRational
The structure to clone from.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIRational Structure
FIRational Overload


FIRational Constructor (FITAG)

[image]

FreeImage .NET Documentation
FIRational Constructor (FITAG)
FIRational Structure See Also Send Feedback
Initializes a new instance based on the specified parameters.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIRational(
    FITAG tag
)
Visual Basic (Declaration)
Public Sub New ( _
    tag As FITAG _
)
Visual C++
public:
FIRational(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag to read the data from.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
FIRational Overload


FIRational Constructor (Decimal)

[image]

FreeImage .NET Documentation
FIRational Constructor (Decimal)
FIRational Structure See Also Send Feedback
Initializes a new instance based on the specified parameters.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIRational(
    decimal value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Decimal _
)
Visual C++
public:
FIRational(
    Decimal value
)

Parameters

value
Type: System..::.Decimal
The value to convert into a fraction.

Exceptions

Exception | Condition
System..::.OverflowException | value cannot be converted into a fraction represented by two integer values.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
FIRational Overload


FIRational Constructor (Int32, Int32)

[image]

FreeImage .NET Documentation
FIRational Constructor (Int32, Int32)
FIRational Structure See Also Send Feedback
Initializes a new instance based on the specified parameters.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIRational(
    int n,
    int d
)
Visual Basic (Declaration)
Public Sub New ( _
    n As Integer, _
    d As Integer _
)
Visual C++
public:
FIRational(
    int n,
    int d
)

Parameters

n
Type: System..::.Int32
The numerator.
d
Type: System..::.Int32
The denominator.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
FIRational Overload


FIRational Fields

[image] [image] [image]

FreeImage .NET Documentation
FIRational Fields
FIRational Structure See Also Send Feedback

The FIRational type exposes the following members.

Fields

Name | Description
Epsilon | Represents the smallest positive FIRational value greater than zero. This field is constant.
MaxValue | Represents the largest possible value of FIRational. This field is constant.
MinValue | Represents the smallest possible value of FIRational. This field is constant.

See Also

FIRational Structure


Epsilon Field

[image]

FreeImage .NET Documentation
FIRational..::.Epsilon Field
FIRational Structure See Also Send Feedback
Represents the smallest positive FIRational value greater than zero. This field is constant.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FIRational Epsilon
Visual Basic (Declaration)
Public Shared ReadOnly Epsilon As FIRational
Visual C++
public:
static initonly FIRational Epsilon

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


MaxValue Field

[image]

FreeImage .NET Documentation
FIRational..::.MaxValue Field
FIRational Structure See Also Send Feedback
Represents the largest possible value of FIRational. This field is constant.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FIRational MaxValue
Visual Basic (Declaration)
Public Shared ReadOnly MaxValue As FIRational
Visual C++
public:
static initonly FIRational MaxValue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


MinValue Field

[image]

FreeImage .NET Documentation
FIRational..::.MinValue Field
FIRational Structure See Also Send Feedback
Represents the smallest possible value of FIRational. This field is constant.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FIRational MinValue
Visual Basic (Declaration)
Public Shared ReadOnly MinValue As FIRational
Visual C++
public:
static initonly FIRational MinValue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


FIRational Methods

[image] [image] [image]

FreeImage .NET Documentation
FIRational Methods
FIRational Structure See Also Send Feedback

The FIRational type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIRational structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Overloaded.
Truncate | Returns the truncated value of the fraction.

Operators

Name | Description
Addition | Standard implementation of the operator.
Decrement | Standard implementation of the operator.
Division | Standard implementation of the operator.
Equality | Standard implementation of the operator.
Explicit | Overloaded.
GreaterThan | Standard implementation of the operator.
GreaterThanOrEqual | Standard implementation of the operator.
Implicit | Overloaded.
Increment | Standard implementation of the operator.
Inequality | Standard implementation of the operator.
LessThan | Standard implementation of the operator.
LessThanOrEqual | Standard implementation of the operator.
Modulus | Standard implementation of the operator.
Multiply | Standard implementation of the operator.
OnesComplement | Returns the reciprocal value of this instance.
Subtraction | Standard implementation of the operator.
UnaryNegation | Standard implementation of the operator.
UnaryPlus | Standard implementation of the operator.

See Also

FIRational Structure


Addition Operator

[image]

FreeImage .NET Documentation
FIRational..::.Addition Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIRational operator +(
    FIRational r1,
    FIRational r2
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    r1 As FIRational, _
    r2 As FIRational _
) As FIRational
Visual C++
public:
static FIRational operator +(
    FIRational r1,
    FIRational r2
)

Parameters

r1
Type: FreeImageAPI..::.FIRational
r2
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FIRational..::.CompareTo Method
FIRational Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FIRational) | Compares this instance with a specified FIRational object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FIRational Structure
FIRational Members


CompareTo Method (FIRational)

[image]

FreeImage .NET Documentation
FIRational..::.CompareTo Method (FIRational)
FIRational Structure See Also Send Feedback
Compares this instance with a specified FIRational object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FIRational other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FIRational _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FIRational other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIRational
A FIRational to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FIRational..::.CompareTo Method (Object)
FIRational Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FIRational.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
CompareTo Overload


Decrement Operator

[image]

FreeImage .NET Documentation
FIRational..::.Decrement Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIRational operator --(
    FIRational r1
)
Visual Basic (Declaration)
Public Shared Operator -- ( _
    r1 As FIRational _
) As FIRational
Visual C++
public:
static FIRational operator --(
    FIRational r1
)

Parameters

r1
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


Division Operator

[image]

FreeImage .NET Documentation
FIRational..::.Division Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIRational operator /(
    FIRational r1,
    FIRational r2
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    r1 As FIRational, _
    r2 As FIRational _
) As FIRational
Visual C++
public:
static FIRational operator /(
    FIRational r1,
    FIRational r2
)

Parameters

r1
Type: FreeImageAPI..::.FIRational
r2
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


Equality Operator

[image]

FreeImage .NET Documentation
FIRational..::.Equality Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FIRational r1,
    FIRational r2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    r1 As FIRational, _
    r2 As FIRational _
) As Boolean
Visual C++
public:
static bool operator ==(
    FIRational r1,
    FIRational r2
)

Parameters

r1
Type: FreeImageAPI..::.FIRational
r2
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FIRational..::.Equals Method
FIRational Structure See Also Send Feedback

Overload List

Name | Description
Equals(FIRational) | Tests whether the specified FIRational structure is equivalent to this FIRational structure.
Equals(Object) | Tests whether the specified object is a FIRational structure and is equivalent to this FIRational structure. (Overrides ValueType..::.Equals(Object).)

See Also

FIRational Structure
FIRational Members


Equals Method (FIRational)

[image]

FreeImage .NET Documentation
FIRational..::.Equals Method (FIRational)
FIRational Structure See Also Send Feedback
Tests whether the specified FIRational structure is equivalent to this FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FIRational other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FIRational _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FIRational other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIRational
A FIRational structure to compare to this instance.

Return Value

true if obj is a FIRational structure equivalent to this FIRational structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FIRational..::.Equals Method (Object)
FIRational Structure See Also Send Feedback
Tests whether the specified object is a FIRational structure and is equivalent to this FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a FIRational structure equivalent to this FIRational structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Equals Overload


Explicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIRational..::.Explicit Method
FIRational Structure See Also Send Feedback

Overload List

Name | Description
Explicit(FIRational) | Converts the value of a FIRational structure to an Int64 structure.
Explicit(FIRational) | Converts the value of a FIRational structure to an Int32 structure.
Explicit(FIRational) | Converts the value of a FIRational structure to a Byte structure.
Explicit(FIRational) | Converts the value of a FIRational structure to a Char structure.
Explicit(FIRational) | Converts the value of a FIRational structure to an UInt32 structure.
Explicit(FIRational) | Converts the value of a FIRational structure to an UInt64 structure.
Explicit(FIRational) | Converts the value of a FIRational structure to a SByte structure.
Explicit(FIRational) | Converts the value of a FIRational structure to an UInt16 structure.
Explicit(FIRational) | Converts the value of a FIRational structure to a Boolean structure.
Explicit(FIRational) | Converts the value of a FIRational structure to an Int16 structure.
Explicit(Boolean) | Converts the value of a Boolean structure to a FIRational structure.
Explicit(Decimal) | Converts the value of a Decimal structure to a FIRational structure.
Explicit(Double) | Converts the value of a Double structure to a FIRational structure.
Explicit(Int64) | Converts the value of an Int64 structure to a FIRational structure.
Explicit(Single) | Converts the value of a Single structure to a FIRational structure.
Explicit(UInt32) | Converts the value of an UInt32 structure to a FIRational structure.
Explicit(UInt64) | Converts the value of an UInt64 structure to a FIRational structure.

See Also

FIRational Structure
FIRational Members


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to an Int64 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator long (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIRational _
) As Long
Visual C++
static explicit operator long long (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of Int64 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to an Int32 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator int (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIRational _
) As Integer
Visual C++
static explicit operator int (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of Int32 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to a Byte structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator byte (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIRational _
) As Byte
Visual C++
static explicit operator unsigned char (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of Byte initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to a Char structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator char (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIRational _
) As Char
Visual C++
static explicit operator wchar_t (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of Char initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to an UInt32 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator uint (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIRational _
) As UInteger
Visual C++
static explicit operator unsigned int (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of UInt32 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to an UInt64 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator ulong (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIRational _
) As ULong
Visual C++
static explicit operator unsigned long long (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of UInt64 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to a SByte structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator sbyte (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIRational _
) As SByte
Visual C++
static explicit operator signed char (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of SByte initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to an UInt16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator ushort (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIRational _
) As UShort
Visual C++
static explicit operator unsigned short (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of UInt16 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to a Boolean structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator bool (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIRational _
) As Boolean
Visual C++
static explicit operator bool (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of Boolean initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to an Int16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator short (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIRational _
) As Short
Visual C++
static explicit operator short (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of Int16 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a Boolean structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIRational (
    bool value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As Boolean _
) As FIRational
Visual C++
static explicit operator FIRational (
    bool value
)

Parameters

value
Type: System..::.Boolean
A Boolean structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a Decimal structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIRational (
    decimal value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As Decimal _
) As FIRational
Visual C++
static explicit operator FIRational (
    Decimal value
)

Parameters

value
Type: System..::.Decimal
A Decimal structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a Double structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIRational (
    double value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As Double _
) As FIRational
Visual C++
static explicit operator FIRational (
    double value
)

Parameters

value
Type: System..::.Double
A Double structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of an Int64 structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIRational (
    long value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As Long _
) As FIRational
Visual C++
static explicit operator FIRational (
    long long value
)

Parameters

value
Type: System..::.Int64
An Int64 structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a Single structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIRational (
    float value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As Single _
) As FIRational
Visual C++
static explicit operator FIRational (
    float value
)

Parameters

value
Type: System..::.Single
A Single structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of an UInt32 structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIRational (
    uint value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As UInteger _
) As FIRational
Visual C++
static explicit operator FIRational (
    unsigned int value
)

Parameters

value
Type: System..::.UInt32
An UInt32 structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Explicit Operator
FIRational Structure See Also Send Feedback
Converts the value of an UInt64 structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIRational (
    ulong value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As ULong _
) As FIRational
Visual C++
static explicit operator FIRational (
    unsigned long long value
)

Parameters

value
Type: System..::.UInt64
An UInt64 structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Explicit Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FIRational..::.GetHashCode Method
FIRational Structure See Also Send Feedback
Returns a hash code for this FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FIRational.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


GreaterThan Operator

[image]

FreeImage .NET Documentation
FIRational..::.GreaterThan Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator >(
    FIRational r1,
    FIRational r2
)
Visual Basic (Declaration)
Public Shared Operator > ( _
    r1 As FIRational, _
    r2 As FIRational _
) As Boolean
Visual C++
public:
static bool operator >(
    FIRational r1,
    FIRational r2
)

Parameters

r1
Type: FreeImageAPI..::.FIRational
r2
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


GreaterThanOrEqual Operator

[image]

FreeImage .NET Documentation
FIRational..::.GreaterThanOrEqual Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator >=(
    FIRational r1,
    FIRational r2
)
Visual Basic (Declaration)
Public Shared Operator >= ( _
    r1 As FIRational, _
    r2 As FIRational _
) As Boolean
Visual C++
public:
static bool operator >=(
    FIRational r1,
    FIRational r2
)

Parameters

r1
Type: FreeImageAPI..::.FIRational
r2
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIRational..::.Implicit Method
FIRational Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FIRational) | Converts the value of a FIRational structure to a Decimal structure.
Implicit(FIRational) | Converts the value of a FIRational structure to a Double structure.
Implicit(FIRational) | Converts the value of a FIRational structure to a Single structure.
Implicit(Byte) | Converts the value of a Byte structure to a FIRational structure.
Implicit(Char) | Converts the value of a Char structure to a FIRational structure.
Implicit(Int16) | Converts the value of an Int16 structure to a FIRational structure.
Implicit(Int32) | Converts the value of an Int32 structure to a FIRational structure.
Implicit(SByte) | Converts the value of a SByte structure to a FIRational structure.
Implicit(UInt16) | Converts the value of an UInt16 structure to a FIRational structure.

See Also

FIRational Structure
FIRational Members


Implicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Implicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to a Decimal structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator decimal (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FIRational _
) As Decimal
Visual C++
static implicit operator Decimal (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of Decimal initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Implicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to a Double structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator double (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FIRational _
) As Double
Visual C++
static implicit operator double (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of Double initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Implicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a FIRational structure to a Single structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator float (
    FIRational value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FIRational _
) As Single
Visual C++
static implicit operator float (
    FIRational value
)

Parameters

value
Type: FreeImageAPI..::.FIRational
A FIRational structure.

Return Value

A new instance of Single initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Implicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a Byte structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIRational (
    byte value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Byte _
) As FIRational
Visual C++
static implicit operator FIRational (
    unsigned char value
)

Parameters

value
Type: System..::.Byte
A Byte structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Implicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a Char structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIRational (
    char value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Char _
) As FIRational
Visual C++
static implicit operator FIRational (
    wchar_t value
)

Parameters

value
Type: System..::.Char
A Char structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Implicit Operator
FIRational Structure See Also Send Feedback
Converts the value of an Int16 structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIRational (
    short value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Short _
) As FIRational
Visual C++
static implicit operator FIRational (
    short value
)

Parameters

value
Type: System..::.Int16
An Int16 structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Implicit Operator
FIRational Structure See Also Send Feedback
Converts the value of an Int32 structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIRational (
    int value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Integer _
) As FIRational
Visual C++
static implicit operator FIRational (
    int value
)

Parameters

value
Type: System..::.Int32
An Int32 structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Implicit Operator
FIRational Structure See Also Send Feedback
Converts the value of a SByte structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIRational (
    sbyte value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As SByte _
) As FIRational
Visual C++
static implicit operator FIRational (
    signed char value
)

Parameters

value
Type: System..::.SByte
A SByte structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRational..::.Implicit Operator
FIRational Structure See Also Send Feedback
Converts the value of an UInt16 structure to a FIRational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIRational (
    ushort value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As UShort _
) As FIRational
Visual C++
static implicit operator FIRational (
    unsigned short value
)

Parameters

value
Type: System..::.UInt16
An UInt16 structure.

Return Value

A new instance of FIRational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
Implicit Overload


Increment Operator

[image]

FreeImage .NET Documentation
FIRational..::.Increment Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIRational operator ++(
    FIRational r1
)
Visual Basic (Declaration)
Public Shared Operator ++ ( _
    r1 As FIRational _
) As FIRational
Visual C++
public:
static FIRational operator ++(
    FIRational r1
)

Parameters

r1
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


Inequality Operator

[image]

FreeImage .NET Documentation
FIRational..::.Inequality Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FIRational r1,
    FIRational r2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    r1 As FIRational, _
    r2 As FIRational _
) As Boolean
Visual C++
public:
static bool operator !=(
    FIRational r1,
    FIRational r2
)

Parameters

r1
Type: FreeImageAPI..::.FIRational
r2
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


LessThan Operator

[image]

FreeImage .NET Documentation
FIRational..::.LessThan Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator <(
    FIRational r1,
    FIRational r2
)
Visual Basic (Declaration)
Public Shared Operator < ( _
    r1 As FIRational, _
    r2 As FIRational _
) As Boolean
Visual C++
public:
static bool operator <(
    FIRational r1,
    FIRational r2
)

Parameters

r1
Type: FreeImageAPI..::.FIRational
r2
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


LessThanOrEqual Operator

[image]

FreeImage .NET Documentation
FIRational..::.LessThanOrEqual Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator <=(
    FIRational r1,
    FIRational r2
)
Visual Basic (Declaration)
Public Shared Operator <= ( _
    r1 As FIRational, _
    r2 As FIRational _
) As Boolean
Visual C++
public:
static bool operator <=(
    FIRational r1,
    FIRational r2
)

Parameters

r1
Type: FreeImageAPI..::.FIRational
r2
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


Modulus Operator

[image]

FreeImage .NET Documentation
FIRational..::.Modulus Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIRational operator %(
    FIRational r1,
    FIRational r2
)
Visual Basic (Declaration)
Public Shared Operator Mod ( _
    r1 As FIRational, _
    r2 As FIRational _
) As FIRational
Visual C++
public:
static FIRational operator %(
    FIRational r1,
    FIRational r2
)

Parameters

r1
Type: FreeImageAPI..::.FIRational
r2
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


Multiply Operator

[image]

FreeImage .NET Documentation
FIRational..::.Multiply Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIRational operator *(
    FIRational r1,
    FIRational r2
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    r1 As FIRational, _
    r2 As FIRational _
) As FIRational
Visual C++
public:
static FIRational operator *(
    FIRational r1,
    FIRational r2
)

Parameters

r1
Type: FreeImageAPI..::.FIRational
r2
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


OnesComplement Operator

[image]

FreeImage .NET Documentation
FIRational..::.OnesComplement Operator
FIRational Structure See Also Send Feedback
Returns the reciprocal value of this instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIRational operator ~(
    FIRational r1
)
Visual Basic (Declaration)
Public Shared Operator ~ ( _
    r1 As FIRational _
) As FIRational
Visual C++
public:
static FIRational operator ~(
    FIRational r1
)

Parameters

r1
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


Subtraction Operator

[image]

FreeImage .NET Documentation
FIRational..::.Subtraction Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIRational operator -(
    FIRational r1,
    FIRational r2
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    r1 As FIRational, _
    r2 As FIRational _
) As FIRational
Visual C++
public:
static FIRational operator -(
    FIRational r1,
    FIRational r2
)

Parameters

r1
Type: FreeImageAPI..::.FIRational
r2
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


ToString Method

[image] [image] [image]

FreeImage .NET Documentation
FIRational..::.ToString Method
FIRational Structure See Also Send Feedback

Overload List

Name | Description
ToString()()() | Converts the numeric value of the FIRational object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)
ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format.

See Also

FIRational Structure
FIRational Members


ToString Method

[image]

FreeImage .NET Documentation
FIRational..::.ToString Method
FIRational Structure See Also Send Feedback
Converts the numeric value of the FIRational object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
ToString Overload


ToString Method (String, IFormatProvider)

[image]

FreeImage .NET Documentation
FIRational..::.ToString Method (String, IFormatProvider)
FIRational Structure See Also Send Feedback
Formats the value of the current instance using the specified format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ToString(
    string format,
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As String, _
    formatProvider As IFormatProvider _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ formatProvider
) sealed

Parameters

format
Type: System..::.String
The String specifying the format to use.
formatProvider
Type: System..::.IFormatProvider
The IFormatProvider to use to format the value.

Return Value

A String containing the value of the current instance in the specified format.

Implements

IFormattable..::.ToString(String, IFormatProvider)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure
ToString Overload


Truncate Method

[image]

FreeImage .NET Documentation
FIRational..::.Truncate Method
FIRational Structure See Also Send Feedback
Returns the truncated value of the fraction.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Truncate()
Visual Basic (Declaration)
Public Function Truncate As Integer
Visual C++
public:
int Truncate()

Return Value

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


UnaryNegation Operator

[image]

FreeImage .NET Documentation
FIRational..::.UnaryNegation Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIRational operator -(
    FIRational r1
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    r1 As FIRational _
) As FIRational
Visual C++
public:
static FIRational operator -(
    FIRational r1
)

Parameters

r1
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


UnaryPlus Operator

[image]

FreeImage .NET Documentation
FIRational..::.UnaryPlus Operator
FIRational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIRational operator +(
    FIRational r1
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    r1 As FIRational _
) As FIRational
Visual C++
public:
static FIRational operator +(
    FIRational r1
)

Parameters

r1
Type: FreeImageAPI..::.FIRational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


FIRational Properties

[image] [image] [image]

FreeImage .NET Documentation
FIRational Properties
FIRational Structure See Also Send Feedback

The FIRational type exposes the following members.

Properties

Name | Description
Denominator | The denominator of the fraction.
IsInteger | Returns whether the fraction is representing an integer value.
Numerator | The numerator of the fraction.

See Also

FIRational Structure


Denominator Property

[image]

FreeImage .NET Documentation
FIRational..::.Denominator Property
FIRational Structure See Also Send Feedback
The denominator of the fraction.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Denominator { get; }
Visual Basic (Declaration)
Public ReadOnly Property Denominator As Integer
Visual C++
public:
property int Denominator {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


IsInteger Property

[image]

FreeImage .NET Documentation
FIRational..::.IsInteger Property
FIRational Structure See Also Send Feedback
Returns whether the fraction is representing an integer value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsInteger { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInteger As Boolean
Visual C++
public:
property bool IsInteger {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


Numerator Property

[image]

FreeImage .NET Documentation
FIRational..::.Numerator Property
FIRational Structure See Also Send Feedback
The numerator of the fraction.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Numerator { get; }
Visual Basic (Declaration)
Public ReadOnly Property Numerator As Integer
Visual C++
public:
property int Numerator {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRational Structure


FIRGB16 Structure

[image]

FreeImage .NET Documentation
FIRGB16 Structure
Members Example See Also Send Feedback
The FIRGB16 structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 16 bits and so, takes values in the range from 0 to 65535.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FIRGB16 : IComparable, IComparable<FIRGB16>,
    IEquatable<FIRGB16>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FIRGB16 _
    Implements IComparable, IComparable(Of FIRGB16),  _
    IEquatable(Of FIRGB16)
Visual C++
[SerializableAttribute]
public value class FIRGB16 : IComparable,
    IComparable<FIRGB16>, IEquatable<FIRGB16>

Remarks

The FIRGB16 structure provides access to an underlying FreeImage FIRGB16 structure. To determine the red, green or blue component of a color, use the red, green or blue fields, respectively.

For easy integration of the underlying structure into the .NET framework, the FIRGB16 structure implements implicit conversion operators to convert the represented color to and from the Color type. This makes the Color type a real replacement for the FIRGB16 structure and my be used in all situations which require an FIRGB16 type.

Each color component red, green or blue of FIRGB16 is translated into it's corresponding color component R, G or B of Color by right shifting 8 bits and shifting left 8 bits for the reverse conversion. When converting from Color into FIRGB16, the color's alpha value is ignored and assumed to be 255 when converting from FIRGB16 into Color, creating a fully opaque color.

Conversion from System.Drawing.Color to FIRGB16

FIRGB16.component = Color.component << 8

Conversion from FIRGB16 to System.Drawing.Color

Color.component = FIRGB16.component >> 8

The same conversion is also applied when the Color property or the FIRGB16(Color) constructor is invoked.

Examples

The following code example demonstrates the various conversions between the FIRGB16 structure and the Color structure.
CopyC#
FIRGB16 firgb16;
// Initialize the structure using a native .NET Color structure.
firgb16 = new FIRGBA16(Color.Indigo);
// Initialize the structure using the implicit operator.
firgb16 = Color.DarkSeaGreen;
// Convert the FIRGB16 instance into a native .NET Color
// using its implicit operator.
Color color = firgb16;
// Using the structure's Color property for converting it
// into a native .NET Color.
Color another = firgb16.Color;

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Members


FIRGB16 Members

[image] [image] [image]

FreeImage .NET Documentation
FIRGB16 Members
FIRGB16 Structure Constructors Methods Fields Properties See Also Send Feedback

The FIRGB16 type exposes the following members.

Constructors

Name | Description
FIRGB16 | Initializes a new instance based on the specified Color.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIRGB16 structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FIRGB16 object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIRGB16 structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIRGB16 structures are different.

Fields

Name | Description
blue | The blue color component.
green | The green color component.
red | The red color component.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

FIRGB16 Structure


FIRGB16 Constructor

[image]

FreeImage .NET Documentation
FIRGB16 Constructor
FIRGB16 Structure See Also Send Feedback
Initializes a new instance based on the specified Color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIRGB16(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
FIRGB16(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Color to initialize with.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure


FIRGB16 Fields

[image] [image] [image]

FreeImage .NET Documentation
FIRGB16 Fields
FIRGB16 Structure See Also Send Feedback

The FIRGB16 type exposes the following members.

Fields

Name | Description
blue | The blue color component.
green | The green color component.
red | The red color component.

See Also

FIRGB16 Structure


blue Field

[image]

FreeImage .NET Documentation
FIRGB16..::.blue Field
FIRGB16 Structure See Also Send Feedback
The blue color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort blue
Visual Basic (Declaration)
Public blue As UShort
Visual C++
public:
unsigned short blue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure


green Field

[image]

FreeImage .NET Documentation
FIRGB16..::.green Field
FIRGB16 Structure See Also Send Feedback
The green color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort green
Visual Basic (Declaration)
Public green As UShort
Visual C++
public:
unsigned short green

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure


red Field

[image]

FreeImage .NET Documentation
FIRGB16..::.red Field
FIRGB16 Structure See Also Send Feedback
The red color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort red
Visual Basic (Declaration)
Public red As UShort
Visual C++
public:
unsigned short red

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure


FIRGB16 Methods

[image] [image] [image]

FreeImage .NET Documentation
FIRGB16 Methods
FIRGB16 Structure See Also Send Feedback

The FIRGB16 type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIRGB16 structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FIRGB16 object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIRGB16 structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIRGB16 structures are different.

See Also

FIRGB16 Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGB16..::.CompareTo Method
FIRGB16 Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FIRGB16) | Compares this instance with a specified FIRGB16 object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FIRGB16 Structure
FIRGB16 Members


CompareTo Method (FIRGB16)

[image]

FreeImage .NET Documentation
FIRGB16..::.CompareTo Method (FIRGB16)
FIRGB16 Structure See Also Send Feedback
Compares this instance with a specified FIRGB16 object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FIRGB16 other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FIRGB16 _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FIRGB16 other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIRGB16
A FIRGB16 to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FIRGB16..::.CompareTo Method (Object)
FIRGB16 Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FIRGB16.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FIRGB16..::.Equality Operator
FIRGB16 Structure See Also Send Feedback
Tests whether two specified FIRGB16 structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FIRGB16 left,
    FIRGB16 right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FIRGB16, _
    right As FIRGB16 _
) As Boolean
Visual C++
public:
static bool operator ==(
    FIRGB16 left,
    FIRGB16 right
)

Parameters

left
Type: FreeImageAPI..::.FIRGB16
The FIRGB16 that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FIRGB16
The FIRGB16 that is to the right of the equality operator.

Return Value

true if the two FIRGB16 structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGB16..::.Equals Method
FIRGB16 Structure See Also Send Feedback

Overload List

Name | Description
Equals(FIRGB16) | Tests whether the specified FIRGB16 structure is equivalent to this FIRGB16 structure.
Equals(Object) | Tests whether the specified object is a FIRGB16 structure and is equivalent to this FIRGB16 structure. (Overrides ValueType..::.Equals(Object).)

See Also

FIRGB16 Structure
FIRGB16 Members


Equals Method (FIRGB16)

[image]

FreeImage .NET Documentation
FIRGB16..::.Equals Method (FIRGB16)
FIRGB16 Structure See Also Send Feedback
Tests whether the specified FIRGB16 structure is equivalent to this FIRGB16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FIRGB16 other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FIRGB16 _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FIRGB16 other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIRGB16
A FIRGB16 structure to compare to this instance.

Return Value

true if obj is a FIRGB16 structure equivalent to this FIRGB16 structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FIRGB16..::.Equals Method (Object)
FIRGB16 Structure See Also Send Feedback
Tests whether the specified object is a FIRGB16 structure and is equivalent to this FIRGB16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a FIRGB16 structure equivalent to this FIRGB16 structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FIRGB16..::.GetHashCode Method
FIRGB16 Structure See Also Send Feedback
Returns a hash code for this FIRGB16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FIRGB16.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGB16..::.Implicit Method
FIRGB16 Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FIRGB16) | Converts the value of a FIRGB16 structure to a Color structure.
Implicit(Color) | Converts the value of a Color structure to a FIRGB16 structure.

See Also

FIRGB16 Structure
FIRGB16 Members


Implicit Operator

[image]

FreeImage .NET Documentation
FIRGB16..::.Implicit Operator
FIRGB16 Structure See Also Send Feedback
Converts the value of a FIRGB16 structure to a Color structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator Color (
    FIRGB16 value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FIRGB16 _
) As Color
Visual C++
static implicit operator Color (
    FIRGB16 value
)

Parameters

value
Type: FreeImageAPI..::.FIRGB16
A FIRGB16 structure.

Return Value

A new instance of Color initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRGB16..::.Implicit Operator
FIRGB16 Structure See Also Send Feedback
Converts the value of a Color structure to a FIRGB16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIRGB16 (
    Color value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Color _
) As FIRGB16
Visual C++
static implicit operator FIRGB16 (
    Color value
)

Parameters

value
Type: System.Drawing..::.Color
A Color structure.

Return Value

A new instance of FIRGB16 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FIRGB16..::.Inequality Operator
FIRGB16 Structure See Also Send Feedback
Tests whether two specified FIRGB16 structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FIRGB16 left,
    FIRGB16 right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FIRGB16, _
    right As FIRGB16 _
) As Boolean
Visual C++
public:
static bool operator !=(
    FIRGB16 left,
    FIRGB16 right
)

Parameters

left
Type: FreeImageAPI..::.FIRGB16
The FIRGB16 that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FIRGB16
The FIRGB16 that is to the right of the inequality operator.

Return Value

true if the two FIRGB16 structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure


ToString Method

[image]

FreeImage .NET Documentation
FIRGB16..::.ToString Method
FIRGB16 Structure See Also Send Feedback
Converts the numeric value of the FIRGB16 object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure


FIRGB16 Properties

[image] [image] [image]

FreeImage .NET Documentation
FIRGB16 Properties
FIRGB16 Structure See Also Send Feedback

The FIRGB16 type exposes the following members.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

FIRGB16 Structure


Color Property

[image]

FreeImage .NET Documentation
FIRGB16..::.Color Property
FIRGB16 Structure See Also Send Feedback
Gets or sets the Color of the structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGB16 Structure


FIRGBA16 Structure

[image]

FreeImage .NET Documentation
FIRGBA16 Structure
Members Example See Also Send Feedback
The FIRGBA16 structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 16 bits and so, takes values in the range from 0 to 65535.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FIRGBA16 : IComparable, IComparable<FIRGBA16>,
    IEquatable<FIRGBA16>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FIRGBA16 _
    Implements IComparable, IComparable(Of FIRGBA16),  _
    IEquatable(Of FIRGBA16)
Visual C++
[SerializableAttribute]
public value class FIRGBA16 : IComparable,
    IComparable<FIRGBA16>, IEquatable<FIRGBA16>

Remarks

The FIRGBA16 structure provides access to an underlying FreeImage FIRGBA16 structure. To determine the alpha, red, green or blue component of a color, use the alpha, red, green or blue fields, respectively.

For easy integration of the underlying structure into the .NET framework, the FIRGBA16 structure implements implicit conversion operators to convert the represented color to and from the Color type. This makes the Color type a real replacement for the FIRGBA16 structure and my be used in all situations which require an FIRGBA16 type.

Each color component alpha, red, green or blue of FIRGBA16 is translated into it's corresponding color component A, R, G or B of Color by an 8 bit right shift and vice versa.

Conversion from System.Drawing.Color to FIRGBA16

FIRGBA16.component = Color.component << 8

Conversion from FIRGBA16 to System.Drawing.Color

Color.component = FIRGBA16.component >> 8

The same conversion is also applied when the Color property or the FIRGBA16(Color) constructor is invoked.

Examples

The following code example demonstrates the various conversions between the FIRGBA16 structure and the Color structure.
CopyC#
FIRGBA16 firgba16;
// Initialize the structure using a native .NET Color structure.
firgba16 = new FIRGBA16(Color.Indigo);
// Initialize the structure using the implicit operator.
firgba16 = Color.DarkSeaGreen;
// Convert the FIRGBA16 instance into a native .NET Color
// using its implicit operator.
Color color = firgba16;
// Using the structure's Color property for converting it
// into a native .NET Color.
Color another = firgba16.Color;

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Members


FIRGBA16 Members

[image] [image] [image]

FreeImage .NET Documentation
FIRGBA16 Members
FIRGBA16 Structure Constructors Methods Fields Properties See Also Send Feedback

The FIRGBA16 type exposes the following members.

Constructors

Name | Description
FIRGBA16 | Initializes a new instance based on the specified Color.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIRGBA16 structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FIRGBA16 object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIRGBA16 structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIRGBA16 structures are different.

Fields

Name | Description
alpha | The alpha color component.
blue | The blue color component.
green | The green color component.
red | The red color component.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

FIRGBA16 Structure


FIRGBA16 Constructor

[image]

FreeImage .NET Documentation
FIRGBA16 Constructor
FIRGBA16 Structure See Also Send Feedback
Initializes a new instance based on the specified Color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIRGBA16(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
FIRGBA16(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Color to initialize with.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure


FIRGBA16 Fields

[image] [image] [image]

FreeImage .NET Documentation
FIRGBA16 Fields
FIRGBA16 Structure See Also Send Feedback

The FIRGBA16 type exposes the following members.

Fields

Name | Description
alpha | The alpha color component.
blue | The blue color component.
green | The green color component.
red | The red color component.

See Also

FIRGBA16 Structure


alpha Field

[image]

FreeImage .NET Documentation
FIRGBA16..::.alpha Field
FIRGBA16 Structure See Also Send Feedback
The alpha color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort alpha
Visual Basic (Declaration)
Public alpha As UShort
Visual C++
public:
unsigned short alpha

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure


blue Field

[image]

FreeImage .NET Documentation
FIRGBA16..::.blue Field
FIRGBA16 Structure See Also Send Feedback
The blue color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort blue
Visual Basic (Declaration)
Public blue As UShort
Visual C++
public:
unsigned short blue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure


green Field

[image]

FreeImage .NET Documentation
FIRGBA16..::.green Field
FIRGBA16 Structure See Also Send Feedback
The green color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort green
Visual Basic (Declaration)
Public green As UShort
Visual C++
public:
unsigned short green

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure


red Field

[image]

FreeImage .NET Documentation
FIRGBA16..::.red Field
FIRGBA16 Structure See Also Send Feedback
The red color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort red
Visual Basic (Declaration)
Public red As UShort
Visual C++
public:
unsigned short red

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure


FIRGBA16 Methods

[image] [image] [image]

FreeImage .NET Documentation
FIRGBA16 Methods
FIRGBA16 Structure See Also Send Feedback

The FIRGBA16 type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIRGBA16 structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FIRGBA16 object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIRGBA16 structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIRGBA16 structures are different.

See Also

FIRGBA16 Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGBA16..::.CompareTo Method
FIRGBA16 Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FIRGBA16) | Compares this instance with a specified FIRGBA16 object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FIRGBA16 Structure
FIRGBA16 Members


CompareTo Method (FIRGBA16)

[image]

FreeImage .NET Documentation
FIRGBA16..::.CompareTo Method (FIRGBA16)
FIRGBA16 Structure See Also Send Feedback
Compares this instance with a specified FIRGBA16 object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FIRGBA16 other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FIRGBA16 _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FIRGBA16 other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIRGBA16
A FIRGBA16 to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FIRGBA16..::.CompareTo Method (Object)
FIRGBA16 Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FIRGBA16.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FIRGBA16..::.Equality Operator
FIRGBA16 Structure See Also Send Feedback
Tests whether two specified FIRGBA16 structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FIRGBA16 left,
    FIRGBA16 right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FIRGBA16, _
    right As FIRGBA16 _
) As Boolean
Visual C++
public:
static bool operator ==(
    FIRGBA16 left,
    FIRGBA16 right
)

Parameters

left
Type: FreeImageAPI..::.FIRGBA16
The FIRGBA16 that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FIRGBA16
The FIRGBA16 that is to the right of the equality operator.

Return Value

true if the two FIRGBA16 structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGBA16..::.Equals Method
FIRGBA16 Structure See Also Send Feedback

Overload List

Name | Description
Equals(FIRGBA16) | Tests whether the specified FIRGBA16 structure is equivalent to this FIRGBA16 structure.
Equals(Object) | Tests whether the specified object is a FIRGBA16 structure and is equivalent to this FIRGBA16 structure. (Overrides ValueType..::.Equals(Object).)

See Also

FIRGBA16 Structure
FIRGBA16 Members


Equals Method (FIRGBA16)

[image]

FreeImage .NET Documentation
FIRGBA16..::.Equals Method (FIRGBA16)
FIRGBA16 Structure See Also Send Feedback
Tests whether the specified FIRGBA16 structure is equivalent to this FIRGBA16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FIRGBA16 other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FIRGBA16 _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FIRGBA16 other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIRGBA16
A FIRGBA16 structure to compare to this instance.

Return Value

true if obj is a FIRGBA16 structure equivalent to this FIRGBA16 structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FIRGBA16..::.Equals Method (Object)
FIRGBA16 Structure See Also Send Feedback
Tests whether the specified object is a FIRGBA16 structure and is equivalent to this FIRGBA16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a FIRGBA16 structure equivalent to this FIRGBA16 structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FIRGBA16..::.GetHashCode Method
FIRGBA16 Structure See Also Send Feedback
Returns a hash code for this FIRGBA16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FIRGBA16.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGBA16..::.Implicit Method
FIRGBA16 Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FIRGBA16) | Converts the value of a FIRGBA16 structure to a Color structure.
Implicit(Color) | Converts the value of a Color structure to a FIRGBA16 structure.

See Also

FIRGBA16 Structure
FIRGBA16 Members


Implicit Operator

[image]

FreeImage .NET Documentation
FIRGBA16..::.Implicit Operator
FIRGBA16 Structure See Also Send Feedback
Converts the value of a FIRGBA16 structure to a Color structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator Color (
    FIRGBA16 value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FIRGBA16 _
) As Color
Visual C++
static implicit operator Color (
    FIRGBA16 value
)

Parameters

value
Type: FreeImageAPI..::.FIRGBA16
A FIRGBA16 structure.

Return Value

A new instance of Color initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRGBA16..::.Implicit Operator
FIRGBA16 Structure See Also Send Feedback
Converts the value of a Color structure to a FIRGBA16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIRGBA16 (
    Color value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Color _
) As FIRGBA16
Visual C++
static implicit operator FIRGBA16 (
    Color value
)

Parameters

value
Type: System.Drawing..::.Color
A Color structure.

Return Value

A new instance of FIRGBA16 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FIRGBA16..::.Inequality Operator
FIRGBA16 Structure See Also Send Feedback
Tests whether two specified FIRGBA16 structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FIRGBA16 left,
    FIRGBA16 right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FIRGBA16, _
    right As FIRGBA16 _
) As Boolean
Visual C++
public:
static bool operator !=(
    FIRGBA16 left,
    FIRGBA16 right
)

Parameters

left
Type: FreeImageAPI..::.FIRGBA16
The FIRGBA16 that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FIRGBA16
The FIRGBA16 that is to the right of the inequality operator.

Return Value

true if the two FIRGBA16 structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure


ToString Method

[image]

FreeImage .NET Documentation
FIRGBA16..::.ToString Method
FIRGBA16 Structure See Also Send Feedback
Converts the numeric value of the FIRGBA16 object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure


FIRGBA16 Properties

[image] [image] [image]

FreeImage .NET Documentation
FIRGBA16 Properties
FIRGBA16 Structure See Also Send Feedback

The FIRGBA16 type exposes the following members.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

FIRGBA16 Structure


Color Property

[image]

FreeImage .NET Documentation
FIRGBA16..::.Color Property
FIRGBA16 Structure See Also Send Feedback
Gets or sets the Color of the structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBA16 Structure


FIRGBAF Structure

[image]

FreeImage .NET Documentation
FIRGBAF Structure
Members Example See Also Send Feedback
The FIRGBAF structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 32 bits and takes values in the range from 0 to 1.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FIRGBAF : IComparable, IComparable<FIRGBAF>,
    IEquatable<FIRGBAF>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FIRGBAF _
    Implements IComparable, IComparable(Of FIRGBAF),  _
    IEquatable(Of FIRGBAF)
Visual C++
[SerializableAttribute]
public value class FIRGBAF : IComparable,
    IComparable<FIRGBAF>, IEquatable<FIRGBAF>

Remarks

The FIRGBAF structure provides access to an underlying FreeImage FIRGBAF structure. To determine the alpha, red, green or blue component of a color, use the alpha, red, green or blue fields, respectively.

For easy integration of the underlying structure into the .NET framework, the FIRGBAF structure implements implicit conversion operators to convert the represented color to and from the Color type. This makes the Color type a real replacement for the FIRGBAF structure and my be used in all situations which require an FIRGBAF type.

Each color component alpha, red, green or blue of FIRGBAF is translated into it's corresponding color component A, R, G or B of Color by linearly mapping the values of one range into the other range and vice versa.

Conversion from System.Drawing.Color to FIRGBAF

FIRGBAF.component = (float)Color.component / 255f

Conversion from FIRGBAF to System.Drawing.Color

Color.component = (int)(FIRGBAF.component * 255f)

The same conversion is also applied when the Color property or the FIRGBAF(Color) constructor is invoked.

Examples

The following code example demonstrates the various conversions between the FIRGBAF structure and the Color structure.
CopyC#
FIRGBAF firgbaf;
// Initialize the structure using a native .NET Color structure.
firgbaf = new FIRGBAF(Color.Indigo);
// Initialize the structure using the implicit operator.
firgbaf = Color.DarkSeaGreen;
// Convert the FIRGBAF instance into a native .NET Color
// using its implicit operator.
Color color = firgbaf;
// Using the structure's Color property for converting it
// into a native .NET Color.
Color another = firgbaf.Color;

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Members


FIRGBAF Members

[image] [image] [image]

FreeImage .NET Documentation
FIRGBAF Members
FIRGBAF Structure Constructors Methods Fields Properties See Also Send Feedback

The FIRGBAF type exposes the following members.

Constructors

Name | Description
FIRGBAF | Initializes a new instance based on the specified Color.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIRGBAF structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FIRGBAF object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIRGBAF structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIRGBAF structures are different.

Fields

Name | Description
alpha | The alpha color component.
blue | The blue color component.
green | The green color component.
red | The red color component.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

FIRGBAF Structure


FIRGBAF Constructor

[image]

FreeImage .NET Documentation
FIRGBAF Constructor
FIRGBAF Structure See Also Send Feedback
Initializes a new instance based on the specified Color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIRGBAF(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
FIRGBAF(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Color to initialize with.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure


FIRGBAF Fields

[image] [image] [image]

FreeImage .NET Documentation
FIRGBAF Fields
FIRGBAF Structure See Also Send Feedback

The FIRGBAF type exposes the following members.

Fields

Name | Description
alpha | The alpha color component.
blue | The blue color component.
green | The green color component.
red | The red color component.

See Also

FIRGBAF Structure


alpha Field

[image]

FreeImage .NET Documentation
FIRGBAF..::.alpha Field
FIRGBAF Structure See Also Send Feedback
The alpha color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public float alpha
Visual Basic (Declaration)
Public alpha As Single
Visual C++
public:
float alpha

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure


blue Field

[image]

FreeImage .NET Documentation
FIRGBAF..::.blue Field
FIRGBAF Structure See Also Send Feedback
The blue color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public float blue
Visual Basic (Declaration)
Public blue As Single
Visual C++
public:
float blue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure


green Field

[image]

FreeImage .NET Documentation
FIRGBAF..::.green Field
FIRGBAF Structure See Also Send Feedback
The green color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public float green
Visual Basic (Declaration)
Public green As Single
Visual C++
public:
float green

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure


red Field

[image]

FreeImage .NET Documentation
FIRGBAF..::.red Field
FIRGBAF Structure See Also Send Feedback
The red color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public float red
Visual Basic (Declaration)
Public red As Single
Visual C++
public:
float red

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure


FIRGBAF Methods

[image] [image] [image]

FreeImage .NET Documentation
FIRGBAF Methods
FIRGBAF Structure See Also Send Feedback

The FIRGBAF type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIRGBAF structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FIRGBAF object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIRGBAF structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIRGBAF structures are different.

See Also

FIRGBAF Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGBAF..::.CompareTo Method
FIRGBAF Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FIRGBAF) | Compares this instance with a specified FIRGBAF object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FIRGBAF Structure
FIRGBAF Members


CompareTo Method (FIRGBAF)

[image]

FreeImage .NET Documentation
FIRGBAF..::.CompareTo Method (FIRGBAF)
FIRGBAF Structure See Also Send Feedback
Compares this instance with a specified FIRGBAF object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FIRGBAF other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FIRGBAF _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FIRGBAF other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIRGBAF
A FIRGBAF to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FIRGBAF..::.CompareTo Method (Object)
FIRGBAF Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FIRGBAF.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FIRGBAF..::.Equality Operator
FIRGBAF Structure See Also Send Feedback
Tests whether two specified FIRGBAF structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FIRGBAF left,
    FIRGBAF right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FIRGBAF, _
    right As FIRGBAF _
) As Boolean
Visual C++
public:
static bool operator ==(
    FIRGBAF left,
    FIRGBAF right
)

Parameters

left
Type: FreeImageAPI..::.FIRGBAF
The FIRGBAF that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FIRGBAF
The FIRGBAF that is to the right of the equality operator.

Return Value

true if the two FIRGBAF structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGBAF..::.Equals Method
FIRGBAF Structure See Also Send Feedback

Overload List

Name | Description
Equals(FIRGBAF) | Tests whether the specified FIRGBAF structure is equivalent to this FIRGBAF structure.
Equals(Object) | Tests whether the specified object is a FIRGBAF structure and is equivalent to this FIRGBAF structure. (Overrides ValueType..::.Equals(Object).)

See Also

FIRGBAF Structure
FIRGBAF Members


Equals Method (FIRGBAF)

[image]

FreeImage .NET Documentation
FIRGBAF..::.Equals Method (FIRGBAF)
FIRGBAF Structure See Also Send Feedback
Tests whether the specified FIRGBAF structure is equivalent to this FIRGBAF structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FIRGBAF other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FIRGBAF _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FIRGBAF other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIRGBAF
A FIRGBAF structure to compare to this instance.

Return Value

true if obj is a FIRGBAF structure equivalent to this FIRGBAF structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FIRGBAF..::.Equals Method (Object)
FIRGBAF Structure See Also Send Feedback
Tests whether the specified object is a FIRGBAF structure and is equivalent to this FIRGBAF structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a FIRGBAF structure equivalent to this FIRGBAF structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FIRGBAF..::.GetHashCode Method
FIRGBAF Structure See Also Send Feedback
Returns a hash code for this FIRGBAF structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FIRGBAF.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGBAF..::.Implicit Method
FIRGBAF Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FIRGBAF) | Converts the value of a FIRGBAF structure to a Color structure.
Implicit(Color) | Converts the value of a Color structure to a FIRGBAF structure.

See Also

FIRGBAF Structure
FIRGBAF Members


Implicit Operator

[image]

FreeImage .NET Documentation
FIRGBAF..::.Implicit Operator
FIRGBAF Structure See Also Send Feedback
Converts the value of a FIRGBAF structure to a Color structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator Color (
    FIRGBAF value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FIRGBAF _
) As Color
Visual C++
static implicit operator Color (
    FIRGBAF value
)

Parameters

value
Type: FreeImageAPI..::.FIRGBAF
A FIRGBAF structure.

Return Value

A new instance of Color initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRGBAF..::.Implicit Operator
FIRGBAF Structure See Also Send Feedback
Converts the value of a Color structure to a FIRGBAF structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIRGBAF (
    Color value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Color _
) As FIRGBAF
Visual C++
static implicit operator FIRGBAF (
    Color value
)

Parameters

value
Type: System.Drawing..::.Color
A Color structure.

Return Value

A new instance of FIRGBAF initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FIRGBAF..::.Inequality Operator
FIRGBAF Structure See Also Send Feedback
Tests whether two specified FIRGBAF structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FIRGBAF left,
    FIRGBAF right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FIRGBAF, _
    right As FIRGBAF _
) As Boolean
Visual C++
public:
static bool operator !=(
    FIRGBAF left,
    FIRGBAF right
)

Parameters

left
Type: FreeImageAPI..::.FIRGBAF
The FIRGBAF that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FIRGBAF
The FIRGBAF that is to the right of the inequality operator.

Return Value

true if the two FIRGBAF structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure


ToString Method

[image]

FreeImage .NET Documentation
FIRGBAF..::.ToString Method
FIRGBAF Structure See Also Send Feedback
Converts the numeric value of the FIRGBAF object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure


FIRGBAF Properties

[image] [image] [image]

FreeImage .NET Documentation
FIRGBAF Properties
FIRGBAF Structure See Also Send Feedback

The FIRGBAF type exposes the following members.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

FIRGBAF Structure


Color Property

[image]

FreeImage .NET Documentation
FIRGBAF..::.Color Property
FIRGBAF Structure See Also Send Feedback
Gets or sets the Color of the structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBAF Structure


FIRGBF Structure

[image]

FreeImage .NET Documentation
FIRGBF Structure
Members Example See Also Send Feedback
The FIRGBF structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 32 bits and takes values in the range from 0 to 1.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FIRGBF : IComparable, IComparable<FIRGBF>,
    IEquatable<FIRGBF>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FIRGBF _
    Implements IComparable, IComparable(Of FIRGBF),  _
    IEquatable(Of FIRGBF)
Visual C++
[SerializableAttribute]
public value class FIRGBF : IComparable,
    IComparable<FIRGBF>, IEquatable<FIRGBF>

Remarks

The FIRGBF structure provides access to an underlying FreeImage FIRGBF structure. To determine the red, green or blue component of a color, use the red, green or blue fields, respectively.

For easy integration of the underlying structure into the .NET framework, the FIRGBF structure implements implicit conversion operators to convert the represented color to and from the Color type. This makes the Color type a real replacement for the FIRGBF structure and my be used in all situations which require an FIRGBF type.

Each color component alpha, red, green or blue of FIRGBF is translated into it's corresponding color component A, R, G or B of Color by linearly mapping the values of one range into the other range and vice versa. When converting from Color into FIRGBF, the color's alpha value is ignored and assumed to be 255 when converting from FIRGBF into Color, creating a fully opaque color.

Conversion from System.Drawing.Color to FIRGBF

FIRGBF.component = (float)Color.component / 255f

Conversion from FIRGBF to System.Drawing.Color

Color.component = (int)(FIRGBF.component * 255f)

The same conversion is also applied when the Color property or the FIRGBF(Color) constructor is invoked.

Examples

The following code example demonstrates the various conversions between the FIRGBF structure and the Color structure.
CopyC#
FIRGBF firgbf;
// Initialize the structure using a native .NET Color structure.
firgbf = new FIRGBF(Color.Indigo);
// Initialize the structure using the implicit operator.
firgbf = Color.DarkSeaGreen;
// Convert the FIRGBF instance into a native .NET Color
// using its implicit operator.
Color color = firgbf;
// Using the structure's Color property for converting it
// into a native .NET Color.
Color another = firgbf.Color;

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Members


FIRGBF Members

[image] [image] [image]

FreeImage .NET Documentation
FIRGBF Members
FIRGBF Structure Constructors Methods Fields Properties See Also Send Feedback

The FIRGBF type exposes the following members.

Constructors

Name | Description
FIRGBF | Initializes a new instance based on the specified Color.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIRGBF structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FIRGBF object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIRGBF structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIRGBF structures are different.

Fields

Name | Description
blue | The blue color component.
green | The green color component.
red | The red color component.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

FIRGBF Structure


FIRGBF Constructor

[image]

FreeImage .NET Documentation
FIRGBF Constructor
FIRGBF Structure See Also Send Feedback
Initializes a new instance based on the specified Color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIRGBF(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
FIRGBF(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Color to initialize with.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure


FIRGBF Fields

[image] [image] [image]

FreeImage .NET Documentation
FIRGBF Fields
FIRGBF Structure See Also Send Feedback

The FIRGBF type exposes the following members.

Fields

Name | Description
blue | The blue color component.
green | The green color component.
red | The red color component.

See Also

FIRGBF Structure


blue Field

[image]

FreeImage .NET Documentation
FIRGBF..::.blue Field
FIRGBF Structure See Also Send Feedback
The blue color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public float blue
Visual Basic (Declaration)
Public blue As Single
Visual C++
public:
float blue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure


green Field

[image]

FreeImage .NET Documentation
FIRGBF..::.green Field
FIRGBF Structure See Also Send Feedback
The green color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public float green
Visual Basic (Declaration)
Public green As Single
Visual C++
public:
float green

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure


red Field

[image]

FreeImage .NET Documentation
FIRGBF..::.red Field
FIRGBF Structure See Also Send Feedback
The red color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public float red
Visual Basic (Declaration)
Public red As Single
Visual C++
public:
float red

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure


FIRGBF Methods

[image] [image] [image]

FreeImage .NET Documentation
FIRGBF Methods
FIRGBF Structure See Also Send Feedback

The FIRGBF type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIRGBF structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the FIRGBF object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FIRGBF structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FIRGBF structures are different.

See Also

FIRGBF Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGBF..::.CompareTo Method
FIRGBF Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FIRGBF) | Compares this instance with a specified FIRGBF object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FIRGBF Structure
FIRGBF Members


CompareTo Method (FIRGBF)

[image]

FreeImage .NET Documentation
FIRGBF..::.CompareTo Method (FIRGBF)
FIRGBF Structure See Also Send Feedback
Compares this instance with a specified FIRGBF object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FIRGBF other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FIRGBF _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FIRGBF other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIRGBF
A FIRGBF to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FIRGBF..::.CompareTo Method (Object)
FIRGBF Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FIRGBF.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FIRGBF..::.Equality Operator
FIRGBF Structure See Also Send Feedback
Tests whether two specified FIRGBF structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FIRGBF left,
    FIRGBF right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FIRGBF, _
    right As FIRGBF _
) As Boolean
Visual C++
public:
static bool operator ==(
    FIRGBF left,
    FIRGBF right
)

Parameters

left
Type: FreeImageAPI..::.FIRGBF
The FIRGBF that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FIRGBF
The FIRGBF that is to the right of the equality operator.

Return Value

true if the two FIRGBF structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGBF..::.Equals Method
FIRGBF Structure See Also Send Feedback

Overload List

Name | Description
Equals(FIRGBF) | Tests whether the specified FIRGBF structure is equivalent to this FIRGBF structure.
Equals(Object) | Tests whether the specified object is a FIRGBF structure and is equivalent to this FIRGBF structure. (Overrides ValueType..::.Equals(Object).)

See Also

FIRGBF Structure
FIRGBF Members


Equals Method (FIRGBF)

[image]

FreeImage .NET Documentation
FIRGBF..::.Equals Method (FIRGBF)
FIRGBF Structure See Also Send Feedback
Tests whether the specified FIRGBF structure is equivalent to this FIRGBF structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FIRGBF other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FIRGBF _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FIRGBF other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIRGBF
A FIRGBF structure to compare to this instance.

Return Value

true if obj is a FIRGBF structure equivalent to this FIRGBF structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FIRGBF..::.Equals Method (Object)
FIRGBF Structure See Also Send Feedback
Tests whether the specified object is a FIRGBF structure and is equivalent to this FIRGBF structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a FIRGBF structure equivalent to this FIRGBF structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FIRGBF..::.GetHashCode Method
FIRGBF Structure See Also Send Feedback
Returns a hash code for this FIRGBF structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FIRGBF.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIRGBF..::.Implicit Method
FIRGBF Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FIRGBF) | Converts the value of a FIRGBF structure to a Color structure.
Implicit(Color) | Converts the value of a Color structure to a FIRGBF structure.

See Also

FIRGBF Structure
FIRGBF Members


Implicit Operator

[image]

FreeImage .NET Documentation
FIRGBF..::.Implicit Operator
FIRGBF Structure See Also Send Feedback
Converts the value of a FIRGBF structure to a Color structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator Color (
    FIRGBF value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FIRGBF _
) As Color
Visual C++
static implicit operator Color (
    FIRGBF value
)

Parameters

value
Type: FreeImageAPI..::.FIRGBF
A FIRGBF structure.

Return Value

A new instance of Color initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIRGBF..::.Implicit Operator
FIRGBF Structure See Also Send Feedback
Converts the value of a Color structure to a FIRGBF structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIRGBF (
    Color value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Color _
) As FIRGBF
Visual C++
static implicit operator FIRGBF (
    Color value
)

Parameters

value
Type: System.Drawing..::.Color
A Color structure.

Return Value

A new instance of FIRGBF initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FIRGBF..::.Inequality Operator
FIRGBF Structure See Also Send Feedback
Tests whether two specified FIRGBF structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FIRGBF left,
    FIRGBF right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FIRGBF, _
    right As FIRGBF _
) As Boolean
Visual C++
public:
static bool operator !=(
    FIRGBF left,
    FIRGBF right
)

Parameters

left
Type: FreeImageAPI..::.FIRGBF
The FIRGBF that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FIRGBF
The FIRGBF that is to the right of the inequality operator.

Return Value

true if the two FIRGBF structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure


ToString Method

[image]

FreeImage .NET Documentation
FIRGBF..::.ToString Method
FIRGBF Structure See Also Send Feedback
Converts the numeric value of the FIRGBF object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure


FIRGBF Properties

[image] [image] [image]

FreeImage .NET Documentation
FIRGBF Properties
FIRGBF Structure See Also Send Feedback

The FIRGBF type exposes the following members.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

FIRGBF Structure


Color Property

[image]

FreeImage .NET Documentation
FIRGBF..::.Color Property
FIRGBF Structure See Also Send Feedback
Gets or sets the Color of the structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIRGBF Structure


FITAG Structure

[image]

FreeImage .NET Documentation
FITAG Structure
Members See Also Send Feedback
The FITAG structure is a handle to a FreeImage metadata tag.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FITAG : IComparable, IComparable<FITAG>,
    IEquatable<FITAG>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FITAG _
    Implements IComparable, IComparable(Of FITAG),  _
    IEquatable(Of FITAG)
Visual C++
[SerializableAttribute]
public value class FITAG : IComparable,
    IComparable<FITAG>, IEquatable<FITAG>

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Members


FITAG Members

[image] [image] [image]

FreeImage .NET Documentation
FITAG Members
FITAG Structure Constructors Methods Fields Properties See Also Send Feedback

The FITAG type exposes the following members.

Constructors

Name | Description
FITAG | Overloaded.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FITAG structure. (Overrides ValueType..::.GetHashCode()()().)
SetNull | Sets the handle to null.
ToString | Converts the numeric value of the FITAG object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FITAG structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FITAG structures are different.

Fields

Name | Description
Zero | A read-only field that represents a handle that has been initialized to zero.

Properties

Name | Description
IsNull | Gets whether the pointer is a null pointer or not.

See Also

FITAG Structure


FITAG Constructor

[image] [image] [image]

FreeImage .NET Documentation
FITAG Constructor
FITAG Structure See Also Send Feedback

Overload List

Name | Description
FITAG(Int32) | Initializes a new instance of the FITAG structure to the value indicated by a specified pointer to a native FITAG structure.
FITAG(IntPtr) | Initializes a new instance of the FITAG structure to the value indicated by a specified pointer to a native FITAG structure.

See Also

FITAG Structure
FITAG Members


FITAG Constructor (Int32)

[image]

FreeImage .NET Documentation
FITAG Constructor (Int32)
FITAG Structure See Also Send Feedback
Initializes a new instance of the FITAG structure to the value indicated by a specified pointer to a native FITAG structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FITAG(
    int ptr
)
Visual Basic (Declaration)
Public Sub New ( _
    ptr As Integer _
)
Visual C++
public:
FITAG(
    int ptr
)

Parameters

ptr
Type: System..::.Int32
A pointer to a native FITAG structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FITAG Structure
FITAG Overload


FITAG Constructor (IntPtr)

[image]

FreeImage .NET Documentation
FITAG Constructor (IntPtr)
FITAG Structure See Also Send Feedback
Initializes a new instance of the FITAG structure to the value indicated by a specified pointer to a native FITAG structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FITAG(
    IntPtr ptr
)
Visual Basic (Declaration)
Public Sub New ( _
    ptr As IntPtr _
)
Visual C++
public:
FITAG(
    IntPtr ptr
)

Parameters

ptr
Type: System..::.IntPtr
A pointer to a native FITAG structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FITAG Structure
FITAG Overload


FITAG Fields

[image] [image] [image]

FreeImage .NET Documentation
FITAG Fields
FITAG Structure See Also Send Feedback

The FITAG type exposes the following members.

Fields

Name | Description
Zero | A read-only field that represents a handle that has been initialized to zero.

See Also

FITAG Structure


Zero Field

[image]

FreeImage .NET Documentation
FITAG..::.Zero Field
FITAG Structure See Also Send Feedback
A read-only field that represents a handle that has been initialized to zero.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FITAG Zero
Visual Basic (Declaration)
Public Shared ReadOnly Zero As FITAG
Visual C++
public:
static initonly FITAG Zero

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Structure


FITAG Methods

[image] [image] [image]

FreeImage .NET Documentation
FITAG Methods
FITAG Structure See Also Send Feedback

The FITAG type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FITAG structure. (Overrides ValueType..::.GetHashCode()()().)
SetNull | Sets the handle to null.
ToString | Converts the numeric value of the FITAG object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified FITAG structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified FITAG structures are different.

See Also

FITAG Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FITAG..::.CompareTo Method
FITAG Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FITAG) | Compares this instance with a specified FITAG object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FITAG Structure
FITAG Members


CompareTo Method (FITAG)

[image]

FreeImage .NET Documentation
FITAG..::.CompareTo Method (FITAG)
FITAG Structure See Also Send Feedback
Compares this instance with a specified FITAG object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FITAG other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FITAG _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FITAG other
) sealed

Parameters

other
Type: FreeImageAPI..::.FITAG
A FITAG to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FITAG..::.CompareTo Method (Object)
FITAG Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FITAG.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
FITAG..::.Equality Operator
FITAG Structure See Also Send Feedback
Tests whether two specified FITAG structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FITAG left,
    FITAG right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FITAG, _
    right As FITAG _
) As Boolean
Visual C++
public:
static bool operator ==(
    FITAG left,
    FITAG right
)

Parameters

left
Type: FreeImageAPI..::.FITAG
The FITAG that is to the left of the equality operator.
right
Type: FreeImageAPI..::.FITAG
The FITAG that is to the right of the equality operator.

Return Value

true if the two FITAG structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FITAG..::.Equals Method
FITAG Structure See Also Send Feedback

Overload List

Name | Description
Equals(FITAG) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides ValueType..::.Equals(Object).)

See Also

FITAG Structure
FITAG Members


Equals Method (FITAG)

[image]

FreeImage .NET Documentation
FITAG..::.Equals Method (FITAG)
FITAG Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FITAG other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FITAG _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FITAG other
) sealed

Parameters

other
Type: FreeImageAPI..::.FITAG
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FITAG..::.Equals Method (Object)
FITAG Structure See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FITAG..::.GetHashCode Method
FITAG Structure See Also Send Feedback
Returns a hash code for this FITAG structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FITAG.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FITAG..::.Implicit Method
FITAG Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FITAG) | Converts the FITAG structure specified in handle to an IntPtr.
Implicit(FITAG) | Converts the FITAG structure specified in handle to a 32-bit value.
Implicit(Int32) | Converts the pointer specified in ptr to a FITAG structure.
Implicit(IntPtr) | Converts the pointer specified in ptr to a FITAG structure.

See Also

FITAG Structure
FITAG Members


Implicit Operator

[image]

FreeImage .NET Documentation
FITAG..::.Implicit Operator
FITAG Structure See Also Send Feedback
Converts the FITAG structure specified in handle to an IntPtr.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator IntPtr (
    FITAG handle
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    handle As FITAG _
) As IntPtr
Visual C++
static implicit operator IntPtr (
    FITAG handle
)

Parameters

handle
Type: FreeImageAPI..::.FITAG
A FITAG structure to be converted into an IntPtr.

Return Value

An IntPtr initialized with the pointer of the FITAG structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FITAG Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FITAG..::.Implicit Operator
FITAG Structure See Also Send Feedback
Converts the FITAG structure specified in handle to a 32-bit value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator int (
    FITAG handle
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    handle As FITAG _
) As Integer
Visual C++
static implicit operator int (
    FITAG handle
)

Parameters

handle
Type: FreeImageAPI..::.FITAG
A FITAG structure to be converted into a 32-bit value.

Return Value

A 32-bit value initialized with the pointer of the FITAG structure.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FITAG Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FITAG..::.Implicit Operator
FITAG Structure See Also Send Feedback
Converts the pointer specified in ptr to a FITAG structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FITAG (
    int ptr
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    ptr As Integer _
) As FITAG
Visual C++
static implicit operator FITAG (
    int ptr
)

Parameters

ptr
Type: System..::.Int32
A 32-bit value to be converted into a FITAG structure.

Return Value

A FITAG structure initialized with the specified pointer.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FITAG Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FITAG..::.Implicit Operator
FITAG Structure See Also Send Feedback
Converts the pointer specified in ptr to a FITAG structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FITAG (
    IntPtr ptr
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    ptr As IntPtr _
) As FITAG
Visual C++
static implicit operator FITAG (
    IntPtr ptr
)

Parameters

ptr
Type: System..::.IntPtr
A 32-bit value to be converted into a FITAG structure.

Return Value

A FITAG structure initialized with the specified pointer.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FITAG Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FITAG..::.Inequality Operator
FITAG Structure See Also Send Feedback
Tests whether two specified FITAG structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FITAG left,
    FITAG right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FITAG, _
    right As FITAG _
) As Boolean
Visual C++
public:
static bool operator !=(
    FITAG left,
    FITAG right
)

Parameters

left
Type: FreeImageAPI..::.FITAG
The FITAG that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.FITAG
The FITAG that is to the right of the inequality operator.

Return Value

true if the two FITAG structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Structure


SetNull Method

[image]

FreeImage .NET Documentation
FITAG..::.SetNull Method
FITAG Structure See Also Send Feedback
Sets the handle to null.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SetNull()
Visual Basic (Declaration)
Public Sub SetNull
Visual C++
public:
void SetNull()

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Structure


ToString Method

[image]

FreeImage .NET Documentation
FITAG..::.ToString Method
FITAG Structure See Also Send Feedback
Converts the numeric value of the FITAG object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Structure


FITAG Properties

[image] [image] [image]

FreeImage .NET Documentation
FITAG Properties
FITAG Structure See Also Send Feedback

The FITAG type exposes the following members.

Properties

Name | Description
IsNull | Gets whether the pointer is a null pointer or not.

See Also

FITAG Structure


IsNull Property

[image]

FreeImage .NET Documentation
FITAG..::.IsNull Property
FITAG Structure See Also Send Feedback
Gets whether the pointer is a null pointer or not.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsNull { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
Visual C++
public:
property bool IsNull {
    bool get ();
}

Field Value

true if this FITAG is a null pointer; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FITAG Structure


FIURational Structure

[image]

FreeImage .NET Documentation
FIURational Structure
Members See Also Send Feedback
The FIURational structure represents a fraction via two UInt32 instances which are interpreted as numerator and denominator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct FIURational : IConvertible,
    IComparable, IFormattable, IComparable<FIURational>, IEquatable<FIURational>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure FIURational _
    Implements IConvertible, IComparable, IFormattable, IComparable(Of FIURational),  _
    IEquatable(Of FIURational)
Visual C++
[SerializableAttribute]
public value class FIURational : IConvertible,
    IComparable, IFormattable, IComparable<FIURational>, IEquatable<FIURational>

Remarks

The structure tries to approximate the value of FIURational(Decimal) when creating a new instance by using a better algorithm than FreeImage does.

The structure implements the following operators: +, ++, --, ==, != , >, >==, <, <== and ~ (which switches nominator and denomiator).

The structure can be converted into all .NET standard types either implicit or explicit.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Members


FIURational Members

[image] [image] [image]

FreeImage .NET Documentation
FIURational Members
FIURational Structure Constructors Methods Fields Properties See Also Send Feedback

The FIURational type exposes the following members.

Constructors

Name | Description
FIURational | Overloaded.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIURational structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Overloaded.
Truncate | Returns the truncated value of the fraction.

Operators

Name | Description
Addition | Standard implementation of the operator.
Decrement | Standard implementation of the operator.
Division | Standard implementation of the operator.
Equality | Standard implementation of the operator.
Explicit | Overloaded.
GreaterThan | Standard implementation of the operator.
GreaterThanOrEqual | Standard implementation of the operator.
Implicit | Overloaded.
Increment | Standard implementation of the operator.
Inequality | Standard implementation of the operator.
LessThan | Standard implementation of the operator.
LessThanOrEqual | Standard implementation of the operator.
Modulus | Standard implementation of the operator.
Multiply | Standard implementation of the operator.
OnesComplement | Returns the reciprocal value of this instance.
Subtraction | Standard implementation of the operator.
UnaryPlus | Standard implementation of the operator.

Fields

Name | Description
Epsilon | Represents the smallest positive FIURational value greater than zero. This field is constant.
MaxValue | Represents the largest possible value of FIURational. This field is constant.
MinValue | Represents the smallest possible value of FIURational. This field is constant.

Properties

Name | Description
Denominator | The denominator of the fraction.
IsInteger | Returns whether the fraction is representing an integer value.
Numerator | The numerator of the fraction.

See Also

FIURational Structure


FIURational Constructor

[image] [image] [image]

FreeImage .NET Documentation
FIURational Constructor
FIURational Structure See Also Send Feedback

Overload List

Name | Description
FIURational(FITAG) | Initializes a new instance based on the specified parameters.
FIURational(FIURational) | Initializes a new instance based on the specified parameters.
FIURational(Decimal) | Initializes a new instance based on the specified parameters.
FIURational(UInt32, UInt32) | Initializes a new instance based on the specified parameters.

See Also

FIURational Structure
FIURational Members


FIURational Constructor (FITAG)

[image]

FreeImage .NET Documentation
FIURational Constructor (FITAG)
FIURational Structure See Also Send Feedback
Initializes a new instance based on the specified parameters.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational(
    FITAG tag
)
Visual Basic (Declaration)
Public Sub New ( _
    tag As FITAG _
)
Visual C++
public:
FIURational(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag to read the data from.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
FIURational Overload


FIURational Constructor (FIURational)

[image]

FreeImage .NET Documentation
FIURational Constructor (FIURational)
FIURational Structure See Also Send Feedback
Initializes a new instance based on the specified parameters.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational(
    FIURational r
)
Visual Basic (Declaration)
Public Sub New ( _
    r As FIURational _
)
Visual C++
public:
FIURational(
    FIURational r
)

Parameters

r
Type: FreeImageAPI..::.FIURational
The structure to clone from.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FIURational Structure
FIURational Overload


FIURational Constructor (Decimal)

[image]

FreeImage .NET Documentation
FIURational Constructor (Decimal)
FIURational Structure See Also Send Feedback
Initializes a new instance based on the specified parameters.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational(
    decimal value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Decimal _
)
Visual C++
public:
FIURational(
    Decimal value
)

Parameters

value
Type: System..::.Decimal
The value to convert into a fraction.

Exceptions

Exception | Condition
System..::.OverflowException | value cannot be converted into a fraction represented by two unsigned integer values.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
FIURational Overload


FIURational Constructor (UInt32, UInt32)

[image]

FreeImage .NET Documentation
FIURational Constructor (UInt32, UInt32)
FIURational Structure See Also Send Feedback
Initializes a new instance based on the specified parameters.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational(
    uint n,
    uint d
)
Visual Basic (Declaration)
Public Sub New ( _
    n As UInteger, _
    d As UInteger _
)
Visual C++
public:
FIURational(
    unsigned int n,
    unsigned int d
)

Parameters

n
Type: System..::.UInt32
The numerator.
d
Type: System..::.UInt32
The denominator.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
FIURational Overload


FIURational Fields

[image] [image] [image]

FreeImage .NET Documentation
FIURational Fields
FIURational Structure See Also Send Feedback

The FIURational type exposes the following members.

Fields

Name | Description
Epsilon | Represents the smallest positive FIURational value greater than zero. This field is constant.
MaxValue | Represents the largest possible value of FIURational. This field is constant.
MinValue | Represents the smallest possible value of FIURational. This field is constant.

See Also

FIURational Structure


Epsilon Field

[image]

FreeImage .NET Documentation
FIURational..::.Epsilon Field
FIURational Structure See Also Send Feedback
Represents the smallest positive FIURational value greater than zero. This field is constant.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FIURational Epsilon
Visual Basic (Declaration)
Public Shared ReadOnly Epsilon As FIURational
Visual C++
public:
static initonly FIURational Epsilon

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


MaxValue Field

[image]

FreeImage .NET Documentation
FIURational..::.MaxValue Field
FIURational Structure See Also Send Feedback
Represents the largest possible value of FIURational. This field is constant.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FIURational MaxValue
Visual Basic (Declaration)
Public Shared ReadOnly MaxValue As FIURational
Visual C++
public:
static initonly FIURational MaxValue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


MinValue Field

[image]

FreeImage .NET Documentation
FIURational..::.MinValue Field
FIURational Structure See Also Send Feedback
Represents the smallest possible value of FIURational. This field is constant.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FIURational MinValue
Visual Basic (Declaration)
Public Shared ReadOnly MinValue As FIURational
Visual C++
public:
static initonly FIURational MinValue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


FIURational Methods

[image] [image] [image]

FreeImage .NET Documentation
FIURational Methods
FIURational Structure See Also Send Feedback

The FIURational type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this FIURational structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Overloaded.
Truncate | Returns the truncated value of the fraction.

Operators

Name | Description
Addition | Standard implementation of the operator.
Decrement | Standard implementation of the operator.
Division | Standard implementation of the operator.
Equality | Standard implementation of the operator.
Explicit | Overloaded.
GreaterThan | Standard implementation of the operator.
GreaterThanOrEqual | Standard implementation of the operator.
Implicit | Overloaded.
Increment | Standard implementation of the operator.
Inequality | Standard implementation of the operator.
LessThan | Standard implementation of the operator.
LessThanOrEqual | Standard implementation of the operator.
Modulus | Standard implementation of the operator.
Multiply | Standard implementation of the operator.
OnesComplement | Returns the reciprocal value of this instance.
Subtraction | Standard implementation of the operator.
UnaryPlus | Standard implementation of the operator.

See Also

FIURational Structure


Addition Operator

[image]

FreeImage .NET Documentation
FIURational..::.Addition Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIURational operator +(
    FIURational left,
    FIURational right
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    left As FIURational, _
    right As FIURational _
) As FIURational
Visual C++
public:
static FIURational operator +(
    FIURational left,
    FIURational right
)

Parameters

left
Type: FreeImageAPI..::.FIURational
right
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
FIURational..::.CompareTo Method
FIURational Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(FIURational) | Compares this instance with a specified FIURational object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

FIURational Structure
FIURational Members


CompareTo Method (FIURational)

[image]

FreeImage .NET Documentation
FIURational..::.CompareTo Method (FIURational)
FIURational Structure See Also Send Feedback
Compares this instance with a specified FIURational object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    FIURational other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As FIURational _
) As Integer
Visual C++
public:
virtual int CompareTo(
    FIURational other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIURational
A FIURational to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
FIURational..::.CompareTo Method (Object)
FIURational Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a FIURational.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
CompareTo Overload


Decrement Operator

[image]

FreeImage .NET Documentation
FIURational..::.Decrement Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIURational operator --(
    FIURational value
)
Visual Basic (Declaration)
Public Shared Operator -- ( _
    value As FIURational _
) As FIURational
Visual C++
public:
static FIURational operator --(
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


Division Operator

[image]

FreeImage .NET Documentation
FIURational..::.Division Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIURational operator /(
    FIURational left,
    FIURational right
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    left As FIURational, _
    right As FIURational _
) As FIURational
Visual C++
public:
static FIURational operator /(
    FIURational left,
    FIURational right
)

Parameters

left
Type: FreeImageAPI..::.FIURational
right
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


Equality Operator

[image]

FreeImage .NET Documentation
FIURational..::.Equality Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FIURational left,
    FIURational right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FIURational, _
    right As FIURational _
) As Boolean
Visual C++
public:
static bool operator ==(
    FIURational left,
    FIURational right
)

Parameters

left
Type: FreeImageAPI..::.FIURational
right
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
FIURational..::.Equals Method
FIURational Structure See Also Send Feedback

Overload List

Name | Description
Equals(FIURational) | Tests whether the specified FIURational structure is equivalent to this FIURational structure.
Equals(Object) | Tests whether the specified object is a FIURational structure and is equivalent to this FIURational structure. (Overrides ValueType..::.Equals(Object).)

See Also

FIURational Structure
FIURational Members


Equals Method (FIURational)

[image]

FreeImage .NET Documentation
FIURational..::.Equals Method (FIURational)
FIURational Structure See Also Send Feedback
Tests whether the specified FIURational structure is equivalent to this FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    FIURational other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As FIURational _
) As Boolean
Visual C++
public:
virtual bool Equals(
    FIURational other
) sealed

Parameters

other
Type: FreeImageAPI..::.FIURational
A FIURational structure to compare to this instance.

Return Value

true if obj is a FIURational structure equivalent to this FIURational structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
FIURational..::.Equals Method (Object)
FIURational Structure See Also Send Feedback
Tests whether the specified object is a FIURational structure and is equivalent to this FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a FIURational structure equivalent to this FIURational structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Equals Overload


Explicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIURational..::.Explicit Method
FIURational Structure See Also Send Feedback

Overload List

Name | Description
Explicit(FIURational) | Converts the value of a FIURational structure to an Int64 structure.
Explicit(FIURational) | Converts the value of a FIURational structure to a SByte structure.
Explicit(FIURational) | Converts the value of a FIURational structure to a Char structure.
Explicit(FIURational) | Converts the value of a FIURational structure to an Int32 structure.
Explicit(FIURational) | Converts the value of a FIURational structure to an Int16 structure.
Explicit(FIURational) | Converts the value of a FIURational structure to an UInt32 structure.
Explicit(FIURational) | Converts the value of a FIURational structure to an UInt16 structure.
Explicit(FIURational) | Converts the value of a FIURational structure to an UInt32 structure.
Explicit(FIURational) | Converts the value of a FIURational structure to a Byte structure.
Explicit(FIURational) | Converts the value of a FIURational structure to a Boolean structure.
Explicit(Boolean) | Converts the value of a Boolean structure to a FIURational structure.
Explicit(Decimal) | Converts the value of a Decimal structure to a FIURational structure.
Explicit(Double) | Converts the value of a Double structure to a FIURational structure.
Explicit(Int64) | Converts the value of an Int64 structure to a FIURational structure.
Explicit(Single) | Converts the value of a Single structure to a FIURational structure.
Explicit(UInt32) | Converts the value of an UInt32 structure to a FIURational structure.
Explicit(UInt64) | Converts the value of an UInt64 structure to a FIURational structure.

See Also

FIURational Structure
FIURational Members


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to an Int64 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator long (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIURational _
) As Long
Visual C++
static explicit operator long long (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of Int64 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to a SByte structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator sbyte (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIURational _
) As SByte
Visual C++
static explicit operator signed char (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of SByte initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to a Char structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator char (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIURational _
) As Char
Visual C++
static explicit operator wchar_t (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of Char initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to an Int32 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator int (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIURational _
) As Integer
Visual C++
static explicit operator int (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of Int32 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to an Int16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator short (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIURational _
) As Short
Visual C++
static explicit operator short (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of Int16 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to an UInt32 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator ulong (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIURational _
) As ULong
Visual C++
static explicit operator unsigned long long (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of UInt32 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to an UInt16 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator ushort (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIURational _
) As UShort
Visual C++
static explicit operator unsigned short (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of UInt16 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to an UInt32 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator uint (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIURational _
) As UInteger
Visual C++
static explicit operator unsigned int (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of UInt32 initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to a Byte structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator byte (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIURational _
) As Byte
Visual C++
static explicit operator unsigned char (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of Byte initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to a Boolean structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator bool (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FIURational _
) As Boolean
Visual C++
static explicit operator bool (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of Boolean initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a Boolean structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIURational (
    bool value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As Boolean _
) As FIURational
Visual C++
static explicit operator FIURational (
    bool value
)

Parameters

value
Type: System..::.Boolean
A Boolean structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a Decimal structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIURational (
    decimal value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As Decimal _
) As FIURational
Visual C++
static explicit operator FIURational (
    Decimal value
)

Parameters

value
Type: System..::.Decimal
A Decimal structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a Double structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIURational (
    double value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As Double _
) As FIURational
Visual C++
static explicit operator FIURational (
    double value
)

Parameters

value
Type: System..::.Double
A Double structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of an Int64 structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIURational (
    long value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As Long _
) As FIURational
Visual C++
static explicit operator FIURational (
    long long value
)

Parameters

value
Type: System..::.Int64
An Int64 structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a Single structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIURational (
    float value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As Single _
) As FIURational
Visual C++
static explicit operator FIURational (
    float value
)

Parameters

value
Type: System..::.Single
A Single structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of an UInt32 structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIURational (
    uint value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As UInteger _
) As FIURational
Visual C++
static explicit operator FIURational (
    unsigned int value
)

Parameters

value
Type: System..::.UInt32
An UInt32 structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Explicit Operator
FIURational Structure See Also Send Feedback
Converts the value of an UInt64 structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FIURational (
    ulong value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As ULong _
) As FIURational
Visual C++
static explicit operator FIURational (
    unsigned long long value
)

Parameters

value
Type: System..::.UInt64
An UInt64 structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Explicit Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FIURational..::.GetHashCode Method
FIURational Structure See Also Send Feedback
Returns a hash code for this FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FIURational.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


GreaterThan Operator

[image]

FreeImage .NET Documentation
FIURational..::.GreaterThan Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator >(
    FIURational left,
    FIURational right
)
Visual Basic (Declaration)
Public Shared Operator > ( _
    left As FIURational, _
    right As FIURational _
) As Boolean
Visual C++
public:
static bool operator >(
    FIURational left,
    FIURational right
)

Parameters

left
Type: FreeImageAPI..::.FIURational
right
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


GreaterThanOrEqual Operator

[image]

FreeImage .NET Documentation
FIURational..::.GreaterThanOrEqual Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator >=(
    FIURational left,
    FIURational right
)
Visual Basic (Declaration)
Public Shared Operator >= ( _
    left As FIURational, _
    right As FIURational _
) As Boolean
Visual C++
public:
static bool operator >=(
    FIURational left,
    FIURational right
)

Parameters

left
Type: FreeImageAPI..::.FIURational
right
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FIURational..::.Implicit Method
FIURational Structure See Also Send Feedback

Overload List

Name | Description
Implicit(FIURational) | Converts the value of a FIURational structure to a Double structure.
Implicit(FIURational) | Converts the value of a FIURational structure to a Decimal structure.
Implicit(FIURational) | Converts the value of a FIURational structure to a Single structure.
Implicit(Byte) | Converts the value of a Byte structure to a FIURational structure.
Implicit(Char) | Converts the value of a Char structure to a FIURational structure.
Implicit(Int16) | Converts the value of an Int16 structure to a FIURational structure.
Implicit(Int32) | Converts the value of an Int32 structure to a FIURational structure.
Implicit(SByte) | Converts the value of a SByte structure to a FIURational structure.
Implicit(UInt16) | Converts the value of an UInt16 structure to a FIURational structure.

See Also

FIURational Structure
FIURational Members


Implicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Implicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to a Double structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator double (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FIURational _
) As Double
Visual C++
static implicit operator double (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of Double initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Implicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to a Decimal structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator decimal (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FIURational _
) As Decimal
Visual C++
static implicit operator Decimal (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of Decimal initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Implicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a FIURational structure to a Single structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator float (
    FIURational value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FIURational _
) As Single
Visual C++
static implicit operator float (
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational
A FIURational structure.

Return Value

A new instance of Single initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Implicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a Byte structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIURational (
    byte value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Byte _
) As FIURational
Visual C++
static implicit operator FIURational (
    unsigned char value
)

Parameters

value
Type: System..::.Byte
A Byte structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Implicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a Char structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIURational (
    char value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Char _
) As FIURational
Visual C++
static implicit operator FIURational (
    wchar_t value
)

Parameters

value
Type: System..::.Char
A Char structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Implicit Operator
FIURational Structure See Also Send Feedback
Converts the value of an Int16 structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIURational (
    short value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Short _
) As FIURational
Visual C++
static implicit operator FIURational (
    short value
)

Parameters

value
Type: System..::.Int16
An Int16 structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Implicit Operator
FIURational Structure See Also Send Feedback
Converts the value of an Int32 structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIURational (
    int value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Integer _
) As FIURational
Visual C++
static implicit operator FIURational (
    int value
)

Parameters

value
Type: System..::.Int32
An Int32 structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Implicit Operator
FIURational Structure See Also Send Feedback
Converts the value of a SByte structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIURational (
    sbyte value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As SByte _
) As FIURational
Visual C++
static implicit operator FIURational (
    signed char value
)

Parameters

value
Type: System..::.SByte
A SByte structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FIURational..::.Implicit Operator
FIURational Structure See Also Send Feedback
Converts the value of an UInt16 structure to a FIURational structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FIURational (
    ushort value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As UShort _
) As FIURational
Visual C++
static implicit operator FIURational (
    unsigned short value
)

Parameters

value
Type: System..::.UInt16
An UInt16 structure.

Return Value

A new instance of FIURational initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
Implicit Overload


Increment Operator

[image]

FreeImage .NET Documentation
FIURational..::.Increment Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIURational operator ++(
    FIURational value
)
Visual Basic (Declaration)
Public Shared Operator ++ ( _
    value As FIURational _
) As FIURational
Visual C++
public:
static FIURational operator ++(
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


Inequality Operator

[image]

FreeImage .NET Documentation
FIURational..::.Inequality Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FIURational left,
    FIURational right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FIURational, _
    right As FIURational _
) As Boolean
Visual C++
public:
static bool operator !=(
    FIURational left,
    FIURational right
)

Parameters

left
Type: FreeImageAPI..::.FIURational
right
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


LessThan Operator

[image]

FreeImage .NET Documentation
FIURational..::.LessThan Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator <(
    FIURational left,
    FIURational right
)
Visual Basic (Declaration)
Public Shared Operator < ( _
    left As FIURational, _
    right As FIURational _
) As Boolean
Visual C++
public:
static bool operator <(
    FIURational left,
    FIURational right
)

Parameters

left
Type: FreeImageAPI..::.FIURational
right
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


LessThanOrEqual Operator

[image]

FreeImage .NET Documentation
FIURational..::.LessThanOrEqual Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator <=(
    FIURational left,
    FIURational right
)
Visual Basic (Declaration)
Public Shared Operator <= ( _
    left As FIURational, _
    right As FIURational _
) As Boolean
Visual C++
public:
static bool operator <=(
    FIURational left,
    FIURational right
)

Parameters

left
Type: FreeImageAPI..::.FIURational
right
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


Modulus Operator

[image]

FreeImage .NET Documentation
FIURational..::.Modulus Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIURational operator %(
    FIURational left,
    FIURational right
)
Visual Basic (Declaration)
Public Shared Operator Mod ( _
    left As FIURational, _
    right As FIURational _
) As FIURational
Visual C++
public:
static FIURational operator %(
    FIURational left,
    FIURational right
)

Parameters

left
Type: FreeImageAPI..::.FIURational
right
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


Multiply Operator

[image]

FreeImage .NET Documentation
FIURational..::.Multiply Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIURational operator *(
    FIURational left,
    FIURational r2
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    left As FIURational, _
    r2 As FIURational _
) As FIURational
Visual C++
public:
static FIURational operator *(
    FIURational left,
    FIURational r2
)

Parameters

left
Type: FreeImageAPI..::.FIURational
r2
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


OnesComplement Operator

[image]

FreeImage .NET Documentation
FIURational..::.OnesComplement Operator
FIURational Structure See Also Send Feedback
Returns the reciprocal value of this instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIURational operator ~(
    FIURational value
)
Visual Basic (Declaration)
Public Shared Operator ~ ( _
    value As FIURational _
) As FIURational
Visual C++
public:
static FIURational operator ~(
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


Subtraction Operator

[image]

FreeImage .NET Documentation
FIURational..::.Subtraction Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIURational operator -(
    FIURational left,
    FIURational right
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    left As FIURational, _
    right As FIURational _
) As FIURational
Visual C++
public:
static FIURational operator -(
    FIURational left,
    FIURational right
)

Parameters

left
Type: FreeImageAPI..::.FIURational
right
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


ToString Method

[image] [image] [image]

FreeImage .NET Documentation
FIURational..::.ToString Method
FIURational Structure See Also Send Feedback

Overload List

Name | Description
ToString()()() | Converts the numeric value of the FIURational object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)
ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format.

See Also

FIURational Structure
FIURational Members


ToString Method

[image]

FreeImage .NET Documentation
FIURational..::.ToString Method
FIURational Structure See Also Send Feedback
Converts the numeric value of the FIURational object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
ToString Overload


ToString Method (String, IFormatProvider)

[image]

FreeImage .NET Documentation
FIURational..::.ToString Method (String, IFormatProvider)
FIURational Structure See Also Send Feedback
Formats the value of the current instance using the specified format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ToString(
    string format,
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As String, _
    formatProvider As IFormatProvider _
) As String
Visual C++
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ formatProvider
) sealed

Parameters

format
Type: System..::.String
The String specifying the format to use.
formatProvider
Type: System..::.IFormatProvider
The IFormatProvider to use to format the value.

Return Value

A String containing the value of the current instance in the specified format.

Implements

IFormattable..::.ToString(String, IFormatProvider)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure
ToString Overload


Truncate Method

[image]

FreeImage .NET Documentation
FIURational..::.Truncate Method
FIURational Structure See Also Send Feedback
Returns the truncated value of the fraction.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Truncate()
Visual Basic (Declaration)
Public Function Truncate As Integer
Visual C++
public:
int Truncate()

Return Value

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


UnaryPlus Operator

[image]

FreeImage .NET Documentation
FIURational..::.UnaryPlus Operator
FIURational Structure See Also Send Feedback
Standard implementation of the operator.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIURational operator +(
    FIURational value
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    value As FIURational _
) As FIURational
Visual C++
public:
static FIURational operator +(
    FIURational value
)

Parameters

value
Type: FreeImageAPI..::.FIURational

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


FIURational Properties

[image] [image] [image]

FreeImage .NET Documentation
FIURational Properties
FIURational Structure See Also Send Feedback

The FIURational type exposes the following members.

Properties

Name | Description
Denominator | The denominator of the fraction.
IsInteger | Returns whether the fraction is representing an integer value.
Numerator | The numerator of the fraction.

See Also

FIURational Structure


Denominator Property

[image]

FreeImage .NET Documentation
FIURational..::.Denominator Property
FIURational Structure See Also Send Feedback
The denominator of the fraction.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint Denominator { get; }
Visual Basic (Declaration)
Public ReadOnly Property Denominator As UInteger
Visual C++
public:
property unsigned int Denominator {
    unsigned int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


IsInteger Property

[image]

FreeImage .NET Documentation
FIURational..::.IsInteger Property
FIURational Structure See Also Send Feedback
Returns whether the fraction is representing an integer value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsInteger { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInteger As Boolean
Visual C++
public:
property bool IsInteger {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


Numerator Property

[image]

FreeImage .NET Documentation
FIURational..::.Numerator Property
FIURational Structure See Also Send Feedback
The numerator of the fraction.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint Numerator { get; }
Visual Basic (Declaration)
Public ReadOnly Property Numerator As UInteger
Visual C++
public:
property unsigned int Numerator {
    unsigned int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FIURational Structure


FREE_IMAGE_COLOR_CHANNEL Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_COLOR_CHANNEL Enumeration
See Also Send Feedback
Color channels. Constants used in color manipulation routines.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_COLOR_CHANNEL
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_COLOR_CHANNEL
Visual C++
public enum class FREE_IMAGE_COLOR_CHANNEL

Members

Member name | Description
FICC_RGB | Use red, green and blue channels
FICC_RED | Use red channel
FICC_GREEN | Use green channel
FICC_BLUE | Use blue channel
FICC_ALPHA | Use alpha channel
FICC_BLACK | Use black channel
FICC_REAL | Complex images: use real part
FICC_IMAG | Complex images: use imaginary part
FICC_MAG | Complex images: use magnitude
FICC_PHASE | Complex images: use phase

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_COLOR_DEPTH Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_COLOR_DEPTH Enumeration
See Also Send Feedback
Enumeration used for color conversions. FREE_IMAGE_COLOR_DEPTH contains several colors to convert to. The default value 'FICD_AUTO'.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[FlagsAttribute]
public enum FREE_IMAGE_COLOR_DEPTH
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration FREE_IMAGE_COLOR_DEPTH
Visual C++
[FlagsAttribute]
public enum class FREE_IMAGE_COLOR_DEPTH

Members

Member name | Description
FICD_UNKNOWN | Unknown.
FICD_AUTO | Auto selected by the used algorithm.
FICD_01_BPP | 1-bit.
FICD_01_BPP_DITHER | 1-bit using dithering.
FICD_01_BPP_THRESHOLD | 1-bit using threshold.
FICD_04_BPP | 4-bit.
FICD_08_BPP | 8-bit.
FICD_16_BPP_555 | 16-bit 555 (1 bit remains unused).
FICD_16_BPP | 16-bit 565 (all bits are used).
FICD_24_BPP | 24-bit.
FICD_32_BPP | 32-bit.
FICD_REORDER_PALETTE | Reorder palette (make it linear). Only affects 1-, 4- and 8-bit images. The palette is only reordered in case the image is greyscale (all palette entries have the same red, green and blue value).
FICD_FORCE_GREYSCALE | Converts the image to greyscale.
FICD_COLOR_MASK | Flag to mask out all non color depth flags.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_COLOR_OPTIONS Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_COLOR_OPTIONS Enumeration
See Also Send Feedback
Constants used in color filling routines.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_COLOR_OPTIONS
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_COLOR_OPTIONS
Visual C++
public enum class FREE_IMAGE_COLOR_OPTIONS

Members

Member name | Description
FICO_DEFAULT | Default value.
FICO_RGB | RGBQUAD color is RGB color (contains no valid alpha channel).
FICO_RGBA | RGBQUAD color is RGBA color (contains a valid alpha channel).
FICO_NEAREST_COLOR | Lookup nearest RGB color from palette.
FICO_EQUAL_COLOR | Lookup equal RGB color from palette.
FICO_ALPHA_IS_INDEX | rgbReserved contains the palette index to be used.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also


FREE_IMAGE_COLOR_TYPE Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_COLOR_TYPE Enumeration
See Also Send Feedback
Image color types used in FreeImage.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_COLOR_TYPE
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_COLOR_TYPE
Visual C++
public enum class FREE_IMAGE_COLOR_TYPE

Members

Member name | Description
FIC_MINISWHITE | min value is white
FIC_MINISBLACK | min value is black
FIC_RGB | RGB color model
FIC_PALETTE | color map indexed
FIC_RGBALPHA | RGB color model with alpha channel
FIC_CMYK | CMYK color model

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_COMPARE_FLAGS Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_COMPARE_FLAGS Enumeration
See Also Send Feedback
List of combinable compare modes.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[FlagsAttribute]
public enum FREE_IMAGE_COMPARE_FLAGS
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration FREE_IMAGE_COMPARE_FLAGS
Visual C++
[FlagsAttribute]
public enum class FREE_IMAGE_COMPARE_FLAGS

Members

Member name | Description
HEADER | Compare headers.
PALETTE | Compare palettes.
DATA | Compare pixel data.
METADATA | Compare meta data.
COMPLETE | Compare everything.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_DITHER Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_DITHER Enumeration
See Also Send Feedback
Dithering algorithms. Constants used in FreeImage_Dither.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_DITHER
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_DITHER
Visual C++
public enum class FREE_IMAGE_DITHER

Members

Member name | Description
FID_FS | Floyd and Steinberg error diffusion
FID_BAYER4x4 | Bayer ordered dispersed dot dithering (order 2 dithering matrix)
FID_BAYER8x8 | Bayer ordered dispersed dot dithering (order 3 dithering matrix)
FID_CLUSTER6x6 | Ordered clustered dot dithering (order 3 - 6x6 matrix)
FID_CLUSTER8x8 | Ordered clustered dot dithering (order 4 - 8x8 matrix)
FID_CLUSTER16x16 | Ordered clustered dot dithering (order 8 - 16x16 matrix)
FID_BAYER16x16 | Bayer ordered dispersed dot dithering (order 4 dithering matrix)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_FILTER Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_FILTER Enumeration
See Also Send Feedback
Upsampling / downsampling filters. Constants used in FreeImage_Rescale.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_FILTER
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_FILTER
Visual C++
public enum class FREE_IMAGE_FILTER

Members

Member name | Description
FILTER_BOX | Box, pulse, Fourier window, 1st order (constant) b-spline
FILTER_BICUBIC | Mitchell and Netravali's two-param cubic filter
FILTER_BILINEAR | Bilinear filter
FILTER_BSPLINE | 4th order (cubic) b-spline
FILTER_CATMULLROM | Catmull-Rom spline, Overhauser spline
FILTER_LANCZOS3 | Lanczos3 filter

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_FORMAT Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_FORMAT Enumeration
See Also Send Feedback
I/O image format identifiers.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_FORMAT
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_FORMAT
Visual C++
public enum class FREE_IMAGE_FORMAT

Members

Member name | Description
FIF_UNKNOWN | Unknown format (returned value only, never use it as input value)
FIF_BMP | Windows or OS/2 Bitmap File (*.BMP)
FIF_ICO | Windows Icon (*.ICO)
FIF_JPEG | Independent JPEG Group (*.JPG, *.JIF, *.JPEG, *.JPE)
FIF_JNG | JPEG Network Graphics (*.JNG)
FIF_KOALA | Commodore 64 Koala format (*.KOA)
FIF_LBM | Amiga IFF (*.IFF, *.LBM)
FIF_IFF | Amiga IFF (*.IFF, *.LBM)
FIF_MNG | Multiple Network Graphics (*.MNG)
FIF_PBM | Portable Bitmap (ASCII) (*.PBM)
FIF_PBMRAW | Portable Bitmap (BINARY) (*.PBM)
FIF_PCD | Kodak PhotoCD (*.PCD)
FIF_PCX | Zsoft Paintbrush PCX bitmap format (*.PCX)
FIF_PGM | Portable Graymap (ASCII) (*.PGM)
FIF_PGMRAW | Portable Graymap (BINARY) (*.PGM)
FIF_PNG | Portable Network Graphics (*.PNG)
FIF_PPM | Portable Pixelmap (ASCII) (*.PPM)
FIF_PPMRAW | Portable Pixelmap (BINARY) (*.PPM)
FIF_RAS | Sun Rasterfile (*.RAS)
FIF_TARGA | truevision Targa files (*.TGA, *.TARGA)
FIF_TIFF | Tagged Image File Format (*.TIF, *.TIFF)
FIF_WBMP | Wireless Bitmap (*.WBMP)
FIF_PSD | Adobe Photoshop (*.PSD)
FIF_CUT | Dr. Halo (*.CUT)
FIF_XBM | X11 Bitmap Format (*.XBM)
FIF_XPM | X11 Pixmap Format (*.XPM)
FIF_DDS | DirectDraw Surface (*.DDS)
FIF_GIF | Graphics Interchange Format (*.GIF)
FIF_HDR | High Dynamic Range (*.HDR)
FIF_FAXG3 | Raw Fax format CCITT G3 (*.G3)
FIF_SGI | Silicon Graphics SGI image format (*.SGI)
FIF_EXR | OpenEXR format (*.EXR)
FIF_J2K | JPEG-2000 format (*.J2K, *.J2C)
FIF_JP2 | JPEG-2000 format (*.JP2)
FIF_PFM | Portable FloatMap (*.PFM)
FIF_PICT | Macintosh PICT (*.PICT)
FIF_RAW | RAW camera image (*.*)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_JPEG_OPERATION Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_JPEG_OPERATION Enumeration
See Also Send Feedback
Lossless JPEG transformations constants used in FreeImage_JPEGTransform.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_JPEG_OPERATION
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_JPEG_OPERATION
Visual C++
public enum class FREE_IMAGE_JPEG_OPERATION

Members

Member name | Description
FIJPEG_OP_NONE | no transformation
FIJPEG_OP_FLIP_H | horizontal flip
FIJPEG_OP_FLIP_V | vertical flip
FIJPEG_OP_TRANSPOSE | transpose across UL-to-LR axis
FIJPEG_OP_TRANSVERSE | transpose across UR-to-LL axis
FIJPEG_OP_ROTATE_90 | 90-degree clockwise rotation
FIJPEG_OP_ROTATE_180 | 180-degree rotation
FIJPEG_OP_ROTATE_270 | 270-degree clockwise (or 90 ccw)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_LOAD_FLAGS Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_LOAD_FLAGS Enumeration
See Also Send Feedback
Flags used in load functions.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[FlagsAttribute]
public enum FREE_IMAGE_LOAD_FLAGS
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration FREE_IMAGE_LOAD_FLAGS
Visual C++
[FlagsAttribute]
public enum class FREE_IMAGE_LOAD_FLAGS

Members

Member name | Description
DEFAULT | Default option for all types.
GIF_LOAD256 | Load the image as a 256 color image with ununsed palette entries, if it's 16 or 2 color.
GIF_PLAYBACK | 'Play' the GIF to generate each frame (as 32bpp) instead of returning raw frame data when loading.
ICO_MAKEALPHA | Convert to 32bpp and create an alpha channel from the AND-mask when loading.
JPEG_FAST | Load the file as fast as possible, sacrificing some quality.
JPEG_ACCURATE | Load the file with the best quality, sacrificing some speed.
JPEG_CMYK | Load separated CMYK "as is" (use | to combine with other load flags).
PCD_BASE | Load the bitmap sized 768 x 512.
PCD_BASEDIV4 | Load the bitmap sized 384 x 256.
PCD_BASEDIV16 | Load the bitmap sized 192 x 128.
PNG_IGNOREGAMMA | Avoid gamma correction.
TARGA_LOAD_RGB888 | If set the loader converts RGB555 and ARGB8888 -> RGB888.
TIFF_CMYK | Reads tags for separated CMYK.
JPEG_EXIFROTATE | Load and rotate according to Exif 'Orientation' tag if available.
RAW_PREVIEW | Tries to load the JPEG preview image, embedded in Exif Metadata or load the image as RGB 24-bit if no preview image is available.
RAW_DISPLAY | Loads the image as RGB 24-bit.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_MDMODEL Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_MDMODEL Enumeration
See Also Send Feedback
Metadata models supported by FreeImage.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_MDMODEL
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_MDMODEL
Visual C++
public enum class FREE_IMAGE_MDMODEL

Members

Member name | Description
FIMD_NODATA | No data
FIMD_COMMENTS | single comment or keywords
FIMD_EXIF_MAIN | Exif-TIFF metadata
FIMD_EXIF_EXIF | Exif-specific metadata
FIMD_EXIF_GPS | Exif GPS metadata
FIMD_EXIF_MAKERNOTE | Exif maker note metadata
FIMD_EXIF_INTEROP | Exif interoperability metadata
FIMD_IPTC | IPTC/NAA metadata
FIMD_XMP | Abobe XMP metadata
FIMD_GEOTIFF | GeoTIFF metadata
FIMD_ANIMATION | Animation metadata
FIMD_CUSTOM | Used to attach other metadata types to a dib

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_MDTYPE Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_MDTYPE Enumeration
See Also Send Feedback
Tag data type information (based on TIFF specifications) Note: RATIONALs are the ratio of two 32-bit integer values.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_MDTYPE
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_MDTYPE
Visual C++
public enum class FREE_IMAGE_MDTYPE

Members

Member name | Description
FIDT_NOTYPE | placeholder
FIDT_BYTE | 8-bit unsigned integer
FIDT_ASCII | 8-bit bytes w/ last byte null
FIDT_SHORT | 16-bit unsigned integer
FIDT_LONG | 32-bit unsigned integer
FIDT_RATIONAL | 64-bit unsigned fraction
FIDT_SBYTE | 8-bit signed integer
FIDT_UNDEFINED | 8-bit untyped data
FIDT_SSHORT | 16-bit signed integer
FIDT_SLONG | 32-bit signed integer
FIDT_SRATIONAL | 64-bit signed fraction
FIDT_FLOAT | 32-bit IEEE floating point
FIDT_DOUBLE | 64-bit IEEE floating point
FIDT_IFD | 32-bit unsigned integer (offset)
FIDT_PALETTE | 32-bit RGBQUAD

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_METADATA_COPY Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_METADATA_COPY Enumeration
See Also Send Feedback
Flags for copying data from a bitmap to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_METADATA_COPY
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_METADATA_COPY
Visual C++
public enum class FREE_IMAGE_METADATA_COPY

Members

Member name | Description
KEEP_EXISITNG | Exisiting metadata will remain unchanged.
CLEAR_EXISTING | Existing metadata will be cleared.
REPLACE_EXISTING | Existing metadata will be overwritten.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_QUANTIZE Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_QUANTIZE Enumeration
See Also Send Feedback
Color quantization algorithms. Constants used in FreeImage_ColorQuantize.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_QUANTIZE
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_QUANTIZE
Visual C++
public enum class FREE_IMAGE_QUANTIZE

Members

Member name | Description
FIQ_WUQUANT | Xiaolin Wu color quantization algorithm
FIQ_NNQUANT | NeuQuant neural-net quantization algorithm by Anthony Dekker

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_SAVE_FLAGS Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_SAVE_FLAGS Enumeration
See Also Send Feedback
Flags used in save functions.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[FlagsAttribute]
public enum FREE_IMAGE_SAVE_FLAGS
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration FREE_IMAGE_SAVE_FLAGS
Visual C++
[FlagsAttribute]
public enum class FREE_IMAGE_SAVE_FLAGS

Members

Member name | Description
DEFAULT | Default option for all types.
BMP_SAVE_RLE | Save with run length encoding.
EXR_FLOAT | Save data as float instead of as half (not recommended).
EXR_NONE | Save with no compression.
EXR_ZIP | Save with zlib compression, in blocks of 16 scan lines.
EXR_PIZ | Save with piz-based wavelet compression.
EXR_PXR24 | Save with lossy 24-bit float compression.
EXR_B44 | Save with lossy 44% float compression - goes to 22% when combined with EXR_LC.
EXR_LC | Save images with one luminance and two chroma channels, rather than as RGB (lossy compression).
JPEG_QUALITYSUPERB | Save with superb quality (100:1).
JPEG_QUALITYGOOD | Save with good quality (75:1).
JPEG_QUALITYNORMAL | Save with normal quality (50:1).
JPEG_QUALITYAVERAGE | Save with average quality (25:1).
JPEG_QUALITYBAD | Save with bad quality (10:1).
JPEG_PROGRESSIVE | Save as a progressive-JPEG (use | to combine with other save flags).
JPEG_SUBSAMPLING_411 | Save with high 4x1 chroma subsampling (4:1:1).
JPEG_SUBSAMPLING_420 | Save with medium 2x2 medium chroma (4:2:0).
JPEG_SUBSAMPLING_422 | Save with low 2x1 chroma subsampling (4:2:2).
JPEG_SUBSAMPLING_444 | Save with no chroma subsampling (4:4:4).
PNG_Z_BEST_SPEED | Save using ZLib level 1 compression flag (default value is PNG_Z_DEFAULT_COMPRESSION).
PNG_Z_DEFAULT_COMPRESSION | Save using ZLib level 6 compression flag (default recommended value).
PNG_Z_BEST_COMPRESSION | save using ZLib level 9 compression flag (default value is PNG_Z_DEFAULT_COMPRESSION).
PNG_Z_NO_COMPRESSION | Save without ZLib compression.
PNG_INTERLACED | Save using Adam7 interlacing (use | to combine with other save flags).
PNM_SAVE_ASCII | If set the writer saves in ASCII format (i.e. P1, P2 or P3).
TIFF_CMYK | Stores tags for separated CMYK (use | to combine with compression flags).
TIFF_PACKBITS | Save using PACKBITS compression.
TIFF_DEFLATE | Save using DEFLATE compression (a.k.a. ZLIB compression).
TIFF_ADOBE_DEFLATE | Save using ADOBE DEFLATE compression.
TIFF_NONE | Save without any compression.
TIFF_CCITTFAX3 | Save using CCITT Group 3 fax encoding.
TIFF_CCITTFAX4 | Save using CCITT Group 4 fax encoding.
TIFF_LZW | Save using LZW compression.
TIFF_JPEG | Save using JPEG compression.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_TMO Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_TMO Enumeration
See Also Send Feedback
Tone mapping operators. Constants used in FreeImage_ToneMapping.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_TMO
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_TMO
Visual C++
public enum class FREE_IMAGE_TMO

Members

Member name | Description
FITMO_DRAGO03 | Adaptive logarithmic mapping (F. Drago, 2003)
FITMO_REINHARD05 | Dynamic range reduction inspired by photoreceptor physiology (E. Reinhard, 2005)
FITMO_FATTAL02 | Gradient domain high dynamic range compression (R. Fattal, 2002)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FREE_IMAGE_TYPE Enumeration

[image]

FreeImage .NET Documentation
FREE_IMAGE_TYPE Enumeration
See Also Send Feedback
Image types used in FreeImage.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum FREE_IMAGE_TYPE
Visual Basic (Declaration)
Public Enumeration FREE_IMAGE_TYPE
Visual C++
public enum class FREE_IMAGE_TYPE

Members

Member name | Description
FIT_UNKNOWN | unknown type
FIT_BITMAP | standard image : 1-, 4-, 8-, 16-, 24-, 32-bit
FIT_UINT16 | array of unsigned short : unsigned 16-bit
FIT_INT16 | array of short : signed 16-bit
FIT_UINT32 | array of unsigned long : unsigned 32-bit
FIT_INT32 | array of long : signed 32-bit
FIT_FLOAT | array of float : 32-bit IEEE floating point
FIT_DOUBLE | array of double : 64-bit IEEE floating point
FIT_COMPLEX | array of FICOMPLEX : 2 x 64-bit IEEE floating point
FIT_RGB16 | 48-bit RGB image : 3 x 16-bit
FIT_RGBA16 | 64-bit RGBA image : 4 x 16-bit
FIT_RGBF | 96-bit RGB float image : 3 x 32-bit IEEE floating point
FIT_RGBAF | 128-bit RGBA float image : 4 x 32-bit IEEE floating point

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


FreeImage Class

[image]

FreeImage .NET Documentation
FreeImage Class
Members See Also Send Feedback
Static class importing functions from the FreeImage library and providing additional functions.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static class FreeImage
Visual Basic (Declaration)
Public NotInheritable Class FreeImage
Visual C++
public ref class FreeImage abstract sealed

Inheritance Hierarchy

System..::.Object
FreeImageAPI..::.FreeImage

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Members


FreeImage Members

[image] [image] [image]

FreeImage .NET Documentation
FreeImage Members
FreeImage Class Methods Fields Events See Also Send Feedback

The FreeImage type exposes the following members.

Methods

Name | Description
AcquireMemory | Provides a direct buffer access to a memory stream.
AdjustBrightness | Adjusts the brightness of a 8-, 24- or 32-bit image by a certain amount.
AdjustColors | Adjusts an image's brightness, contrast and gamma as well as it may optionally invert the image within a single operation.
AdjustContrast | Adjusts the contrast of a 8-, 24- or 32-bit image by a certain amount.
AdjustCurve | Perfoms an histogram transformation on a 8-, 24- or 32-bit image.
AdjustGamma | Performs gamma correction on a 8-, 24- or 32-bit image.
Allocate | Overloaded.
AllocateEx | Overloaded.
AllocateExT | Overloaded.
AllocateT | Overloaded.
AppendPage | Appends a new page to the end of the bitmap.
ApplyColorMapping | Applies color mapping for one or several colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.
ApplyPaletteIndexMapping | Applies palette index mapping for one or several indices on a 1-, 4- or 8-bit palletized image.
Clone | Makes an exact reproduction of an existing bitmap, including metadata and attached profile if any.
CloneMetadata | Copies the metadata of FreeImage bitmap to another.
CloneMetadataEx | Copies metadata from one FreeImage bitmap to another.
CloneTag | Creates and returns a copy of a FITAG object.
CloseMemory | Close and free a memory stream.
CloseMultiBitmap | Closes a previously opened multi-page bitmap and, when the bitmap was not opened read-only, applies any changes made to it.
CloseMultiBitmapEx | Overloaded.
ColorQuantize | Quantizes a high-color 24-bit bitmap to an 8-bit palette color bitmap.
ColorQuantizeEx | Overloaded.
Compare | Compares two FreeImage bitmaps.
CompareMemory | Overloaded.
Composite | Overloaded.
ConvertColorDepth | Overloaded.
ConvertFromRawBits | Overloaded.
ConvertTo16Bits555 | Converts a bitmap to 16 bits, where each pixel has a color pattern of 5 bits red, 5 bits green and 5 bits blue. One bit in each pixel is unused.
ConvertTo16Bits565 | Converts a bitmap to 16 bits, where each pixel has a color pattern of 5 bits red, 6 bits green and 5 bits blue.
ConvertTo24Bits | Converts a bitmap to 24 bits. A clone of the input bitmap is returned for 24-bit bitmaps.
ConvertTo32Bits | Converts a bitmap to 32 bits. A clone of the input bitmap is returned for 32-bit bitmaps.
ConvertTo4Bits | Converts a bitmap to 4 bits. If the bitmap was a high-color bitmap (16, 24 or 32-bit) or if it was a monochrome or greyscale bitmap (1 or 8-bit), the end result will be a greyscale bitmap, otherwise (1-bit palletised bitmaps) it will be a palletised bitmap.
ConvertTo8Bits | Converts a bitmap to 8 bits. If the bitmap was a high-color bitmap (16, 24 or 32-bit) or if it was a monochrome or greyscale bitmap (1 or 4-bit), the end result will be a greyscale bitmap, otherwise (1 or 4-bit palletised bitmaps) it will be a palletised bitmap.
ConvertToGreyscale | Converts a bitmap to a 8-bit greyscale image with a linear ramp.
ConvertToRawBits | Overloaded.
ConvertToRGBF | Converts a 24- or 32-bit RGB(A) standard image or a 48-bit RGB image to a FIT_RGBF type image.
ConvertToStandardType | Converts a non standard image whose color type is FIC_MINISBLACK to a standard 8-bit greyscale image.
ConvertToType | Converts an image of any type to type dst_type.
Copy | Copy a sub part of the current dib image.
CopyMemory | Overloaded.
CreateFromBitmap | Converts an .NET Bitmap into a FreeImage bitmap.
CreateFromHbitmap | Creates a FreeImage DIB from a Device Context/Compatible Bitmap.
CreateICCProfile | Creates a new FIICCPROFILE block from ICC profile data previously read from a file or built by a color management system. The profile data is attached to the bitmap.
CreateICCProfileEx | Overloaded.
CreateTag | Allocates a new FITAG object. This object must be destroyed with a call to DeleteTag(FITAG) when no longer in use.
DeletePage | Deletes the page on the given position.
DeleteTag | Delete a previously allocated FITAG object.
DestroyICCProfile | This function destroys an FIICCPROFILE previously created by CreateICCProfile(FIBITMAP, array<Byte>[]()[], Int32). After this call the bitmap will contain no profile information. This function should be called to ensure that a stored bitmap will not contain any profile information.
Dither | Converts a bitmap to 1-bit monochrome bitmap using a dithering algorithm. For 1-bit input bitmaps, the function clones the input bitmap and builds a monochrome palette.
EnlargeCanvas<(Of <(T>)>) | Enlarges or shrinks the FreeImage bitmap selectively per side and fills newly added areas with the specified background color. See remarks for further details.
FIFSupportsExportBPP | Checks if a plugin can save bitmaps in the desired bit depth.
FIFSupportsExportType | Checks if a plugin can save a bitmap in the desired data type.
FIFSupportsICCProfiles | Checks if a plugin can load or save an ICC profile.
FIFSupportsReading | Checks if a plugin can load bitmaps.
FIFSupportsWriting | Checks if a plugin can save bitmaps.
FillBackground<(Of <(T>)>) | Sets all pixels of the specified image to the color provided through the color parameter. See remarks for further details.
FindCloseMetadata | Closes the specified metadata search handle and releases associated resources.
FindFirstMetadata | Overloaded.
FindNextMetadata | Overloaded.
FlipHorizontal | Flip the input dib horizontally along the vertical axis.
FlipVertical | Flip the input dib vertically along the horizontal axis.
FreeHbitmap | Frees a bitmap handle.
GetAdjustColorsLookupTable | Creates a lookup table to be used with AdjustCurve(FIBITMAP, array<Byte>[]()[], FREE_IMAGE_COLOR_CHANNEL) which may adjusts brightness and contrast, correct gamma and invert the image with a single call to AdjustCurve(FIBITMAP, array<Byte>[]()[], FREE_IMAGE_COLOR_CHANNEL).
GetBackgroundColor | Returns the file background color of an image. For 8-bit images, the color index in the palette is returned in the rgbReserved member of the bkcolor parameter.
GetBitmap | Converts a FreeImage bitmap to a .NET Bitmap.
GetBitmapForDevice | Returns an HBITMAP created by the CreateDIBitmap() function which in turn has always the same color depth as the reference DC, which may be provided through hdc. The desktop DC will be used, if IntPtr.Zero DC is specified. Call FreeHbitmap(IntPtr) to free the handle.
GetBits | Returns a pointer to the data-bits of the bitmap.
GetBlueMask | Returns a bit pattern describing the blue color component of a pixel in a FreeImage bitmap.
GetBPP | Returns the size of one pixel in the bitmap in bits.
GetChannel | Retrieves the red, green, blue or alpha channel of a 24- or 32-bit image.
GetColorsUsed | Returns the number of colors used in a bitmap.
GetColorType | Investigates the color type of the bitmap by reading the bitmap's pixel bits and analysing them.
GetComplexChannel | Retrieves the real part, imaginary part, magnitude or phase of a complex image.
GetCopyrightMessage | Returns a string containing a standard copyright message.
GetDIBSize | Returns the size of the DIB-element of a FIBITMAP in memory.
GetDotsPerMeterX | Returns the horizontal resolution, in pixels-per-meter, of the target device for the bitmap.
GetDotsPerMeterY | Returns the vertical resolution, in pixels-per-meter, of the target device for the bitmap.
GetFIFCount | Retrieves the number of FREE_IMAGE_FORMAT identifiers being currently registered.
GetFIFDescription | Returns a descriptive string that describes the bitmap formats the given plugin can read and/or write.
GetFIFExtensionList | Returns a comma-delimited file extension list describing the bitmap formats the given plugin can read and/or write.
GetFIFFromFilename | This function takes a filename or a file-extension and returns the plugin that can read/write files with that extension in the form of a FREE_IMAGE_FORMAT identifier.
GetFIFFromFormat | Returns a FREE_IMAGE_FORMAT identifier from the format string that was used to register the FIF.
GetFIFFromMime | Returns a FREE_IMAGE_FORMAT identifier from a MIME content type string (MIME stands for Multipurpose Internet Mail Extension).
GetFIFMimeType | Given a FREE_IMAGE_FORMAT identifier, returns a MIME content type string (MIME stands for Multipurpose Internet Mail Extension).
GetFIFRegExpr | Returns a regular expression string that can be used by a regular expression engine to identify the bitmap. FreeImageQt makes use of this function.
GetFileType | Orders FreeImage to analyze the bitmap signature.
GetFileTypeFromHandle | Uses the FreeImageIO structure as described in the topic bitmap management functions to identify a bitmap type.
GetFileTypeFromMemory | Uses a memory handle to identify a bitmap type.
GetFileTypeFromStream | Orders FreeImage to analyze the bitmap signature. In case the stream is not seekable, the stream will have been used and must be recreated for loading.
GetFormat | Returns the FREE_IMAGE_FORMAT for the specified ImageFormat.
GetFormatFromFIF | Returns the string that was used to register a plugin from the system assigned FREE_IMAGE_FORMAT.
GetFormatParameters | Overloaded.
GetGreenMask | Returns a bit pattern describing the green color component of a pixel in a FreeImage bitmap.
GetHbitmap | Retrieves an hBitmap for a FreeImage bitmap. Call FreeHbitmap(IntPtr) to free the handle.
GetHeight | Returns the height of the bitmap in pixel units.
GetHistogram | Computes the image histogram.
GetICCProfile | Retrieves a pointer to the FIICCPROFILE data of the bitmap. This function can also be called safely, when the original format does not support profiles.
GetICCProfileEx | Retrieves the FIICCPROFILE data of the bitmap. This function can also be called safely, when the original format does not support profiles.
GetImageComment | Returns the comment of a JPEG, PNG or GIF image.
GetImageType | Retrieves the type of the bitmap.
GetInfo | Alias for FreeImage_GetInfoHeader that returns a pointer to a BITMAPINFO rather than to a BITMAPINFOHEADER.
GetInfoEx | Returns the BITMAPINFO structure of a FreeImage bitmap. The structure is a copy, so changes will have no effect on the bitmap itself.
GetInfoHeader | Returns a pointer to the BITMAPINFOHEADER of the DIB-element in a FIBITMAP.
GetInfoHeaderEx | Returns the BITMAPINFOHEADER structure of a FreeImage bitmap. The structure is a copy, so changes will have no effect on the bitmap itself.
GetLine | Returns the width of the bitmap in bytes.
GetLockedPageCount | Retrieves the number of pages that are locked in a multi-paged bitmap.
GetLockedPageNumbers | Returns an array of page-numbers that are currently locked in memory. When the pages parameter is null, the size of the array is returned in the count variable.
GetLockedPages | Retrieves a list locked pages of a multi-paged bitmap.
GetMetadata | Overloaded.
GetMetadataCount | Returns the number of tags contained in the model metadata model attached to the input dib.
GetNativeVersion | Returns the version of the native FreeImage library.
GetPageCount | Returns the number of pages currently available in the multi-paged bitmap.
GetPalette | Returns a pointer to the bitmap's palette.
GetPaletteEx | Returns a structure that represents the palette of a FreeImage bitmap.
GetPitch | Returns the width of the bitmap in bytes, rounded to the next 32-bit boundary, also known as pitch or stride or scan width.
GetPixelColor | Get the pixel color of a 16-, 24- or 32-bit image at position (x, y), including range check (slow access).
GetPixelFormat | Returns the pixelformat of the bitmap.
GetPixelIndex | Get the pixel index of a palettized image at position (x, y), including range check (slow access).
GetPrimaryExtensionFromFIF | This function returns the primary (main or most commonly used?) extension of a certain image format (fif). This is done by returning the first of all possible extensions returned by GetFIFExtensionList(). That assumes, that the plugin returns the extensions in ordered form.
GetRedMask | Returns a bit pattern describing the red color component of a pixel in a FreeImage bitmap.
GetResolutionX | Retrieves a DIB's resolution in X-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.
GetResolutionY | Retrieves a DIB's resolution in Y-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.
GetScanLine | Returns a pointer to the start of the given scanline in the bitmap's data-bits.
GetTagCount | Returns the number of components in the tag (in tag type units).
GetTagDescription | Returns the tag description.
GetTagID | Returns the tag ID.
GetTagKey | Returns the tag field name (unique inside a metadata model).
GetTagLength | Returns the length of the tag value in bytes.
GetTagType | Returns the tag data type.
GetTagValue | Returns the tag value. It is up to the programmer to interpret the returned pointer correctly, according to the results of GetTagType and GetTagCount.
GetTransparencyCount | Returns the number of transparent colors in a palletised bitmap.
GetTransparencyTable | Returns a pointer to the bitmap's transparency table.
GetTransparencyTableEx | Returns the FreeImage bitmap's transparency table. The array is empty in case the bitmap has no transparency table.
GetTransparentIndex | Returns the palette entry used as transparent color for the image specified. Works for palletised images only and returns -1 for high color images or if the image has no color set to be transparent.
GetTypeParameters | Retrieves all parameters needed to create a new FreeImage bitmap from raw bits Image.
GetUniqueColors | This function returns the number of unique colors actually used by the specified 1-, 4-, 8-, 16-, 24- or 32-bit image. This might be different from what function FreeImage_GetColorsUsed() returns, which actually returns the palette size for palletised images. Works for FIT_BITMAP type images only.
GetVersion | Returns a string containing the current version of the library.
GetWidth | Returns the width of the bitmap in pixel units.
GetWrapperVersion | Returns the internal version of this FreeImage .NET wrapper.
HasBackgroundColor | Returns whether the bitmap has a file background color.
InsertPage | Inserts a new page before the given position in the bitmap.
Invert | Inverts each pixel data.
IsAvailable | Returns a value indicating if the FreeImage library is available or not. See remarks for further details.
IsExtensionValidForFIF | Overloaded.
IsFilenameValidForFIF | Overloaded.
IsGreyscaleImage | Returns whether the image is a greyscale image or not. The function scans all colors in the bitmaps palette for entries where red, green and blue are not all the same (not a grey color). Supports 1-, 4- and 8-bit bitmaps.
IsLittleEndian | Returns whether the platform is using Little Endian.
IsPluginEnabled | Retrieves the state of a plugin.
IsRGB555 | Verifies whether the FreeImage bitmap is 16bit 555.
IsRGB565 | Verifies whether the FreeImage bitmap is 16bit 565.
IsTransparent | Returns whether the transparency table is enabled.
JPEGCrop | Performs a lossless crop on a JPEG file.
JPEGTransform | Performs a lossless rotation or flipping on a JPEG file.
Load | Decodes a bitmap, allocates memory for it and returns it as a FIBITMAP.
LoadBitmap | Loads a .NET Bitmap from a file.
LoadEx | Overloaded.
LoadFromHandle | Loads a bitmap from an arbitrary source.
LoadFromMemory | Decodes a bitmap from a stream, allocates memory for it and returns it as a FIBITMAP.
LoadFromStream | Overloaded.
LoadMultiBitmapFromMemory | Open a multi-page bitmap from a memory stream.
LoadMultiBitmapFromStream | Loads a FreeImage multi-paged bitmap from a stream and returns the FreeImage memory stream used as temporary buffer. The bitmap can not be modified by calling AppendPage(FIMULTIBITMAP, FIBITMAP), InsertPage(FIMULTIBITMAP, Int32, FIBITMAP), MovePage(FIMULTIBITMAP, Int32, Int32) or DeletePage(FIMULTIBITMAP, Int32).
LockPage | Locks a page in memory for editing.
LookupSVGColor | Converts a SVG color name into a corresponding RGB value.
LookupX11Color | Converts a X11 color name into a corresponding RGB value.
MakeThumbnail | Creates a thumbnail from a greyscale or RGB(A) image, keeping aspect ratio.
MoveMemory | Overloaded.
MovePage | Moves the source page to the position of the target page.
MultigridPoissonSolver | Solves a Poisson equation, remap result pixels to [0..1] and returns the solution.
OpenMemory | Open a memory stream.
OpenMultiBitmap | Loads a FreeImage multi-paged bitmap. Load flags can be provided by the flags parameter.
OpenMultiBitmapEx | Overloaded.
OpenMultiBitmapFromHandle | Loads a FreeImage multi-pages bitmap from the specified handle using the specified functions. Load flags can be provided by the flags parameter.
OpenMultiBitmapFromStream | Overloaded.
OutputMessageProc | Calls the set error message function in FreeImage.
Paste | Alpha blend or combine a sub part image with the current dib image. The bit depth of the dst bitmap must be greater than or equal to the bit depth of the src.
PreMultiplyWithAlpha | Applies the alpha value of each pixel to its color components. The aplha value stays unchanged. Only works with 32-bits color depth.
ReadMemory | Reads data from a memory stream.
RegisterExternalPlugin | Registers a new plugin to be used in FreeImage. The plugin is residing in a DLL. The Init function must be called “Init” and must use the stdcall calling convention.
RegisterLocalPlugin | Registers a new plugin to be used in FreeImage.
Rescale | Performs resampling (or scaling, zooming) of a greyscale or RGB(A) image to the desired destination width and height.
Rotate | Overloaded.
Rotate4bit | Rotates a 4-bit color FreeImage bitmap. Allowed values for angle are 90, 180 and 270. In case angle is 0 or 360 a clone is returned. 0 is returned for other values or in case the rotation fails.
RotateClassic | This function rotates a 1-, 8-bit greyscale or a 24-, 32-bit color image by means of 3 shears. 1-bit images rotation is limited to integer multiple of 90°. null is returned for other values.
RotateEx | This function performs a rotation and / or translation of an 8-bit greyscale, 24- or 32-bit image, using a 3rd order (cubic) B-Spline.
Save | Saves a previosly loaded FIBITMAP to a file.
SaveBitmap | Overloaded.
SaveEx | Overloaded.
SaveToHandle | Saves a bitmap to an arbitrary source.
SaveToMemory | Saves a previosly loaded FIBITMAP to a stream.
SaveToStream | Overloaded.
SeekMemory | Moves the memory handle to a specified location.
SetBackgroundColor | Overloaded.
SetChannel | Insert a 8-bit dib into a 24- or 32-bit image. Both images must have to same width and height.
SetComplexChannel | Set the real or imaginary part of a complex image. Both images must have to same width and height.
SetDotsPerMeterX | Set the horizontal resolution, in pixels-per-meter, of the target device for the bitmap.
SetDotsPerMeterY | Set the vertical resolution, in pixels-per-meter, of the target device for the bitmap.
SetImageComment | Sets the comment of a JPEG, PNG or GIF image.
SetMetadata | Overloaded.
SetPixelColor | Set the pixel color of a 16-, 24- or 32-bit image at position (x, y), including range check (slow access).
SetPixelIndex | Set the pixel index of a palettized image at position (x, y), including range check (slow access).
SetPluginEnabled | Enables or disables a plugin.
SetResolutionX | Sets a DIB's resolution in X-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.
SetResolutionY | Sets a DIB's resolution in Y-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.
SetTagCount | Sets the number of data in the tag.
SetTagDescription | Sets the tag description.
SetTagID | Sets the tag ID.
SetTagKey | Sets the tag field name.
SetTagLength | Sets the length of the tag value in bytes.
SetTagType | Sets the tag data type.
SetTagValue | Sets the tag value.
SetTransparencyTable | Set the FreeImage bitmap's transparency table. Only affects palletised bitmaps.
SetTransparent | Tells FreeImage if it should make use of the transparency table or the alpha channel that may accompany a bitmap.
SetTransparentIndex | Sets the index of the palette entry to be used as transparent color for the image specified. Does nothing on high color images.
SwapColors | Swaps two specified colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.
SwapPaletteIndices | Swaps two specified palette indices on a 1-, 4- or 8-bit palletized image.
TagToString | Converts a FreeImage tag structure to a string that represents the interpreted tag value. The function is not thread safe.
TellMemory | Gets the current position of a memory handle.
Threshold | Converts a bitmap to 1-bit monochrome bitmap using a threshold T between [0..255]. The function first converts the bitmap to a 8-bit greyscale bitmap. Then, any brightness level that is less than T is set to zero, otherwise to 1. For 1-bit input bitmaps, the function clones the input bitmap and builds a monochrome palette.
TmoDrago03 | Converts a High Dynamic Range image to a 24-bit RGB image using a global operator based on logarithmic compression of luminance values, imitating the human response to light.
TmoFattal02 | Apply the Gradient Domain High Dynamic Range Compression to a RGBF image and convert to 24-bit RGB.
TmoReinhard05 | Converts a High Dynamic Range image to a 24-bit RGB image using a global operator inspired by photoreceptor physiology of the human visual system.
ToneMapping | Converts a High Dynamic Range image (48-bit RGB or 96-bit RGBF) to a 24-bit RGB image, suitable for display.
Unload | Deletes a previously loaded FIBITMAP from memory.
UnloadEx | Deletes a previously loaded FreeImage bitmap from memory and resets the handle to 0.
UnlockPage | Unlocks a previously locked page and gives it back to the multi-page engine.
WriteMemory | Writes data to a memory stream.
ZLibCompress | Compresses a source buffer into a target buffer, using the ZLib library.
ZLibCRC32 | Generates a CRC32 checksum.
ZLibGUnzip | Decompresses a source buffer into a target buffer, using the ZLib library.
ZLibGZip | Compresses a source buffer into a target buffer, using the ZLib library.
ZLibUncompress | Decompresses a source buffer into a target buffer, using the ZLib library.

Fields

Name | Description
BI_BITFIELDS | Specifies that the bitmap is not compressed and that the color table consists of three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. This is valid when used with 16- and 32-bpp bitmaps.
BI_JPEG | Windows 98/Me, Windows 2000/XP: Indicates that the image is a JPEG image.
BI_PNG | Windows 98/Me, Windows 2000/XP: Indicates that the image is a PNG image.
BI_RGB | An uncompressed format.
BI_RLE4 | An RLE format for bitmaps with 4 bpp. The compression format is a 2-byte format consisting of a count byte followed by two word-length color indexes.
BI_RLE8 | A run-length encoded (RLE) format for bitmaps with 8 bpp. The compression format is a 2-byte format consisting of a count byte followed by a byte containing a color index.
FI_RGBA_ALPHA | Number of bytes to shift left within a 4 byte block.
FI_RGBA_ALPHA_MASK | Mask indicating the position of the given color.
FI_RGBA_ALPHA_SHIFT | Number of bits to shift left within a 32 bit block.
FI_RGBA_BLUE | Number of bytes to shift left within a 4 byte block.
FI_RGBA_BLUE_MASK | Mask indicating the position of the given color.
FI_RGBA_BLUE_SHIFT | Number of bits to shift left within a 32 bit block.
FI_RGBA_GREEN | Number of bytes to shift left within a 4 byte block.
FI_RGBA_GREEN_MASK | Mask indicating the position of the given color.
FI_RGBA_GREEN_SHIFT | Number of bits to shift left within a 32 bit block.
FI_RGBA_RED | Number of bytes to shift left within a 4 byte block.
FI_RGBA_RED_MASK | Mask indicating the position of the given color.
FI_RGBA_RED_SHIFT | Number of bits to shift left within a 32 bit block.
FI_RGBA_RGB_MASK | Mask indicating the position of color components of a 32 bit color.
FI16_555_BLUE_MASK | Mask indicating the position of the given color.
FI16_555_BLUE_SHIFT | Number of bits to shift left within a 16 bit block.
FI16_555_GREEN_MASK | Mask indicating the position of the given color.
FI16_555_GREEN_SHIFT | Number of bits to shift left within a 16 bit block.
FI16_555_RED_MASK | Mask indicating the position of the given color.
FI16_555_RED_SHIFT | Number of bits to shift left within a 16 bit block.
FI16_565_BLUE_MASK | Mask indicating the position of the given color.
FI16_565_BLUE_SHIFT | Number of bits to shift left within a 16 bit block.
FI16_565_GREEN_MASK | Mask indicating the position of the given color.
FI16_565_GREEN_SHIFT | Number of bits to shift left within a 16 bit block.
FI16_565_RED_MASK | Mask indicating the position of the given color.
FI16_565_RED_SHIFT | Number of bits to shift left within a 16 bit block.
FREE_IMAGE_MDMODELS | Array containing all 'FREE_IMAGE_MDMODEL's.
FREEIMAGE_MAJOR_VERSION | Major version of the library.
FREEIMAGE_MINOR_VERSION | Minor version of the library.
FREEIMAGE_RELEASE_SERIAL | Release version of the library.

Events

Name | Description
Message | Internal errors in FreeImage generate a logstring that can be captured by this event.

See Also

FreeImage Class


FreeImage Fields

[image] [image] [image]

FreeImage .NET Documentation
FreeImage Fields
FreeImage Class See Also Send Feedback

The FreeImage type exposes the following members.

Fields

Name | Description
BI_BITFIELDS | Specifies that the bitmap is not compressed and that the color table consists of three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. This is valid when used with 16- and 32-bpp bitmaps.
BI_JPEG | Windows 98/Me, Windows 2000/XP: Indicates that the image is a JPEG image.
BI_PNG | Windows 98/Me, Windows 2000/XP: Indicates that the image is a PNG image.
BI_RGB | An uncompressed format.
BI_RLE4 | An RLE format for bitmaps with 4 bpp. The compression format is a 2-byte format consisting of a count byte followed by two word-length color indexes.
BI_RLE8 | A run-length encoded (RLE) format for bitmaps with 8 bpp. The compression format is a 2-byte format consisting of a count byte followed by a byte containing a color index.
FI_RGBA_ALPHA | Number of bytes to shift left within a 4 byte block.
FI_RGBA_ALPHA_MASK | Mask indicating the position of the given color.
FI_RGBA_ALPHA_SHIFT | Number of bits to shift left within a 32 bit block.
FI_RGBA_BLUE | Number of bytes to shift left within a 4 byte block.
FI_RGBA_BLUE_MASK | Mask indicating the position of the given color.
FI_RGBA_BLUE_SHIFT | Number of bits to shift left within a 32 bit block.
FI_RGBA_GREEN | Number of bytes to shift left within a 4 byte block.
FI_RGBA_GREEN_MASK | Mask indicating the position of the given color.
FI_RGBA_GREEN_SHIFT | Number of bits to shift left within a 32 bit block.
FI_RGBA_RED | Number of bytes to shift left within a 4 byte block.
FI_RGBA_RED_MASK | Mask indicating the position of the given color.
FI_RGBA_RED_SHIFT | Number of bits to shift left within a 32 bit block.
FI_RGBA_RGB_MASK | Mask indicating the position of color components of a 32 bit color.
FI16_555_BLUE_MASK | Mask indicating the position of the given color.
FI16_555_BLUE_SHIFT | Number of bits to shift left within a 16 bit block.
FI16_555_GREEN_MASK | Mask indicating the position of the given color.
FI16_555_GREEN_SHIFT | Number of bits to shift left within a 16 bit block.
FI16_555_RED_MASK | Mask indicating the position of the given color.
FI16_555_RED_SHIFT | Number of bits to shift left within a 16 bit block.
FI16_565_BLUE_MASK | Mask indicating the position of the given color.
FI16_565_BLUE_SHIFT | Number of bits to shift left within a 16 bit block.
FI16_565_GREEN_MASK | Mask indicating the position of the given color.
FI16_565_GREEN_SHIFT | Number of bits to shift left within a 16 bit block.
FI16_565_RED_MASK | Mask indicating the position of the given color.
FI16_565_RED_SHIFT | Number of bits to shift left within a 16 bit block.
FREE_IMAGE_MDMODELS | Array containing all 'FREE_IMAGE_MDMODEL's.
FREEIMAGE_MAJOR_VERSION | Major version of the library.
FREEIMAGE_MINOR_VERSION | Minor version of the library.
FREEIMAGE_RELEASE_SERIAL | Release version of the library.

See Also

FreeImage Class


BI_BITFIELDS Field

[image]

FreeImage .NET Documentation
FreeImage..::.BI_BITFIELDS Field
FreeImage Class See Also Send Feedback
Specifies that the bitmap is not compressed and that the color table consists of three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. This is valid when used with 16- and 32-bpp bitmaps.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int BI_BITFIELDS
Visual Basic (Declaration)
Public Const BI_BITFIELDS As Integer
Visual C++
public:
literal int BI_BITFIELDS

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


BI_JPEG Field

[image]

FreeImage .NET Documentation
FreeImage..::.BI_JPEG Field
FreeImage Class See Also Send Feedback
Windows 98/Me, Windows 2000/XP: Indicates that the image is a JPEG image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int BI_JPEG
Visual Basic (Declaration)
Public Const BI_JPEG As Integer
Visual C++
public:
literal int BI_JPEG

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


BI_PNG Field

[image]

FreeImage .NET Documentation
FreeImage..::.BI_PNG Field
FreeImage Class See Also Send Feedback
Windows 98/Me, Windows 2000/XP: Indicates that the image is a PNG image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int BI_PNG
Visual Basic (Declaration)
Public Const BI_PNG As Integer
Visual C++
public:
literal int BI_PNG

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


BI_RGB Field

[image]

FreeImage .NET Documentation
FreeImage..::.BI_RGB Field
FreeImage Class See Also Send Feedback
An uncompressed format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int BI_RGB
Visual Basic (Declaration)
Public Const BI_RGB As Integer
Visual C++
public:
literal int BI_RGB

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


BI_RLE4 Field

[image]

FreeImage .NET Documentation
FreeImage..::.BI_RLE4 Field
FreeImage Class See Also Send Feedback
An RLE format for bitmaps with 4 bpp. The compression format is a 2-byte format consisting of a count byte followed by two word-length color indexes.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int BI_RLE4
Visual Basic (Declaration)
Public Const BI_RLE4 As Integer
Visual C++
public:
literal int BI_RLE4

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


BI_RLE8 Field

[image]

FreeImage .NET Documentation
FreeImage..::.BI_RLE8 Field
FreeImage Class See Also Send Feedback
A run-length encoded (RLE) format for bitmaps with 8 bpp. The compression format is a 2-byte format consisting of a count byte followed by a byte containing a color index.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int BI_RLE8
Visual Basic (Declaration)
Public Const BI_RLE8 As Integer
Visual C++
public:
literal int BI_RLE8

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_ALPHA Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_ALPHA Field
FreeImage Class See Also Send Feedback
Number of bytes to shift left within a 4 byte block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI_RGBA_ALPHA
Visual Basic (Declaration)
Public Const FI_RGBA_ALPHA As Integer
Visual C++
public:
literal int FI_RGBA_ALPHA

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_ALPHA_MASK Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_ALPHA_MASK Field
FreeImage Class See Also Send Feedback
Mask indicating the position of the given color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const uint FI_RGBA_ALPHA_MASK
Visual Basic (Declaration)
Public Const FI_RGBA_ALPHA_MASK As UInteger
Visual C++
public:
literal unsigned int FI_RGBA_ALPHA_MASK

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_ALPHA_SHIFT Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_ALPHA_SHIFT Field
FreeImage Class See Also Send Feedback
Number of bits to shift left within a 32 bit block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI_RGBA_ALPHA_SHIFT
Visual Basic (Declaration)
Public Const FI_RGBA_ALPHA_SHIFT As Integer
Visual C++
public:
literal int FI_RGBA_ALPHA_SHIFT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_BLUE Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_BLUE Field
FreeImage Class See Also Send Feedback
Number of bytes to shift left within a 4 byte block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI_RGBA_BLUE
Visual Basic (Declaration)
Public Const FI_RGBA_BLUE As Integer
Visual C++
public:
literal int FI_RGBA_BLUE

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_BLUE_MASK Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_BLUE_MASK Field
FreeImage Class See Also Send Feedback
Mask indicating the position of the given color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const uint FI_RGBA_BLUE_MASK
Visual Basic (Declaration)
Public Const FI_RGBA_BLUE_MASK As UInteger
Visual C++
public:
literal unsigned int FI_RGBA_BLUE_MASK

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_BLUE_SHIFT Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_BLUE_SHIFT Field
FreeImage Class See Also Send Feedback
Number of bits to shift left within a 32 bit block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI_RGBA_BLUE_SHIFT
Visual Basic (Declaration)
Public Const FI_RGBA_BLUE_SHIFT As Integer
Visual C++
public:
literal int FI_RGBA_BLUE_SHIFT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_GREEN Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_GREEN Field
FreeImage Class See Also Send Feedback
Number of bytes to shift left within a 4 byte block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI_RGBA_GREEN
Visual Basic (Declaration)
Public Const FI_RGBA_GREEN As Integer
Visual C++
public:
literal int FI_RGBA_GREEN

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_GREEN_MASK Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_GREEN_MASK Field
FreeImage Class See Also Send Feedback
Mask indicating the position of the given color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const uint FI_RGBA_GREEN_MASK
Visual Basic (Declaration)
Public Const FI_RGBA_GREEN_MASK As UInteger
Visual C++
public:
literal unsigned int FI_RGBA_GREEN_MASK

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_GREEN_SHIFT Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_GREEN_SHIFT Field
FreeImage Class See Also Send Feedback
Number of bits to shift left within a 32 bit block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI_RGBA_GREEN_SHIFT
Visual Basic (Declaration)
Public Const FI_RGBA_GREEN_SHIFT As Integer
Visual C++
public:
literal int FI_RGBA_GREEN_SHIFT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_RED Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_RED Field
FreeImage Class See Also Send Feedback
Number of bytes to shift left within a 4 byte block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI_RGBA_RED
Visual Basic (Declaration)
Public Const FI_RGBA_RED As Integer
Visual C++
public:
literal int FI_RGBA_RED

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_RED_MASK Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_RED_MASK Field
FreeImage Class See Also Send Feedback
Mask indicating the position of the given color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const uint FI_RGBA_RED_MASK
Visual Basic (Declaration)
Public Const FI_RGBA_RED_MASK As UInteger
Visual C++
public:
literal unsigned int FI_RGBA_RED_MASK

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_RED_SHIFT Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_RED_SHIFT Field
FreeImage Class See Also Send Feedback
Number of bits to shift left within a 32 bit block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI_RGBA_RED_SHIFT
Visual Basic (Declaration)
Public Const FI_RGBA_RED_SHIFT As Integer
Visual C++
public:
literal int FI_RGBA_RED_SHIFT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI_RGBA_RGB_MASK Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI_RGBA_RGB_MASK Field
FreeImage Class See Also Send Feedback
Mask indicating the position of color components of a 32 bit color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const uint FI_RGBA_RGB_MASK
Visual Basic (Declaration)
Public Const FI_RGBA_RGB_MASK As UInteger
Visual C++
public:
literal unsigned int FI_RGBA_RGB_MASK

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_555_BLUE_MASK Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_555_BLUE_MASK Field
FreeImage Class See Also Send Feedback
Mask indicating the position of the given color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_555_BLUE_MASK
Visual Basic (Declaration)
Public Const FI16_555_BLUE_MASK As Integer
Visual C++
public:
literal int FI16_555_BLUE_MASK

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_555_BLUE_SHIFT Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_555_BLUE_SHIFT Field
FreeImage Class See Also Send Feedback
Number of bits to shift left within a 16 bit block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_555_BLUE_SHIFT
Visual Basic (Declaration)
Public Const FI16_555_BLUE_SHIFT As Integer
Visual C++
public:
literal int FI16_555_BLUE_SHIFT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_555_GREEN_MASK Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_555_GREEN_MASK Field
FreeImage Class See Also Send Feedback
Mask indicating the position of the given color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_555_GREEN_MASK
Visual Basic (Declaration)
Public Const FI16_555_GREEN_MASK As Integer
Visual C++
public:
literal int FI16_555_GREEN_MASK

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_555_GREEN_SHIFT Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_555_GREEN_SHIFT Field
FreeImage Class See Also Send Feedback
Number of bits to shift left within a 16 bit block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_555_GREEN_SHIFT
Visual Basic (Declaration)
Public Const FI16_555_GREEN_SHIFT As Integer
Visual C++
public:
literal int FI16_555_GREEN_SHIFT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_555_RED_MASK Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_555_RED_MASK Field
FreeImage Class See Also Send Feedback
Mask indicating the position of the given color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_555_RED_MASK
Visual Basic (Declaration)
Public Const FI16_555_RED_MASK As Integer
Visual C++
public:
literal int FI16_555_RED_MASK

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_555_RED_SHIFT Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_555_RED_SHIFT Field
FreeImage Class See Also Send Feedback
Number of bits to shift left within a 16 bit block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_555_RED_SHIFT
Visual Basic (Declaration)
Public Const FI16_555_RED_SHIFT As Integer
Visual C++
public:
literal int FI16_555_RED_SHIFT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_565_BLUE_MASK Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_565_BLUE_MASK Field
FreeImage Class See Also Send Feedback
Mask indicating the position of the given color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_565_BLUE_MASK
Visual Basic (Declaration)
Public Const FI16_565_BLUE_MASK As Integer
Visual C++
public:
literal int FI16_565_BLUE_MASK

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_565_BLUE_SHIFT Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_565_BLUE_SHIFT Field
FreeImage Class See Also Send Feedback
Number of bits to shift left within a 16 bit block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_565_BLUE_SHIFT
Visual Basic (Declaration)
Public Const FI16_565_BLUE_SHIFT As Integer
Visual C++
public:
literal int FI16_565_BLUE_SHIFT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_565_GREEN_MASK Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_565_GREEN_MASK Field
FreeImage Class See Also Send Feedback
Mask indicating the position of the given color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_565_GREEN_MASK
Visual Basic (Declaration)
Public Const FI16_565_GREEN_MASK As Integer
Visual C++
public:
literal int FI16_565_GREEN_MASK

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_565_GREEN_SHIFT Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_565_GREEN_SHIFT Field
FreeImage Class See Also Send Feedback
Number of bits to shift left within a 16 bit block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_565_GREEN_SHIFT
Visual Basic (Declaration)
Public Const FI16_565_GREEN_SHIFT As Integer
Visual C++
public:
literal int FI16_565_GREEN_SHIFT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_565_RED_MASK Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_565_RED_MASK Field
FreeImage Class See Also Send Feedback
Mask indicating the position of the given color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_565_RED_MASK
Visual Basic (Declaration)
Public Const FI16_565_RED_MASK As Integer
Visual C++
public:
literal int FI16_565_RED_MASK

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FI16_565_RED_SHIFT Field

[image]

FreeImage .NET Documentation
FreeImage..::.FI16_565_RED_SHIFT Field
FreeImage Class See Also Send Feedback
Number of bits to shift left within a 16 bit block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FI16_565_RED_SHIFT
Visual Basic (Declaration)
Public Const FI16_565_RED_SHIFT As Integer
Visual C++
public:
literal int FI16_565_RED_SHIFT

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FREE_IMAGE_MDMODELS Field

[image]

FreeImage .NET Documentation
FreeImage..::.FREE_IMAGE_MDMODELS Field
FreeImage Class See Also Send Feedback
Array containing all 'FREE_IMAGE_MDMODEL's.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static readonly FREE_IMAGE_MDMODEL[] FREE_IMAGE_MDMODELS
Visual Basic (Declaration)
Public Shared ReadOnly FREE_IMAGE_MDMODELS As FREE_IMAGE_MDMODEL()
Visual C++
public:
static initonly array<FREE_IMAGE_MDMODEL>^ FREE_IMAGE_MDMODELS

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FREEIMAGE_MAJOR_VERSION Field

[image]

FreeImage .NET Documentation
FreeImage..::.FREEIMAGE_MAJOR_VERSION Field
FreeImage Class See Also Send Feedback
Major version of the library.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FREEIMAGE_MAJOR_VERSION
Visual Basic (Declaration)
Public Const FREEIMAGE_MAJOR_VERSION As Integer
Visual C++
public:
literal int FREEIMAGE_MAJOR_VERSION

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0

See Also

FreeImage Class


FREEIMAGE_MINOR_VERSION Field

[image]

FreeImage .NET Documentation
FreeImage..::.FREEIMAGE_MINOR_VERSION Field
FreeImage Class See Also Send Feedback
Minor version of the library.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FREEIMAGE_MINOR_VERSION
Visual Basic (Declaration)
Public Const FREEIMAGE_MINOR_VERSION As Integer
Visual C++
public:
literal int FREEIMAGE_MINOR_VERSION

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0

See Also

FreeImage Class


FREEIMAGE_RELEASE_SERIAL Field

[image]

FreeImage .NET Documentation
FreeImage..::.FREEIMAGE_RELEASE_SERIAL Field
FreeImage Class See Also Send Feedback
Release version of the library.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public const int FREEIMAGE_RELEASE_SERIAL
Visual Basic (Declaration)
Public Const FREEIMAGE_RELEASE_SERIAL As Integer
Visual C++
public:
literal int FREEIMAGE_RELEASE_SERIAL

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0

See Also

FreeImage Class


FreeImage Methods

[image] [image] [image]

FreeImage .NET Documentation
FreeImage Methods
FreeImage Class See Also Send Feedback

The FreeImage type exposes the following members.

Methods

Name | Description
AcquireMemory | Provides a direct buffer access to a memory stream.
AdjustBrightness | Adjusts the brightness of a 8-, 24- or 32-bit image by a certain amount.
AdjustColors | Adjusts an image's brightness, contrast and gamma as well as it may optionally invert the image within a single operation.
AdjustContrast | Adjusts the contrast of a 8-, 24- or 32-bit image by a certain amount.
AdjustCurve | Perfoms an histogram transformation on a 8-, 24- or 32-bit image.
AdjustGamma | Performs gamma correction on a 8-, 24- or 32-bit image.
Allocate | Overloaded.
AllocateEx | Overloaded.
AllocateExT | Overloaded.
AllocateT | Overloaded.
AppendPage | Appends a new page to the end of the bitmap.
ApplyColorMapping | Applies color mapping for one or several colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.
ApplyPaletteIndexMapping | Applies palette index mapping for one or several indices on a 1-, 4- or 8-bit palletized image.
Clone | Makes an exact reproduction of an existing bitmap, including metadata and attached profile if any.
CloneMetadata | Copies the metadata of FreeImage bitmap to another.
CloneMetadataEx | Copies metadata from one FreeImage bitmap to another.
CloneTag | Creates and returns a copy of a FITAG object.
CloseMemory | Close and free a memory stream.
CloseMultiBitmap | Closes a previously opened multi-page bitmap and, when the bitmap was not opened read-only, applies any changes made to it.
CloseMultiBitmapEx | Overloaded.
ColorQuantize | Quantizes a high-color 24-bit bitmap to an 8-bit palette color bitmap.
ColorQuantizeEx | Overloaded.
Compare | Compares two FreeImage bitmaps.
CompareMemory | Overloaded.
Composite | Overloaded.
ConvertColorDepth | Overloaded.
ConvertFromRawBits | Overloaded.
ConvertTo16Bits555 | Converts a bitmap to 16 bits, where each pixel has a color pattern of 5 bits red, 5 bits green and 5 bits blue. One bit in each pixel is unused.
ConvertTo16Bits565 | Converts a bitmap to 16 bits, where each pixel has a color pattern of 5 bits red, 6 bits green and 5 bits blue.
ConvertTo24Bits | Converts a bitmap to 24 bits. A clone of the input bitmap is returned for 24-bit bitmaps.
ConvertTo32Bits | Converts a bitmap to 32 bits. A clone of the input bitmap is returned for 32-bit bitmaps.
ConvertTo4Bits | Converts a bitmap to 4 bits. If the bitmap was a high-color bitmap (16, 24 or 32-bit) or if it was a monochrome or greyscale bitmap (1 or 8-bit), the end result will be a greyscale bitmap, otherwise (1-bit palletised bitmaps) it will be a palletised bitmap.
ConvertTo8Bits | Converts a bitmap to 8 bits. If the bitmap was a high-color bitmap (16, 24 or 32-bit) or if it was a monochrome or greyscale bitmap (1 or 4-bit), the end result will be a greyscale bitmap, otherwise (1 or 4-bit palletised bitmaps) it will be a palletised bitmap.
ConvertToGreyscale | Converts a bitmap to a 8-bit greyscale image with a linear ramp.
ConvertToRawBits | Overloaded.
ConvertToRGBF | Converts a 24- or 32-bit RGB(A) standard image or a 48-bit RGB image to a FIT_RGBF type image.
ConvertToStandardType | Converts a non standard image whose color type is FIC_MINISBLACK to a standard 8-bit greyscale image.
ConvertToType | Converts an image of any type to type dst_type.
Copy | Copy a sub part of the current dib image.
CopyMemory | Overloaded.
CreateFromBitmap | Converts an .NET Bitmap into a FreeImage bitmap.
CreateFromHbitmap | Creates a FreeImage DIB from a Device Context/Compatible Bitmap.
CreateICCProfile | Creates a new FIICCPROFILE block from ICC profile data previously read from a file or built by a color management system. The profile data is attached to the bitmap.
CreateICCProfileEx | Overloaded.
CreateTag | Allocates a new FITAG object. This object must be destroyed with a call to DeleteTag(FITAG) when no longer in use.
DeletePage | Deletes the page on the given position.
DeleteTag | Delete a previously allocated FITAG object.
DestroyICCProfile | This function destroys an FIICCPROFILE previously created by CreateICCProfile(FIBITMAP, array<Byte>[]()[], Int32). After this call the bitmap will contain no profile information. This function should be called to ensure that a stored bitmap will not contain any profile information.
Dither | Converts a bitmap to 1-bit monochrome bitmap using a dithering algorithm. For 1-bit input bitmaps, the function clones the input bitmap and builds a monochrome palette.
EnlargeCanvas<(Of <(T>)>) | Enlarges or shrinks the FreeImage bitmap selectively per side and fills newly added areas with the specified background color. See remarks for further details.
FIFSupportsExportBPP | Checks if a plugin can save bitmaps in the desired bit depth.
FIFSupportsExportType | Checks if a plugin can save a bitmap in the desired data type.
FIFSupportsICCProfiles | Checks if a plugin can load or save an ICC profile.
FIFSupportsReading | Checks if a plugin can load bitmaps.
FIFSupportsWriting | Checks if a plugin can save bitmaps.
FillBackground<(Of <(T>)>) | Sets all pixels of the specified image to the color provided through the color parameter. See remarks for further details.
FindCloseMetadata | Closes the specified metadata search handle and releases associated resources.
FindFirstMetadata | Overloaded.
FindNextMetadata | Overloaded.
FlipHorizontal | Flip the input dib horizontally along the vertical axis.
FlipVertical | Flip the input dib vertically along the horizontal axis.
FreeHbitmap | Frees a bitmap handle.
GetAdjustColorsLookupTable | Creates a lookup table to be used with AdjustCurve(FIBITMAP, array<Byte>[]()[], FREE_IMAGE_COLOR_CHANNEL) which may adjusts brightness and contrast, correct gamma and invert the image with a single call to AdjustCurve(FIBITMAP, array<Byte>[]()[], FREE_IMAGE_COLOR_CHANNEL).
GetBackgroundColor | Returns the file background color of an image. For 8-bit images, the color index in the palette is returned in the rgbReserved member of the bkcolor parameter.
GetBitmap | Converts a FreeImage bitmap to a .NET Bitmap.
GetBitmapForDevice | Returns an HBITMAP created by the CreateDIBitmap() function which in turn has always the same color depth as the reference DC, which may be provided through hdc. The desktop DC will be used, if IntPtr.Zero DC is specified. Call FreeHbitmap(IntPtr) to free the handle.
GetBits | Returns a pointer to the data-bits of the bitmap.
GetBlueMask | Returns a bit pattern describing the blue color component of a pixel in a FreeImage bitmap.
GetBPP | Returns the size of one pixel in the bitmap in bits.
GetChannel | Retrieves the red, green, blue or alpha channel of a 24- or 32-bit image.
GetColorsUsed | Returns the number of colors used in a bitmap.
GetColorType | Investigates the color type of the bitmap by reading the bitmap's pixel bits and analysing them.
GetComplexChannel | Retrieves the real part, imaginary part, magnitude or phase of a complex image.
GetCopyrightMessage | Returns a string containing a standard copyright message.
GetDIBSize | Returns the size of the DIB-element of a FIBITMAP in memory.
GetDotsPerMeterX | Returns the horizontal resolution, in pixels-per-meter, of the target device for the bitmap.
GetDotsPerMeterY | Returns the vertical resolution, in pixels-per-meter, of the target device for the bitmap.
GetFIFCount | Retrieves the number of FREE_IMAGE_FORMAT identifiers being currently registered.
GetFIFDescription | Returns a descriptive string that describes the bitmap formats the given plugin can read and/or write.
GetFIFExtensionList | Returns a comma-delimited file extension list describing the bitmap formats the given plugin can read and/or write.
GetFIFFromFilename | This function takes a filename or a file-extension and returns the plugin that can read/write files with that extension in the form of a FREE_IMAGE_FORMAT identifier.
GetFIFFromFormat | Returns a FREE_IMAGE_FORMAT identifier from the format string that was used to register the FIF.
GetFIFFromMime | Returns a FREE_IMAGE_FORMAT identifier from a MIME content type string (MIME stands for Multipurpose Internet Mail Extension).
GetFIFMimeType | Given a FREE_IMAGE_FORMAT identifier, returns a MIME content type string (MIME stands for Multipurpose Internet Mail Extension).
GetFIFRegExpr | Returns a regular expression string that can be used by a regular expression engine to identify the bitmap. FreeImageQt makes use of this function.
GetFileType | Orders FreeImage to analyze the bitmap signature.
GetFileTypeFromHandle | Uses the FreeImageIO structure as described in the topic bitmap management functions to identify a bitmap type.
GetFileTypeFromMemory | Uses a memory handle to identify a bitmap type.
GetFileTypeFromStream | Orders FreeImage to analyze the bitmap signature. In case the stream is not seekable, the stream will have been used and must be recreated for loading.
GetFormat | Returns the FREE_IMAGE_FORMAT for the specified ImageFormat.
GetFormatFromFIF | Returns the string that was used to register a plugin from the system assigned FREE_IMAGE_FORMAT.
GetFormatParameters | Overloaded.
GetGreenMask | Returns a bit pattern describing the green color component of a pixel in a FreeImage bitmap.
GetHbitmap | Retrieves an hBitmap for a FreeImage bitmap. Call FreeHbitmap(IntPtr) to free the handle.
GetHeight | Returns the height of the bitmap in pixel units.
GetHistogram | Computes the image histogram.
GetICCProfile | Retrieves a pointer to the FIICCPROFILE data of the bitmap. This function can also be called safely, when the original format does not support profiles.
GetICCProfileEx | Retrieves the FIICCPROFILE data of the bitmap. This function can also be called safely, when the original format does not support profiles.
GetImageComment | Returns the comment of a JPEG, PNG or GIF image.
GetImageType | Retrieves the type of the bitmap.
GetInfo | Alias for FreeImage_GetInfoHeader that returns a pointer to a BITMAPINFO rather than to a BITMAPINFOHEADER.
GetInfoEx | Returns the BITMAPINFO structure of a FreeImage bitmap. The structure is a copy, so changes will have no effect on the bitmap itself.
GetInfoHeader | Returns a pointer to the BITMAPINFOHEADER of the DIB-element in a FIBITMAP.
GetInfoHeaderEx | Returns the BITMAPINFOHEADER structure of a FreeImage bitmap. The structure is a copy, so changes will have no effect on the bitmap itself.
GetLine | Returns the width of the bitmap in bytes.
GetLockedPageCount | Retrieves the number of pages that are locked in a multi-paged bitmap.
GetLockedPageNumbers | Returns an array of page-numbers that are currently locked in memory. When the pages parameter is null, the size of the array is returned in the count variable.
GetLockedPages | Retrieves a list locked pages of a multi-paged bitmap.
GetMetadata | Overloaded.
GetMetadataCount | Returns the number of tags contained in the model metadata model attached to the input dib.
GetNativeVersion | Returns the version of the native FreeImage library.
GetPageCount | Returns the number of pages currently available in the multi-paged bitmap.
GetPalette | Returns a pointer to the bitmap's palette.
GetPaletteEx | Returns a structure that represents the palette of a FreeImage bitmap.
GetPitch | Returns the width of the bitmap in bytes, rounded to the next 32-bit boundary, also known as pitch or stride or scan width.
GetPixelColor | Get the pixel color of a 16-, 24- or 32-bit image at position (x, y), including range check (slow access).
GetPixelFormat | Returns the pixelformat of the bitmap.
GetPixelIndex | Get the pixel index of a palettized image at position (x, y), including range check (slow access).
GetPrimaryExtensionFromFIF | This function returns the primary (main or most commonly used?) extension of a certain image format (fif). This is done by returning the first of all possible extensions returned by GetFIFExtensionList(). That assumes, that the plugin returns the extensions in ordered form.
GetRedMask | Returns a bit pattern describing the red color component of a pixel in a FreeImage bitmap.
GetResolutionX | Retrieves a DIB's resolution in X-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.
GetResolutionY | Retrieves a DIB's resolution in Y-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.
GetScanLine | Returns a pointer to the start of the given scanline in the bitmap's data-bits.
GetTagCount | Returns the number of components in the tag (in tag type units).
GetTagDescription | Returns the tag description.
GetTagID | Returns the tag ID.
GetTagKey | Returns the tag field name (unique inside a metadata model).
GetTagLength | Returns the length of the tag value in bytes.
GetTagType | Returns the tag data type.
GetTagValue | Returns the tag value. It is up to the programmer to interpret the returned pointer correctly, according to the results of GetTagType and GetTagCount.
GetTransparencyCount | Returns the number of transparent colors in a palletised bitmap.
GetTransparencyTable | Returns a pointer to the bitmap's transparency table.
GetTransparencyTableEx | Returns the FreeImage bitmap's transparency table. The array is empty in case the bitmap has no transparency table.
GetTransparentIndex | Returns the palette entry used as transparent color for the image specified. Works for palletised images only and returns -1 for high color images or if the image has no color set to be transparent.
GetTypeParameters | Retrieves all parameters needed to create a new FreeImage bitmap from raw bits Image.
GetUniqueColors | This function returns the number of unique colors actually used by the specified 1-, 4-, 8-, 16-, 24- or 32-bit image. This might be different from what function FreeImage_GetColorsUsed() returns, which actually returns the palette size for palletised images. Works for FIT_BITMAP type images only.
GetVersion | Returns a string containing the current version of the library.
GetWidth | Returns the width of the bitmap in pixel units.
GetWrapperVersion | Returns the internal version of this FreeImage .NET wrapper.
HasBackgroundColor | Returns whether the bitmap has a file background color.
InsertPage | Inserts a new page before the given position in the bitmap.
Invert | Inverts each pixel data.
IsAvailable | Returns a value indicating if the FreeImage library is available or not. See remarks for further details.
IsExtensionValidForFIF | Overloaded.
IsFilenameValidForFIF | Overloaded.
IsGreyscaleImage | Returns whether the image is a greyscale image or not. The function scans all colors in the bitmaps palette for entries where red, green and blue are not all the same (not a grey color). Supports 1-, 4- and 8-bit bitmaps.
IsLittleEndian | Returns whether the platform is using Little Endian.
IsPluginEnabled | Retrieves the state of a plugin.
IsRGB555 | Verifies whether the FreeImage bitmap is 16bit 555.
IsRGB565 | Verifies whether the FreeImage bitmap is 16bit 565.
IsTransparent | Returns whether the transparency table is enabled.
JPEGCrop | Performs a lossless crop on a JPEG file.
JPEGTransform | Performs a lossless rotation or flipping on a JPEG file.
Load | Decodes a bitmap, allocates memory for it and returns it as a FIBITMAP.
LoadBitmap | Loads a .NET Bitmap from a file.
LoadEx | Overloaded.
LoadFromHandle | Loads a bitmap from an arbitrary source.
LoadFromMemory | Decodes a bitmap from a stream, allocates memory for it and returns it as a FIBITMAP.
LoadFromStream | Overloaded.
LoadMultiBitmapFromMemory | Open a multi-page bitmap from a memory stream.
LoadMultiBitmapFromStream | Loads a FreeImage multi-paged bitmap from a stream and returns the FreeImage memory stream used as temporary buffer. The bitmap can not be modified by calling AppendPage(FIMULTIBITMAP, FIBITMAP), InsertPage(FIMULTIBITMAP, Int32, FIBITMAP), MovePage(FIMULTIBITMAP, Int32, Int32) or DeletePage(FIMULTIBITMAP, Int32).
LockPage | Locks a page in memory for editing.
LookupSVGColor | Converts a SVG color name into a corresponding RGB value.
LookupX11Color | Converts a X11 color name into a corresponding RGB value.
MakeThumbnail | Creates a thumbnail from a greyscale or RGB(A) image, keeping aspect ratio.
MoveMemory | Overloaded.
MovePage | Moves the source page to the position of the target page.
MultigridPoissonSolver | Solves a Poisson equation, remap result pixels to [0..1] and returns the solution.
OpenMemory | Open a memory stream.
OpenMultiBitmap | Loads a FreeImage multi-paged bitmap. Load flags can be provided by the flags parameter.
OpenMultiBitmapEx | Overloaded.
OpenMultiBitmapFromHandle | Loads a FreeImage multi-pages bitmap from the specified handle using the specified functions. Load flags can be provided by the flags parameter.
OpenMultiBitmapFromStream | Overloaded.
OutputMessageProc | Calls the set error message function in FreeImage.
Paste | Alpha blend or combine a sub part image with the current dib image. The bit depth of the dst bitmap must be greater than or equal to the bit depth of the src.
PreMultiplyWithAlpha | Applies the alpha value of each pixel to its color components. The aplha value stays unchanged. Only works with 32-bits color depth.
ReadMemory | Reads data from a memory stream.
RegisterExternalPlugin | Registers a new plugin to be used in FreeImage. The plugin is residing in a DLL. The Init function must be called “Init” and must use the stdcall calling convention.
RegisterLocalPlugin | Registers a new plugin to be used in FreeImage.
Rescale | Performs resampling (or scaling, zooming) of a greyscale or RGB(A) image to the desired destination width and height.
Rotate | Overloaded.
Rotate4bit | Rotates a 4-bit color FreeImage bitmap. Allowed values for angle are 90, 180 and 270. In case angle is 0 or 360 a clone is returned. 0 is returned for other values or in case the rotation fails.
RotateClassic | This function rotates a 1-, 8-bit greyscale or a 24-, 32-bit color image by means of 3 shears. 1-bit images rotation is limited to integer multiple of 90°. null is returned for other values.
RotateEx | This function performs a rotation and / or translation of an 8-bit greyscale, 24- or 32-bit image, using a 3rd order (cubic) B-Spline.
Save | Saves a previosly loaded FIBITMAP to a file.
SaveBitmap | Overloaded.
SaveEx | Overloaded.
SaveToHandle | Saves a bitmap to an arbitrary source.
SaveToMemory | Saves a previosly loaded FIBITMAP to a stream.
SaveToStream | Overloaded.
SeekMemory | Moves the memory handle to a specified location.
SetBackgroundColor | Overloaded.
SetChannel | Insert a 8-bit dib into a 24- or 32-bit image. Both images must have to same width and height.
SetComplexChannel | Set the real or imaginary part of a complex image. Both images must have to same width and height.
SetDotsPerMeterX | Set the horizontal resolution, in pixels-per-meter, of the target device for the bitmap.
SetDotsPerMeterY | Set the vertical resolution, in pixels-per-meter, of the target device for the bitmap.
SetImageComment | Sets the comment of a JPEG, PNG or GIF image.
SetMetadata | Overloaded.
SetPixelColor | Set the pixel color of a 16-, 24- or 32-bit image at position (x, y), including range check (slow access).
SetPixelIndex | Set the pixel index of a palettized image at position (x, y), including range check (slow access).
SetPluginEnabled | Enables or disables a plugin.
SetResolutionX | Sets a DIB's resolution in X-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.
SetResolutionY | Sets a DIB's resolution in Y-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.
SetTagCount | Sets the number of data in the tag.
SetTagDescription | Sets the tag description.
SetTagID | Sets the tag ID.
SetTagKey | Sets the tag field name.
SetTagLength | Sets the length of the tag value in bytes.
SetTagType | Sets the tag data type.
SetTagValue | Sets the tag value.
SetTransparencyTable | Set the FreeImage bitmap's transparency table. Only affects palletised bitmaps.
SetTransparent | Tells FreeImage if it should make use of the transparency table or the alpha channel that may accompany a bitmap.
SetTransparentIndex | Sets the index of the palette entry to be used as transparent color for the image specified. Does nothing on high color images.
SwapColors | Swaps two specified colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.
SwapPaletteIndices | Swaps two specified palette indices on a 1-, 4- or 8-bit palletized image.
TagToString | Converts a FreeImage tag structure to a string that represents the interpreted tag value. The function is not thread safe.
TellMemory | Gets the current position of a memory handle.
Threshold | Converts a bitmap to 1-bit monochrome bitmap using a threshold T between [0..255]. The function first converts the bitmap to a 8-bit greyscale bitmap. Then, any brightness level that is less than T is set to zero, otherwise to 1. For 1-bit input bitmaps, the function clones the input bitmap and builds a monochrome palette.
TmoDrago03 | Converts a High Dynamic Range image to a 24-bit RGB image using a global operator based on logarithmic compression of luminance values, imitating the human response to light.
TmoFattal02 | Apply the Gradient Domain High Dynamic Range Compression to a RGBF image and convert to 24-bit RGB.
TmoReinhard05 | Converts a High Dynamic Range image to a 24-bit RGB image using a global operator inspired by photoreceptor physiology of the human visual system.
ToneMapping | Converts a High Dynamic Range image (48-bit RGB or 96-bit RGBF) to a 24-bit RGB image, suitable for display.
Unload | Deletes a previously loaded FIBITMAP from memory.
UnloadEx | Deletes a previously loaded FreeImage bitmap from memory and resets the handle to 0.
UnlockPage | Unlocks a previously locked page and gives it back to the multi-page engine.
WriteMemory | Writes data to a memory stream.
ZLibCompress | Compresses a source buffer into a target buffer, using the ZLib library.
ZLibCRC32 | Generates a CRC32 checksum.
ZLibGUnzip | Decompresses a source buffer into a target buffer, using the ZLib library.
ZLibGZip | Compresses a source buffer into a target buffer, using the ZLib library.
ZLibUncompress | Decompresses a source buffer into a target buffer, using the ZLib library.

See Also

FreeImage Class


AcquireMemory Method

[image]

FreeImage .NET Documentation
FreeImage..::.AcquireMemory Method
FreeImage Class See Also Send Feedback
Provides a direct buffer access to a memory stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool AcquireMemory(
    FIMEMORY stream,
    ref IntPtr data,
    ref uint size_in_bytes
)
Visual Basic (Declaration)
Public Shared Function AcquireMemory ( _
    stream As FIMEMORY, _
    ByRef data As IntPtr, _
    ByRef size_in_bytes As UInteger _
) As Boolean
Visual C++
public:
static bool AcquireMemory(
    FIMEMORY stream,
    IntPtr% data,
    unsigned int% size_in_bytes
)

Parameters

stream
Type: FreeImageAPI..::.FIMEMORY
The target memory stream.
data
Type: System..::.IntPtr %
Pointer to the data in memory.
size_in_bytes
Type: System..::.UInt32 %
Size of the data in bytes.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


AdjustBrightness Method

[image]

FreeImage .NET Documentation
FreeImage..::.AdjustBrightness Method
FreeImage Class See Also Send Feedback
Adjusts the brightness of a 8-, 24- or 32-bit image by a certain amount.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool AdjustBrightness(
    FIBITMAP dib,
    double percentage
)
Visual Basic (Declaration)
Public Shared Function AdjustBrightness ( _
    dib As FIBITMAP, _
    percentage As Double _
) As Boolean
Visual C++
public:
static bool AdjustBrightness(
    FIBITMAP dib,
    double percentage
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
percentage
Type: System..::.Double
A value 0 means no change, less than 0 will make the image darker and greater than 0 will make the image brighter.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


AdjustColors Method

[image]

FreeImage .NET Documentation
FreeImage..::.AdjustColors Method
FreeImage Class See Also Send Feedback
Adjusts an image's brightness, contrast and gamma as well as it may optionally invert the image within a single operation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool AdjustColors(
    FIBITMAP dib,
    double brightness,
    double contrast,
    double gamma,
    bool invert
)
Visual Basic (Declaration)
Public Shared Function AdjustColors ( _
    dib As FIBITMAP, _
    brightness As Double, _
    contrast As Double, _
    gamma As Double, _
    invert As Boolean _
) As Boolean
Visual C++
public:
static bool AdjustColors(
    FIBITMAP dib,
    double brightness,
    double contrast,
    double gamma,
    bool invert
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
brightness
Type: System..::.Double
Percentage brightness value where -100 <= brightness <= 100.

A value of 0 means no change, less than 0 will make the image darker and greater than 0 will make the image brighter.

contrast
Type: System..::.Double
Percentage contrast value where -100 <= contrast <= 100.

A value of 0 means no change, less than 0 will decrease the contrast and greater than 0 will increase the contrast of the image.

gamma
Type: System..::.Double
Gamma value to be used for gamma correction.

A value of 1.0 leaves the image alone, less than one darkens it, and greater than one lightens it.

This parameter must not be zero or smaller than zero. If so, it will be ignored and no gamma correction will be performed on the image.
invert
Type: System..::.Boolean
If set to true, the image will be inverted.

Return Value

Returns true on success, false on failure.

Remarks

This function adjusts an image's brightness, contrast and gamma as well as it may optionally invert the image within a single operation. If more than one of these image display properties need to be adjusted, using this function should be preferred over calling each adjustment function separately. That's particularly true for huge images or if performance is an issue.

This function relies on GetAdjustColorsLookupTable(array<Byte>[]()[], Double, Double, Double, Boolean), which creates a single lookup table, that combines all adjustment operations requested.

Furthermore, the lookup table created by GetAdjustColorsLookupTable(array<Byte>[]()[], Double, Double, Double, Boolean) does not depend on the order, in which each single adjustment operation is performed. Due to rounding and byte casting issues, it actually matters in which order individual adjustment operations are performed. Both of the following snippets most likely produce different results:

CopyC#
// snippet 1: contrast, brightness
AdjustContrast(dib, 15.0);
AdjustBrightness(dib, 50.0);

CopyC#
// snippet 2: brightness, contrast
AdjustBrightness(dib, 50.0);
AdjustContrast(dib, 15.0);

Better and even faster would be snippet 3:

CopyC#
// snippet 3:
AdjustColors(dib, 50.0, 15.0, 1.0, false);

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


AdjustContrast Method

[image]

FreeImage .NET Documentation
FreeImage..::.AdjustContrast Method
FreeImage Class See Also Send Feedback
Adjusts the contrast of a 8-, 24- or 32-bit image by a certain amount.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool AdjustContrast(
    FIBITMAP dib,
    double percentage
)
Visual Basic (Declaration)
Public Shared Function AdjustContrast ( _
    dib As FIBITMAP, _
    percentage As Double _
) As Boolean
Visual C++
public:
static bool AdjustContrast(
    FIBITMAP dib,
    double percentage
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
percentage
Type: System..::.Double
A value 0 means no change, less than 0 will decrease the contrast and greater than 0 will increase the contrast of the image.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


AdjustCurve Method

[image]

FreeImage .NET Documentation
FreeImage..::.AdjustCurve Method
FreeImage Class See Also Send Feedback
Perfoms an histogram transformation on a 8-, 24- or 32-bit image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool AdjustCurve(
    FIBITMAP dib,
    byte[] LUT,
    FREE_IMAGE_COLOR_CHANNEL channel
)
Visual Basic (Declaration)
Public Shared Function AdjustCurve ( _
    dib As FIBITMAP, _
    LUT As Byte(), _
    channel As FREE_IMAGE_COLOR_CHANNEL _
) As Boolean
Visual C++
public:
static bool AdjustCurve(
    FIBITMAP dib,
    array<unsigned char>^ LUT,
    FREE_IMAGE_COLOR_CHANNEL channel
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
LUT
Type: array< System..::.Byte >[]()[]
channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
The color channel to be transformed.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


AdjustGamma Method

[image]

FreeImage .NET Documentation
FreeImage..::.AdjustGamma Method
FreeImage Class See Also Send Feedback
Performs gamma correction on a 8-, 24- or 32-bit image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool AdjustGamma(
    FIBITMAP dib,
    double gamma
)
Visual Basic (Declaration)
Public Shared Function AdjustGamma ( _
    dib As FIBITMAP, _
    gamma As Double _
) As Boolean
Visual C++
public:
static bool AdjustGamma(
    FIBITMAP dib,
    double gamma
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
gamma
Type: System..::.Double
The parameter represents the gamma value to use (gamma > 0). A value of 1.0 leaves the image alone, less than one darkens it, and greater than one lightens it.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Allocate Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.Allocate Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
Allocate(Int32, Int32, Int32) | Creates a new bitmap in memory.
Allocate(Int32, Int32, Int32, UInt32, UInt32, UInt32) | Creates a new bitmap in memory.

See Also

FreeImage Class
FreeImage Members


Allocate Method (Int32, Int32, Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.Allocate Method (Int32, Int32, Int32)
FreeImage Class See Also Send Feedback
Creates a new bitmap in memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Allocate(
    int width,
    int height,
    int bpp
)
Visual Basic (Declaration)
Public Shared Function Allocate ( _
    width As Integer, _
    height As Integer, _
    bpp As Integer _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Allocate(
    int width,
    int height,
    int bpp
)

Parameters

width
Type: System..::.Int32
Width of the new bitmap.
height
Type: System..::.Int32
Height of the new bitmap.
bpp
Type: System..::.Int32
Bit depth of the new Bitmap. Supported pixel depth: 1-, 4-, 8-, 16-, 24-, 32-bit per pixel for standard bitmap

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class
Allocate Overload


Allocate Method (Int32, Int32, Int32, UInt32, UInt32, UInt32)

[image]

FreeImage .NET Documentation
FreeImage..::.Allocate Method (Int32, Int32, Int32, UInt32, UInt32, UInt32)
FreeImage Class See Also Send Feedback
Creates a new bitmap in memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Allocate(
    int width,
    int height,
    int bpp,
    uint red_mask,
    uint green_mask,
    uint blue_mask
)
Visual Basic (Declaration)
Public Shared Function Allocate ( _
    width As Integer, _
    height As Integer, _
    bpp As Integer, _
    red_mask As UInteger, _
    green_mask As UInteger, _
    blue_mask As UInteger _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Allocate(
    int width,
    int height,
    int bpp,
    unsigned int red_mask,
    unsigned int green_mask,
    unsigned int blue_mask
)

Parameters

width
Type: System..::.Int32
Width of the new bitmap.
height
Type: System..::.Int32
Height of the new bitmap.
bpp
Type: System..::.Int32
Bit depth of the new Bitmap. Supported pixel depth: 1-, 4-, 8-, 16-, 24-, 32-bit per pixel for standard bitmap
red_mask
Type: System..::.UInt32
Red part of the color layout. eg: 0xFF0000
green_mask
Type: System..::.UInt32
Green part of the color layout. eg: 0x00FF00
blue_mask
Type: System..::.UInt32
Blue part of the color layout. eg: 0x0000FF

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
Allocate Overload


AllocateEx Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.AllocateEx Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
AllocateEx(Int32, Int32, Int32, Nullable<(Of <(RGBQUAD>)>), FREE_IMAGE_COLOR_OPTIONS, array<RGBQUAD>[]()[]) | Allocates a new image of the specified width, height and bit depth and optionally fills it with the specified color. See remarks for further details.
AllocateEx(Int32, Int32, Int32, Nullable<(Of <(RGBQUAD>)>), FREE_IMAGE_COLOR_OPTIONS, array<RGBQUAD>[]()[], UInt32, UInt32, UInt32) | Allocates a new image of the specified width, height and bit depth and optionally fills it with the specified color. See remarks for further details.

See Also

FreeImage Class
FreeImage Members


AllocateEx Method (Int32, Int32, Int32, Nullable(RGBQUAD), FREE_IMAGE_COLOR_OPTIONS, RGBQUAD[])

[image]

FreeImage .NET Documentation
FreeImage..::.AllocateEx Method (Int32, Int32, Int32, Nullable<(Of <(RGBQUAD>)>), FREE_IMAGE_COLOR_OPTIONS, array<RGBQUAD>[]()[])
FreeImage Class See Also Send Feedback
Allocates a new image of the specified width, height and bit depth and optionally fills it with the specified color. See remarks for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP AllocateEx(
    int width,
    int height,
    int bpp,
    Nullable<RGBQUAD> color,
    FREE_IMAGE_COLOR_OPTIONS options,
    RGBQUAD[] palette
)
Visual Basic (Declaration)
Public Shared Function AllocateEx ( _
    width As Integer, _
    height As Integer, _
    bpp As Integer, _
    color As Nullable(Of RGBQUAD), _
    options As FREE_IMAGE_COLOR_OPTIONS, _
    palette As RGBQUAD() _
) As FIBITMAP
Visual C++
public:
static FIBITMAP AllocateEx(
    int width,
    int height,
    int bpp,
    Nullable<RGBQUAD> color,
    FREE_IMAGE_COLOR_OPTIONS options,
    array<RGBQUAD>^ palette
)

Parameters

width
Type: System..::.Int32
Width of the new bitmap.
height
Type: System..::.Int32
Height of the new bitmap.
bpp
Type: System..::.Int32
Bit depth of the new bitmap. Supported pixel depth: 1-, 4-, 8-, 16-, 24-, 32-bit per pixel for standard bitmaps.
color
Type: System..::.Nullable <(Of <( RGBQUAD >)>)
The color to fill the bitmap with or null.
options
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_OPTIONS
Options to enable or disable function-features.
palette
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The palette of the bitmap or null.

Return Value

Handle to a FreeImage bitmap.

Remarks

This function is an extension to Allocate(Int32, Int32, Int32, UInt32, UInt32, UInt32), which additionally supports specifying a palette to be set for the newly create image, as well as specifying a background color, the newly created image should initially be filled with.

Basically, this function internally relies on function Allocate(Int32, Int32, Int32, UInt32, UInt32, UInt32), followed by a call to FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS). This is why both parameters color and options behave the same as it is documented for function FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS). So, please refer to the documentation of FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS) to learn more about parameters color and options.

The palette specified through parameter palette is only copied to the newly created image, if the desired bit depth is smaller than or equal to 8 bits per pixel. In other words, the palette parameter is only taken into account for palletized images. So, for an 8-bit image, the length is 256, for an 4-bit image it is 16 and it is 2 for a 1-bit image. In other words, this function does not support partial palettes.

However, specifying a palette is not necesarily needed, even for palletized images. This function is capable of implicitly creating a palette, if palette is null. If the specified background color is a greyscale value (red = green = blue) or if option FICO_ALPHA_IS_INDEX is specified, a greyscale palette is created. For a 1-bit image, only if the specified background color is either black or white, a monochrome palette, consisting of black and white only is created. In any case, the darker colors are stored at the smaller palette indices.

If the specified background color is not a greyscale value, or is neither black nor white for a 1-bit image, solely this specified color is injected into the otherwise black-initialized palette. For this operation, option FICO_ALPHA_IS_INDEX is implicit, so the specified color is applied to the palette entry, specified by the background color's rgbReserved field. The image is then filled with this palette index.

This function returns a newly created image as function Allocate(Int32, Int32, Int32, UInt32, UInt32, UInt32) does, if both parameters color and palette are null. If only color is null, the palette pointed to by parameter palette is initially set for the new image, if a palletized image of type FIT_BITMAP is created. However, in the latter case, this function returns an image, whose pixels are all initialized with zeros so, the image will be filled with the color of the first palette entry.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class
AllocateEx Overload


AllocateEx Method (Int32, Int32, Int32, Nullable(RGBQUAD), FREE_IMAGE_COLOR_OPTIONS, RGBQUAD[], UInt32, UInt32, UInt32)

[image]

FreeImage .NET Documentation
FreeImage..::.AllocateEx Method (Int32, Int32, Int32, Nullable<(Of <(RGBQUAD>)>), FREE_IMAGE_COLOR_OPTIONS, array<RGBQUAD>[]()[], UInt32, UInt32, UInt32)
FreeImage Class See Also Send Feedback
Allocates a new image of the specified width, height and bit depth and optionally fills it with the specified color. See remarks for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP AllocateEx(
    int width,
    int height,
    int bpp,
    Nullable<RGBQUAD> color,
    FREE_IMAGE_COLOR_OPTIONS options,
    RGBQUAD[] palette,
    uint red_mask,
    uint green_mask,
    uint blue_mask
)
Visual Basic (Declaration)
Public Shared Function AllocateEx ( _
    width As Integer, _
    height As Integer, _
    bpp As Integer, _
    color As Nullable(Of RGBQUAD), _
    options As FREE_IMAGE_COLOR_OPTIONS, _
    palette As RGBQUAD(), _
    red_mask As UInteger, _
    green_mask As UInteger, _
    blue_mask As UInteger _
) As FIBITMAP
Visual C++
public:
static FIBITMAP AllocateEx(
    int width,
    int height,
    int bpp,
    Nullable<RGBQUAD> color,
    FREE_IMAGE_COLOR_OPTIONS options,
    array<RGBQUAD>^ palette,
    unsigned int red_mask,
    unsigned int green_mask,
    unsigned int blue_mask
)

Parameters

width
Type: System..::.Int32
Width of the new bitmap.
height
Type: System..::.Int32
Height of the new bitmap.
bpp
Type: System..::.Int32
Bit depth of the new bitmap. Supported pixel depth: 1-, 4-, 8-, 16-, 24-, 32-bit per pixel for standard bitmaps.
color
Type: System..::.Nullable <(Of <( RGBQUAD >)>)
The color to fill the bitmap with or null.
options
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_OPTIONS
Options to enable or disable function-features.
palette
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The palette of the bitmap or null.
red_mask
Type: System..::.UInt32
Red part of the color layout. eg: 0xFF0000
green_mask
Type: System..::.UInt32
Green part of the color layout. eg: 0x00FF00
blue_mask
Type: System..::.UInt32
Blue part of the color layout. eg: 0x0000FF

Return Value

Handle to a FreeImage bitmap.

Remarks

This function is an extension to Allocate(Int32, Int32, Int32, UInt32, UInt32, UInt32), which additionally supports specifying a palette to be set for the newly create image, as well as specifying a background color, the newly created image should initially be filled with.

Basically, this function internally relies on function Allocate(Int32, Int32, Int32, UInt32, UInt32, UInt32), followed by a call to FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS). This is why both parameters color and options behave the same as it is documented for function FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS). So, please refer to the documentation of FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS) to learn more about parameters color and options.

The palette specified through parameter palette is only copied to the newly created image, if the desired bit depth is smaller than or equal to 8 bits per pixel. In other words, the palette parameter is only taken into account for palletized images. So, for an 8-bit image, the length is 256, for an 4-bit image it is 16 and it is 2 for a 1-bit image. In other words, this function does not support partial palettes.

However, specifying a palette is not necesarily needed, even for palletized images. This function is capable of implicitly creating a palette, if palette is null. If the specified background color is a greyscale value (red = green = blue) or if option FICO_ALPHA_IS_INDEX is specified, a greyscale palette is created. For a 1-bit image, only if the specified background color is either black or white, a monochrome palette, consisting of black and white only is created. In any case, the darker colors are stored at the smaller palette indices.

If the specified background color is not a greyscale value, or is neither black nor white for a 1-bit image, solely this specified color is injected into the otherwise black-initialized palette. For this operation, option FICO_ALPHA_IS_INDEX is implicit, so the specified color is applied to the palette entry, specified by the background color's rgbReserved field. The image is then filled with this palette index.

This function returns a newly created image as function Allocate(Int32, Int32, Int32, UInt32, UInt32, UInt32) does, if both parameters color and palette are null. If only color is null, the palette pointed to by parameter palette is initially set for the new image, if a palletized image of type FIT_BITMAP is created. However, in the latter case, this function returns an image, whose pixels are all initialized with zeros so, the image will be filled with the color of the first palette entry.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class
AllocateEx Overload


AllocateExT Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.AllocateExT Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
AllocateExT<(Of <(T>)>)(FREE_IMAGE_TYPE, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS, array<RGBQUAD>[]()[], UInt32, UInt32, UInt32) | Allocates a new image of the specified type, width, height and bit depth and optionally fills it with the specified color. See remarks for further details.
AllocateExT<(Of <(T>)>)(FREE_IMAGE_TYPE, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS, array<RGBQUAD>[]()[]) | Allocates a new image of the specified type, width, height and bit depth and optionally fills it with the specified color. See remarks for further details.

See Also

FreeImage Class
FreeImage Members


AllocateExT(T) Method (FREE_IMAGE_TYPE, Int32, Int32, Int32, Nullable(T), FREE_IMAGE_COLOR_OPTIONS, RGBQUAD[], UInt32, UInt32, UInt32)

[image]

FreeImage .NET Documentation
FreeImage..::.AllocateExT<(Of <(T>)>) Method (FREE_IMAGE_TYPE, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS, array<RGBQUAD>[]()[], UInt32, UInt32, UInt32)
FreeImage Class See Also Send Feedback
Allocates a new image of the specified type, width, height and bit depth and optionally fills it with the specified color. See remarks for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP AllocateExT<T>(
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int bpp,
    Nullable<T> color,
    FREE_IMAGE_COLOR_OPTIONS options,
    RGBQUAD[] palette,
    uint red_mask,
    uint green_mask,
    uint blue_mask
)
where T : struct, new()
Visual Basic (Declaration)
Public Shared Function AllocateExT(Of T As {Structure, New}) ( _
    type As FREE_IMAGE_TYPE, _
    width As Integer, _
    height As Integer, _
    bpp As Integer, _
    color As Nullable(Of T), _
    options As FREE_IMAGE_COLOR_OPTIONS, _
    palette As RGBQUAD(), _
    red_mask As UInteger, _
    green_mask As UInteger, _
    blue_mask As UInteger _
) As FIBITMAP
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
static FIBITMAP AllocateExT(
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int bpp,
    Nullable<T> color,
    FREE_IMAGE_COLOR_OPTIONS options,
    array<RGBQUAD>^ palette,
    unsigned int red_mask,
    unsigned int green_mask,
    unsigned int blue_mask
)

Parameters

type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
Type of the image.
width
Type: System..::.Int32
Width of the new bitmap.
height
Type: System..::.Int32
Height of the new bitmap.
bpp
Type: System..::.Int32
Bit depth of the new bitmap. Supported pixel depth: 1-, 4-, 8-, 16-, 24-, 32-bit per pixel for standard bitmap
color
Type: System..::.Nullable <(Of <(T>)>)
The color to fill the bitmap with or null.
options
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_OPTIONS
Options to enable or disable function-features.
palette
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The palette of the bitmap or null.
red_mask
Type: System..::.UInt32
Red part of the color layout. eg: 0xFF0000
green_mask
Type: System..::.UInt32
Green part of the color layout. eg: 0x00FF00
blue_mask
Type: System..::.UInt32
Blue part of the color layout. eg: 0x0000FF

Type Parameters

T
The type of the specified color.

Return Value

Handle to a FreeImage bitmap.

Remarks

This function is an extension to AllocateT(FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32), which additionally supports specifying a palette to be set for the newly create image, as well as specifying a background color, the newly created image should initially be filled with.

Basically, this function internally relies on function AllocateT(FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32), followed by a call to FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS). This is why both parameters color and options behave the same as it is documented for function FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS). So, please refer to the documentation of FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS) to learn more about parameters color and options.

The palette specified through parameter palette is only copied to the newly created image, if its image type is FIT_BITMAP and the desired bit depth is smaller than or equal to 8 bits per pixel. In other words, the palette palette is only taken into account for palletized images. However, if the preceding conditions match and if palette is not null, the palette is assumed to be at least as large as the size of a fully populated palette for the desired bit depth. So, for an 8-bit image, this length is 256, for an 4-bit image it is 16 and it is 2 for a 1-bit image. In other words, this function does not support partial palettes.

However, specifying a palette is not necesarily needed, even for palletized images. This function is capable of implicitly creating a palette, if palette is null. If the specified background color is a greyscale value (red = green = blue) or if option FICO_ALPHA_IS_INDEX is specified, a greyscale palette is created. For a 1-bit image, only if the specified background color is either black or white, a monochrome palette, consisting of black and white only is created. In any case, the darker colors are stored at the smaller palette indices.

If the specified background color is not a greyscale value, or is neither black nor white for a 1-bit image, solely this specified color is injected into the otherwise black-initialized palette. For this operation, option FICO_ALPHA_IS_INDEX is implicit, so the specified color is applied to the palette entry, specified by the background color's rgbReserved field. The image is then filled with this palette index.

This function returns a newly created image as function AllocateT(FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32) does, if both parameters color and palette are null. If only color is null, the palette pointed to by parameter palette is initially set for the new image, if a palletized image of type FIT_BITMAP is created. However, in the latter case, this function returns an image, whose pixels are all initialized with zeros so, the image will be filled with the color of the first palette entry.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class
AllocateExT Overload


AllocateExT(T) Method (FREE_IMAGE_TYPE, Int32, Int32, Int32, Nullable(T), FREE_IMAGE_COLOR_OPTIONS, RGBQUAD[])

[image]

FreeImage .NET Documentation
FreeImage..::.AllocateExT<(Of <(T>)>) Method (FREE_IMAGE_TYPE, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS, array<RGBQUAD>[]()[])
FreeImage Class See Also Send Feedback
Allocates a new image of the specified type, width, height and bit depth and optionally fills it with the specified color. See remarks for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP AllocateExT<T>(
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int bpp,
    Nullable<T> color,
    FREE_IMAGE_COLOR_OPTIONS options,
    RGBQUAD[] palette
)
where T : struct, new()
Visual Basic (Declaration)
Public Shared Function AllocateExT(Of T As {Structure, New}) ( _
    type As FREE_IMAGE_TYPE, _
    width As Integer, _
    height As Integer, _
    bpp As Integer, _
    color As Nullable(Of T), _
    options As FREE_IMAGE_COLOR_OPTIONS, _
    palette As RGBQUAD() _
) As FIBITMAP
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
static FIBITMAP AllocateExT(
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int bpp,
    Nullable<T> color,
    FREE_IMAGE_COLOR_OPTIONS options,
    array<RGBQUAD>^ palette
)

Parameters

type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
Type of the image.
width
Type: System..::.Int32
Width of the new bitmap.
height
Type: System..::.Int32
Height of the new bitmap.
bpp
Type: System..::.Int32
Bit depth of the new bitmap. Supported pixel depth: 1-, 4-, 8-, 16-, 24-, 32-bit per pixel for standard bitmap
color
Type: System..::.Nullable <(Of <(T>)>)
The color to fill the bitmap with or null.
options
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_OPTIONS
Options to enable or disable function-features.
palette
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The palette of the bitmap or null.

Type Parameters

T
The type of the specified color.

Return Value

Handle to a FreeImage bitmap.

Remarks

This function is an extension to AllocateT(FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32), which additionally supports specifying a palette to be set for the newly create image, as well as specifying a background color, the newly created image should initially be filled with.

Basically, this function internally relies on function AllocateT(FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32), followed by a call to FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS). This is why both parameters color and options behave the same as it is documented for function FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS). So, please refer to the documentation of FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS) to learn more about parameters color and options.

The palette specified through parameter palette is only copied to the newly created image, if its image type is FIT_BITMAP and the desired bit depth is smaller than or equal to 8 bits per pixel. In other words, the palette palette is only taken into account for palletized images. However, if the preceding conditions match and if palette is not null, the palette is assumed to be at least as large as the size of a fully populated palette for the desired bit depth. So, for an 8-bit image, this length is 256, for an 4-bit image it is 16 and it is 2 for a 1-bit image. In other words, this function does not support partial palettes.

However, specifying a palette is not necesarily needed, even for palletized images. This function is capable of implicitly creating a palette, if palette is null. If the specified background color is a greyscale value (red = green = blue) or if option FICO_ALPHA_IS_INDEX is specified, a greyscale palette is created. For a 1-bit image, only if the specified background color is either black or white, a monochrome palette, consisting of black and white only is created. In any case, the darker colors are stored at the smaller palette indices.

If the specified background color is not a greyscale value, or is neither black nor white for a 1-bit image, solely this specified color is injected into the otherwise black-initialized palette. For this operation, option FICO_ALPHA_IS_INDEX is implicit, so the specified color is applied to the palette entry, specified by the background color's rgbReserved field. The image is then filled with this palette index.

This function returns a newly created image as function AllocateT(FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32) does, if both parameters color and palette are null. If only color is null, the palette pointed to by parameter palette is initially set for the new image, if a palletized image of type FIT_BITMAP is created. However, in the latter case, this function returns an image, whose pixels are all initialized with zeros so, the image will be filled with the color of the first palette entry.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class
AllocateExT Overload


AllocateT Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.AllocateT Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
AllocateT(FREE_IMAGE_TYPE, Int32, Int32, Int32) | Creates a new bitmap in memory.
AllocateT(FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32) | Creates a new bitmap in memory.

See Also

FreeImage Class
FreeImage Members


AllocateT Method (FREE_IMAGE_TYPE, Int32, Int32, Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.AllocateT Method (FREE_IMAGE_TYPE, Int32, Int32, Int32)
FreeImage Class See Also Send Feedback
Creates a new bitmap in memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP AllocateT(
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int bpp
)
Visual Basic (Declaration)
Public Shared Function AllocateT ( _
    type As FREE_IMAGE_TYPE, _
    width As Integer, _
    height As Integer, _
    bpp As Integer _
) As FIBITMAP
Visual C++
public:
static FIBITMAP AllocateT(
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int bpp
)

Parameters

type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
Type of the image.
width
Type: System..::.Int32
Width of the new bitmap.
height
Type: System..::.Int32
Height of the new bitmap.
bpp
Type: System..::.Int32
Bit depth of the new Bitmap. Supported pixel depth: 1-, 4-, 8-, 16-, 24-, 32-bit per pixel for standard bitmap

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class
AllocateT Overload


AllocateT Method (FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32)

[image]

FreeImage .NET Documentation
FreeImage..::.AllocateT Method (FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32)
FreeImage Class See Also Send Feedback
Creates a new bitmap in memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP AllocateT(
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int bpp,
    uint red_mask,
    uint green_mask,
    uint blue_mask
)
Visual Basic (Declaration)
Public Shared Function AllocateT ( _
    type As FREE_IMAGE_TYPE, _
    width As Integer, _
    height As Integer, _
    bpp As Integer, _
    red_mask As UInteger, _
    green_mask As UInteger, _
    blue_mask As UInteger _
) As FIBITMAP
Visual C++
public:
static FIBITMAP AllocateT(
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int bpp,
    unsigned int red_mask,
    unsigned int green_mask,
    unsigned int blue_mask
)

Parameters

type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
Type of the image.
width
Type: System..::.Int32
Width of the new bitmap.
height
Type: System..::.Int32
Height of the new bitmap.
bpp
Type: System..::.Int32
Bit depth of the new Bitmap. Supported pixel depth: 1-, 4-, 8-, 16-, 24-, 32-bit per pixel for standard bitmap
red_mask
Type: System..::.UInt32
Red part of the color layout. eg: 0xFF0000
green_mask
Type: System..::.UInt32
Green part of the color layout. eg: 0x00FF00
blue_mask
Type: System..::.UInt32
Blue part of the color layout. eg: 0x0000FF

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
AllocateT Overload


AppendPage Method

[image]

FreeImage .NET Documentation
FreeImage..::.AppendPage Method
FreeImage Class See Also Send Feedback
Appends a new page to the end of the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void AppendPage(
    FIMULTIBITMAP bitmap,
    FIBITMAP data
)
Visual Basic (Declaration)
Public Shared Sub AppendPage ( _
    bitmap As FIMULTIBITMAP, _
    data As FIBITMAP _
)
Visual C++
public:
static void AppendPage(
    FIMULTIBITMAP bitmap,
    FIBITMAP data
)

Parameters

bitmap
Type: FreeImageAPI..::.FIMULTIBITMAP
Handle to a FreeImage multi-paged bitmap.
data
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ApplyColorMapping Method

[image]

FreeImage .NET Documentation
FreeImage..::.ApplyColorMapping Method
FreeImage Class See Also Send Feedback
Applies color mapping for one or several colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint ApplyColorMapping(
    FIBITMAP dib,
    RGBQUAD[] srccolors,
    RGBQUAD[] dstcolors,
    uint count,
    bool ignore_alpha,
    bool swap
)
Visual Basic (Declaration)
Public Shared Function ApplyColorMapping ( _
    dib As FIBITMAP, _
    srccolors As RGBQUAD(), _
    dstcolors As RGBQUAD(), _
    count As UInteger, _
    ignore_alpha As Boolean, _
    swap As Boolean _
) As UInteger
Visual C++
public:
static unsigned int ApplyColorMapping(
    FIBITMAP dib,
    array<RGBQUAD>^ srccolors,
    array<RGBQUAD>^ dstcolors,
    unsigned int count,
    bool ignore_alpha,
    bool swap
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
srccolors
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
Array of colors to be used as the mapping source.
dstcolors
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
Array of colors to be used as the mapping destination.
count
Type: System..::.UInt32
The number of colors to be mapped. This is the size of both srccolors and dstcolors.
ignore_alpha
Type: System..::.Boolean
If true, 32-bit images and colors are treated as 24-bit.
swap
Type: System..::.Boolean
If true, source and destination colors are swapped, that is, each destination color is also mapped to the corresponding source color.

Return Value

The total number of pixels changed.

Remarks

This function maps up to count colors specified in srccolors to these specified in dstcolors. Thereby, color srccolors[N], if found in the image, will be replaced by color dstcolors[N]. If swap is true, additionally all colors specified in dstcolors are also mapped to these specified in srccolors. For high color images, the actual image data will be modified whereas, for palletized images only the palette will be changed.

The function returns the number of pixels changed or zero, if no pixels were changed.

Both arrays srccolors and dstcolors are assumed not to hold less than count colors.

For 16-bit images, all colors specified are transparently converted to their proper 16-bit representation (either in RGB555 or RGB565 format, which is determined by the image's red- green- and blue-mask).

Note, that this behaviour is different from what ApplyPaletteIndexMapping(FIBITMAP, array<Byte>[]()[], array<Byte>[]()[], UInt32, Boolean) does, which modifies the actual image data on palletized images.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ApplyPaletteIndexMapping Method

[image]

FreeImage .NET Documentation
FreeImage..::.ApplyPaletteIndexMapping Method
FreeImage Class See Also Send Feedback
Applies palette index mapping for one or several indices on a 1-, 4- or 8-bit palletized image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint ApplyPaletteIndexMapping(
    FIBITMAP dib,
    byte[] srcindices,
    byte[] dstindices,
    uint count,
    bool swap
)
Visual Basic (Declaration)
Public Shared Function ApplyPaletteIndexMapping ( _
    dib As FIBITMAP, _
    srcindices As Byte(), _
    dstindices As Byte(), _
    count As UInteger, _
    swap As Boolean _
) As UInteger
Visual C++
public:
static unsigned int ApplyPaletteIndexMapping(
    FIBITMAP dib,
    array<unsigned char>^ srcindices,
    array<unsigned char>^ dstindices,
    unsigned int count,
    bool swap
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
srcindices
Type: array< System..::.Byte >[]()[]
Array of palette indices to be used as the mapping source.
dstindices
Type: array< System..::.Byte >[]()[]
Array of palette indices to be used as the mapping destination.
count
Type: System..::.UInt32
The number of palette indices to be mapped. This is the size of both srcindices and dstindices
swap
Type: System..::.Boolean
If true, source and destination palette indices are swapped, that is, each destination index is also mapped to the corresponding source index.

Return Value

The total number of pixels changed.

Remarks

This function maps up to count palette indices specified in srcindices to these specified in dstindices. Thereby, index srcindices[N], if present in the image, will be replaced by index dstindices[N]. If swap is true, additionally all indices specified in dstindices are also mapped to these specified in srcindices.

The function returns the number of pixels changed or zero, if no pixels were changed. Both arrays srcindices and dstindices are assumed not to hold less than count indices.

Note, that this behaviour is different from what ApplyColorMapping(FIBITMAP, array<RGBQUAD>[]()[], array<RGBQUAD>[]()[], UInt32, Boolean, Boolean) does, which modifies the actual image data on palletized images.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Clone Method

[image]

FreeImage .NET Documentation
FreeImage..::.Clone Method
FreeImage Class See Also Send Feedback
Makes an exact reproduction of an existing bitmap, including metadata and attached profile if any.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Clone(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function Clone ( _
    dib As FIBITMAP _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Clone(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


CloneMetadata Method

[image]

FreeImage .NET Documentation
FreeImage..::.CloneMetadata Method
FreeImage Class See Also Send Feedback
Copies the metadata of FreeImage bitmap to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool CloneMetadata(
    FIBITMAP dst,
    FIBITMAP src
)
Visual Basic (Declaration)
Public Shared Function CloneMetadata ( _
    dst As FIBITMAP, _
    src As FIBITMAP _
) As Boolean
Visual C++
public:
static bool CloneMetadata(
    FIBITMAP dst,
    FIBITMAP src
)

Parameters

dst
Type: FreeImageAPI..::.FIBITMAP
The FreeImage bitmap to copy the metadata to.
src
Type: FreeImageAPI..::.FIBITMAP
The FreeImage bitmap to copy the metadata from.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


CloneMetadataEx Method

[image]

FreeImage .NET Documentation
FreeImage..::.CloneMetadataEx Method
FreeImage Class See Also Send Feedback
Copies metadata from one FreeImage bitmap to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int CloneMetadataEx(
    FIBITMAP src,
    FIBITMAP dst,
    FREE_IMAGE_METADATA_COPY flags
)
Visual Basic (Declaration)
Public Shared Function CloneMetadataEx ( _
    src As FIBITMAP, _
    dst As FIBITMAP, _
    flags As FREE_IMAGE_METADATA_COPY _
) As Integer
Visual C++
public:
static int CloneMetadataEx(
    FIBITMAP src,
    FIBITMAP dst,
    FREE_IMAGE_METADATA_COPY flags
)

Parameters

src
Type: FreeImageAPI..::.FIBITMAP
Source FreeImage bitmap containing the metadata.
dst
Type: FreeImageAPI..::.FIBITMAP
FreeImage bitmap to copy the metadata to.
flags
Type: FreeImageAPI..::.FREE_IMAGE_METADATA_COPY
Flags to switch different copy modes.

Return Value

Returns -1 on failure else the number of copied tags.

Exceptions

Exception | Condition
System..::.ArgumentNullException | src or dst is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


CloneTag Method

[image]

FreeImage .NET Documentation
FreeImage..::.CloneTag Method
FreeImage Class See Also Send Feedback
Creates and returns a copy of a FITAG object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FITAG CloneTag(
    FITAG tag
)
Visual Basic (Declaration)
Public Shared Function CloneTag ( _
    tag As FITAG _
) As FITAG
Visual C++
public:
static FITAG CloneTag(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The FITAG to clone.

Return Value

The new FITAG.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


CloseMemory Method

[image]

FreeImage .NET Documentation
FreeImage..::.CloseMemory Method
FreeImage Class See Also Send Feedback
Close and free a memory stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CloseMemory(
    FIMEMORY stream
)
Visual Basic (Declaration)
Public Shared Sub CloseMemory ( _
    stream As FIMEMORY _
)
Visual C++
public:
static void CloseMemory(
    FIMEMORY stream
)

Parameters

stream
Type: FreeImageAPI..::.FIMEMORY
Handle to a memory stream.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


CloseMultiBitmap Method

[image]

FreeImage .NET Documentation
FreeImage..::.CloseMultiBitmap Method
FreeImage Class See Also Send Feedback
Closes a previously opened multi-page bitmap and, when the bitmap was not opened read-only, applies any changes made to it.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool CloseMultiBitmap(
    FIMULTIBITMAP bitmap,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function CloseMultiBitmap ( _
    bitmap As FIMULTIBITMAP, _
    flags As FREE_IMAGE_SAVE_FLAGS _
) As Boolean
Visual C++
public:
static bool CloseMultiBitmap(
    FIMULTIBITMAP bitmap,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

bitmap
Type: FreeImageAPI..::.FIMULTIBITMAP
Handle to a FreeImage multi-paged bitmap.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


CloseMultiBitmapEx Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.CloseMultiBitmapEx Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
CloseMultiBitmapEx(FIMULTIBITMAP%) | Closes a previously opened multi-page bitmap and, when the bitmap was not opened read-only, applies any changes made to it. On success the handle will be reset to null.
CloseMultiBitmapEx(FIMULTIBITMAP%, FREE_IMAGE_SAVE_FLAGS) | Closes a previously opened multi-page bitmap and, when the bitmap was not opened read-only, applies any changes made to it. On success the handle will be reset to null.

See Also

FreeImage Class
FreeImage Members


CloseMultiBitmapEx Method (FIMULTIBITMAP)

[image]

FreeImage .NET Documentation
FreeImage..::.CloseMultiBitmapEx Method (FIMULTIBITMAP%)
FreeImage Class See Also Send Feedback
Closes a previously opened multi-page bitmap and, when the bitmap was not opened read-only, applies any changes made to it. On success the handle will be reset to null.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool CloseMultiBitmapEx(
    ref FIMULTIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function CloseMultiBitmapEx ( _
    ByRef dib As FIMULTIBITMAP _
) As Boolean
Visual C++
public:
static bool CloseMultiBitmapEx(
    FIMULTIBITMAP% dib
)

Parameters

dib
Type: FreeImageAPI..::.FIMULTIBITMAP %

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CloseMultiBitmapEx Overload


CloseMultiBitmapEx Method (FIMULTIBITMAP, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImage..::.CloseMultiBitmapEx Method (FIMULTIBITMAP%, FREE_IMAGE_SAVE_FLAGS)
FreeImage Class See Also Send Feedback
Closes a previously opened multi-page bitmap and, when the bitmap was not opened read-only, applies any changes made to it. On success the handle will be reset to null.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool CloseMultiBitmapEx(
    ref FIMULTIBITMAP dib,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function CloseMultiBitmapEx ( _
    ByRef dib As FIMULTIBITMAP, _
    flags As FREE_IMAGE_SAVE_FLAGS _
) As Boolean
Visual C++
public:
static bool CloseMultiBitmapEx(
    FIMULTIBITMAP% dib,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

dib
Type: FreeImageAPI..::.FIMULTIBITMAP %
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CloseMultiBitmapEx Overload


ColorQuantize Method

[image]

FreeImage .NET Documentation
FreeImage..::.ColorQuantize Method
FreeImage Class See Also Send Feedback
Quantizes a high-color 24-bit bitmap to an 8-bit palette color bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ColorQuantize(
    FIBITMAP dib,
    FREE_IMAGE_QUANTIZE quantize
)
Visual Basic (Declaration)
Public Shared Function ColorQuantize ( _
    dib As FIBITMAP, _
    quantize As FREE_IMAGE_QUANTIZE _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ColorQuantize(
    FIBITMAP dib,
    FREE_IMAGE_QUANTIZE quantize
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
quantize
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
Specifies the color reduction algorithm to be used.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ColorQuantizeEx Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.ColorQuantizeEx Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
ColorQuantizeEx(FIBITMAP, FREE_IMAGE_QUANTIZE, Int32, Int32, array<RGBQUAD>[]()[]) | ColorQuantizeEx is an extension to the ColorQuantize(FIBITMAP, FREE_IMAGE_QUANTIZE) method that provides additional options used to quantize a 24-bit image to any number of colors (up to 256), as well as quantize a 24-bit image using a partial or full provided palette.
ColorQuantizeEx(FIBITMAP, FREE_IMAGE_QUANTIZE, Int32, array<RGBQUAD>[]()[], Boolean) | ColorQuantizeEx is an extension to the ColorQuantize(FIBITMAP, FREE_IMAGE_QUANTIZE) method that provides additional options used to quantize a 24-bit image to any number of colors (up to 256), as well as quantize a 24-bit image using a provided palette.
ColorQuantizeEx(FIBITMAP, FREE_IMAGE_QUANTIZE, Int32, array<RGBQUAD>[]()[], Int32) | ColorQuantizeEx is an extension to the ColorQuantize(FIBITMAP, FREE_IMAGE_QUANTIZE) method that provides additional options used to quantize a 24-bit image to any number of colors (up to 256), as well as quantize a 24-bit image using a partial or full provided palette.

See Also

FreeImage Class
FreeImage Members


ColorQuantizeEx Method (FIBITMAP, FREE_IMAGE_QUANTIZE, Int32, Int32, RGBQUAD[])

[image]

FreeImage .NET Documentation
FreeImage..::.ColorQuantizeEx Method (FIBITMAP, FREE_IMAGE_QUANTIZE, Int32, Int32, array<RGBQUAD>[]()[])
FreeImage Class See Also Send Feedback
ColorQuantizeEx is an extension to the ColorQuantize(FIBITMAP, FREE_IMAGE_QUANTIZE) method that provides additional options used to quantize a 24-bit image to any number of colors (up to 256), as well as quantize a 24-bit image using a partial or full provided palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ColorQuantizeEx(
    FIBITMAP dib,
    FREE_IMAGE_QUANTIZE quantize,
    int PaletteSize,
    int ReserveSize,
    RGBQUAD[] ReservePalette
)
Visual Basic (Declaration)
Public Shared Function ColorQuantizeEx ( _
    dib As FIBITMAP, _
    quantize As FREE_IMAGE_QUANTIZE, _
    PaletteSize As Integer, _
    ReserveSize As Integer, _
    ReservePalette As RGBQUAD() _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ColorQuantizeEx(
    FIBITMAP dib,
    FREE_IMAGE_QUANTIZE quantize,
    int PaletteSize,
    int ReserveSize,
    array<RGBQUAD>^ ReservePalette
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
quantize
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
Specifies the color reduction algorithm to be used.
PaletteSize
Type: System..::.Int32
Size of the desired output palette.
ReserveSize
Type: System..::.Int32
Size of the provided palette of ReservePalette.
ReservePalette
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The provided palette.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ColorQuantizeEx Overload


ColorQuantizeEx Method (FIBITMAP, FREE_IMAGE_QUANTIZE, Int32, RGBQUAD[], Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.ColorQuantizeEx Method (FIBITMAP, FREE_IMAGE_QUANTIZE, Int32, array<RGBQUAD>[]()[], Boolean)
FreeImage Class See Also Send Feedback
ColorQuantizeEx is an extension to the ColorQuantize(FIBITMAP, FREE_IMAGE_QUANTIZE) method that provides additional options used to quantize a 24-bit image to any number of colors (up to 256), as well as quantize a 24-bit image using a provided palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ColorQuantizeEx(
    FIBITMAP dib,
    FREE_IMAGE_QUANTIZE quantize,
    int PaletteSize,
    RGBQUAD[] ReservePalette,
    bool minColorDepth
)
Visual Basic (Declaration)
Public Shared Function ColorQuantizeEx ( _
    dib As FIBITMAP, _
    quantize As FREE_IMAGE_QUANTIZE, _
    PaletteSize As Integer, _
    ReservePalette As RGBQUAD(), _
    minColorDepth As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ColorQuantizeEx(
    FIBITMAP dib,
    FREE_IMAGE_QUANTIZE quantize,
    int PaletteSize,
    array<RGBQUAD>^ ReservePalette,
    bool minColorDepth
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
quantize
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
Specifies the color reduction algorithm to be used.
PaletteSize
Type: System..::.Int32
Size of the desired output palette.
ReservePalette
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The provided palette.
minColorDepth
Type: System..::.Boolean
true to create a bitmap with the smallest possible color depth for the specified PaletteSize.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ColorQuantizeEx Overload


ColorQuantizeEx Method (FIBITMAP, FREE_IMAGE_QUANTIZE, Int32, RGBQUAD[], Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.ColorQuantizeEx Method (FIBITMAP, FREE_IMAGE_QUANTIZE, Int32, array<RGBQUAD>[]()[], Int32)
FreeImage Class See Also Send Feedback
ColorQuantizeEx is an extension to the ColorQuantize(FIBITMAP, FREE_IMAGE_QUANTIZE) method that provides additional options used to quantize a 24-bit image to any number of colors (up to 256), as well as quantize a 24-bit image using a partial or full provided palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ColorQuantizeEx(
    FIBITMAP dib,
    FREE_IMAGE_QUANTIZE quantize,
    int PaletteSize,
    RGBQUAD[] ReservePalette,
    int bpp
)
Visual Basic (Declaration)
Public Shared Function ColorQuantizeEx ( _
    dib As FIBITMAP, _
    quantize As FREE_IMAGE_QUANTIZE, _
    PaletteSize As Integer, _
    ReservePalette As RGBQUAD(), _
    bpp As Integer _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ColorQuantizeEx(
    FIBITMAP dib,
    FREE_IMAGE_QUANTIZE quantize,
    int PaletteSize,
    array<RGBQUAD>^ ReservePalette,
    int bpp
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
quantize
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
Specifies the color reduction algorithm to be used.
PaletteSize
Type: System..::.Int32
Size of the desired output palette.
ReservePalette
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The provided palette.
bpp
Type: System..::.Int32
The desired color depth of the created image.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ColorQuantizeEx Overload


Compare Method

[image]

FreeImage .NET Documentation
FreeImage..::.Compare Method
FreeImage Class See Also Send Feedback
Compares two FreeImage bitmaps.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool Compare(
    FIBITMAP dib1,
    FIBITMAP dib2,
    FREE_IMAGE_COMPARE_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function Compare ( _
    dib1 As FIBITMAP, _
    dib2 As FIBITMAP, _
    flags As FREE_IMAGE_COMPARE_FLAGS _
) As Boolean
Visual C++
public:
static bool Compare(
    FIBITMAP dib1,
    FIBITMAP dib2,
    FREE_IMAGE_COMPARE_FLAGS flags
)

Parameters

dib1
Type: FreeImageAPI..::.FIBITMAP
The first bitmap to compare.
dib2
Type: FreeImageAPI..::.FIBITMAP
The second bitmap to compare.
flags
Type: FreeImageAPI..::.FREE_IMAGE_COMPARE_FLAGS
Determines which components of the bitmaps will be compared.

Return Value

True in case both bitmaps match the compare conditions, false otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


CompareMemory Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.CompareMemory Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
CompareMemory(IntPtr, IntPtr, Int64) | Compares blocks of memory.
CompareMemory(IntPtr, IntPtr, UInt32) | Compares blocks of memory.
CompareMemory(Void*, Void*, Int64) | Compares blocks of memory.
CompareMemory(Void*, Void*, UInt32) | Compares blocks of memory.

See Also

FreeImage Class
FreeImage Members


CompareMemory Method (IntPtr, IntPtr, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.CompareMemory Method (IntPtr, IntPtr, Int64)
FreeImage Class See Also Send Feedback
Compares blocks of memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool CompareMemory(
    IntPtr buf1,
    IntPtr buf2,
    long length
)
Visual Basic (Declaration)
Public Shared Function CompareMemory ( _
    buf1 As IntPtr, _
    buf2 As IntPtr, _
    length As Long _
) As Boolean
Visual C++
public:
static bool CompareMemory(
    IntPtr buf1,
    IntPtr buf2,
    long long length
)

Parameters

buf1
Type: System..::.IntPtr
A pointer to a block of memory to compare.
buf2
Type: System..::.IntPtr
A pointer to a block of memory to compare.
length
Type: System..::.Int64
Specifies the number of bytes to be compared.

Return Value

true, if all bytes compare as equal, false otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CompareMemory Overload


CompareMemory Method (IntPtr, IntPtr, UInt32)

[image]

FreeImage .NET Documentation
FreeImage..::.CompareMemory Method (IntPtr, IntPtr, UInt32)
FreeImage Class See Also Send Feedback
Compares blocks of memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool CompareMemory(
    IntPtr buf1,
    IntPtr buf2,
    uint length
)
Visual Basic (Declaration)
Public Shared Function CompareMemory ( _
    buf1 As IntPtr, _
    buf2 As IntPtr, _
    length As UInteger _
) As Boolean
Visual C++
public:
static bool CompareMemory(
    IntPtr buf1,
    IntPtr buf2,
    unsigned int length
)

Parameters

buf1
Type: System..::.IntPtr
A pointer to a block of memory to compare.
buf2
Type: System..::.IntPtr
A pointer to a block of memory to compare.
length
Type: System..::.UInt32
Specifies the number of bytes to be compared.

Return Value

true, if all bytes compare as equal, false otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CompareMemory Overload


CompareMemory Method (Void*, Void*, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.CompareMemory Method (Void*, Void*, Int64)
FreeImage Class See Also Send Feedback
Compares blocks of memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool CompareMemory(
    void* buf1,
    void* buf2,
    long length
)
Visual Basic (Declaration)
Public Shared Function CompareMemory ( _
    buf1 As Void*, _
    buf2 As Void*, _
    length As Long _
) As Boolean
Visual C++
public:
static bool CompareMemory(
    void* buf1,
    void* buf2,
    long long length
)

Parameters

buf1
Type: System..::.Void *
A pointer to a block of memory to compare.
buf2
Type: System..::.Void *
A pointer to a block of memory to compare.
length
Type: System..::.Int64
Specifies the number of bytes to be compared.

Return Value

true, if all bytes compare as equal, false otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CompareMemory Overload


CompareMemory Method (Void*, Void*, UInt32)

[image]

FreeImage .NET Documentation
FreeImage..::.CompareMemory Method (Void*, Void*, UInt32)
FreeImage Class See Also Send Feedback
Compares blocks of memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool CompareMemory(
    void* buf1,
    void* buf2,
    uint length
)
Visual Basic (Declaration)
Public Shared Function CompareMemory ( _
    buf1 As Void*, _
    buf2 As Void*, _
    length As UInteger _
) As Boolean
Visual C++
public:
static bool CompareMemory(
    void* buf1,
    void* buf2,
    unsigned int length
)

Parameters

buf1
Type: System..::.Void *
A pointer to a block of memory to compare.
buf2
Type: System..::.Void *
A pointer to a block of memory to compare.
length
Type: System..::.UInt32
Specifies the number of bytes to be compared.

Return Value

true, if all bytes compare as equal, false otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CompareMemory Overload


Composite Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.Composite Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
Composite(FIBITMAP, Boolean, RGBQUAD%, FIBITMAP) | This function composite a transparent foreground image against a single background color or against a background image.
Composite(FIBITMAP, Boolean, array<RGBQUAD>[]()[], FIBITMAP) | This function composite a transparent foreground image against a single background color or against a background image.

See Also

FreeImage Class
FreeImage Members


Composite Method (FIBITMAP, Boolean, RGBQUAD, FIBITMAP)

[image]

FreeImage .NET Documentation
FreeImage..::.Composite Method (FIBITMAP, Boolean, RGBQUAD%, FIBITMAP)
FreeImage Class See Also Send Feedback
This function composite a transparent foreground image against a single background color or against a background image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Composite(
    FIBITMAP fg,
    bool useFileBkg,
    ref RGBQUAD appBkColor,
    FIBITMAP bg
)
Visual Basic (Declaration)
Public Shared Function Composite ( _
    fg As FIBITMAP, _
    useFileBkg As Boolean, _
    ByRef appBkColor As RGBQUAD, _
    bg As FIBITMAP _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Composite(
    FIBITMAP fg,
    bool useFileBkg,
    RGBQUAD% appBkColor,
    FIBITMAP bg
)

Parameters

fg
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
useFileBkg
Type: System..::.Boolean
When true the background of fg is used if it contains one.
appBkColor
Type: FreeImageAPI..::.RGBQUAD %
The application background is used if useFileBkg is false.
bg
Type: FreeImageAPI..::.FIBITMAP
Image used as background when useFileBkg is false or fg has no background and appBkColor is null.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
Composite Overload


Composite Method (FIBITMAP, Boolean, RGBQUAD[], FIBITMAP)

[image]

FreeImage .NET Documentation
FreeImage..::.Composite Method (FIBITMAP, Boolean, array<RGBQUAD>[]()[], FIBITMAP)
FreeImage Class See Also Send Feedback
This function composite a transparent foreground image against a single background color or against a background image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Composite(
    FIBITMAP fg,
    bool useFileBkg,
    RGBQUAD[] appBkColor,
    FIBITMAP bg
)
Visual Basic (Declaration)
Public Shared Function Composite ( _
    fg As FIBITMAP, _
    useFileBkg As Boolean, _
    appBkColor As RGBQUAD(), _
    bg As FIBITMAP _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Composite(
    FIBITMAP fg,
    bool useFileBkg,
    array<RGBQUAD>^ appBkColor,
    FIBITMAP bg
)

Parameters

fg
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
useFileBkg
Type: System..::.Boolean
When true the background of fg is used if it contains one.
appBkColor
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The application background is used if useFileBkg is false and 'appBkColor' is not null.
bg
Type: FreeImageAPI..::.FIBITMAP
Image used as background when useFileBkg is false or fg has no background and appBkColor is null.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
Composite Overload


ConvertColorDepth Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.ConvertColorDepth Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
ConvertColorDepth(FIBITMAP, FREE_IMAGE_COLOR_DEPTH) | Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.
ConvertColorDepth(FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_DITHER) | Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.
ConvertColorDepth(FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_QUANTIZE) | Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.
ConvertColorDepth(FIBITMAP, FREE_IMAGE_COLOR_DEPTH, Boolean) | Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.
ConvertColorDepth(FIBITMAP, FREE_IMAGE_COLOR_DEPTH, Byte) | Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.
ConvertColorDepth(FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_DITHER, Boolean) | Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.
ConvertColorDepth(FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_QUANTIZE, Boolean) | Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.
ConvertColorDepth(FIBITMAP, FREE_IMAGE_COLOR_DEPTH, Byte, Boolean) | Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.

See Also

FreeImage Class
FreeImage Members


ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH)
FreeImage Class See Also Send Feedback
Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion
)
Visual Basic (Declaration)
Public Shared Function ConvertColorDepth ( _
    dib As FIBITMAP, _
    conversion As FREE_IMAGE_COLOR_DEPTH _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
conversion
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
The desired output format.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertColorDepth Overload


ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_DITHER)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_DITHER)
FreeImage Class See Also Send Feedback
Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    FREE_IMAGE_DITHER ditherMethod
)
Visual Basic (Declaration)
Public Shared Function ConvertColorDepth ( _
    dib As FIBITMAP, _
    conversion As FREE_IMAGE_COLOR_DEPTH, _
    ditherMethod As FREE_IMAGE_DITHER _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    FREE_IMAGE_DITHER ditherMethod
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
conversion
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
The desired output format.
ditherMethod
Type: FreeImageAPI..::.FREE_IMAGE_DITHER
Dither algorithm when converting with FICD_01_BPP_DITHER.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertColorDepth Overload


ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_QUANTIZE)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_QUANTIZE)
FreeImage Class See Also Send Feedback
Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    FREE_IMAGE_QUANTIZE quantizationMethod
)
Visual Basic (Declaration)
Public Shared Function ConvertColorDepth ( _
    dib As FIBITMAP, _
    conversion As FREE_IMAGE_COLOR_DEPTH, _
    quantizationMethod As FREE_IMAGE_QUANTIZE _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    FREE_IMAGE_QUANTIZE quantizationMethod
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
conversion
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
The desired output format.
quantizationMethod
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
The quantization algorithm for conversion to 8-bit color depth.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertColorDepth Overload


ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, Boolean)
FreeImage Class See Also Send Feedback
Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    bool unloadSource
)
Visual Basic (Declaration)
Public Shared Function ConvertColorDepth ( _
    dib As FIBITMAP, _
    conversion As FREE_IMAGE_COLOR_DEPTH, _
    unloadSource As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    bool unloadSource
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
conversion
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
The desired output format.
unloadSource
Type: System..::.Boolean
When true the structure will be unloaded on success.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertColorDepth Overload


ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, Byte)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, Byte)
FreeImage Class See Also Send Feedback
Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    byte threshold
)
Visual Basic (Declaration)
Public Shared Function ConvertColorDepth ( _
    dib As FIBITMAP, _
    conversion As FREE_IMAGE_COLOR_DEPTH, _
    threshold As Byte _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    unsigned char threshold
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
conversion
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
The desired output format.
threshold
Type: System..::.Byte
Threshold value when converting with FICD_01_BPP_THRESHOLD.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertColorDepth Overload


ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_DITHER, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_DITHER, Boolean)
FreeImage Class See Also Send Feedback
Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    FREE_IMAGE_DITHER ditherMethod,
    bool unloadSource
)
Visual Basic (Declaration)
Public Shared Function ConvertColorDepth ( _
    dib As FIBITMAP, _
    conversion As FREE_IMAGE_COLOR_DEPTH, _
    ditherMethod As FREE_IMAGE_DITHER, _
    unloadSource As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    FREE_IMAGE_DITHER ditherMethod,
    bool unloadSource
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
conversion
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
The desired output format.
ditherMethod
Type: FreeImageAPI..::.FREE_IMAGE_DITHER
Dither algorithm when converting with FICD_01_BPP_DITHER.
unloadSource
Type: System..::.Boolean
When true the structure will be unloaded on success.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertColorDepth Overload


ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_QUANTIZE, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, FREE_IMAGE_QUANTIZE, Boolean)
FreeImage Class See Also Send Feedback
Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    FREE_IMAGE_QUANTIZE quantizationMethod,
    bool unloadSource
)
Visual Basic (Declaration)
Public Shared Function ConvertColorDepth ( _
    dib As FIBITMAP, _
    conversion As FREE_IMAGE_COLOR_DEPTH, _
    quantizationMethod As FREE_IMAGE_QUANTIZE, _
    unloadSource As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    FREE_IMAGE_QUANTIZE quantizationMethod,
    bool unloadSource
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
conversion
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
The desired output format.
quantizationMethod
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
The quantization algorithm for conversion to 8-bit color depth.
unloadSource
Type: System..::.Boolean
When true the structure will be unloaded on success.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertColorDepth Overload


ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, Byte, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertColorDepth Method (FIBITMAP, FREE_IMAGE_COLOR_DEPTH, Byte, Boolean)
FreeImage Class See Also Send Feedback
Converts a FreeImage bitmap from one color depth to another. If the conversion fails the original FreeImage bitmap is returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    byte threshold,
    bool unloadSource
)
Visual Basic (Declaration)
Public Shared Function ConvertColorDepth ( _
    dib As FIBITMAP, _
    conversion As FREE_IMAGE_COLOR_DEPTH, _
    threshold As Byte, _
    unloadSource As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertColorDepth(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_DEPTH conversion,
    unsigned char threshold,
    bool unloadSource
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
conversion
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
The desired output format.
threshold
Type: System..::.Byte
Threshold value when converting with FICD_01_BPP_THRESHOLD.
unloadSource
Type: System..::.Boolean
When true the structure will be unloaded on success.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertColorDepth Overload


ConvertFromRawBits Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.ConvertFromRawBits Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
ConvertFromRawBits(array<Byte>[]()[], FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean) | Converts a raw bitmap to a FreeImage bitmap.
ConvertFromRawBits(IntPtr, FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean) | Converts a raw bitmap to a FreeImage bitmap.
ConvertFromRawBits(IntPtr, Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean) | Converts a raw bitmap to a FreeImage bitmap.
ConvertFromRawBits(array<Byte>[]()[], Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean) | Converts a raw bitmap to a FreeImage bitmap.

See Also

FreeImage Class
FreeImage Members


ConvertFromRawBits Method (Byte[], FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertFromRawBits Method (array<Byte>[]()[], FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)
FreeImage Class See Also Send Feedback
Converts a raw bitmap to a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertFromRawBits(
    byte[] bits,
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int pitch,
    uint bpp,
    uint red_mask,
    uint green_mask,
    uint blue_mask,
    bool topdown
)
Visual Basic (Declaration)
Public Shared Function ConvertFromRawBits ( _
    bits As Byte(), _
    type As FREE_IMAGE_TYPE, _
    width As Integer, _
    height As Integer, _
    pitch As Integer, _
    bpp As UInteger, _
    red_mask As UInteger, _
    green_mask As UInteger, _
    blue_mask As UInteger, _
    topdown As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertFromRawBits(
    array<unsigned char>^ bits,
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int pitch,
    unsigned int bpp,
    unsigned int red_mask,
    unsigned int green_mask,
    unsigned int blue_mask,
    bool topdown
)

Parameters

bits
Type: array< System..::.Byte >[]()[]
Array of bytes containing the raw bitmap.
type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
The type of the raw bitmap.
width
Type: System..::.Int32
The width in pixels of the raw bitmap.
height
Type: System..::.Int32
The height in pixels of the raw bitmap.
pitch
Type: System..::.Int32
Defines the total width of a scanline in the raw bitmap, including padding bytes.
bpp
Type: System..::.UInt32
The bit depth (bits per pixel) of the raw bitmap.
red_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's red component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
green_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's green component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
blue_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's blue component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
topdown
Type: System..::.Boolean
If true, the raw bitmap is stored in top-down order (top-left pixel first) and in bottom-up order (bottom-left pixel first) otherwise.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertFromRawBits Overload


ConvertFromRawBits Method (IntPtr, FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertFromRawBits Method (IntPtr, FREE_IMAGE_TYPE, Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)
FreeImage Class See Also Send Feedback
Converts a raw bitmap to a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertFromRawBits(
    IntPtr bits,
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int pitch,
    uint bpp,
    uint red_mask,
    uint green_mask,
    uint blue_mask,
    bool topdown
)
Visual Basic (Declaration)
Public Shared Function ConvertFromRawBits ( _
    bits As IntPtr, _
    type As FREE_IMAGE_TYPE, _
    width As Integer, _
    height As Integer, _
    pitch As Integer, _
    bpp As UInteger, _
    red_mask As UInteger, _
    green_mask As UInteger, _
    blue_mask As UInteger, _
    topdown As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertFromRawBits(
    IntPtr bits,
    FREE_IMAGE_TYPE type,
    int width,
    int height,
    int pitch,
    unsigned int bpp,
    unsigned int red_mask,
    unsigned int green_mask,
    unsigned int blue_mask,
    bool topdown
)

Parameters

bits
Type: System..::.IntPtr
Pointer to the memory block containing the raw bitmap.
type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
The type of the raw bitmap.
width
Type: System..::.Int32
The width in pixels of the raw bitmap.
height
Type: System..::.Int32
The height in pixels of the raw bitmap.
pitch
Type: System..::.Int32
Defines the total width of a scanline in the raw bitmap, including padding bytes.
bpp
Type: System..::.UInt32
The bit depth (bits per pixel) of the raw bitmap.
red_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's red component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
green_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's green component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
blue_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's blue component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
topdown
Type: System..::.Boolean
If true, the raw bitmap is stored in top-down order (top-left pixel first) and in bottom-up order (bottom-left pixel first) otherwise.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertFromRawBits Overload


ConvertFromRawBits Method (IntPtr, Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertFromRawBits Method (IntPtr, Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)
FreeImage Class See Also Send Feedback
Converts a raw bitmap to a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertFromRawBits(
    IntPtr bits,
    int width,
    int height,
    int pitch,
    uint bpp,
    uint red_mask,
    uint green_mask,
    uint blue_mask,
    bool topdown
)
Visual Basic (Declaration)
Public Shared Function ConvertFromRawBits ( _
    bits As IntPtr, _
    width As Integer, _
    height As Integer, _
    pitch As Integer, _
    bpp As UInteger, _
    red_mask As UInteger, _
    green_mask As UInteger, _
    blue_mask As UInteger, _
    topdown As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertFromRawBits(
    IntPtr bits,
    int width,
    int height,
    int pitch,
    unsigned int bpp,
    unsigned int red_mask,
    unsigned int green_mask,
    unsigned int blue_mask,
    bool topdown
)

Parameters

bits
Type: System..::.IntPtr
Pointer to the memory block containing the raw bitmap.
width
Type: System..::.Int32
The width in pixels of the raw bitmap.
height
Type: System..::.Int32
The height in pixels of the raw bitmap.
pitch
Type: System..::.Int32
Defines the total width of a scanline in the raw bitmap, including padding bytes.
bpp
Type: System..::.UInt32
The bit depth (bits per pixel) of the raw bitmap.
red_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's red component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
green_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's green component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
blue_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's blue component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
topdown
Type: System..::.Boolean
If true, the raw bitmap is stored in top-down order (top-left pixel first) and in bottom-up order (bottom-left pixel first) otherwise.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertFromRawBits Overload


ConvertFromRawBits Method (Byte[], Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertFromRawBits Method (array<Byte>[]()[], Int32, Int32, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)
FreeImage Class See Also Send Feedback
Converts a raw bitmap to a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertFromRawBits(
    byte[] bits,
    int width,
    int height,
    int pitch,
    uint bpp,
    uint red_mask,
    uint green_mask,
    uint blue_mask,
    bool topdown
)
Visual Basic (Declaration)
Public Shared Function ConvertFromRawBits ( _
    bits As Byte(), _
    width As Integer, _
    height As Integer, _
    pitch As Integer, _
    bpp As UInteger, _
    red_mask As UInteger, _
    green_mask As UInteger, _
    blue_mask As UInteger, _
    topdown As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertFromRawBits(
    array<unsigned char>^ bits,
    int width,
    int height,
    int pitch,
    unsigned int bpp,
    unsigned int red_mask,
    unsigned int green_mask,
    unsigned int blue_mask,
    bool topdown
)

Parameters

bits
Type: array< System..::.Byte >[]()[]
Array of bytes containing the raw bitmap.
width
Type: System..::.Int32
The width in pixels of the raw bitmap.
height
Type: System..::.Int32
The height in pixels of the raw bitmap.
pitch
Type: System..::.Int32
Defines the total width of a scanline in the raw bitmap, including padding bytes.
bpp
Type: System..::.UInt32
The bit depth (bits per pixel) of the raw bitmap.
red_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's red component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
green_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's green component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
blue_mask
Type: System..::.UInt32
The bit mask describing the bits used to store a single pixel's blue component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
topdown
Type: System..::.Boolean
If true, the raw bitmap is stored in top-down order (top-left pixel first) and in bottom-up order (bottom-left pixel first) otherwise.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertFromRawBits Overload


ConvertTo16Bits555 Method

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertTo16Bits555 Method
FreeImage Class See Also Send Feedback
Converts a bitmap to 16 bits, where each pixel has a color pattern of 5 bits red, 5 bits green and 5 bits blue. One bit in each pixel is unused.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertTo16Bits555(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function ConvertTo16Bits555 ( _
    dib As FIBITMAP _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertTo16Bits555(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ConvertTo16Bits565 Method

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertTo16Bits565 Method
FreeImage Class See Also Send Feedback
Converts a bitmap to 16 bits, where each pixel has a color pattern of 5 bits red, 6 bits green and 5 bits blue.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertTo16Bits565(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function ConvertTo16Bits565 ( _
    dib As FIBITMAP _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertTo16Bits565(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ConvertTo24Bits Method

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertTo24Bits Method
FreeImage Class See Also Send Feedback
Converts a bitmap to 24 bits. A clone of the input bitmap is returned for 24-bit bitmaps.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertTo24Bits(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function ConvertTo24Bits ( _
    dib As FIBITMAP _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertTo24Bits(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ConvertTo32Bits Method

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertTo32Bits Method
FreeImage Class See Also Send Feedback
Converts a bitmap to 32 bits. A clone of the input bitmap is returned for 32-bit bitmaps.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertTo32Bits(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function ConvertTo32Bits ( _
    dib As FIBITMAP _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertTo32Bits(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ConvertTo4Bits Method

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertTo4Bits Method
FreeImage Class See Also Send Feedback
Converts a bitmap to 4 bits. If the bitmap was a high-color bitmap (16, 24 or 32-bit) or if it was a monochrome or greyscale bitmap (1 or 8-bit), the end result will be a greyscale bitmap, otherwise (1-bit palletised bitmaps) it will be a palletised bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertTo4Bits(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function ConvertTo4Bits ( _
    dib As FIBITMAP _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertTo4Bits(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ConvertTo8Bits Method

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertTo8Bits Method
FreeImage Class See Also Send Feedback
Converts a bitmap to 8 bits. If the bitmap was a high-color bitmap (16, 24 or 32-bit) or if it was a monochrome or greyscale bitmap (1 or 4-bit), the end result will be a greyscale bitmap, otherwise (1 or 4-bit palletised bitmaps) it will be a palletised bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertTo8Bits(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function ConvertTo8Bits ( _
    dib As FIBITMAP _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertTo8Bits(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ConvertToGreyscale Method

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertToGreyscale Method
FreeImage Class See Also Send Feedback
Converts a bitmap to a 8-bit greyscale image with a linear ramp.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertToGreyscale(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function ConvertToGreyscale ( _
    dib As FIBITMAP _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertToGreyscale(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ConvertToRawBits Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.ConvertToRawBits Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
ConvertToRawBits(IntPtr, FIBITMAP, Int32, UInt32, UInt32, UInt32, UInt32, Boolean) | Converts a FreeImage bitmap to a raw bitmap, that is a raw piece of memory.
ConvertToRawBits(array<Byte>[]()[], FIBITMAP, Int32, UInt32, UInt32, UInt32, UInt32, Boolean) | Converts a FreeImage bitmap to a raw bitmap, that is a raw piece of memory.

See Also

FreeImage Class
FreeImage Members


ConvertToRawBits Method (IntPtr, FIBITMAP, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertToRawBits Method (IntPtr, FIBITMAP, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)
FreeImage Class See Also Send Feedback
Converts a FreeImage bitmap to a raw bitmap, that is a raw piece of memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void ConvertToRawBits(
    IntPtr bits,
    FIBITMAP dib,
    int pitch,
    uint bpp,
    uint red_mask,
    uint green_mask,
    uint blue_mask,
    bool topdown
)
Visual Basic (Declaration)
Public Shared Sub ConvertToRawBits ( _
    bits As IntPtr, _
    dib As FIBITMAP, _
    pitch As Integer, _
    bpp As UInteger, _
    red_mask As UInteger, _
    green_mask As UInteger, _
    blue_mask As UInteger, _
    topdown As Boolean _
)
Visual C++
public:
static void ConvertToRawBits(
    IntPtr bits,
    FIBITMAP dib,
    int pitch,
    unsigned int bpp,
    unsigned int red_mask,
    unsigned int green_mask,
    unsigned int blue_mask,
    bool topdown
)

Parameters

bits
Type: System..::.IntPtr
Pointer to the memory block receiving the raw bitmap.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
pitch
Type: System..::.Int32
The desired total width in bytes of a scanline in the raw bitmap, including any padding bytes.
bpp
Type: System..::.UInt32
The desired bit depth (bits per pixel) of the raw bitmap.
red_mask
Type: System..::.UInt32
The desired bit mask describing the bits used to store a single pixel's red component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
green_mask
Type: System..::.UInt32
The desired bit mask describing the bits used to store a single pixel's green component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
blue_mask
Type: System..::.UInt32
The desired bit mask describing the bits used to store a single pixel's blue component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
topdown
Type: System..::.Boolean
If true, the raw bitmap will be stored in top-down order (top-left pixel first) and in bottom-up order (bottom-left pixel first) otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertToRawBits Overload


ConvertToRawBits Method (Byte[], FIBITMAP, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertToRawBits Method (array<Byte>[]()[], FIBITMAP, Int32, UInt32, UInt32, UInt32, UInt32, Boolean)
FreeImage Class See Also Send Feedback
Converts a FreeImage bitmap to a raw bitmap, that is a raw piece of memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void ConvertToRawBits(
    byte[] bits,
    FIBITMAP dib,
    int pitch,
    uint bpp,
    uint red_mask,
    uint green_mask,
    uint blue_mask,
    bool topdown
)
Visual Basic (Declaration)
Public Shared Sub ConvertToRawBits ( _
    bits As Byte(), _
    dib As FIBITMAP, _
    pitch As Integer, _
    bpp As UInteger, _
    red_mask As UInteger, _
    green_mask As UInteger, _
    blue_mask As UInteger, _
    topdown As Boolean _
)
Visual C++
public:
static void ConvertToRawBits(
    array<unsigned char>^ bits,
    FIBITMAP dib,
    int pitch,
    unsigned int bpp,
    unsigned int red_mask,
    unsigned int green_mask,
    unsigned int blue_mask,
    bool topdown
)

Parameters

bits
Type: array< System..::.Byte >[]()[]
Array of bytes receiving the raw bitmap.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
pitch
Type: System..::.Int32
The desired total width in bytes of a scanline in the raw bitmap, including any padding bytes.
bpp
Type: System..::.UInt32
The desired bit depth (bits per pixel) of the raw bitmap.
red_mask
Type: System..::.UInt32
The desired bit mask describing the bits used to store a single pixel's red component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
green_mask
Type: System..::.UInt32
The desired bit mask describing the bits used to store a single pixel's green component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
blue_mask
Type: System..::.UInt32
The desired bit mask describing the bits used to store a single pixel's blue component in the raw bitmap. This is only applied to 16-bpp raw bitmaps.
topdown
Type: System..::.Boolean
If true, the raw bitmap will be stored in top-down order (top-left pixel first) and in bottom-up order (bottom-left pixel first) otherwise.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
ConvertToRawBits Overload


ConvertToRGBF Method

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertToRGBF Method
FreeImage Class See Also Send Feedback
Converts a 24- or 32-bit RGB(A) standard image or a 48-bit RGB image to a FIT_RGBF type image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertToRGBF(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function ConvertToRGBF ( _
    dib As FIBITMAP _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertToRGBF(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ConvertToStandardType Method

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertToStandardType Method
FreeImage Class See Also Send Feedback
Converts a non standard image whose color type is FIC_MINISBLACK to a standard 8-bit greyscale image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertToStandardType(
    FIBITMAP src,
    bool scale_linear
)
Visual Basic (Declaration)
Public Shared Function ConvertToStandardType ( _
    src As FIBITMAP, _
    scale_linear As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertToStandardType(
    FIBITMAP src,
    bool scale_linear
)

Parameters

src
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
scale_linear
Type: System..::.Boolean
When true the conversion is done by scaling linearly each pixel value from [min, max] to an integer value between [0..255], where min and max are the minimum and maximum pixel values in the image. When false the conversion is done by rounding each pixel value to an integer between [0..255]. Rounding is done using the following formula: dst_pixel = (BYTE) MIN(255, MAX(0, q)) where int q = int(src_pixel + 0.5);

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ConvertToType Method

[image]

FreeImage .NET Documentation
FreeImage..::.ConvertToType Method
FreeImage Class See Also Send Feedback
Converts an image of any type to type dst_type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ConvertToType(
    FIBITMAP src,
    FREE_IMAGE_TYPE dst_type,
    bool scale_linear
)
Visual Basic (Declaration)
Public Shared Function ConvertToType ( _
    src As FIBITMAP, _
    dst_type As FREE_IMAGE_TYPE, _
    scale_linear As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ConvertToType(
    FIBITMAP src,
    FREE_IMAGE_TYPE dst_type,
    bool scale_linear
)

Parameters

src
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
dst_type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
Destination type.
scale_linear
Type: System..::.Boolean
True to scale linear, else false.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Copy Method

[image]

FreeImage .NET Documentation
FreeImage..::.Copy Method
FreeImage Class See Also Send Feedback
Copy a sub part of the current dib image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Copy(
    FIBITMAP dib,
    int left,
    int top,
    int right,
    int bottom
)
Visual Basic (Declaration)
Public Shared Function Copy ( _
    dib As FIBITMAP, _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Copy(
    FIBITMAP dib,
    int left,
    int top,
    int right,
    int bottom
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
left
Type: System..::.Int32
Specifies the left position of the cropped rectangle.
top
Type: System..::.Int32
Specifies the top position of the cropped rectangle.
right
Type: System..::.Int32
Specifies the right position of the cropped rectangle.
bottom
Type: System..::.Int32
Specifies the bottom position of the cropped rectangle.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


CopyMemory Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
CopyMemory(Byte*, Byte*, Int32) | Copies a block of memory from one location to another.
CopyMemory(IntPtr, IntPtr, Int32) | Copies a block of memory from one location to another.
CopyMemory(IntPtr, IntPtr, Int64) | Copies a block of memory from one location to another.
CopyMemory(Void*, Void*, Int32) | Copies a block of memory from one location to another.
CopyMemory(Void*, Void*, Int64) | Copies a block of memory from one location to another.
CopyMemory(Array, Array, Int32) | Copies the content of one array into another array.
CopyMemory(Array, Array, Int64) | Copies the content of one array into another array.
CopyMemory(Array, IntPtr, Int32) | Copies a block of memory into an array.
CopyMemory(Array, IntPtr, Int64) | Copies a block of memory into an array.
CopyMemory(Array, Void*, Int32) | Copies a block of memory into an array.
CopyMemory(Array, Void*, Int64) | Copies a block of memory into an array.
CopyMemory(Byte*, Byte*, Int64) | Copies a block of memory from one location to another.
CopyMemory(IntPtr, Array, Int32) | Copies the content of an array to a memory location.
CopyMemory(IntPtr, Array, Int64) | Copies the content of an array to a memory location.
CopyMemory(Void*, Array, Int32) | Copies the content of an array to a memory location.
CopyMemory(Void*, Array, Int64) | Copies the content of an array to a memory location.

See Also

FreeImage Class
FreeImage Members


CopyMemory Method (Byte*, Byte*, Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Byte*, Byte*, Int32)
FreeImage Class See Also Send Feedback
Copies a block of memory from one location to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    byte* dest,
    byte* src,
    int len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Byte*, _
    src As Byte*, _
    len As Integer _
)
Visual C++
public:
static void CopyMemory(
    unsigned char* dest,
    unsigned char* src,
    int len
)

Parameters

dest
Type: System..::.Byte *
A pointer to the starting address of the copied block's destination.
src
Type: System..::.Byte *
A pointer to the starting address of the block of memory to copy.
len
Type: System..::.Int32
The size of the block of memory to copy, in bytes.

Remarks

CopyMemory runs faster than MoveMemory(Void*, Void*, UInt32). However, if both blocks overlap the result is undefined.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (IntPtr, IntPtr, Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (IntPtr, IntPtr, Int32)
FreeImage Class See Also Send Feedback
Copies a block of memory from one location to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    IntPtr dest,
    IntPtr src,
    int size
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As IntPtr, _
    src As IntPtr, _
    size As Integer _
)
Visual C++
public:
static void CopyMemory(
    IntPtr dest,
    IntPtr src,
    int size
)

Parameters

dest
Type: System..::.IntPtr
A pointer to the starting address of the copied block's destination.
src
Type: System..::.IntPtr
A pointer to the starting address of the block of memory to copy.
size
Type: System..::.Int32

Remarks

CopyMemory runs faster than MoveMemory(IntPtr, IntPtr, UInt32). However, if both blocks overlap the result is undefined.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (IntPtr, IntPtr, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (IntPtr, IntPtr, Int64)
FreeImage Class See Also Send Feedback
Copies a block of memory from one location to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    IntPtr dest,
    IntPtr src,
    long size
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As IntPtr, _
    src As IntPtr, _
    size As Long _
)
Visual C++
public:
static void CopyMemory(
    IntPtr dest,
    IntPtr src,
    long long size
)

Parameters

dest
Type: System..::.IntPtr
A pointer to the starting address of the copied block's destination.
src
Type: System..::.IntPtr
A pointer to the starting address of the block of memory to copy.
size
Type: System..::.Int64

Remarks

CopyMemory runs faster than MoveMemory(IntPtr, IntPtr, Int64). However, if both blocks overlap the result is undefined.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (Void*, Void*, Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Void*, Void*, Int32)
FreeImage Class See Also Send Feedback
Copies a block of memory from one location to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    void* dest,
    void* src,
    int size
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Void*, _
    src As Void*, _
    size As Integer _
)
Visual C++
public:
static void CopyMemory(
    void* dest,
    void* src,
    int size
)

Parameters

dest
Type: System..::.Void *
A pointer to the starting address of the copied block's destination.
src
Type: System..::.Void *
A pointer to the starting address of the block of memory to copy.
size
Type: System..::.Int32

Remarks

CopyMemory runs faster than MoveMemory(Void*, Void*, UInt32). However, if both blocks overlap the result is undefined.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (Void*, Void*, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Void*, Void*, Int64)
FreeImage Class See Also Send Feedback
Copies a block of memory from one location to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    void* dest,
    void* src,
    long size
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Void*, _
    src As Void*, _
    size As Long _
)
Visual C++
public:
static void CopyMemory(
    void* dest,
    void* src,
    long long size
)

Parameters

dest
Type: System..::.Void *
A pointer to the starting address of the copied block's destination.
src
Type: System..::.Void *
A pointer to the starting address of the block of memory to copy.
size
Type: System..::.Int64

Remarks

CopyMemory runs faster than MoveMemory(Void*, Void*, Int64). However, if both blocks overlap the result is undefined.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (Array, Array, Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Array, Array, Int32)
FreeImage Class See Also Send Feedback
Copies the content of one array into another array.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    Array dest,
    Array src,
    int len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Array, _
    src As Array, _
    len As Integer _
)
Visual C++
public:
static void CopyMemory(
    Array^ dest,
    Array^ src,
    int len
)

Parameters

dest
Type: System..::.Array
An array used as the destination of the copy process.
src
Type: System..::.Array
An array used as the source of the copy process.
len
Type: System..::.Int32
The size of the content to copy, in bytes.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (Array, Array, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Array, Array, Int64)
FreeImage Class See Also Send Feedback
Copies the content of one array into another array.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    Array dest,
    Array src,
    long len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Array, _
    src As Array, _
    len As Long _
)
Visual C++
public:
static void CopyMemory(
    Array^ dest,
    Array^ src,
    long long len
)

Parameters

dest
Type: System..::.Array
An array used as the destination of the copy process.
src
Type: System..::.Array
An array used as the source of the copy process.
len
Type: System..::.Int64
The size of the content to copy, in bytes.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (Array, IntPtr, Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Array, IntPtr, Int32)
FreeImage Class See Also Send Feedback
Copies a block of memory into an array.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    Array dest,
    IntPtr src,
    int len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Array, _
    src As IntPtr, _
    len As Integer _
)
Visual C++
public:
static void CopyMemory(
    Array^ dest,
    IntPtr src,
    int len
)

Parameters

dest
Type: System..::.Array
An array used as the destination of the copy process.
src
Type: System..::.IntPtr
A pointer to the starting address of the block of memory to copy.
len
Type: System..::.Int32
The size of the block of memory to copy, in bytes.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (Array, IntPtr, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Array, IntPtr, Int64)
FreeImage Class See Also Send Feedback
Copies a block of memory into an array.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    Array dest,
    IntPtr src,
    long len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Array, _
    src As IntPtr, _
    len As Long _
)
Visual C++
public:
static void CopyMemory(
    Array^ dest,
    IntPtr src,
    long long len
)

Parameters

dest
Type: System..::.Array
An array used as the destination of the copy process.
src
Type: System..::.IntPtr
A pointer to the starting address of the block of memory to copy.
len
Type: System..::.Int64
The size of the block of memory to copy, in bytes.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (Array, Void*, Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Array, Void*, Int32)
FreeImage Class See Also Send Feedback
Copies a block of memory into an array.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    Array dest,
    void* src,
    int len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Array, _
    src As Void*, _
    len As Integer _
)
Visual C++
public:
static void CopyMemory(
    Array^ dest,
    void* src,
    int len
)

Parameters

dest
Type: System..::.Array
An array used as the destination of the copy process.
src
Type: System..::.Void *
A pointer to the starting address of the block of memory to copy.
len
Type: System..::.Int32
The size of the block of memory to copy, in bytes.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (Array, Void*, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Array, Void*, Int64)
FreeImage Class See Also Send Feedback
Copies a block of memory into an array.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    Array dest,
    void* src,
    long len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Array, _
    src As Void*, _
    len As Long _
)
Visual C++
public:
static void CopyMemory(
    Array^ dest,
    void* src,
    long long len
)

Parameters

dest
Type: System..::.Array
An array used as the destination of the copy process.
src
Type: System..::.Void *
A pointer to the starting address of the block of memory to copy.
len
Type: System..::.Int64
The size of the block of memory to copy, in bytes.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (Byte*, Byte*, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Byte*, Byte*, Int64)
FreeImage Class See Also Send Feedback
Copies a block of memory from one location to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    byte* dest,
    byte* src,
    long len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Byte*, _
    src As Byte*, _
    len As Long _
)
Visual C++
public:
static void CopyMemory(
    unsigned char* dest,
    unsigned char* src,
    long long len
)

Parameters

dest
Type: System..::.Byte *
A pointer to the starting address of the copied block's destination.
src
Type: System..::.Byte *
A pointer to the starting address of the block of memory to copy.
len
Type: System..::.Int64
The size of the block of memory to copy, in bytes.

Remarks

CopyMemory runs faster than MoveMemory(Void*, Void*, Int64). However, if both blocks overlap the result is undefined.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (IntPtr, Array, Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (IntPtr, Array, Int32)
FreeImage Class See Also Send Feedback
Copies the content of an array to a memory location.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    IntPtr dest,
    Array src,
    int len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As IntPtr, _
    src As Array, _
    len As Integer _
)
Visual C++
public:
static void CopyMemory(
    IntPtr dest,
    Array^ src,
    int len
)

Parameters

dest
Type: System..::.IntPtr
A pointer to the starting address of the copied block's destination.
src
Type: System..::.Array
An array used as the source of the copy process.
len
Type: System..::.Int32
The size of the block of memory to copy, in bytes.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (IntPtr, Array, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (IntPtr, Array, Int64)
FreeImage Class See Also Send Feedback
Copies the content of an array to a memory location.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    IntPtr dest,
    Array src,
    long len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As IntPtr, _
    src As Array, _
    len As Long _
)
Visual C++
public:
static void CopyMemory(
    IntPtr dest,
    Array^ src,
    long long len
)

Parameters

dest
Type: System..::.IntPtr
A pointer to the starting address of the copied block's destination.
src
Type: System..::.Array
An array used as the source of the copy process.
len
Type: System..::.Int64
The size of the block of memory to copy, in bytes.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (Void*, Array, Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Void*, Array, Int32)
FreeImage Class See Also Send Feedback
Copies the content of an array to a memory location.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    void* dest,
    Array src,
    int len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Void*, _
    src As Array, _
    len As Integer _
)
Visual C++
public:
static void CopyMemory(
    void* dest,
    Array^ src,
    int len
)

Parameters

dest
Type: System..::.Void *
A pointer to the starting address of the copied block's destination.
src
Type: System..::.Array
An array used as the source of the copy process.
len
Type: System..::.Int32
The size of the block of memory to copy, in bytes.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CopyMemory Method (Void*, Array, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.CopyMemory Method (Void*, Array, Int64)
FreeImage Class See Also Send Feedback
Copies the content of an array to a memory location.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void CopyMemory(
    void* dest,
    Array src,
    long len
)
Visual Basic (Declaration)
Public Shared Sub CopyMemory ( _
    dest As Void*, _
    src As Array, _
    len As Long _
)
Visual C++
public:
static void CopyMemory(
    void* dest,
    Array^ src,
    long long len
)

Parameters

dest
Type: System..::.Void *
A pointer to the starting address of the copied block's destination.
src
Type: System..::.Array
An array used as the source of the copy process.
len
Type: System..::.Int64
The size of the block of memory to copy, in bytes.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CopyMemory Overload


CreateFromBitmap Method

[image]

FreeImage .NET Documentation
FreeImage..::.CreateFromBitmap Method
FreeImage Class See Also Send Feedback
Converts an .NET Bitmap into a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP CreateFromBitmap(
    Bitmap bitmap
)
Visual Basic (Declaration)
Public Shared Function CreateFromBitmap ( _
    bitmap As Bitmap _
) As FIBITMAP
Visual C++
public:
static FIBITMAP CreateFromBitmap(
    Bitmap^ bitmap
)

Parameters

bitmap
Type: System.Drawing..::.Bitmap
The Bitmap to convert.

Return Value

Handle to a FreeImage bitmap.

Remarks

Copying metadata has been disabled until a proper way of reading and storing metadata in a .NET bitmap is found.

Exceptions

Exception | Condition
System..::.ArgumentNullException | bitmap is null.
System..::.ArgumentException | The bitmaps pixelformat is invalid.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


CreateFromHbitmap Method

[image]

FreeImage .NET Documentation
FreeImage..::.CreateFromHbitmap Method
FreeImage Class See Also Send Feedback
Creates a FreeImage DIB from a Device Context/Compatible Bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP CreateFromHbitmap(
    IntPtr hbitmap,
    IntPtr hdc
)
Visual Basic (Declaration)
Public Shared Function CreateFromHbitmap ( _
    hbitmap As IntPtr, _
    hdc As IntPtr _
) As FIBITMAP
Visual C++
public:
static FIBITMAP CreateFromHbitmap(
    IntPtr hbitmap,
    IntPtr hdc
)

Parameters

hbitmap
Type: System..::.IntPtr
Handle to the bitmap.
hdc
Type: System..::.IntPtr
Handle to a device context.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | hbitmap is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


CreateICCProfile Method

[image]

FreeImage .NET Documentation
FreeImage..::.CreateICCProfile Method
FreeImage Class See Also Send Feedback
Creates a new FIICCPROFILE block from ICC profile data previously read from a file or built by a color management system. The profile data is attached to the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static IntPtr CreateICCProfile(
    FIBITMAP dib,
    byte[] data,
    int size
)
Visual Basic (Declaration)
Public Shared Function CreateICCProfile ( _
    dib As FIBITMAP, _
    data As Byte(), _
    size As Integer _
) As IntPtr
Visual C++
public:
static IntPtr CreateICCProfile(
    FIBITMAP dib,
    array<unsigned char>^ data,
    int size
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
data
Type: array< System..::.Byte >[]()[]
Pointer to the new FIICCPROFILE data.
size
Type: System..::.Int32
Size of the FIICCPROFILE data.

Return Value

Pointer to the created FIICCPROFILE structure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


CreateICCProfileEx Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.CreateICCProfileEx Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
CreateICCProfileEx(FIBITMAP, array<Byte>[]()[]) | Creates a new ICC-Profile for a FreeImage bitmap.
CreateICCProfileEx(FIBITMAP, array<Byte>[]()[], Int32) | Creates a new ICC-Profile for a FreeImage bitmap.

See Also

FreeImage Class
FreeImage Members


CreateICCProfileEx Method (FIBITMAP, Byte[])

[image]

FreeImage .NET Documentation
FreeImage..::.CreateICCProfileEx Method (FIBITMAP, array<Byte>[]()[])
FreeImage Class See Also Send Feedback
Creates a new ICC-Profile for a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIICCPROFILE CreateICCProfileEx(
    FIBITMAP dib,
    byte[] data
)
Visual Basic (Declaration)
Public Shared Function CreateICCProfileEx ( _
    dib As FIBITMAP, _
    data As Byte() _
) As FIICCPROFILE
Visual C++
public:
static FIICCPROFILE CreateICCProfileEx(
    FIBITMAP dib,
    array<unsigned char>^ data
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
data
Type: array< System..::.Byte >[]()[]
The data of the new ICC-Profile.

Return Value

The new ICC-Profile of the bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CreateICCProfileEx Overload


CreateICCProfileEx Method (FIBITMAP, Byte[], Int32)

[image]

FreeImage .NET Documentation
FreeImage..::.CreateICCProfileEx Method (FIBITMAP, array<Byte>[]()[], Int32)
FreeImage Class See Also Send Feedback
Creates a new ICC-Profile for a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIICCPROFILE CreateICCProfileEx(
    FIBITMAP dib,
    byte[] data,
    int size
)
Visual Basic (Declaration)
Public Shared Function CreateICCProfileEx ( _
    dib As FIBITMAP, _
    data As Byte(), _
    size As Integer _
) As FIICCPROFILE
Visual C++
public:
static FIICCPROFILE CreateICCProfileEx(
    FIBITMAP dib,
    array<unsigned char>^ data,
    int size
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
data
Type: array< System..::.Byte >[]()[]
The data of the new ICC-Profile.
size
Type: System..::.Int32
The number of bytes of data to use.

Return Value

The new ICC-Profile of the FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
CreateICCProfileEx Overload


CreateTag Method

[image]

FreeImage .NET Documentation
FreeImage..::.CreateTag Method
FreeImage Class See Also Send Feedback
Allocates a new FITAG object. This object must be destroyed with a call to DeleteTag(FITAG) when no longer in use.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FITAG CreateTag()
Visual Basic (Declaration)
Public Shared Function CreateTag As FITAG
Visual C++
public:
static FITAG CreateTag()

Return Value

The new FITAG.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


DeletePage Method

[image]

FreeImage .NET Documentation
FreeImage..::.DeletePage Method
FreeImage Class See Also Send Feedback
Deletes the page on the given position.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void DeletePage(
    FIMULTIBITMAP bitmap,
    int page
)
Visual Basic (Declaration)
Public Shared Sub DeletePage ( _
    bitmap As FIMULTIBITMAP, _
    page As Integer _
)
Visual C++
public:
static void DeletePage(
    FIMULTIBITMAP bitmap,
    int page
)

Parameters

bitmap
Type: FreeImageAPI..::.FIMULTIBITMAP
Handle to a FreeImage multi-paged bitmap.
page
Type: System..::.Int32
Number of the page to delete.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


DeleteTag Method

[image]

FreeImage .NET Documentation
FreeImage..::.DeleteTag Method
FreeImage Class See Also Send Feedback
Delete a previously allocated FITAG object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void DeleteTag(
    FITAG tag
)
Visual Basic (Declaration)
Public Shared Sub DeleteTag ( _
    tag As FITAG _
)
Visual C++
public:
static void DeleteTag(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The FITAG to destroy.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


DestroyICCProfile Method

[image]

FreeImage .NET Documentation
FreeImage..::.DestroyICCProfile Method
FreeImage Class See Also Send Feedback
This function destroys an FIICCPROFILE previously created by CreateICCProfile(FIBITMAP, array<Byte>[]()[], Int32). After this call the bitmap will contain no profile information. This function should be called to ensure that a stored bitmap will not contain any profile information.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void DestroyICCProfile(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Sub DestroyICCProfile ( _
    dib As FIBITMAP _
)
Visual C++
public:
static void DestroyICCProfile(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Dither Method

[image]

FreeImage .NET Documentation
FreeImage..::.Dither Method
FreeImage Class See Also Send Feedback
Converts a bitmap to 1-bit monochrome bitmap using a dithering algorithm. For 1-bit input bitmaps, the function clones the input bitmap and builds a monochrome palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Dither(
    FIBITMAP dib,
    FREE_IMAGE_DITHER algorithm
)
Visual Basic (Declaration)
Public Shared Function Dither ( _
    dib As FIBITMAP, _
    algorithm As FREE_IMAGE_DITHER _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Dither(
    FIBITMAP dib,
    FREE_IMAGE_DITHER algorithm
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
algorithm
Type: FreeImageAPI..::.FREE_IMAGE_DITHER
The dithering algorithm to use.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


EnlargeCanvas(T) Method

[image]

FreeImage .NET Documentation
FreeImage..::.EnlargeCanvas<(Of <(T>)>) Method
FreeImage Class Example See Also Send Feedback
Enlarges or shrinks the FreeImage bitmap selectively per side and fills newly added areas with the specified background color. See remarks for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP EnlargeCanvas<T>(
    FIBITMAP dib,
    int left,
    int top,
    int right,
    int bottom,
    Nullable<T> color,
    FREE_IMAGE_COLOR_OPTIONS options
)
where T : struct, new()
Visual Basic (Declaration)
Public Shared Function EnlargeCanvas(Of T As {Structure, New}) ( _
    dib As FIBITMAP, _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer, _
    color As Nullable(Of T), _
    options As FREE_IMAGE_COLOR_OPTIONS _
) As FIBITMAP
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
static FIBITMAP EnlargeCanvas(
    FIBITMAP dib,
    int left,
    int top,
    int right,
    int bottom,
    Nullable<T> color,
    FREE_IMAGE_COLOR_OPTIONS options
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
left
Type: System..::.Int32
The number of pixels, the image should be enlarged on its left side. Negative values shrink the image on its left side.
top
Type: System..::.Int32
The number of pixels, the image should be enlarged on its top side. Negative values shrink the image on its top side.
right
Type: System..::.Int32
The number of pixels, the image should be enlarged on its right side. Negative values shrink the image on its right side.
bottom
Type: System..::.Int32
The number of pixels, the image should be enlarged on its bottom side. Negative values shrink the image on its bottom side.
color
Type: System..::.Nullable <(Of <(T>)>)
The color, the enlarged sides of the image should be filled with.
options
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_OPTIONS
Options that affect the color search process for palletized images.

Type Parameters

T
The type of the specified color.

Return Value

Handle to a FreeImage bitmap.

Remarks

This function enlarges or shrinks an image selectively per side. The main purpose of this function is to add borders to an image. To add a border to any of the image's sides, a positive integer value must be passed in any of the parameters left, top, right or bottom. This value represents the border's width in pixels. Newly created parts of the image (the border areas) are filled with the specified color. Specifying a negative integer value for a certain side, will shrink or crop the image on this side. Consequently, specifying zero for a certain side will not change the image's extension on that side.

So, calling this function with all parameters left, top, right and bottom set to zero, is effectively the same as calling function Clone(FIBITMAP); setting all parameters left, top, right and bottom to value equal to or smaller than zero, my easily be substituted by a call to function Copy(FIBITMAP, Int32, Int32, Int32, Int32). Both these cases produce a new image, which is guaranteed not to be larger than the input image. Thus, since the specified color is not needed in these cases, color may be null.

Both parameters color and options work according to function FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS). So, please refer to the documentation of FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS) to learn more about parameters color and options. For palletized images, the palette of the input image is transparently copied to the newly created enlarged or shrunken image, so any color look-ups are performed on this palette.

Examples

// create a white color
RGBQUAD c;
c.rgbRed = 0xFF;
c.rgbGreen = 0xFF;
c.rgbBlue = 0xFF;
c.rgbReserved = 0x00;

// add a white, symmetric 10 pixel wide border to the image
dib2 = FreeImage_EnlargeCanvas(dib, 10, 10, 10, 10, c, FREE_IMAGE_COLOR_OPTIONS.FICO_RGB);

// add white, 20 pixel wide stripes to the top and bottom side of the image
dib3 = FreeImage_EnlargeCanvas(dib, 0, 20, 0, 20, c, FREE_IMAGE_COLOR_OPTIONS.FICO_RGB);

// add white, 30 pixel wide stripes to the right side of the image and
// cut off the 40 leftmost pixel columns
dib3 = FreeImage_EnlargeCanvas(dib, -40, 0, 30, 0, c, FREE_IMAGE_COLOR_OPTIONS.FICO_RGB);

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class


FIFSupportsExportBPP Method

[image]

FreeImage .NET Documentation
FreeImage..::.FIFSupportsExportBPP Method
FreeImage Class See Also Send Feedback
Checks if a plugin can save bitmaps in the desired bit depth.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FIFSupportsExportBPP(
    FREE_IMAGE_FORMAT fif,
    int bpp
)
Visual Basic (Declaration)
Public Shared Function FIFSupportsExportBPP ( _
    fif As FREE_IMAGE_FORMAT, _
    bpp As Integer _
) As Boolean
Visual C++
public:
static bool FIFSupportsExportBPP(
    FREE_IMAGE_FORMAT fif,
    int bpp
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The FREE_IMAGE_FORMAT of the plugin.
bpp
Type: System..::.Int32
The desired bit depth.

Return Value

True if the plugin can save bitmaps in the desired bit depth, else false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FIFSupportsExportType Method

[image]

FreeImage .NET Documentation
FreeImage..::.FIFSupportsExportType Method
FreeImage Class See Also Send Feedback
Checks if a plugin can save a bitmap in the desired data type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FIFSupportsExportType(
    FREE_IMAGE_FORMAT fif,
    FREE_IMAGE_TYPE type
)
Visual Basic (Declaration)
Public Shared Function FIFSupportsExportType ( _
    fif As FREE_IMAGE_FORMAT, _
    type As FREE_IMAGE_TYPE _
) As Boolean
Visual C++
public:
static bool FIFSupportsExportType(
    FREE_IMAGE_FORMAT fif,
    FREE_IMAGE_TYPE type
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The FREE_IMAGE_FORMAT of the plugin.
type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
The desired image type.

Return Value

True if the plugin can save bitmaps as the desired type, else false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FIFSupportsICCProfiles Method

[image]

FreeImage .NET Documentation
FreeImage..::.FIFSupportsICCProfiles Method
FreeImage Class See Also Send Feedback
Checks if a plugin can load or save an ICC profile.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FIFSupportsICCProfiles(
    FREE_IMAGE_FORMAT fif
)
Visual Basic (Declaration)
Public Shared Function FIFSupportsICCProfiles ( _
    fif As FREE_IMAGE_FORMAT _
) As Boolean
Visual C++
public:
static bool FIFSupportsICCProfiles(
    FREE_IMAGE_FORMAT fif
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The FREE_IMAGE_FORMAT of the plugin.

Return Value

True if the plugin can load or save an ICC profile, else false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FIFSupportsReading Method

[image]

FreeImage .NET Documentation
FreeImage..::.FIFSupportsReading Method
FreeImage Class See Also Send Feedback
Checks if a plugin can load bitmaps.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FIFSupportsReading(
    FREE_IMAGE_FORMAT fif
)
Visual Basic (Declaration)
Public Shared Function FIFSupportsReading ( _
    fif As FREE_IMAGE_FORMAT _
) As Boolean
Visual C++
public:
static bool FIFSupportsReading(
    FREE_IMAGE_FORMAT fif
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The FREE_IMAGE_FORMAT of the plugin.

Return Value

True if the plugin can load bitmaps, else false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FIFSupportsWriting Method

[image]

FreeImage .NET Documentation
FreeImage..::.FIFSupportsWriting Method
FreeImage Class See Also Send Feedback
Checks if a plugin can save bitmaps.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FIFSupportsWriting(
    FREE_IMAGE_FORMAT fif
)
Visual Basic (Declaration)
Public Shared Function FIFSupportsWriting ( _
    fif As FREE_IMAGE_FORMAT _
) As Boolean
Visual C++
public:
static bool FIFSupportsWriting(
    FREE_IMAGE_FORMAT fif
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The FREE_IMAGE_FORMAT of the plugin.

Return Value

True if the plugin can save bitmaps, else false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FillBackground(T) Method

[image]

FreeImage .NET Documentation
FreeImage..::.FillBackground<(Of <(T>)>) Method
FreeImage Class See Also Send Feedback
Sets all pixels of the specified image to the color provided through the color parameter. See remarks for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FillBackground<T>(
    FIBITMAP dib,
    T color,
    FREE_IMAGE_COLOR_OPTIONS options
)
where T : struct, new()
Visual Basic (Declaration)
Public Shared Function FillBackground(Of T As {Structure, New}) ( _
    dib As FIBITMAP, _
    color As T, _
    options As FREE_IMAGE_COLOR_OPTIONS _
) As Boolean
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
static bool FillBackground(
    FIBITMAP dib,
    T color,
    FREE_IMAGE_COLOR_OPTIONS options
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
color
Type: T
The color to fill the bitmap with. See remarks for further details.
options
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_OPTIONS
Options that affect the color search process for palletized images.

Type Parameters

T
The type of the specified color.

Return Value

true on success, false on failure.

Remarks

This function sets all pixels of an image to the color provided through the color parameter. RGBQUAD is used for standard type images. For non standard type images the underlaying structure is used.

So, color must be of type Double, if the image to be filled is of type FIT_DOUBLE and must be a FIRGBF structure if the image is of type FIT_RGBF and so on.

However, the fill color is always specified through a RGBQUAD structure for all images of type FIT_BITMAP. So, for 32- and 24-bit images, the red, green and blue members of the RGBQUAD structure are directly used for the image's red, green and blue channel respectively. Although alpha transparent RGBQUAD colors are supported, the alpha channel of a 32-bit image never gets modified by this function. A fill color with an alpha value smaller than 255 gets blended with the image's actual background color, which is determined from the image's bottom-left pixel. So, currently using alpha enabled colors, assumes the image to be unicolor before the fill operation. However, the rgbReserved field is only taken into account, if option FICO_RGBA has been specified.

For 16-bit images, the red-, green- and blue components of the specified color are transparently translated into either the 16-bit 555 or 565 representation. This depends on the image's actual red- green- and blue masks.

Special attention must be payed for palletized images. Generally, the RGB color specified is looked up in the image's palette. The found palette index is then used to fill the image. There are some option flags, that affect this lookup process:

Value | Meaning
FICO_DEFAULT | Uses the color, that is nearest to the specified color. This is the default behavior and should always find a color in the palette. However, the visual result may far from what was expected and mainly depends on the image's palette.
FICO_EQUAL_COLOR | Searches the image's palette for the specified color but only uses the returned palette index, if the specified color exactly matches the palette entry. Of course, depending on the image's actual palette entries, this operation may fail. In this case, the function falls back to option FICO_ALPHA_IS_INDEX and uses the RGBQUAD's rgbReserved member (or its low nibble for 4-bit images or its least significant bit (LSB) for 1-bit images) as the palette index used for the fill operation.
FICO_ALPHA_IS_INDEX | Does not perform any color lookup from the palette, but uses the RGBQUAD's alpha channel member rgbReserved as the palette index to be used for the fill operation. However, for 4-bit images, only the low nibble of the rgbReserved member are used and for 1-bit images, only the least significant bit (LSB) is used.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class


FindCloseMetadata Method

[image]

FreeImage .NET Documentation
FreeImage..::.FindCloseMetadata Method
FreeImage Class See Also Send Feedback
Closes the specified metadata search handle and releases associated resources.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void FindCloseMetadata(
    FIMETADATA mdhandle
)
Visual Basic (Declaration)
Public Shared Sub FindCloseMetadata ( _
    mdhandle As FIMETADATA _
)
Visual C++
public:
static void FindCloseMetadata(
    FIMETADATA mdhandle
)

Parameters

mdhandle
Type: FreeImageAPI..::.FIMETADATA
The handle to close.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FindFirstMetadata Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.FindFirstMetadata Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
FindFirstMetadata(FREE_IMAGE_MDMODEL, FIBITMAP, FITAG%) | Provides information about the first instance of a tag that matches the metadata model.
FindFirstMetadata(FREE_IMAGE_MDMODEL, FIBITMAP, MetadataTag%) | Provides information about the first instance of a tag that matches the metadata model.

See Also

FreeImage Class
FreeImage Members


FindFirstMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, FITAG)

[image]

FreeImage .NET Documentation
FreeImage..::.FindFirstMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, FITAG%)
FreeImage Class See Also Send Feedback
Provides information about the first instance of a tag that matches the metadata model.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMETADATA FindFirstMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    out FITAG tag
)
Visual Basic (Declaration)
Public Shared Function FindFirstMetadata ( _
    model As FREE_IMAGE_MDMODEL, _
    dib As FIBITMAP, _
    <OutAttribute> ByRef tag As FITAG _
) As FIMETADATA
Visual C++
public:
static FIMETADATA FindFirstMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    [OutAttribute] FITAG% tag
)

Parameters

model
Type: FreeImageAPI..::.FREE_IMAGE_MDMODEL
The model to match.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
tag
Type: FreeImageAPI..::.FITAG %
Tag that matches the metadata model.

Return Value

Unique search handle that can be used to call FindNextMetadata or FindCloseMetadata. Null if the metadata model does not exist.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
FindFirstMetadata Overload


FindFirstMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, MetadataTag)

[image]

FreeImage .NET Documentation
FreeImage..::.FindFirstMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, MetadataTag%)
FreeImage Class See Also Send Feedback
Provides information about the first instance of a tag that matches the metadata model.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMETADATA FindFirstMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    out MetadataTag tag
)
Visual Basic (Declaration)
Public Shared Function FindFirstMetadata ( _
    model As FREE_IMAGE_MDMODEL, _
    dib As FIBITMAP, _
    <OutAttribute> ByRef tag As MetadataTag _
) As FIMETADATA
Visual C++
public:
static FIMETADATA FindFirstMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    [OutAttribute] MetadataTag^% tag
)

Parameters

model
Type: FreeImageAPI..::.FREE_IMAGE_MDMODEL
The model to match.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
tag
Type: FreeImageAPI.Metadata..::.MetadataTag %
Tag that matches the metadata model.

Return Value

Unique search handle that can be used to call FindNextMetadata or FindCloseMetadata. Null if the metadata model does not exist.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
FindFirstMetadata Overload


FindNextMetadata Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.FindNextMetadata Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
FindNextMetadata(FIMETADATA, FITAG%) | Find the next tag, if any, that matches the metadata model argument in a previous call to FindFirstMetadata, and then alters the tag object contents accordingly.
FindNextMetadata(FIMETADATA, MetadataTag%) | Find the next tag, if any, that matches the metadata model argument in a previous call to FindFirstMetadata, and then alters the tag object contents accordingly.

See Also

FreeImage Class
FreeImage Members


FindNextMetadata Method (FIMETADATA, FITAG)

[image]

FreeImage .NET Documentation
FreeImage..::.FindNextMetadata Method (FIMETADATA, FITAG%)
FreeImage Class See Also Send Feedback
Find the next tag, if any, that matches the metadata model argument in a previous call to FindFirstMetadata, and then alters the tag object contents accordingly.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FindNextMetadata(
    FIMETADATA mdhandle,
    out FITAG tag
)
Visual Basic (Declaration)
Public Shared Function FindNextMetadata ( _
    mdhandle As FIMETADATA, _
    <OutAttribute> ByRef tag As FITAG _
) As Boolean
Visual C++
public:
static bool FindNextMetadata(
    FIMETADATA mdhandle,
    [OutAttribute] FITAG% tag
)

Parameters

mdhandle
Type: FreeImageAPI..::.FIMETADATA
Unique search handle provided by FindFirstMetadata.
tag
Type: FreeImageAPI..::.FITAG %
Tag that matches the metadata model.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
FindNextMetadata Overload


FindNextMetadata Method (FIMETADATA, MetadataTag)

[image]

FreeImage .NET Documentation
FreeImage..::.FindNextMetadata Method (FIMETADATA, MetadataTag%)
FreeImage Class See Also Send Feedback
Find the next tag, if any, that matches the metadata model argument in a previous call to FindFirstMetadata, and then alters the tag object contents accordingly.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FindNextMetadata(
    FIMETADATA mdhandle,
    out MetadataTag tag
)
Visual Basic (Declaration)
Public Shared Function FindNextMetadata ( _
    mdhandle As FIMETADATA, _
    <OutAttribute> ByRef tag As MetadataTag _
) As Boolean
Visual C++
public:
static bool FindNextMetadata(
    FIMETADATA mdhandle,
    [OutAttribute] MetadataTag^% tag
)

Parameters

mdhandle
Type: FreeImageAPI..::.FIMETADATA
Unique search handle provided by FindFirstMetadata.
tag
Type: FreeImageAPI.Metadata..::.MetadataTag %
Tag that matches the metadata model.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
FindNextMetadata Overload


FlipHorizontal Method

[image]

FreeImage .NET Documentation
FreeImage..::.FlipHorizontal Method
FreeImage Class See Also Send Feedback
Flip the input dib horizontally along the vertical axis.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FlipHorizontal(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function FlipHorizontal ( _
    dib As FIBITMAP _
) As Boolean
Visual C++
public:
static bool FlipHorizontal(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FlipVertical Method

[image]

FreeImage .NET Documentation
FreeImage..::.FlipVertical Method
FreeImage Class See Also Send Feedback
Flip the input dib vertically along the horizontal axis.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FlipVertical(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function FlipVertical ( _
    dib As FIBITMAP _
) As Boolean
Visual C++
public:
static bool FlipVertical(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FreeHbitmap Method

[image]

FreeImage .NET Documentation
FreeImage..::.FreeHbitmap Method
FreeImage Class See Also Send Feedback
Frees a bitmap handle.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FreeHbitmap(
    IntPtr hbitmap
)
Visual Basic (Declaration)
Public Shared Function FreeHbitmap ( _
    hbitmap As IntPtr _
) As Boolean
Visual C++
public:
static bool FreeHbitmap(
    IntPtr hbitmap
)

Parameters

hbitmap
Type: System..::.IntPtr
Handle to a bitmap.

Return Value

True on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetAdjustColorsLookupTable Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetAdjustColorsLookupTable Method
FreeImage Class See Also Send Feedback
Creates a lookup table to be used with AdjustCurve(FIBITMAP, array<Byte>[]()[], FREE_IMAGE_COLOR_CHANNEL) which may adjusts brightness and contrast, correct gamma and invert the image with a single call to AdjustCurve(FIBITMAP, array<Byte>[]()[], FREE_IMAGE_COLOR_CHANNEL).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int GetAdjustColorsLookupTable(
    byte[] LUT,
    double brightness,
    double contrast,
    double gamma,
    bool invert
)
Visual Basic (Declaration)
Public Shared Function GetAdjustColorsLookupTable ( _
    LUT As Byte(), _
    brightness As Double, _
    contrast As Double, _
    gamma As Double, _
    invert As Boolean _
) As Integer
Visual C++
public:
static int GetAdjustColorsLookupTable(
    array<unsigned char>^ LUT,
    double brightness,
    double contrast,
    double gamma,
    bool invert
)

Parameters

LUT
Type: array< System..::.Byte >[]()[]
brightness
Type: System..::.Double
Percentage brightness value where -100 <= brightness <= 100.

A value of 0 means no change, less than 0 will make the image darker and greater than 0 will make the image brighter.

contrast
Type: System..::.Double
Percentage contrast value where -100 <= contrast <= 100.

A value of 0 means no change, less than 0 will decrease the contrast and greater than 0 will increase the contrast of the image.

gamma
Type: System..::.Double
Gamma value to be used for gamma correction.

A value of 1.0 leaves the image alone, less than one darkens it, and greater than one lightens it.

invert
Type: System..::.Boolean
If set to true, the image will be inverted.

Return Value

The number of adjustments applied to the resulting lookup table compared to a blind lookup table.

Remarks

This function creates a lookup table to be used with AdjustCurve(FIBITMAP, array<Byte>[]()[], FREE_IMAGE_COLOR_CHANNEL) which may adjust brightness and contrast, correct gamma and invert the image with a single call to AdjustCurve(FIBITMAP, array<Byte>[]()[], FREE_IMAGE_COLOR_CHANNEL). If more than one of these image display properties need to be adjusted, using a combined lookup table should be preferred over calling each adjustment function separately. That's particularly true for huge images or if performance is an issue. Then, the expensive process of iterating over all pixels of an image is performed only once and not up to four times.

Furthermore, the lookup table created does not depend on the order, in which each single adjustment operation is performed. Due to rounding and byte casting issues, it actually matters in which order individual adjustment operations are performed. Both of the following snippets most likely produce different results:

CopyC#
// snippet 1: contrast, brightness
AdjustContrast(dib, 15.0);
AdjustBrightness(dib, 50.0);

CopyC#
// snippet 2: brightness, contrast
AdjustBrightness(dib, 50.0);
AdjustContrast(dib, 15.0);

Better and even faster would be snippet 3:

CopyC#
// snippet 3:
byte[] lut = new byte[256];
GetAdjustColorsLookupTable(lut, 50.0, 15.0, 1.0, false);
AdjustCurve(dib, lut, FREE_IMAGE_COLOR_CHANNEL.FICC_RGB);

This function is also used internally by AdjustColors(FIBITMAP, Double, Double, Double, Boolean), which does not return the lookup table, but uses it to call AdjustCurve(FIBITMAP, array<Byte>[]()[], FREE_IMAGE_COLOR_CHANNEL) on the passed image.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetBackgroundColor Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetBackgroundColor Method
FreeImage Class See Also Send Feedback
Returns the file background color of an image. For 8-bit images, the color index in the palette is returned in the rgbReserved member of the bkcolor parameter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool GetBackgroundColor(
    FIBITMAP dib,
    out RGBQUAD bkcolor
)
Visual Basic (Declaration)
Public Shared Function GetBackgroundColor ( _
    dib As FIBITMAP, _
    <OutAttribute> ByRef bkcolor As RGBQUAD _
) As Boolean
Visual C++
public:
static bool GetBackgroundColor(
    FIBITMAP dib,
    [OutAttribute] RGBQUAD% bkcolor
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
bkcolor
Type: FreeImageAPI..::.RGBQUAD %
The background color.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetBitmap Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetBitmap Method
FreeImage Class See Also Send Feedback
Converts a FreeImage bitmap to a .NET Bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static Bitmap GetBitmap(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetBitmap ( _
    dib As FIBITMAP _
) As Bitmap
Visual C++
public:
static Bitmap^ GetBitmap(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The converted .NET Bitmap.

Remarks

Copying metadata has been disabled until a proper way of reading and storing metadata in a .NET bitmap is found.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.
System..::.ArgumentException | The image type of dib is not FIT_BITMAP.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetBitmapForDevice Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetBitmapForDevice Method
FreeImage Class See Also Send Feedback
Returns an HBITMAP created by the CreateDIBitmap() function which in turn has always the same color depth as the reference DC, which may be provided through hdc. The desktop DC will be used, if IntPtr.Zero DC is specified. Call FreeHbitmap(IntPtr) to free the handle.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static IntPtr GetBitmapForDevice(
    FIBITMAP dib,
    IntPtr hdc,
    bool unload
)
Visual Basic (Declaration)
Public Shared Function GetBitmapForDevice ( _
    dib As FIBITMAP, _
    hdc As IntPtr, _
    unload As Boolean _
) As IntPtr
Visual C++
public:
static IntPtr GetBitmapForDevice(
    FIBITMAP dib,
    IntPtr hdc,
    bool unload
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
hdc
Type: System..::.IntPtr
Handle to a device context.
unload
Type: System..::.Boolean
When true the structure will be unloaded on success. If the function failed and returned false, the bitmap was not unloaded.

Return Value

If the function succeeds, the return value is a handle to the compatible bitmap. If the function fails, the return value is Zero.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetBits Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetBits Method
FreeImage Class See Also Send Feedback
Returns a pointer to the data-bits of the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static IntPtr GetBits(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetBits ( _
    dib As FIBITMAP _
) As IntPtr
Visual C++
public:
static IntPtr GetBits(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Pointer to the data-bits.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetBlueMask Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetBlueMask Method
FreeImage Class See Also Send Feedback
Returns a bit pattern describing the blue color component of a pixel in a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetBlueMask(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetBlueMask ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetBlueMask(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The bit pattern for blue.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetBPP Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetBPP Method
FreeImage Class See Also Send Feedback
Returns the size of one pixel in the bitmap in bits.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetBPP(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetBPP ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetBPP(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Size of one pixel in the bitmap in bits.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetChannel Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetChannel Method
FreeImage Class See Also Send Feedback
Retrieves the red, green, blue or alpha channel of a 24- or 32-bit image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP GetChannel(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_CHANNEL channel
)
Visual Basic (Declaration)
Public Shared Function GetChannel ( _
    dib As FIBITMAP, _
    channel As FREE_IMAGE_COLOR_CHANNEL _
) As FIBITMAP
Visual C++
public:
static FIBITMAP GetChannel(
    FIBITMAP dib,
    FREE_IMAGE_COLOR_CHANNEL channel
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
The color channel to extract.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetColorsUsed Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetColorsUsed Method
FreeImage Class See Also Send Feedback
Returns the number of colors used in a bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetColorsUsed(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetColorsUsed ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetColorsUsed(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Palette-size for palletised bitmaps, and 0 for high-colour bitmaps.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetColorType Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetColorType Method
FreeImage Class See Also Send Feedback
Investigates the color type of the bitmap by reading the bitmap's pixel bits and analysing them.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_COLOR_TYPE GetColorType(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetColorType ( _
    dib As FIBITMAP _
) As FREE_IMAGE_COLOR_TYPE
Visual C++
public:
static FREE_IMAGE_COLOR_TYPE GetColorType(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The color type of the bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetComplexChannel Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetComplexChannel Method
FreeImage Class See Also Send Feedback
Retrieves the real part, imaginary part, magnitude or phase of a complex image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP GetComplexChannel(
    FIBITMAP src,
    FREE_IMAGE_COLOR_CHANNEL channel
)
Visual Basic (Declaration)
Public Shared Function GetComplexChannel ( _
    src As FIBITMAP, _
    channel As FREE_IMAGE_COLOR_CHANNEL _
) As FIBITMAP
Visual C++
public:
static FIBITMAP GetComplexChannel(
    FIBITMAP src,
    FREE_IMAGE_COLOR_CHANNEL channel
)

Parameters

src
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
The color channel to extract.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetCopyrightMessage Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetCopyrightMessage Method
FreeImage Class See Also Send Feedback
Returns a string containing a standard copyright message.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetCopyrightMessage()
Visual Basic (Declaration)
Public Shared Function GetCopyrightMessage As String
Visual C++
public:
static String^ GetCopyrightMessage()

Return Value

A standard copyright message.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetDIBSize Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetDIBSize Method
FreeImage Class See Also Send Feedback
Returns the size of the DIB-element of a FIBITMAP in memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetDIBSize(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetDIBSize ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetDIBSize(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Size of the DIB-element

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetDotsPerMeterX Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetDotsPerMeterX Method
FreeImage Class See Also Send Feedback
Returns the horizontal resolution, in pixels-per-meter, of the target device for the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetDotsPerMeterX(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetDotsPerMeterX ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetDotsPerMeterX(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The horizontal resolution, in pixels-per-meter.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetDotsPerMeterY Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetDotsPerMeterY Method
FreeImage Class See Also Send Feedback
Returns the vertical resolution, in pixels-per-meter, of the target device for the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetDotsPerMeterY(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetDotsPerMeterY ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetDotsPerMeterY(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The vertical resolution, in pixels-per-meter.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFIFCount Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFIFCount Method
FreeImage Class See Also Send Feedback
Retrieves the number of FREE_IMAGE_FORMAT identifiers being currently registered.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int GetFIFCount()
Visual Basic (Declaration)
Public Shared Function GetFIFCount As Integer
Visual C++
public:
static int GetFIFCount()

Return Value

The number of registered formats.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFIFDescription Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFIFDescription Method
FreeImage Class See Also Send Feedback
Returns a descriptive string that describes the bitmap formats the given plugin can read and/or write.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetFIFDescription(
    FREE_IMAGE_FORMAT fif
)
Visual Basic (Declaration)
Public Shared Function GetFIFDescription ( _
    fif As FREE_IMAGE_FORMAT _
) As String
Visual C++
public:
static String^ GetFIFDescription(
    FREE_IMAGE_FORMAT fif
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The desired FREE_IMAGE_FORMAT.

Return Value

A descriptive string that describes the bitmap formats.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFIFExtensionList Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFIFExtensionList Method
FreeImage Class See Also Send Feedback
Returns a comma-delimited file extension list describing the bitmap formats the given plugin can read and/or write.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetFIFExtensionList(
    FREE_IMAGE_FORMAT fif
)
Visual Basic (Declaration)
Public Shared Function GetFIFExtensionList ( _
    fif As FREE_IMAGE_FORMAT _
) As String
Visual C++
public:
static String^ GetFIFExtensionList(
    FREE_IMAGE_FORMAT fif
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The desired FREE_IMAGE_FORMAT.

Return Value

A comma-delimited file extension list.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFIFFromFilename Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFIFFromFilename Method
FreeImage Class See Also Send Feedback
This function takes a filename or a file-extension and returns the plugin that can read/write files with that extension in the form of a FREE_IMAGE_FORMAT identifier.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_FORMAT GetFIFFromFilename(
    string filename
)
Visual Basic (Declaration)
Public Shared Function GetFIFFromFilename ( _
    filename As String _
) As FREE_IMAGE_FORMAT
Visual C++
public:
static FREE_IMAGE_FORMAT GetFIFFromFilename(
    String^ filename
)

Parameters

filename
Type: System..::.String
The filename or -extension.

Return Value

The FREE_IMAGE_FORMAT of the plugin.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFIFFromFormat Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFIFFromFormat Method
FreeImage Class See Also Send Feedback
Returns a FREE_IMAGE_FORMAT identifier from the format string that was used to register the FIF.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_FORMAT GetFIFFromFormat(
    string format
)
Visual Basic (Declaration)
Public Shared Function GetFIFFromFormat ( _
    format As String _
) As FREE_IMAGE_FORMAT
Visual C++
public:
static FREE_IMAGE_FORMAT GetFIFFromFormat(
    String^ format
)

Parameters

format
Type: System..::.String
The string that was used to register the plugin.

Return Value

A FREE_IMAGE_FORMAT identifier from the format.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFIFFromMime Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFIFFromMime Method
FreeImage Class See Also Send Feedback
Returns a FREE_IMAGE_FORMAT identifier from a MIME content type string (MIME stands for Multipurpose Internet Mail Extension).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_FORMAT GetFIFFromMime(
    string mime
)
Visual Basic (Declaration)
Public Shared Function GetFIFFromMime ( _
    mime As String _
) As FREE_IMAGE_FORMAT
Visual C++
public:
static FREE_IMAGE_FORMAT GetFIFFromMime(
    String^ mime
)

Parameters

mime
Type: System..::.String
A MIME content type.

Return Value

A FREE_IMAGE_FORMAT identifier from the MIME.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFIFMimeType Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFIFMimeType Method
FreeImage Class See Also Send Feedback
Given a FREE_IMAGE_FORMAT identifier, returns a MIME content type string (MIME stands for Multipurpose Internet Mail Extension).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetFIFMimeType(
    FREE_IMAGE_FORMAT fif
)
Visual Basic (Declaration)
Public Shared Function GetFIFMimeType ( _
    fif As FREE_IMAGE_FORMAT _
) As String
Visual C++
public:
static String^ GetFIFMimeType(
    FREE_IMAGE_FORMAT fif
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The desired FREE_IMAGE_FORMAT.

Return Value

A MIME content type string.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFIFRegExpr Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFIFRegExpr Method
FreeImage Class See Also Send Feedback
Returns a regular expression string that can be used by a regular expression engine to identify the bitmap. FreeImageQt makes use of this function.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetFIFRegExpr(
    FREE_IMAGE_FORMAT fif
)
Visual Basic (Declaration)
Public Shared Function GetFIFRegExpr ( _
    fif As FREE_IMAGE_FORMAT _
) As String
Visual C++
public:
static String^ GetFIFRegExpr(
    FREE_IMAGE_FORMAT fif
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The desired FREE_IMAGE_FORMAT.

Return Value

A regular expression string.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFileType Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFileType Method
FreeImage Class See Also Send Feedback
Orders FreeImage to analyze the bitmap signature.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_FORMAT GetFileType(
    string filename,
    int size
)
Visual Basic (Declaration)
Public Shared Function GetFileType ( _
    filename As String, _
    size As Integer _
) As FREE_IMAGE_FORMAT
Visual C++
public:
static FREE_IMAGE_FORMAT GetFileType(
    String^ filename,
    int size
)

Parameters

filename
Type: System..::.String
Name of the file to analyze.
size
Type: System..::.Int32
Reserved parameter - use 0.

Return Value

Type of the bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFileTypeFromHandle Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFileTypeFromHandle Method
FreeImage Class See Also Send Feedback
Uses the FreeImageIO structure as described in the topic bitmap management functions to identify a bitmap type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_FORMAT GetFileTypeFromHandle(
    ref FreeImageIO io,
    fi_handle handle,
    int size
)
Visual Basic (Declaration)
Public Shared Function GetFileTypeFromHandle ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    size As Integer _
) As FREE_IMAGE_FORMAT
Visual C++
public:
static FREE_IMAGE_FORMAT GetFileTypeFromHandle(
    FreeImageIO% io,
    fi_handle handle,
    int size
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
A FreeImageIO structure with functionpointers to handle the source.
handle
Type: FreeImageAPI.IO..::.fi_handle
A handle to the source.
size
Type: System..::.Int32
Size in bytes of the source.

Return Value

Type of the bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFileTypeFromMemory Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFileTypeFromMemory Method
FreeImage Class See Also Send Feedback
Uses a memory handle to identify a bitmap type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_FORMAT GetFileTypeFromMemory(
    FIMEMORY stream,
    int size
)
Visual Basic (Declaration)
Public Shared Function GetFileTypeFromMemory ( _
    stream As FIMEMORY, _
    size As Integer _
) As FREE_IMAGE_FORMAT
Visual C++
public:
static FREE_IMAGE_FORMAT GetFileTypeFromMemory(
    FIMEMORY stream,
    int size
)

Parameters

stream
Type: FreeImageAPI..::.FIMEMORY
Pointer to the stream.
size
Type: System..::.Int32
Size in bytes of the source.

Return Value

Type of the bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFileTypeFromStream Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFileTypeFromStream Method
FreeImage Class See Also Send Feedback
Orders FreeImage to analyze the bitmap signature. In case the stream is not seekable, the stream will have been used and must be recreated for loading.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_FORMAT GetFileTypeFromStream(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function GetFileTypeFromStream ( _
    stream As Stream _
) As FREE_IMAGE_FORMAT
Visual C++
public:
static FREE_IMAGE_FORMAT GetFileTypeFromStream(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Name of the stream to analyze.

Return Value

Type of the bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | stream is null.
System..::.ArgumentException | stream can not read.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFormat Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFormat Method
FreeImage Class See Also Send Feedback
Returns the FREE_IMAGE_FORMAT for the specified ImageFormat.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_FORMAT GetFormat(
    ImageFormat imageFormat
)
Visual Basic (Declaration)
Public Shared Function GetFormat ( _
    imageFormat As ImageFormat _
) As FREE_IMAGE_FORMAT
Visual C++
public:
static FREE_IMAGE_FORMAT GetFormat(
    ImageFormat^ imageFormat
)

Parameters

imageFormat
Type: System.Drawing.Imaging..::.ImageFormat
The ImageFormat for which to return the corresponding FREE_IMAGE_FORMAT.

Return Value

The FREE_IMAGE_FORMAT for the specified ImageFormat

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class


GetFormatFromFIF Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetFormatFromFIF Method
FreeImage Class See Also Send Feedback
Returns the string that was used to register a plugin from the system assigned FREE_IMAGE_FORMAT.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetFormatFromFIF(
    FREE_IMAGE_FORMAT fif
)
Visual Basic (Declaration)
Public Shared Function GetFormatFromFIF ( _
    fif As FREE_IMAGE_FORMAT _
) As String
Visual C++
public:
static String^ GetFormatFromFIF(
    FREE_IMAGE_FORMAT fif
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The assigned FREE_IMAGE_FORMAT.

Return Value

The string that was used to register the plugin.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetFormatParameters Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.GetFormatParameters Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
GetFormatParameters(PixelFormat, UInt32%, UInt32%, UInt32%, UInt32%) | Retrieves all parameters needed to create a new FreeImage bitmap from the format of a .NET Image.
GetFormatParameters(PixelFormat, FREE_IMAGE_TYPE%, UInt32%, UInt32%, UInt32%, UInt32%) | Retrieves all parameters needed to create a new FreeImage bitmap from the format of a .NET Image.

See Also

FreeImage Class
FreeImage Members


GetFormatParameters Method (PixelFormat, UInt32, UInt32, UInt32, UInt32)

[image]

FreeImage .NET Documentation
FreeImage..::.GetFormatParameters Method (PixelFormat, UInt32%, UInt32%, UInt32%, UInt32%)
FreeImage Class See Also Send Feedback
Retrieves all parameters needed to create a new FreeImage bitmap from the format of a .NET Image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool GetFormatParameters(
    PixelFormat format,
    out uint bpp,
    out uint red_mask,
    out uint green_mask,
    out uint blue_mask
)
Visual Basic (Declaration)
Public Shared Function GetFormatParameters ( _
    format As PixelFormat, _
    <OutAttribute> ByRef bpp As UInteger, _
    <OutAttribute> ByRef red_mask As UInteger, _
    <OutAttribute> ByRef green_mask As UInteger, _
    <OutAttribute> ByRef blue_mask As UInteger _
) As Boolean
Visual C++
public:
static bool GetFormatParameters(
    PixelFormat format,
    [OutAttribute] unsigned int% bpp,
    [OutAttribute] unsigned int% red_mask,
    [OutAttribute] unsigned int% green_mask,
    [OutAttribute] unsigned int% blue_mask
)

Parameters

format
Type: System.Drawing.Imaging..::.PixelFormat
The PixelFormat of the .NET Image.
bpp
Type: System..::.UInt32 %
Returns the color depth for the new bitmap.
red_mask
Type: System..::.UInt32 %
Returns the red_mask for the new bitmap.
green_mask
Type: System..::.UInt32 %
Returns the green_mask for the new bitmap.
blue_mask
Type: System..::.UInt32 %
Returns the blue_mask for the new bitmap.

Return Value

True in case format is FIT_BITMAP, else false.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FreeImage Class
GetFormatParameters Overload


GetFormatParameters Method (PixelFormat, FREE_IMAGE_TYPE, UInt32, UInt32, UInt32, UInt32)

[image]

FreeImage .NET Documentation
FreeImage..::.GetFormatParameters Method (PixelFormat, FREE_IMAGE_TYPE%, UInt32%, UInt32%, UInt32%, UInt32%)
FreeImage Class See Also Send Feedback
Retrieves all parameters needed to create a new FreeImage bitmap from the format of a .NET Image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool GetFormatParameters(
    PixelFormat format,
    out FREE_IMAGE_TYPE type,
    out uint bpp,
    out uint red_mask,
    out uint green_mask,
    out uint blue_mask
)
Visual Basic (Declaration)
Public Shared Function GetFormatParameters ( _
    format As PixelFormat, _
    <OutAttribute> ByRef type As FREE_IMAGE_TYPE, _
    <OutAttribute> ByRef bpp As UInteger, _
    <OutAttribute> ByRef red_mask As UInteger, _
    <OutAttribute> ByRef green_mask As UInteger, _
    <OutAttribute> ByRef blue_mask As UInteger _
) As Boolean
Visual C++
public:
static bool GetFormatParameters(
    PixelFormat format,
    [OutAttribute] FREE_IMAGE_TYPE% type,
    [OutAttribute] unsigned int% bpp,
    [OutAttribute] unsigned int% red_mask,
    [OutAttribute] unsigned int% green_mask,
    [OutAttribute] unsigned int% blue_mask
)

Parameters

format
Type: System.Drawing.Imaging..::.PixelFormat
The PixelFormat of the .NET Image.
type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE %
Returns the type used for the new bitmap.
bpp
Type: System..::.UInt32 %
Returns the color depth for the new bitmap.
red_mask
Type: System..::.UInt32 %
Returns the red_mask for the new bitmap.
green_mask
Type: System..::.UInt32 %
Returns the green_mask for the new bitmap.
blue_mask
Type: System..::.UInt32 %
Returns the blue_mask for the new bitmap.

Return Value

True in case a matching conversion exists; else false.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
GetFormatParameters Overload


GetGreenMask Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetGreenMask Method
FreeImage Class See Also Send Feedback
Returns a bit pattern describing the green color component of a pixel in a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetGreenMask(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetGreenMask ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetGreenMask(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The bit pattern for green.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetHbitmap Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetHbitmap Method
FreeImage Class See Also Send Feedback
Retrieves an hBitmap for a FreeImage bitmap. Call FreeHbitmap(IntPtr) to free the handle.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static IntPtr GetHbitmap(
    FIBITMAP dib,
    IntPtr hdc,
    bool unload
)
Visual Basic (Declaration)
Public Shared Function GetHbitmap ( _
    dib As FIBITMAP, _
    hdc As IntPtr, _
    unload As Boolean _
) As IntPtr
Visual C++
public:
static IntPtr GetHbitmap(
    FIBITMAP dib,
    IntPtr hdc,
    bool unload
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
hdc
Type: System..::.IntPtr
A reference device context. Use IntPtr.Zero if no reference is available.
unload
Type: System..::.Boolean
When true dib will be unloaded if the function succeeded.

Return Value

The hBitmap for the FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetHeight Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetHeight Method
FreeImage Class See Also Send Feedback
Returns the height of the bitmap in pixel units.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetHeight(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetHeight ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetHeight(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Height of the bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetHistogram Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetHistogram Method
FreeImage Class See Also Send Feedback
Computes the image histogram.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool GetHistogram(
    FIBITMAP dib,
    int[] histo,
    FREE_IMAGE_COLOR_CHANNEL channel
)
Visual Basic (Declaration)
Public Shared Function GetHistogram ( _
    dib As FIBITMAP, _
    histo As Integer(), _
    channel As FREE_IMAGE_COLOR_CHANNEL _
) As Boolean
Visual C++
public:
static bool GetHistogram(
    FIBITMAP dib,
    array<int>^ histo,
    FREE_IMAGE_COLOR_CHANNEL channel
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
histo
Type: array< System..::.Int32 >[]()[]
Array of integers with a size of 256.
channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
Channel to compute from.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetICCProfile Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetICCProfile Method
FreeImage Class See Also Send Feedback
Retrieves a pointer to the FIICCPROFILE data of the bitmap. This function can also be called safely, when the original format does not support profiles.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static IntPtr GetICCProfile(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetICCProfile ( _
    dib As FIBITMAP _
) As IntPtr
Visual C++
public:
static IntPtr GetICCProfile(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Pointer to the FIICCPROFILE data of the bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetICCProfileEx Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetICCProfileEx Method
FreeImage Class See Also Send Feedback
Retrieves the FIICCPROFILE data of the bitmap. This function can also be called safely, when the original format does not support profiles.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIICCPROFILE GetICCProfileEx(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetICCProfileEx ( _
    dib As FIBITMAP _
) As FIICCPROFILE
Visual C++
public:
static FIICCPROFILE GetICCProfileEx(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The FIICCPROFILE data of the bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetImageComment Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetImageComment Method
FreeImage Class See Also Send Feedback
Returns the comment of a JPEG, PNG or GIF image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetImageComment(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetImageComment ( _
    dib As FIBITMAP _
) As String
Visual C++
public:
static String^ GetImageComment(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Comment of the FreeImage bitmp, or null in case no comment exists.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetImageType Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetImageType Method
FreeImage Class See Also Send Feedback
Retrieves the type of the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_TYPE GetImageType(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetImageType ( _
    dib As FIBITMAP _
) As FREE_IMAGE_TYPE
Visual C++
public:
static FREE_IMAGE_TYPE GetImageType(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Type of the bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetInfo Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetInfo Method
FreeImage Class See Also Send Feedback
Alias for FreeImage_GetInfoHeader that returns a pointer to a BITMAPINFO rather than to a BITMAPINFOHEADER.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static IntPtr GetInfo(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetInfo ( _
    dib As FIBITMAP _
) As IntPtr
Visual C++
public:
static IntPtr GetInfo(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Pointer to the BITMAPINFO structure for the bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetInfoEx Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetInfoEx Method
FreeImage Class See Also Send Feedback
Returns the BITMAPINFO structure of a FreeImage bitmap. The structure is a copy, so changes will have no effect on the bitmap itself.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static BITMAPINFO GetInfoEx(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetInfoEx ( _
    dib As FIBITMAP _
) As BITMAPINFO
Visual C++
public:
static BITMAPINFO GetInfoEx(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

BITMAPINFO structure of the bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetInfoHeader Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetInfoHeader Method
FreeImage Class See Also Send Feedback
Returns a pointer to the BITMAPINFOHEADER of the DIB-element in a FIBITMAP.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static IntPtr GetInfoHeader(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetInfoHeader ( _
    dib As FIBITMAP _
) As IntPtr
Visual C++
public:
static IntPtr GetInfoHeader(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Poiter to the header of the bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetInfoHeaderEx Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetInfoHeaderEx Method
FreeImage Class See Also Send Feedback
Returns the BITMAPINFOHEADER structure of a FreeImage bitmap. The structure is a copy, so changes will have no effect on the bitmap itself.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static BITMAPINFOHEADER GetInfoHeaderEx(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetInfoHeaderEx ( _
    dib As FIBITMAP _
) As BITMAPINFOHEADER
Visual C++
public:
static BITMAPINFOHEADER GetInfoHeaderEx(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

BITMAPINFOHEADER structure of the bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetLine Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetLine Method
FreeImage Class See Also Send Feedback
Returns the width of the bitmap in bytes.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetLine(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetLine ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetLine(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

With of the bitmap in bytes.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetLockedPageCount Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetLockedPageCount Method
FreeImage Class See Also Send Feedback
Retrieves the number of pages that are locked in a multi-paged bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int GetLockedPageCount(
    FIMULTIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetLockedPageCount ( _
    dib As FIMULTIBITMAP _
) As Integer
Visual C++
public:
static int GetLockedPageCount(
    FIMULTIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIMULTIBITMAP
Handle to a FreeImage multi-paged bitmap.

Return Value

Number of locked pages.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetLockedPageNumbers Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetLockedPageNumbers Method
FreeImage Class Example See Also Send Feedback
Returns an array of page-numbers that are currently locked in memory. When the pages parameter is null, the size of the array is returned in the count variable.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool GetLockedPageNumbers(
    FIMULTIBITMAP bitmap,
    int[] pages,
    ref int count
)
Visual Basic (Declaration)
Public Shared Function GetLockedPageNumbers ( _
    bitmap As FIMULTIBITMAP, _
    pages As Integer(), _
    ByRef count As Integer _
) As Boolean
Visual C++
public:
static bool GetLockedPageNumbers(
    FIMULTIBITMAP bitmap,
    array<int>^ pages,
    int% count
)

Parameters

bitmap
Type: FreeImageAPI..::.FIMULTIBITMAP
Handle to a FreeImage multi-paged bitmap.
pages
Type: array< System..::.Int32 >[]()[]
The list of locked pages in the multi-pages bitmap. If set to null, count will contain the number of pages.
count
Type: System..::.Int32 %
If pages is set to null count will contain the number of locked pages.

Return Value

Returns true on success, false on failure.

Examples

CopyC#
int[] lockedPages = null;
int count = 0;
GetLockedPageNumbers(dib, lockedPages, ref count);
lockedPages = new int[count];
GetLockedPageNumbers(dib, lockedPages, ref count);

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetLockedPages Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetLockedPages Method
FreeImage Class See Also Send Feedback
Retrieves a list locked pages of a multi-paged bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int[] GetLockedPages(
    FIMULTIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetLockedPages ( _
    dib As FIMULTIBITMAP _
) As Integer()
Visual C++
public:
static array<int>^ GetLockedPages(
    FIMULTIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIMULTIBITMAP
Handle to a FreeImage multi-paged bitmap.

Return Value

List containing the indexes of the locked pages.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetMetadata Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.GetMetadata Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
GetMetadata(FREE_IMAGE_MDMODEL, FIBITMAP, String, FITAG%) | Retrieve a metadata attached to a dib.
GetMetadata(FREE_IMAGE_MDMODEL, FIBITMAP, String, MetadataTag%) | Retrieve a metadata attached to a FreeImage bitmap.

See Also

FreeImage Class
FreeImage Members


GetMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, String, FITAG)

[image]

FreeImage .NET Documentation
FreeImage..::.GetMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, String, FITAG%)
FreeImage Class See Also Send Feedback
Retrieve a metadata attached to a dib.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool GetMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    string key,
    out FITAG tag
)
Visual Basic (Declaration)
Public Shared Function GetMetadata ( _
    model As FREE_IMAGE_MDMODEL, _
    dib As FIBITMAP, _
    key As String, _
    <OutAttribute> ByRef tag As FITAG _
) As Boolean
Visual C++
public:
static bool GetMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    String^ key,
    [OutAttribute] FITAG% tag
)

Parameters

model
Type: FreeImageAPI..::.FREE_IMAGE_MDMODEL
The metadata model to look for.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
key
Type: System..::.String
The metadata field name.
tag
Type: FreeImageAPI..::.FITAG %
A FITAG structure returned by the function.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
GetMetadata Overload


GetMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, String, MetadataTag)

[image]

FreeImage .NET Documentation
FreeImage..::.GetMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, String, MetadataTag%)
FreeImage Class See Also Send Feedback
Retrieve a metadata attached to a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool GetMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    string key,
    out MetadataTag tag
)
Visual Basic (Declaration)
Public Shared Function GetMetadata ( _
    model As FREE_IMAGE_MDMODEL, _
    dib As FIBITMAP, _
    key As String, _
    <OutAttribute> ByRef tag As MetadataTag _
) As Boolean
Visual C++
public:
static bool GetMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    String^ key,
    [OutAttribute] MetadataTag^% tag
)

Parameters

model
Type: FreeImageAPI..::.FREE_IMAGE_MDMODEL
The metadata model to look for.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
key
Type: System..::.String
The metadata field name.
tag
Type: FreeImageAPI.Metadata..::.MetadataTag %
A MetadataTag structure returned by the function.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
GetMetadata Overload


GetMetadataCount Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetMetadataCount Method
FreeImage Class See Also Send Feedback
Returns the number of tags contained in the model metadata model attached to the input dib.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetMetadataCount(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetMetadataCount ( _
    model As FREE_IMAGE_MDMODEL, _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetMetadataCount(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib
)

Parameters

model
Type: FreeImageAPI..::.FREE_IMAGE_MDMODEL
The metadata model.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Number of tags contained in the metadata model.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetNativeVersion Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetNativeVersion Method
FreeImage Class See Also Send Feedback
Returns the version of the native FreeImage library.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static Version GetNativeVersion()
Visual Basic (Declaration)
Public Shared Function GetNativeVersion As Version
Visual C++
public:
static Version^ GetNativeVersion()

Return Value

The version of the native FreeImage library.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class


GetPageCount Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetPageCount Method
FreeImage Class See Also Send Feedback
Returns the number of pages currently available in the multi-paged bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int GetPageCount(
    FIMULTIBITMAP bitmap
)
Visual Basic (Declaration)
Public Shared Function GetPageCount ( _
    bitmap As FIMULTIBITMAP _
) As Integer
Visual C++
public:
static int GetPageCount(
    FIMULTIBITMAP bitmap
)

Parameters

bitmap
Type: FreeImageAPI..::.FIMULTIBITMAP
Handle to a FreeImage multi-paged bitmap.

Return Value

Number of pages.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetPalette Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetPalette Method
FreeImage Class See Also Send Feedback
Returns a pointer to the bitmap's palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static IntPtr GetPalette(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetPalette ( _
    dib As FIBITMAP _
) As IntPtr
Visual C++
public:
static IntPtr GetPalette(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Pointer to the bitmap's palette.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetPaletteEx Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetPaletteEx Method
FreeImage Class See Also Send Feedback
Returns a structure that represents the palette of a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static Palette GetPaletteEx(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetPaletteEx ( _
    dib As FIBITMAP _
) As Palette
Visual C++
public:
static Palette^ GetPaletteEx(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

A structure representing the bitmaps palette.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetPitch Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetPitch Method
FreeImage Class See Also Send Feedback
Returns the width of the bitmap in bytes, rounded to the next 32-bit boundary, also known as pitch or stride or scan width.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetPitch(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetPitch ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetPitch(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

With of the bitmap in bytes.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetPixelColor Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetPixelColor Method
FreeImage Class See Also Send Feedback
Get the pixel color of a 16-, 24- or 32-bit image at position (x, y), including range check (slow access).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool GetPixelColor(
    FIBITMAP dib,
    uint x,
    uint y,
    out RGBQUAD value
)
Visual Basic (Declaration)
Public Shared Function GetPixelColor ( _
    dib As FIBITMAP, _
    x As UInteger, _
    y As UInteger, _
    <OutAttribute> ByRef value As RGBQUAD _
) As Boolean
Visual C++
public:
static bool GetPixelColor(
    FIBITMAP dib,
    unsigned int x,
    unsigned int y,
    [OutAttribute] RGBQUAD% value
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
x
Type: System..::.UInt32
Pixel position in horizontal direction.
y
Type: System..::.UInt32
Pixel position in vertical direction.
value
Type: FreeImageAPI..::.RGBQUAD %
The pixel color.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetPixelFormat Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetPixelFormat Method
FreeImage Class See Also Send Feedback
Returns the pixelformat of the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static PixelFormat GetPixelFormat(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetPixelFormat ( _
    dib As FIBITMAP _
) As PixelFormat
Visual C++
public:
static PixelFormat GetPixelFormat(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

PixelFormat of the bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetPixelIndex Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetPixelIndex Method
FreeImage Class See Also Send Feedback
Get the pixel index of a palettized image at position (x, y), including range check (slow access).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool GetPixelIndex(
    FIBITMAP dib,
    uint x,
    uint y,
    out byte value
)
Visual Basic (Declaration)
Public Shared Function GetPixelIndex ( _
    dib As FIBITMAP, _
    x As UInteger, _
    y As UInteger, _
    <OutAttribute> ByRef value As Byte _
) As Boolean
Visual C++
public:
static bool GetPixelIndex(
    FIBITMAP dib,
    unsigned int x,
    unsigned int y,
    [OutAttribute] unsigned char% value
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
x
Type: System..::.UInt32
Pixel position in horizontal direction.
y
Type: System..::.UInt32
Pixel position in vertical direction.
value
Type: System..::.Byte %
The pixel index.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetPrimaryExtensionFromFIF Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetPrimaryExtensionFromFIF Method
FreeImage Class See Also Send Feedback
This function returns the primary (main or most commonly used?) extension of a certain image format (fif). This is done by returning the first of all possible extensions returned by GetFIFExtensionList(). That assumes, that the plugin returns the extensions in ordered form.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetPrimaryExtensionFromFIF(
    FREE_IMAGE_FORMAT fif
)
Visual Basic (Declaration)
Public Shared Function GetPrimaryExtensionFromFIF ( _
    fif As FREE_IMAGE_FORMAT _
) As String
Visual C++
public:
static String^ GetPrimaryExtensionFromFIF(
    FREE_IMAGE_FORMAT fif
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The image format to obtain the primary extension for.

Return Value

The primary extension of the specified image format.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetRedMask Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetRedMask Method
FreeImage Class See Also Send Feedback
Returns a bit pattern describing the red color component of a pixel in a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetRedMask(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetRedMask ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetRedMask(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The bit pattern for RED.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetResolutionX Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetResolutionX Method
FreeImage Class See Also Send Feedback
Retrieves a DIB's resolution in X-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetResolutionX(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetResolutionX ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetResolutionX(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The resolution in 'dots per inch'.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetResolutionY Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetResolutionY Method
FreeImage Class See Also Send Feedback
Retrieves a DIB's resolution in Y-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetResolutionY(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetResolutionY ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetResolutionY(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The resolution in 'dots per inch'.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetScanLine Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetScanLine Method
FreeImage Class See Also Send Feedback
Returns a pointer to the start of the given scanline in the bitmap's data-bits.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static IntPtr GetScanLine(
    FIBITMAP dib,
    int scanline
)
Visual Basic (Declaration)
Public Shared Function GetScanLine ( _
    dib As FIBITMAP, _
    scanline As Integer _
) As IntPtr
Visual C++
public:
static IntPtr GetScanLine(
    FIBITMAP dib,
    int scanline
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
scanline
Type: System..::.Int32
Number of the scanline.

Return Value

Pointer to the scanline.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTagCount Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTagCount Method
FreeImage Class See Also Send Feedback
Returns the number of components in the tag (in tag type units).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetTagCount(
    FITAG tag
)
Visual Basic (Declaration)
Public Shared Function GetTagCount ( _
    tag As FITAG _
) As UInteger
Visual C++
public:
static unsigned int GetTagCount(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.

Return Value

The number of components.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTagDescription Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTagDescription Method
FreeImage Class See Also Send Feedback
Returns the tag description.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetTagDescription(
    FITAG tag
)
Visual Basic (Declaration)
Public Shared Function GetTagDescription ( _
    tag As FITAG _
) As String
Visual C++
public:
static String^ GetTagDescription(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.

Return Value

The description or NULL if unavailable.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTagID Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTagID Method
FreeImage Class See Also Send Feedback
Returns the tag ID.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static ushort GetTagID(
    FITAG tag
)
Visual Basic (Declaration)
Public Shared Function GetTagID ( _
    tag As FITAG _
) As UShort
Visual C++
public:
static unsigned short GetTagID(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.

Return Value

The ID or 0 if unavailable.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTagKey Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTagKey Method
FreeImage Class See Also Send Feedback
Returns the tag field name (unique inside a metadata model).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetTagKey(
    FITAG tag
)
Visual Basic (Declaration)
Public Shared Function GetTagKey ( _
    tag As FITAG _
) As String
Visual C++
public:
static String^ GetTagKey(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.

Return Value

The field name.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTagLength Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTagLength Method
FreeImage Class See Also Send Feedback
Returns the length of the tag value in bytes.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetTagLength(
    FITAG tag
)
Visual Basic (Declaration)
Public Shared Function GetTagLength ( _
    tag As FITAG _
) As UInteger
Visual C++
public:
static unsigned int GetTagLength(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.

Return Value

The length of the tag value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTagType Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTagType Method
FreeImage Class See Also Send Feedback
Returns the tag data type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_MDTYPE GetTagType(
    FITAG tag
)
Visual Basic (Declaration)
Public Shared Function GetTagType ( _
    tag As FITAG _
) As FREE_IMAGE_MDTYPE
Visual C++
public:
static FREE_IMAGE_MDTYPE GetTagType(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.

Return Value

The tag type.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTagValue Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTagValue Method
FreeImage Class See Also Send Feedback
Returns the tag value. It is up to the programmer to interpret the returned pointer correctly, according to the results of GetTagType and GetTagCount.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static IntPtr GetTagValue(
    FITAG tag
)
Visual Basic (Declaration)
Public Shared Function GetTagValue ( _
    tag As FITAG _
) As IntPtr
Visual C++
public:
static IntPtr GetTagValue(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.

Return Value

Pointer to the value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTransparencyCount Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTransparencyCount Method
FreeImage Class See Also Send Feedback
Returns the number of transparent colors in a palletised bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetTransparencyCount(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetTransparencyCount ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetTransparencyCount(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The number of transparent colors in a palletised bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTransparencyTable Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTransparencyTable Method
FreeImage Class See Also Send Feedback
Returns a pointer to the bitmap's transparency table.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static IntPtr GetTransparencyTable(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetTransparencyTable ( _
    dib As FIBITMAP _
) As IntPtr
Visual C++
public:
static IntPtr GetTransparencyTable(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Pointer to the bitmap's transparency table.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTransparencyTableEx Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTransparencyTableEx Method
FreeImage Class See Also Send Feedback
Returns the FreeImage bitmap's transparency table. The array is empty in case the bitmap has no transparency table.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static byte[] GetTransparencyTableEx(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetTransparencyTableEx ( _
    dib As FIBITMAP _
) As Byte()
Visual C++
public:
static array<unsigned char>^ GetTransparencyTableEx(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

The FreeImage bitmap's transparency table.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTransparentIndex Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTransparentIndex Method
FreeImage Class See Also Send Feedback
Returns the palette entry used as transparent color for the image specified. Works for palletised images only and returns -1 for high color images or if the image has no color set to be transparent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int GetTransparentIndex(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetTransparentIndex ( _
    dib As FIBITMAP _
) As Integer
Visual C++
public:
static int GetTransparentIndex(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

the index of the palette entry used as transparent color for the image specified or -1 if there is no transparent color found (e.g. the image is a high color image).

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetTypeParameters Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetTypeParameters Method
FreeImage Class See Also Send Feedback
Retrieves all parameters needed to create a new FreeImage bitmap from raw bits Image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool GetTypeParameters(
    FREE_IMAGE_TYPE type,
    int bpp,
    out uint red_mask,
    out uint green_mask,
    out uint blue_mask
)
Visual Basic (Declaration)
Public Shared Function GetTypeParameters ( _
    type As FREE_IMAGE_TYPE, _
    bpp As Integer, _
    <OutAttribute> ByRef red_mask As UInteger, _
    <OutAttribute> ByRef green_mask As UInteger, _
    <OutAttribute> ByRef blue_mask As UInteger _
) As Boolean
Visual C++
public:
static bool GetTypeParameters(
    FREE_IMAGE_TYPE type,
    int bpp,
    [OutAttribute] unsigned int% red_mask,
    [OutAttribute] unsigned int% green_mask,
    [OutAttribute] unsigned int% blue_mask
)

Parameters

type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
The FREE_IMAGE_TYPE of the data in memory.
bpp
Type: System..::.Int32
The color depth for the data.
red_mask
Type: System..::.UInt32 %
Returns the red_mask for the data.
green_mask
Type: System..::.UInt32 %
Returns the green_mask for the data.
blue_mask
Type: System..::.UInt32 %
Returns the blue_mask for the data.

Return Value

True in case a matching conversion exists; else false.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetUniqueColors Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetUniqueColors Method
FreeImage Class See Also Send Feedback
This function returns the number of unique colors actually used by the specified 1-, 4-, 8-, 16-, 24- or 32-bit image. This might be different from what function FreeImage_GetColorsUsed() returns, which actually returns the palette size for palletised images. Works for FIT_BITMAP type images only.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int GetUniqueColors(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetUniqueColors ( _
    dib As FIBITMAP _
) As Integer
Visual C++
public:
static int GetUniqueColors(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Returns the number of unique colors used by the image specified or zero, if the image type cannot be handled.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetVersion Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetVersion Method
FreeImage Class See Also Send Feedback
Returns a string containing the current version of the library.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetVersion()
Visual Basic (Declaration)
Public Shared Function GetVersion As String
Visual C++
public:
static String^ GetVersion()

Return Value

The current version of the library.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetWidth Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetWidth Method
FreeImage Class See Also Send Feedback
Returns the width of the bitmap in pixel units.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint GetWidth(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function GetWidth ( _
    dib As FIBITMAP _
) As UInteger
Visual C++
public:
static unsigned int GetWidth(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

With of the bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


GetWrapperVersion Method

[image]

FreeImage .NET Documentation
FreeImage..::.GetWrapperVersion Method
FreeImage Class See Also Send Feedback
Returns the internal version of this FreeImage .NET wrapper.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string GetWrapperVersion()
Visual Basic (Declaration)
Public Shared Function GetWrapperVersion As String
Visual C++
public:
static String^ GetWrapperVersion()

Return Value

The internal version of this FreeImage .NET wrapper.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


HasBackgroundColor Method

[image]

FreeImage .NET Documentation
FreeImage..::.HasBackgroundColor Method
FreeImage Class See Also Send Feedback
Returns whether the bitmap has a file background color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool HasBackgroundColor(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function HasBackgroundColor ( _
    dib As FIBITMAP _
) As Boolean
Visual C++
public:
static bool HasBackgroundColor(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Returns true when the image has a file background color, false otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


InsertPage Method

[image]

FreeImage .NET Documentation
FreeImage..::.InsertPage Method
FreeImage Class See Also Send Feedback
Inserts a new page before the given position in the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void InsertPage(
    FIMULTIBITMAP bitmap,
    int page,
    FIBITMAP data
)
Visual Basic (Declaration)
Public Shared Sub InsertPage ( _
    bitmap As FIMULTIBITMAP, _
    page As Integer, _
    data As FIBITMAP _
)
Visual C++
public:
static void InsertPage(
    FIMULTIBITMAP bitmap,
    int page,
    FIBITMAP data
)

Parameters

bitmap
Type: FreeImageAPI..::.FIMULTIBITMAP
Handle to a FreeImage multi-paged bitmap.
page
Type: System..::.Int32
Page has to be a number smaller than the current number of pages available in the bitmap.
data
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Invert Method

[image]

FreeImage .NET Documentation
FreeImage..::.Invert Method
FreeImage Class See Also Send Feedback
Inverts each pixel data.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool Invert(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function Invert ( _
    dib As FIBITMAP _
) As Boolean
Visual C++
public:
static bool Invert(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


IsAvailable Method

[image]

FreeImage .NET Documentation
FreeImage..::.IsAvailable Method
FreeImage Class See Also Send Feedback
Returns a value indicating if the FreeImage library is available or not. See remarks for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsAvailable()
Visual Basic (Declaration)
Public Shared Function IsAvailable As Boolean
Visual C++
public:
static bool IsAvailable()

Return Value

false if the file is not available or out of date; true, otherwise.

Remarks

The FreeImage.NET library is a wrapper for the native C++ library (FreeImage.dll ... dont mix ist up with this library FreeImageNet.dll). The native library must be either in the same folder as the program's executable or in a folder contained in the envirent variable PATH (for example %WINDIR%\System32).

Further more must both libraries, including the program itself, be the same architecture (x86 or x64).

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


IsExtensionValidForFIF Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.IsExtensionValidForFIF Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
IsExtensionValidForFIF(FREE_IMAGE_FORMAT, String) | Checks if an extension is valid for a certain format.
IsExtensionValidForFIF(FREE_IMAGE_FORMAT, String, StringComparison) | Checks if an extension is valid for a certain format.

See Also

FreeImage Class
FreeImage Members


IsExtensionValidForFIF Method (FREE_IMAGE_FORMAT, String)

[image]

FreeImage .NET Documentation
FreeImage..::.IsExtensionValidForFIF Method (FREE_IMAGE_FORMAT, String)
FreeImage Class See Also Send Feedback
Checks if an extension is valid for a certain format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsExtensionValidForFIF(
    FREE_IMAGE_FORMAT fif,
    string extension
)
Visual Basic (Declaration)
Public Shared Function IsExtensionValidForFIF ( _
    fif As FREE_IMAGE_FORMAT, _
    extension As String _
) As Boolean
Visual C++
public:
static bool IsExtensionValidForFIF(
    FREE_IMAGE_FORMAT fif,
    String^ extension
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The desired format.
extension
Type: System..::.String
The desired extension.

Return Value

True if the extension is valid for the given format, false otherwise.

Exceptions

Exception | Condition
System..::.ArgumentNullException | extension is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
IsExtensionValidForFIF Overload


IsExtensionValidForFIF Method (FREE_IMAGE_FORMAT, String, StringComparison)

[image]

FreeImage .NET Documentation
FreeImage..::.IsExtensionValidForFIF Method (FREE_IMAGE_FORMAT, String, StringComparison)
FreeImage Class See Also Send Feedback
Checks if an extension is valid for a certain format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsExtensionValidForFIF(
    FREE_IMAGE_FORMAT fif,
    string extension,
    StringComparison comparisonType
)
Visual Basic (Declaration)
Public Shared Function IsExtensionValidForFIF ( _
    fif As FREE_IMAGE_FORMAT, _
    extension As String, _
    comparisonType As StringComparison _
) As Boolean
Visual C++
public:
static bool IsExtensionValidForFIF(
    FREE_IMAGE_FORMAT fif,
    String^ extension,
    StringComparison comparisonType
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The desired format.
extension
Type: System..::.String
The desired extension.
comparisonType
Type: System..::.StringComparison
The string comparison type.

Return Value

True if the extension is valid for the given format, false otherwise.

Exceptions

Exception | Condition
System..::.ArgumentNullException | extension is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
IsExtensionValidForFIF Overload


IsFilenameValidForFIF Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.IsFilenameValidForFIF Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
IsFilenameValidForFIF(FREE_IMAGE_FORMAT, String) | Checks if a filename is valid for a certain format.
IsFilenameValidForFIF(FREE_IMAGE_FORMAT, String, StringComparison) | Checks if a filename is valid for a certain format.

See Also

FreeImage Class
FreeImage Members


IsFilenameValidForFIF Method (FREE_IMAGE_FORMAT, String)

[image]

FreeImage .NET Documentation
FreeImage..::.IsFilenameValidForFIF Method (FREE_IMAGE_FORMAT, String)
FreeImage Class See Also Send Feedback
Checks if a filename is valid for a certain format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsFilenameValidForFIF(
    FREE_IMAGE_FORMAT fif,
    string filename
)
Visual Basic (Declaration)
Public Shared Function IsFilenameValidForFIF ( _
    fif As FREE_IMAGE_FORMAT, _
    filename As String _
) As Boolean
Visual C++
public:
static bool IsFilenameValidForFIF(
    FREE_IMAGE_FORMAT fif,
    String^ filename
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The desired format.
filename
Type: System..::.String
The desired filename.

Return Value

True if the filename is valid for the given format, false otherwise.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
IsFilenameValidForFIF Overload


IsFilenameValidForFIF Method (FREE_IMAGE_FORMAT, String, StringComparison)

[image]

FreeImage .NET Documentation
FreeImage..::.IsFilenameValidForFIF Method (FREE_IMAGE_FORMAT, String, StringComparison)
FreeImage Class See Also Send Feedback
Checks if a filename is valid for a certain format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsFilenameValidForFIF(
    FREE_IMAGE_FORMAT fif,
    string filename,
    StringComparison comparisonType
)
Visual Basic (Declaration)
Public Shared Function IsFilenameValidForFIF ( _
    fif As FREE_IMAGE_FORMAT, _
    filename As String, _
    comparisonType As StringComparison _
) As Boolean
Visual C++
public:
static bool IsFilenameValidForFIF(
    FREE_IMAGE_FORMAT fif,
    String^ filename,
    StringComparison comparisonType
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The desired format.
filename
Type: System..::.String
The desired filename.
comparisonType
Type: System..::.StringComparison
The string comparison type.

Return Value

True if the filename is valid for the given format, false otherwise.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
IsFilenameValidForFIF Overload


IsGreyscaleImage Method

[image]

FreeImage .NET Documentation
FreeImage..::.IsGreyscaleImage Method
FreeImage Class See Also Send Feedback
Returns whether the image is a greyscale image or not. The function scans all colors in the bitmaps palette for entries where red, green and blue are not all the same (not a grey color). Supports 1-, 4- and 8-bit bitmaps.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsGreyscaleImage(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function IsGreyscaleImage ( _
    dib As FIBITMAP _
) As Boolean
Visual C++
public:
static bool IsGreyscaleImage(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

True if the image is a greyscale image, else false.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


IsLittleEndian Method

[image]

FreeImage .NET Documentation
FreeImage..::.IsLittleEndian Method
FreeImage Class See Also Send Feedback
Returns whether the platform is using Little Endian.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsLittleEndian()
Visual Basic (Declaration)
Public Shared Function IsLittleEndian As Boolean
Visual C++
public:
static bool IsLittleEndian()

Return Value

Returns true if the platform is using Litte Endian, else false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


IsPluginEnabled Method

[image]

FreeImage .NET Documentation
FreeImage..::.IsPluginEnabled Method
FreeImage Class See Also Send Feedback
Retrieves the state of a plugin.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int IsPluginEnabled(
    FREE_IMAGE_FORMAT fif
)
Visual Basic (Declaration)
Public Shared Function IsPluginEnabled ( _
    fif As FREE_IMAGE_FORMAT _
) As Integer
Visual C++
public:
static int IsPluginEnabled(
    FREE_IMAGE_FORMAT fif
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The plugin to check.

Return Value

1 - enabled. 0 - disables. -1 plugin does not exist.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


IsRGB555 Method

[image]

FreeImage .NET Documentation
FreeImage..::.IsRGB555 Method
FreeImage Class See Also Send Feedback
Verifies whether the FreeImage bitmap is 16bit 555.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsRGB555(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function IsRGB555 ( _
    dib As FIBITMAP _
) As Boolean
Visual C++
public:
static bool IsRGB555(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
The FreeImage bitmap to verify.

Return Value

true if the bitmap is RGB16-555; otherwise false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


IsRGB565 Method

[image]

FreeImage .NET Documentation
FreeImage..::.IsRGB565 Method
FreeImage Class See Also Send Feedback
Verifies whether the FreeImage bitmap is 16bit 565.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsRGB565(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function IsRGB565 ( _
    dib As FIBITMAP _
) As Boolean
Visual C++
public:
static bool IsRGB565(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
The FreeImage bitmap to verify.

Return Value

true if the bitmap is RGB16-565; otherwise false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


IsTransparent Method

[image]

FreeImage .NET Documentation
FreeImage..::.IsTransparent Method
FreeImage Class See Also Send Feedback
Returns whether the transparency table is enabled.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsTransparent(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function IsTransparent ( _
    dib As FIBITMAP _
) As Boolean
Visual C++
public:
static bool IsTransparent(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Returns true when the transparency table is enabled (1-, 4- or 8-bit images) or when the input dib contains alpha values (32-bit images). Returns false otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


JPEGCrop Method

[image]

FreeImage .NET Documentation
FreeImage..::.JPEGCrop Method
FreeImage Class See Also Send Feedback
Performs a lossless crop on a JPEG file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool JPEGCrop(
    string src_file,
    string dst_file,
    int left,
    int top,
    int right,
    int bottom
)
Visual Basic (Declaration)
Public Shared Function JPEGCrop ( _
    src_file As String, _
    dst_file As String, _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
) As Boolean
Visual C++
public:
static bool JPEGCrop(
    String^ src_file,
    String^ dst_file,
    int left,
    int top,
    int right,
    int bottom
)

Parameters

src_file
Type: System..::.String
Source filename.
dst_file
Type: System..::.String
Destination filename.
left
Type: System..::.Int32
Specifies the left position of the cropped rectangle.
top
Type: System..::.Int32
Specifies the top position of the cropped rectangle.
right
Type: System..::.Int32
Specifies the right position of the cropped rectangle.
bottom
Type: System..::.Int32
Specifies the bottom position of the cropped rectangle.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


JPEGTransform Method

[image]

FreeImage .NET Documentation
FreeImage..::.JPEGTransform Method
FreeImage Class See Also Send Feedback
Performs a lossless rotation or flipping on a JPEG file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool JPEGTransform(
    string src_file,
    string dst_file,
    FREE_IMAGE_JPEG_OPERATION operation,
    bool perfect
)
Visual Basic (Declaration)
Public Shared Function JPEGTransform ( _
    src_file As String, _
    dst_file As String, _
    operation As FREE_IMAGE_JPEG_OPERATION, _
    perfect As Boolean _
) As Boolean
Visual C++
public:
static bool JPEGTransform(
    String^ src_file,
    String^ dst_file,
    FREE_IMAGE_JPEG_OPERATION operation,
    bool perfect
)

Parameters

src_file
Type: System..::.String
Source file.
dst_file
Type: System..::.String
Destination file; can be the source file; will be overwritten.
operation
Type: FreeImageAPI..::.FREE_IMAGE_JPEG_OPERATION
The operation to apply.
perfect
Type: System..::.Boolean
To avoid lossy transformation, you can set the perfect parameter to true.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Load Method

[image]

FreeImage .NET Documentation
FreeImage..::.Load Method
FreeImage Class See Also Send Feedback
Decodes a bitmap, allocates memory for it and returns it as a FIBITMAP.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Load(
    FREE_IMAGE_FORMAT fif,
    string filename,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function Load ( _
    fif As FREE_IMAGE_FORMAT, _
    filename As String, _
    flags As FREE_IMAGE_LOAD_FLAGS _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Load(
    FREE_IMAGE_FORMAT fif,
    String^ filename,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Type of the bitmap.
filename
Type: System..::.String
Name of the file to decode.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


LoadBitmap Method

[image]

FreeImage .NET Documentation
FreeImage..::.LoadBitmap Method
FreeImage Class See Also Send Feedback
Loads a .NET Bitmap from a file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static Bitmap LoadBitmap(
    string filename,
    FREE_IMAGE_LOAD_FLAGS flags,
    ref FREE_IMAGE_FORMAT format
)
Visual Basic (Declaration)
Public Shared Function LoadBitmap ( _
    filename As String, _
    flags As FREE_IMAGE_LOAD_FLAGS, _
    ByRef format As FREE_IMAGE_FORMAT _
) As Bitmap
Visual C++
public:
static Bitmap^ LoadBitmap(
    String^ filename,
    FREE_IMAGE_LOAD_FLAGS flags,
    FREE_IMAGE_FORMAT% format
)

Parameters

filename
Type: System..::.String
Name of the file to be loaded.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT %
Format of the image. If the format should be taken from the filename use FIF_UNKNOWN.

Return Value

The loaded .NET Bitmap.

Exceptions

Exception | Condition
System.IO..::.FileNotFoundException | filename does not exists.
System..::.ArgumentException | The image type of the image is not FIT_BITMAP.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


LoadEx Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.LoadEx Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
LoadEx(String) | Loads a FreeImage bitmap. The file will be loaded with default loading flags.
LoadEx(String, FREE_IMAGE_FORMAT%) | Loads a FreeImage bitmap. In case the loading format is FIF_UNKNOWN the files real format is being analysed. If no plugin can read the file, format remains FIF_UNKNOWN and 0 is returned. The file will be loaded with default loading flags.
LoadEx(String, FREE_IMAGE_LOAD_FLAGS) | Loads a FreeImage bitmap. Load flags can be provided by the flags parameter.
LoadEx(String, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_FORMAT%) | Loads a FreeImage bitmap. In case the loading format is FIF_UNKNOWN the files real format is being analysed. If no plugin can read the file, format remains FIF_UNKNOWN and 0 is returned. Load flags can be provided by the flags parameter.

See Also

FreeImage Class
FreeImage Members


LoadEx Method (String)

[image]

FreeImage .NET Documentation
FreeImage..::.LoadEx Method (String)
FreeImage Class See Also Send Feedback
Loads a FreeImage bitmap. The file will be loaded with default loading flags.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP LoadEx(
    string filename
)
Visual Basic (Declaration)
Public Shared Function LoadEx ( _
    filename As String _
) As FIBITMAP
Visual C++
public:
static FIBITMAP LoadEx(
    String^ filename
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System.IO..::.FileNotFoundException | filename does not exists.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
LoadEx Overload


LoadEx Method (String, FREE_IMAGE_FORMAT)

[image]

FreeImage .NET Documentation
FreeImage..::.LoadEx Method (String, FREE_IMAGE_FORMAT%)
FreeImage Class See Also Send Feedback
Loads a FreeImage bitmap. In case the loading format is FIF_UNKNOWN the files real format is being analysed. If no plugin can read the file, format remains FIF_UNKNOWN and 0 is returned. The file will be loaded with default loading flags.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP LoadEx(
    string filename,
    ref FREE_IMAGE_FORMAT format
)
Visual Basic (Declaration)
Public Shared Function LoadEx ( _
    filename As String, _
    ByRef format As FREE_IMAGE_FORMAT _
) As FIBITMAP
Visual C++
public:
static FIBITMAP LoadEx(
    String^ filename,
    FREE_IMAGE_FORMAT% format
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT %
Format of the image. If the format is unknown use FIF_UNKNOWN. In case a suitable format was found by LoadEx it will be returned in format.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System.IO..::.FileNotFoundException | filename does not exists.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
LoadEx Overload


LoadEx Method (String, FREE_IMAGE_LOAD_FLAGS)

[image]

FreeImage .NET Documentation
FreeImage..::.LoadEx Method (String, FREE_IMAGE_LOAD_FLAGS)
FreeImage Class See Also Send Feedback
Loads a FreeImage bitmap. Load flags can be provided by the flags parameter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP LoadEx(
    string filename,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function LoadEx ( _
    filename As String, _
    flags As FREE_IMAGE_LOAD_FLAGS _
) As FIBITMAP
Visual C++
public:
static FIBITMAP LoadEx(
    String^ filename,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System.IO..::.FileNotFoundException | filename does not exists.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
LoadEx Overload


LoadEx Method (String, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_FORMAT)

[image]

FreeImage .NET Documentation
FreeImage..::.LoadEx Method (String, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_FORMAT%)
FreeImage Class See Also Send Feedback
Loads a FreeImage bitmap. In case the loading format is FIF_UNKNOWN the files real format is being analysed. If no plugin can read the file, format remains FIF_UNKNOWN and 0 is returned. Load flags can be provided by the flags parameter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP LoadEx(
    string filename,
    FREE_IMAGE_LOAD_FLAGS flags,
    ref FREE_IMAGE_FORMAT format
)
Visual Basic (Declaration)
Public Shared Function LoadEx ( _
    filename As String, _
    flags As FREE_IMAGE_LOAD_FLAGS, _
    ByRef format As FREE_IMAGE_FORMAT _
) As FIBITMAP
Visual C++
public:
static FIBITMAP LoadEx(
    String^ filename,
    FREE_IMAGE_LOAD_FLAGS flags,
    FREE_IMAGE_FORMAT% format
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT %
Format of the image. If the format is unknown use FIF_UNKNOWN. In case a suitable format was found by LoadEx it will be returned in format.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System.IO..::.FileNotFoundException | filename does not exists.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
LoadEx Overload


LoadFromHandle Method

[image]

FreeImage .NET Documentation
FreeImage..::.LoadFromHandle Method
FreeImage Class See Also Send Feedback
Loads a bitmap from an arbitrary source.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP LoadFromHandle(
    FREE_IMAGE_FORMAT fif,
    ref FreeImageIO io,
    fi_handle handle,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function LoadFromHandle ( _
    fif As FREE_IMAGE_FORMAT, _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    flags As FREE_IMAGE_LOAD_FLAGS _
) As FIBITMAP
Visual C++
public:
static FIBITMAP LoadFromHandle(
    FREE_IMAGE_FORMAT fif,
    FreeImageIO% io,
    fi_handle handle,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Type of the bitmap.
io
Type: FreeImageAPI.IO..::.FreeImageIO %
A FreeImageIO structure with functionpointers to handle the source.
handle
Type: FreeImageAPI.IO..::.fi_handle
A handle to the source.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


LoadFromMemory Method

[image]

FreeImage .NET Documentation
FreeImage..::.LoadFromMemory Method
FreeImage Class See Also Send Feedback
Decodes a bitmap from a stream, allocates memory for it and returns it as a FIBITMAP.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP LoadFromMemory(
    FREE_IMAGE_FORMAT fif,
    FIMEMORY stream,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function LoadFromMemory ( _
    fif As FREE_IMAGE_FORMAT, _
    stream As FIMEMORY, _
    flags As FREE_IMAGE_LOAD_FLAGS _
) As FIBITMAP
Visual C++
public:
static FIBITMAP LoadFromMemory(
    FREE_IMAGE_FORMAT fif,
    FIMEMORY stream,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Type of the bitmap.
stream
Type: FreeImageAPI..::.FIMEMORY
Handle to a memory stream.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


LoadFromStream Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.LoadFromStream Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
LoadFromStream(Stream) | Loads a FreeImage bitmap. The stream must be set to the correct position before calling LoadFromStream.
LoadFromStream(Stream, FREE_IMAGE_FORMAT%) | Loads a FreeImage bitmap. In case the loading format is FIF_UNKNOWN the bitmaps real format is being analysed. The stream must be set to the correct position before calling LoadFromStream.
LoadFromStream(Stream, FREE_IMAGE_LOAD_FLAGS) | Loads a FreeImage bitmap. The stream must be set to the correct position before calling LoadFromStream.
LoadFromStream(Stream, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_FORMAT%) | Loads a FreeImage bitmap. In case the loading format is FIF_UNKNOWN the bitmaps real format is being analysed. The stream must be set to the correct position before calling LoadFromStream.

See Also

FreeImage Class
FreeImage Members


LoadFromStream Method (Stream)

[image]

FreeImage .NET Documentation
FreeImage..::.LoadFromStream Method (Stream)
FreeImage Class See Also Send Feedback
Loads a FreeImage bitmap. The stream must be set to the correct position before calling LoadFromStream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP LoadFromStream(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function LoadFromStream ( _
    stream As Stream _
) As FIBITMAP
Visual C++
public:
static FIBITMAP LoadFromStream(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream to read from.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | stream is null.
System..::.ArgumentException | stream is not capable of reading.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
LoadFromStream Overload


LoadFromStream Method (Stream, FREE_IMAGE_FORMAT)

[image]

FreeImage .NET Documentation
FreeImage..::.LoadFromStream Method (Stream, FREE_IMAGE_FORMAT%)
FreeImage Class See Also Send Feedback
Loads a FreeImage bitmap. In case the loading format is FIF_UNKNOWN the bitmaps real format is being analysed. The stream must be set to the correct position before calling LoadFromStream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP LoadFromStream(
    Stream stream,
    ref FREE_IMAGE_FORMAT format
)
Visual Basic (Declaration)
Public Shared Function LoadFromStream ( _
    stream As Stream, _
    ByRef format As FREE_IMAGE_FORMAT _
) As FIBITMAP
Visual C++
public:
static FIBITMAP LoadFromStream(
    Stream^ stream,
    FREE_IMAGE_FORMAT% format
)

Parameters

stream
Type: System.IO..::.Stream
The stream to read from.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT %
Format of the image. If the format is unknown use FIF_UNKNOWN. In case a suitable format was found by LoadFromStream it will be returned in format.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | stream is null.
System..::.ArgumentException | stream is not capable of reading.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
LoadFromStream Overload


LoadFromStream Method (Stream, FREE_IMAGE_LOAD_FLAGS)

[image]

FreeImage .NET Documentation
FreeImage..::.LoadFromStream Method (Stream, FREE_IMAGE_LOAD_FLAGS)
FreeImage Class See Also Send Feedback
Loads a FreeImage bitmap. The stream must be set to the correct position before calling LoadFromStream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP LoadFromStream(
    Stream stream,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function LoadFromStream ( _
    stream As Stream, _
    flags As FREE_IMAGE_LOAD_FLAGS _
) As FIBITMAP
Visual C++
public:
static FIBITMAP LoadFromStream(
    Stream^ stream,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

stream
Type: System.IO..::.Stream
The stream to read from.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | stream is null.
System..::.ArgumentException | stream is not capable of reading.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
LoadFromStream Overload


LoadFromStream Method (Stream, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_FORMAT)

[image]

FreeImage .NET Documentation
FreeImage..::.LoadFromStream Method (Stream, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_FORMAT%)
FreeImage Class See Also Send Feedback
Loads a FreeImage bitmap. In case the loading format is FIF_UNKNOWN the bitmaps real format is being analysed. The stream must be set to the correct position before calling LoadFromStream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP LoadFromStream(
    Stream stream,
    FREE_IMAGE_LOAD_FLAGS flags,
    ref FREE_IMAGE_FORMAT format
)
Visual Basic (Declaration)
Public Shared Function LoadFromStream ( _
    stream As Stream, _
    flags As FREE_IMAGE_LOAD_FLAGS, _
    ByRef format As FREE_IMAGE_FORMAT _
) As FIBITMAP
Visual C++
public:
static FIBITMAP LoadFromStream(
    Stream^ stream,
    FREE_IMAGE_LOAD_FLAGS flags,
    FREE_IMAGE_FORMAT% format
)

Parameters

stream
Type: System.IO..::.Stream
The stream to read from.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT %
Format of the image. If the format is unknown use FIF_UNKNOWN. In case a suitable format was found by LoadFromStream it will be returned in format.

Return Value

Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | stream is null.
System..::.ArgumentException | stream is not capable of reading.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
LoadFromStream Overload


LoadMultiBitmapFromMemory Method

[image]

FreeImage .NET Documentation
FreeImage..::.LoadMultiBitmapFromMemory Method
FreeImage Class See Also Send Feedback
Open a multi-page bitmap from a memory stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP LoadMultiBitmapFromMemory(
    FREE_IMAGE_FORMAT fif,
    FIMEMORY stream,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function LoadMultiBitmapFromMemory ( _
    fif As FREE_IMAGE_FORMAT, _
    stream As FIMEMORY, _
    flags As FREE_IMAGE_LOAD_FLAGS _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP LoadMultiBitmapFromMemory(
    FREE_IMAGE_FORMAT fif,
    FIMEMORY stream,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Type of the bitmap.
stream
Type: FreeImageAPI..::.FIMEMORY
The stream to decode.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Return Value

Handle to a FreeImage multi-paged bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


LoadMultiBitmapFromStream Method

[image]

FreeImage .NET Documentation
FreeImage..::.LoadMultiBitmapFromStream Method
FreeImage Class See Also Send Feedback
Loads a FreeImage multi-paged bitmap from a stream and returns the FreeImage memory stream used as temporary buffer. The bitmap can not be modified by calling AppendPage(FIMULTIBITMAP, FIBITMAP), InsertPage(FIMULTIBITMAP, Int32, FIBITMAP), MovePage(FIMULTIBITMAP, Int32, Int32) or DeletePage(FIMULTIBITMAP, Int32).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP LoadMultiBitmapFromStream(
    Stream stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS flags,
    out FIMEMORY memory
)
Visual Basic (Declaration)
Public Shared Function LoadMultiBitmapFromStream ( _
    stream As Stream, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_LOAD_FLAGS, _
    <OutAttribute> ByRef memory As FIMEMORY _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP LoadMultiBitmapFromStream(
    Stream^ stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS flags,
    [OutAttribute] FIMEMORY% memory
)

Parameters

stream
Type: System.IO..::.Stream
The stream to read from.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.
memory
Type: FreeImageAPI..::.FIMEMORY %
The temporary memory buffer used to load the bitmap.

Return Value

Handle to a FreeImage multi-paged bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | stream is null.
System..::.ArgumentException | stream can not read.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


LockPage Method

[image]

FreeImage .NET Documentation
FreeImage..::.LockPage Method
FreeImage Class See Also Send Feedback
Locks a page in memory for editing.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP LockPage(
    FIMULTIBITMAP bitmap,
    int page
)
Visual Basic (Declaration)
Public Shared Function LockPage ( _
    bitmap As FIMULTIBITMAP, _
    page As Integer _
) As FIBITMAP
Visual C++
public:
static FIBITMAP LockPage(
    FIMULTIBITMAP bitmap,
    int page
)

Parameters

bitmap
Type: FreeImageAPI..::.FIMULTIBITMAP
Handle to a FreeImage multi-paged bitmap.
page
Type: System..::.Int32
Number of the page to lock.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


LookupSVGColor Method

[image]

FreeImage .NET Documentation
FreeImage..::.LookupSVGColor Method
FreeImage Class See Also Send Feedback
Converts a SVG color name into a corresponding RGB value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool LookupSVGColor(
    string szColor,
    out byte nRed,
    out byte nGreen,
    out byte nBlue
)
Visual Basic (Declaration)
Public Shared Function LookupSVGColor ( _
    szColor As String, _
    <OutAttribute> ByRef nRed As Byte, _
    <OutAttribute> ByRef nGreen As Byte, _
    <OutAttribute> ByRef nBlue As Byte _
) As Boolean
Visual C++
public:
static bool LookupSVGColor(
    String^ szColor,
    [OutAttribute] unsigned char% nRed,
    [OutAttribute] unsigned char% nGreen,
    [OutAttribute] unsigned char% nBlue
)

Parameters

szColor
Type: System..::.String
Name of the color to convert.
nRed
Type: System..::.Byte %
Red component.
nGreen
Type: System..::.Byte %
Green component.
nBlue
Type: System..::.Byte %
Blue component.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


LookupX11Color Method

[image]

FreeImage .NET Documentation
FreeImage..::.LookupX11Color Method
FreeImage Class See Also Send Feedback
Converts a X11 color name into a corresponding RGB value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool LookupX11Color(
    string szColor,
    out byte nRed,
    out byte nGreen,
    out byte nBlue
)
Visual Basic (Declaration)
Public Shared Function LookupX11Color ( _
    szColor As String, _
    <OutAttribute> ByRef nRed As Byte, _
    <OutAttribute> ByRef nGreen As Byte, _
    <OutAttribute> ByRef nBlue As Byte _
) As Boolean
Visual C++
public:
static bool LookupX11Color(
    String^ szColor,
    [OutAttribute] unsigned char% nRed,
    [OutAttribute] unsigned char% nGreen,
    [OutAttribute] unsigned char% nBlue
)

Parameters

szColor
Type: System..::.String
Name of the color to convert.
nRed
Type: System..::.Byte %
Red component.
nGreen
Type: System..::.Byte %
Green component.
nBlue
Type: System..::.Byte %
Blue component.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


MakeThumbnail Method

[image]

FreeImage .NET Documentation
FreeImage..::.MakeThumbnail Method
FreeImage Class See Also Send Feedback
Creates a thumbnail from a greyscale or RGB(A) image, keeping aspect ratio.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP MakeThumbnail(
    FIBITMAP dib,
    int max_pixel_size,
    bool convert
)
Visual Basic (Declaration)
Public Shared Function MakeThumbnail ( _
    dib As FIBITMAP, _
    max_pixel_size As Integer, _
    convert As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP MakeThumbnail(
    FIBITMAP dib,
    int max_pixel_size,
    bool convert
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
max_pixel_size
Type: System..::.Int32
Thumbnail square size.
convert
Type: System..::.Boolean
When true HDR images are transperantly converted to standard images.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


MoveMemory Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.MoveMemory Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
MoveMemory(IntPtr, IntPtr, Int64) | Moves a block of memory from one location to another.
MoveMemory(IntPtr, IntPtr, UInt32) | Moves a block of memory from one location to another.
MoveMemory(Void*, Void*, Int64) | Moves a block of memory from one location to another.
MoveMemory(Void*, Void*, UInt32) | Moves a block of memory from one location to another.

See Also

FreeImage Class
FreeImage Members


MoveMemory Method (IntPtr, IntPtr, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.MoveMemory Method (IntPtr, IntPtr, Int64)
FreeImage Class See Also Send Feedback
Moves a block of memory from one location to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void MoveMemory(
    IntPtr dst,
    IntPtr src,
    long size
)
Visual Basic (Declaration)
Public Shared Sub MoveMemory ( _
    dst As IntPtr, _
    src As IntPtr, _
    size As Long _
)
Visual C++
public:
static void MoveMemory(
    IntPtr dst,
    IntPtr src,
    long long size
)

Parameters

dst
Type: System..::.IntPtr
A pointer to the starting address of the move destination.
src
Type: System..::.IntPtr
A pointer to the starting address of the block of memory to be moved.
size
Type: System..::.Int64
The size of the block of memory to move, in bytes.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
MoveMemory Overload


MoveMemory Method (IntPtr, IntPtr, UInt32)

[image]

FreeImage .NET Documentation
FreeImage..::.MoveMemory Method (IntPtr, IntPtr, UInt32)
FreeImage Class See Also Send Feedback
Moves a block of memory from one location to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void MoveMemory(
    IntPtr dst,
    IntPtr src,
    uint size
)
Visual Basic (Declaration)
Public Shared Sub MoveMemory ( _
    dst As IntPtr, _
    src As IntPtr, _
    size As UInteger _
)
Visual C++
public:
static void MoveMemory(
    IntPtr dst,
    IntPtr src,
    unsigned int size
)

Parameters

dst
Type: System..::.IntPtr
A pointer to the starting address of the move destination.
src
Type: System..::.IntPtr
A pointer to the starting address of the block of memory to be moved.
size
Type: System..::.UInt32
The size of the block of memory to move, in bytes.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
MoveMemory Overload


MoveMemory Method (Void*, Void*, Int64)

[image]

FreeImage .NET Documentation
FreeImage..::.MoveMemory Method (Void*, Void*, Int64)
FreeImage Class See Also Send Feedback
Moves a block of memory from one location to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void MoveMemory(
    void* dst,
    void* src,
    long size
)
Visual Basic (Declaration)
Public Shared Sub MoveMemory ( _
    dst As Void*, _
    src As Void*, _
    size As Long _
)
Visual C++
public:
static void MoveMemory(
    void* dst,
    void* src,
    long long size
)

Parameters

dst
Type: System..::.Void *
A pointer to the starting address of the move destination.
src
Type: System..::.Void *
A pointer to the starting address of the block of memory to be moved.
size
Type: System..::.Int64
The size of the block of memory to move, in bytes.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
MoveMemory Overload


MoveMemory Method (Void*, Void*, UInt32)

[image]

FreeImage .NET Documentation
FreeImage..::.MoveMemory Method (Void*, Void*, UInt32)
FreeImage Class See Also Send Feedback
Moves a block of memory from one location to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void MoveMemory(
    void* dst,
    void* src,
    uint size
)
Visual Basic (Declaration)
Public Shared Sub MoveMemory ( _
    dst As Void*, _
    src As Void*, _
    size As UInteger _
)
Visual C++
public:
static void MoveMemory(
    void* dst,
    void* src,
    unsigned int size
)

Parameters

dst
Type: System..::.Void *
Pointer to the starting address of the move destination.
src
Type: System..::.Void *
Pointer to the starting address of the block of memory to be moved.
size
Type: System..::.UInt32
Size of the block of memory to move, in bytes.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
MoveMemory Overload


MovePage Method

[image]

FreeImage .NET Documentation
FreeImage..::.MovePage Method
FreeImage Class See Also Send Feedback
Moves the source page to the position of the target page.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool MovePage(
    FIMULTIBITMAP bitmap,
    int target,
    int source
)
Visual Basic (Declaration)
Public Shared Function MovePage ( _
    bitmap As FIMULTIBITMAP, _
    target As Integer, _
    source As Integer _
) As Boolean
Visual C++
public:
static bool MovePage(
    FIMULTIBITMAP bitmap,
    int target,
    int source
)

Parameters

bitmap
Type: FreeImageAPI..::.FIMULTIBITMAP
Handle to a FreeImage multi-paged bitmap.
target
Type: System..::.Int32
New position of the page.
source
Type: System..::.Int32
Old position of the page.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


MultigridPoissonSolver Method

[image]

FreeImage .NET Documentation
FreeImage..::.MultigridPoissonSolver Method
FreeImage Class See Also Send Feedback
Solves a Poisson equation, remap result pixels to [0..1] and returns the solution.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP MultigridPoissonSolver(
    FIBITMAP Laplacian,
    int ncycle
)
Visual Basic (Declaration)
Public Shared Function MultigridPoissonSolver ( _
    Laplacian As FIBITMAP, _
    ncycle As Integer _
) As FIBITMAP
Visual C++
public:
static FIBITMAP MultigridPoissonSolver(
    FIBITMAP Laplacian,
    int ncycle
)

Parameters

Laplacian
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
ncycle
Type: System..::.Int32
Number of cycles in the multigrid algorithm (usually 2 or 3)

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


OpenMemory Method

[image]

FreeImage .NET Documentation
FreeImage..::.OpenMemory Method
FreeImage Class See Also Send Feedback
Open a memory stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMEMORY OpenMemory(
    IntPtr data,
    uint size_in_bytes
)
Visual Basic (Declaration)
Public Shared Function OpenMemory ( _
    data As IntPtr, _
    size_in_bytes As UInteger _
) As FIMEMORY
Visual C++
public:
static FIMEMORY OpenMemory(
    IntPtr data,
    unsigned int size_in_bytes
)

Parameters

data
Type: System..::.IntPtr
Pointer to the data in memory.
size_in_bytes
Type: System..::.UInt32
Length of the data in byte.

Return Value

Handle to a memory stream.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


OpenMultiBitmap Method

[image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmap Method
FreeImage Class See Also Send Feedback
Loads a FreeImage multi-paged bitmap. Load flags can be provided by the flags parameter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP OpenMultiBitmap(
    FREE_IMAGE_FORMAT fif,
    string filename,
    bool create_new,
    bool read_only,
    bool keep_cache_in_memory,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function OpenMultiBitmap ( _
    fif As FREE_IMAGE_FORMAT, _
    filename As String, _
    create_new As Boolean, _
    read_only As Boolean, _
    keep_cache_in_memory As Boolean, _
    flags As FREE_IMAGE_LOAD_FLAGS _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP OpenMultiBitmap(
    FREE_IMAGE_FORMAT fif,
    String^ filename,
    bool create_new,
    bool read_only,
    bool keep_cache_in_memory,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
filename
Type: System..::.String
The complete name of the file to load.
create_new
Type: System..::.Boolean
When true a new bitmap is created.
read_only
Type: System..::.Boolean
When true the bitmap will be loaded read only.
keep_cache_in_memory
Type: System..::.Boolean
When true performance is increased at the cost of memory.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Return Value

Handle to a FreeImage multi-paged bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


OpenMultiBitmapEx Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmapEx Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
OpenMultiBitmapEx(String) | Loads a FreeImage multi-paged bitmap.
OpenMultiBitmapEx(String, Boolean) | Loads a FreeImage multi-paged bitmap.
OpenMultiBitmapEx(String, Boolean, Boolean) | Loads a FreeImage multi-paged bitmap.
OpenMultiBitmapEx(String, Boolean, Boolean, Boolean) | Loads a FreeImage multi-paged bitmap.
OpenMultiBitmapEx(String, FREE_IMAGE_FORMAT%, Boolean, Boolean, Boolean) | Loads a FreeImage multi-paged bitmap. In case the loading format is FIF_UNKNOWN the files real format is being analysed. If no plugin can read the file, format remains FIF_UNKNOWN and 0 is returned.
OpenMultiBitmapEx(String, FREE_IMAGE_FORMAT%, FREE_IMAGE_LOAD_FLAGS, Boolean, Boolean, Boolean) | Loads a FreeImage multi-paged bitmap. In case the loading format is FIF_UNKNOWN the files real format is being analysed. If no plugin can read the file, format remains FIF_UNKNOWN and 0 is returned. Load flags can be provided by the flags parameter.

See Also

FreeImage Class
FreeImage Members


OpenMultiBitmapEx Method (String)

[image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmapEx Method (String)
FreeImage Class See Also Send Feedback
Loads a FreeImage multi-paged bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP OpenMultiBitmapEx(
    string filename
)
Visual Basic (Declaration)
Public Shared Function OpenMultiBitmapEx ( _
    filename As String _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP OpenMultiBitmapEx(
    String^ filename
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.

Return Value

Handle to a FreeImage multi-paged bitmap.

Exceptions

Exception | Condition
System.IO..::.FileNotFoundException | filename does not exists while opening.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
OpenMultiBitmapEx Overload


OpenMultiBitmapEx Method (String, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmapEx Method (String, Boolean)
FreeImage Class See Also Send Feedback
Loads a FreeImage multi-paged bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP OpenMultiBitmapEx(
    string filename,
    bool keep_cache_in_memory
)
Visual Basic (Declaration)
Public Shared Function OpenMultiBitmapEx ( _
    filename As String, _
    keep_cache_in_memory As Boolean _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP OpenMultiBitmapEx(
    String^ filename,
    bool keep_cache_in_memory
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
keep_cache_in_memory
Type: System..::.Boolean
When true performance is increased at the cost of memory.

Return Value

Handle to a FreeImage multi-paged bitmap.

Exceptions

Exception | Condition
System.IO..::.FileNotFoundException | filename does not exists while opening.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
OpenMultiBitmapEx Overload


OpenMultiBitmapEx Method (String, Boolean, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmapEx Method (String, Boolean, Boolean)
FreeImage Class See Also Send Feedback
Loads a FreeImage multi-paged bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP OpenMultiBitmapEx(
    string filename,
    bool read_only,
    bool keep_cache_in_memory
)
Visual Basic (Declaration)
Public Shared Function OpenMultiBitmapEx ( _
    filename As String, _
    read_only As Boolean, _
    keep_cache_in_memory As Boolean _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP OpenMultiBitmapEx(
    String^ filename,
    bool read_only,
    bool keep_cache_in_memory
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
read_only
Type: System..::.Boolean
When true the bitmap will be loaded read only.
keep_cache_in_memory
Type: System..::.Boolean
When true performance is increased at the cost of memory.

Return Value

Handle to a FreeImage multi-paged bitmap.

Exceptions

Exception | Condition
System.IO..::.FileNotFoundException | filename does not exists while opening.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
OpenMultiBitmapEx Overload


OpenMultiBitmapEx Method (String, Boolean, Boolean, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmapEx Method (String, Boolean, Boolean, Boolean)
FreeImage Class See Also Send Feedback
Loads a FreeImage multi-paged bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP OpenMultiBitmapEx(
    string filename,
    bool create_new,
    bool read_only,
    bool keep_cache_in_memory
)
Visual Basic (Declaration)
Public Shared Function OpenMultiBitmapEx ( _
    filename As String, _
    create_new As Boolean, _
    read_only As Boolean, _
    keep_cache_in_memory As Boolean _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP OpenMultiBitmapEx(
    String^ filename,
    bool create_new,
    bool read_only,
    bool keep_cache_in_memory
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
create_new
Type: System..::.Boolean
When true a new bitmap is created.
read_only
Type: System..::.Boolean
When true the bitmap will be loaded read only.
keep_cache_in_memory
Type: System..::.Boolean
When true performance is increased at the cost of memory.

Return Value

Handle to a FreeImage multi-paged bitmap.

Exceptions

Exception | Condition
System.IO..::.FileNotFoundException | filename does not exists while opening.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
OpenMultiBitmapEx Overload


OpenMultiBitmapEx Method (String, FREE_IMAGE_FORMAT, Boolean, Boolean, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmapEx Method (String, FREE_IMAGE_FORMAT%, Boolean, Boolean, Boolean)
FreeImage Class See Also Send Feedback
Loads a FreeImage multi-paged bitmap. In case the loading format is FIF_UNKNOWN the files real format is being analysed. If no plugin can read the file, format remains FIF_UNKNOWN and 0 is returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP OpenMultiBitmapEx(
    string filename,
    ref FREE_IMAGE_FORMAT format,
    bool create_new,
    bool read_only,
    bool keep_cache_in_memory
)
Visual Basic (Declaration)
Public Shared Function OpenMultiBitmapEx ( _
    filename As String, _
    ByRef format As FREE_IMAGE_FORMAT, _
    create_new As Boolean, _
    read_only As Boolean, _
    keep_cache_in_memory As Boolean _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP OpenMultiBitmapEx(
    String^ filename,
    FREE_IMAGE_FORMAT% format,
    bool create_new,
    bool read_only,
    bool keep_cache_in_memory
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT %
Format of the image. If the format is unknown use FIF_UNKNOWN. In case a suitable format was found by LoadEx it will be returned in format.
create_new
Type: System..::.Boolean
When true a new bitmap is created.
read_only
Type: System..::.Boolean
When true the bitmap will be loaded read only.
keep_cache_in_memory
Type: System..::.Boolean
When true performance is increased at the cost of memory.

Return Value

Handle to a FreeImage multi-paged bitmap.

Exceptions

Exception | Condition
System.IO..::.FileNotFoundException | filename does not exists while opening.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
OpenMultiBitmapEx Overload


OpenMultiBitmapEx Method (String, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, Boolean, Boolean, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmapEx Method (String, FREE_IMAGE_FORMAT%, FREE_IMAGE_LOAD_FLAGS, Boolean, Boolean, Boolean)
FreeImage Class See Also Send Feedback
Loads a FreeImage multi-paged bitmap. In case the loading format is FIF_UNKNOWN the files real format is being analysed. If no plugin can read the file, format remains FIF_UNKNOWN and 0 is returned. Load flags can be provided by the flags parameter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP OpenMultiBitmapEx(
    string filename,
    ref FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS flags,
    bool create_new,
    bool read_only,
    bool keep_cache_in_memory
)
Visual Basic (Declaration)
Public Shared Function OpenMultiBitmapEx ( _
    filename As String, _
    ByRef format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_LOAD_FLAGS, _
    create_new As Boolean, _
    read_only As Boolean, _
    keep_cache_in_memory As Boolean _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP OpenMultiBitmapEx(
    String^ filename,
    FREE_IMAGE_FORMAT% format,
    FREE_IMAGE_LOAD_FLAGS flags,
    bool create_new,
    bool read_only,
    bool keep_cache_in_memory
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT %
Format of the image. If the format is unknown use FIF_UNKNOWN. In case a suitable format was found by LoadEx it will be returned in format.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.
create_new
Type: System..::.Boolean
When true a new bitmap is created.
read_only
Type: System..::.Boolean
When true the bitmap will be loaded read only.
keep_cache_in_memory
Type: System..::.Boolean
When true performance is increased at the cost of memory.

Return Value

Handle to a FreeImage multi-paged bitmap.

Exceptions

Exception | Condition
System.IO..::.FileNotFoundException | filename does not exists while opening.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
OpenMultiBitmapEx Overload


OpenMultiBitmapFromHandle Method

[image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmapFromHandle Method
FreeImage Class See Also Send Feedback
Loads a FreeImage multi-pages bitmap from the specified handle using the specified functions. Load flags can be provided by the flags parameter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP OpenMultiBitmapFromHandle(
    FREE_IMAGE_FORMAT fif,
    ref FreeImageIO io,
    fi_handle handle,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function OpenMultiBitmapFromHandle ( _
    fif As FREE_IMAGE_FORMAT, _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    flags As FREE_IMAGE_LOAD_FLAGS _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP OpenMultiBitmapFromHandle(
    FREE_IMAGE_FORMAT fif,
    FreeImageIO% io,
    fi_handle handle,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
io
Type: FreeImageAPI.IO..::.FreeImageIO %
IO functions used to read from the specified handle.
handle
Type: FreeImageAPI.IO..::.fi_handle
The handle to load the bitmap from.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Return Value

Handle to a FreeImage multi-paged bitmap.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class


OpenMultiBitmapFromStream Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmapFromStream Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
OpenMultiBitmapFromStream(Stream) | Loads a FreeImage multi-paged bitmap.
OpenMultiBitmapFromStream(Stream, FREE_IMAGE_FORMAT%, FREE_IMAGE_LOAD_FLAGS) | Loads a FreeImage multi-paged bitmap. In case the loading format is FIF_UNKNOWN the files real format is being analysed. If no plugin can read the file, format remains FIF_UNKNOWN and 0 is returned. Load flags can be provided by the flags parameter.

See Also

FreeImage Class
FreeImage Members


OpenMultiBitmapFromStream Method (Stream)

[image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmapFromStream Method (Stream)
FreeImage Class See Also Send Feedback
Loads a FreeImage multi-paged bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP OpenMultiBitmapFromStream(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function OpenMultiBitmapFromStream ( _
    stream As Stream _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP OpenMultiBitmapFromStream(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream to load the bitmap from.

Return Value

Handle to a FreeImage multi-paged bitmap.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class
OpenMultiBitmapFromStream Overload


OpenMultiBitmapFromStream Method (Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS)

[image]

FreeImage .NET Documentation
FreeImage..::.OpenMultiBitmapFromStream Method (Stream, FREE_IMAGE_FORMAT%, FREE_IMAGE_LOAD_FLAGS)
FreeImage Class See Also Send Feedback
Loads a FreeImage multi-paged bitmap. In case the loading format is FIF_UNKNOWN the files real format is being analysed. If no plugin can read the file, format remains FIF_UNKNOWN and 0 is returned. Load flags can be provided by the flags parameter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIMULTIBITMAP OpenMultiBitmapFromStream(
    Stream stream,
    ref FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function OpenMultiBitmapFromStream ( _
    stream As Stream, _
    ByRef format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_LOAD_FLAGS _
) As FIMULTIBITMAP
Visual C++
public:
static FIMULTIBITMAP OpenMultiBitmapFromStream(
    Stream^ stream,
    FREE_IMAGE_FORMAT% format,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

stream
Type: System.IO..::.Stream
The stream to load the bitmap from.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT %
Format of the image. If the format is unknown use FIF_UNKNOWN
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Return Value

Handle to a FreeImage multi-paged bitmap.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class
OpenMultiBitmapFromStream Overload


OutputMessageProc Method

[image]

FreeImage .NET Documentation
FreeImage..::.OutputMessageProc Method
FreeImage Class See Also Send Feedback
Calls the set error message function in FreeImage.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void OutputMessageProc(
    FREE_IMAGE_FORMAT fif,
    string message
)
Visual Basic (Declaration)
Public Shared Sub OutputMessageProc ( _
    fif As FREE_IMAGE_FORMAT, _
    message As String _
)
Visual C++
public:
static void OutputMessageProc(
    FREE_IMAGE_FORMAT fif,
    String^ message
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the bitmaps.
message
Type: System..::.String
The error message.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Paste Method

[image]

FreeImage .NET Documentation
FreeImage..::.Paste Method
FreeImage Class See Also Send Feedback
Alpha blend or combine a sub part image with the current dib image. The bit depth of the dst bitmap must be greater than or equal to the bit depth of the src.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool Paste(
    FIBITMAP dst,
    FIBITMAP src,
    int left,
    int top,
    int alpha
)
Visual Basic (Declaration)
Public Shared Function Paste ( _
    dst As FIBITMAP, _
    src As FIBITMAP, _
    left As Integer, _
    top As Integer, _
    alpha As Integer _
) As Boolean
Visual C++
public:
static bool Paste(
    FIBITMAP dst,
    FIBITMAP src,
    int left,
    int top,
    int alpha
)

Parameters

dst
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
src
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
left
Type: System..::.Int32
Specifies the left position of the sub image.
top
Type: System..::.Int32
Specifies the top position of the sub image.
alpha
Type: System..::.Int32
alpha blend factor. The source and destination images are alpha blended if alpha=0..255. If alpha > 255, then the source image is combined to the destination image.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


PreMultiplyWithAlpha Method

[image]

FreeImage .NET Documentation
FreeImage..::.PreMultiplyWithAlpha Method
FreeImage Class See Also Send Feedback
Applies the alpha value of each pixel to its color components. The aplha value stays unchanged. Only works with 32-bits color depth.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool PreMultiplyWithAlpha(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Function PreMultiplyWithAlpha ( _
    dib As FIBITMAP _
) As Boolean
Visual C++
public:
static bool PreMultiplyWithAlpha(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ReadMemory Method

[image]

FreeImage .NET Documentation
FreeImage..::.ReadMemory Method
FreeImage Class See Also Send Feedback
Reads data from a memory stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint ReadMemory(
    byte[] buffer,
    uint size,
    uint count,
    FIMEMORY stream
)
Visual Basic (Declaration)
Public Shared Function ReadMemory ( _
    buffer As Byte(), _
    size As UInteger, _
    count As UInteger, _
    stream As FIMEMORY _
) As UInteger
Visual C++
public:
static unsigned int ReadMemory(
    array<unsigned char>^ buffer,
    unsigned int size,
    unsigned int count,
    FIMEMORY stream
)

Parameters

buffer
Type: array< System..::.Byte >[]()[]
The buffer to store the data in.
size
Type: System..::.UInt32
Size in bytes of the items.
count
Type: System..::.UInt32
Number of items to read.
stream
Type: FreeImageAPI..::.FIMEMORY
The stream to read from. The memory pointer associated with stream is increased by the number of bytes actually read.

Return Value

The number of full items actually read. May be less than count on error or stream-end.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


RegisterExternalPlugin Method

[image]

FreeImage .NET Documentation
FreeImage..::.RegisterExternalPlugin Method
FreeImage Class See Also Send Feedback
Registers a new plugin to be used in FreeImage. The plugin is residing in a DLL. The Init function must be called “Init” and must use the stdcall calling convention.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_FORMAT RegisterExternalPlugin(
    string path,
    string format,
    string description,
    string extension,
    string regexpr
)
Visual Basic (Declaration)
Public Shared Function RegisterExternalPlugin ( _
    path As String, _
    format As String, _
    description As String, _
    extension As String, _
    regexpr As String _
) As FREE_IMAGE_FORMAT
Visual C++
public:
static FREE_IMAGE_FORMAT RegisterExternalPlugin(
    String^ path,
    String^ format,
    String^ description,
    String^ extension,
    String^ regexpr
)

Parameters

path
Type: System..::.String
Complete path to the dll file hosting the plugin.
format
Type: System..::.String
A string describing the format of the plugin.
description
Type: System..::.String
A string describing the plugin.
extension
Type: System..::.String
A string witha comma sperated list of extensions. f.e: "pl,pl2,pl4"
regexpr
Type: System..::.String
A regular expression used to identify the bitmap.

Return Value

The format idientifier assigned by FreeImage.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


RegisterLocalPlugin Method

[image]

FreeImage .NET Documentation
FreeImage..::.RegisterLocalPlugin Method
FreeImage Class See Also Send Feedback
Registers a new plugin to be used in FreeImage.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FREE_IMAGE_FORMAT RegisterLocalPlugin(
    InitProc proc_address,
    string format,
    string description,
    string extension,
    string regexpr
)
Visual Basic (Declaration)
Public Shared Function RegisterLocalPlugin ( _
    proc_address As InitProc, _
    format As String, _
    description As String, _
    extension As String, _
    regexpr As String _
) As FREE_IMAGE_FORMAT
Visual C++
public:
static FREE_IMAGE_FORMAT RegisterLocalPlugin(
    InitProc^ proc_address,
    String^ format,
    String^ description,
    String^ extension,
    String^ regexpr
)

Parameters

proc_address
Type: FreeImageAPI.Plugins..::.InitProc
Pointer to the function that initialises the plugin.
format
Type: System..::.String
A string describing the format of the plugin.
description
Type: System..::.String
A string describing the plugin.
extension
Type: System..::.String
A string witha comma sperated list of extensions. f.e: "pl,pl2,pl4"
regexpr
Type: System..::.String
A regular expression used to identify the bitmap.

Return Value

The format idientifier assigned by FreeImage.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Rescale Method

[image]

FreeImage .NET Documentation
FreeImage..::.Rescale Method
FreeImage Class See Also Send Feedback
Performs resampling (or scaling, zooming) of a greyscale or RGB(A) image to the desired destination width and height.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Rescale(
    FIBITMAP dib,
    int dst_width,
    int dst_height,
    FREE_IMAGE_FILTER filter
)
Visual Basic (Declaration)
Public Shared Function Rescale ( _
    dib As FIBITMAP, _
    dst_width As Integer, _
    dst_height As Integer, _
    filter As FREE_IMAGE_FILTER _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Rescale(
    FIBITMAP dib,
    int dst_width,
    int dst_height,
    FREE_IMAGE_FILTER filter
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
dst_width
Type: System..::.Int32
Destination width.
dst_height
Type: System..::.Int32
Destination height.
filter
Type: FreeImageAPI..::.FREE_IMAGE_FILTER
The filter to apply.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Rotate Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.Rotate Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
Rotate(FIBITMAP, Double) | This function rotates a 1-, 8-bit greyscale or a 24-, 32-bit color image by means of 3 shears. 1-bit images rotation is limited to integer multiple of 90°. null is returned for other values.
Rotate<(Of <(T>)>)(FIBITMAP, Double, Nullable<(Of <(T>)>)) | This function rotates a 1-, 8-bit greyscale or a 24-, 32-bit color image by means of 3 shears. 1-bit images rotation is limited to integer multiple of 90°. null is returned for other values.

See Also

FreeImage Class
FreeImage Members


Rotate Method (FIBITMAP, Double)

[image]

FreeImage .NET Documentation
FreeImage..::.Rotate Method (FIBITMAP, Double)
FreeImage Class See Also Send Feedback
This function rotates a 1-, 8-bit greyscale or a 24-, 32-bit color image by means of 3 shears. 1-bit images rotation is limited to integer multiple of 90°. null is returned for other values.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Rotate(
    FIBITMAP dib,
    double angle
)
Visual Basic (Declaration)
Public Shared Function Rotate ( _
    dib As FIBITMAP, _
    angle As Double _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Rotate(
    FIBITMAP dib,
    double angle
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
angle
Type: System..::.Double
The angle of rotation.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class
Rotate Overload


Rotate(T) Method (FIBITMAP, Double, Nullable(T))

[image]

FreeImage .NET Documentation
FreeImage..::.Rotate<(Of <(T>)>) Method (FIBITMAP, Double, Nullable<(Of <(T>)>))
FreeImage Class See Also Send Feedback
This function rotates a 1-, 8-bit greyscale or a 24-, 32-bit color image by means of 3 shears. 1-bit images rotation is limited to integer multiple of 90°. null is returned for other values.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Rotate<T>(
    FIBITMAP dib,
    double angle,
    Nullable<T> backgroundColor
)
where T : struct, new()
Visual Basic (Declaration)
Public Shared Function Rotate(Of T As {Structure, New}) ( _
    dib As FIBITMAP, _
    angle As Double, _
    backgroundColor As Nullable(Of T) _
) As FIBITMAP
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
static FIBITMAP Rotate(
    FIBITMAP dib,
    double angle,
    Nullable<T> backgroundColor
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
angle
Type: System..::.Double
The angle of rotation.
backgroundColor
Type: System..::.Nullable <(Of <(T>)>)
The color used used to fill the bitmap's background.

Type Parameters

T
The type of the color to use as background.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImage Class
Rotate Overload


Rotate4bit Method

[image]

FreeImage .NET Documentation
FreeImage..::.Rotate4bit Method
FreeImage Class See Also Send Feedback
Rotates a 4-bit color FreeImage bitmap. Allowed values for angle are 90, 180 and 270. In case angle is 0 or 360 a clone is returned. 0 is returned for other values or in case the rotation fails.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Rotate4bit(
    FIBITMAP dib,
    double angle
)
Visual Basic (Declaration)
Public Shared Function Rotate4bit ( _
    dib As FIBITMAP, _
    angle As Double _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Rotate4bit(
    FIBITMAP dib,
    double angle
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
angle
Type: System..::.Double
The angle of rotation.

Return Value

Handle to a FreeImage bitmap.

Remarks

This function is kind of temporary due to FreeImage's lack of rotating 4-bit images. It's particularly used by FreeImageBitmap's method RotateFlip. This function will be removed as soon as FreeImage supports rotating 4-bit images.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


RotateClassic Method

[image]

FreeImage .NET Documentation
FreeImage..::.RotateClassic Method
FreeImage Class See Also Send Feedback
This function rotates a 1-, 8-bit greyscale or a 24-, 32-bit color image by means of 3 shears. 1-bit images rotation is limited to integer multiple of 90°. null is returned for other values.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP RotateClassic(
    FIBITMAP dib,
    double angle
)
Visual Basic (Declaration)
Public Shared Function RotateClassic ( _
    dib As FIBITMAP, _
    angle As Double _
) As FIBITMAP
Visual C++
public:
static FIBITMAP RotateClassic(
    FIBITMAP dib,
    double angle
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
angle
Type: System..::.Double
The angle of rotation.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0
Obsolete (compiler warning) in 3.13.0
Obsolete (compiler warning) in 3.13.1

See Also

FreeImage Class


RotateEx Method

[image]

FreeImage .NET Documentation
FreeImage..::.RotateEx Method
FreeImage Class See Also Send Feedback
This function performs a rotation and / or translation of an 8-bit greyscale, 24- or 32-bit image, using a 3rd order (cubic) B-Spline.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP RotateEx(
    FIBITMAP dib,
    double angle,
    double x_shift,
    double y_shift,
    double x_origin,
    double y_origin,
    bool use_mask
)
Visual Basic (Declaration)
Public Shared Function RotateEx ( _
    dib As FIBITMAP, _
    angle As Double, _
    x_shift As Double, _
    y_shift As Double, _
    x_origin As Double, _
    y_origin As Double, _
    use_mask As Boolean _
) As FIBITMAP
Visual C++
public:
static FIBITMAP RotateEx(
    FIBITMAP dib,
    double angle,
    double x_shift,
    double y_shift,
    double x_origin,
    double y_origin,
    bool use_mask
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
angle
Type: System..::.Double
The angle of rotation.
x_shift
Type: System..::.Double
Horizontal image translation.
y_shift
Type: System..::.Double
Vertical image translation.
x_origin
Type: System..::.Double
Rotation center x-coordinate.
y_origin
Type: System..::.Double
Rotation center y-coordinate.
use_mask
Type: System..::.Boolean
When true the irrelevant part of the image is set to a black color, otherwise, a mirroring technique is used to fill irrelevant pixels.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Save Method

[image]

FreeImage .NET Documentation
FreeImage..::.Save Method
FreeImage Class See Also Send Feedback
Saves a previosly loaded FIBITMAP to a file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool Save(
    FREE_IMAGE_FORMAT fif,
    FIBITMAP dib,
    string filename,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function Save ( _
    fif As FREE_IMAGE_FORMAT, _
    dib As FIBITMAP, _
    filename As String, _
    flags As FREE_IMAGE_SAVE_FLAGS _
) As Boolean
Visual C++
public:
static bool Save(
    FREE_IMAGE_FORMAT fif,
    FIBITMAP dib,
    String^ filename,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Type of the bitmap.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
filename
Type: System..::.String
Name of the file to save to.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SaveBitmap Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.SaveBitmap Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
SaveBitmap(Bitmap, String) | Saves a .NET Bitmap to a file.
SaveBitmap(Bitmap, String, FREE_IMAGE_SAVE_FLAGS) | Saves a .NET Bitmap to a file.
SaveBitmap(Bitmap, String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS) | Saves a .NET Bitmap to a file.

See Also

FreeImage Class
FreeImage Members


SaveBitmap Method (Bitmap, String)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveBitmap Method (Bitmap, String)
FreeImage Class See Also Send Feedback
Saves a .NET Bitmap to a file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveBitmap(
    Bitmap bitmap,
    string filename
)
Visual Basic (Declaration)
Public Shared Function SaveBitmap ( _
    bitmap As Bitmap, _
    filename As String _
) As Boolean
Visual C++
public:
static bool SaveBitmap(
    Bitmap^ bitmap,
    String^ filename
)

Parameters

bitmap
Type: System.Drawing..::.Bitmap
The .NET Bitmap to save.
filename
Type: System..::.String
Name of the file to save to.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | bitmap or filename is null.
System..::.ArgumentException | The bitmaps pixelformat is invalid.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveBitmap Overload


SaveBitmap Method (Bitmap, String, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveBitmap Method (Bitmap, String, FREE_IMAGE_SAVE_FLAGS)
FreeImage Class See Also Send Feedback
Saves a .NET Bitmap to a file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveBitmap(
    Bitmap bitmap,
    string filename,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function SaveBitmap ( _
    bitmap As Bitmap, _
    filename As String, _
    flags As FREE_IMAGE_SAVE_FLAGS _
) As Boolean
Visual C++
public:
static bool SaveBitmap(
    Bitmap^ bitmap,
    String^ filename,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

bitmap
Type: System.Drawing..::.Bitmap
The .NET Bitmap to save.
filename
Type: System..::.String
Name of the file to save to.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | bitmap or filename is null.
System..::.ArgumentException | The bitmaps pixelformat is invalid.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveBitmap Overload


SaveBitmap Method (Bitmap, String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveBitmap Method (Bitmap, String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS)
FreeImage Class See Also Send Feedback
Saves a .NET Bitmap to a file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveBitmap(
    Bitmap bitmap,
    string filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function SaveBitmap ( _
    bitmap As Bitmap, _
    filename As String, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_SAVE_FLAGS _
) As Boolean
Visual C++
public:
static bool SaveBitmap(
    Bitmap^ bitmap,
    String^ filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

bitmap
Type: System.Drawing..::.Bitmap
The .NET Bitmap to save.
filename
Type: System..::.String
Name of the file to save to.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the bitmap. If the format should be taken from the filename use FIF_UNKNOWN.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | bitmap or filename is null.
System..::.ArgumentException | The bitmaps pixelformat is invalid.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveBitmap Overload


SaveEx Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.SaveEx Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
SaveEx(FIBITMAP, String) | Saves a previously loaded FreeImage bitmap to a file. The format is taken off the filename. If no suitable format was found false will be returned.
SaveEx(FIBITMAP, String, FREE_IMAGE_FORMAT) | Saves a previously loaded FreeImage bitmap to a file. In case the loading format is FIF_UNKNOWN the format is taken off the filename. If no suitable format was found false will be returned.
SaveEx(FIBITMAP, String, FREE_IMAGE_SAVE_FLAGS) | Saves a previously loaded FreeImage bitmap to a file. The format is taken off the filename. If no suitable format was found false will be returned. Save flags can be provided by the flags parameter.
SaveEx(FIBITMAP%, String, Boolean) | Saves a previously loaded FreeImage bitmap to a file. The format is taken off the filename. If no suitable format was found false will be returned.
SaveEx(FIBITMAP, String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS) | Saves a previously loaded FreeImage bitmap to a file. In case the loading format is FIF_UNKNOWN the format is taken off the filename. If no suitable format was found false will be returned. Save flags can be provided by the flags parameter.
SaveEx(FIBITMAP%, String, FREE_IMAGE_FORMAT, Boolean) | Saves a previously loaded FreeImage bitmap to a file. In case the loading format is FIF_UNKNOWN the format is taken off the filename. If no suitable format was found false will be returned.
SaveEx(FIBITMAP%, String, FREE_IMAGE_SAVE_FLAGS, Boolean) | Saves a previously loaded FreeImage bitmap to a file. The format is taken off the filename. If no suitable format was found false will be returned. Save flags can be provided by the flags parameter.
SaveEx(FIBITMAP%, String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, FREE_IMAGE_COLOR_DEPTH, Boolean) | Saves a previously loaded FreeImage bitmap to a file. In case the loading format is FIF_UNKNOWN the format is taken off the filename. If no suitable format was found false will be returned. Save flags can be provided by the flags parameter. The bitmaps color depth can be set by 'colorDepth'. If set to FICD_AUTO a suitable color depth will be taken if available.

See Also

FreeImage Class
FreeImage Members


SaveEx Method (FIBITMAP, String)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveEx Method (FIBITMAP, String)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a file. The format is taken off the filename. If no suitable format was found false will be returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveEx(
    FIBITMAP dib,
    string filename
)
Visual Basic (Declaration)
Public Shared Function SaveEx ( _
    dib As FIBITMAP, _
    filename As String _
) As Boolean
Visual C++
public:
static bool SaveEx(
    FIBITMAP dib,
    String^ filename
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
filename
Type: System..::.String
The complete name of the file to save to. The extension will be corrected if it is no valid extension for the selected format or if no extension was specified.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or filename is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveEx Overload


SaveEx Method (FIBITMAP, String, FREE_IMAGE_FORMAT)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveEx Method (FIBITMAP, String, FREE_IMAGE_FORMAT)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a file. In case the loading format is FIF_UNKNOWN the format is taken off the filename. If no suitable format was found false will be returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveEx(
    FIBITMAP dib,
    string filename,
    FREE_IMAGE_FORMAT format
)
Visual Basic (Declaration)
Public Shared Function SaveEx ( _
    dib As FIBITMAP, _
    filename As String, _
    format As FREE_IMAGE_FORMAT _
) As Boolean
Visual C++
public:
static bool SaveEx(
    FIBITMAP dib,
    String^ filename,
    FREE_IMAGE_FORMAT format
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
filename
Type: System..::.String
The complete name of the file to save to. The extension will be corrected if it is no valid extension for the selected format or if no extension was specified.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image. If the format should be taken from the filename use FIF_UNKNOWN.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or filename is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveEx Overload


SaveEx Method (FIBITMAP, String, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveEx Method (FIBITMAP, String, FREE_IMAGE_SAVE_FLAGS)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a file. The format is taken off the filename. If no suitable format was found false will be returned. Save flags can be provided by the flags parameter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveEx(
    FIBITMAP dib,
    string filename,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function SaveEx ( _
    dib As FIBITMAP, _
    filename As String, _
    flags As FREE_IMAGE_SAVE_FLAGS _
) As Boolean
Visual C++
public:
static bool SaveEx(
    FIBITMAP dib,
    String^ filename,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
filename
Type: System..::.String
The complete name of the file to save to. The extension will be corrected if it is no valid extension for the selected format or if no extension was specified
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or filename is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveEx Overload


SaveEx Method (FIBITMAP, String, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveEx Method (FIBITMAP%, String, Boolean)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a file. The format is taken off the filename. If no suitable format was found false will be returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveEx(
    ref FIBITMAP dib,
    string filename,
    bool unloadSource
)
Visual Basic (Declaration)
Public Shared Function SaveEx ( _
    ByRef dib As FIBITMAP, _
    filename As String, _
    unloadSource As Boolean _
) As Boolean
Visual C++
public:
static bool SaveEx(
    FIBITMAP% dib,
    String^ filename,
    bool unloadSource
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP %
Handle to a FreeImage bitmap.
filename
Type: System..::.String
The complete name of the file to save to. The extension will be corrected if it is no valid extension for the selected format or if no extension was specified.
unloadSource
Type: System..::.Boolean
When true the structure will be unloaded on success. If the function failed and returned false, the bitmap was not unloaded.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or filename is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveEx Overload


SaveEx Method (FIBITMAP, String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveEx Method (FIBITMAP, String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a file. In case the loading format is FIF_UNKNOWN the format is taken off the filename. If no suitable format was found false will be returned. Save flags can be provided by the flags parameter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveEx(
    FIBITMAP dib,
    string filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function SaveEx ( _
    dib As FIBITMAP, _
    filename As String, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_SAVE_FLAGS _
) As Boolean
Visual C++
public:
static bool SaveEx(
    FIBITMAP dib,
    String^ filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
filename
Type: System..::.String
The complete name of the file to save to. The extension will be corrected if it is no valid extension for the selected format or if no extension was specified.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image. If the format should be taken from the filename use FIF_UNKNOWN.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or filename is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveEx Overload


SaveEx Method (FIBITMAP, String, FREE_IMAGE_FORMAT, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveEx Method (FIBITMAP%, String, FREE_IMAGE_FORMAT, Boolean)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a file. In case the loading format is FIF_UNKNOWN the format is taken off the filename. If no suitable format was found false will be returned.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveEx(
    ref FIBITMAP dib,
    string filename,
    FREE_IMAGE_FORMAT format,
    bool unloadSource
)
Visual Basic (Declaration)
Public Shared Function SaveEx ( _
    ByRef dib As FIBITMAP, _
    filename As String, _
    format As FREE_IMAGE_FORMAT, _
    unloadSource As Boolean _
) As Boolean
Visual C++
public:
static bool SaveEx(
    FIBITMAP% dib,
    String^ filename,
    FREE_IMAGE_FORMAT format,
    bool unloadSource
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP %
Handle to a FreeImage bitmap.
filename
Type: System..::.String
The complete name of the file to save to. The extension will be corrected if it is no valid extension for the selected format or if no extension was specified.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image. If the format should be taken from the filename use FIF_UNKNOWN.
unloadSource
Type: System..::.Boolean
When true the structure will be unloaded on success. If the function failed and returned false, the bitmap was not unloaded.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or filename is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveEx Overload


SaveEx Method (FIBITMAP, String, FREE_IMAGE_SAVE_FLAGS, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveEx Method (FIBITMAP%, String, FREE_IMAGE_SAVE_FLAGS, Boolean)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a file. The format is taken off the filename. If no suitable format was found false will be returned. Save flags can be provided by the flags parameter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveEx(
    ref FIBITMAP dib,
    string filename,
    FREE_IMAGE_SAVE_FLAGS flags,
    bool unloadSource
)
Visual Basic (Declaration)
Public Shared Function SaveEx ( _
    ByRef dib As FIBITMAP, _
    filename As String, _
    flags As FREE_IMAGE_SAVE_FLAGS, _
    unloadSource As Boolean _
) As Boolean
Visual C++
public:
static bool SaveEx(
    FIBITMAP% dib,
    String^ filename,
    FREE_IMAGE_SAVE_FLAGS flags,
    bool unloadSource
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP %
Handle to a FreeImage bitmap.
filename
Type: System..::.String
The complete name of the file to save to. The extension will be corrected if it is no valid extension for the selected format or if no extension was specified.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.
unloadSource
Type: System..::.Boolean
When true the structure will be unloaded on success. If the function failed and returned false, the bitmap was not unloaded.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or filename is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveEx Overload


SaveEx Method (FIBITMAP, String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, FREE_IMAGE_COLOR_DEPTH, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveEx Method (FIBITMAP%, String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, FREE_IMAGE_COLOR_DEPTH, Boolean)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a file. In case the loading format is FIF_UNKNOWN the format is taken off the filename. If no suitable format was found false will be returned. Save flags can be provided by the flags parameter. The bitmaps color depth can be set by 'colorDepth'. If set to FICD_AUTO a suitable color depth will be taken if available.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveEx(
    ref FIBITMAP dib,
    string filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags,
    FREE_IMAGE_COLOR_DEPTH colorDepth,
    bool unloadSource
)
Visual Basic (Declaration)
Public Shared Function SaveEx ( _
    ByRef dib As FIBITMAP, _
    filename As String, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_SAVE_FLAGS, _
    colorDepth As FREE_IMAGE_COLOR_DEPTH, _
    unloadSource As Boolean _
) As Boolean
Visual C++
public:
static bool SaveEx(
    FIBITMAP% dib,
    String^ filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags,
    FREE_IMAGE_COLOR_DEPTH colorDepth,
    bool unloadSource
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP %
Handle to a FreeImage bitmap.
filename
Type: System..::.String
The complete name of the file to save to. The extension will be corrected if it is no valid extension for the selected format or if no extension was specified.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image. If the format should be taken from the filename use FIF_UNKNOWN.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.
colorDepth
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
The new color depth of the bitmap. Set to FICD_AUTO if Save should take the best suitable color depth. If a color depth is selected that the provided format cannot write an error-message will be thrown.
unloadSource
Type: System..::.Boolean
When true the structure will be unloaded on success. If the function failed and returned false, the bitmap was not unloaded.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentException | A direct color conversion failed.
System..::.ArgumentNullException | dib or filename is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveEx Overload


SaveToHandle Method

[image]

FreeImage .NET Documentation
FreeImage..::.SaveToHandle Method
FreeImage Class See Also Send Feedback
Saves a bitmap to an arbitrary source.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveToHandle(
    FREE_IMAGE_FORMAT fif,
    FIBITMAP dib,
    ref FreeImageIO io,
    fi_handle handle,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function SaveToHandle ( _
    fif As FREE_IMAGE_FORMAT, _
    dib As FIBITMAP, _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    flags As FREE_IMAGE_SAVE_FLAGS _
) As Boolean
Visual C++
public:
static bool SaveToHandle(
    FREE_IMAGE_FORMAT fif,
    FIBITMAP dib,
    FreeImageIO% io,
    fi_handle handle,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Type of the bitmap.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
io
Type: FreeImageAPI.IO..::.FreeImageIO %
A FreeImageIO structure with functionpointers to handle the source.
handle
Type: FreeImageAPI.IO..::.fi_handle
A handle to the source.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SaveToMemory Method

[image]

FreeImage .NET Documentation
FreeImage..::.SaveToMemory Method
FreeImage Class See Also Send Feedback
Saves a previosly loaded FIBITMAP to a stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveToMemory(
    FREE_IMAGE_FORMAT fif,
    FIBITMAP dib,
    FIMEMORY stream,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function SaveToMemory ( _
    fif As FREE_IMAGE_FORMAT, _
    dib As FIBITMAP, _
    stream As FIMEMORY, _
    flags As FREE_IMAGE_SAVE_FLAGS _
) As Boolean
Visual C++
public:
static bool SaveToMemory(
    FREE_IMAGE_FORMAT fif,
    FIBITMAP dib,
    FIMEMORY stream,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Type of the bitmap.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
stream
Type: FreeImageAPI..::.FIMEMORY
Handle to a memory stream.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SaveToStream Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.SaveToStream Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
SaveToStream(FIBITMAP, Stream, FREE_IMAGE_FORMAT) | Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.
SaveToStream(FIBITMAP, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS) | Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.
SaveToStream(FIBITMAP%, Stream, FREE_IMAGE_FORMAT, Boolean) | Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.
SaveToStream(FIBITMAP, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, FREE_IMAGE_COLOR_DEPTH) | Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.
SaveToStream(FIBITMAP%, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, Boolean) | Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.
SaveToStream(FIBITMAP%, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, FREE_IMAGE_COLOR_DEPTH, Boolean) | Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.

See Also

FreeImage Class
FreeImage Members


SaveToStream Method (FIBITMAP, Stream, FREE_IMAGE_FORMAT)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveToStream Method (FIBITMAP, Stream, FREE_IMAGE_FORMAT)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveToStream(
    FIBITMAP dib,
    Stream stream,
    FREE_IMAGE_FORMAT format
)
Visual Basic (Declaration)
Public Shared Function SaveToStream ( _
    dib As FIBITMAP, _
    stream As Stream, _
    format As FREE_IMAGE_FORMAT _
) As Boolean
Visual C++
public:
static bool SaveToStream(
    FIBITMAP dib,
    Stream^ stream,
    FREE_IMAGE_FORMAT format
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
stream
Type: System.IO..::.Stream
The stream to write to.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or stream is null.
System..::.ArgumentException | stream cannot write.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveToStream Overload


SaveToStream Method (FIBITMAP, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveToStream Method (FIBITMAP, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveToStream(
    FIBITMAP dib,
    Stream stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Shared Function SaveToStream ( _
    dib As FIBITMAP, _
    stream As Stream, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_SAVE_FLAGS _
) As Boolean
Visual C++
public:
static bool SaveToStream(
    FIBITMAP dib,
    Stream^ stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
stream
Type: System.IO..::.Stream
The stream to write to.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or stream is null.
System..::.ArgumentException | stream cannot write.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveToStream Overload


SaveToStream Method (FIBITMAP, Stream, FREE_IMAGE_FORMAT, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveToStream Method (FIBITMAP%, Stream, FREE_IMAGE_FORMAT, Boolean)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveToStream(
    ref FIBITMAP dib,
    Stream stream,
    FREE_IMAGE_FORMAT format,
    bool unloadSource
)
Visual Basic (Declaration)
Public Shared Function SaveToStream ( _
    ByRef dib As FIBITMAP, _
    stream As Stream, _
    format As FREE_IMAGE_FORMAT, _
    unloadSource As Boolean _
) As Boolean
Visual C++
public:
static bool SaveToStream(
    FIBITMAP% dib,
    Stream^ stream,
    FREE_IMAGE_FORMAT format,
    bool unloadSource
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP %
Handle to a FreeImage bitmap.
stream
Type: System.IO..::.Stream
The stream to write to.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
unloadSource
Type: System..::.Boolean
When true the structure will be unloaded on success.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or stream is null.
System..::.ArgumentException | stream cannot write.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveToStream Overload


SaveToStream Method (FIBITMAP, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, FREE_IMAGE_COLOR_DEPTH)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveToStream Method (FIBITMAP, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, FREE_IMAGE_COLOR_DEPTH)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveToStream(
    FIBITMAP dib,
    Stream stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags,
    FREE_IMAGE_COLOR_DEPTH colorDepth
)
Visual Basic (Declaration)
Public Shared Function SaveToStream ( _
    dib As FIBITMAP, _
    stream As Stream, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_SAVE_FLAGS, _
    colorDepth As FREE_IMAGE_COLOR_DEPTH _
) As Boolean
Visual C++
public:
static bool SaveToStream(
    FIBITMAP dib,
    Stream^ stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags,
    FREE_IMAGE_COLOR_DEPTH colorDepth
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
stream
Type: System.IO..::.Stream
The stream to write to.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.
colorDepth
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
The new color depth of the bitmap. Set to FICD_AUTO if SaveToStream should take the best suitable color depth. If a color depth is selected that the provided format cannot write an error-message will be thrown.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or stream is null.
System..::.ArgumentException | stream cannot write.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveToStream Overload


SaveToStream Method (FIBITMAP, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveToStream Method (FIBITMAP%, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, Boolean)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveToStream(
    ref FIBITMAP dib,
    Stream stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags,
    bool unloadSource
)
Visual Basic (Declaration)
Public Shared Function SaveToStream ( _
    ByRef dib As FIBITMAP, _
    stream As Stream, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_SAVE_FLAGS, _
    unloadSource As Boolean _
) As Boolean
Visual C++
public:
static bool SaveToStream(
    FIBITMAP% dib,
    Stream^ stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags,
    bool unloadSource
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP %
Handle to a FreeImage bitmap.
stream
Type: System.IO..::.Stream
The stream to write to.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.
unloadSource
Type: System..::.Boolean
When true the structure will be unloaded on success.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or stream is null.
System..::.ArgumentException | stream cannot write.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveToStream Overload


SaveToStream Method (FIBITMAP, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, FREE_IMAGE_COLOR_DEPTH, Boolean)

[image]

FreeImage .NET Documentation
FreeImage..::.SaveToStream Method (FIBITMAP%, Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS, FREE_IMAGE_COLOR_DEPTH, Boolean)
FreeImage Class See Also Send Feedback
Saves a previously loaded FreeImage bitmap to a stream. The stream must be set to the correct position before calling SaveToStream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SaveToStream(
    ref FIBITMAP dib,
    Stream stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags,
    FREE_IMAGE_COLOR_DEPTH colorDepth,
    bool unloadSource
)
Visual Basic (Declaration)
Public Shared Function SaveToStream ( _
    ByRef dib As FIBITMAP, _
    stream As Stream, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_SAVE_FLAGS, _
    colorDepth As FREE_IMAGE_COLOR_DEPTH, _
    unloadSource As Boolean _
) As Boolean
Visual C++
public:
static bool SaveToStream(
    FIBITMAP% dib,
    Stream^ stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags,
    FREE_IMAGE_COLOR_DEPTH colorDepth,
    bool unloadSource
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP %
Handle to a FreeImage bitmap.
stream
Type: System.IO..::.Stream
The stream to write to.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.
colorDepth
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
The new color depth of the bitmap. Set to FICD_AUTO if SaveToStream should take the best suitable color depth. If a color depth is selected that the provided format cannot write an error-message will be thrown.
unloadSource
Type: System..::.Boolean
When true the structure will be unloaded on success.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or stream is null.
System..::.ArgumentException | stream cannot write.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SaveToStream Overload


SeekMemory Method

[image]

FreeImage .NET Documentation
FreeImage..::.SeekMemory Method
FreeImage Class See Also Send Feedback
Moves the memory handle to a specified location.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SeekMemory(
    FIMEMORY stream,
    int offset,
    SeekOrigin origin
)
Visual Basic (Declaration)
Public Shared Function SeekMemory ( _
    stream As FIMEMORY, _
    offset As Integer, _
    origin As SeekOrigin _
) As Boolean
Visual C++
public:
static bool SeekMemory(
    FIMEMORY stream,
    int offset,
    SeekOrigin origin
)

Parameters

stream
Type: FreeImageAPI..::.FIMEMORY
Handle to a memory stream.
offset
Type: System..::.Int32
Number of bytes from origin.
origin
Type: System.IO..::.SeekOrigin
Initial position.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetBackgroundColor Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.SetBackgroundColor Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
SetBackgroundColor(FIBITMAP, RGBQUAD%) | Set the file background color of an image. When saving an image to PNG, this background color is transparently saved to the PNG file.
SetBackgroundColor(FIBITMAP, array<RGBQUAD>[]()[]) | Set the file background color of an image. When saving an image to PNG, this background color is transparently saved to the PNG file. When the bkcolor parameter is null, the background color is removed from the image. This overloaded version of the function with an array parameter is provided to allow passing null in the bkcolor parameter. This is similar to the original C/C++ function. Passing null as bkcolor parameter will unset the dib's previously set background color.

See Also

FreeImage Class
FreeImage Members


SetBackgroundColor Method (FIBITMAP, RGBQUAD)

[image]

FreeImage .NET Documentation
FreeImage..::.SetBackgroundColor Method (FIBITMAP, RGBQUAD%)
FreeImage Class See Also Send Feedback
Set the file background color of an image. When saving an image to PNG, this background color is transparently saved to the PNG file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetBackgroundColor(
    FIBITMAP dib,
    ref RGBQUAD bkcolor
)
Visual Basic (Declaration)
Public Shared Function SetBackgroundColor ( _
    dib As FIBITMAP, _
    ByRef bkcolor As RGBQUAD _
) As Boolean
Visual C++
public:
static bool SetBackgroundColor(
    FIBITMAP dib,
    RGBQUAD% bkcolor
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
bkcolor
Type: FreeImageAPI..::.RGBQUAD %
The new background color.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SetBackgroundColor Overload


SetBackgroundColor Method (FIBITMAP, RGBQUAD[])

[image]

FreeImage .NET Documentation
FreeImage..::.SetBackgroundColor Method (FIBITMAP, array<RGBQUAD>[]()[])
FreeImage Class Example See Also Send Feedback
Set the file background color of an image. When saving an image to PNG, this background color is transparently saved to the PNG file. When the bkcolor parameter is null, the background color is removed from the image.

This overloaded version of the function with an array parameter is provided to allow passing null in the bkcolor parameter. This is similar to the original C/C++ function. Passing null as bkcolor parameter will unset the dib's previously set background color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetBackgroundColor(
    FIBITMAP dib,
    RGBQUAD[] bkcolor
)
Visual Basic (Declaration)
Public Shared Function SetBackgroundColor ( _
    dib As FIBITMAP, _
    bkcolor As RGBQUAD() _
) As Boolean
Visual C++
public:
static bool SetBackgroundColor(
    FIBITMAP dib,
    array<RGBQUAD>^ bkcolor
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
bkcolor
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The new background color. The first entry in the array is used.

Return Value

Returns true on success, false on failure.

Examples

CopyC#
// create a RGBQUAD color
RGBQUAD color = new RGBQUAD(Color.Green);

// set the dib's background color (using the other version of the function)
FreeImage.SetBackgroundColor(dib, ref color);

// remove it again (this only works due to the array parameter RGBQUAD[])
FreeImage.SetBackgroundColor(dib, null);

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SetBackgroundColor Overload


SetChannel Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetChannel Method
FreeImage Class See Also Send Feedback
Insert a 8-bit dib into a 24- or 32-bit image. Both images must have to same width and height.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetChannel(
    FIBITMAP dib,
    FIBITMAP dib8,
    FREE_IMAGE_COLOR_CHANNEL channel
)
Visual Basic (Declaration)
Public Shared Function SetChannel ( _
    dib As FIBITMAP, _
    dib8 As FIBITMAP, _
    channel As FREE_IMAGE_COLOR_CHANNEL _
) As Boolean
Visual C++
public:
static bool SetChannel(
    FIBITMAP dib,
    FIBITMAP dib8,
    FREE_IMAGE_COLOR_CHANNEL channel
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
dib8
Type: FreeImageAPI..::.FIBITMAP
Handle to the bitmap to insert.
channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
The color channel to replace.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetComplexChannel Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetComplexChannel Method
FreeImage Class See Also Send Feedback
Set the real or imaginary part of a complex image. Both images must have to same width and height.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetComplexChannel(
    FIBITMAP dst,
    FIBITMAP src,
    FREE_IMAGE_COLOR_CHANNEL channel
)
Visual Basic (Declaration)
Public Shared Function SetComplexChannel ( _
    dst As FIBITMAP, _
    src As FIBITMAP, _
    channel As FREE_IMAGE_COLOR_CHANNEL _
) As Boolean
Visual C++
public:
static bool SetComplexChannel(
    FIBITMAP dst,
    FIBITMAP src,
    FREE_IMAGE_COLOR_CHANNEL channel
)

Parameters

dst
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
src
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
The color channel to replace.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetDotsPerMeterX Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetDotsPerMeterX Method
FreeImage Class See Also Send Feedback
Set the horizontal resolution, in pixels-per-meter, of the target device for the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void SetDotsPerMeterX(
    FIBITMAP dib,
    uint res
)
Visual Basic (Declaration)
Public Shared Sub SetDotsPerMeterX ( _
    dib As FIBITMAP, _
    res As UInteger _
)
Visual C++
public:
static void SetDotsPerMeterX(
    FIBITMAP dib,
    unsigned int res
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
res
Type: System..::.UInt32
The new horizontal resolution.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetDotsPerMeterY Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetDotsPerMeterY Method
FreeImage Class See Also Send Feedback
Set the vertical resolution, in pixels-per-meter, of the target device for the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void SetDotsPerMeterY(
    FIBITMAP dib,
    uint res
)
Visual Basic (Declaration)
Public Shared Sub SetDotsPerMeterY ( _
    dib As FIBITMAP, _
    res As UInteger _
)
Visual C++
public:
static void SetDotsPerMeterY(
    FIBITMAP dib,
    unsigned int res
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
res
Type: System..::.UInt32
The new vertical resolution.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetImageComment Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetImageComment Method
FreeImage Class See Also Send Feedback
Sets the comment of a JPEG, PNG or GIF image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetImageComment(
    FIBITMAP dib,
    string comment
)
Visual Basic (Declaration)
Public Shared Function SetImageComment ( _
    dib As FIBITMAP, _
    comment As String _
) As Boolean
Visual C++
public:
static bool SetImageComment(
    FIBITMAP dib,
    String^ comment
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
comment
Type: System..::.String
New comment of the FreeImage bitmap. Use null to remove the comment.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetMetadata Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImage..::.SetMetadata Method
FreeImage Class See Also Send Feedback

Overload List

Name | Description
SetMetadata(FREE_IMAGE_MDMODEL, FIBITMAP, String, FITAG) | Attach a new FreeImage tag to a dib.
SetMetadata(FREE_IMAGE_MDMODEL, FIBITMAP, String, MetadataTag) | Attach a new metadata tag to a FreeImage bitmap.

See Also

FreeImage Class
FreeImage Members


SetMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, String, FITAG)

[image]

FreeImage .NET Documentation
FreeImage..::.SetMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, String, FITAG)
FreeImage Class See Also Send Feedback
Attach a new FreeImage tag to a dib.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    string key,
    FITAG tag
)
Visual Basic (Declaration)
Public Shared Function SetMetadata ( _
    model As FREE_IMAGE_MDMODEL, _
    dib As FIBITMAP, _
    key As String, _
    tag As FITAG _
) As Boolean
Visual C++
public:
static bool SetMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    String^ key,
    FITAG tag
)

Parameters

model
Type: FreeImageAPI..::.FREE_IMAGE_MDMODEL
The metadata model used to store the tag.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
key
Type: System..::.String
The tag field name.
tag
Type: FreeImageAPI..::.FITAG
The FreeImage tag to be attached.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SetMetadata Overload


SetMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, String, MetadataTag)

[image]

FreeImage .NET Documentation
FreeImage..::.SetMetadata Method (FREE_IMAGE_MDMODEL, FIBITMAP, String, MetadataTag)
FreeImage Class See Also Send Feedback
Attach a new metadata tag to a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    string key,
    MetadataTag tag
)
Visual Basic (Declaration)
Public Shared Function SetMetadata ( _
    model As FREE_IMAGE_MDMODEL, _
    dib As FIBITMAP, _
    key As String, _
    tag As MetadataTag _
) As Boolean
Visual C++
public:
static bool SetMetadata(
    FREE_IMAGE_MDMODEL model,
    FIBITMAP dib,
    String^ key,
    MetadataTag^ tag
)

Parameters

model
Type: FreeImageAPI..::.FREE_IMAGE_MDMODEL
The metadata model used to store the tag.
dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
key
Type: System..::.String
The tag field name.
tag
Type: FreeImageAPI.Metadata..::.MetadataTag
The MetadataTag to be attached.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class
SetMetadata Overload


SetPixelColor Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetPixelColor Method
FreeImage Class See Also Send Feedback
Set the pixel color of a 16-, 24- or 32-bit image at position (x, y), including range check (slow access).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetPixelColor(
    FIBITMAP dib,
    uint x,
    uint y,
    ref RGBQUAD value
)
Visual Basic (Declaration)
Public Shared Function SetPixelColor ( _
    dib As FIBITMAP, _
    x As UInteger, _
    y As UInteger, _
    ByRef value As RGBQUAD _
) As Boolean
Visual C++
public:
static bool SetPixelColor(
    FIBITMAP dib,
    unsigned int x,
    unsigned int y,
    RGBQUAD% value
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
x
Type: System..::.UInt32
Pixel position in horizontal direction.
y
Type: System..::.UInt32
Pixel position in vertical direction.
value
Type: FreeImageAPI..::.RGBQUAD %
The new pixel color.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetPixelIndex Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetPixelIndex Method
FreeImage Class See Also Send Feedback
Set the pixel index of a palettized image at position (x, y), including range check (slow access).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetPixelIndex(
    FIBITMAP dib,
    uint x,
    uint y,
    ref byte value
)
Visual Basic (Declaration)
Public Shared Function SetPixelIndex ( _
    dib As FIBITMAP, _
    x As UInteger, _
    y As UInteger, _
    ByRef value As Byte _
) As Boolean
Visual C++
public:
static bool SetPixelIndex(
    FIBITMAP dib,
    unsigned int x,
    unsigned int y,
    unsigned char% value
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
x
Type: System..::.UInt32
Pixel position in horizontal direction.
y
Type: System..::.UInt32
Pixel position in vertical direction.
value
Type: System..::.Byte %
The new pixel index.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetPluginEnabled Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetPluginEnabled Method
FreeImage Class See Also Send Feedback
Enables or disables a plugin.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int SetPluginEnabled(
    FREE_IMAGE_FORMAT fif,
    bool enable
)
Visual Basic (Declaration)
Public Shared Function SetPluginEnabled ( _
    fif As FREE_IMAGE_FORMAT, _
    enable As Boolean _
) As Integer
Visual C++
public:
static int SetPluginEnabled(
    FREE_IMAGE_FORMAT fif,
    bool enable
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The plugin to enable or disable.
enable
Type: System..::.Boolean
True: enable the plugin. false: disable the plugin.

Return Value

The previous state of the plugin. 1 - enabled. 0 - disables. -1 plugin does not exist.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetResolutionX Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetResolutionX Method
FreeImage Class See Also Send Feedback
Sets a DIB's resolution in X-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void SetResolutionX(
    FIBITMAP dib,
    uint res
)
Visual Basic (Declaration)
Public Shared Sub SetResolutionX ( _
    dib As FIBITMAP, _
    res As UInteger _
)
Visual C++
public:
static void SetResolutionX(
    FIBITMAP dib,
    unsigned int res
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
res
Type: System..::.UInt32
The new resolution in 'dots per inch'.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetResolutionY Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetResolutionY Method
FreeImage Class See Also Send Feedback
Sets a DIB's resolution in Y-direction measured in 'dots per inch' (DPI) and not in 'dots per meter'.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void SetResolutionY(
    FIBITMAP dib,
    uint res
)
Visual Basic (Declaration)
Public Shared Sub SetResolutionY ( _
    dib As FIBITMAP, _
    res As UInteger _
)
Visual C++
public:
static void SetResolutionY(
    FIBITMAP dib,
    unsigned int res
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
res
Type: System..::.UInt32
The new resolution in 'dots per inch'.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetTagCount Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetTagCount Method
FreeImage Class See Also Send Feedback
Sets the number of data in the tag.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetTagCount(
    FITAG tag,
    uint count
)
Visual Basic (Declaration)
Public Shared Function SetTagCount ( _
    tag As FITAG, _
    count As UInteger _
) As Boolean
Visual C++
public:
static bool SetTagCount(
    FITAG tag,
    unsigned int count
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.
count
Type: System..::.UInt32
New number of data.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetTagDescription Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetTagDescription Method
FreeImage Class See Also Send Feedback
Sets the tag description.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetTagDescription(
    FITAG tag,
    string description
)
Visual Basic (Declaration)
Public Shared Function SetTagDescription ( _
    tag As FITAG, _
    description As String _
) As Boolean
Visual C++
public:
static bool SetTagDescription(
    FITAG tag,
    String^ description
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.
description
Type: System..::.String
The new description.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetTagID Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetTagID Method
FreeImage Class See Also Send Feedback
Sets the tag ID.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetTagID(
    FITAG tag,
    ushort id
)
Visual Basic (Declaration)
Public Shared Function SetTagID ( _
    tag As FITAG, _
    id As UShort _
) As Boolean
Visual C++
public:
static bool SetTagID(
    FITAG tag,
    unsigned short id
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.
id
Type: System..::.UInt16
The new ID.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetTagKey Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetTagKey Method
FreeImage Class See Also Send Feedback
Sets the tag field name.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetTagKey(
    FITAG tag,
    string key
)
Visual Basic (Declaration)
Public Shared Function SetTagKey ( _
    tag As FITAG, _
    key As String _
) As Boolean
Visual C++
public:
static bool SetTagKey(
    FITAG tag,
    String^ key
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.
key
Type: System..::.String
The new name.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetTagLength Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetTagLength Method
FreeImage Class See Also Send Feedback
Sets the length of the tag value in bytes.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetTagLength(
    FITAG tag,
    uint length
)
Visual Basic (Declaration)
Public Shared Function SetTagLength ( _
    tag As FITAG, _
    length As UInteger _
) As Boolean
Visual C++
public:
static bool SetTagLength(
    FITAG tag,
    unsigned int length
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.
length
Type: System..::.UInt32
The new length.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetTagType Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetTagType Method
FreeImage Class See Also Send Feedback
Sets the tag data type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetTagType(
    FITAG tag,
    FREE_IMAGE_MDTYPE type
)
Visual Basic (Declaration)
Public Shared Function SetTagType ( _
    tag As FITAG, _
    type As FREE_IMAGE_MDTYPE _
) As Boolean
Visual C++
public:
static bool SetTagType(
    FITAG tag,
    FREE_IMAGE_MDTYPE type
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.
type
Type: FreeImageAPI..::.FREE_IMAGE_MDTYPE
The new type.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetTagValue Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetTagValue Method
FreeImage Class See Also Send Feedback
Sets the tag value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool SetTagValue(
    FITAG tag,
    byte[] value
)
Visual Basic (Declaration)
Public Shared Function SetTagValue ( _
    tag As FITAG, _
    value As Byte() _
) As Boolean
Visual C++
public:
static bool SetTagValue(
    FITAG tag,
    array<unsigned char>^ value
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag field.
value
Type: array< System..::.Byte >[]()[]
Pointer to the new value.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetTransparencyTable Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetTransparencyTable Method
FreeImage Class See Also Send Feedback
Set the FreeImage bitmap's transparency table. Only affects palletised bitmaps.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void SetTransparencyTable(
    FIBITMAP dib,
    byte[] table
)
Visual Basic (Declaration)
Public Shared Sub SetTransparencyTable ( _
    dib As FIBITMAP, _
    table As Byte() _
)
Visual C++
public:
static void SetTransparencyTable(
    FIBITMAP dib,
    array<unsigned char>^ table
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
table
Type: array< System..::.Byte >[]()[]
The FreeImage bitmap's new transparency table.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib or table is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetTransparent Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetTransparent Method
FreeImage Class See Also Send Feedback
Tells FreeImage if it should make use of the transparency table or the alpha channel that may accompany a bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void SetTransparent(
    FIBITMAP dib,
    bool enabled
)
Visual Basic (Declaration)
Public Shared Sub SetTransparent ( _
    dib As FIBITMAP, _
    enabled As Boolean _
)
Visual C++
public:
static void SetTransparent(
    FIBITMAP dib,
    bool enabled
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
enabled
Type: System..::.Boolean
True to enable the transparency, false to disable.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SetTransparentIndex Method

[image]

FreeImage .NET Documentation
FreeImage..::.SetTransparentIndex Method
FreeImage Class See Also Send Feedback
Sets the index of the palette entry to be used as transparent color for the image specified. Does nothing on high color images.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void SetTransparentIndex(
    FIBITMAP dib,
    int index
)
Visual Basic (Declaration)
Public Shared Sub SetTransparentIndex ( _
    dib As FIBITMAP, _
    index As Integer _
)
Visual C++
public:
static void SetTransparentIndex(
    FIBITMAP dib,
    int index
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
index
Type: System..::.Int32
The index of the palette entry to be set as transparent color.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SwapColors Method

[image]

FreeImage .NET Documentation
FreeImage..::.SwapColors Method
FreeImage Class See Also Send Feedback
Swaps two specified colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint SwapColors(
    FIBITMAP dib,
    ref RGBQUAD color_a,
    ref RGBQUAD color_b,
    bool ignore_alpha
)
Visual Basic (Declaration)
Public Shared Function SwapColors ( _
    dib As FIBITMAP, _
    ByRef color_a As RGBQUAD, _
    ByRef color_b As RGBQUAD, _
    ignore_alpha As Boolean _
) As UInteger
Visual C++
public:
static unsigned int SwapColors(
    FIBITMAP dib,
    RGBQUAD% color_a,
    RGBQUAD% color_b,
    bool ignore_alpha
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
color_a
Type: FreeImageAPI..::.RGBQUAD %
One of the two colors to be swapped.
color_b
Type: FreeImageAPI..::.RGBQUAD %
The other of the two colors to be swapped.
ignore_alpha
Type: System..::.Boolean
If true, 32-bit images and colors are treated as 24-bit.

Return Value

The total number of pixels changed.

Remarks

This function swaps the two specified colors color_a and color_b on a palletized or high color image. For high color images, the actual image data will be modified whereas, for palletized images only the palette will be changed.

Note, that this behaviour is different from what SwapPaletteIndices(FIBITMAP, Byte%, Byte%) does, which modifies the actual image data on palletized images.

This is just a thin wrapper for ApplyColorMapping(FIBITMAP, array<RGBQUAD>[]()[], array<RGBQUAD>[]()[], UInt32, Boolean, Boolean) and resolves to:

CopyC#
return ApplyColorMapping(dib, color_a, color_b, 1, ignore_alpha, true);

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


SwapPaletteIndices Method

[image]

FreeImage .NET Documentation
FreeImage..::.SwapPaletteIndices Method
FreeImage Class See Also Send Feedback
Swaps two specified palette indices on a 1-, 4- or 8-bit palletized image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint SwapPaletteIndices(
    FIBITMAP dib,
    ref byte index_a,
    ref byte index_b
)
Visual Basic (Declaration)
Public Shared Function SwapPaletteIndices ( _
    dib As FIBITMAP, _
    ByRef index_a As Byte, _
    ByRef index_b As Byte _
) As UInteger
Visual C++
public:
static unsigned int SwapPaletteIndices(
    FIBITMAP dib,
    unsigned char% index_a,
    unsigned char% index_b
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
index_a
Type: System..::.Byte %
One of the two palette indices to be swapped.
index_b
Type: System..::.Byte %
The other of the two palette indices to be swapped.

Return Value

The total number of pixels changed.

Remarks

This function swaps the two specified palette indices index_a and index_b on a palletized image. Therefore, not the palette, but the actual image data will be modified.

Note, that this behaviour is different from what SwapColors(FIBITMAP, RGBQUAD%, RGBQUAD%, Boolean) does on palletized images, which only swaps the colors in the palette.

This is just a thin wrapper for ApplyColorMapping(FIBITMAP, array<RGBQUAD>[]()[], array<RGBQUAD>[]()[], UInt32, Boolean, Boolean) and resolves to:

CopyC#
return ApplyPaletteIndexMapping(dib, index_a, index_b, 1, true);

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


TagToString Method

[image]

FreeImage .NET Documentation
FreeImage..::.TagToString Method
FreeImage Class See Also Send Feedback
Converts a FreeImage tag structure to a string that represents the interpreted tag value. The function is not thread safe.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string TagToString(
    FREE_IMAGE_MDMODEL model,
    FITAG tag,
    uint Make
)
Visual Basic (Declaration)
Public Shared Function TagToString ( _
    model As FREE_IMAGE_MDMODEL, _
    tag As FITAG, _
    Make As UInteger _
) As String
Visual C++
public:
static String^ TagToString(
    FREE_IMAGE_MDMODEL model,
    FITAG tag,
    unsigned int Make
)

Parameters

model
Type: FreeImageAPI..::.FREE_IMAGE_MDMODEL
The metadata model.
tag
Type: FreeImageAPI..::.FITAG
The interpreted tag value.
Make
Type: System..::.UInt32
Reserved.

Return Value

The representing string.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


TellMemory Method

[image]

FreeImage .NET Documentation
FreeImage..::.TellMemory Method
FreeImage Class See Also Send Feedback
Gets the current position of a memory handle.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int TellMemory(
    FIMEMORY stream
)
Visual Basic (Declaration)
Public Shared Function TellMemory ( _
    stream As FIMEMORY _
) As Integer
Visual C++
public:
static int TellMemory(
    FIMEMORY stream
)

Parameters

stream
Type: FreeImageAPI..::.FIMEMORY
Handle to a memory stream.

Return Value

The current file position if successful, -1 otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Threshold Method

[image]

FreeImage .NET Documentation
FreeImage..::.Threshold Method
FreeImage Class See Also Send Feedback
Converts a bitmap to 1-bit monochrome bitmap using a threshold T between [0..255]. The function first converts the bitmap to a 8-bit greyscale bitmap. Then, any brightness level that is less than T is set to zero, otherwise to 1. For 1-bit input bitmaps, the function clones the input bitmap and builds a monochrome palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP Threshold(
    FIBITMAP dib,
    byte t
)
Visual Basic (Declaration)
Public Shared Function Threshold ( _
    dib As FIBITMAP, _
    t As Byte _
) As FIBITMAP
Visual C++
public:
static FIBITMAP Threshold(
    FIBITMAP dib,
    unsigned char t
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
t
Type: System..::.Byte
The threshold.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


TmoDrago03 Method

[image]

FreeImage .NET Documentation
FreeImage..::.TmoDrago03 Method
FreeImage Class See Also Send Feedback
Converts a High Dynamic Range image to a 24-bit RGB image using a global operator based on logarithmic compression of luminance values, imitating the human response to light.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP TmoDrago03(
    FIBITMAP src,
    double gamma,
    double exposure
)
Visual Basic (Declaration)
Public Shared Function TmoDrago03 ( _
    src As FIBITMAP, _
    gamma As Double, _
    exposure As Double _
) As FIBITMAP
Visual C++
public:
static FIBITMAP TmoDrago03(
    FIBITMAP src,
    double gamma,
    double exposure
)

Parameters

src
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
gamma
Type: System..::.Double
A gamma correction that is applied after the tone mapping. A value of 1 means no correction.
exposure
Type: System..::.Double
Scale factor allowing to adjust the brightness of the output image.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


TmoFattal02 Method

[image]

FreeImage .NET Documentation
FreeImage..::.TmoFattal02 Method
FreeImage Class See Also Send Feedback
Apply the Gradient Domain High Dynamic Range Compression to a RGBF image and convert to 24-bit RGB.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP TmoFattal02(
    FIBITMAP src,
    double color_saturation,
    double attenuation
)
Visual Basic (Declaration)
Public Shared Function TmoFattal02 ( _
    src As FIBITMAP, _
    color_saturation As Double, _
    attenuation As Double _
) As FIBITMAP
Visual C++
public:
static FIBITMAP TmoFattal02(
    FIBITMAP src,
    double color_saturation,
    double attenuation
)

Parameters

src
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
color_saturation
Type: System..::.Double
Color saturation (s parameter in the paper) in [0.4..0.6]
attenuation
Type: System..::.Double
Atenuation factor (beta parameter in the paper) in [0.8..0.9]

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


TmoReinhard05 Method

[image]

FreeImage .NET Documentation
FreeImage..::.TmoReinhard05 Method
FreeImage Class See Also Send Feedback
Converts a High Dynamic Range image to a 24-bit RGB image using a global operator inspired by photoreceptor physiology of the human visual system.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP TmoReinhard05(
    FIBITMAP src,
    double intensity,
    double contrast
)
Visual Basic (Declaration)
Public Shared Function TmoReinhard05 ( _
    src As FIBITMAP, _
    intensity As Double, _
    contrast As Double _
) As FIBITMAP
Visual C++
public:
static FIBITMAP TmoReinhard05(
    FIBITMAP src,
    double intensity,
    double contrast
)

Parameters

src
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
intensity
Type: System..::.Double
Controls the overall image intensity in the range [-8, 8].
contrast
Type: System..::.Double
Controls the overall image contrast in the range [0.3, 1.0[.

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ToneMapping Method

[image]

FreeImage .NET Documentation
FreeImage..::.ToneMapping Method
FreeImage Class See Also Send Feedback
Converts a High Dynamic Range image (48-bit RGB or 96-bit RGBF) to a 24-bit RGB image, suitable for display.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FIBITMAP ToneMapping(
    FIBITMAP dib,
    FREE_IMAGE_TMO tmo,
    double first_param,
    double second_param
)
Visual Basic (Declaration)
Public Shared Function ToneMapping ( _
    dib As FIBITMAP, _
    tmo As FREE_IMAGE_TMO, _
    first_param As Double, _
    second_param As Double _
) As FIBITMAP
Visual C++
public:
static FIBITMAP ToneMapping(
    FIBITMAP dib,
    FREE_IMAGE_TMO tmo,
    double first_param,
    double second_param
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
tmo
Type: FreeImageAPI..::.FREE_IMAGE_TMO
The tone mapping operator to be used.
first_param
Type: System..::.Double
Parmeter depending on the used algorithm
second_param
Type: System..::.Double
Parmeter depending on the used algorithm

Return Value

Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


Unload Method

[image]

FreeImage .NET Documentation
FreeImage..::.Unload Method
FreeImage Class See Also Send Feedback
Deletes a previously loaded FIBITMAP from memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void Unload(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Sub Unload ( _
    dib As FIBITMAP _
)
Visual C++
public:
static void Unload(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


UnloadEx Method

[image]

FreeImage .NET Documentation
FreeImage..::.UnloadEx Method
FreeImage Class See Also Send Feedback
Deletes a previously loaded FreeImage bitmap from memory and resets the handle to 0.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void UnloadEx(
    ref FIBITMAP dib
)
Visual Basic (Declaration)
Public Shared Sub UnloadEx ( _
    ByRef dib As FIBITMAP _
)
Visual C++
public:
static void UnloadEx(
    FIBITMAP% dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP %
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


UnlockPage Method

[image]

FreeImage .NET Documentation
FreeImage..::.UnlockPage Method
FreeImage Class See Also Send Feedback
Unlocks a previously locked page and gives it back to the multi-page engine.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void UnlockPage(
    FIMULTIBITMAP bitmap,
    FIBITMAP data,
    bool changed
)
Visual Basic (Declaration)
Public Shared Sub UnlockPage ( _
    bitmap As FIMULTIBITMAP, _
    data As FIBITMAP, _
    changed As Boolean _
)
Visual C++
public:
static void UnlockPage(
    FIMULTIBITMAP bitmap,
    FIBITMAP data,
    bool changed
)

Parameters

bitmap
Type: FreeImageAPI..::.FIMULTIBITMAP
Handle to a FreeImage multi-paged bitmap.
data
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
changed
Type: System..::.Boolean
If true, the page is applied to the multi-page bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


WriteMemory Method

[image]

FreeImage .NET Documentation
FreeImage..::.WriteMemory Method
FreeImage Class See Also Send Feedback
Writes data to a memory stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint WriteMemory(
    byte[] buffer,
    uint size,
    uint count,
    FIMEMORY stream
)
Visual Basic (Declaration)
Public Shared Function WriteMemory ( _
    buffer As Byte(), _
    size As UInteger, _
    count As UInteger, _
    stream As FIMEMORY _
) As UInteger
Visual C++
public:
static unsigned int WriteMemory(
    array<unsigned char>^ buffer,
    unsigned int size,
    unsigned int count,
    FIMEMORY stream
)

Parameters

buffer
Type: array< System..::.Byte >[]()[]
The buffer to read the data from.
size
Type: System..::.UInt32
Size in bytes of the items.
count
Type: System..::.UInt32
Number of items to write.
stream
Type: FreeImageAPI..::.FIMEMORY
The stream to write to. The memory pointer associated with stream is increased by the number of bytes actually written.

Return Value

The number of full items actually written. May be less than count on error or stream-end.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ZLibCompress Method

[image]

FreeImage .NET Documentation
FreeImage..::.ZLibCompress Method
FreeImage Class See Also Send Feedback
Compresses a source buffer into a target buffer, using the ZLib library.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint ZLibCompress(
    byte[] target,
    uint target_size,
    byte[] source,
    uint source_size
)
Visual Basic (Declaration)
Public Shared Function ZLibCompress ( _
    target As Byte(), _
    target_size As UInteger, _
    source As Byte(), _
    source_size As UInteger _
) As UInteger
Visual C++
public:
static unsigned int ZLibCompress(
    array<unsigned char>^ target,
    unsigned int target_size,
    array<unsigned char>^ source,
    unsigned int source_size
)

Parameters

target
Type: array< System..::.Byte >[]()[]
Pointer to the target buffer.
target_size
Type: System..::.UInt32
Size of the target buffer. Must be at least 0.1% larger than source_size plus 12 bytes.
source
Type: array< System..::.Byte >[]()[]
Pointer to the source buffer.
source_size
Type: System..::.UInt32
Size of the source buffer.

Return Value

The actual size of the compressed buffer, or 0 if an error occurred.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ZLibCRC32 Method

[image]

FreeImage .NET Documentation
FreeImage..::.ZLibCRC32 Method
FreeImage Class See Also Send Feedback
Generates a CRC32 checksum.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint ZLibCRC32(
    uint crc,
    byte[] source,
    uint source_size
)
Visual Basic (Declaration)
Public Shared Function ZLibCRC32 ( _
    crc As UInteger, _
    source As Byte(), _
    source_size As UInteger _
) As UInteger
Visual C++
public:
static unsigned int ZLibCRC32(
    unsigned int crc,
    array<unsigned char>^ source,
    unsigned int source_size
)

Parameters

crc
Type: System..::.UInt32
The CRC32 checksum to begin with.
source
Type: array< System..::.Byte >[]()[]
Pointer to the source buffer. If the value is 0, the function returns the required initial value for the crc.
source_size
Type: System..::.UInt32
Size of the source buffer.

Return Value

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ZLibGUnzip Method

[image]

FreeImage .NET Documentation
FreeImage..::.ZLibGUnzip Method
FreeImage Class See Also Send Feedback
Decompresses a source buffer into a target buffer, using the ZLib library.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint ZLibGUnzip(
    byte[] target,
    uint target_size,
    byte[] source,
    uint source_size
)
Visual Basic (Declaration)
Public Shared Function ZLibGUnzip ( _
    target As Byte(), _
    target_size As UInteger, _
    source As Byte(), _
    source_size As UInteger _
) As UInteger
Visual C++
public:
static unsigned int ZLibGUnzip(
    array<unsigned char>^ target,
    unsigned int target_size,
    array<unsigned char>^ source,
    unsigned int source_size
)

Parameters

target
Type: array< System..::.Byte >[]()[]
Pointer to the target buffer.
target_size
Type: System..::.UInt32
Size of the target buffer. Must have been saved outlide of zlib.
source
Type: array< System..::.Byte >[]()[]
Pointer to the source buffer.
source_size
Type: System..::.UInt32
Size of the source buffer.

Return Value

The actual size of the uncompressed buffer, or 0 if an error occurred.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ZLibGZip Method

[image]

FreeImage .NET Documentation
FreeImage..::.ZLibGZip Method
FreeImage Class See Also Send Feedback
Compresses a source buffer into a target buffer, using the ZLib library.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint ZLibGZip(
    byte[] target,
    uint target_size,
    byte[] source,
    uint source_size
)
Visual Basic (Declaration)
Public Shared Function ZLibGZip ( _
    target As Byte(), _
    target_size As UInteger, _
    source As Byte(), _
    source_size As UInteger _
) As UInteger
Visual C++
public:
static unsigned int ZLibGZip(
    array<unsigned char>^ target,
    unsigned int target_size,
    array<unsigned char>^ source,
    unsigned int source_size
)

Parameters

target
Type: array< System..::.Byte >[]()[]
Pointer to the target buffer.
target_size
Type: System..::.UInt32
Size of the target buffer. Must be at least 0.1% larger than source_size plus 24 bytes.
source
Type: array< System..::.Byte >[]()[]
Pointer to the source buffer.
source_size
Type: System..::.UInt32
Size of the source buffer.

Return Value

The actual size of the compressed buffer, or 0 if an error occurred.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


ZLibUncompress Method

[image]

FreeImage .NET Documentation
FreeImage..::.ZLibUncompress Method
FreeImage Class See Also Send Feedback
Decompresses a source buffer into a target buffer, using the ZLib library.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static uint ZLibUncompress(
    byte[] target,
    uint target_size,
    byte[] source,
    uint source_size
)
Visual Basic (Declaration)
Public Shared Function ZLibUncompress ( _
    target As Byte(), _
    target_size As UInteger, _
    source As Byte(), _
    source_size As UInteger _
) As UInteger
Visual C++
public:
static unsigned int ZLibUncompress(
    array<unsigned char>^ target,
    unsigned int target_size,
    array<unsigned char>^ source,
    unsigned int source_size
)

Parameters

target
Type: array< System..::.Byte >[]()[]
Pointer to the target buffer.
target_size
Type: System..::.UInt32
Size of the target buffer. Must have been saved outlide of zlib.
source
Type: array< System..::.Byte >[]()[]
Pointer to the source buffer.
source_size
Type: System..::.UInt32
Size of the source buffer.

Return Value

The actual size of the uncompressed buffer, or 0 if an error occurred.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImage Class


FreeImage Events

[image] [image] [image]

FreeImage .NET Documentation
FreeImage Events
FreeImage Class See Also Send Feedback

The FreeImage type exposes the following members.

Events

Name | Description
Message | Internal errors in FreeImage generate a logstring that can be captured by this event.

See Also

FreeImage Class


Message Event

[image]

FreeImage .NET Documentation
FreeImage..::.Message Event
FreeImage Class See Also Send Feedback
Internal errors in FreeImage generate a logstring that can be captured by this event.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static event OutputMessageFunction Message
Visual Basic (Declaration)
Public Shared Event Message As OutputMessageFunction
Visual C++
public:
static  event OutputMessageFunction^ Message {
    void add (OutputMessageFunction^ value);
    void remove (OutputMessageFunction^ value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FreeImage Class


FreeImageBitmap Class

[image]

FreeImage .NET Documentation
FreeImageBitmap Class
Members See Also Send Feedback
Encapsulates a FreeImage-bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public class FreeImageBitmap : ICloneable,
    IDisposable, IEnumerable, ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FreeImageBitmap _
    Implements ICloneable, IDisposable, IEnumerable, ISerializable
Visual C++
[SerializableAttribute]
public ref class FreeImageBitmap : ICloneable,
    IDisposable, IEnumerable, ISerializable

Inheritance Hierarchy

System..::.Object
FreeImageAPI..::.FreeImageBitmap

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Members


FreeImageBitmap Members

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap Members
FreeImageBitmap Class Constructors Methods Properties See Also Send Feedback

The FreeImageBitmap type exposes the following members.

Constructors

Name | Description
FreeImageBitmap | Overloaded.

Methods

Name | Description
AdjustBrightness | Adjusts the brightness of a 8-, 24- or 32-bit image by a certain amount.
AdjustColors | Adjusts an image's brightness, contrast and gamma as well as it may optionally invert the image within a single operation.
AdjustContrast | Adjusts the contrast of a 8-, 24- or 32-bit image by a certain amount.
AdjustCurve | Perfoms an histogram transformation on a 8-, 24- or 32-bit image.
AdjustGamma | Performs gamma correction on a 8-, 24- or 32-bit image.
ApplyColorMapping | Applies color mapping for one or several colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.
ApplyPaletteIndexMapping | Applies palette index mapping for one or several indices on a 1-, 4- or 8-bit palletized image.
Clone | Creates a deep copy of this FreeImageBitmap.
CloneMetadataFrom | Overloaded.
Composite | This method composite a transparent foreground image against a single background color or against a background image. In case useBitmapBackground is false and applicationBackground and bitmapBackGround are null, a checkerboard will be used as background.
ConvertColorDepth | Converts this FreeImageBitmap into a different color depth. The parameter bpp specifies color depth, greyscale conversion and palette reorder. Adding the FICD_FORCE_GREYSCALE flag will first perform a convesion to greyscale. This can be done with any target color depth. Adding the FICD_REORDER_PALETTE flag will allow the algorithm to reorder the palette. This operation will not be performed to non-greyscale images to prevent data loss by mistake.
ConvertType | Converts this FreeImageBitmap FREE_IMAGE_TYPE to type initializing a new instance. In case source and destination type are the same, the operation fails. An error message can be catched using the 'Message' event.
Copy | Overloaded.
CreateICCProfile | Overloaded.
CreateNewPropertyItem | Returns a new instance of the PropertyItem class which has no public accessible constructor.
Dispose | Overloaded.
EnlargeCanvas | Overloaded.
Equals | Determines whether this and the specified instances are the same. (Overrides Object..::.Equals(Object).)
FillBackground | Overloaded.
Finalize | Frees all managed and unmanaged ressources. (Overrides Object..::.Finalize()()().)
FreeHbitmap | Frees a bitmap handle.
FromFile | Overloaded.
FromHbitmap | Overloaded.
FromHicon | Creates a FreeImageBitmap from a Windows handle to an icon.
FromResource | Creates a FreeImageBitmap from the specified Windows resource.
FromStream | Overloaded.
GetAdjustColorsLookupTable | Creates a lookup table to be used with AdjustCurve() which may adjusts brightness and contrast, correct gamma and invert the image with a single call to AdjustCurve().
GetBounds | Gets the bounds of this FreeImageBitmap in the specified unit.
GetChannel | Retrieves the red, green, blue or alpha channel of a 24- or 32-bit image.
GetColorConvertedInstance | Converts this FreeImageBitmap into a different color depth initializing a new instance. The parameter bpp specifies color depth, greyscale conversion and palette reorder. Adding the FICD_FORCE_GREYSCALE flag will first perform a convesion to greyscale. This can be done with any target color depth. Adding the FICD_REORDER_PALETTE flag will allow the algorithm to reorder the palette. This operation will not be performed to non-greyscale images to prevent data loss by mistake.
GetComplexChannel | Retrieves the real part, imaginary part, magnitude or phase of a complex image.
GetEnlargedInstance | Overloaded.
GetHashCode | Returns a hash code for this FreeImageBitmap structure. (Overrides Object..::.GetHashCode()()().)
GetHbitmap | Overloaded.
GetHbitmapForDevice | Creates a GDI bitmap object from this FreeImageBitmap with the same color depth as the primary device.
GetHicon | Returns the handle to an icon.
GetHistogram | Computes the image histogram.
GetPixel | Gets the Color of the specified pixel in this FreeImageBitmap.
GetPixelFormatSize | Returns the color depth, in number of bits per pixel, of the specified pixel format.
GetPropertyItem | Gets the specified property item from this FreeImageBitmap.
GetQuantizedInstance | Overloaded.
GetRotatedInstance | Overloaded.
GetScaledInstance | Overloaded.
GetScanline | Overloaded.
GetScanlinePointer | Returns a pointer to the specified scanline. Due to FreeImage bitmaps are bottum up, scanline 0 is the most bottom line of the image.
GetScanlines | Returns a list of structures, representing the scanlines of this FreeImageBitmap. Due to FreeImage bitmaps are bottum up, scanline 0 is the bottom-most line of the image. Each color depth has a different representing structure due to different memory layouts.
GetThumbnailImage | Overloaded.
GetTypeConvertedInstance | Converts this FreeImageBitmap FreeImageBitmap to type. In case source and destination type are the same, the operation fails. An error message can be catched using the 'Message' event.
Invert | Inverts each pixel data.
IsAlphaPixelFormat | Returns a value that indicates whether the pixel format for this FreeImageBitmap contains alpha information.
IsCanonicalPixelFormat | Returns a value that indicates whether the pixel format is 32 bits per pixel.
IsExtendedPixelFormat | Returns a value that indicates whether the pixel format is 64 bits per pixel.
JPEGCrop | Overloaded.
JPEGTransform | Performs a lossless rotation or flipping on a JPEG file.
LockBits | Overloaded.
LookupSVGColor | Converts a SVG color name into a corresponding RGB value.
LookupX11Color | Converts a X11 color name into a corresponding RGB value.
MakeTransparent | Overloaded.
MultigridPoissonSolver | Solves a Poisson equation, remap result pixels to [0..1] and returns the solution.
Paste | Overloaded.
PreMultiplyWithAlpha | Applies the alpha value of each pixel to its color components. The aplha value stays unchanged. Only works with 32-bits color depth.
Quantize | Overloaded.
RemovePropertyItem | Removes the specified property item from this FreeImageBitmap.
Rescale | Overloaded.
Rotate | Overloaded.
RotateFlip | This method rotates, flips, or rotates and flips this FreeImageBitmap.
Save | Overloaded.
SaveAdd | Overloaded.
SelectActiveFrame | Selects the frame specified by the index.
SetChannel | Insert a 8-bit dib into a 24- or 32-bit image. Both images must have to same width and height.
SetComplexChannel | Set the real or imaginary part of a complex image. Both images must have to same width and height.
SetPixel | Sets the Color of the specified pixel in this FreeImageBitmap.
SetResolution | Sets the resolution for this FreeImageBitmap.
SwapColors | Swaps two specified colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.
SwapPaletteIndices | Swaps two specified palette indices on a 1-, 4- or 8-bit palletized image.
TmoDrago03 | Converts a High Dynamic Range image to a 24-bit RGB image using a global operator based on logarithmic compression of luminance values, imitating the human response to light.
TmoFattal02 | Apply the Gradient Domain High Dynamic Range Compression to a RGBF image and convert to 24-bit RGB.
TmoReinhard05 | Converts a High Dynamic Range image to a 24-bit RGB image using a global operator inspired by photoreceptor physiology of the human visual system.
ToBitmap | Converts this FreeImageBitmap instance to a Bitmap instance.
UnlockBits | This function is not yet implemented.

Operators

Name | Description
Equality | Determines whether two specified FreeImageBitmap objects have the same value.
Explicit | Overloaded.
Implicit | Overloaded.
Inequality | Determines whether two specified FreeImageBitmap objects have different values.

Properties

Name | Description
BackgroundColor | Gets or sets the background color of this FreeImageBitmap. In case the value is null, the background color is removed.
Bits | Pointer to the data-bits of this FreeImageBitmap.
BlueMask | Bit pattern describing the blue color component of a pixel in this FreeImageBitmap.
ColorDepth | The size of one pixel in the bitmap in bits.
ColorsUsed | Number of palette entries.
ColorType | Investigates the color type of this FreeImageBitmap by reading the bitmaps pixel bits and analysing them.
Comment | Gets or sets the comment of this FreeImageBitmap. Supported formats are JPEG, PNG and GIF.
DataSize | Size of the bitmap in memory.
Flags | Gets attribute flags for the pixel data of this FreeImageBitmap.
FrameCount | Gets the number of frames in this FreeImageBitmap.
GreenMask | Bit pattern describing the green color component of a pixel in this FreeImageBitmap.
HasBackgroundColor | Gets whether this FreeImageBitmap has a file background color.
HasPalette | Returns whether this FreeImageBitmap has a palette.
Height | Height of the bitmap in pixel units.
HorizontalResolution | Gets the horizontal resolution, in pixels per inch, of this FreeImageBitmap.
ICCProfile | Gets the ICCProfile structure of this FreeImageBitmap.
ImageFormat | Gets the format of the original image in case this FreeImageBitmap was loaded from a file or stream.
ImageType | Type of the bitmap.
Info | Returns the BITMAPINFO structure of a this FreeImageBitmap.
InfoHeader | Returns the BITMAPINFOHEADER structure of this FreeImageBitmap.
IsDisposed | Gets whether this FreeImageBitmap has been disposed.
IsRGB555 | Gets whether the bitmap is RGB 555.
IsRGB565 | Gets whether the bitmap is RGB 565.
IsTransparent | Gets or sets whether this FreeImageBitmap is transparent.
Line | Width, in bytes, of this FreeImageBitmap.
Metadata | Gets a new instance of a metadata representing class.
Palette | Returns a structure that represents the palette of a FreeImage bitmap.
PhysicalDimension | Gets the width and height of this FreeImageBitmap.
Pitch | Returns the width of the bitmap in bytes, rounded to the next 32-bit boundary.
PixelFormat | Gets the pixel format for this FreeImageBitmap.
PropertyIdList | Gets IDs of the property items stored in this FreeImageBitmap.
PropertyItems | Gets all the property items (pieces of metadata) stored in this FreeImageBitmap.
RawFormat | Gets the format of this FreeImageBitmap.
RedMask | Bit pattern describing the red color component of a pixel in this FreeImageBitmap.
Scan0 | Pointer to the scanline of the top most pixel row of this FreeImageBitmap.
Size | Gets the width and height, in pixels, of this FreeImageBitmap.
Stride | Width, in bytes, of this FreeImageBitmap. In case this FreeImageBitmap is top down Stride will be positive, else negative.
Tag | Gets or sets an object that provides additional data about the FreeImageBitmap.
TransparencyCount | Number of transparent colors in a palletised FreeImageBitmap.
TransparencyTable | Get or sets transparency table of this FreeImageBitmap.
TransparentIndex | Gets or sets the entry used as transparent color in this FreeImageBitmap. Only works for 1-, 4- and 8-bpp.
UniqueColors | The number of unique colors actually used by the bitmap. This might be different from what ColorsUsed returns, which actually returns the palette size for palletised images. Works for FIT_BITMAP type bitmaps only.
VerticalResolution | Gets the vertical resolution, in pixels per inch, of this FreeImageBitmap.
Width | Width of the bitmap in pixel units.

See Also

FreeImageBitmap Class


FreeImageBitmap Constructor

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap Constructor
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
FreeImageBitmap()()() | Initializes a new instance of the FreeImageBitmap class.
FreeImageBitmap(FIBITMAP) | Initializes a new instance of the FreeImageBitmap class. For internal use only.
FreeImageBitmap(FreeImageBitmap) | Initializes a new instance of the FreeImageBitmap class bases on the specified image.
FreeImageBitmap(Bitmap) | Initializes a new instance of the FreeImageBitmap class bases on the specified image.
FreeImageBitmap(Image) | Initializes a new instance of the FreeImageBitmap class bases on the specified image.
FreeImageBitmap(Stream) | Initializes a new instance of the FreeImageBitmap class bases on the specified stream.
FreeImageBitmap(String) | Initializes a new instance of the FreeImageBitmap class bases on the specified file.
FreeImageBitmap(FreeImageBitmap, Size) | Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.
FreeImageBitmap(Bitmap, Size) | Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.
FreeImageBitmap(Image, Size) | Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.
FreeImageBitmap(Int32, Int32) | Initializes a new instance of the FreeImageBitmap class bases on the specified size.
FreeImageBitmap(Stream, FREE_IMAGE_FORMAT) | Initializes a new instance of the FreeImageBitmap class bases on the specified stream in the specified format.
FreeImageBitmap(Stream, FREE_IMAGE_LOAD_FLAGS) | Initializes a new instance of the FreeImageBitmap class bases on the specified stream with the specified loading flags.
FreeImageBitmap(Stream, Boolean) | Initializes a new instance of the FreeImageBitmap class bases on the specified stream.
FreeImageBitmap(SerializationInfo, StreamingContext) | Initializes a new instance of the FreeImageBitmap class.
FreeImageBitmap(String, FREE_IMAGE_FORMAT) | Initializes a new instance of the FreeImageBitmap class bases on the specified file in the specified format.
FreeImageBitmap(String, FREE_IMAGE_LOAD_FLAGS) | Initializes a new instance of the FreeImageBitmap class bases on the specified file with the specified loading flags.
FreeImageBitmap(String, Boolean) | Initializes a new instance of the FreeImageBitmap class bases on the specified file.
FreeImageBitmap(Type, String) | Initializes a new instance of the FreeImageBitmap class bases on the specified resource.
FreeImageBitmap(FreeImageBitmap, Int32, Int32) | Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.
FreeImageBitmap(Bitmap, Int32, Int32) | Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.
FreeImageBitmap(Image, Int32, Int32) | Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.
FreeImageBitmap(Int32, Int32, FREE_IMAGE_TYPE) | Initializes a new instance of the FreeImageBitmap class bases on the specified size and type. Only non standard bitmaps are supported.
FreeImageBitmap(Int32, Int32, Graphics) | Initializes a new instance of the FreeImageBitmap class bases on the specified size and with the resolution of the specified Graphics object.
FreeImageBitmap(Int32, Int32, PixelFormat) | Initializes a new instance of the FreeImageBitmap class bases on the specified size and format.
FreeImageBitmap(Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS) | Initializes a new instance of the FreeImageBitmap class bases on the specified stream in the specified format with the specified loading flags.
FreeImageBitmap(String, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS) | Initializes a new instance of the FreeImageBitmap class bases on the specified file in the specified format with the specified loading flags.
FreeImageBitmap(Int32, Int32, Int32, PixelFormat, IntPtr) | Initializes a new instance of the FreeImageBitmap class bases on the specified size, pixel format and pixel data.
FreeImageBitmap(Int32, Int32, Int32, PixelFormat, array<Byte>[]()[]) | Initializes a new instance of the FreeImageBitmap class bases on the specified size, pixel format and pixel data.
FreeImageBitmap(Int32, Int32, Int32, Int32, FREE_IMAGE_TYPE, array<Byte>[]()[]) | Initializes a new instance of the FreeImageBitmap class bases on the specified size, pixel format and pixel data.
FreeImageBitmap(Int32, Int32, Int32, Int32, FREE_IMAGE_TYPE, IntPtr) | Initializes a new instance of the FreeImageBitmap class bases on the specified size, pixel format and pixel data.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


FreeImageBitmap Constructor

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected FreeImageBitmap()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
FreeImageBitmap()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (FIBITMAP)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (FIBITMAP)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class. For internal use only.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected internal FreeImageBitmap(
    FIBITMAP dib
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    dib As FIBITMAP _
)
Visual C++
protected public:
FreeImageBitmap(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP

Exceptions

Exception | Condition
System..::.Exception | The operation failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (FreeImageBitmap)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (FreeImageBitmap)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    FreeImageBitmap original
)
Visual Basic (Declaration)
Public Sub New ( _
    original As FreeImageBitmap _
)
Visual C++
public:
FreeImageBitmap(
    FreeImageBitmap^ original
)

Parameters

original
Type: FreeImageAPI..::.FreeImageBitmap
The original to clone from.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | original is a null reference.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Bitmap)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Bitmap)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Bitmap original
)
Visual Basic (Declaration)
Public Sub New ( _
    original As Bitmap _
)
Visual C++
public:
FreeImageBitmap(
    Bitmap^ original
)

Parameters

original
Type: System.Drawing..::.Bitmap
The original to clone from.

Remarks

Although this constructor supports creating images in both formats Format32bppPArgb and Format64bppPArgb, bitmaps created in these formats are treated like any normal 32-bit RGBA and 64-bit RGBA images respectively. Currently, there is no support for automatic premultiplying images in FreeImageBitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | original is a null reference.
System..::.Exception | The operation failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Image)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Image)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Image original
)
Visual Basic (Declaration)
Public Sub New ( _
    original As Image _
)
Visual C++
public:
FreeImageBitmap(
    Image^ original
)

Parameters

original
Type: System.Drawing..::.Image
The original to clone from.

Remarks

Although this constructor supports creating images in both formats Format32bppPArgb and Format64bppPArgb, bitmaps created in these formats are treated like any normal 32-bit RGBA and 64-bit RGBA images respectively. Currently, there is no support for automatic premultiplying images in FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Stream)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Stream)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Stream stream
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
FreeImageBitmap(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
Stream to read from.

Remarks

You must keep the stream open for the lifetime of the FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | stream is a null reference.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (String)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (String)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    string filename
)
Visual Basic (Declaration)
Public Sub New ( _
    filename As String _
)
Visual C++
public:
FreeImageBitmap(
    String^ filename
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | filename is a null reference.
System.IO..::.FileNotFoundException | filename does not exist.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (FreeImageBitmap, Size)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (FreeImageBitmap, Size)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    FreeImageBitmap original,
    Size newSize
)
Visual Basic (Declaration)
Public Sub New ( _
    original As FreeImageBitmap, _
    newSize As Size _
)
Visual C++
public:
FreeImageBitmap(
    FreeImageBitmap^ original,
    Size newSize
)

Parameters

original
Type: FreeImageAPI..::.FreeImageBitmap
The original to clone from.
newSize
Type: System.Drawing..::.Size
The Size structure that represent the size of the new FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | original is a null reference.
System..::.ArgumentOutOfRangeException | newSize.Width or newSize.Height are less or equal zero.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Bitmap, Size)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Bitmap, Size)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Bitmap original,
    Size newSize
)
Visual Basic (Declaration)
Public Sub New ( _
    original As Bitmap, _
    newSize As Size _
)
Visual C++
public:
FreeImageBitmap(
    Bitmap^ original,
    Size newSize
)

Parameters

original
Type: System.Drawing..::.Bitmap
The original to clone from.
newSize
Type: System.Drawing..::.Size
The Size structure that represent the size of the new FreeImageBitmap.

Remarks

Although this constructor supports creating images in both formats Format32bppPArgb and Format64bppPArgb, bitmaps created in these formats are treated like any normal 32-bit RGBA and 64-bit RGBA images respectively. Currently, there is no support for automatic premultiplying images in FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | original is a null reference.
System..::.ArgumentOutOfRangeException | newSize.Width or newSize.Height are less or equal zero.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Image, Size)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Image, Size)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Image original,
    Size newSize
)
Visual Basic (Declaration)
Public Sub New ( _
    original As Image, _
    newSize As Size _
)
Visual C++
public:
FreeImageBitmap(
    Image^ original,
    Size newSize
)

Parameters

original
Type: System.Drawing..::.Image
The original to clone from.
newSize
Type: System.Drawing..::.Size
The Size structure that represent the size of the new FreeImageBitmap.

Remarks

Although this constructor supports creating images in both formats Format32bppPArgb and Format64bppPArgb, bitmaps created in these formats are treated like any normal 32-bit RGBA and 64-bit RGBA images respectively. Currently, there is no support for automatic premultiplying images in FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | original is a null reference.
System..::.ArgumentOutOfRangeException | newSize.Width or newSize.Height are less or equal zero.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Int32, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Int32, Int32)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified size.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    int width,
    int height
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
FreeImageBitmap(
    int width,
    int height
)

Parameters

width
Type: System..::.Int32
The width, in pixels, of the new FreeImageBitmap.
height
Type: System..::.Int32
The height, in pixels, of the new FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Stream, FREE_IMAGE_FORMAT)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Stream, FREE_IMAGE_FORMAT)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified stream in the specified format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Stream stream,
    FREE_IMAGE_FORMAT format
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As Stream, _
    format As FREE_IMAGE_FORMAT _
)
Visual C++
public:
FreeImageBitmap(
    Stream^ stream,
    FREE_IMAGE_FORMAT format
)

Parameters

stream
Type: System.IO..::.Stream
Stream to read from.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.

Remarks

You must keep the stream open for the lifetime of the FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | stream is a null reference.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Stream, FREE_IMAGE_LOAD_FLAGS)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Stream, FREE_IMAGE_LOAD_FLAGS)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified stream with the specified loading flags.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Stream stream,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As Stream, _
    flags As FREE_IMAGE_LOAD_FLAGS _
)
Visual C++
public:
FreeImageBitmap(
    Stream^ stream,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

stream
Type: System.IO..::.Stream
Stream to read from.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Remarks

You must keep the stream open for the lifetime of the FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | stream is a null reference.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Stream, Boolean)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Stream, Boolean)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Stream stream,
    bool useIcm
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As Stream, _
    useIcm As Boolean _
)
Visual C++
public:
FreeImageBitmap(
    Stream^ stream,
    bool useIcm
)

Parameters

stream
Type: System.IO..::.Stream
Stream to read from.
useIcm
Type: System..::.Boolean
Ignored.

Remarks

You must keep the stream open for the lifetime of the FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | stream is a null reference.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (SerializationInfo, StreamingContext)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (SerializationInfo, StreamingContext)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
FreeImageBitmap(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
context
Type: System.Runtime.Serialization..::.StreamingContext

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System.Runtime.Serialization..::.SerializationException | The operation failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (String, FREE_IMAGE_FORMAT)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (String, FREE_IMAGE_FORMAT)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified file in the specified format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    string filename,
    FREE_IMAGE_FORMAT format
)
Visual Basic (Declaration)
Public Sub New ( _
    filename As String, _
    format As FREE_IMAGE_FORMAT _
)
Visual C++
public:
FreeImageBitmap(
    String^ filename,
    FREE_IMAGE_FORMAT format
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | filename is a null reference.
System.IO..::.FileNotFoundException | filename does not exist.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (String, FREE_IMAGE_LOAD_FLAGS)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (String, FREE_IMAGE_LOAD_FLAGS)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified file with the specified loading flags.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    string filename,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Sub New ( _
    filename As String, _
    flags As FREE_IMAGE_LOAD_FLAGS _
)
Visual C++
public:
FreeImageBitmap(
    String^ filename,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | filename is a null reference.
System.IO..::.FileNotFoundException | filename does not exist.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (String, Boolean)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (String, Boolean)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    string filename,
    bool useIcm
)
Visual Basic (Declaration)
Public Sub New ( _
    filename As String, _
    useIcm As Boolean _
)
Visual C++
public:
FreeImageBitmap(
    String^ filename,
    bool useIcm
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
useIcm
Type: System..::.Boolean
Ignored.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | filename is a null reference.
System.IO..::.FileNotFoundException | filename does not exist.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Type, String)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Type, String)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified resource.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Type type,
    string resource
)
Visual Basic (Declaration)
Public Sub New ( _
    type As Type, _
    resource As String _
)
Visual C++
public:
FreeImageBitmap(
    Type^ type,
    String^ resource
)

Parameters

type
Type: System..::.Type
The class used to extract the resource.
resource
Type: System..::.String
The name of the resource.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (FreeImageBitmap, Int32, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (FreeImageBitmap, Int32, Int32)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    FreeImageBitmap original,
    int width,
    int height
)
Visual Basic (Declaration)
Public Sub New ( _
    original As FreeImageBitmap, _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
FreeImageBitmap(
    FreeImageBitmap^ original,
    int width,
    int height
)

Parameters

original
Type: FreeImageAPI..::.FreeImageBitmap
The original to clone from.
width
Type: System..::.Int32
Width of the new FreeImageBitmap.
height
Type: System..::.Int32
Height of the new FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | original is a null reference.
System..::.ArgumentOutOfRangeException | width or height are less or equal zero.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Bitmap, Int32, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Bitmap, Int32, Int32)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Bitmap original,
    int width,
    int height
)
Visual Basic (Declaration)
Public Sub New ( _
    original As Bitmap, _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
FreeImageBitmap(
    Bitmap^ original,
    int width,
    int height
)

Parameters

original
Type: System.Drawing..::.Bitmap
The original to clone from.
width
Type: System..::.Int32
The width, in pixels, of the new FreeImageBitmap.
height
Type: System..::.Int32
The height, in pixels, of the new FreeImageBitmap.

Remarks

Although this constructor supports creating images in both formats Format32bppPArgb and Format64bppPArgb, bitmaps created in these formats are treated like any normal 32-bit RGBA and 64-bit RGBA images respectively. Currently, there is no support for automatic premultiplying images in FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | original is a null reference.
System..::.ArgumentOutOfRangeException | width or height are less or equal zero.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Image, Int32, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Image, Int32, Int32)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified image with the specified size.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Image original,
    int width,
    int height
)
Visual Basic (Declaration)
Public Sub New ( _
    original As Image, _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
FreeImageBitmap(
    Image^ original,
    int width,
    int height
)

Parameters

original
Type: System.Drawing..::.Image
The original to clone from.
width
Type: System..::.Int32
The width, in pixels, of the new FreeImageBitmap.
height
Type: System..::.Int32
The height, in pixels, of the new FreeImageBitmap.

Remarks

Although this constructor supports creating images in both formats Format32bppPArgb and Format64bppPArgb, bitmaps created in these formats are treated like any normal 32-bit RGBA and 64-bit RGBA images respectively. Currently, there is no support for automatic premultiplying images in FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | original is a null reference.
System..::.ArgumentOutOfRangeException | width or height are less or equal zero.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Int32, Int32, FREE_IMAGE_TYPE)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Int32, Int32, FREE_IMAGE_TYPE)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified size and type. Only non standard bitmaps are supported.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    int width,
    int height,
    FREE_IMAGE_TYPE type
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    type As FREE_IMAGE_TYPE _
)
Visual C++
public:
FreeImageBitmap(
    int width,
    int height,
    FREE_IMAGE_TYPE type
)

Parameters

width
Type: System..::.Int32
The width, in pixels, of the new FreeImageBitmap.
height
Type: System..::.Int32
The height, in pixels, of the new FreeImageBitmap.
type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
The type of the bitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentOutOfRangeException | type is FIT_BITMAP or FIT_UNKNOWN.
System..::.ArgumentException | type is invalid.
System..::.ArgumentOutOfRangeException | width or height are less or equal zero.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Int32, Int32, Graphics)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Int32, Int32, Graphics)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified size and with the resolution of the specified Graphics object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    int width,
    int height,
    Graphics g
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    g As Graphics _
)
Visual C++
public:
FreeImageBitmap(
    int width,
    int height,
    Graphics^ g
)

Parameters

width
Type: System..::.Int32
The width, in pixels, of the new FreeImageBitmap.
height
Type: System..::.Int32
The height, in pixels, of the new FreeImageBitmap.
g
Type: System.Drawing..::.Graphics
The Graphics object that specifies the resolution for the new FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | g is a null reference.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Int32, Int32, PixelFormat)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Int32, Int32, PixelFormat)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified size and format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    int width,
    int height,
    PixelFormat format
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    format As PixelFormat _
)
Visual C++
public:
FreeImageBitmap(
    int width,
    int height,
    PixelFormat format
)

Parameters

width
Type: System..::.Int32
The width, in pixels, of the new FreeImageBitmap.
height
Type: System..::.Int32
The height, in pixels, of the new FreeImageBitmap.
format
Type: System.Drawing.Imaging..::.PixelFormat
The PixelFormat enumeration for the new FreeImageBitmap.

Remarks

Although this constructor supports creating images in both formats Format32bppPArgb and Format64bppPArgb, bitmaps created in these formats are treated like any normal 32-bit RGBA and 64-bit RGBA images respectively. Currently, there is no support for automatic premultiplying images in FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentException | format is invalid.
System..::.ArgumentOutOfRangeException | width or height are less or equal zero.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified stream in the specified format with the specified loading flags.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    Stream stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As Stream, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_LOAD_FLAGS _
)
Visual C++
public:
FreeImageBitmap(
    Stream^ stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

stream
Type: System.IO..::.Stream
Stream to read from.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Remarks

You must keep the stream open for the lifetime of the FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | stream is a null reference.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (String, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (String, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified file in the specified format with the specified loading flags.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    string filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS flags
)
Visual Basic (Declaration)
Public Sub New ( _
    filename As String, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_LOAD_FLAGS _
)
Visual C++
public:
FreeImageBitmap(
    String^ filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS flags
)

Parameters

filename
Type: System..::.String
The complete name of the file to load.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
flags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentNullException | filename is a null reference.
System.IO..::.FileNotFoundException | filename does not exist.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Int32, Int32, Int32, PixelFormat, IntPtr)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Int32, Int32, Int32, PixelFormat, IntPtr)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified size, pixel format and pixel data.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    int width,
    int height,
    int stride,
    PixelFormat format,
    IntPtr scan0
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    stride As Integer, _
    format As PixelFormat, _
    scan0 As IntPtr _
)
Visual C++
public:
FreeImageBitmap(
    int width,
    int height,
    int stride,
    PixelFormat format,
    IntPtr scan0
)

Parameters

width
Type: System..::.Int32
The width, in pixels, of the new FreeImageBitmap.
height
Type: System..::.Int32
The height, in pixels, of the new FreeImageBitmap.
stride
Type: System..::.Int32
Integer that specifies the byte offset between the beginning of one scan line and the next. This is usually (but not necessarily) the number of bytes in the pixel format (for example, 2 for 16 bits per pixel) multiplied by the width of the bitmap. The value passed to this parameter must be a multiple of four..
format
Type: System.Drawing.Imaging..::.PixelFormat
The PixelFormat enumeration for the new FreeImageBitmap.
scan0
Type: System..::.IntPtr
Pointer to an array of bytes that contains the pixel data.

Remarks

Although this constructor supports creating images in both formats Format32bppPArgb and Format64bppPArgb, bitmaps created in these formats are treated like any normal 32-bit RGBA and 64-bit RGBA images respectively. Currently, there is no support for automatic premultiplying images in FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentException | format is invalid.
System..::.ArgumentOutOfRangeException | width or height are less or equal zero.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Int32, Int32, Int32, PixelFormat, Byte[])

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Int32, Int32, Int32, PixelFormat, array<Byte>[]()[])
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified size, pixel format and pixel data.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    int width,
    int height,
    int stride,
    PixelFormat format,
    byte[] bits
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    stride As Integer, _
    format As PixelFormat, _
    bits As Byte() _
)
Visual C++
public:
FreeImageBitmap(
    int width,
    int height,
    int stride,
    PixelFormat format,
    array<unsigned char>^ bits
)

Parameters

width
Type: System..::.Int32
The width, in pixels, of the new FreeImageBitmap.
height
Type: System..::.Int32
The height, in pixels, of the new FreeImageBitmap.
stride
Type: System..::.Int32
Integer that specifies the byte offset between the beginning of one scan line and the next. This is usually (but not necessarily) the number of bytes in the pixel format (for example, 2 for 16 bits per pixel) multiplied by the width of the bitmap. The value passed to this parameter must be a multiple of four..
format
Type: System.Drawing.Imaging..::.PixelFormat
The PixelFormat enumeration for the new FreeImageBitmap.
bits
Type: array< System..::.Byte >[]()[]
Array of bytes containing the bitmap data.

Remarks

Although this constructor supports creating images in both formats Format32bppPArgb and Format64bppPArgb, bitmaps created in these formats are treated like any normal 32-bit RGBA and 64-bit RGBA images respectively. Currently, there is no support for automatic premultiplying images in FreeImageBitmap.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentException | format is invalid.
System..::.ArgumentOutOfRangeException | width or height are less or equal zero.
System..::.ArgumentNullException | bits is null

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Int32, Int32, Int32, Int32, FREE_IMAGE_TYPE, Byte[])

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Int32, Int32, Int32, Int32, FREE_IMAGE_TYPE, array<Byte>[]()[])
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified size, pixel format and pixel data.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    int width,
    int height,
    int stride,
    int bpp,
    FREE_IMAGE_TYPE type,
    byte[] bits
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    stride As Integer, _
    bpp As Integer, _
    type As FREE_IMAGE_TYPE, _
    bits As Byte() _
)
Visual C++
public:
FreeImageBitmap(
    int width,
    int height,
    int stride,
    int bpp,
    FREE_IMAGE_TYPE type,
    array<unsigned char>^ bits
)

Parameters

width
Type: System..::.Int32
The width, in pixels, of the new FreeImageBitmap.
height
Type: System..::.Int32
The height, in pixels, of the new FreeImageBitmap.
stride
Type: System..::.Int32
Integer that specifies the byte offset between the beginning of one scan line and the next. This is usually (but not necessarily) the number of bytes in the pixel format (for example, 2 for 16 bits per pixel) multiplied by the width of the bitmap. The value passed to this parameter must be a multiple of four..
bpp
Type: System..::.Int32
The color depth of the new FreeImageBitmap
type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
The type for the new FreeImageBitmap.
bits
Type: array< System..::.Byte >[]()[]
Array of bytes containing the bitmap data.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentException | format is invalid.
System..::.ArgumentOutOfRangeException | width or height are less or equal zero.
System..::.ArgumentNullException | bits is null

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Constructor (Int32, Int32, Int32, Int32, FREE_IMAGE_TYPE, IntPtr)

[image]

FreeImage .NET Documentation
FreeImageBitmap Constructor (Int32, Int32, Int32, Int32, FREE_IMAGE_TYPE, IntPtr)
FreeImageBitmap Class See Also Send Feedback
Initializes a new instance of the FreeImageBitmap class bases on the specified size, pixel format and pixel data.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap(
    int width,
    int height,
    int stride,
    int bpp,
    FREE_IMAGE_TYPE type,
    IntPtr scan0
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    stride As Integer, _
    bpp As Integer, _
    type As FREE_IMAGE_TYPE, _
    scan0 As IntPtr _
)
Visual C++
public:
FreeImageBitmap(
    int width,
    int height,
    int stride,
    int bpp,
    FREE_IMAGE_TYPE type,
    IntPtr scan0
)

Parameters

width
Type: System..::.Int32
The width, in pixels, of the new FreeImageBitmap.
height
Type: System..::.Int32
The height, in pixels, of the new FreeImageBitmap.
stride
Type: System..::.Int32
Integer that specifies the byte offset between the beginning of one scan line and the next. This is usually (but not necessarily) the number of bytes in the pixel format (for example, 2 for 16 bits per pixel) multiplied by the width of the bitmap. The value passed to this parameter must be a multiple of four..
bpp
Type: System..::.Int32
The color depth of the new FreeImageBitmap
type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
The type for the new FreeImageBitmap.
scan0
Type: System..::.IntPtr
Pointer to an array of bytes that contains the pixel data.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.ArgumentException | format is invalid.
System..::.ArgumentOutOfRangeException | width or height are less or equal zero.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FreeImageBitmap Overload


FreeImageBitmap Methods

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap Methods
FreeImageBitmap Class See Also Send Feedback

The FreeImageBitmap type exposes the following members.

Methods

Name | Description
AdjustBrightness | Adjusts the brightness of a 8-, 24- or 32-bit image by a certain amount.
AdjustColors | Adjusts an image's brightness, contrast and gamma as well as it may optionally invert the image within a single operation.
AdjustContrast | Adjusts the contrast of a 8-, 24- or 32-bit image by a certain amount.
AdjustCurve | Perfoms an histogram transformation on a 8-, 24- or 32-bit image.
AdjustGamma | Performs gamma correction on a 8-, 24- or 32-bit image.
ApplyColorMapping | Applies color mapping for one or several colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.
ApplyPaletteIndexMapping | Applies palette index mapping for one or several indices on a 1-, 4- or 8-bit palletized image.
Clone | Creates a deep copy of this FreeImageBitmap.
CloneMetadataFrom | Overloaded.
Composite | This method composite a transparent foreground image against a single background color or against a background image. In case useBitmapBackground is false and applicationBackground and bitmapBackGround are null, a checkerboard will be used as background.
ConvertColorDepth | Converts this FreeImageBitmap into a different color depth. The parameter bpp specifies color depth, greyscale conversion and palette reorder. Adding the FICD_FORCE_GREYSCALE flag will first perform a convesion to greyscale. This can be done with any target color depth. Adding the FICD_REORDER_PALETTE flag will allow the algorithm to reorder the palette. This operation will not be performed to non-greyscale images to prevent data loss by mistake.
ConvertType | Converts this FreeImageBitmap FREE_IMAGE_TYPE to type initializing a new instance. In case source and destination type are the same, the operation fails. An error message can be catched using the 'Message' event.
Copy | Overloaded.
CreateICCProfile | Overloaded.
CreateNewPropertyItem | Returns a new instance of the PropertyItem class which has no public accessible constructor.
Dispose | Overloaded.
EnlargeCanvas | Overloaded.
Equals | Determines whether this and the specified instances are the same. (Overrides Object..::.Equals(Object).)
FillBackground | Overloaded.
Finalize | Frees all managed and unmanaged ressources. (Overrides Object..::.Finalize()()().)
FreeHbitmap | Frees a bitmap handle.
FromFile | Overloaded.
FromHbitmap | Overloaded.
FromHicon | Creates a FreeImageBitmap from a Windows handle to an icon.
FromResource | Creates a FreeImageBitmap from the specified Windows resource.
FromStream | Overloaded.
GetAdjustColorsLookupTable | Creates a lookup table to be used with AdjustCurve() which may adjusts brightness and contrast, correct gamma and invert the image with a single call to AdjustCurve().
GetBounds | Gets the bounds of this FreeImageBitmap in the specified unit.
GetChannel | Retrieves the red, green, blue or alpha channel of a 24- or 32-bit image.
GetColorConvertedInstance | Converts this FreeImageBitmap into a different color depth initializing a new instance. The parameter bpp specifies color depth, greyscale conversion and palette reorder. Adding the FICD_FORCE_GREYSCALE flag will first perform a convesion to greyscale. This can be done with any target color depth. Adding the FICD_REORDER_PALETTE flag will allow the algorithm to reorder the palette. This operation will not be performed to non-greyscale images to prevent data loss by mistake.
GetComplexChannel | Retrieves the real part, imaginary part, magnitude or phase of a complex image.
GetEnlargedInstance | Overloaded.
GetHashCode | Returns a hash code for this FreeImageBitmap structure. (Overrides Object..::.GetHashCode()()().)
GetHbitmap | Overloaded.
GetHbitmapForDevice | Creates a GDI bitmap object from this FreeImageBitmap with the same color depth as the primary device.
GetHicon | Returns the handle to an icon.
GetHistogram | Computes the image histogram.
GetPixel | Gets the Color of the specified pixel in this FreeImageBitmap.
GetPixelFormatSize | Returns the color depth, in number of bits per pixel, of the specified pixel format.
GetPropertyItem | Gets the specified property item from this FreeImageBitmap.
GetQuantizedInstance | Overloaded.
GetRotatedInstance | Overloaded.
GetScaledInstance | Overloaded.
GetScanline | Overloaded.
GetScanlinePointer | Returns a pointer to the specified scanline. Due to FreeImage bitmaps are bottum up, scanline 0 is the most bottom line of the image.
GetScanlines | Returns a list of structures, representing the scanlines of this FreeImageBitmap. Due to FreeImage bitmaps are bottum up, scanline 0 is the bottom-most line of the image. Each color depth has a different representing structure due to different memory layouts.
GetThumbnailImage | Overloaded.
GetTypeConvertedInstance | Converts this FreeImageBitmap FreeImageBitmap to type. In case source and destination type are the same, the operation fails. An error message can be catched using the 'Message' event.
Invert | Inverts each pixel data.
IsAlphaPixelFormat | Returns a value that indicates whether the pixel format for this FreeImageBitmap contains alpha information.
IsCanonicalPixelFormat | Returns a value that indicates whether the pixel format is 32 bits per pixel.
IsExtendedPixelFormat | Returns a value that indicates whether the pixel format is 64 bits per pixel.
JPEGCrop | Overloaded.
JPEGTransform | Performs a lossless rotation or flipping on a JPEG file.
LockBits | Overloaded.
LookupSVGColor | Converts a SVG color name into a corresponding RGB value.
LookupX11Color | Converts a X11 color name into a corresponding RGB value.
MakeTransparent | Overloaded.
MultigridPoissonSolver | Solves a Poisson equation, remap result pixels to [0..1] and returns the solution.
Paste | Overloaded.
PreMultiplyWithAlpha | Applies the alpha value of each pixel to its color components. The aplha value stays unchanged. Only works with 32-bits color depth.
Quantize | Overloaded.
RemovePropertyItem | Removes the specified property item from this FreeImageBitmap.
Rescale | Overloaded.
Rotate | Overloaded.
RotateFlip | This method rotates, flips, or rotates and flips this FreeImageBitmap.
Save | Overloaded.
SaveAdd | Overloaded.
SelectActiveFrame | Selects the frame specified by the index.
SetChannel | Insert a 8-bit dib into a 24- or 32-bit image. Both images must have to same width and height.
SetComplexChannel | Set the real or imaginary part of a complex image. Both images must have to same width and height.
SetPixel | Sets the Color of the specified pixel in this FreeImageBitmap.
SetResolution | Sets the resolution for this FreeImageBitmap.
SwapColors | Swaps two specified colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.
SwapPaletteIndices | Swaps two specified palette indices on a 1-, 4- or 8-bit palletized image.
TmoDrago03 | Converts a High Dynamic Range image to a 24-bit RGB image using a global operator based on logarithmic compression of luminance values, imitating the human response to light.
TmoFattal02 | Apply the Gradient Domain High Dynamic Range Compression to a RGBF image and convert to 24-bit RGB.
TmoReinhard05 | Converts a High Dynamic Range image to a 24-bit RGB image using a global operator inspired by photoreceptor physiology of the human visual system.
ToBitmap | Converts this FreeImageBitmap instance to a Bitmap instance.
UnlockBits | This function is not yet implemented.

Operators

Name | Description
Equality | Determines whether two specified FreeImageBitmap objects have the same value.
Explicit | Overloaded.
Implicit | Overloaded.
Inequality | Determines whether two specified FreeImageBitmap objects have different values.

See Also

FreeImageBitmap Class


AdjustBrightness Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.AdjustBrightness Method
FreeImageBitmap Class See Also Send Feedback
Adjusts the brightness of a 8-, 24- or 32-bit image by a certain amount.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool AdjustBrightness(
    double percentage
)
Visual Basic (Declaration)
Public Function AdjustBrightness ( _
    percentage As Double _
) As Boolean
Visual C++
public:
bool AdjustBrightness(
    double percentage
)

Parameters

percentage
Type: System..::.Double
A value 0 means no change, less than 0 will make the image darker and greater than 0 will make the image brighter.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


AdjustColors Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.AdjustColors Method
FreeImageBitmap Class See Also Send Feedback
Adjusts an image's brightness, contrast and gamma as well as it may optionally invert the image within a single operation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool AdjustColors(
    double brightness,
    double contrast,
    double gamma,
    bool invert
)
Visual Basic (Declaration)
Public Function AdjustColors ( _
    brightness As Double, _
    contrast As Double, _
    gamma As Double, _
    invert As Boolean _
) As Boolean
Visual C++
public:
bool AdjustColors(
    double brightness,
    double contrast,
    double gamma,
    bool invert
)

Parameters

brightness
Type: System..::.Double
Percentage brightness value where -100 <= brightness <= 100.

A value of 0 means no change, less than 0 will make the image darker and greater than 0 will make the image brighter.

contrast
Type: System..::.Double
Percentage contrast value where -100 <= contrast <= 100.

A value of 0 means no change, less than 0 will decrease the contrast and greater than 0 will increase the contrast of the image.

gamma
Type: System..::.Double
Gamma value to be used for gamma correction.

A value of 1.0 leaves the image alone, less than one darkens it, and greater than one lightens it.

This parameter must not be zero or smaller than zero. If so, it will be ignored and no gamma correction will be performed on the image.
invert
Type: System..::.Boolean
If set to true, the image will be inverted.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


AdjustContrast Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.AdjustContrast Method
FreeImageBitmap Class See Also Send Feedback
Adjusts the contrast of a 8-, 24- or 32-bit image by a certain amount.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool AdjustContrast(
    double percentage
)
Visual Basic (Declaration)
Public Function AdjustContrast ( _
    percentage As Double _
) As Boolean
Visual C++
public:
bool AdjustContrast(
    double percentage
)

Parameters

percentage
Type: System..::.Double
A value 0 means no change, less than 0 will decrease the contrast and greater than 0 will increase the contrast of the image.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


AdjustCurve Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.AdjustCurve Method
FreeImageBitmap Class See Also Send Feedback
Perfoms an histogram transformation on a 8-, 24- or 32-bit image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool AdjustCurve(
    byte[] lookUpTable,
    FREE_IMAGE_COLOR_CHANNEL channel
)
Visual Basic (Declaration)
Public Function AdjustCurve ( _
    lookUpTable As Byte(), _
    channel As FREE_IMAGE_COLOR_CHANNEL _
) As Boolean
Visual C++
public:
bool AdjustCurve(
    array<unsigned char>^ lookUpTable,
    FREE_IMAGE_COLOR_CHANNEL channel
)

Parameters

lookUpTable
Type: array< System..::.Byte >[]()[]
The lookup table (LUT). It's size is assumed to be 256 in length.
channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
The color channel to be transformed.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


AdjustGamma Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.AdjustGamma Method
FreeImageBitmap Class See Also Send Feedback
Performs gamma correction on a 8-, 24- or 32-bit image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool AdjustGamma(
    double gamma
)
Visual Basic (Declaration)
Public Function AdjustGamma ( _
    gamma As Double _
) As Boolean
Visual C++
public:
bool AdjustGamma(
    double gamma
)

Parameters

gamma
Type: System..::.Double
The parameter represents the gamma value to use (gamma > 0). A value of 1.0 leaves the image alone, less than one darkens it, and greater than one lightens it.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


ApplyColorMapping Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.ApplyColorMapping Method
FreeImageBitmap Class See Also Send Feedback
Applies color mapping for one or several colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint ApplyColorMapping(
    RGBQUAD[] srccolors,
    RGBQUAD[] dstcolors,
    bool ignore_alpha,
    bool swap
)
Visual Basic (Declaration)
Public Function ApplyColorMapping ( _
    srccolors As RGBQUAD(), _
    dstcolors As RGBQUAD(), _
    ignore_alpha As Boolean, _
    swap As Boolean _
) As UInteger
Visual C++
public:
unsigned int ApplyColorMapping(
    array<RGBQUAD>^ srccolors,
    array<RGBQUAD>^ dstcolors,
    bool ignore_alpha,
    bool swap
)

Parameters

srccolors
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
Array of colors to be used as the mapping source.
dstcolors
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
Array of colors to be used as the mapping destination.
ignore_alpha
Type: System..::.Boolean
If true, 32-bit images and colors are treated as 24-bit.
swap
Type: System..::.Boolean
If true, source and destination colors are swapped, that is, each destination color is also mapped to the corresponding source color.

Return Value

The total number of pixels changed.

Exceptions

Exception | Condition
System..::.ArgumentNullException | srccolors or dstcolors is a null reference.
System..::.ArgumentException | srccolors has a different length than dstcolors.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


ApplyPaletteIndexMapping Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.ApplyPaletteIndexMapping Method
FreeImageBitmap Class See Also Send Feedback
Applies palette index mapping for one or several indices on a 1-, 4- or 8-bit palletized image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint ApplyPaletteIndexMapping(
    byte[] srcindices,
    byte[] dstindices,
    uint count,
    bool swap
)
Visual Basic (Declaration)
Public Function ApplyPaletteIndexMapping ( _
    srcindices As Byte(), _
    dstindices As Byte(), _
    count As UInteger, _
    swap As Boolean _
) As UInteger
Visual C++
public:
unsigned int ApplyPaletteIndexMapping(
    array<unsigned char>^ srcindices,
    array<unsigned char>^ dstindices,
    unsigned int count,
    bool swap
)

Parameters

srcindices
Type: array< System..::.Byte >[]()[]
Array of palette indices to be used as the mapping source.
dstindices
Type: array< System..::.Byte >[]()[]
Array of palette indices to be used as the mapping destination.
count
Type: System..::.UInt32
The number of palette indices to be mapped. This is the size of both srcindices and dstindices
swap
Type: System..::.Boolean
If true, source and destination palette indices are swapped, that is, each destination index is also mapped to the corresponding source index.

Return Value

The total number of pixels changed.

Exceptions

Exception | Condition
System..::.ArgumentNullException | srccolors or dstcolors is a null reference.
System..::.ArgumentException | srccolors has a different length than dstcolors.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Clone Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Clone Method
FreeImageBitmap Class See Also Send Feedback
Creates a deep copy of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

A deep copy of this FreeImageBitmap.

Implements

ICloneable..::.Clone()()()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


CloneMetadataFrom Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.CloneMetadataFrom Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
CloneMetadataFrom(FreeImageBitmap) | Copies the metadata from another FreeImageBitmap.
CloneMetadataFrom(FreeImageBitmap, FREE_IMAGE_METADATA_COPY) | Copies the metadata from another FreeImageBitmap using the provided options.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


CloneMetadataFrom Method (FreeImageBitmap)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.CloneMetadataFrom Method (FreeImageBitmap)
FreeImageBitmap Class See Also Send Feedback
Copies the metadata from another FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CloneMetadataFrom(
    FreeImageBitmap bitmap
)
Visual Basic (Declaration)
Public Sub CloneMetadataFrom ( _
    bitmap As FreeImageBitmap _
)
Visual C++
public:
void CloneMetadataFrom(
    FreeImageBitmap^ bitmap
)

Parameters

bitmap
Type: FreeImageAPI..::.FreeImageBitmap
The bitmap to read the metadata from.

Exceptions

Exception | Condition
System..::.ArgumentNullException | bitmap is a null reference.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
CloneMetadataFrom Overload


CloneMetadataFrom Method (FreeImageBitmap, FREE_IMAGE_METADATA_COPY)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.CloneMetadataFrom Method (FreeImageBitmap, FREE_IMAGE_METADATA_COPY)
FreeImageBitmap Class See Also Send Feedback
Copies the metadata from another FreeImageBitmap using the provided options.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CloneMetadataFrom(
    FreeImageBitmap bitmap,
    FREE_IMAGE_METADATA_COPY flags
)
Visual Basic (Declaration)
Public Sub CloneMetadataFrom ( _
    bitmap As FreeImageBitmap, _
    flags As FREE_IMAGE_METADATA_COPY _
)
Visual C++
public:
void CloneMetadataFrom(
    FreeImageBitmap^ bitmap,
    FREE_IMAGE_METADATA_COPY flags
)

Parameters

bitmap
Type: FreeImageAPI..::.FreeImageBitmap
The bitmap to read the metadata from.
flags
Type: FreeImageAPI..::.FREE_IMAGE_METADATA_COPY
Specifies the way the metadata is copied.

Exceptions

Exception | Condition
System..::.ArgumentNullException | bitmap is a null reference.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
CloneMetadataFrom Overload


Composite Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Composite Method
FreeImageBitmap Class See Also Send Feedback
This method composite a transparent foreground image against a single background color or against a background image. In case useBitmapBackground is false and applicationBackground and bitmapBackGround are null, a checkerboard will be used as background.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Composite(
    bool useBitmapBackground,
    Nullable<Color> applicationBackground,
    FreeImageBitmap bitmapBackGround
)
Visual Basic (Declaration)
Public Function Composite ( _
    useBitmapBackground As Boolean, _
    applicationBackground As Nullable(Of Color), _
    bitmapBackGround As FreeImageBitmap _
) As Boolean
Visual C++
public:
bool Composite(
    bool useBitmapBackground,
    Nullable<Color> applicationBackground,
    FreeImageBitmap^ bitmapBackGround
)

Parameters

useBitmapBackground
Type: System..::.Boolean
When true the background of this instance is used if it contains one.
applicationBackground
Type: System..::.Nullable <(Of <( Color >)>)
Backgroundcolor used in case useBitmapBackground is false and applicationBackground is not null.
bitmapBackGround
Type: FreeImageAPI..::.FreeImageBitmap
Background used in case useBitmapBackground is false and applicationBackground is a null reference.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


ConvertColorDepth Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.ConvertColorDepth Method
FreeImageBitmap Class See Also Send Feedback
Converts this FreeImageBitmap into a different color depth. The parameter bpp specifies color depth, greyscale conversion and palette reorder.

Adding the FICD_FORCE_GREYSCALE flag will first perform a convesion to greyscale. This can be done with any target color depth.

Adding the FICD_REORDER_PALETTE flag will allow the algorithm to reorder the palette. This operation will not be performed to non-greyscale images to prevent data loss by mistake.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool ConvertColorDepth(
    FREE_IMAGE_COLOR_DEPTH bpp
)
Visual Basic (Declaration)
Public Function ConvertColorDepth ( _
    bpp As FREE_IMAGE_COLOR_DEPTH _
) As Boolean
Visual C++
public:
bool ConvertColorDepth(
    FREE_IMAGE_COLOR_DEPTH bpp
)

Parameters

bpp
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
A bitfield containing information about the conversion to perform.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


ConvertType Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.ConvertType Method
FreeImageBitmap Class See Also Send Feedback
Converts this FreeImageBitmap FREE_IMAGE_TYPE to type initializing a new instance. In case source and destination type are the same, the operation fails. An error message can be catched using the 'Message' event.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool ConvertType(
    FREE_IMAGE_TYPE type,
    bool scaleLinear
)
Visual Basic (Declaration)
Public Function ConvertType ( _
    type As FREE_IMAGE_TYPE, _
    scaleLinear As Boolean _
) As Boolean
Visual C++
public:
bool ConvertType(
    FREE_IMAGE_TYPE type,
    bool scaleLinear
)

Parameters

type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
Destination type.
scaleLinear
Type: System..::.Boolean
True to scale linear, else false.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Copy Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.Copy Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
Copy(Rectangle) | Copy a sub part of this FreeImageBitmap.
Copy(Int32, Int32, Int32, Int32) | Copy a sub part of this FreeImageBitmap.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


Copy Method (Rectangle)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Copy Method (Rectangle)
FreeImageBitmap Class See Also Send Feedback
Copy a sub part of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap Copy(
    Rectangle rect
)
Visual Basic (Declaration)
Public Function Copy ( _
    rect As Rectangle _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ Copy(
    Rectangle rect
)

Parameters

rect
Type: System.Drawing..::.Rectangle
The subpart to copy.

Return Value

The sub part in a new instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Copy Overload


Copy Method (Int32, Int32, Int32, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Copy Method (Int32, Int32, Int32, Int32)
FreeImageBitmap Class See Also Send Feedback
Copy a sub part of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap Copy(
    int left,
    int top,
    int right,
    int bottom
)
Visual Basic (Declaration)
Public Function Copy ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ Copy(
    int left,
    int top,
    int right,
    int bottom
)

Parameters

left
Type: System..::.Int32
Specifies the left position of the cropped rectangle.
top
Type: System..::.Int32
Specifies the top position of the cropped rectangle.
right
Type: System..::.Int32
Specifies the right position of the cropped rectangle.
bottom
Type: System..::.Int32
Specifies the bottom position of the cropped rectangle.

Return Value

The sub part in a new instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Copy Overload


CreateICCProfile Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.CreateICCProfile Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
CreateICCProfile(array<Byte>[]()[]) | Creates a new ICC-Profile.
CreateICCProfile(array<Byte>[]()[], Int32) | Creates a new ICC-Profile.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


CreateICCProfile Method (Byte[])

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.CreateICCProfile Method (array<Byte>[]()[])
FreeImageBitmap Class See Also Send Feedback
Creates a new ICC-Profile.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIICCPROFILE CreateICCProfile(
    byte[] data
)
Visual Basic (Declaration)
Public Function CreateICCProfile ( _
    data As Byte() _
) As FIICCPROFILE
Visual C++
public:
FIICCPROFILE CreateICCProfile(
    array<unsigned char>^ data
)

Parameters

data
Type: array< System..::.Byte >[]()[]
The data of the new ICC-Profile.

Return Value

The new ICC-Profile of the bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | data is a null reference.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
CreateICCProfile Overload


CreateICCProfile Method (Byte[], Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.CreateICCProfile Method (array<Byte>[]()[], Int32)
FreeImageBitmap Class See Also Send Feedback
Creates a new ICC-Profile.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIICCPROFILE CreateICCProfile(
    byte[] data,
    int size
)
Visual Basic (Declaration)
Public Function CreateICCProfile ( _
    data As Byte(), _
    size As Integer _
) As FIICCPROFILE
Visual C++
public:
FIICCPROFILE CreateICCProfile(
    array<unsigned char>^ data,
    int size
)

Parameters

data
Type: array< System..::.Byte >[]()[]
The data of the new ICC-Profile.
size
Type: System..::.Int32
The number of bytes of data to use.

Return Value

The new ICC-Profile of the bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | data is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
CreateICCProfile Overload


CreateNewPropertyItem Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.CreateNewPropertyItem Method
FreeImageBitmap Class See Also Send Feedback
Returns a new instance of the PropertyItem class which has no public accessible constructor.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static PropertyItem CreateNewPropertyItem()
Visual Basic (Declaration)
Public Shared Function CreateNewPropertyItem As PropertyItem
Visual C++
public:
static PropertyItem^ CreateNewPropertyItem()

Return Value

A new instace of PropertyItem.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Dispose Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.Dispose Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Dispose(Boolean) | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


Dispose Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Dispose Method
FreeImageBitmap Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Dispose Overload


Dispose Method (Boolean)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Dispose Method (Boolean)
FreeImageBitmap Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
If true managed ressources are released.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Dispose Overload


EnlargeCanvas Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.EnlargeCanvas Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
EnlargeCanvas<(Of <(T>)>)(Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>)) | Enlarges or shrinks this FreeImageBitmap selectively per side and fills newly added areas with the specified background color. See EnlargeCanvas<(Of <(T>)>)(FIBITMAP, Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS) for further details.
EnlargeCanvas<(Of <(T>)>)(Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS) | Enlarges or shrinks this FreeImageBitmap selectively per side and fills newly added areas with the specified background color. See EnlargeCanvas<(Of <(T>)>)(FIBITMAP, Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS) for further details.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


EnlargeCanvas(T) Method (Int32, Int32, Int32, Int32, Nullable(T))

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.EnlargeCanvas<(Of <(T>)>) Method (Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>))
FreeImageBitmap Class See Also Send Feedback
Enlarges or shrinks this FreeImageBitmap selectively per side and fills newly added areas with the specified background color. See EnlargeCanvas<(Of <(T>)>)(FIBITMAP, Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS) for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool EnlargeCanvas<T>(
    int left,
    int top,
    int right,
    int bottom,
    Nullable<T> color
)
where T : struct, new()
Visual Basic (Declaration)
Public Function EnlargeCanvas(Of T As {Structure, New}) ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer, _
    color As Nullable(Of T) _
) As Boolean
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
bool EnlargeCanvas(
    int left,
    int top,
    int right,
    int bottom,
    Nullable<T> color
)

Parameters

left
Type: System..::.Int32
The number of pixels, the image should be enlarged on its left side. Negative values shrink the image on its left side.
top
Type: System..::.Int32
The number of pixels, the image should be enlarged on its top side. Negative values shrink the image on its top side.
right
Type: System..::.Int32
The number of pixels, the image should be enlarged on its right side. Negative values shrink the image on its right side.
bottom
Type: System..::.Int32
The number of pixels, the image should be enlarged on its bottom side. Negative values shrink the image on its bottom side.
color
Type: System..::.Nullable <(Of <(T>)>)
The color, the enlarged sides of the image should be filled with.

Type Parameters

T
The type of the specified color.

Return Value

true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
EnlargeCanvas Overload


EnlargeCanvas(T) Method (Int32, Int32, Int32, Int32, Nullable(T), FREE_IMAGE_COLOR_OPTIONS)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.EnlargeCanvas<(Of <(T>)>) Method (Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS)
FreeImageBitmap Class See Also Send Feedback
Enlarges or shrinks this FreeImageBitmap selectively per side and fills newly added areas with the specified background color. See EnlargeCanvas<(Of <(T>)>)(FIBITMAP, Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS) for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool EnlargeCanvas<T>(
    int left,
    int top,
    int right,
    int bottom,
    Nullable<T> color,
    FREE_IMAGE_COLOR_OPTIONS options
)
where T : struct, new()
Visual Basic (Declaration)
Public Function EnlargeCanvas(Of T As {Structure, New}) ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer, _
    color As Nullable(Of T), _
    options As FREE_IMAGE_COLOR_OPTIONS _
) As Boolean
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
bool EnlargeCanvas(
    int left,
    int top,
    int right,
    int bottom,
    Nullable<T> color,
    FREE_IMAGE_COLOR_OPTIONS options
)

Parameters

left
Type: System..::.Int32
The number of pixels, the image should be enlarged on its left side. Negative values shrink the image on its left side.
top
Type: System..::.Int32
The number of pixels, the image should be enlarged on its top side. Negative values shrink the image on its top side.
right
Type: System..::.Int32
The number of pixels, the image should be enlarged on its right side. Negative values shrink the image on its right side.
bottom
Type: System..::.Int32
The number of pixels, the image should be enlarged on its bottom side. Negative values shrink the image on its bottom side.
color
Type: System..::.Nullable <(Of <(T>)>)
The color, the enlarged sides of the image should be filled with.
options
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_OPTIONS
Options that affect the color search process for palletized images.

Type Parameters

T
The type of the specified color.

Return Value

true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
EnlargeCanvas Overload


Equality Operator

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Equality Operator
FreeImageBitmap Class See Also Send Feedback
Determines whether two specified FreeImageBitmap objects have the same value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    FreeImageBitmap left,
    FreeImageBitmap right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As FreeImageBitmap, _
    right As FreeImageBitmap _
) As Boolean
Visual C++
public:
static bool operator ==(
    FreeImageBitmap^ left,
    FreeImageBitmap^ right
)

Parameters

left
Type: FreeImageAPI..::.FreeImageBitmap
A FreeImageBitmap or a null reference (Nothing in Visual Basic).
right
Type: FreeImageAPI..::.FreeImageBitmap
A FreeImageBitmap or a null reference (Nothing in Visual Basic).

Return Value

true if the value of left is the same as the value of right; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Equals Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Equals Method
FreeImageBitmap Class See Also Send Feedback
Determines whether this and the specified instances are the same.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if this instance is the same obj or if both are null references; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Explicit Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.Explicit Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
Explicit(FreeImageBitmap) | Converts a FreeImageBitmap instance to a Bitmap instance.
Explicit(Bitmap) | Converts a Bitmap instance to a FreeImageBitmap instance.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


Explicit Operator

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Explicit Operator
FreeImageBitmap Class See Also Send Feedback
Converts a FreeImageBitmap instance to a Bitmap instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator Bitmap (
    FreeImageBitmap value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As FreeImageBitmap _
) As Bitmap
Visual C++
static explicit operator Bitmap^ (
    FreeImageBitmap^ value
)

Parameters

value
Type: FreeImageAPI..::.FreeImageBitmap
A FreeImageBitmap instance.

Return Value

A new instance of Bitmap initialized to value.

Remarks

The explicit conversion from FreeImageBitmap into Bitmap allows to create an instance on the fly and use it as if was a Bitmap. This way it can be directly used with a PixtureBox for example without having to call any conversion operations.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Explicit Overload


Explicit Operator

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Explicit Operator
FreeImageBitmap Class See Also Send Feedback
Converts a Bitmap instance to a FreeImageBitmap instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static explicit operator FreeImageBitmap (
    Bitmap value
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    value As Bitmap _
) As FreeImageBitmap
Visual C++
static explicit operator FreeImageBitmap^ (
    Bitmap^ value
)

Parameters

value
Type: System.Drawing..::.Bitmap
A Bitmap instance.

Return Value

A new instance of FreeImageBitmap initialized to value.

Remarks

The explicit conversion from Bitmap into FreeImageBitmap allows to create an instance on the fly to perform image processing operations and converting it back.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Explicit Overload


FillBackground Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.FillBackground Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
FillBackground<(Of <(T>)>)(T) | Sets all pixels of this FreeImageBitmap to the specified color. See FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS) for further details.
FillBackground<(Of <(T>)>)(T, FREE_IMAGE_COLOR_OPTIONS) | Sets all pixels of this FreeImageBitmap to the specified color. See FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS) for further details.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


FillBackground(T) Method (T)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FillBackground<(Of <(T>)>) Method (T)
FreeImageBitmap Class See Also Send Feedback
Sets all pixels of this FreeImageBitmap to the specified color. See FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS) for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool FillBackground<T>(
    T color
)
where T : struct, new()
Visual Basic (Declaration)
Public Function FillBackground(Of T As {Structure, New}) ( _
    color As T _
) As Boolean
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
bool FillBackground(
    T color
)

Parameters

color
Type: T
The color to fill this FreeImageBitmap with.

Type Parameters

T
The type of the specified color.

Return Value

true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FillBackground Overload


FillBackground(T) Method (T, FREE_IMAGE_COLOR_OPTIONS)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FillBackground<(Of <(T>)>) Method (T, FREE_IMAGE_COLOR_OPTIONS)
FreeImageBitmap Class See Also Send Feedback
Sets all pixels of this FreeImageBitmap to the specified color. See FillBackground<(Of <(T>)>)(FIBITMAP, T, FREE_IMAGE_COLOR_OPTIONS) for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool FillBackground<T>(
    T color,
    FREE_IMAGE_COLOR_OPTIONS options
)
where T : struct, new()
Visual Basic (Declaration)
Public Function FillBackground(Of T As {Structure, New}) ( _
    color As T, _
    options As FREE_IMAGE_COLOR_OPTIONS _
) As Boolean
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
bool FillBackground(
    T color,
    FREE_IMAGE_COLOR_OPTIONS options
)

Parameters

color
Type: T
The color to fill this FreeImageBitmap with.
options
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_OPTIONS
Options that affect the color search process for palletized images.

Type Parameters

T
The type of the specified color.

Return Value

true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FillBackground Overload


Finalize Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Finalize Method
FreeImageBitmap Class See Also Send Feedback
Frees all managed and unmanaged ressources.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


FreeHbitmap Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FreeHbitmap Method
FreeImageBitmap Class See Also Send Feedback
Frees a bitmap handle.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool FreeHbitmap(
    IntPtr hbitmap
)
Visual Basic (Declaration)
Public Shared Function FreeHbitmap ( _
    hbitmap As IntPtr _
) As Boolean
Visual C++
public:
static bool FreeHbitmap(
    IntPtr hbitmap
)

Parameters

hbitmap
Type: System..::.IntPtr
Handle to a bitmap.

Return Value

true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


FromFile Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromFile Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
FromFile(String) | Creates a FreeImageBitmap from the specified file.
FromFile(String, Boolean) | Creates a FreeImageBitmap from the specified file using embedded color management information in that file.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


FromFile Method (String)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromFile Method (String)
FreeImageBitmap Class See Also Send Feedback
Creates a FreeImageBitmap from the specified file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImageBitmap FromFile(
    string filename
)
Visual Basic (Declaration)
Public Shared Function FromFile ( _
    filename As String _
) As FreeImageBitmap
Visual C++
public:
static FreeImageBitmap^ FromFile(
    String^ filename
)

Parameters

filename
Type: System..::.String
A string that contains the name of the file from which to create the FreeImageBitmap.

Return Value

The FreeImageBitmap this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FromFile Overload


FromFile Method (String, Boolean)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromFile Method (String, Boolean)
FreeImageBitmap Class See Also Send Feedback
Creates a FreeImageBitmap from the specified file using embedded color management information in that file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImageBitmap FromFile(
    string filename,
    bool useEmbeddedColorManagement
)
Visual Basic (Declaration)
Public Shared Function FromFile ( _
    filename As String, _
    useEmbeddedColorManagement As Boolean _
) As FreeImageBitmap
Visual C++
public:
static FreeImageBitmap^ FromFile(
    String^ filename,
    bool useEmbeddedColorManagement
)

Parameters

filename
Type: System..::.String
A string that contains the name of the file from which to create the FreeImageBitmap.
useEmbeddedColorManagement
Type: System..::.Boolean
Ignored.

Return Value

The FreeImageBitmap this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FromFile Overload


FromHbitmap Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromHbitmap Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
FromHbitmap(IntPtr) | Creates a FreeImageBitmap from a handle to a GDI bitmap.
FromHbitmap(IntPtr, IntPtr) | Creates a FreeImageBitmap from a handle to a GDI bitmap and a handle to a GDI palette.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


FromHbitmap Method (IntPtr)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromHbitmap Method (IntPtr)
FreeImageBitmap Class See Also Send Feedback
Creates a FreeImageBitmap from a handle to a GDI bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImageBitmap FromHbitmap(
    IntPtr hbitmap
)
Visual Basic (Declaration)
Public Shared Function FromHbitmap ( _
    hbitmap As IntPtr _
) As FreeImageBitmap
Visual C++
public:
static FreeImageBitmap^ FromHbitmap(
    IntPtr hbitmap
)

Parameters

hbitmap
Type: System..::.IntPtr
The GDI bitmap handle from which to create the FreeImageBitmap.

Return Value

The FreeImageBitmap this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FromHbitmap Overload


FromHbitmap Method (IntPtr, IntPtr)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromHbitmap Method (IntPtr, IntPtr)
FreeImageBitmap Class See Also Send Feedback
Creates a FreeImageBitmap from a handle to a GDI bitmap and a handle to a GDI palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImageBitmap FromHbitmap(
    IntPtr hbitmap,
    IntPtr hpalette
)
Visual Basic (Declaration)
Public Shared Function FromHbitmap ( _
    hbitmap As IntPtr, _
    hpalette As IntPtr _
) As FreeImageBitmap
Visual C++
public:
static FreeImageBitmap^ FromHbitmap(
    IntPtr hbitmap,
    IntPtr hpalette
)

Parameters

hbitmap
Type: System..::.IntPtr
The GDI bitmap handle from which to create the FreeImageBitmap.
hpalette
Type: System..::.IntPtr
Ignored.

Return Value

The FreeImageBitmap this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FromHbitmap Overload


FromHicon Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromHicon Method
FreeImageBitmap Class See Also Send Feedback
Creates a FreeImageBitmap from a Windows handle to an icon.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImageBitmap FromHicon(
    IntPtr hicon
)
Visual Basic (Declaration)
Public Shared Function FromHicon ( _
    hicon As IntPtr _
) As FreeImageBitmap
Visual C++
public:
static FreeImageBitmap^ FromHicon(
    IntPtr hicon
)

Parameters

hicon
Type: System..::.IntPtr
A handle to an icon.

Return Value

The FreeImageBitmap that this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


FromResource Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromResource Method
FreeImageBitmap Class See Also Send Feedback
Creates a FreeImageBitmap from the specified Windows resource.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImageBitmap FromResource(
    IntPtr hinstance,
    string bitmapName
)
Visual Basic (Declaration)
Public Shared Function FromResource ( _
    hinstance As IntPtr, _
    bitmapName As String _
) As FreeImageBitmap
Visual C++
public:
static FreeImageBitmap^ FromResource(
    IntPtr hinstance,
    String^ bitmapName
)

Parameters

hinstance
Type: System..::.IntPtr
A handle to an instance of the executable file that contains the resource.
bitmapName
Type: System..::.String
A string containing the name of the resource bitmap.

Return Value

The FreeImageBitmap that this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


FromStream Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromStream Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
FromStream(Stream) | Creates a FreeImageBitmap from the specified data stream.
FromStream(Stream, Boolean) | Creates a FreeImageBitmap from the specified data stream.
FromStream(Stream, Boolean, Boolean) | Creates a FreeImageBitmap from the specified data stream.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


FromStream Method (Stream)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromStream Method (Stream)
FreeImageBitmap Class See Also Send Feedback
Creates a FreeImageBitmap from the specified data stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImageBitmap FromStream(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function FromStream ( _
    stream As Stream _
) As FreeImageBitmap
Visual C++
public:
static FreeImageBitmap^ FromStream(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
A Stream that contains the data for this FreeImageBitmap.

Return Value

The FreeImageBitmap this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FromStream Overload


FromStream Method (Stream, Boolean)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromStream Method (Stream, Boolean)
FreeImageBitmap Class See Also Send Feedback
Creates a FreeImageBitmap from the specified data stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImageBitmap FromStream(
    Stream stream,
    bool useEmbeddedColorManagement
)
Visual Basic (Declaration)
Public Shared Function FromStream ( _
    stream As Stream, _
    useEmbeddedColorManagement As Boolean _
) As FreeImageBitmap
Visual C++
public:
static FreeImageBitmap^ FromStream(
    Stream^ stream,
    bool useEmbeddedColorManagement
)

Parameters

stream
Type: System.IO..::.Stream
A Stream that contains the data for this FreeImageBitmap.
useEmbeddedColorManagement
Type: System..::.Boolean
Ignored.

Return Value

The FreeImageBitmap this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FromStream Overload


FromStream Method (Stream, Boolean, Boolean)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FromStream Method (Stream, Boolean, Boolean)
FreeImageBitmap Class See Also Send Feedback
Creates a FreeImageBitmap from the specified data stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImageBitmap FromStream(
    Stream stream,
    bool useEmbeddedColorManagement,
    bool validateImageData
)
Visual Basic (Declaration)
Public Shared Function FromStream ( _
    stream As Stream, _
    useEmbeddedColorManagement As Boolean, _
    validateImageData As Boolean _
) As FreeImageBitmap
Visual C++
public:
static FreeImageBitmap^ FromStream(
    Stream^ stream,
    bool useEmbeddedColorManagement,
    bool validateImageData
)

Parameters

stream
Type: System.IO..::.Stream
A Stream that contains the data for this FreeImageBitmap.
useEmbeddedColorManagement
Type: System..::.Boolean
Ignored.
validateImageData
Type: System..::.Boolean
Ignored.

Return Value

The FreeImageBitmap this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
FromStream Overload


GetAdjustColorsLookupTable Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetAdjustColorsLookupTable Method
FreeImageBitmap Class See Also Send Feedback
Creates a lookup table to be used with AdjustCurve() which may adjusts brightness and contrast, correct gamma and invert the image with a single call to AdjustCurve().

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int GetAdjustColorsLookupTable(
    byte[] lookUpTable,
    double brightness,
    double contrast,
    double gamma,
    bool invert
)
Visual Basic (Declaration)
Public Shared Function GetAdjustColorsLookupTable ( _
    lookUpTable As Byte(), _
    brightness As Double, _
    contrast As Double, _
    gamma As Double, _
    invert As Boolean _
) As Integer
Visual C++
public:
static int GetAdjustColorsLookupTable(
    array<unsigned char>^ lookUpTable,
    double brightness,
    double contrast,
    double gamma,
    bool invert
)

Parameters

lookUpTable
Type: array< System..::.Byte >[]()[]
Output lookup table to be used with AdjustCurve(). The size of lookUpTable is assumed to be 256.
brightness
Type: System..::.Double
Percentage brightness value where -100 <= brightness <= 100.

A value of 0 means no change, less than 0 will make the image darker and greater than 0 will make the image brighter.

contrast
Type: System..::.Double
Percentage contrast value where -100 <= contrast <= 100.

A value of 0 means no change, less than 0 will decrease the contrast and greater than 0 will increase the contrast of the image.

gamma
Type: System..::.Double
Gamma value to be used for gamma correction.

A value of 1.0 leaves the image alone, less than one darkens it, and greater than one lightens it.

invert
Type: System..::.Boolean
If set to true, the image will be inverted.

Return Value

The number of adjustments applied to the resulting lookup table compared to a blind lookup table.

Exceptions

Exception | Condition
System..::.ArgumentNullException | lookUpTable is null.
System..::.ArgumentException | lookUpTable.Length is not 256.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetBounds Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetBounds Method
FreeImageBitmap Class See Also Send Feedback
Gets the bounds of this FreeImageBitmap in the specified unit.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public RectangleF GetBounds(
    ref GraphicsUnit pageUnit
)
Visual Basic (Declaration)
Public Function GetBounds ( _
    ByRef pageUnit As GraphicsUnit _
) As RectangleF
Visual C++
public:
RectangleF GetBounds(
    GraphicsUnit% pageUnit
)

Parameters

pageUnit
Type: System.Drawing..::.GraphicsUnit %
One of the GraphicsUnit values indicating the unit of measure for the bounding rectangle.

Return Value

The RectangleF that represents the bounds of this FreeImageBitmap, in the specified unit.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetChannel Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetChannel Method
FreeImageBitmap Class See Also Send Feedback
Retrieves the red, green, blue or alpha channel of a 24- or 32-bit image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetChannel(
    FREE_IMAGE_COLOR_CHANNEL channel
)
Visual Basic (Declaration)
Public Function GetChannel ( _
    channel As FREE_IMAGE_COLOR_CHANNEL _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetChannel(
    FREE_IMAGE_COLOR_CHANNEL channel
)

Parameters

channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
The color channel to extract.

Return Value

The color channel in a new instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetColorConvertedInstance Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetColorConvertedInstance Method
FreeImageBitmap Class See Also Send Feedback
Converts this FreeImageBitmap into a different color depth initializing a new instance. The parameter bpp specifies color depth, greyscale conversion and palette reorder.

Adding the FICD_FORCE_GREYSCALE flag will first perform a convesion to greyscale. This can be done with any target color depth.

Adding the FICD_REORDER_PALETTE flag will allow the algorithm to reorder the palette. This operation will not be performed to non-greyscale images to prevent data loss by mistake.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetColorConvertedInstance(
    FREE_IMAGE_COLOR_DEPTH bpp
)
Visual Basic (Declaration)
Public Function GetColorConvertedInstance ( _
    bpp As FREE_IMAGE_COLOR_DEPTH _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetColorConvertedInstance(
    FREE_IMAGE_COLOR_DEPTH bpp
)

Parameters

bpp
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_DEPTH
A bitfield containing information about the conversion to perform.

Return Value

The converted instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetComplexChannel Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetComplexChannel Method
FreeImageBitmap Class See Also Send Feedback
Retrieves the real part, imaginary part, magnitude or phase of a complex image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetComplexChannel(
    FREE_IMAGE_COLOR_CHANNEL channel
)
Visual Basic (Declaration)
Public Function GetComplexChannel ( _
    channel As FREE_IMAGE_COLOR_CHANNEL _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetComplexChannel(
    FREE_IMAGE_COLOR_CHANNEL channel
)

Parameters

channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
The color channel to extract.

Return Value

The color channel in a new instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetEnlargedInstance Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetEnlargedInstance Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
GetEnlargedInstance<(Of <(T>)>)(Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>)) | Enlarges or shrinks this FreeImageBitmap selectively per side and fills newly added areas with the specified background color returning a new instance. See EnlargeCanvas<(Of <(T>)>)(FIBITMAP, Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS) for further details.
GetEnlargedInstance<(Of <(T>)>)(Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS) | Enlarges or shrinks this FreeImageBitmap selectively per side and fills newly added areas with the specified background color returning a new instance. See EnlargeCanvas<(Of <(T>)>)(FIBITMAP, Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS) for further details.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


GetEnlargedInstance(T) Method (Int32, Int32, Int32, Int32, Nullable(T))

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetEnlargedInstance<(Of <(T>)>) Method (Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>))
FreeImageBitmap Class See Also Send Feedback
Enlarges or shrinks this FreeImageBitmap selectively per side and fills newly added areas with the specified background color returning a new instance. See EnlargeCanvas<(Of <(T>)>)(FIBITMAP, Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS) for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetEnlargedInstance<T>(
    int left,
    int top,
    int right,
    int bottom,
    Nullable<T> color
)
where T : struct, new()
Visual Basic (Declaration)
Public Function GetEnlargedInstance(Of T As {Structure, New}) ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer, _
    color As Nullable(Of T) _
) As FreeImageBitmap
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
FreeImageBitmap^ GetEnlargedInstance(
    int left,
    int top,
    int right,
    int bottom,
    Nullable<T> color
)

Parameters

left
Type: System..::.Int32
The number of pixels, the image should be enlarged on its left side. Negative values shrink the image on its left side.
top
Type: System..::.Int32
The number of pixels, the image should be enlarged on its top side. Negative values shrink the image on its top side.
right
Type: System..::.Int32
The number of pixels, the image should be enlarged on its right side. Negative values shrink the image on its right side.
bottom
Type: System..::.Int32
The number of pixels, the image should be enlarged on its bottom side. Negative values shrink the image on its bottom side.
color
Type: System..::.Nullable <(Of <(T>)>)
The color, the enlarged sides of the image should be filled with.

Type Parameters

T
The type of the specified color.

Return Value

The enlarged instance.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetEnlargedInstance Overload


GetEnlargedInstance(T) Method (Int32, Int32, Int32, Int32, Nullable(T), FREE_IMAGE_COLOR_OPTIONS)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetEnlargedInstance<(Of <(T>)>) Method (Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS)
FreeImageBitmap Class See Also Send Feedback
Enlarges or shrinks this FreeImageBitmap selectively per side and fills newly added areas with the specified background color returning a new instance. See EnlargeCanvas<(Of <(T>)>)(FIBITMAP, Int32, Int32, Int32, Int32, Nullable<(Of <(T>)>), FREE_IMAGE_COLOR_OPTIONS) for further details.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetEnlargedInstance<T>(
    int left,
    int top,
    int right,
    int bottom,
    Nullable<T> color,
    FREE_IMAGE_COLOR_OPTIONS options
)
where T : struct, new()
Visual Basic (Declaration)
Public Function GetEnlargedInstance(Of T As {Structure, New}) ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer, _
    color As Nullable(Of T), _
    options As FREE_IMAGE_COLOR_OPTIONS _
) As FreeImageBitmap
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
FreeImageBitmap^ GetEnlargedInstance(
    int left,
    int top,
    int right,
    int bottom,
    Nullable<T> color,
    FREE_IMAGE_COLOR_OPTIONS options
)

Parameters

left
Type: System..::.Int32
The number of pixels, the image should be enlarged on its left side. Negative values shrink the image on its left side.
top
Type: System..::.Int32
The number of pixels, the image should be enlarged on its top side. Negative values shrink the image on its top side.
right
Type: System..::.Int32
The number of pixels, the image should be enlarged on its right side. Negative values shrink the image on its right side.
bottom
Type: System..::.Int32
The number of pixels, the image should be enlarged on its bottom side. Negative values shrink the image on its bottom side.
color
Type: System..::.Nullable <(Of <(T>)>)
The color, the enlarged sides of the image should be filled with.
options
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_OPTIONS
Options that affect the color search process for palletized images.

Type Parameters

T
The type of the specified color.

Return Value

The enlarged instance.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetEnlargedInstance Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetHashCode Method
FreeImageBitmap Class See Also Send Feedback
Returns a hash code for this FreeImageBitmap structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this FreeImageBitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetHbitmap Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetHbitmap Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
GetHbitmap()()() | Creates a GDI bitmap object from this FreeImageBitmap.
GetHbitmap(Color) | Creates a GDI bitmap object from this FreeImageBitmap.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


GetHbitmap Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetHbitmap Method
FreeImageBitmap Class See Also Send Feedback
Creates a GDI bitmap object from this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IntPtr GetHbitmap()
Visual Basic (Declaration)
Public Function GetHbitmap As IntPtr
Visual C++
public:
IntPtr GetHbitmap()

Return Value

A handle to the GDI bitmap object that this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetHbitmap Overload


GetHbitmap Method (Color)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetHbitmap Method (Color)
FreeImageBitmap Class See Also Send Feedback
Creates a GDI bitmap object from this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IntPtr GetHbitmap(
    Color background
)
Visual Basic (Declaration)
Public Function GetHbitmap ( _
    background As Color _
) As IntPtr
Visual C++
public:
IntPtr GetHbitmap(
    Color background
)

Parameters

background
Type: System.Drawing..::.Color
A Color structure that specifies the background color. This parameter is ignored if the bitmap is totally opaque.

Return Value

A handle to the GDI bitmap object that this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetHbitmap Overload


GetHbitmapForDevice Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetHbitmapForDevice Method
FreeImageBitmap Class See Also Send Feedback
Creates a GDI bitmap object from this FreeImageBitmap with the same color depth as the primary device.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IntPtr GetHbitmapForDevice()
Visual Basic (Declaration)
Public Function GetHbitmapForDevice As IntPtr
Visual C++
public:
IntPtr GetHbitmapForDevice()

Return Value

A handle to the GDI bitmap object that this method creates.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetHicon Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetHicon Method
FreeImageBitmap Class See Also Send Feedback
Returns the handle to an icon.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IntPtr GetHicon()
Visual Basic (Declaration)
Public Function GetHicon As IntPtr
Visual C++
public:
IntPtr GetHicon()

Return Value

A Windows handle to an icon with the same image as this FreeImageBitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetHistogram Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetHistogram Method
FreeImageBitmap Class See Also Send Feedback
Computes the image histogram.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool GetHistogram(
    FREE_IMAGE_COLOR_CHANNEL channel,
    out int[] histogram
)
Visual Basic (Declaration)
Public Function GetHistogram ( _
    channel As FREE_IMAGE_COLOR_CHANNEL, _
    <OutAttribute> ByRef histogram As Integer() _
) As Boolean
Visual C++
public:
bool GetHistogram(
    FREE_IMAGE_COLOR_CHANNEL channel,
    [OutAttribute] array<int>^% histogram
)

Parameters

channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
Channel to compute from.
histogram
Type: array< System..::.Int32 >[]()[] %
Array of integers containing the histogram.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetPixel Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetPixel Method
FreeImageBitmap Class See Also Send Feedback
Gets the Color of the specified pixel in this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Color GetPixel(
    int x,
    int y
)
Visual Basic (Declaration)
Public Function GetPixel ( _
    x As Integer, _
    y As Integer _
) As Color
Visual C++
public:
Color GetPixel(
    int x,
    int y
)

Parameters

x
Type: System..::.Int32
The x-coordinate of the pixel to retrieve.
y
Type: System..::.Int32
The y-coordinate of the pixel to retrieve.

Return Value

A Color structure that represents the color of the specified pixel.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.NotSupportedException | The type of this bitmap is not supported.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetPixelFormatSize Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetPixelFormatSize Method
FreeImageBitmap Class See Also Send Feedback
Returns the color depth, in number of bits per pixel, of the specified pixel format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int GetPixelFormatSize(
    PixelFormat pixfmt
)
Visual Basic (Declaration)
Public Shared Function GetPixelFormatSize ( _
    pixfmt As PixelFormat _
) As Integer
Visual C++
public:
static int GetPixelFormatSize(
    PixelFormat pixfmt
)

Parameters

pixfmt
Type: System.Drawing.Imaging..::.PixelFormat
The PixelFormat member that specifies the format for which to find the size.

Return Value

The color depth of the specified pixel format.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetPropertyItem Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetPropertyItem Method
FreeImageBitmap Class See Also Send Feedback
Gets the specified property item from this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public PropertyItem GetPropertyItem(
    int propid
)
Visual Basic (Declaration)
Public Function GetPropertyItem ( _
    propid As Integer _
) As PropertyItem
Visual C++
public:
PropertyItem^ GetPropertyItem(
    int propid
)

Parameters

propid
Type: System..::.Int32
The ID of the property item to get.

Return Value

The PropertyItem this method gets.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetQuantizedInstance Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetQuantizedInstance Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
GetQuantizedInstance(FREE_IMAGE_QUANTIZE, Int32) | Quantizes this FreeImageBitmap from 24 bit, using the specified algorithm initializing a new 8 bit instance with the specified paletteSize.
GetQuantizedInstance(FREE_IMAGE_QUANTIZE, Int32, Palette) | Quantizes this FreeImageBitmap from 24 bit, using the specified algorithm and reservePalette initializing a new 8 bit instance with the specified paletteSize.
GetQuantizedInstance(FREE_IMAGE_QUANTIZE, Int32, Int32, Palette) | Quantizes this FreeImageBitmap from 24 bit, using the specified algorithm and up to reserveSize entries from reservePalette initializing a new 8 bit instance with the specified paletteSize.
GetQuantizedInstance(FREE_IMAGE_QUANTIZE, Int32, Int32, array<RGBQUAD>[]()[]) | Quantizes this FreeImageBitmap from 24 bit, using the specified algorithm and up to reserveSize entries from reservePalette initializing a new 8 bit instance with the specified paletteSize.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


GetQuantizedInstance Method (FREE_IMAGE_QUANTIZE, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetQuantizedInstance Method (FREE_IMAGE_QUANTIZE, Int32)
FreeImageBitmap Class See Also Send Feedback
Quantizes this FreeImageBitmap from 24 bit, using the specified algorithm initializing a new 8 bit instance with the specified paletteSize.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetQuantizedInstance(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize
)
Visual Basic (Declaration)
Public Function GetQuantizedInstance ( _
    algorithm As FREE_IMAGE_QUANTIZE, _
    paletteSize As Integer _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetQuantizedInstance(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize
)

Parameters

algorithm
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
The color reduction algorithm to be used.
paletteSize
Type: System..::.Int32
Size of the desired output palette.

Return Value

The quantized instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetQuantizedInstance Overload


GetQuantizedInstance Method (FREE_IMAGE_QUANTIZE, Int32, Palette)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetQuantizedInstance Method (FREE_IMAGE_QUANTIZE, Int32, Palette)
FreeImageBitmap Class See Also Send Feedback
Quantizes this FreeImageBitmap from 24 bit, using the specified algorithm and reservePalette initializing a new 8 bit instance with the specified paletteSize.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetQuantizedInstance(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    Palette reservePalette
)
Visual Basic (Declaration)
Public Function GetQuantizedInstance ( _
    algorithm As FREE_IMAGE_QUANTIZE, _
    paletteSize As Integer, _
    reservePalette As Palette _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetQuantizedInstance(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    Palette^ reservePalette
)

Parameters

algorithm
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
The color reduction algorithm to be used.
paletteSize
Type: System..::.Int32
Size of the desired output palette.
reservePalette
Type: FreeImageAPI..::.Palette
The provided palette.

Return Value

The quantized instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetQuantizedInstance Overload


GetQuantizedInstance Method (FREE_IMAGE_QUANTIZE, Int32, Int32, Palette)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetQuantizedInstance Method (FREE_IMAGE_QUANTIZE, Int32, Int32, Palette)
FreeImageBitmap Class See Also Send Feedback
Quantizes this FreeImageBitmap from 24 bit, using the specified algorithm and up to reserveSize entries from reservePalette initializing a new 8 bit instance with the specified paletteSize.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetQuantizedInstance(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    int reserveSize,
    Palette reservePalette
)
Visual Basic (Declaration)
Public Function GetQuantizedInstance ( _
    algorithm As FREE_IMAGE_QUANTIZE, _
    paletteSize As Integer, _
    reserveSize As Integer, _
    reservePalette As Palette _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetQuantizedInstance(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    int reserveSize,
    Palette^ reservePalette
)

Parameters

algorithm
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
The color reduction algorithm to be used.
paletteSize
Type: System..::.Int32
Size of the desired output palette.
reserveSize
Type: System..::.Int32
Size of the provided palette.
reservePalette
Type: FreeImageAPI..::.Palette
The provided palette.

Return Value

The quantized instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetQuantizedInstance Overload


GetQuantizedInstance Method (FREE_IMAGE_QUANTIZE, Int32, Int32, RGBQUAD[])

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetQuantizedInstance Method (FREE_IMAGE_QUANTIZE, Int32, Int32, array<RGBQUAD>[]()[])
FreeImageBitmap Class See Also Send Feedback
Quantizes this FreeImageBitmap from 24 bit, using the specified algorithm and up to reserveSize entries from reservePalette initializing a new 8 bit instance with the specified paletteSize.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetQuantizedInstance(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    int reserveSize,
    RGBQUAD[] reservePalette
)
Visual Basic (Declaration)
Public Function GetQuantizedInstance ( _
    algorithm As FREE_IMAGE_QUANTIZE, _
    paletteSize As Integer, _
    reserveSize As Integer, _
    reservePalette As RGBQUAD() _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetQuantizedInstance(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    int reserveSize,
    array<RGBQUAD>^ reservePalette
)

Parameters

algorithm
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
The color reduction algorithm to be used.
paletteSize
Type: System..::.Int32
Size of the desired output palette.
reserveSize
Type: System..::.Int32
Size of the provided palette.
reservePalette
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The provided palette.

Return Value

The quantized instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetQuantizedInstance Overload


GetRotatedInstance Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetRotatedInstance Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
GetRotatedInstance(Double) | Rotates this FreeImageBitmap by the specified angle initializing a new instance. For 1- and 4-bit images, rotation is limited to angles whose value is an integer multiple of 90.
GetRotatedInstance<(Of <(T>)>)(Double, Nullable<(Of <(T>)>)) | Rotates this FreeImageBitmap by the specified angle initializing a new instance. For 1- and 4-bit images, rotation is limited to angles whose value is an integer multiple of 90.
GetRotatedInstance(Double, Double, Double, Double, Double, Boolean) | This method performs a rotation and / or translation of an 8-bit greyscale, 24- or 32-bit image, using a 3rd order (cubic) B-Spline initializing a new instance.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


GetRotatedInstance Method (Double)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetRotatedInstance Method (Double)
FreeImageBitmap Class See Also Send Feedback
Rotates this FreeImageBitmap by the specified angle initializing a new instance. For 1- and 4-bit images, rotation is limited to angles whose value is an integer multiple of 90.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetRotatedInstance(
    double angle
)
Visual Basic (Declaration)
Public Function GetRotatedInstance ( _
    angle As Double _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetRotatedInstance(
    double angle
)

Parameters

angle
Type: System..::.Double
The angle of rotation.

Return Value

The rotated instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetRotatedInstance Overload


GetRotatedInstance(T) Method (Double, Nullable(T))

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetRotatedInstance<(Of <(T>)>) Method (Double, Nullable<(Of <(T>)>))
FreeImageBitmap Class See Also Send Feedback
Rotates this FreeImageBitmap by the specified angle initializing a new instance. For 1- and 4-bit images, rotation is limited to angles whose value is an integer multiple of 90.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetRotatedInstance<T>(
    double angle,
    Nullable<T> backgroundColor
)
where T : struct, new()
Visual Basic (Declaration)
Public Function GetRotatedInstance(Of T As {Structure, New}) ( _
    angle As Double, _
    backgroundColor As Nullable(Of T) _
) As FreeImageBitmap
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
FreeImageBitmap^ GetRotatedInstance(
    double angle,
    Nullable<T> backgroundColor
)

Parameters

angle
Type: System..::.Double
The angle of rotation.
backgroundColor
Type: System..::.Nullable <(Of <(T>)>)
The color used used to fill the bitmap's background.

Type Parameters

T
The type of the color to use as background.

Return Value

The rotated instance.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetRotatedInstance Overload


GetRotatedInstance Method (Double, Double, Double, Double, Double, Boolean)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetRotatedInstance Method (Double, Double, Double, Double, Double, Boolean)
FreeImageBitmap Class See Also Send Feedback
This method performs a rotation and / or translation of an 8-bit greyscale, 24- or 32-bit image, using a 3rd order (cubic) B-Spline initializing a new instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetRotatedInstance(
    double angle,
    double xShift,
    double yShift,
    double xOrigin,
    double yOrigin,
    bool useMask
)
Visual Basic (Declaration)
Public Function GetRotatedInstance ( _
    angle As Double, _
    xShift As Double, _
    yShift As Double, _
    xOrigin As Double, _
    yOrigin As Double, _
    useMask As Boolean _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetRotatedInstance(
    double angle,
    double xShift,
    double yShift,
    double xOrigin,
    double yOrigin,
    bool useMask
)

Parameters

angle
Type: System..::.Double
The angle of rotation.
xShift
Type: System..::.Double
Horizontal image translation.
yShift
Type: System..::.Double
Vertical image translation.
xOrigin
Type: System..::.Double
Rotation center x-coordinate.
yOrigin
Type: System..::.Double
Rotation center y-coordinate.
useMask
Type: System..::.Boolean
When true the irrelevant part of the image is set to a black color, otherwise, a mirroring technique is used to fill irrelevant pixels.

Return Value

The rotated instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetRotatedInstance Overload


GetScaledInstance Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetScaledInstance Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
GetScaledInstance(Size, FREE_IMAGE_FILTER) | Rescales this FreeImageBitmap to the specified size using the specified filter initializing a new instance.
GetScaledInstance(Int32, Int32, FREE_IMAGE_FILTER) | Rescales this FreeImageBitmap to the specified size using the specified filter initializing a new instance.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


GetScaledInstance Method (Size, FREE_IMAGE_FILTER)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetScaledInstance Method (Size, FREE_IMAGE_FILTER)
FreeImageBitmap Class See Also Send Feedback
Rescales this FreeImageBitmap to the specified size using the specified filter initializing a new instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetScaledInstance(
    Size newSize,
    FREE_IMAGE_FILTER filter
)
Visual Basic (Declaration)
Public Function GetScaledInstance ( _
    newSize As Size, _
    filter As FREE_IMAGE_FILTER _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetScaledInstance(
    Size newSize,
    FREE_IMAGE_FILTER filter
)

Parameters

newSize
Type: System.Drawing..::.Size
The Size structure that represent the size of the new FreeImageBitmap.
filter
Type: FreeImageAPI..::.FREE_IMAGE_FILTER
Filter to use for resizing.

Return Value

The rescaled instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetScaledInstance Overload


GetScaledInstance Method (Int32, Int32, FREE_IMAGE_FILTER)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetScaledInstance Method (Int32, Int32, FREE_IMAGE_FILTER)
FreeImageBitmap Class See Also Send Feedback
Rescales this FreeImageBitmap to the specified size using the specified filter initializing a new instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetScaledInstance(
    int width,
    int height,
    FREE_IMAGE_FILTER filter
)
Visual Basic (Declaration)
Public Function GetScaledInstance ( _
    width As Integer, _
    height As Integer, _
    filter As FREE_IMAGE_FILTER _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetScaledInstance(
    int width,
    int height,
    FREE_IMAGE_FILTER filter
)

Parameters

width
Type: System..::.Int32
Width of the new FreeImageBitmap.
height
Type: System..::.Int32
Height of the new FreeImageBitmap.
filter
Type: FreeImageAPI..::.FREE_IMAGE_FILTER
Filter to use for resizing.

Return Value

The rescaled instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetScaledInstance Overload


GetScanline Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetScanline Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
GetScanline<(Of <(T>)>)(Int32) | Returns an instance of Scanline<(Of <(T>)>), representing the scanline specified by scanline of this FreeImageBitmap. Since FreeImage bitmaps are always bottum up aligned, keep in mind that scanline 0 is the bottom-most line of the image.
GetScanline(Int32) | Returns an instance of Scanline<(Of <(T>)>), representing the scanline specified by scanline of this FreeImageBitmap. Since FreeImage bitmaps are always bottum up aligned, keep in mind that scanline 0 is the bottom-most line of the image.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


GetScanline(T) Method (Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetScanline<(Of <(T>)>) Method (Int32)
FreeImageBitmap Class Example See Also Send Feedback
Returns an instance of Scanline<(Of <(T>)>), representing the scanline specified by scanline of this FreeImageBitmap. Since FreeImage bitmaps are always bottum up aligned, keep in mind that scanline 0 is the bottom-most line of the image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Scanline<T> GetScanline<T>(
    int scanline
)
where T : struct, new()
Visual Basic (Declaration)
Public Function GetScanline(Of T As {Structure, New}) ( _
    scanline As Integer _
) As Scanline(Of T)
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
Scanline<T>^ GetScanline(
    int scanline
)

Parameters

scanline
Type: System..::.Int32
Number of the scanline to retrieve.

Type Parameters

T

Return Value

An instance of Scanline<(Of <(T>)>) representing the scanlineth scanline.

Remarks

List of return-types of T:

Color Depth / Type | Result Type
1 (FIT_BITMAP) | FI1BIT
4 (FIT_BITMAP) | FI4BIT
8 (FIT_BITMAP) | Byte
16 (FIT_BITMAP) | UInt16
16 - 555 (FIT_BITMAP) | FI16RGB555
16 - 565 (FIT_BITMAP) | FI16RGB565
24 (FIT_BITMAP) | RGBTRIPLE
32 (FIT_BITMAP) | RGBQUAD
FIT_COMPLEX | FICOMPLEX
FIT_DOUBLE | Double
FIT_FLOAT | Single
FIT_INT16 | Int16
FIT_INT32 | Int32
FIT_RGB16 | FIRGB16
FIT_RGBA16 | FIRGBA16
FIT_RGBAF | FIRGBAF
FIT_RGBF | FIRGBF
FIT_UINT16 | UInt16
FIT_UINT32 | UInt32

Examples

CopyC#
FreeImageBitmap bitmap = new FreeImageBitmap(@"C:\Pictures\picture.bmp");
if (bitmap.ColorDepth == 32)
{
    Scanline<RGBQUAD> scanline = bitmap.GetScanline<RGBQUAD>(0);
    foreach (RGBQUAD pixel in scanline)
    {
        Console.WriteLine(pixel);
    }
}

Exceptions

Exception | Condition
System..::.ArgumentException | The bitmap's type or color depth are not supported.
System..::.ArgumentOutOfRangeException | scanline is no valid value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetScanline Overload


GetScanline Method (Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetScanline Method (Int32)
FreeImageBitmap Class Example See Also Send Feedback
Returns an instance of Scanline<(Of <(T>)>), representing the scanline specified by scanline of this FreeImageBitmap. Since FreeImage bitmaps are always bottum up aligned, keep in mind that scanline 0 is the bottom-most line of the image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Object GetScanline(
    int scanline
)
Visual Basic (Declaration)
Public Function GetScanline ( _
    scanline As Integer _
) As Object
Visual C++
public:
Object^ GetScanline(
    int scanline
)

Parameters

scanline
Type: System..::.Int32
Number of the scanline to retrieve.

Return Value

An instance of Scanline<(Of <(T>)>) representing the scanlineth scanline.

Remarks

List of return-types of T:

Color Depth / Type | Result Type
1 (FIT_BITMAP) | FI1BIT
4 (FIT_BITMAP) | FI4BIT
8 (FIT_BITMAP) | Byte
16 (FIT_BITMAP) | UInt16
16 - 555 (FIT_BITMAP) | FI16RGB555
16 - 565 (FIT_BITMAP) | FI16RGB565
24 (FIT_BITMAP) | RGBTRIPLE
32 (FIT_BITMAP) | RGBQUAD
FIT_COMPLEX | FICOMPLEX
FIT_DOUBLE | Double
FIT_FLOAT | Single
FIT_INT16 | Int16
FIT_INT32 | Int32
FIT_RGB16 | FIRGB16
FIT_RGBA16 | FIRGBA16
FIT_RGBAF | FIRGBAF
FIT_RGBF | FIRGBF
FIT_UINT16 | UInt16
FIT_UINT32 | UInt32

Examples

CopyC#
FreeImageBitmap bitmap = new FreeImageBitmap(@"C:\Pictures\picture.bmp");
if (bitmap.ColorDepth == 32)
{
    Scanline<RGBQUAD> scanline = (Scanline<RGBQUAD>)bitmap.GetScanline(0);
    foreach (RGBQUAD pixel in scanline)
    {
        Console.WriteLine(pixel);
    }
}

Exceptions

Exception | Condition
System..::.ArgumentException | The type of the bitmap or color depth are not supported.
System..::.ArgumentOutOfRangeException | scanline is no valid value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetScanline Overload


GetScanlinePointer Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetScanlinePointer Method
FreeImageBitmap Class See Also Send Feedback
Returns a pointer to the specified scanline. Due to FreeImage bitmaps are bottum up, scanline 0 is the most bottom line of the image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IntPtr GetScanlinePointer(
    int scanline
)
Visual Basic (Declaration)
Public Function GetScanlinePointer ( _
    scanline As Integer _
) As IntPtr
Visual C++
public:
IntPtr GetScanlinePointer(
    int scanline
)

Parameters

scanline
Type: System..::.Int32
Number of the scanline.

Return Value

Pointer to the scanline.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetScanlines Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetScanlines Method
FreeImageBitmap Class See Also Send Feedback
Returns a list of structures, representing the scanlines of this FreeImageBitmap. Due to FreeImage bitmaps are bottum up, scanline 0 is the bottom-most line of the image. Each color depth has a different representing structure due to different memory layouts.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IList GetScanlines()
Visual Basic (Declaration)
Public Function GetScanlines As IList
Visual C++
public:
IList^ GetScanlines()

Remarks

List of return-types of T:

Color Depth / Type | Result Type of IEnmuerable<Scanline<T>>
1 (FIT_BITMAP) | FI1BIT
4 (FIT_BITMAP) | FI4BIT
8 (FIT_BITMAP) | Byte
16 (FIT_BITMAP) | UInt16
16 - 555 (FIT_BITMAP) | FI16RGB555
16 - 565 (FIT_BITMAP) | FI16RGB565
24 (FIT_BITMAP) | RGBTRIPLE
32 (FIT_BITMAP) | RGBQUAD
FIT_COMPLEX | FICOMPLEX
FIT_DOUBLE | Double
FIT_FLOAT | Single
FIT_INT16 | Int16
FIT_INT32 | Int32
FIT_RGB16 | FIRGB16
FIT_RGBA16 | FIRGBA16
FIT_RGBAF | FIRGBAF
FIT_RGBF | FIRGBF
FIT_UINT16 | UInt16
FIT_UINT32 | UInt32

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GetThumbnailImage Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetThumbnailImage Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
GetThumbnailImage(Int32, Boolean) | Returns a thumbnail for this FreeImageBitmap, keeping aspect ratio. maxPixelSize defines the maximum width or height of the thumbnail.
GetThumbnailImage(Int32, Int32, Image..::.GetThumbnailImageAbort, IntPtr) | Returns a thumbnail for this FreeImageBitmap.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


GetThumbnailImage Method (Int32, Boolean)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetThumbnailImage Method (Int32, Boolean)
FreeImageBitmap Class See Also Send Feedback
Returns a thumbnail for this FreeImageBitmap, keeping aspect ratio. maxPixelSize defines the maximum width or height of the thumbnail.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetThumbnailImage(
    int maxPixelSize,
    bool convert
)
Visual Basic (Declaration)
Public Function GetThumbnailImage ( _
    maxPixelSize As Integer, _
    convert As Boolean _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetThumbnailImage(
    int maxPixelSize,
    bool convert
)

Parameters

maxPixelSize
Type: System..::.Int32
Thumbnail square size.
convert
Type: System..::.Boolean
When true HDR images are transperantly converted to standard images.

Return Value

The thumbnail in a new instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetThumbnailImage Overload


GetThumbnailImage Method (Int32, Int32, Image.GetThumbnailImageAbort, IntPtr)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetThumbnailImage Method (Int32, Int32, Image..::.GetThumbnailImageAbort, IntPtr)
FreeImageBitmap Class See Also Send Feedback
Returns a thumbnail for this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetThumbnailImage(
    int thumbWidth,
    int thumbHeight,
    Image..::.GetThumbnailImageAbort callback,
    IntPtr callBackData
)
Visual Basic (Declaration)
Public Function GetThumbnailImage ( _
    thumbWidth As Integer, _
    thumbHeight As Integer, _
    callback As Image..::.GetThumbnailImageAbort, _
    callBackData As IntPtr _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetThumbnailImage(
    int thumbWidth,
    int thumbHeight,
    Image..::.GetThumbnailImageAbort^ callback,
    IntPtr callBackData
)

Parameters

thumbWidth
Type: System..::.Int32
The width, in pixels, of the requested thumbnail image.
thumbHeight
Type: System..::.Int32
The height, in pixels, of the requested thumbnail image.
callback
Type: System.Drawing..::.Image..::.GetThumbnailImageAbort
Ignored.
callBackData
Type: System..::.IntPtr
Ignored.

Return Value

A FreeImageBitmap that represents the thumbnail.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
GetThumbnailImage Overload


GetTypeConvertedInstance Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GetTypeConvertedInstance Method
FreeImageBitmap Class See Also Send Feedback
Converts this FreeImageBitmap FreeImageBitmap to type. In case source and destination type are the same, the operation fails. An error message can be catched using the 'Message' event.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FreeImageBitmap GetTypeConvertedInstance(
    FREE_IMAGE_TYPE type,
    bool scaleLinear
)
Visual Basic (Declaration)
Public Function GetTypeConvertedInstance ( _
    type As FREE_IMAGE_TYPE, _
    scaleLinear As Boolean _
) As FreeImageBitmap
Visual C++
public:
FreeImageBitmap^ GetTypeConvertedInstance(
    FREE_IMAGE_TYPE type,
    bool scaleLinear
)

Parameters

type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
Destination type.
scaleLinear
Type: System..::.Boolean
True to scale linear, else false.

Return Value

The converted instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.Implicit Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
Implicit(FreeImageBitmap) | Converts a FreeImageBitmap instance to a Bitmap instance.
Implicit(Bitmap) | Converts a Bitmap instance to a FreeImageBitmap instance.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


Implicit Operator

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Implicit Operator
FreeImageBitmap Class See Also Send Feedback
Converts a FreeImageBitmap instance to a Bitmap instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator Bitmap (
    FreeImageBitmap value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As FreeImageBitmap _
) As Bitmap
Visual C++
static implicit operator Bitmap^ (
    FreeImageBitmap^ value
)

Parameters

value
Type: FreeImageAPI..::.FreeImageBitmap
A FreeImageBitmap instance.

Return Value

A new instance of Bitmap initialized to value.

Remarks

The implicit conversion from FreeImageBitmap into Bitmap allows to create an instance on the fly and use it as if was a Bitmap. This way it can be directly used with a PixtureBox for example without having to call any conversion operations.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FreeImageBitmap Class
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Implicit Operator
FreeImageBitmap Class See Also Send Feedback
Converts a Bitmap instance to a FreeImageBitmap instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FreeImageBitmap (
    Bitmap value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Bitmap _
) As FreeImageBitmap
Visual C++
static implicit operator FreeImageBitmap^ (
    Bitmap^ value
)

Parameters

value
Type: System.Drawing..::.Bitmap
A Bitmap instance.

Return Value

A new instance of FreeImageBitmap initialized to value.

Remarks

The implicit conversion from Bitmap into FreeImageBitmap allows to create an instance on the fly to perform image processing operations and converting it back.

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

FreeImageBitmap Class
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Inequality Operator
FreeImageBitmap Class See Also Send Feedback
Determines whether two specified FreeImageBitmap objects have different values.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    FreeImageBitmap left,
    FreeImageBitmap right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As FreeImageBitmap, _
    right As FreeImageBitmap _
) As Boolean
Visual C++
public:
static bool operator !=(
    FreeImageBitmap^ left,
    FreeImageBitmap^ right
)

Parameters

left
Type: FreeImageAPI..::.FreeImageBitmap
A FreeImageBitmap or a null reference (Nothing in Visual Basic).
right
Type: FreeImageAPI..::.FreeImageBitmap
A FreeImageBitmap or a null reference (Nothing in Visual Basic).

Return Value

true if the value of left is different from the value of right; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Invert Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Invert Method
FreeImageBitmap Class See Also Send Feedback
Inverts each pixel data.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Invert()
Visual Basic (Declaration)
Public Function Invert As Boolean
Visual C++
public:
bool Invert()

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


IsAlphaPixelFormat Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.IsAlphaPixelFormat Method
FreeImageBitmap Class See Also Send Feedback
Returns a value that indicates whether the pixel format for this FreeImageBitmap contains alpha information.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsAlphaPixelFormat(
    PixelFormat pixfmt
)
Visual Basic (Declaration)
Public Shared Function IsAlphaPixelFormat ( _
    pixfmt As PixelFormat _
) As Boolean
Visual C++
public:
static bool IsAlphaPixelFormat(
    PixelFormat pixfmt
)

Parameters

pixfmt
Type: System.Drawing.Imaging..::.PixelFormat
The PixelFormat to test.

Return Value

true if pixfmt contains alpha information; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


IsCanonicalPixelFormat Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.IsCanonicalPixelFormat Method
FreeImageBitmap Class See Also Send Feedback
Returns a value that indicates whether the pixel format is 32 bits per pixel.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsCanonicalPixelFormat(
    PixelFormat pixfmt
)
Visual Basic (Declaration)
Public Shared Function IsCanonicalPixelFormat ( _
    pixfmt As PixelFormat _
) As Boolean
Visual C++
public:
static bool IsCanonicalPixelFormat(
    PixelFormat pixfmt
)

Parameters

pixfmt
Type: System.Drawing.Imaging..::.PixelFormat
The PixelFormat to test.

Return Value

true if pixfmt is canonical; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


IsExtendedPixelFormat Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.IsExtendedPixelFormat Method
FreeImageBitmap Class See Also Send Feedback
Returns a value that indicates whether the pixel format is 64 bits per pixel.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsExtendedPixelFormat(
    PixelFormat pixfmt
)
Visual Basic (Declaration)
Public Shared Function IsExtendedPixelFormat ( _
    pixfmt As PixelFormat _
) As Boolean
Visual C++
public:
static bool IsExtendedPixelFormat(
    PixelFormat pixfmt
)

Parameters

pixfmt
Type: System.Drawing.Imaging..::.PixelFormat
The PixelFormat enumeration to test.

Return Value

true if pixfmt is extended; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


JPEGCrop Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.JPEGCrop Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
JPEGCrop(String, String, Rectangle) | Performs a lossless crop on a JPEG file.
JPEGCrop(String, String, Int32, Int32, Int32, Int32) | Performs a lossless crop on a JPEG file.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


JPEGCrop Method (String, String, Rectangle)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.JPEGCrop Method (String, String, Rectangle)
FreeImageBitmap Class See Also Send Feedback
Performs a lossless crop on a JPEG file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool JPEGCrop(
    string source,
    string destination,
    Rectangle rect
)
Visual Basic (Declaration)
Public Shared Function JPEGCrop ( _
    source As String, _
    destination As String, _
    rect As Rectangle _
) As Boolean
Visual C++
public:
static bool JPEGCrop(
    String^ source,
    String^ destination,
    Rectangle rect
)

Parameters

source
Type: System..::.String
Source filename.
destination
Type: System..::.String
Destination filename.
rect
Type: System.Drawing..::.Rectangle
Specifies the cropped rectangle.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | source or destination is null.
System.IO..::.FileNotFoundException | source does not exist.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
JPEGCrop Overload


JPEGCrop Method (String, String, Int32, Int32, Int32, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.JPEGCrop Method (String, String, Int32, Int32, Int32, Int32)
FreeImageBitmap Class See Also Send Feedback
Performs a lossless crop on a JPEG file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool JPEGCrop(
    string source,
    string destination,
    int left,
    int top,
    int right,
    int bottom
)
Visual Basic (Declaration)
Public Shared Function JPEGCrop ( _
    source As String, _
    destination As String, _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
) As Boolean
Visual C++
public:
static bool JPEGCrop(
    String^ source,
    String^ destination,
    int left,
    int top,
    int right,
    int bottom
)

Parameters

source
Type: System..::.String
Source filename.
destination
Type: System..::.String
Destination filename.
left
Type: System..::.Int32
Specifies the left position of the cropped rectangle.
top
Type: System..::.Int32
Specifies the top position of the cropped rectangle.
right
Type: System..::.Int32
Specifies the right position of the cropped rectangle.
bottom
Type: System..::.Int32
Specifies the bottom position of the cropped rectangle.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | source or destination is null.
System.IO..::.FileNotFoundException | source does not exist.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
JPEGCrop Overload


JPEGTransform Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.JPEGTransform Method
FreeImageBitmap Class See Also Send Feedback
Performs a lossless rotation or flipping on a JPEG file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool JPEGTransform(
    string source,
    string destination,
    FREE_IMAGE_JPEG_OPERATION operation,
    bool perfect
)
Visual Basic (Declaration)
Public Shared Function JPEGTransform ( _
    source As String, _
    destination As String, _
    operation As FREE_IMAGE_JPEG_OPERATION, _
    perfect As Boolean _
) As Boolean
Visual C++
public:
static bool JPEGTransform(
    String^ source,
    String^ destination,
    FREE_IMAGE_JPEG_OPERATION operation,
    bool perfect
)

Parameters

source
Type: System..::.String
Source file.
destination
Type: System..::.String
Destination file; can be the source file; will be overwritten.
operation
Type: FreeImageAPI..::.FREE_IMAGE_JPEG_OPERATION
The operation to apply.
perfect
Type: System..::.Boolean
To avoid lossy transformation, you can set the perfect parameter to true.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


LockBits Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.LockBits Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
LockBits(Rectangle, ImageLockMode, PixelFormat) | This function is not yet implemented.
LockBits(Rectangle, ImageLockMode, PixelFormat, BitmapData) | This function is not yet implemented.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


LockBits Method (Rectangle, ImageLockMode, PixelFormat)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.LockBits Method (Rectangle, ImageLockMode, PixelFormat)
FreeImageBitmap Class See Also Send Feedback
This function is not yet implemented.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public BitmapData LockBits(
    Rectangle rect,
    ImageLockMode flags,
    PixelFormat format
)
Visual Basic (Declaration)
Public Function LockBits ( _
    rect As Rectangle, _
    flags As ImageLockMode, _
    format As PixelFormat _
) As BitmapData
Visual C++
public:
BitmapData^ LockBits(
    Rectangle rect,
    ImageLockMode flags,
    PixelFormat format
)

Parameters

rect
Type: System.Drawing..::.Rectangle
flags
Type: System.Drawing.Imaging..::.ImageLockMode
format
Type: System.Drawing.Imaging..::.PixelFormat

Exceptions

Exception | Condition
System..::.NotImplementedException | This method is not implemented.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
LockBits Overload


LockBits Method (Rectangle, ImageLockMode, PixelFormat, BitmapData)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.LockBits Method (Rectangle, ImageLockMode, PixelFormat, BitmapData)
FreeImageBitmap Class See Also Send Feedback
This function is not yet implemented.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public BitmapData LockBits(
    Rectangle rect,
    ImageLockMode flags,
    PixelFormat format,
    BitmapData bitmapData
)
Visual Basic (Declaration)
Public Function LockBits ( _
    rect As Rectangle, _
    flags As ImageLockMode, _
    format As PixelFormat, _
    bitmapData As BitmapData _
) As BitmapData
Visual C++
public:
BitmapData^ LockBits(
    Rectangle rect,
    ImageLockMode flags,
    PixelFormat format,
    BitmapData^ bitmapData
)

Parameters

rect
Type: System.Drawing..::.Rectangle
flags
Type: System.Drawing.Imaging..::.ImageLockMode
format
Type: System.Drawing.Imaging..::.PixelFormat
bitmapData
Type: System.Drawing.Imaging..::.BitmapData

Exceptions

Exception | Condition
System..::.NotImplementedException | This method is not implemented.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
LockBits Overload


LookupSVGColor Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.LookupSVGColor Method
FreeImageBitmap Class See Also Send Feedback
Converts a SVG color name into a corresponding RGB value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool LookupSVGColor(
    string color,
    out byte red,
    out byte green,
    out byte blue
)
Visual Basic (Declaration)
Public Shared Function LookupSVGColor ( _
    color As String, _
    <OutAttribute> ByRef red As Byte, _
    <OutAttribute> ByRef green As Byte, _
    <OutAttribute> ByRef blue As Byte _
) As Boolean
Visual C++
public:
static bool LookupSVGColor(
    String^ color,
    [OutAttribute] unsigned char% red,
    [OutAttribute] unsigned char% green,
    [OutAttribute] unsigned char% blue
)

Parameters

color
Type: System..::.String
Name of the color to convert.
red
Type: System..::.Byte %
Red component.
green
Type: System..::.Byte %
Green component.
blue
Type: System..::.Byte %
Blue component.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | color is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


LookupX11Color Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.LookupX11Color Method
FreeImageBitmap Class See Also Send Feedback
Converts a X11 color name into a corresponding RGB value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool LookupX11Color(
    string color,
    out byte red,
    out byte green,
    out byte blue
)
Visual Basic (Declaration)
Public Shared Function LookupX11Color ( _
    color As String, _
    <OutAttribute> ByRef red As Byte, _
    <OutAttribute> ByRef green As Byte, _
    <OutAttribute> ByRef blue As Byte _
) As Boolean
Visual C++
public:
static bool LookupX11Color(
    String^ color,
    [OutAttribute] unsigned char% red,
    [OutAttribute] unsigned char% green,
    [OutAttribute] unsigned char% blue
)

Parameters

color
Type: System..::.String
Name of the color to convert.
red
Type: System..::.Byte %
Red component.
green
Type: System..::.Byte %
Green component.
blue
Type: System..::.Byte %
Blue component.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | color is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


MakeTransparent Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.MakeTransparent Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
MakeTransparent()()() | Makes the default transparent color transparent for this FreeImageBitmap.
MakeTransparent(Color) | Makes the specified color transparent for this FreeImageBitmap.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


MakeTransparent Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.MakeTransparent Method
FreeImageBitmap Class See Also Send Feedback
Makes the default transparent color transparent for this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void MakeTransparent()
Visual Basic (Declaration)
Public Sub MakeTransparent
Visual C++
public:
void MakeTransparent()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
MakeTransparent Overload


MakeTransparent Method (Color)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.MakeTransparent Method (Color)
FreeImageBitmap Class See Also Send Feedback
Makes the specified color transparent for this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void MakeTransparent(
    Color transparentColor
)
Visual Basic (Declaration)
Public Sub MakeTransparent ( _
    transparentColor As Color _
)
Visual C++
public:
void MakeTransparent(
    Color transparentColor
)

Parameters

transparentColor
Type: System.Drawing..::.Color
The Color structure that represents the color to make transparent.

Exceptions

Exception | Condition
System..::.NotImplementedException | This method is not implemented.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
MakeTransparent Overload


MultigridPoissonSolver Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.MultigridPoissonSolver Method
FreeImageBitmap Class See Also Send Feedback
Solves a Poisson equation, remap result pixels to [0..1] and returns the solution.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool MultigridPoissonSolver(
    int ncycle
)
Visual Basic (Declaration)
Public Function MultigridPoissonSolver ( _
    ncycle As Integer _
) As Boolean
Visual C++
public:
bool MultigridPoissonSolver(
    int ncycle
)

Parameters

ncycle
Type: System..::.Int32
Number of cycles in the multigrid algorithm (usually 2 or 3)

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Paste Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.Paste Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
Paste(FreeImageBitmap, Point, Int32) | Alpha blend or combine a sub part image with tthis FreeImageBitmap. The bit depth of bitmap must be greater than or equal to the bit depth this instance.
Paste(FreeImageBitmap, Int32, Int32, Int32) | Alpha blend or combine a sub part image with this FreeImageBitmap. The bit depth of bitmap must be greater than or equal to the bit depth this instance.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


Paste Method (FreeImageBitmap, Point, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Paste Method (FreeImageBitmap, Point, Int32)
FreeImageBitmap Class See Also Send Feedback
Alpha blend or combine a sub part image with tthis FreeImageBitmap. The bit depth of bitmap must be greater than or equal to the bit depth this instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Paste(
    FreeImageBitmap bitmap,
    Point point,
    int alpha
)
Visual Basic (Declaration)
Public Function Paste ( _
    bitmap As FreeImageBitmap, _
    point As Point, _
    alpha As Integer _
) As Boolean
Visual C++
public:
bool Paste(
    FreeImageBitmap^ bitmap,
    Point point,
    int alpha
)

Parameters

bitmap
Type: FreeImageAPI..::.FreeImageBitmap
The FreeImageBitmap to paste into this instance.
point
Type: System.Drawing..::.Point
Specifies the position of the sub image.
alpha
Type: System..::.Int32
alpha blend factor. The source and destination images are alpha blended if alpha=0..255. If alpha > 255, then the source image is combined to the destination image.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Paste Overload


Paste Method (FreeImageBitmap, Int32, Int32, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Paste Method (FreeImageBitmap, Int32, Int32, Int32)
FreeImageBitmap Class See Also Send Feedback
Alpha blend or combine a sub part image with this FreeImageBitmap. The bit depth of bitmap must be greater than or equal to the bit depth this instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Paste(
    FreeImageBitmap bitmap,
    int left,
    int top,
    int alpha
)
Visual Basic (Declaration)
Public Function Paste ( _
    bitmap As FreeImageBitmap, _
    left As Integer, _
    top As Integer, _
    alpha As Integer _
) As Boolean
Visual C++
public:
bool Paste(
    FreeImageBitmap^ bitmap,
    int left,
    int top,
    int alpha
)

Parameters

bitmap
Type: FreeImageAPI..::.FreeImageBitmap
The FreeImageBitmap to paste into this instance.
left
Type: System..::.Int32
Specifies the left position of the sub image.
top
Type: System..::.Int32
Specifies the top position of the sub image.
alpha
Type: System..::.Int32
alpha blend factor. The source and destination images are alpha blended if alpha=0..255. If alpha > 255, then the source image is combined to the destination image.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Paste Overload


PreMultiplyWithAlpha Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.PreMultiplyWithAlpha Method
FreeImageBitmap Class See Also Send Feedback
Applies the alpha value of each pixel to its color components. The aplha value stays unchanged. Only works with 32-bits color depth.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool PreMultiplyWithAlpha()
Visual Basic (Declaration)
Public Function PreMultiplyWithAlpha As Boolean
Visual C++
public:
bool PreMultiplyWithAlpha()

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Quantize Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.Quantize Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
Quantize(FREE_IMAGE_QUANTIZE, Int32) | Quantizes this FreeImageBitmap from 24 bit to 8bit creating a new palette with the specified paletteSize using the specified algorithm.
Quantize(FREE_IMAGE_QUANTIZE, Int32, Palette) | Quantizes this FreeImageBitmap from 24 bit to 8bit creating a new palette with the specified paletteSize using the specified algorithm and the specified reservePalette up to the specified paletteSize.
Quantize(FREE_IMAGE_QUANTIZE, Int32, Int32, Palette) | Quantizes this FreeImageBitmap from 24 bit to 8bit creating a new palette with the specified paletteSize using the specified algorithm and the specified reservePalette up to the specified paletteSize.
Quantize(FREE_IMAGE_QUANTIZE, Int32, Int32, array<RGBQUAD>[]()[]) | Quantizes this FreeImageBitmap from 24 bit to 8bit creating a new palette with the specified paletteSize using the specified algorithm and the specified reservePalette up to the specified paletteSize.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


Quantize Method (FREE_IMAGE_QUANTIZE, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Quantize Method (FREE_IMAGE_QUANTIZE, Int32)
FreeImageBitmap Class See Also Send Feedback
Quantizes this FreeImageBitmap from 24 bit to 8bit creating a new palette with the specified paletteSize using the specified algorithm.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Quantize(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize
)
Visual Basic (Declaration)
Public Function Quantize ( _
    algorithm As FREE_IMAGE_QUANTIZE, _
    paletteSize As Integer _
) As Boolean
Visual C++
public:
bool Quantize(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize
)

Parameters

algorithm
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
The color reduction algorithm to be used.
paletteSize
Type: System..::.Int32
Size of the desired output palette.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Quantize Overload


Quantize Method (FREE_IMAGE_QUANTIZE, Int32, Palette)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Quantize Method (FREE_IMAGE_QUANTIZE, Int32, Palette)
FreeImageBitmap Class See Also Send Feedback
Quantizes this FreeImageBitmap from 24 bit to 8bit creating a new palette with the specified paletteSize using the specified algorithm and the specified reservePalette up to the specified paletteSize.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Quantize(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    Palette reservePalette
)
Visual Basic (Declaration)
Public Function Quantize ( _
    algorithm As FREE_IMAGE_QUANTIZE, _
    paletteSize As Integer, _
    reservePalette As Palette _
) As Boolean
Visual C++
public:
bool Quantize(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    Palette^ reservePalette
)

Parameters

algorithm
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
The color reduction algorithm to be used.
paletteSize
Type: System..::.Int32
Size of the desired output palette.
reservePalette
Type: FreeImageAPI..::.Palette
The provided palette.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Quantize Overload


Quantize Method (FREE_IMAGE_QUANTIZE, Int32, Int32, Palette)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Quantize Method (FREE_IMAGE_QUANTIZE, Int32, Int32, Palette)
FreeImageBitmap Class See Also Send Feedback
Quantizes this FreeImageBitmap from 24 bit to 8bit creating a new palette with the specified paletteSize using the specified algorithm and the specified reservePalette up to the specified paletteSize.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Quantize(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    int reserveSize,
    Palette reservePalette
)
Visual Basic (Declaration)
Public Function Quantize ( _
    algorithm As FREE_IMAGE_QUANTIZE, _
    paletteSize As Integer, _
    reserveSize As Integer, _
    reservePalette As Palette _
) As Boolean
Visual C++
public:
bool Quantize(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    int reserveSize,
    Palette^ reservePalette
)

Parameters

algorithm
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
The color reduction algorithm to be used.
paletteSize
Type: System..::.Int32
Size of the desired output palette.
reserveSize
Type: System..::.Int32
Size of the provided palette of ReservePalette.
reservePalette
Type: FreeImageAPI..::.Palette
The provided palette.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Quantize Overload


Quantize Method (FREE_IMAGE_QUANTIZE, Int32, Int32, RGBQUAD[])

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Quantize Method (FREE_IMAGE_QUANTIZE, Int32, Int32, array<RGBQUAD>[]()[])
FreeImageBitmap Class See Also Send Feedback
Quantizes this FreeImageBitmap from 24 bit to 8bit creating a new palette with the specified paletteSize using the specified algorithm and the specified reservePalette up to the specified paletteSize.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Quantize(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    int reserveSize,
    RGBQUAD[] reservePalette
)
Visual Basic (Declaration)
Public Function Quantize ( _
    algorithm As FREE_IMAGE_QUANTIZE, _
    paletteSize As Integer, _
    reserveSize As Integer, _
    reservePalette As RGBQUAD() _
) As Boolean
Visual C++
public:
bool Quantize(
    FREE_IMAGE_QUANTIZE algorithm,
    int paletteSize,
    int reserveSize,
    array<RGBQUAD>^ reservePalette
)

Parameters

algorithm
Type: FreeImageAPI..::.FREE_IMAGE_QUANTIZE
The color reduction algorithm to be used.
paletteSize
Type: System..::.Int32
Size of the desired output palette.
reserveSize
Type: System..::.Int32
Size of the provided palette of ReservePalette.
reservePalette
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The provided palette.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Quantize Overload


RemovePropertyItem Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.RemovePropertyItem Method
FreeImageBitmap Class See Also Send Feedback
Removes the specified property item from this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void RemovePropertyItem(
    int propid
)
Visual Basic (Declaration)
Public Sub RemovePropertyItem ( _
    propid As Integer _
)
Visual C++
public:
void RemovePropertyItem(
    int propid
)

Parameters

propid
Type: System..::.Int32
The ID of the property item to remove.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Rescale Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.Rescale Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
Rescale(Size, FREE_IMAGE_FILTER) | Rescales this FreeImageBitmap to the specified size using the specified filter.
Rescale(Int32, Int32, FREE_IMAGE_FILTER) | Rescales this FreeImageBitmap to the specified size using the specified filter.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


Rescale Method (Size, FREE_IMAGE_FILTER)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Rescale Method (Size, FREE_IMAGE_FILTER)
FreeImageBitmap Class See Also Send Feedback
Rescales this FreeImageBitmap to the specified size using the specified filter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Rescale(
    Size newSize,
    FREE_IMAGE_FILTER filter
)
Visual Basic (Declaration)
Public Function Rescale ( _
    newSize As Size, _
    filter As FREE_IMAGE_FILTER _
) As Boolean
Visual C++
public:
bool Rescale(
    Size newSize,
    FREE_IMAGE_FILTER filter
)

Parameters

newSize
Type: System.Drawing..::.Size
The Size structure that represent the size of the new FreeImageBitmap.
filter
Type: FreeImageAPI..::.FREE_IMAGE_FILTER
Filter to use for resizing.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Rescale Overload


Rescale Method (Int32, Int32, FREE_IMAGE_FILTER)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Rescale Method (Int32, Int32, FREE_IMAGE_FILTER)
FreeImageBitmap Class See Also Send Feedback
Rescales this FreeImageBitmap to the specified size using the specified filter.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Rescale(
    int width,
    int height,
    FREE_IMAGE_FILTER filter
)
Visual Basic (Declaration)
Public Function Rescale ( _
    width As Integer, _
    height As Integer, _
    filter As FREE_IMAGE_FILTER _
) As Boolean
Visual C++
public:
bool Rescale(
    int width,
    int height,
    FREE_IMAGE_FILTER filter
)

Parameters

width
Type: System..::.Int32
Width of the new FreeImageBitmap.
height
Type: System..::.Int32
Height of the new FreeImageBitmap.
filter
Type: FreeImageAPI..::.FREE_IMAGE_FILTER
Filter to use for resizing.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Rescale Overload


Rotate Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.Rotate Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
Rotate(Double) | This method rotates a 1-, 4-, 8-bit greyscale or a 24-, 32-bit color image by means of 3 shears. For 1- and 4-bit images, rotation is limited to angles whose value is an integer multiple of 90.
Rotate<(Of <(T>)>)(Double, Nullable<(Of <(T>)>)) | This method rotates a 1-, 4-, 8-bit greyscale or a 24-, 32-bit color image by means of 3 shears. For 1- and 4-bit images, rotation is limited to angles whose value is an integer multiple of 90.
Rotate(Double, Double, Double, Double, Double, Boolean) | This method performs a rotation and / or translation of an 8-bit greyscale, 24- or 32-bit image, using a 3rd order (cubic) B-Spline.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


Rotate Method (Double)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Rotate Method (Double)
FreeImageBitmap Class See Also Send Feedback
This method rotates a 1-, 4-, 8-bit greyscale or a 24-, 32-bit color image by means of 3 shears. For 1- and 4-bit images, rotation is limited to angles whose value is an integer multiple of 90.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Rotate(
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    double angle
)

Parameters

angle
Type: System..::.Double
The angle of rotation.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Rotate Overload


Rotate(T) Method (Double, Nullable(T))

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Rotate<(Of <(T>)>) Method (Double, Nullable<(Of <(T>)>))
FreeImageBitmap Class See Also Send Feedback
This method rotates a 1-, 4-, 8-bit greyscale or a 24-, 32-bit color image by means of 3 shears. For 1- and 4-bit images, rotation is limited to angles whose value is an integer multiple of 90.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Rotate<T>(
    double angle,
    Nullable<T> backgroundColor
)
where T : struct, new()
Visual Basic (Declaration)
Public Function Rotate(Of T As {Structure, New}) ( _
    angle As Double, _
    backgroundColor As Nullable(Of T) _
) As Boolean
Visual C++
public:
generic<typename T>
where T : value class, gcnew()
bool Rotate(
    double angle,
    Nullable<T> backgroundColor
)

Parameters

angle
Type: System..::.Double
The angle of rotation.
backgroundColor
Type: System..::.Nullable <(Of <(T>)>)
The color used used to fill the bitmap's background.

Type Parameters

T
The type of the color to use as background.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Rotate Overload


Rotate Method (Double, Double, Double, Double, Double, Boolean)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Rotate Method (Double, Double, Double, Double, Double, Boolean)
FreeImageBitmap Class See Also Send Feedback
This method performs a rotation and / or translation of an 8-bit greyscale, 24- or 32-bit image, using a 3rd order (cubic) B-Spline.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Rotate(
    double angle,
    double xShift,
    double yShift,
    double xOrigin,
    double yOrigin,
    bool useMask
)
Visual Basic (Declaration)
Public Function Rotate ( _
    angle As Double, _
    xShift As Double, _
    yShift As Double, _
    xOrigin As Double, _
    yOrigin As Double, _
    useMask As Boolean _
) As Boolean
Visual C++
public:
bool Rotate(
    double angle,
    double xShift,
    double yShift,
    double xOrigin,
    double yOrigin,
    bool useMask
)

Parameters

angle
Type: System..::.Double
The angle of rotation.
xShift
Type: System..::.Double
Horizontal image translation.
yShift
Type: System..::.Double
Vertical image translation.
xOrigin
Type: System..::.Double
Rotation center x-coordinate.
yOrigin
Type: System..::.Double
Rotation center y-coordinate.
useMask
Type: System..::.Boolean
When true the irrelevant part of the image is set to a black color, otherwise, a mirroring technique is used to fill irrelevant pixels.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Rotate Overload


RotateFlip Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.RotateFlip Method
FreeImageBitmap Class See Also Send Feedback
This method rotates, flips, or rotates and flips this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void RotateFlip(
    RotateFlipType rotateFlipType
)
Visual Basic (Declaration)
Public Sub RotateFlip ( _
    rotateFlipType As RotateFlipType _
)
Visual C++
public:
void RotateFlip(
    RotateFlipType rotateFlipType
)

Parameters

rotateFlipType
Type: System.Drawing..::.RotateFlipType
A RotateFlipType member that specifies the type of rotation and flip to apply to this FreeImageBitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Save Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.Save Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
Save(String) | Saves this FreeImageBitmap to the specified file.
Save(Stream, FREE_IMAGE_FORMAT) | Saves this FreeImageBitmap to the specified stream in the specified format.
Save(String, FREE_IMAGE_FORMAT) | Saves this FreeImageBitmap to the specified file in the specified format.
Save(Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS) | Saves this FreeImageBitmap to the specified stream in the specified format using the specified saving flags.
Save(String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS) | Saves this FreeImageBitmap to the specified file in the specified format using the specified saving flags.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


Save Method (String)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Save Method (String)
FreeImageBitmap Class See Also Send Feedback
Saves this FreeImageBitmap to the specified file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Save(
    string filename
)
Visual Basic (Declaration)
Public Sub Save ( _
    filename As String _
)
Visual C++
public:
void Save(
    String^ filename
)

Parameters

filename
Type: System..::.String
A string that contains the name of the file to which to save this FreeImageBitmap.

Exceptions

Exception | Condition
System..::.ArgumentException | filename is null or empty.
System..::.Exception | Saving the image failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Save Overload


Save Method (Stream, FREE_IMAGE_FORMAT)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Save Method (Stream, FREE_IMAGE_FORMAT)
FreeImageBitmap Class See Also Send Feedback
Saves this FreeImageBitmap to the specified stream in the specified format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Save(
    Stream stream,
    FREE_IMAGE_FORMAT format
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream, _
    format As FREE_IMAGE_FORMAT _
)
Visual C++
public:
void Save(
    Stream^ stream,
    FREE_IMAGE_FORMAT format
)

Parameters

stream
Type: System.IO..::.Stream
The stream where this FreeImageBitmap will be saved.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
An FREE_IMAGE_FORMAT that specifies the format of the saved image.

Exceptions

Exception | Condition
System..::.ArgumentNullException | stream is a null reference.
System..::.Exception | Saving the image failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Save Overload


Save Method (String, FREE_IMAGE_FORMAT)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Save Method (String, FREE_IMAGE_FORMAT)
FreeImageBitmap Class See Also Send Feedback
Saves this FreeImageBitmap to the specified file in the specified format.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Save(
    string filename,
    FREE_IMAGE_FORMAT format
)
Visual Basic (Declaration)
Public Sub Save ( _
    filename As String, _
    format As FREE_IMAGE_FORMAT _
)
Visual C++
public:
void Save(
    String^ filename,
    FREE_IMAGE_FORMAT format
)

Parameters

filename
Type: System..::.String
A string that contains the name of the file to which to save this FreeImageBitmap.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
An FREE_IMAGE_FORMAT that specifies the format of the saved image.

Exceptions

Exception | Condition
System..::.ArgumentException | filename is null or empty.
System..::.Exception | Saving the image failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Save Overload


Save Method (Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Save Method (Stream, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS)
FreeImageBitmap Class See Also Send Feedback
Saves this FreeImageBitmap to the specified stream in the specified format using the specified saving flags.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Save(
    Stream stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_SAVE_FLAGS _
)
Visual C++
public:
void Save(
    Stream^ stream,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

stream
Type: System.IO..::.Stream
The stream where this FreeImageBitmap will be saved.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
An FREE_IMAGE_FORMAT that specifies the format of the saved image.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Exceptions

Exception | Condition
System..::.ArgumentNullException | stream is a null reference.
System..::.Exception | Saving the image failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Save Overload


Save Method (String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Save Method (String, FREE_IMAGE_FORMAT, FREE_IMAGE_SAVE_FLAGS)
FreeImageBitmap Class See Also Send Feedback
Saves this FreeImageBitmap to the specified file in the specified format using the specified saving flags.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Save(
    string filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags
)
Visual Basic (Declaration)
Public Sub Save ( _
    filename As String, _
    format As FREE_IMAGE_FORMAT, _
    flags As FREE_IMAGE_SAVE_FLAGS _
)
Visual C++
public:
void Save(
    String^ filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_SAVE_FLAGS flags
)

Parameters

filename
Type: System..::.String
A string that contains the name of the file to which to save this FreeImageBitmap.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
An FREE_IMAGE_FORMAT that specifies the format of the saved image.
flags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Exceptions

Exception | Condition
System..::.ArgumentException | filename is null or empty.
System..::.Exception | Saving the image failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
Save Overload


SaveAdd Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap..::.SaveAdd Method
FreeImageBitmap Class See Also Send Feedback

Overload List

Name | Description
SaveAdd()()() | Adds a frame to the file specified in a previous call to the Save(String) method.
SaveAdd(FreeImageBitmap) | Adds a frame to the file specified in a previous call to the Save(String) method.
SaveAdd(String) | Adds a frame to the file specified.
SaveAdd(Int32) | Adds a frame to the file specified in a previous call to the Save(String) method.
SaveAdd(FreeImageBitmap, Int32) | Adds a frame to the file specified in a previous call to the Save(String) method.
SaveAdd(String, Int32) | Adds a frame to the file specified.
SaveAdd(String, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS) | Adds a frame to the file specified using the specified parameters.
SaveAdd(String, FreeImageBitmap, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS) | Adds a specified frame to the file specified using the specified parameters. Use this method to save selected frames from an to a multiple-frame image.
SaveAdd(String, Int32, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS) | Adds a frame to the file specified using the specified parameters.
SaveAdd(String, FreeImageBitmap, Int32, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS) | Adds a specified frame to the file specified using the specified parameters. Use this method to save selected frames from an image to a multiple-frame image.

See Also

FreeImageBitmap Class
FreeImageBitmap Members


SaveAdd Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SaveAdd Method
FreeImageBitmap Class See Also Send Feedback
Adds a frame to the file specified in a previous call to the Save(String) method.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SaveAdd()
Visual Basic (Declaration)
Public Sub SaveAdd
Visual C++
public:
void SaveAdd()

Exceptions

Exception | Condition
System..::.InvalidOperationException | This instance has not been saved to a file using Save(...) before.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
SaveAdd Overload


SaveAdd Method (FreeImageBitmap)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SaveAdd Method (FreeImageBitmap)
FreeImageBitmap Class See Also Send Feedback
Adds a frame to the file specified in a previous call to the Save(String) method.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SaveAdd(
    FreeImageBitmap bitmap
)
Visual Basic (Declaration)
Public Sub SaveAdd ( _
    bitmap As FreeImageBitmap _
)
Visual C++
public:
void SaveAdd(
    FreeImageBitmap^ bitmap
)

Parameters

bitmap
Type: FreeImageAPI..::.FreeImageBitmap
A FreeImageBitmap that contains the frame to add.

Exceptions

Exception | Condition
System..::.InvalidOperationException | This instance has not yet been saved to a file using the Save(...) method.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
SaveAdd Overload


SaveAdd Method (String)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SaveAdd Method (String)
FreeImageBitmap Class See Also Send Feedback
Adds a frame to the file specified.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SaveAdd(
    string filename
)
Visual Basic (Declaration)
Public Sub SaveAdd ( _
    filename As String _
)
Visual C++
public:
void SaveAdd(
    String^ filename
)

Parameters

filename
Type: System..::.String
File to add this frame to.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename is a null reference.
System.IO..::.FileNotFoundException | filename does not exist.
System..::.Exception | Saving the image has failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
SaveAdd Overload


SaveAdd Method (Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SaveAdd Method (Int32)
FreeImageBitmap Class See Also Send Feedback
Adds a frame to the file specified in a previous call to the Save(String) method.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SaveAdd(
    int insertPosition
)
Visual Basic (Declaration)
Public Sub SaveAdd ( _
    insertPosition As Integer _
)
Visual C++
public:
void SaveAdd(
    int insertPosition
)

Parameters

insertPosition
Type: System..::.Int32
The position at which the frame should be inserted.

Exceptions

Exception | Condition
System..::.InvalidOperationException | This instance has not yet been saved to a file using the Save(...) method.
System..::.ArgumentOutOfRangeException | insertPosition is out of range.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
SaveAdd Overload


SaveAdd Method (FreeImageBitmap, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SaveAdd Method (FreeImageBitmap, Int32)
FreeImageBitmap Class See Also Send Feedback
Adds a frame to the file specified in a previous call to the Save(String) method.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SaveAdd(
    FreeImageBitmap bitmap,
    int insertPosition
)
Visual Basic (Declaration)
Public Sub SaveAdd ( _
    bitmap As FreeImageBitmap, _
    insertPosition As Integer _
)
Visual C++
public:
void SaveAdd(
    FreeImageBitmap^ bitmap,
    int insertPosition
)

Parameters

bitmap
Type: FreeImageAPI..::.FreeImageBitmap
A FreeImageBitmap that contains the frame to add.
insertPosition
Type: System..::.Int32
The position at which the frame should be inserted.

Exceptions

Exception | Condition
System..::.InvalidOperationException | This instance has not yet been saved to a file using the Save(...) method.
System..::.ArgumentOutOfRangeException | insertPosition is out of range.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
SaveAdd Overload


SaveAdd Method (String, Int32)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SaveAdd Method (String, Int32)
FreeImageBitmap Class See Also Send Feedback
Adds a frame to the file specified.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SaveAdd(
    string filename,
    int insertPosition
)
Visual Basic (Declaration)
Public Sub SaveAdd ( _
    filename As String, _
    insertPosition As Integer _
)
Visual C++
public:
void SaveAdd(
    String^ filename,
    int insertPosition
)

Parameters

filename
Type: System..::.String
File to add this frame to.
insertPosition
Type: System..::.Int32
The position at which the frame should be inserted.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename is a null reference.
System.IO..::.FileNotFoundException | filename does not exist.
System..::.Exception | Saving the image has failed.
System..::.ArgumentOutOfRangeException | insertPosition is out of range.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
SaveAdd Overload


SaveAdd Method (String, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SaveAdd Method (String, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS)
FreeImageBitmap Class See Also Send Feedback
Adds a frame to the file specified using the specified parameters.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SaveAdd(
    string filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS loadFlags,
    FREE_IMAGE_SAVE_FLAGS saveFlags
)
Visual Basic (Declaration)
Public Sub SaveAdd ( _
    filename As String, _
    format As FREE_IMAGE_FORMAT, _
    loadFlags As FREE_IMAGE_LOAD_FLAGS, _
    saveFlags As FREE_IMAGE_SAVE_FLAGS _
)
Visual C++
public:
void SaveAdd(
    String^ filename,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS loadFlags,
    FREE_IMAGE_SAVE_FLAGS saveFlags
)

Parameters

filename
Type: System..::.String
File to add this frame to.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
loadFlags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.
saveFlags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename is a null reference.
System.IO..::.FileNotFoundException | filename does not exist.
System..::.Exception | Saving the image has failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
SaveAdd Overload


SaveAdd Method (String, FreeImageBitmap, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SaveAdd Method (String, FreeImageBitmap, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS)
FreeImageBitmap Class See Also Send Feedback
Adds a specified frame to the file specified using the specified parameters. Use this method to save selected frames from an to a multiple-frame image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void SaveAdd(
    string filename,
    FreeImageBitmap bitmap,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS loadFlags,
    FREE_IMAGE_SAVE_FLAGS saveFlags
)
Visual Basic (Declaration)
Public Shared Sub SaveAdd ( _
    filename As String, _
    bitmap As FreeImageBitmap, _
    format As FREE_IMAGE_FORMAT, _
    loadFlags As FREE_IMAGE_LOAD_FLAGS, _
    saveFlags As FREE_IMAGE_SAVE_FLAGS _
)
Visual C++
public:
static void SaveAdd(
    String^ filename,
    FreeImageBitmap^ bitmap,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS loadFlags,
    FREE_IMAGE_SAVE_FLAGS saveFlags
)

Parameters

filename
Type: System..::.String
File to add this frame to.
bitmap
Type: FreeImageAPI..::.FreeImageBitmap
A FreeImageBitmap that contains the frame to add.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
loadFlags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.
saveFlags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename or bitmap is null.
System.IO..::.FileNotFoundException | filename does not exist.
System..::.Exception | Saving the image failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
SaveAdd Overload


SaveAdd Method (String, Int32, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SaveAdd Method (String, Int32, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS)
FreeImageBitmap Class See Also Send Feedback
Adds a frame to the file specified using the specified parameters.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SaveAdd(
    string filename,
    int insertPosition,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS loadFlags,
    FREE_IMAGE_SAVE_FLAGS saveFlags
)
Visual Basic (Declaration)
Public Sub SaveAdd ( _
    filename As String, _
    insertPosition As Integer, _
    format As FREE_IMAGE_FORMAT, _
    loadFlags As FREE_IMAGE_LOAD_FLAGS, _
    saveFlags As FREE_IMAGE_SAVE_FLAGS _
)
Visual C++
public:
void SaveAdd(
    String^ filename,
    int insertPosition,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS loadFlags,
    FREE_IMAGE_SAVE_FLAGS saveFlags
)

Parameters

filename
Type: System..::.String
File to add this frame to.
insertPosition
Type: System..::.Int32
The position at which the frame should be inserted.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
loadFlags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.
saveFlags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename is a null reference.
System.IO..::.FileNotFoundException | filename does not exist.
System..::.Exception | Saving the image has failed.
System..::.ArgumentOutOfRangeException | insertPosition is out of range.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
SaveAdd Overload


SaveAdd Method (String, FreeImageBitmap, Int32, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS)

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SaveAdd Method (String, FreeImageBitmap, Int32, FREE_IMAGE_FORMAT, FREE_IMAGE_LOAD_FLAGS, FREE_IMAGE_SAVE_FLAGS)
FreeImageBitmap Class See Also Send Feedback
Adds a specified frame to the file specified using the specified parameters. Use this method to save selected frames from an image to a multiple-frame image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static void SaveAdd(
    string filename,
    FreeImageBitmap bitmap,
    int insertPosition,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS loadFlags,
    FREE_IMAGE_SAVE_FLAGS saveFlags
)
Visual Basic (Declaration)
Public Shared Sub SaveAdd ( _
    filename As String, _
    bitmap As FreeImageBitmap, _
    insertPosition As Integer, _
    format As FREE_IMAGE_FORMAT, _
    loadFlags As FREE_IMAGE_LOAD_FLAGS, _
    saveFlags As FREE_IMAGE_SAVE_FLAGS _
)
Visual C++
public:
static void SaveAdd(
    String^ filename,
    FreeImageBitmap^ bitmap,
    int insertPosition,
    FREE_IMAGE_FORMAT format,
    FREE_IMAGE_LOAD_FLAGS loadFlags,
    FREE_IMAGE_SAVE_FLAGS saveFlags
)

Parameters

filename
Type: System..::.String
File to add this frame to.
bitmap
Type: FreeImageAPI..::.FreeImageBitmap
A FreeImageBitmap that contains the frame to add.
insertPosition
Type: System..::.Int32
The position of the inserted frame.
format
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
Format of the image.
loadFlags
Type: FreeImageAPI..::.FREE_IMAGE_LOAD_FLAGS
Flags to enable or disable plugin-features.
saveFlags
Type: FreeImageAPI..::.FREE_IMAGE_SAVE_FLAGS
Flags to enable or disable plugin-features.

Exceptions

Exception | Condition
System..::.ArgumentNullException | filename or bitmap is null.
System.IO..::.FileNotFoundException | filename does not exist.
System..::.Exception | Saving the image failed.
System..::.ArgumentOutOfRangeException | insertPosition is out of range.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class
SaveAdd Overload


SelectActiveFrame Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SelectActiveFrame Method
FreeImageBitmap Class See Also Send Feedback
Selects the frame specified by the index.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SelectActiveFrame(
    int frameIndex
)
Visual Basic (Declaration)
Public Sub SelectActiveFrame ( _
    frameIndex As Integer _
)
Visual C++
public:
void SelectActiveFrame(
    int frameIndex
)

Parameters

frameIndex
Type: System..::.Int32
The index of the active frame.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | frameIndex is out of range.
System..::.Exception | The operation failed.
System..::.InvalidOperationException | The source of the bitmap is not available.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


SetChannel Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SetChannel Method
FreeImageBitmap Class See Also Send Feedback
Insert a 8-bit dib into a 24- or 32-bit image. Both images must have to same width and height.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool SetChannel(
    FreeImageBitmap bitmap,
    FREE_IMAGE_COLOR_CHANNEL channel
)
Visual Basic (Declaration)
Public Function SetChannel ( _
    bitmap As FreeImageBitmap, _
    channel As FREE_IMAGE_COLOR_CHANNEL _
) As Boolean
Visual C++
public:
bool SetChannel(
    FreeImageBitmap^ bitmap,
    FREE_IMAGE_COLOR_CHANNEL channel
)

Parameters

bitmap
Type: FreeImageAPI..::.FreeImageBitmap
The FreeImageBitmap to insert.
channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
The color channel to replace.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


SetComplexChannel Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SetComplexChannel Method
FreeImageBitmap Class See Also Send Feedback
Set the real or imaginary part of a complex image. Both images must have to same width and height.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool SetComplexChannel(
    FreeImageBitmap bitmap,
    FREE_IMAGE_COLOR_CHANNEL channel
)
Visual Basic (Declaration)
Public Function SetComplexChannel ( _
    bitmap As FreeImageBitmap, _
    channel As FREE_IMAGE_COLOR_CHANNEL _
) As Boolean
Visual C++
public:
bool SetComplexChannel(
    FreeImageBitmap^ bitmap,
    FREE_IMAGE_COLOR_CHANNEL channel
)

Parameters

bitmap
Type: FreeImageAPI..::.FreeImageBitmap
The FreeImageBitmap to insert.
channel
Type: FreeImageAPI..::.FREE_IMAGE_COLOR_CHANNEL
The color channel to replace.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


SetPixel Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SetPixel Method
FreeImageBitmap Class See Also Send Feedback
Sets the Color of the specified pixel in this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SetPixel(
    int x,
    int y,
    Color color
)
Visual Basic (Declaration)
Public Sub SetPixel ( _
    x As Integer, _
    y As Integer, _
    color As Color _
)
Visual C++
public:
void SetPixel(
    int x,
    int y,
    Color color
)

Parameters

x
Type: System..::.Int32
The x-coordinate of the pixel to set.
y
Type: System..::.Int32
The y-coordinate of the pixel to set.
color
Type: System.Drawing..::.Color
A Color structure that represents the color to assign to the specified pixel.

Exceptions

Exception | Condition
System..::.Exception | The operation failed.
System..::.NotSupportedException | The type of this bitmap is not supported.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


SetResolution Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SetResolution Method
FreeImageBitmap Class See Also Send Feedback
Sets the resolution for this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SetResolution(
    float xDpi,
    float yDpi
)
Visual Basic (Declaration)
Public Sub SetResolution ( _
    xDpi As Single, _
    yDpi As Single _
)
Visual C++
public:
void SetResolution(
    float xDpi,
    float yDpi
)

Parameters

xDpi
Type: System..::.Single
The horizontal resolution, in dots per inch, of this FreeImageBitmap.
yDpi
Type: System..::.Single
The vertical resolution, in dots per inch, of this FreeImageBitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


SwapColors Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SwapColors Method
FreeImageBitmap Class See Also Send Feedback
Swaps two specified colors on a 1-, 4- or 8-bit palletized or a 16-, 24- or 32-bit high color image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint SwapColors(
    RGBQUAD color_a,
    RGBQUAD color_b,
    bool ignore_alpha
)
Visual Basic (Declaration)
Public Function SwapColors ( _
    color_a As RGBQUAD, _
    color_b As RGBQUAD, _
    ignore_alpha As Boolean _
) As UInteger
Visual C++
public:
unsigned int SwapColors(
    RGBQUAD color_a,
    RGBQUAD color_b,
    bool ignore_alpha
)

Parameters

color_a
Type: FreeImageAPI..::.RGBQUAD
One of the two colors to be swapped.
color_b
Type: FreeImageAPI..::.RGBQUAD
The other of the two colors to be swapped.
ignore_alpha
Type: System..::.Boolean
If true, 32-bit images and colors are treated as 24-bit.

Return Value

The total number of pixels changed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


SwapPaletteIndices Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.SwapPaletteIndices Method
FreeImageBitmap Class See Also Send Feedback
Swaps two specified palette indices on a 1-, 4- or 8-bit palletized image.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint SwapPaletteIndices(
    byte index_a,
    byte index_b
)
Visual Basic (Declaration)
Public Function SwapPaletteIndices ( _
    index_a As Byte, _
    index_b As Byte _
) As UInteger
Visual C++
public:
unsigned int SwapPaletteIndices(
    unsigned char index_a,
    unsigned char index_b
)

Parameters

index_a
Type: System..::.Byte
One of the two palette indices to be swapped.
index_b
Type: System..::.Byte
The other of the two palette indices to be swapped.

Return Value

The total number of pixels changed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


TmoDrago03 Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.TmoDrago03 Method
FreeImageBitmap Class See Also Send Feedback
Converts a High Dynamic Range image to a 24-bit RGB image using a global operator based on logarithmic compression of luminance values, imitating the human response to light.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool TmoDrago03(
    double gamma,
    double exposure
)
Visual Basic (Declaration)
Public Function TmoDrago03 ( _
    gamma As Double, _
    exposure As Double _
) As Boolean
Visual C++
public:
bool TmoDrago03(
    double gamma,
    double exposure
)

Parameters

gamma
Type: System..::.Double
A gamma correction that is applied after the tone mapping. A value of 1 means no correction.
exposure
Type: System..::.Double
Scale factor allowing to adjust the brightness of the output image.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


TmoFattal02 Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.TmoFattal02 Method
FreeImageBitmap Class See Also Send Feedback
Apply the Gradient Domain High Dynamic Range Compression to a RGBF image and convert to 24-bit RGB.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool TmoFattal02(
    double color_saturation,
    double attenuation
)
Visual Basic (Declaration)
Public Function TmoFattal02 ( _
    color_saturation As Double, _
    attenuation As Double _
) As Boolean
Visual C++
public:
bool TmoFattal02(
    double color_saturation,
    double attenuation
)

Parameters

color_saturation
Type: System..::.Double
Color saturation (s parameter in the paper) in [0.4..0.6]
attenuation
Type: System..::.Double
Atenuation factor (beta parameter in the paper) in [0.8..0.9]

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


TmoReinhard05 Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.TmoReinhard05 Method
FreeImageBitmap Class See Also Send Feedback
Converts a High Dynamic Range image to a 24-bit RGB image using a global operator inspired by photoreceptor physiology of the human visual system.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool TmoReinhard05(
    double intensity,
    double contrast
)
Visual Basic (Declaration)
Public Function TmoReinhard05 ( _
    intensity As Double, _
    contrast As Double _
) As Boolean
Visual C++
public:
bool TmoReinhard05(
    double intensity,
    double contrast
)

Parameters

intensity
Type: System..::.Double
Controls the overall image intensity in the range [-8, 8].
contrast
Type: System..::.Double
Controls the overall image contrast in the range [0.3, 1.0[.

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


ToBitmap Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.ToBitmap Method
FreeImageBitmap Class See Also Send Feedback
Converts this FreeImageBitmap instance to a Bitmap instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Bitmap ToBitmap()
Visual Basic (Declaration)
Public Function ToBitmap As Bitmap
Visual C++
public:
Bitmap^ ToBitmap()

Return Value

A new instance of Bitmap initialized this instance.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


UnlockBits Method

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.UnlockBits Method
FreeImageBitmap Class See Also Send Feedback
This function is not yet implemented.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void UnlockBits(
    BitmapData bitmapdata
)
Visual Basic (Declaration)
Public Sub UnlockBits ( _
    bitmapdata As BitmapData _
)
Visual C++
public:
void UnlockBits(
    BitmapData^ bitmapdata
)

Parameters

bitmapdata
Type: System.Drawing.Imaging..::.BitmapData

Exceptions

Exception | Condition
System..::.NotImplementedException | This method is not implemented.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


FreeImageBitmap Properties

[image] [image] [image]

FreeImage .NET Documentation
FreeImageBitmap Properties
FreeImageBitmap Class See Also Send Feedback

The FreeImageBitmap type exposes the following members.

Properties

Name | Description
BackgroundColor | Gets or sets the background color of this FreeImageBitmap. In case the value is null, the background color is removed.
Bits | Pointer to the data-bits of this FreeImageBitmap.
BlueMask | Bit pattern describing the blue color component of a pixel in this FreeImageBitmap.
ColorDepth | The size of one pixel in the bitmap in bits.
ColorsUsed | Number of palette entries.
ColorType | Investigates the color type of this FreeImageBitmap by reading the bitmaps pixel bits and analysing them.
Comment | Gets or sets the comment of this FreeImageBitmap. Supported formats are JPEG, PNG and GIF.
DataSize | Size of the bitmap in memory.
Flags | Gets attribute flags for the pixel data of this FreeImageBitmap.
FrameCount | Gets the number of frames in this FreeImageBitmap.
GreenMask | Bit pattern describing the green color component of a pixel in this FreeImageBitmap.
HasBackgroundColor | Gets whether this FreeImageBitmap has a file background color.
HasPalette | Returns whether this FreeImageBitmap has a palette.
Height | Height of the bitmap in pixel units.
HorizontalResolution | Gets the horizontal resolution, in pixels per inch, of this FreeImageBitmap.
ICCProfile | Gets the ICCProfile structure of this FreeImageBitmap.
ImageFormat | Gets the format of the original image in case this FreeImageBitmap was loaded from a file or stream.
ImageType | Type of the bitmap.
Info | Returns the BITMAPINFO structure of a this FreeImageBitmap.
InfoHeader | Returns the BITMAPINFOHEADER structure of this FreeImageBitmap.
IsDisposed | Gets whether this FreeImageBitmap has been disposed.
IsRGB555 | Gets whether the bitmap is RGB 555.
IsRGB565 | Gets whether the bitmap is RGB 565.
IsTransparent | Gets or sets whether this FreeImageBitmap is transparent.
Line | Width, in bytes, of this FreeImageBitmap.
Metadata | Gets a new instance of a metadata representing class.
Palette | Returns a structure that represents the palette of a FreeImage bitmap.
PhysicalDimension | Gets the width and height of this FreeImageBitmap.
Pitch | Returns the width of the bitmap in bytes, rounded to the next 32-bit boundary.
PixelFormat | Gets the pixel format for this FreeImageBitmap.
PropertyIdList | Gets IDs of the property items stored in this FreeImageBitmap.
PropertyItems | Gets all the property items (pieces of metadata) stored in this FreeImageBitmap.
RawFormat | Gets the format of this FreeImageBitmap.
RedMask | Bit pattern describing the red color component of a pixel in this FreeImageBitmap.
Scan0 | Pointer to the scanline of the top most pixel row of this FreeImageBitmap.
Size | Gets the width and height, in pixels, of this FreeImageBitmap.
Stride | Width, in bytes, of this FreeImageBitmap. In case this FreeImageBitmap is top down Stride will be positive, else negative.
Tag | Gets or sets an object that provides additional data about the FreeImageBitmap.
TransparencyCount | Number of transparent colors in a palletised FreeImageBitmap.
TransparencyTable | Get or sets transparency table of this FreeImageBitmap.
TransparentIndex | Gets or sets the entry used as transparent color in this FreeImageBitmap. Only works for 1-, 4- and 8-bpp.
UniqueColors | The number of unique colors actually used by the bitmap. This might be different from what ColorsUsed returns, which actually returns the palette size for palletised images. Works for FIT_BITMAP type bitmaps only.
VerticalResolution | Gets the vertical resolution, in pixels per inch, of this FreeImageBitmap.
Width | Width of the bitmap in pixel units.

See Also

FreeImageBitmap Class


BackgroundColor Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.BackgroundColor Property
FreeImageBitmap Class See Also Send Feedback
Gets or sets the background color of this FreeImageBitmap. In case the value is null, the background color is removed.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<Color> BackgroundColor { get; set; }
Visual Basic (Declaration)
Public Property BackgroundColor As Nullable(Of Color)
Visual C++
public:
property Nullable<Color> BackgroundColor {
    Nullable<Color> get ();
    void set (Nullable<Color> value);
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | Get: There is no background color available.
System..::.Exception | Set: Setting background color failed.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Bits Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Bits Property
FreeImageBitmap Class See Also Send Feedback
Pointer to the data-bits of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IntPtr Bits { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bits As IntPtr
Visual C++
public:
property IntPtr Bits {
    IntPtr get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


BlueMask Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.BlueMask Property
FreeImageBitmap Class See Also Send Feedback
Bit pattern describing the blue color component of a pixel in this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint BlueMask { get; }
Visual Basic (Declaration)
Public ReadOnly Property BlueMask As UInteger
Visual C++
public:
property unsigned int BlueMask {
    unsigned int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


ColorDepth Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.ColorDepth Property
FreeImageBitmap Class See Also Send Feedback
The size of one pixel in the bitmap in bits.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int ColorDepth { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColorDepth As Integer
Visual C++
public:
property int ColorDepth {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


ColorsUsed Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.ColorsUsed Property
FreeImageBitmap Class See Also Send Feedback
Number of palette entries.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int ColorsUsed { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColorsUsed As Integer
Visual C++
public:
property int ColorsUsed {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


ColorType Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.ColorType Property
FreeImageBitmap Class See Also Send Feedback
Investigates the color type of this FreeImageBitmap by reading the bitmaps pixel bits and analysing them.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FREE_IMAGE_COLOR_TYPE ColorType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColorType As FREE_IMAGE_COLOR_TYPE
Visual C++
public:
property FREE_IMAGE_COLOR_TYPE ColorType {
    FREE_IMAGE_COLOR_TYPE get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Comment Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Comment Property
FreeImageBitmap Class See Also Send Feedback
Gets or sets the comment of this FreeImageBitmap. Supported formats are JPEG, PNG and GIF.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Comment { get; set; }
Visual Basic (Declaration)
Public Property Comment As String
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


DataSize Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.DataSize Property
FreeImageBitmap Class See Also Send Feedback
Size of the bitmap in memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int DataSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataSize As Integer
Visual C++
public:
property int DataSize {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Flags Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Flags Property
FreeImageBitmap Class See Also Send Feedback
Gets attribute flags for the pixel data of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Flags { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flags As Integer
Visual C++
public:
property int Flags {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


FrameCount Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.FrameCount Property
FreeImageBitmap Class See Also Send Feedback
Gets the number of frames in this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int FrameCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property FrameCount As Integer
Visual C++
public:
property int FrameCount {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


GreenMask Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.GreenMask Property
FreeImageBitmap Class See Also Send Feedback
Bit pattern describing the green color component of a pixel in this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint GreenMask { get; }
Visual Basic (Declaration)
Public ReadOnly Property GreenMask As UInteger
Visual C++
public:
property unsigned int GreenMask {
    unsigned int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


HasBackgroundColor Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.HasBackgroundColor Property
FreeImageBitmap Class See Also Send Feedback
Gets whether this FreeImageBitmap has a file background color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool HasBackgroundColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasBackgroundColor As Boolean
Visual C++
public:
property bool HasBackgroundColor {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


HasPalette Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.HasPalette Property
FreeImageBitmap Class See Also Send Feedback
Returns whether this FreeImageBitmap has a palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool HasPalette { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasPalette As Boolean
Visual C++
public:
property bool HasPalette {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Height Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Height Property
FreeImageBitmap Class See Also Send Feedback
Height of the bitmap in pixel units.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Height { get; }
Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


HorizontalResolution Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.HorizontalResolution Property
FreeImageBitmap Class See Also Send Feedback
Gets the horizontal resolution, in pixels per inch, of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public float HorizontalResolution { get; private set; }
Visual Basic (Declaration)
Public Property HorizontalResolution As Single
Visual C++
public:
property float HorizontalResolution {
    float get ();
    void set (float value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


ICCProfile Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.ICCProfile Property
FreeImageBitmap Class See Also Send Feedback
Gets the ICCProfile structure of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIICCPROFILE ICCProfile { get; }
Visual Basic (Declaration)
Public ReadOnly Property ICCProfile As FIICCPROFILE
Visual C++
public:
property FIICCPROFILE ICCProfile {
    FIICCPROFILE get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


ImageFormat Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.ImageFormat Property
FreeImageBitmap Class See Also Send Feedback
Gets the format of the original image in case this FreeImageBitmap was loaded from a file or stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FREE_IMAGE_FORMAT ImageFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property ImageFormat As FREE_IMAGE_FORMAT
Visual C++
public:
property FREE_IMAGE_FORMAT ImageFormat {
    FREE_IMAGE_FORMAT get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


ImageType Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.ImageType Property
FreeImageBitmap Class See Also Send Feedback
Type of the bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FREE_IMAGE_TYPE ImageType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ImageType As FREE_IMAGE_TYPE
Visual C++
public:
property FREE_IMAGE_TYPE ImageType {
    FREE_IMAGE_TYPE get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Info Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Info Property
FreeImageBitmap Class See Also Send Feedback
Returns the BITMAPINFO structure of a this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public BITMAPINFO Info { get; }
Visual Basic (Declaration)
Public ReadOnly Property Info As BITMAPINFO
Visual C++
public:
property BITMAPINFO Info {
    BITMAPINFO get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


InfoHeader Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.InfoHeader Property
FreeImageBitmap Class See Also Send Feedback
Returns the BITMAPINFOHEADER structure of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public BITMAPINFOHEADER InfoHeader { get; }
Visual Basic (Declaration)
Public ReadOnly Property InfoHeader As BITMAPINFOHEADER
Visual C++
public:
property BITMAPINFOHEADER InfoHeader {
    BITMAPINFOHEADER get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


IsDisposed Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.IsDisposed Property
FreeImageBitmap Class See Also Send Feedback
Gets whether this FreeImageBitmap has been disposed.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsDisposed { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
Visual C++
public:
property bool IsDisposed {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


IsRGB555 Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.IsRGB555 Property
FreeImageBitmap Class See Also Send Feedback
Gets whether the bitmap is RGB 555.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsRGB555 { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRGB555 As Boolean
Visual C++
public:
property bool IsRGB555 {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


IsRGB565 Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.IsRGB565 Property
FreeImageBitmap Class See Also Send Feedback
Gets whether the bitmap is RGB 565.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsRGB565 { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRGB565 As Boolean
Visual C++
public:
property bool IsRGB565 {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


IsTransparent Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.IsTransparent Property
FreeImageBitmap Class See Also Send Feedback
Gets or sets whether this FreeImageBitmap is transparent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsTransparent { get; set; }
Visual Basic (Declaration)
Public Property IsTransparent As Boolean
Visual C++
public:
property bool IsTransparent {
    bool get ();
    void set (bool value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Line Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Line Property
FreeImageBitmap Class See Also Send Feedback
Width, in bytes, of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Line { get; }
Visual Basic (Declaration)
Public ReadOnly Property Line As Integer
Visual C++
public:
property int Line {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Metadata Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Metadata Property
FreeImageBitmap Class See Also Send Feedback
Gets a new instance of a metadata representing class.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ImageMetadata Metadata { get; }
Visual Basic (Declaration)
Public ReadOnly Property Metadata As ImageMetadata
Visual C++
public:
property ImageMetadata^ Metadata {
    ImageMetadata^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Palette Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Palette Property
FreeImageBitmap Class See Also Send Feedback
Returns a structure that represents the palette of a FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Palette Palette { get; }
Visual Basic (Declaration)
Public ReadOnly Property Palette As Palette
Visual C++
public:
property Palette^ Palette {
    Palette^ get ();
}

Exceptions

Exception | Condition
System..::.InvalidOperationException | HasPalette is false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


PhysicalDimension Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.PhysicalDimension Property
FreeImageBitmap Class See Also Send Feedback
Gets the width and height of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public SizeF PhysicalDimension { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhysicalDimension As SizeF
Visual C++
public:
property SizeF PhysicalDimension {
    SizeF get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Pitch Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Pitch Property
FreeImageBitmap Class See Also Send Feedback
Returns the width of the bitmap in bytes, rounded to the next 32-bit boundary.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Pitch { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pitch As Integer
Visual C++
public:
property int Pitch {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


PixelFormat Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.PixelFormat Property
FreeImageBitmap Class See Also Send Feedback
Gets the pixel format for this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public PixelFormat PixelFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property PixelFormat As PixelFormat
Visual C++
public:
property PixelFormat PixelFormat {
    PixelFormat get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


PropertyIdList Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.PropertyIdList Property
FreeImageBitmap Class See Also Send Feedback
Gets IDs of the property items stored in this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int[] PropertyIdList { get; }
Visual Basic (Declaration)
Public ReadOnly Property PropertyIdList As Integer()
Visual C++
public:
property array<int>^ PropertyIdList {
    array<int>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


PropertyItems Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.PropertyItems Property
FreeImageBitmap Class See Also Send Feedback
Gets all the property items (pieces of metadata) stored in this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public PropertyItem[] PropertyItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property PropertyItems As PropertyItem()
Visual C++
public:
property array<PropertyItem^>^ PropertyItems {
    array<PropertyItem^>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


RawFormat Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.RawFormat Property
FreeImageBitmap Class See Also Send Feedback
Gets the format of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ImageFormat RawFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property RawFormat As ImageFormat
Visual C++
public:
property ImageFormat^ RawFormat {
    ImageFormat^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


RedMask Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.RedMask Property
FreeImageBitmap Class See Also Send Feedback
Bit pattern describing the red color component of a pixel in this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint RedMask { get; }
Visual Basic (Declaration)
Public ReadOnly Property RedMask As UInteger
Visual C++
public:
property unsigned int RedMask {
    unsigned int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Scan0 Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Scan0 Property
FreeImageBitmap Class See Also Send Feedback
Pointer to the scanline of the top most pixel row of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IntPtr Scan0 { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scan0 As IntPtr
Visual C++
public:
property IntPtr Scan0 {
    IntPtr get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Size Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Size Property
FreeImageBitmap Class See Also Send Feedback
Gets the width and height, in pixels, of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Size Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As Size
Visual C++
public:
property Size Size {
    Size get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Stride Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Stride Property
FreeImageBitmap Class See Also Send Feedback
Width, in bytes, of this FreeImageBitmap. In case this FreeImageBitmap is top down Stride will be positive, else negative.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Stride { get; }
Visual Basic (Declaration)
Public ReadOnly Property Stride As Integer
Visual C++
public:
property int Stride {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Tag Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Tag Property
FreeImageBitmap Class See Also Send Feedback
Gets or sets an object that provides additional data about the FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Object Tag { get; set; }
Visual Basic (Declaration)
Public Property Tag As Object
Visual C++
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


TransparencyCount Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.TransparencyCount Property
FreeImageBitmap Class See Also Send Feedback
Number of transparent colors in a palletised FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int TransparencyCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property TransparencyCount As Integer
Visual C++
public:
property int TransparencyCount {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


TransparencyTable Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.TransparencyTable Property
FreeImageBitmap Class See Also Send Feedback
Get or sets transparency table of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] TransparencyTable { get; set; }
Visual Basic (Declaration)
Public Property TransparencyTable As Byte()
Visual C++
public:
property array<unsigned char>^ TransparencyTable {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


TransparentIndex Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.TransparentIndex Property
FreeImageBitmap Class See Also Send Feedback
Gets or sets the entry used as transparent color in this FreeImageBitmap. Only works for 1-, 4- and 8-bpp.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int TransparentIndex { get; set; }
Visual Basic (Declaration)
Public Property TransparentIndex As Integer
Visual C++
public:
property int TransparentIndex {
    int get ();
    void set (int value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


UniqueColors Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.UniqueColors Property
FreeImageBitmap Class See Also Send Feedback
The number of unique colors actually used by the bitmap. This might be different from what ColorsUsed returns, which actually returns the palette size for palletised images. Works for FIT_BITMAP type bitmaps only.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int UniqueColors { get; }
Visual Basic (Declaration)
Public ReadOnly Property UniqueColors As Integer
Visual C++
public:
property int UniqueColors {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


VerticalResolution Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.VerticalResolution Property
FreeImageBitmap Class See Also Send Feedback
Gets the vertical resolution, in pixels per inch, of this FreeImageBitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public float VerticalResolution { get; private set; }
Visual Basic (Declaration)
Public Property VerticalResolution As Single
Visual C++
public:
property float VerticalResolution {
    float get ();
    void set (float value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


Width Property

[image]

FreeImage .NET Documentation
FreeImageBitmap..::.Width Property
FreeImageBitmap Class See Also Send Feedback
Width of the bitmap in pixel units.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageBitmap Class


FreeImageEngine Class

[image]

FreeImage .NET Documentation
FreeImageEngine Class
Members See Also Send Feedback
Class handling non-bitmap related functions.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static class FreeImageEngine
Visual Basic (Declaration)
Public NotInheritable Class FreeImageEngine
Visual C++
public ref class FreeImageEngine abstract sealed

Inheritance Hierarchy

System..::.Object
FreeImageAPI..::.FreeImageEngine

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageEngine Members


FreeImageEngine Members

[image] [image] [image]

FreeImage .NET Documentation
FreeImageEngine Members
FreeImageEngine Class Properties Events See Also Send Feedback

The FreeImageEngine type exposes the following members.

Properties

Name | Description
CopyrightMessage | Gets a string containing a standard copyright message.
IsAvailable | Gets a value indicating if the FreeImage DLL is available or not.
IsLittleEndian | Gets whether the platform is using Little Endian.
Version | Gets a string containing the current version of the library.

Events

Name | Description
Message | Internal errors in FreeImage generate a logstring that can be captured by this event.

See Also

FreeImageEngine Class


FreeImageEngine Properties

[image] [image] [image]

FreeImage .NET Documentation
FreeImageEngine Properties
FreeImageEngine Class See Also Send Feedback

The FreeImageEngine type exposes the following members.

Properties

Name | Description
CopyrightMessage | Gets a string containing a standard copyright message.
IsAvailable | Gets a value indicating if the FreeImage DLL is available or not.
IsLittleEndian | Gets whether the platform is using Little Endian.
Version | Gets a string containing the current version of the library.

See Also

FreeImageEngine Class


CopyrightMessage Property

[image]

FreeImage .NET Documentation
FreeImageEngine..::.CopyrightMessage Property
FreeImageEngine Class See Also Send Feedback
Gets a string containing a standard copyright message.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string CopyrightMessage { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CopyrightMessage As String
Visual C++
public:
static property String^ CopyrightMessage {
    String^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageEngine Class


IsAvailable Property

[image]

FreeImage .NET Documentation
FreeImageEngine..::.IsAvailable Property
FreeImageEngine Class See Also Send Feedback
Gets a value indicating if the FreeImage DLL is available or not.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsAvailable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IsAvailable As Boolean
Visual C++
public:
static property bool IsAvailable {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageEngine Class


IsLittleEndian Property

[image]

FreeImage .NET Documentation
FreeImageEngine..::.IsLittleEndian Property
FreeImageEngine Class See Also Send Feedback
Gets whether the platform is using Little Endian.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool IsLittleEndian { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IsLittleEndian As Boolean
Visual C++
public:
static property bool IsLittleEndian {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageEngine Class


Version Property

[image]

FreeImage .NET Documentation
FreeImageEngine..::.Version Property
FreeImageEngine Class See Also Send Feedback
Gets a string containing the current version of the library.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static string Version { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Version As String
Visual C++
public:
static property String^ Version {
    String^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageEngine Class


FreeImageEngine Events

[image] [image] [image]

FreeImage .NET Documentation
FreeImageEngine Events
FreeImageEngine Class See Also Send Feedback

The FreeImageEngine type exposes the following members.

Events

Name | Description
Message | Internal errors in FreeImage generate a logstring that can be captured by this event.

See Also

FreeImageEngine Class


Message Event

[image]

FreeImage .NET Documentation
FreeImageEngine..::.Message Event
FreeImageEngine Class See Also Send Feedback
Internal errors in FreeImage generate a logstring that can be captured by this event.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static event OutputMessageFunction Message
Visual Basic (Declaration)
Public Shared Event Message As OutputMessageFunction
Visual C++
public:
static  event OutputMessageFunction^ Message {
    void add (OutputMessageFunction^ value);
    void remove (OutputMessageFunction^ value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageEngine Class


ICC_FLAGS Enumeration

[image]

FreeImage .NET Documentation
ICC_FLAGS Enumeration
See Also Send Feedback
Flags for ICC profiles.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[FlagsAttribute]
public enum ICC_FLAGS
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ICC_FLAGS
Visual C++
[FlagsAttribute]
public enum class ICC_FLAGS

Members

Member name | Description
FIICC_DEFAULT | Default value.
FIICC_COLOR_IS_CMYK | The color is CMYK.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


MD_SEARCH_FLAGS Enumeration

[image]

FreeImage .NET Documentation
MD_SEARCH_FLAGS Enumeration
See Also Send Feedback
List different search modes.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[FlagsAttribute]
public enum MD_SEARCH_FLAGS
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration MD_SEARCH_FLAGS
Visual C++
[FlagsAttribute]
public enum class MD_SEARCH_FLAGS

Members

Member name | Description
KEY | The key of the metadata.
DESCRIPTION | The description of the metadata
TOSTRING | The ToString value of the metadata

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


MemoryArray(T) Class

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>) Class
Members See Also Send Feedback
Represents unmanaged memory, containing an array of a given structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public class MemoryArray<T> : ICloneable,
    ICollection, IEnumerable<T>, IEnumerable, IEquatable<MemoryArray<T>>
where T : struct, new()
Visual Basic (Declaration)
Public Class MemoryArray(Of T As {Structure, New}) _
    Implements ICloneable, ICollection, IEnumerable(Of T),  _
    IEnumerable, IEquatable(Of MemoryArray(Of T))
Visual C++
generic<typename T>
where T : value class, gcnew()
public ref class MemoryArray : ICloneable,
    ICollection, IEnumerable<T>, IEnumerable, IEquatable<MemoryArray<T>^>

Type Parameters

T
Structuretype represented by the instance.

Remarks

Boolean and Char can not be marshalled.

Use Int32 instead of Boolean and Byte instead of Char.

Inheritance Hierarchy

System..::.Object
FreeImageAPI..::.MemoryArray<(Of <(T>)>)
FreeImageAPI..::.Palette
FreeImageAPI..::.Scanline<(Of <(T>)>)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Members


MemoryArray(T) Members

[image] [image] [image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>) Members
MemoryArray<(Of <(T>)>) Class Constructors Methods Fields Properties See Also Send Feedback

The MemoryArray<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
MemoryArray<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Clone | Creates a shallow copy of the MemoryArray<(Of <(T>)>).
CopyFrom | Copies a range of elements from the array starting at the specified sourceIndex and pastes them to the unmanaged array starting at the specified destinationIndex. The length and the indexes are specified as 32-bit integers.
CopyMemory | Copies a block of memory from one location to another.
CopyTo | Overloaded.
Dispose | Overloaded.
EnsureNotDisposed | Throws an ObjectDisposedException if this instance is disposed.
Equals | Overloaded.
Finalize | Frees the allocated GCHandle. (Overrides Object..::.Finalize()()().)
GetEnumerator | Retrieves an object that can iterate through the individual elements in this MemoryArray<(Of <(T>)>).
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetValue | Gets the value at the specified position.
GetValues | Gets the values at the specified position and length.
SetValue | Sets a value to the element at the specified position.
SetValues | Sets the values at the specified position.
ToByteArray | Returns the represented block of memory as an array of Byte.

Operators

Name | Description
Equality | Tests whether two specified MemoryArray<(Of <(T>)>) structures are equivalent.
Inequality | Tests whether two specified MemoryArray<(Of <(T>)>) structures are different.

Fields

Name | Description
baseAddress | Baseaddress of the wrapped memory.
buffer | Array of T containing a single element. The array is used as a workaround, because there are no pointer for generic types.
handle | Handle for pinning buffer.
isFourBit | Indicates whther the wrapped memory is handles like 4-bit blocks.
isOneBit | Indicates whether the wrapped memory is handled like a bitfield.
length | Number of elements being wrapped.
ptr | Pointer to the element of buffer.
size | Size, in bytes, of each element.
syncRoot | An object that can be used to synchronize access to the MemoryArray<(Of <(T>)>).

Properties

Name | Description
BaseAddress | Gets the base address of the represented memory block.
Count | Gets a 32-bit integer that represents the total number of elements in the MemoryArray<(Of <(T>)>).
Data | Gets or sets the values of the unmanaged array.
IsSynchronized | Gets a value indicating whether access to the MemoryArray<(Of <(T>)>) is synchronized (thread safe).
Item | Gets or sets the value at the specified position in the array.
Length | Gets the length of the unmanaged array.
SyncRoot | Gets an object that can be used to synchronize access to the MemoryArray<(Of <(T>)>).

See Also

MemoryArray<(Of <(T>)>) Class


MemoryArray(T) Constructor

[image] [image] [image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>) Constructor
MemoryArray<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
MemoryArray<(Of <(T>)>)()()() | Initializes a new instance.
MemoryArray<(Of <(T>)>)(IntPtr, Int32) | Initializes a new instance of the MemoryArray<(Of <(T>)>) class.
MemoryArray<(Of <(T>)>)(Void*, Int32) | Initializes a new instance of the MemoryArray<(Of <(T>)>) class.

See Also

MemoryArray<(Of <(T>)>) Class
MemoryArray<(Of <(T>)>) Members


MemoryArray(T) Constructor

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>) Constructor
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Initializes a new instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected MemoryArray()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
MemoryArray()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class
MemoryArray<(Of <(T>)>) Overload


MemoryArray(T) Constructor (IntPtr, Int32)

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>) Constructor (IntPtr, Int32)
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Initializes a new instance of the MemoryArray<(Of <(T>)>) class.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MemoryArray(
    IntPtr baseAddress,
    int length
)
Visual Basic (Declaration)
Public Sub New ( _
    baseAddress As IntPtr, _
    length As Integer _
)
Visual C++
public:
MemoryArray(
    IntPtr baseAddress,
    int length
)

Parameters

baseAddress
Type: System..::.IntPtr
Address of the memory block.
length
Type: System..::.Int32
Length of the array.

Exceptions

Exception | Condition
System..::.ArgumentNullException | baseAddress is null.
System..::.ArgumentOutOfRangeException | length is less or equal zero.
System..::.NotSupportedException | The type is not supported.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class
MemoryArray<(Of <(T>)>) Overload


MemoryArray(T) Constructor (Void*, Int32)

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>) Constructor (Void*, Int32)
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Initializes a new instance of the MemoryArray<(Of <(T>)>) class.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MemoryArray(
    void* baseAddress,
    int length
)
Visual Basic (Declaration)
Visual Basic does not support APIs that consume or return unsafe types.
Visual C++
public:
MemoryArray(
    void* baseAddress,
    int length
)

Parameters

baseAddress
Type: System..::.Void *
Address of the memory block.
length
Type: System..::.Int32
Length of the array.

Exceptions

Exception | Condition
System..::.ArgumentNullException | baseAddress is null.
System..::.ArgumentOutOfRangeException | length is less or equal zero.
System..::.NotSupportedException | The type is not supported.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class
MemoryArray<(Of <(T>)>) Overload


MemoryArray(T) Fields

[image] [image] [image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>) Fields
MemoryArray<(Of <(T>)>) Class See Also Send Feedback

The MemoryArray<(Of <(T>)>) type exposes the following members.

Fields

Name | Description
baseAddress | Baseaddress of the wrapped memory.
buffer | Array of T containing a single element. The array is used as a workaround, because there are no pointer for generic types.
handle | Handle for pinning buffer.
isFourBit | Indicates whther the wrapped memory is handles like 4-bit blocks.
isOneBit | Indicates whether the wrapped memory is handled like a bitfield.
length | Number of elements being wrapped.
ptr | Pointer to the element of buffer.
size | Size, in bytes, of each element.
syncRoot | An object that can be used to synchronize access to the MemoryArray<(Of <(T>)>).

See Also

MemoryArray<(Of <(T>)>) Class


baseAddress Field

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.baseAddress Field
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Baseaddress of the wrapped memory.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected readonly byte* baseAddress
Visual Basic (Declaration)
Visual Basic does not support APIs that consume or return unsafe types.
Visual C++
protected:
initonly unsigned char* baseAddress

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


buffer Field

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.buffer Field
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Array of T containing a single element. The array is used as a workaround, because there are no pointer for generic types.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected readonly T[] buffer
Visual Basic (Declaration)
Protected ReadOnly buffer As T()
Visual C++
protected:
initonly array<T>^ buffer

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


handle Field

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.handle Field
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Handle for pinning buffer.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected readonly GCHandle handle
Visual Basic (Declaration)
Protected ReadOnly handle As GCHandle
Visual C++
protected:
initonly GCHandle handle

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


isFourBit Field

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.isFourBit Field
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Indicates whther the wrapped memory is handles like 4-bit blocks.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected readonly bool isFourBit
Visual Basic (Declaration)
Protected ReadOnly isFourBit As Boolean
Visual C++
protected:
initonly bool isFourBit

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


isOneBit Field

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.isOneBit Field
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Indicates whether the wrapped memory is handled like a bitfield.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected readonly bool isOneBit
Visual Basic (Declaration)
Protected ReadOnly isOneBit As Boolean
Visual C++
protected:
initonly bool isOneBit

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


length Field

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.length Field
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Number of elements being wrapped.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected readonly int length
Visual Basic (Declaration)
Protected ReadOnly length As Integer
Visual C++
protected:
initonly int length

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


ptr Field

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.ptr Field
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Pointer to the element of buffer.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected readonly byte* ptr
Visual Basic (Declaration)
Visual Basic does not support APIs that consume or return unsafe types.
Visual C++
protected:
initonly unsigned char* ptr

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


size Field

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.size Field
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Size, in bytes, of each element.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected readonly int size
Visual Basic (Declaration)
Protected ReadOnly size As Integer
Visual C++
protected:
initonly int size

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

MemoryArray<(Of <(T>)>) Class


syncRoot Field

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.syncRoot Field
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
An object that can be used to synchronize access to the MemoryArray<(Of <(T>)>).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected Object syncRoot
Visual Basic (Declaration)
Protected syncRoot As Object
Visual C++
protected:
Object^ syncRoot

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


MemoryArray(T) Methods

[image] [image] [image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>) Methods
MemoryArray<(Of <(T>)>) Class See Also Send Feedback

The MemoryArray<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Clone | Creates a shallow copy of the MemoryArray<(Of <(T>)>).
CopyFrom | Copies a range of elements from the array starting at the specified sourceIndex and pastes them to the unmanaged array starting at the specified destinationIndex. The length and the indexes are specified as 32-bit integers.
CopyMemory | Copies a block of memory from one location to another.
CopyTo | Overloaded.
Dispose | Overloaded.
EnsureNotDisposed | Throws an ObjectDisposedException if this instance is disposed.
Equals | Overloaded.
Finalize | Frees the allocated GCHandle. (Overrides Object..::.Finalize()()().)
GetEnumerator | Retrieves an object that can iterate through the individual elements in this MemoryArray<(Of <(T>)>).
GetHashCode | Serves as a hash function for a particular type. (Overrides Object..::.GetHashCode()()().)
GetValue | Gets the value at the specified position.
GetValues | Gets the values at the specified position and length.
SetValue | Sets a value to the element at the specified position.
SetValues | Sets the values at the specified position.
ToByteArray | Returns the represented block of memory as an array of Byte.

Operators

Name | Description
Equality | Tests whether two specified MemoryArray<(Of <(T>)>) structures are equivalent.
Inequality | Tests whether two specified MemoryArray<(Of <(T>)>) structures are different.

See Also

MemoryArray<(Of <(T>)>) Class


Clone Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Clone Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Creates a shallow copy of the MemoryArray<(Of <(T>)>).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

A shallow copy of the MemoryArray<(Of <(T>)>).

Implements

ICloneable..::.Clone()()()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


CopyFrom Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.CopyFrom Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Copies a range of elements from the array starting at the specified sourceIndex and pastes them to the unmanaged array starting at the specified destinationIndex. The length and the indexes are specified as 32-bit integers.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CopyFrom(
    T[] array,
    int sourceIndex,
    int destinationIndex,
    int length
)
Visual Basic (Declaration)
Public Sub CopyFrom ( _
    array As T(), _
    sourceIndex As Integer, _
    destinationIndex As Integer, _
    length As Integer _
)
Visual C++
public:
void CopyFrom(
    array<T>^ array,
    int sourceIndex,
    int destinationIndex,
    int length
)

Parameters

array
Type: array< T >[]()[]
The array that holds the data.
sourceIndex
Type: System..::.Int32
A 32-bit integer that represents the index in the array at which copying begins.
destinationIndex
Type: System..::.Int32
A 32-bit integer that represents the index in the unmanaged array at which storing begins.
length
Type: System..::.Int32
A 32-bit integer that represents the number of elements to copy.

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is a null reference (Nothing in Visual Basic).
System..::.ArgumentOutOfRangeException | sourceIndex is outside the range of valid indexes for the array or length is greater than the number of elements from index to the end of the array -or- destinationIndex is outside the range of valid indexes for the unmanaged array or length is greater than the number of elements from index to the end of the unmanaged array.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


CopyMemory Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.CopyMemory Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Copies a block of memory from one location to another.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected static void CopyMemory(
    byte* dest,
    byte* src,
    int len
)
Visual Basic (Declaration)
Protected Shared Sub CopyMemory ( _
    dest As Byte*, _
    src As Byte*, _
    len As Integer _
)
Visual C++
protected:
static void CopyMemory(
    unsigned char* dest,
    unsigned char* src,
    int len
)

Parameters

dest
Type: System..::.Byte *
Pointer to the starting address of the copy destination.
src
Type: System..::.Byte *
Pointer to the starting address of the block of memory to be copied.
len
Type: System..::.Int32
Size of the block of memory to copy, in bytes.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


CopyTo Method

[image] [image] [image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.CopyTo Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
CopyTo(Array, Int32) | Copies the entire array to a compatible one-dimensional Array, starting at the specified index of the target array.
CopyTo(array<T>[]()[], Int32, Int32, Int32) | Copies a range of elements from the unmanaged array starting at the specified sourceIndex and pastes them to array starting at the specified destinationIndex. The length and the indexes are specified as 32-bit integers.

See Also

MemoryArray<(Of <(T>)>) Class
MemoryArray<(Of <(T>)>) Members


CopyTo Method (Array, Int32)

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.CopyTo Method (Array, Int32)
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Copies the entire array to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::.Array
The one-dimensional Array that is the destination of the elements copied from MemoryArray<(Of <(T>)>). The Array must have zero-based indexing.
index
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::.CopyTo(Array, Int32)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class
CopyTo Overload


CopyTo Method (T[], Int32, Int32, Int32)

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.CopyTo Method (array<T>[]()[], Int32, Int32, Int32)
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Copies a range of elements from the unmanaged array starting at the specified sourceIndex and pastes them to array starting at the specified destinationIndex. The length and the indexes are specified as 32-bit integers.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CopyTo(
    T[] array,
    int sourceIndex,
    int destinationIndex,
    int length
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As T(), _
    sourceIndex As Integer, _
    destinationIndex As Integer, _
    length As Integer _
)
Visual C++
public:
void CopyTo(
    array<T>^ array,
    int sourceIndex,
    int destinationIndex,
    int length
)

Parameters

array
Type: array< T >[]()[]
The array that receives the data.
sourceIndex
Type: System..::.Int32
A 32-bit integer that represents the index in the unmanaged array at which copying begins.
destinationIndex
Type: System..::.Int32
A 32-bit integer that represents the index in the destination array at which storing begins.
length
Type: System..::.Int32
A 32-bit integer that represents the number of elements to copy.

Exceptions

Exception | Condition
System..::.ArgumentNullException | array is a null reference (Nothing in Visual Basic).
System..::.ArgumentOutOfRangeException | sourceIndex is outside the range of valid indexes for the unmanaged array or length is greater than the number of elements from index to the end of the unmanaged array -or- destinationIndex is outside the range of valid indexes for the array or length is greater than the number of elements from index to the end of the array.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class
CopyTo Overload


Dispose Method

[image] [image] [image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Dispose Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all ressources.
Dispose(Boolean) | Releases allocated handles associated with this instance.

See Also

MemoryArray<(Of <(T>)>) Class
MemoryArray<(Of <(T>)>) Members


Dispose Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Dispose Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Releases all ressources.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class
Dispose Overload


Dispose Method (Boolean)

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Dispose Method (Boolean)
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Releases allocated handles associated with this instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true to release managed resources.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class
Dispose Overload


EnsureNotDisposed Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.EnsureNotDisposed Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Throws an ObjectDisposedException if this instance is disposed.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual void EnsureNotDisposed()
Visual Basic (Declaration)
Protected Overridable Sub EnsureNotDisposed
Visual C++
protected:
virtual void EnsureNotDisposed()

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


Equality Operator

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Equality Operator
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Tests whether two specified MemoryArray<(Of <(T>)>) structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    MemoryArray<T> left,
    MemoryArray<T> right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As MemoryArray(Of T), _
    right As MemoryArray(Of T) _
) As Boolean
Visual C++
public:
static bool operator ==(
    MemoryArray<T>^ left,
    MemoryArray<T>^ right
)

Parameters

left
Type: FreeImageAPI..::.MemoryArray <(Of <( T >)>)
The MemoryArray<(Of <(T>)>) that is to the left of the equality operator.
right
Type: FreeImageAPI..::.MemoryArray <(Of <( T >)>)
The MemoryArray<(Of <(T>)>) that is to the right of the equality operator.

Return Value

true if the two MemoryArray<(Of <(T>)>) structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Equals Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Equals(MemoryArray<(Of <(T>)>)) | Tests whether the specified MemoryArray<(Of <(T>)>) structure is equivalent to this MemoryArray<(Of <(T>)>) structure.
Equals(Object) | Tests whether the specified MemoryArray<(Of <(T>)>) structure is equivalent to this MemoryArray<(Of <(T>)>) structure. (Overrides Object..::.Equals(Object).)

See Also

MemoryArray<(Of <(T>)>) Class
MemoryArray<(Of <(T>)>) Members


Equals Method (MemoryArray(T))

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Equals Method (MemoryArray<(Of <(T>)>))
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Tests whether the specified MemoryArray<(Of <(T>)>) structure is equivalent to this MemoryArray<(Of <(T>)>) structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    MemoryArray<T> other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As MemoryArray(Of T) _
) As Boolean
Visual C++
public:
virtual bool Equals(
    MemoryArray<T>^ other
) sealed

Parameters

other
Type: FreeImageAPI..::.MemoryArray <(Of <( T >)>)
The structure to test.

Return Value

true if other is equivalent to this MemoryArray<(Of <(T>)>) structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Equals Method (Object)
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Tests whether the specified MemoryArray<(Of <(T>)>) structure is equivalent to this MemoryArray<(Of <(T>)>) structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The structure to test.

Return Value

true if obj is a MemoryArray<(Of <(T>)>) instance equivalent to this MemoryArray<(Of <(T>)>) structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class
Equals Overload


Finalize Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Finalize Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Frees the allocated GCHandle.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


GetEnumerator Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.GetEnumerator Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Retrieves an object that can iterate through the individual elements in this MemoryArray<(Of <(T>)>).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator for the MemoryArray<(Of <(T>)>).

Implements

IEnumerable..::.GetEnumerator()()()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


GetHashCode Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.GetHashCode Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Serves as a hash function for a particular type.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hash code for the current MemoryArray<(Of <(T>)>).

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


GetValue Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.GetValue Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Gets the value at the specified position.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public T GetValue(
    int index
)
Visual Basic (Declaration)
Public Function GetValue ( _
    index As Integer _
) As T
Visual C++
public:
T GetValue(
    int index
)

Parameters

index
Type: System..::.Int32
A 32-bit integer that represents the position of the array element to get.

Return Value

The value at the specified position.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is outside the range of valid indexes for the unmanaged array.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


GetValues Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.GetValues Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Gets the values at the specified position and length.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public T[] GetValues(
    int index,
    int length
)
Visual Basic (Declaration)
Public Function GetValues ( _
    index As Integer, _
    length As Integer _
) As T()
Visual C++
public:
array<T>^ GetValues(
    int index,
    int length
)

Parameters

index
Type: System..::.Int32
A 32-bit integer that represents the position of the array elements to get.
length
Type: System..::.Int32
A 32-bit integer that represents the length of the array elements to get.

Return Value

The values at the specified position and length.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is outside the range of valid indexes for the unmanaged array or length is greater than the number of elements from index to the end of the unmanaged array.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


Inequality Operator

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Inequality Operator
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Tests whether two specified MemoryArray<(Of <(T>)>) structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    MemoryArray<T> left,
    MemoryArray<T> right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As MemoryArray(Of T), _
    right As MemoryArray(Of T) _
) As Boolean
Visual C++
public:
static bool operator !=(
    MemoryArray<T>^ left,
    MemoryArray<T>^ right
)

Parameters

left
Type: FreeImageAPI..::.MemoryArray <(Of <( T >)>)
The MemoryArray<(Of <(T>)>) that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.MemoryArray <(Of <( T >)>)
The MemoryArray<(Of <(T>)>) that is to the right of the inequality operator.

Return Value

true if the two MemoryArray<(Of <(T>)>) structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


SetValue Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.SetValue Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Sets a value to the element at the specified position.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SetValue(
    T value,
    int index
)
Visual Basic (Declaration)
Public Sub SetValue ( _
    value As T, _
    index As Integer _
)
Visual C++
public:
void SetValue(
    T value,
    int index
)

Parameters

value
Type: T
The new value for the specified element.
index
Type: System..::.Int32
A 32-bit integer that represents the position of the array element to set.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is outside the range of valid indexes for the unmanaged array.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


SetValues Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.SetValues Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Sets the values at the specified position.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void SetValues(
    T[] values,
    int index
)
Visual Basic (Declaration)
Public Sub SetValues ( _
    values As T(), _
    index As Integer _
)
Visual C++
public:
void SetValues(
    array<T>^ values,
    int index
)

Parameters

values
Type: array< T >[]()[]
An array containing the new values for the specified elements.
index
Type: System..::.Int32
A 32-bit integer that represents the position of the array elements to set.

Exceptions

Exception | Condition
System..::.ArgumentNullException | values is a null reference (Nothing in Visual Basic).
System..::.ArgumentOutOfRangeException | index is outside the range of valid indexes for the unmanaged array or values.Length is greater than the number of elements from index to the end of the array.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


ToByteArray Method

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.ToByteArray Method
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Returns the represented block of memory as an array of Byte.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] ToByteArray()
Visual Basic (Declaration)
Public Function ToByteArray As Byte()
Visual C++
public:
array<unsigned char>^ ToByteArray()

Return Value

The represented block of memory.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


MemoryArray(T) Properties

[image] [image] [image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>) Properties
MemoryArray<(Of <(T>)>) Class See Also Send Feedback

The MemoryArray<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
BaseAddress | Gets the base address of the represented memory block.
Count | Gets a 32-bit integer that represents the total number of elements in the MemoryArray<(Of <(T>)>).
Data | Gets or sets the values of the unmanaged array.
IsSynchronized | Gets a value indicating whether access to the MemoryArray<(Of <(T>)>) is synchronized (thread safe).
Item | Gets or sets the value at the specified position in the array.
Length | Gets the length of the unmanaged array.
SyncRoot | Gets an object that can be used to synchronize access to the MemoryArray<(Of <(T>)>).

See Also

MemoryArray<(Of <(T>)>) Class


BaseAddress Property

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.BaseAddress Property
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Gets the base address of the represented memory block.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IntPtr BaseAddress { get; }
Visual Basic (Declaration)
Public ReadOnly Property BaseAddress As IntPtr
Visual C++
public:
property IntPtr BaseAddress {
    IntPtr get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


Count Property

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Count Property
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Gets a 32-bit integer that represents the total number of elements in the MemoryArray<(Of <(T>)>).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


Data Property

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Data Property
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Gets or sets the values of the unmanaged array.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public T[] Data { get; set; }
Visual Basic (Declaration)
Public Property Data As T()
Visual C++
public:
property array<T>^ Data {
    array<T>^ get ();
    void set (array<T>^ value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


IsSynchronized Property

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.IsSynchronized Property
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Gets a value indicating whether access to the MemoryArray<(Of <(T>)>) is synchronized (thread safe).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Implements

ICollection..::.IsSynchronized

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


Item Property

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Item Property
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Gets or sets the value at the specified position in the array.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public T this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As T
Visual C++
public:
property T default[int index] {
    T get (int index);
    void set (int index, T value);
}

Parameters

index
Type: System..::.Int32
A 32-bit integer that represents the position of the array element to get.

Return Value

The value at the specified position in the array.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is outside the range of valid indexes for the unmanaged array.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


Length Property

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.Length Property
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Gets the length of the unmanaged array.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
Visual C++
public:
property int Length {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


SyncRoot Property

[image]

FreeImage .NET Documentation
MemoryArray<(Of <(T>)>)..::.SyncRoot Property
MemoryArray<(Of <(T>)>) Class See Also Send Feedback
Gets an object that can be used to synchronize access to the MemoryArray<(Of <(T>)>).

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Implements

ICollection..::.SyncRoot

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MemoryArray<(Of <(T>)>) Class


OutputMessageFunction Delegate

[image]

FreeImage .NET Documentation
OutputMessageFunction Delegate
See Also Send Feedback
Delegate for capturing FreeImage error messages.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate void OutputMessageFunction(
    FREE_IMAGE_FORMAT fif,
    string message
)
Visual Basic (Declaration)
Public Delegate Sub OutputMessageFunction ( _
    fif As FREE_IMAGE_FORMAT, _
    message As String _
)
Visual C++
public delegate void OutputMessageFunction(
    FREE_IMAGE_FORMAT fif,
    String^ message
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The format of the image.
message
Type: System..::.String
The errormessage.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also


Palette Class

[image]

FreeImage .NET Documentation
Palette Class
Members See Also Send Feedback
Provides methods for working with the standard bitmap palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class Palette : MemoryArray<RGBQUAD>
Visual Basic (Declaration)
Public NotInheritable Class Palette _
    Inherits MemoryArray(Of RGBQUAD)
Visual C++
public ref class Palette sealed : public MemoryArray<RGBQUAD>

Inheritance Hierarchy

System..::.Object
FreeImageAPI..::.MemoryArray <(Of <( RGBQUAD >)>)
FreeImageAPI..::.Palette

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Members


Palette Members

[image] [image] [image]

FreeImage .NET Documentation
Palette Members
Palette Class Constructors Methods Properties See Also Send Feedback

The Palette type exposes the following members.

Constructors

Name | Description
Palette | Overloaded.

Methods

Name | Description
Clone | Creates a shallow copy of the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
Colorize | Overloaded.
CopyFrom | Overloaded.
CopyTo | Overloaded.
CreateGrayscalePalette | Overloaded.
Dispose | Releases all ressources. (Inherited from MemoryArray<(Of <(T>)>).)
Equals | Overloaded.
GetEnumerator | Retrieves an object that can iterate through the individual elements in this MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from MemoryArray<(Of <(T>)>).)
GetValue | Gets the value at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
GetValues | Gets the values at the specified position and length. (Inherited from MemoryArray<(Of <(T>)>).)
Load | Overloaded.
Reverse | Reverses the palette.
Save | Overloaded.
SetValue | Sets a value to the element at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
SetValues | Sets the values at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
ToArray | Returns the palette as an array of RGBQUAD.
ToByteArray | Returns the represented block of memory as an array of Byte. (Inherited from MemoryArray<(Of <(T>)>).)

Properties

Name | Description
AsArray | Gets or sets the palette through an array of RGBQUAD.
BaseAddress | Gets the base address of the represented memory block. (Inherited from MemoryArray<(Of <(T>)>).)
Count | Gets a 32-bit integer that represents the total number of elements in the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
Data | Gets or sets the values of the unmanaged array. (Inherited from MemoryArray<(Of <(T>)>).)
IsSynchronized | Gets a value indicating whether access to the MemoryArray<(Of <(T>)>) is synchronized (thread safe). (Inherited from MemoryArray<(Of <(T>)>).)
Item | Gets or sets the value at the specified position in the array. (Inherited from MemoryArray<(Of <(T>)>).)
Length | Gets the length of the unmanaged array. (Inherited from MemoryArray<(Of <(T>)>).)
SyncRoot | Gets an object that can be used to synchronize access to the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)

See Also

Palette Class


Palette Constructor

[image] [image] [image]

FreeImage .NET Documentation
Palette Constructor
Palette Class See Also Send Feedback

Overload List

Name | Description
Palette(FIBITMAP) | Initializes a new instance for the given FreeImage bitmap.
Palette(FITAG) | Initializes a new instance for the given FITAG that contains a palette.
Palette(MetadataTag) | Initializes a new instance for the given MetadataTag that contains a palette.
Palette(array<RGBQUAD>[]()[]) | Initializes a new instance for the given array of RGBQUAD that contains a palette.
Palette(array<Color>[]()[]) | Initializes a new instance for the given array of Color that contains a palette.
Palette(Int32) | Initializes a new instance with the specified size.

See Also

Palette Class
Palette Members


Palette Constructor (FIBITMAP)

[image]

FreeImage .NET Documentation
Palette Constructor (FIBITMAP)
Palette Class See Also Send Feedback
Initializes a new instance for the given FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Palette(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
Palette(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.
System..::.ArgumentException | dib is not FIT_BITMAP -or- dib has more than 8bpp.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Palette Overload


Palette Constructor (FITAG)

[image]

FreeImage .NET Documentation
Palette Constructor (FITAG)
Palette Class See Also Send Feedback
Initializes a new instance for the given FITAG that contains a palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Palette(
    FITAG tag
)
Visual Basic (Declaration)
Public Sub New ( _
    tag As FITAG _
)
Visual C++
public:
Palette(
    FITAG tag
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The tag containing the palette.

Exceptions

Exception | Condition
System..::.ArgumentNullException | tag is null.
System..::.ArgumentException | tag is not FIDT_PALETTE.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Palette Overload


Palette Constructor (MetadataTag)

[image]

FreeImage .NET Documentation
Palette Constructor (MetadataTag)
Palette Class See Also Send Feedback
Initializes a new instance for the given MetadataTag that contains a palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Palette(
    MetadataTag tag
)
Visual Basic (Declaration)
Public Sub New ( _
    tag As MetadataTag _
)
Visual C++
public:
Palette(
    MetadataTag^ tag
)

Parameters

tag
Type: FreeImageAPI.Metadata..::.MetadataTag
The tag containing the palette.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.
System..::.ArgumentException | tag is not FIDT_PALETTE.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Palette Overload


Palette Constructor (RGBQUAD[])

[image]

FreeImage .NET Documentation
Palette Constructor (array<RGBQUAD>[]()[])
Palette Class See Also Send Feedback
Initializes a new instance for the given array of RGBQUAD that contains a palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Palette(
    RGBQUAD[] palette
)
Visual Basic (Declaration)
Public Sub New ( _
    palette As RGBQUAD() _
)
Visual C++
public:
Palette(
    array<RGBQUAD>^ palette
)

Parameters

palette
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
A RGBQUAD array containing the palette data to initialize this instance.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Palette Overload


Palette Constructor (Color[])

[image]

FreeImage .NET Documentation
Palette Constructor (array<Color>[]()[])
Palette Class See Also Send Feedback
Initializes a new instance for the given array of Color that contains a palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Palette(
    Color[] palette
)
Visual Basic (Declaration)
Public Sub New ( _
    palette As Color() _
)
Visual C++
public:
Palette(
    array<Color>^ palette
)

Parameters

palette
Type: array< System.Drawing..::.Color >[]()[]
A Color array containing the palette data to initialize this instance.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Palette Overload


Palette Constructor (Int32)

[image]

FreeImage .NET Documentation
Palette Constructor (Int32)
Palette Class See Also Send Feedback
Initializes a new instance with the specified size.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Palette(
    int size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Integer _
)
Visual C++
public:
Palette(
    int size
)

Parameters

size
Type: System..::.Int32
The size of the palette.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Palette Overload


Palette Methods

[image] [image] [image]

FreeImage .NET Documentation
Palette Methods
Palette Class See Also Send Feedback

The Palette type exposes the following members.

Methods

Name | Description
Clone | Creates a shallow copy of the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
Colorize | Overloaded.
CopyFrom | Overloaded.
CopyTo | Overloaded.
CreateGrayscalePalette | Overloaded.
Dispose | Releases all ressources. (Inherited from MemoryArray<(Of <(T>)>).)
Equals | Overloaded.
GetEnumerator | Retrieves an object that can iterate through the individual elements in this MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from MemoryArray<(Of <(T>)>).)
GetValue | Gets the value at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
GetValues | Gets the values at the specified position and length. (Inherited from MemoryArray<(Of <(T>)>).)
Load | Overloaded.
Reverse | Reverses the palette.
Save | Overloaded.
SetValue | Sets a value to the element at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
SetValues | Sets the values at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
ToArray | Returns the palette as an array of RGBQUAD.
ToByteArray | Returns the represented block of memory as an array of Byte. (Inherited from MemoryArray<(Of <(T>)>).)

See Also

Palette Class


Colorize Method

[image] [image] [image]

FreeImage .NET Documentation
Palette..::.Colorize Method
Palette Class See Also Send Feedback

Overload List

Name | Description
Colorize(Color) | Creates a linear palette based on the provided color.
Colorize(Color, Double) | Creates a linear palette based on the provided color.
Colorize(Color, Int32) | Creates a linear palette based on the provided color.

See Also

Palette Class
Palette Members


Colorize Method (Color)

[image]

FreeImage .NET Documentation
Palette..::.Colorize Method (Color)
Palette Class See Also Send Feedback
Creates a linear palette based on the provided color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Colorize(
    Color color
)
Visual Basic (Declaration)
Public Sub Colorize ( _
    color As Color _
)
Visual C++
public:
void Colorize(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
The Color used to colorize the palette.

Remarks

Only call this method on linear palettes.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Colorize Overload


Colorize Method (Color, Double)

[image]

FreeImage .NET Documentation
Palette..::.Colorize Method (Color, Double)
Palette Class See Also Send Feedback
Creates a linear palette based on the provided color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Colorize(
    Color color,
    double splitSize
)
Visual Basic (Declaration)
Public Sub Colorize ( _
    color As Color, _
    splitSize As Double _
)
Visual C++
public:
void Colorize(
    Color color,
    double splitSize
)

Parameters

color
Type: System.Drawing..::.Color
The Color used to colorize the palette.
splitSize
Type: System..::.Double
The position of the color within the new palette. 0 < splitSize < 1.

Remarks

Only call this method on linear palettes.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Colorize Overload


Colorize Method (Color, Int32)

[image]

FreeImage .NET Documentation
Palette..::.Colorize Method (Color, Int32)
Palette Class See Also Send Feedback
Creates a linear palette based on the provided color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Colorize(
    Color color,
    int splitSize
)
Visual Basic (Declaration)
Public Sub Colorize ( _
    color As Color, _
    splitSize As Integer _
)
Visual C++
public:
void Colorize(
    Color color,
    int splitSize
)

Parameters

color
Type: System.Drawing..::.Color
The Color used to colorize the palette.
splitSize
Type: System..::.Int32
The position of the color within the new palette. 0 < splitSize < Length.

Remarks

Only call this method on linear palettes.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Colorize Overload


CopyFrom Method

[image] [image] [image]

FreeImage .NET Documentation
Palette..::.CopyFrom Method
Palette Class See Also Send Feedback

Overload List

Name | Description
CopyFrom(Palette) | Copies the values from the specified Palette to this instance.
CopyFrom(Palette, Int32) | Copies the values from the specified Palette to this instance, starting at the specified offset.
CopyFrom(array<T>[]()[], Int32, Int32, Int32) | Copies a range of elements from the array starting at the specified sourceIndex and pastes them to the unmanaged array starting at the specified destinationIndex. The length and the indexes are specified as 32-bit integers. (Inherited from MemoryArray<(Of <(T>)>).)

See Also

Palette Class
Palette Members


CopyFrom Method (Palette)

[image]

FreeImage .NET Documentation
Palette..::.CopyFrom Method (Palette)
Palette Class See Also Send Feedback
Copies the values from the specified Palette to this instance.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CopyFrom(
    Palette palette
)
Visual Basic (Declaration)
Public Sub CopyFrom ( _
    palette As Palette _
)
Visual C++
public:
void CopyFrom(
    Palette^ palette
)

Parameters

palette
Type: FreeImageAPI..::.Palette
The palette to copy from.

Exceptions

Exception | Condition
System..::.ArgumentNullException | palette is a null reference.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
CopyFrom Overload


CopyFrom Method (Palette, Int32)

[image]

FreeImage .NET Documentation
Palette..::.CopyFrom Method (Palette, Int32)
Palette Class See Also Send Feedback
Copies the values from the specified Palette to this instance, starting at the specified offset.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CopyFrom(
    Palette palette,
    int offset
)
Visual Basic (Declaration)
Public Sub CopyFrom ( _
    palette As Palette, _
    offset As Integer _
)
Visual C++
public:
void CopyFrom(
    Palette^ palette,
    int offset
)

Parameters

palette
Type: FreeImageAPI..::.Palette
The palette to copy from.
offset
Type: System..::.Int32
The position in this instance where the values will be copied to.

Exceptions

Exception | Condition
System..::.ArgumentNullException | palette is a null reference.
System..::.ArgumentOutOfRangeException | offset is outside the range of valid indexes.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
CopyFrom Overload


CopyTo Method

[image] [image] [image]

FreeImage .NET Documentation
Palette..::.CopyTo Method
Palette Class See Also Send Feedback

Overload List

Name | Description
CopyTo(Array, Int32) | Copies the entire array to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from MemoryArray<(Of <(T>)>).)
CopyTo(array<T>[]()[], Int32, Int32, Int32) | Copies a range of elements from the unmanaged array starting at the specified sourceIndex and pastes them to array starting at the specified destinationIndex. The length and the indexes are specified as 32-bit integers. (Inherited from MemoryArray<(Of <(T>)>).)

See Also

Palette Class
Palette Members


CreateGrayscalePalette Method

[image] [image] [image]

FreeImage .NET Documentation
Palette..::.CreateGrayscalePalette Method
Palette Class See Also Send Feedback

Overload List

Name | Description
CreateGrayscalePalette()()() | Creates a linear grayscale palette.
CreateGrayscalePalette(Boolean) | Creates a linear grayscale palette.
CreateGrayscalePalette(Color, Boolean) | Creates a linear palette with the specified Color.

See Also

Palette Class
Palette Members


CreateGrayscalePalette Method

[image]

FreeImage .NET Documentation
Palette..::.CreateGrayscalePalette Method
Palette Class See Also Send Feedback
Creates a linear grayscale palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CreateGrayscalePalette()
Visual Basic (Declaration)
Public Sub CreateGrayscalePalette
Visual C++
public:
void CreateGrayscalePalette()

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
CreateGrayscalePalette Overload


CreateGrayscalePalette Method (Boolean)

[image]

FreeImage .NET Documentation
Palette..::.CreateGrayscalePalette Method (Boolean)
Palette Class See Also Send Feedback
Creates a linear grayscale palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CreateGrayscalePalette(
    bool inverse
)
Visual Basic (Declaration)
Public Sub CreateGrayscalePalette ( _
    inverse As Boolean _
)
Visual C++
public:
void CreateGrayscalePalette(
    bool inverse
)

Parameters

inverse
Type: System..::.Boolean
true to create an inverse grayscale palette.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
CreateGrayscalePalette Overload


CreateGrayscalePalette Method (Color, Boolean)

[image]

FreeImage .NET Documentation
Palette..::.CreateGrayscalePalette Method (Color, Boolean)
Palette Class See Also Send Feedback
Creates a linear palette with the specified Color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CreateGrayscalePalette(
    Color color,
    bool inverse
)
Visual Basic (Declaration)
Public Sub CreateGrayscalePalette ( _
    color As Color, _
    inverse As Boolean _
)
Visual C++
public:
void CreateGrayscalePalette(
    Color color,
    bool inverse
)

Parameters

color
Type: System.Drawing..::.Color
The Color used to create the palette.
inverse
Type: System..::.Boolean
true to create an inverse palette.

Remarks

A linear grayscale palette contains all shades of colors from black to white. This method creates a similar palette with the white color being replaced by the specified color.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
CreateGrayscalePalette Overload


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
Palette..::.Equals Method
Palette Class See Also Send Feedback

Overload List

Name | Description
Equals(MemoryArray<(Of <(T>)>)) | Tests whether the specified MemoryArray<(Of <(T>)>) structure is equivalent to this MemoryArray<(Of <(T>)>) structure. (Inherited from MemoryArray<(Of <(T>)>).)
Equals(Object) | Tests whether the specified MemoryArray<(Of <(T>)>) structure is equivalent to this MemoryArray<(Of <(T>)>) structure. (Inherited from MemoryArray<(Of <(T>)>).)

See Also

Palette Class
Palette Members


Load Method

[image] [image] [image]

FreeImage .NET Documentation
Palette..::.Load Method
Palette Class See Also Send Feedback

Overload List

Name | Description
Load(BinaryReader) | Loads a palette from the reader.
Load(Stream) | Loads a palette from the specified stream.
Load(String) | Loads a palette from the specified file.

See Also

Palette Class
Palette Members


Load Method (BinaryReader)

[image]

FreeImage .NET Documentation
Palette..::.Load Method (BinaryReader)
Palette Class See Also Send Feedback
Loads a palette from the reader.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Load(
    BinaryReader reader
)
Visual Basic (Declaration)
Public Sub Load ( _
    reader As BinaryReader _
)
Visual C++
public:
void Load(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IO..::.BinaryReader
The reader to load the palette from.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Load Overload


Load Method (Stream)

[image]

FreeImage .NET Documentation
Palette..::.Load Method (Stream)
Palette Class See Also Send Feedback
Loads a palette from the specified stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Load(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Load ( _
    stream As Stream _
)
Visual C++
public:
void Load(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The stream to load the palette from.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Load Overload


Load Method (String)

[image]

FreeImage .NET Documentation
Palette..::.Load Method (String)
Palette Class See Also Send Feedback
Loads a palette from the specified file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Load(
    string filename
)
Visual Basic (Declaration)
Public Sub Load ( _
    filename As String _
)
Visual C++
public:
void Load(
    String^ filename
)

Parameters

filename
Type: System..::.String
The name of the palette file.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Load Overload


Reverse Method

[image]

FreeImage .NET Documentation
Palette..::.Reverse Method
Palette Class See Also Send Feedback
Reverses the palette.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Reverse()
Visual Basic (Declaration)
Public Sub Reverse
Visual C++
public:
void Reverse()

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class


Save Method

[image] [image] [image]

FreeImage .NET Documentation
Palette..::.Save Method
Palette Class See Also Send Feedback

Overload List

Name | Description
Save(BinaryWriter) | Saves this Palette using the specified writer.
Save(Stream) | Saves this Palette to the specified stream.
Save(String) | Saves this Palette to the specified file.

See Also

Palette Class
Palette Members


Save Method (BinaryWriter)

[image]

FreeImage .NET Documentation
Palette..::.Save Method (BinaryWriter)
Palette Class See Also Send Feedback
Saves this Palette using the specified writer.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Save(
    BinaryWriter writer
)
Visual Basic (Declaration)
Public Sub Save ( _
    writer As BinaryWriter _
)
Visual C++
public:
void Save(
    BinaryWriter^ writer
)

Parameters

writer
Type: System.IO..::.BinaryWriter
The BinaryWriter used to save the image.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Save Overload


Save Method (Stream)

[image]

FreeImage .NET Documentation
Palette..::.Save Method (Stream)
Palette Class See Also Send Feedback
Saves this Palette to the specified stream.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The Stream where the image will be saved.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Save Overload


Save Method (String)

[image]

FreeImage .NET Documentation
Palette..::.Save Method (String)
Palette Class See Also Send Feedback
Saves this Palette to the specified file.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Save(
    string filename
)
Visual Basic (Declaration)
Public Sub Save ( _
    filename As String _
)
Visual C++
public:
void Save(
    String^ filename
)

Parameters

filename
Type: System..::.String
A string that contains the name of the file to which to save this Palette.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class
Save Overload


ToArray Method

[image]

FreeImage .NET Documentation
Palette..::.ToArray Method
Palette Class See Also Send Feedback
Returns the palette as an array of RGBQUAD.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public RGBQUAD[] ToArray()
Visual Basic (Declaration)
Public Function ToArray As RGBQUAD()
Visual C++
public:
array<RGBQUAD>^ ToArray()

Return Value

The palette as an array of RGBQUAD.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class


Palette Properties

[image] [image] [image]

FreeImage .NET Documentation
Palette Properties
Palette Class See Also Send Feedback

The Palette type exposes the following members.

Properties

Name | Description
AsArray | Gets or sets the palette through an array of RGBQUAD.
BaseAddress | Gets the base address of the represented memory block. (Inherited from MemoryArray<(Of <(T>)>).)
Count | Gets a 32-bit integer that represents the total number of elements in the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
Data | Gets or sets the values of the unmanaged array. (Inherited from MemoryArray<(Of <(T>)>).)
IsSynchronized | Gets a value indicating whether access to the MemoryArray<(Of <(T>)>) is synchronized (thread safe). (Inherited from MemoryArray<(Of <(T>)>).)
Item | Gets or sets the value at the specified position in the array. (Inherited from MemoryArray<(Of <(T>)>).)
Length | Gets the length of the unmanaged array. (Inherited from MemoryArray<(Of <(T>)>).)
SyncRoot | Gets an object that can be used to synchronize access to the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)

See Also

Palette Class


AsArray Property

[image]

FreeImage .NET Documentation
Palette..::.AsArray Property
Palette Class See Also Send Feedback
Gets or sets the palette through an array of RGBQUAD.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public RGBQUAD[] AsArray { get; set; }
Visual Basic (Declaration)
Public Property AsArray As RGBQUAD()
Visual C++
public:
property array<RGBQUAD>^ AsArray {
    array<RGBQUAD>^ get ();
    void set (array<RGBQUAD>^ value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Palette Class


RGBQUAD Structure

[image]

FreeImage .NET Documentation
RGBQUAD Structure
Members Example See Also Send Feedback
The RGBQUAD structure describes a color consisting of relative intensities of red, green, blue and alpha value. Each single color component consumes 8 bits and so, takes values in the range from 0 to 255.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct RGBQUAD : IComparable, IComparable<RGBQUAD>,
    IEquatable<RGBQUAD>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure RGBQUAD _
    Implements IComparable, IComparable(Of RGBQUAD),  _
    IEquatable(Of RGBQUAD)
Visual C++
[SerializableAttribute]
public value class RGBQUAD : IComparable,
    IComparable<RGBQUAD>, IEquatable<RGBQUAD>

Remarks

The RGBQUAD structure provides access to an underlying Win32 RGBQUAD structure. To determine the alpha, red, green or blue component of a color, use the rgbReserved, rgbRed, rgbGreen or rgbBlue fields, respectively.

For easy integration of the underlying structure into the .NET framework, the RGBQUAD structure implements implicit conversion operators to convert the represented color to and from the Color type. This makes the Color type a real replacement for the RGBQUAD structure and my be used in all situations which require an RGBQUAD type.

Each color component rgbReserved, rgbRed, rgbGreen or rgbBlue of RGBQUAD is translated into it's corresponding color component A, R, G or B of Color by an one-to-one manner and vice versa.

Conversion from System.Drawing.Color to RGBQUAD

RGBQUAD.component = Color.component

Conversion from RGBQUAD to System.Drawing.Color

Color.component = RGBQUAD.component

The same conversion is also applied when the Color property or the RGBQUAD(Color) constructor is invoked.

Examples

The following code example demonstrates the various conversions between the RGBQUAD structure and the Color structure.
CopyC#
RGBQUAD rgbq;
// Initialize the structure using a native .NET Color structure.
rgbq = new RGBQUAD(Color.Indigo);
// Initialize the structure using the implicit operator.
rgbq = Color.DarkSeaGreen;
// Convert the RGBQUAD instance into a native .NET Color
// using its implicit operator.
Color color = rgbq;
// Using the structure's Color property for converting it
// into a native .NET Color.
Color another = rgbq.Color;

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Members


RGBQUAD Members

[image] [image] [image]

FreeImage .NET Documentation
RGBQUAD Members
RGBQUAD Structure Constructors Methods Fields Properties See Also Send Feedback

The RGBQUAD type exposes the following members.

Constructors

Name | Description
RGBQUAD | Initializes a new instance based on the specified Color.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this RGBQUAD structure. (Overrides ValueType..::.GetHashCode()()().)
ToColor | Converts an array of RGBQUAD into an array of Color.
ToRGBQUAD | Converts an array of Color into an array of RGBQUAD.
ToString | Converts the numeric value of the RGBQUAD object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified RGBQUAD structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified RGBQUAD structures are different.

Fields

Name | Description
rgbBlue | The blue color component.
rgbGreen | The green color component.
rgbRed | The red color component.
rgbReserved | The alpha color component.
uintValue | The color's value.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

RGBQUAD Structure


RGBQUAD Constructor

[image]

FreeImage .NET Documentation
RGBQUAD Constructor
RGBQUAD Structure See Also Send Feedback
Initializes a new instance based on the specified Color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public RGBQUAD(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
RGBQUAD(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Color to initialize with.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


RGBQUAD Fields

[image] [image] [image]

FreeImage .NET Documentation
RGBQUAD Fields
RGBQUAD Structure See Also Send Feedback

The RGBQUAD type exposes the following members.

Fields

Name | Description
rgbBlue | The blue color component.
rgbGreen | The green color component.
rgbRed | The red color component.
rgbReserved | The alpha color component.
uintValue | The color's value.

See Also

RGBQUAD Structure


rgbBlue Field

[image]

FreeImage .NET Documentation
RGBQUAD..::.rgbBlue Field
RGBQUAD Structure See Also Send Feedback
The blue color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte rgbBlue
Visual Basic (Declaration)
Public rgbBlue As Byte
Visual C++
public:
unsigned char rgbBlue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


rgbGreen Field

[image]

FreeImage .NET Documentation
RGBQUAD..::.rgbGreen Field
RGBQUAD Structure See Also Send Feedback
The green color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte rgbGreen
Visual Basic (Declaration)
Public rgbGreen As Byte
Visual C++
public:
unsigned char rgbGreen

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


rgbRed Field

[image]

FreeImage .NET Documentation
RGBQUAD..::.rgbRed Field
RGBQUAD Structure See Also Send Feedback
The red color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte rgbRed
Visual Basic (Declaration)
Public rgbRed As Byte
Visual C++
public:
unsigned char rgbRed

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


rgbReserved Field

[image]

FreeImage .NET Documentation
RGBQUAD..::.rgbReserved Field
RGBQUAD Structure See Also Send Feedback
The alpha color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte rgbReserved
Visual Basic (Declaration)
Public rgbReserved As Byte
Visual C++
public:
unsigned char rgbReserved

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


uintValue Field

[image]

FreeImage .NET Documentation
RGBQUAD..::.uintValue Field
RGBQUAD Structure See Also Send Feedback
The color's value.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint uintValue
Visual Basic (Declaration)
Public uintValue As UInteger
Visual C++
public:
unsigned int uintValue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


RGBQUAD Methods

[image] [image] [image]

FreeImage .NET Documentation
RGBQUAD Methods
RGBQUAD Structure See Also Send Feedback

The RGBQUAD type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this RGBQUAD structure. (Overrides ValueType..::.GetHashCode()()().)
ToColor | Converts an array of RGBQUAD into an array of Color.
ToRGBQUAD | Converts an array of Color into an array of RGBQUAD.
ToString | Converts the numeric value of the RGBQUAD object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified RGBQUAD structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified RGBQUAD structures are different.

See Also

RGBQUAD Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
RGBQUAD..::.CompareTo Method
RGBQUAD Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(RGBQUAD) | Compares this instance with a specified RGBQUAD object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

RGBQUAD Structure
RGBQUAD Members


CompareTo Method (RGBQUAD)

[image]

FreeImage .NET Documentation
RGBQUAD..::.CompareTo Method (RGBQUAD)
RGBQUAD Structure See Also Send Feedback
Compares this instance with a specified RGBQUAD object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    RGBQUAD other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As RGBQUAD _
) As Integer
Visual C++
public:
virtual int CompareTo(
    RGBQUAD other
) sealed

Parameters

other
Type: FreeImageAPI..::.RGBQUAD
A RGBQUAD to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
RGBQUAD..::.CompareTo Method (Object)
RGBQUAD Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a RGBQUAD.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
RGBQUAD..::.Equality Operator
RGBQUAD Structure See Also Send Feedback
Tests whether two specified RGBQUAD structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    RGBQUAD left,
    RGBQUAD right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As RGBQUAD, _
    right As RGBQUAD _
) As Boolean
Visual C++
public:
static bool operator ==(
    RGBQUAD left,
    RGBQUAD right
)

Parameters

left
Type: FreeImageAPI..::.RGBQUAD
The RGBQUAD that is to the left of the equality operator.
right
Type: FreeImageAPI..::.RGBQUAD
The RGBQUAD that is to the right of the equality operator.

Return Value

true if the two RGBQUAD structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
RGBQUAD..::.Equals Method
RGBQUAD Structure See Also Send Feedback

Overload List

Name | Description
Equals(RGBQUAD) | Tests whether the specified RGBQUAD structure is equivalent to this RGBQUAD structure.
Equals(Object) | Tests whether the specified object is a RGBQUAD structure and is equivalent to this RGBQUAD structure. (Overrides ValueType..::.Equals(Object).)

See Also

RGBQUAD Structure
RGBQUAD Members


Equals Method (RGBQUAD)

[image]

FreeImage .NET Documentation
RGBQUAD..::.Equals Method (RGBQUAD)
RGBQUAD Structure See Also Send Feedback
Tests whether the specified RGBQUAD structure is equivalent to this RGBQUAD structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    RGBQUAD other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As RGBQUAD _
) As Boolean
Visual C++
public:
virtual bool Equals(
    RGBQUAD other
) sealed

Parameters

other
Type: FreeImageAPI..::.RGBQUAD
A RGBQUAD structure to compare to this instance.

Return Value

true if obj is a RGBQUAD structure equivalent to this RGBQUAD structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
RGBQUAD..::.Equals Method (Object)
RGBQUAD Structure See Also Send Feedback
Tests whether the specified object is a RGBQUAD structure and is equivalent to this RGBQUAD structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a RGBQUAD structure equivalent to this RGBQUAD structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
RGBQUAD..::.GetHashCode Method
RGBQUAD Structure See Also Send Feedback
Returns a hash code for this RGBQUAD structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this RGBQUAD.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
RGBQUAD..::.Implicit Method
RGBQUAD Structure See Also Send Feedback

Overload List

Name | Description
Implicit(RGBQUAD) | Converts the value of a RGBQUAD structure to an UInt32 structure.
Implicit(RGBQUAD) | Converts the value of a RGBQUAD structure to a Color structure.
Implicit(Color) | Converts the value of a Color structure to a RGBQUAD structure.
Implicit(UInt32) | Converts the value of an UInt32 structure to a RGBQUAD structure.

See Also

RGBQUAD Structure
RGBQUAD Members


Implicit Operator

[image]

FreeImage .NET Documentation
RGBQUAD..::.Implicit Operator
RGBQUAD Structure See Also Send Feedback
Converts the value of a RGBQUAD structure to an UInt32 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator uint (
    RGBQUAD value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As RGBQUAD _
) As UInteger
Visual C++
static implicit operator unsigned int (
    RGBQUAD value
)

Parameters

value
Type: FreeImageAPI..::.RGBQUAD
A RGBQUAD structure.

Return Value

A new instance of RGBQUAD initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
RGBQUAD..::.Implicit Operator
RGBQUAD Structure See Also Send Feedback
Converts the value of a RGBQUAD structure to a Color structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator Color (
    RGBQUAD value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As RGBQUAD _
) As Color
Visual C++
static implicit operator Color (
    RGBQUAD value
)

Parameters

value
Type: FreeImageAPI..::.RGBQUAD
A RGBQUAD structure.

Return Value

A new instance of Color initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
RGBQUAD..::.Implicit Operator
RGBQUAD Structure See Also Send Feedback
Converts the value of a Color structure to a RGBQUAD structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator RGBQUAD (
    Color value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Color _
) As RGBQUAD
Visual C++
static implicit operator RGBQUAD (
    Color value
)

Parameters

value
Type: System.Drawing..::.Color
A Color structure.

Return Value

A new instance of RGBQUAD initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
RGBQUAD..::.Implicit Operator
RGBQUAD Structure See Also Send Feedback
Converts the value of an UInt32 structure to a RGBQUAD structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator RGBQUAD (
    uint value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As UInteger _
) As RGBQUAD
Visual C++
static implicit operator RGBQUAD (
    unsigned int value
)

Parameters

value
Type: System..::.UInt32
An UInt32 structure.

Return Value

A new instance of RGBQUAD initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
RGBQUAD..::.Inequality Operator
RGBQUAD Structure See Also Send Feedback
Tests whether two specified RGBQUAD structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    RGBQUAD left,
    RGBQUAD right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As RGBQUAD, _
    right As RGBQUAD _
) As Boolean
Visual C++
public:
static bool operator !=(
    RGBQUAD left,
    RGBQUAD right
)

Parameters

left
Type: FreeImageAPI..::.RGBQUAD
The RGBQUAD that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.RGBQUAD
The RGBQUAD that is to the right of the inequality operator.

Return Value

true if the two RGBQUAD structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


ToColor Method

[image]

FreeImage .NET Documentation
RGBQUAD..::.ToColor Method
RGBQUAD Structure See Also Send Feedback
Converts an array of RGBQUAD into an array of Color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static Color[] ToColor(
    RGBQUAD[] array
)
Visual Basic (Declaration)
Public Shared Function ToColor ( _
    array As RGBQUAD() _
) As Color()
Visual C++
public:
static array<Color>^ ToColor(
    array<RGBQUAD>^ array
)

Parameters

array
Type: array< FreeImageAPI..::.RGBQUAD >[]()[]
The array to convert.

Return Value

An array of RGBQUAD.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


ToRGBQUAD Method

[image]

FreeImage .NET Documentation
RGBQUAD..::.ToRGBQUAD Method
RGBQUAD Structure See Also Send Feedback
Converts an array of Color into an array of RGBQUAD.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static RGBQUAD[] ToRGBQUAD(
    Color[] array
)
Visual Basic (Declaration)
Public Shared Function ToRGBQUAD ( _
    array As Color() _
) As RGBQUAD()
Visual C++
public:
static array<RGBQUAD>^ ToRGBQUAD(
    array<Color>^ array
)

Parameters

array
Type: array< System.Drawing..::.Color >[]()[]
The array to convert.

Return Value

An array of RGBQUAD.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


ToString Method

[image]

FreeImage .NET Documentation
RGBQUAD..::.ToString Method
RGBQUAD Structure See Also Send Feedback
Converts the numeric value of the RGBQUAD object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


RGBQUAD Properties

[image] [image] [image]

FreeImage .NET Documentation
RGBQUAD Properties
RGBQUAD Structure See Also Send Feedback

The RGBQUAD type exposes the following members.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

RGBQUAD Structure


Color Property

[image]

FreeImage .NET Documentation
RGBQUAD..::.Color Property
RGBQUAD Structure See Also Send Feedback
Gets or sets the Color of the structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBQUAD Structure


RGBTRIPLE Structure

[image]

FreeImage .NET Documentation
RGBTRIPLE Structure
Members Example See Also Send Feedback
The RGBTRIPLE structure describes a color consisting of relative intensities of red, green and blue value. Each single color component consumes 8 bits and so, takes values in the range from 0 to 255.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct RGBTRIPLE : IComparable, IComparable<RGBTRIPLE>,
    IEquatable<RGBTRIPLE>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure RGBTRIPLE _
    Implements IComparable, IComparable(Of RGBTRIPLE),  _
    IEquatable(Of RGBTRIPLE)
Visual C++
[SerializableAttribute]
public value class RGBTRIPLE : IComparable,
    IComparable<RGBTRIPLE>, IEquatable<RGBTRIPLE>

Remarks

The RGBTRIPLE structure provides access to an underlying Win32 RGBTRIPLE structure. To determine the red, green or blue component of a color, use the rgbtRed, rgbtGreen or rgbtBlue fields, respectively.

For easy integration of the underlying structure into the .NET framework, the RGBTRIPLE structure implements implicit conversion operators to convert the represented color to and from the Color type. This makes the Color type a real replacement for the RGBTRIPLE structure and my be used in all situations which require an RGBTRIPLE type.

Each of the color components rgbtRed, rgbtGreen or rgbtBlue of RGBTRIPLE is translated into it's corresponding color component R, G or B of Color by an one-to-one manner and vice versa. When converting from Color into RGBTRIPLE, the color's alpha value is ignored and assumed to be 255 when converting from RGBTRIPLE into Color, creating a fully opaque color.

Conversion from System.Drawing.Color to RGBTRIPLE

RGBTRIPLE.component = Color.component

Conversion from RGBTRIPLE to System.Drawing.Color

Color.component = RGBTRIPLE.component

The same conversion is also applied when the Color property or the RGBTRIPLE(Color) constructor is invoked.

Examples

The following code example demonstrates the various conversions between the RGBTRIPLE structure and the Color structure.
CopyC#
RGBTRIPLE rgbt;
// Initialize the structure using a native .NET Color structure.
rgbt = new RGBTRIPLE(Color.Indigo);
// Initialize the structure using the implicit operator.
rgbt = Color.DarkSeaGreen;
// Convert the RGBTRIPLE instance into a native .NET Color
// using its implicit operator.
Color color = rgbt;
// Using the structure's Color property for converting it
// into a native .NET Color.
Color another = rgbt.Color;

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Members


RGBTRIPLE Members

[image] [image] [image]

FreeImage .NET Documentation
RGBTRIPLE Members
RGBTRIPLE Structure Constructors Methods Fields Properties See Also Send Feedback

The RGBTRIPLE type exposes the following members.

Constructors

Name | Description
RGBTRIPLE | Initializes a new instance based on the specified Color.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this RGBTRIPLE structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the RGBTRIPLE object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified RGBTRIPLE structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified RGBTRIPLE structures are different.

Fields

Name | Description
rgbtBlue | The blue color component.
rgbtGreen | The green color component.
rgbtRed | The red color component.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

RGBTRIPLE Structure


RGBTRIPLE Constructor

[image]

FreeImage .NET Documentation
RGBTRIPLE Constructor
RGBTRIPLE Structure See Also Send Feedback
Initializes a new instance based on the specified Color.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public RGBTRIPLE(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
RGBTRIPLE(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
Color to initialize with.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure


RGBTRIPLE Fields

[image] [image] [image]

FreeImage .NET Documentation
RGBTRIPLE Fields
RGBTRIPLE Structure See Also Send Feedback

The RGBTRIPLE type exposes the following members.

Fields

Name | Description
rgbtBlue | The blue color component.
rgbtGreen | The green color component.
rgbtRed | The red color component.

See Also

RGBTRIPLE Structure


rgbtBlue Field

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.rgbtBlue Field
RGBTRIPLE Structure See Also Send Feedback
The blue color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte rgbtBlue
Visual Basic (Declaration)
Public rgbtBlue As Byte
Visual C++
public:
unsigned char rgbtBlue

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure


rgbtGreen Field

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.rgbtGreen Field
RGBTRIPLE Structure See Also Send Feedback
The green color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte rgbtGreen
Visual Basic (Declaration)
Public rgbtGreen As Byte
Visual C++
public:
unsigned char rgbtGreen

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure


rgbtRed Field

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.rgbtRed Field
RGBTRIPLE Structure See Also Send Feedback
The red color component.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte rgbtRed
Visual Basic (Declaration)
Public rgbtRed As Byte
Visual C++
public:
unsigned char rgbtRed

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure


RGBTRIPLE Methods

[image] [image] [image]

FreeImage .NET Documentation
RGBTRIPLE Methods
RGBTRIPLE Structure See Also Send Feedback

The RGBTRIPLE type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode | Returns a hash code for this RGBTRIPLE structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the RGBTRIPLE object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified RGBTRIPLE structures are equivalent.
Implicit | Overloaded.
Inequality | Tests whether two specified RGBTRIPLE structures are different.

See Also

RGBTRIPLE Structure


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
RGBTRIPLE..::.CompareTo Method
RGBTRIPLE Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(RGBTRIPLE) | Compares this instance with a specified RGBTRIPLE object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

RGBTRIPLE Structure
RGBTRIPLE Members


CompareTo Method (RGBTRIPLE)

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.CompareTo Method (RGBTRIPLE)
RGBTRIPLE Structure See Also Send Feedback
Compares this instance with a specified RGBTRIPLE object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    RGBTRIPLE other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As RGBTRIPLE _
) As Integer
Visual C++
public:
virtual int CompareTo(
    RGBTRIPLE other
) sealed

Parameters

other
Type: FreeImageAPI..::.RGBTRIPLE
A RGBTRIPLE to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure
CompareTo Overload


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.CompareTo Method (Object)
RGBTRIPLE Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a RGBTRIPLE.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure
CompareTo Overload


Equality Operator

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.Equality Operator
RGBTRIPLE Structure See Also Send Feedback
Tests whether two specified RGBTRIPLE structures are equivalent.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    RGBTRIPLE left,
    RGBTRIPLE right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As RGBTRIPLE, _
    right As RGBTRIPLE _
) As Boolean
Visual C++
public:
static bool operator ==(
    RGBTRIPLE left,
    RGBTRIPLE right
)

Parameters

left
Type: FreeImageAPI..::.RGBTRIPLE
The RGBTRIPLE that is to the left of the equality operator.
right
Type: FreeImageAPI..::.RGBTRIPLE
The RGBTRIPLE that is to the right of the equality operator.

Return Value

true if the two RGBTRIPLE structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
RGBTRIPLE..::.Equals Method
RGBTRIPLE Structure See Also Send Feedback

Overload List

Name | Description
Equals(RGBTRIPLE) | Tests whether the specified RGBTRIPLE structure is equivalent to this RGBTRIPLE structure.
Equals(Object) | Tests whether the specified object is a RGBTRIPLE structure and is equivalent to this RGBTRIPLE structure. (Overrides ValueType..::.Equals(Object).)

See Also

RGBTRIPLE Structure
RGBTRIPLE Members


Equals Method (RGBTRIPLE)

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.Equals Method (RGBTRIPLE)
RGBTRIPLE Structure See Also Send Feedback
Tests whether the specified RGBTRIPLE structure is equivalent to this RGBTRIPLE structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    RGBTRIPLE other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As RGBTRIPLE _
) As Boolean
Visual C++
public:
virtual bool Equals(
    RGBTRIPLE other
) sealed

Parameters

other
Type: FreeImageAPI..::.RGBTRIPLE
A RGBTRIPLE structure to compare to this instance.

Return Value

true if obj is a RGBTRIPLE structure equivalent to this RGBTRIPLE structure; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure
Equals Overload


Equals Method (Object)

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.Equals Method (Object)
RGBTRIPLE Structure See Also Send Feedback
Tests whether the specified object is a RGBTRIPLE structure and is equivalent to this RGBTRIPLE structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a RGBTRIPLE structure equivalent to this RGBTRIPLE structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure
Equals Overload


GetHashCode Method

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.GetHashCode Method
RGBTRIPLE Structure See Also Send Feedback
Returns a hash code for this RGBTRIPLE structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this RGBTRIPLE.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure


Implicit Method

[image] [image] [image]

FreeImage .NET Documentation
RGBTRIPLE..::.Implicit Method
RGBTRIPLE Structure See Also Send Feedback

Overload List

Name | Description
Implicit(RGBTRIPLE) | Converts the value of a RGBTRIPLE structure to an UInt32 structure.
Implicit(RGBTRIPLE) | Converts the value of a RGBTRIPLE structure to a Color structure.
Implicit(Color) | Converts the value of a Color structure to a RGBTRIPLE structure.
Implicit(UInt32) | Converts the value of an UInt32 structure to a RGBTRIPLE structure.

See Also

RGBTRIPLE Structure
RGBTRIPLE Members


Implicit Operator

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.Implicit Operator
RGBTRIPLE Structure See Also Send Feedback
Converts the value of a RGBTRIPLE structure to an UInt32 structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator uint (
    RGBTRIPLE value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As RGBTRIPLE _
) As UInteger
Visual C++
static implicit operator unsigned int (
    RGBTRIPLE value
)

Parameters

value
Type: FreeImageAPI..::.RGBTRIPLE
A RGBTRIPLE structure.

Return Value

A new instance of RGBTRIPLE initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.Implicit Operator
RGBTRIPLE Structure See Also Send Feedback
Converts the value of a RGBTRIPLE structure to a Color structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator Color (
    RGBTRIPLE value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As RGBTRIPLE _
) As Color
Visual C++
static implicit operator Color (
    RGBTRIPLE value
)

Parameters

value
Type: FreeImageAPI..::.RGBTRIPLE
A RGBTRIPLE structure.

Return Value

A new instance of Color initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.Implicit Operator
RGBTRIPLE Structure See Also Send Feedback
Converts the value of a Color structure to a RGBTRIPLE structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator RGBTRIPLE (
    Color value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Color _
) As RGBTRIPLE
Visual C++
static implicit operator RGBTRIPLE (
    Color value
)

Parameters

value
Type: System.Drawing..::.Color
A Color structure.

Return Value

A new instance of RGBTRIPLE initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure
Implicit Overload


Implicit Operator

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.Implicit Operator
RGBTRIPLE Structure See Also Send Feedback
Converts the value of an UInt32 structure to a RGBTRIPLE structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator RGBTRIPLE (
    uint value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As UInteger _
) As RGBTRIPLE
Visual C++
static implicit operator RGBTRIPLE (
    unsigned int value
)

Parameters

value
Type: System..::.UInt32
An UInt32 structure.

Return Value

A new instance of RGBTRIPLE initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure
Implicit Overload


Inequality Operator

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.Inequality Operator
RGBTRIPLE Structure See Also Send Feedback
Tests whether two specified RGBTRIPLE structures are different.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    RGBTRIPLE left,
    RGBTRIPLE right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As RGBTRIPLE, _
    right As RGBTRIPLE _
) As Boolean
Visual C++
public:
static bool operator !=(
    RGBTRIPLE left,
    RGBTRIPLE right
)

Parameters

left
Type: FreeImageAPI..::.RGBTRIPLE
The RGBTRIPLE that is to the left of the inequality operator.
right
Type: FreeImageAPI..::.RGBTRIPLE
The RGBTRIPLE that is to the right of the inequality operator.

Return Value

true if the two RGBTRIPLE structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure


ToString Method

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.ToString Method
RGBTRIPLE Structure See Also Send Feedback
Converts the numeric value of the RGBTRIPLE object to its equivalent string representation.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure


RGBTRIPLE Properties

[image] [image] [image]

FreeImage .NET Documentation
RGBTRIPLE Properties
RGBTRIPLE Structure See Also Send Feedback

The RGBTRIPLE type exposes the following members.

Properties

Name | Description
Color | Gets or sets the Color of the structure.

See Also

RGBTRIPLE Structure


Color Property

[image]

FreeImage .NET Documentation
RGBTRIPLE..::.Color Property
RGBTRIPLE Structure See Also Send Feedback
Gets or sets the Color of the structure.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

RGBTRIPLE Structure


Scanline(T) Class

[image]

FreeImage .NET Documentation
Scanline<(Of <(T>)>) Class
Members See Also Send Feedback
Provides methods for working with generic bitmap scanlines.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class Scanline<T> : MemoryArray<T>
where T : struct, new()
Visual Basic (Declaration)
Public NotInheritable Class Scanline(Of T As {Structure, New}) _
    Inherits MemoryArray(Of T)
Visual C++
generic<typename T>
where T : value class, gcnew()
public ref class Scanline sealed : public MemoryArray<T>

Type Parameters

T
Type of the bitmaps' scanlines.

Inheritance Hierarchy

System..::.Object
FreeImageAPI..::.MemoryArray <(Of <(T>)>)
FreeImageAPI..::.Scanline<(Of <(T>)>)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Scanline<(Of <(T>)>) Members


Scanline(T) Members

[image] [image] [image]

FreeImage .NET Documentation
Scanline<(Of <(T>)>) Members
Scanline<(Of <(T>)>) Class Constructors Methods Properties See Also Send Feedback

The Scanline<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
Scanline<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Clone | Creates a shallow copy of the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
CopyFrom | Copies a range of elements from the array starting at the specified sourceIndex and pastes them to the unmanaged array starting at the specified destinationIndex. The length and the indexes are specified as 32-bit integers. (Inherited from MemoryArray<(Of <(T>)>).)
CopyTo | Overloaded.
Dispose | Releases all ressources. (Inherited from MemoryArray<(Of <(T>)>).)
Equals | Overloaded.
GetEnumerator | Retrieves an object that can iterate through the individual elements in this MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from MemoryArray<(Of <(T>)>).)
GetValue | Gets the value at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
GetValues | Gets the values at the specified position and length. (Inherited from MemoryArray<(Of <(T>)>).)
SetValue | Sets a value to the element at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
SetValues | Sets the values at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
ToByteArray | Returns the represented block of memory as an array of Byte. (Inherited from MemoryArray<(Of <(T>)>).)

Properties

Name | Description
BaseAddress | Gets the base address of the represented memory block. (Inherited from MemoryArray<(Of <(T>)>).)
Count | Gets a 32-bit integer that represents the total number of elements in the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
Data | Gets or sets the values of the unmanaged array. (Inherited from MemoryArray<(Of <(T>)>).)
IsSynchronized | Gets a value indicating whether access to the MemoryArray<(Of <(T>)>) is synchronized (thread safe). (Inherited from MemoryArray<(Of <(T>)>).)
Item | Gets or sets the value at the specified position in the array. (Inherited from MemoryArray<(Of <(T>)>).)
Length | Gets the length of the unmanaged array. (Inherited from MemoryArray<(Of <(T>)>).)
SyncRoot | Gets an object that can be used to synchronize access to the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)

See Also

Scanline<(Of <(T>)>) Class


Scanline(T) Constructor

[image] [image] [image]

FreeImage .NET Documentation
Scanline<(Of <(T>)>) Constructor
Scanline<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Scanline<(Of <(T>)>)(FIBITMAP) | Initializes a new instance based on the specified FreeImage bitmap.
Scanline<(Of <(T>)>)(FIBITMAP, Int32) | Initializes a new instance based on the specified FreeImage bitmap.

See Also

Scanline<(Of <(T>)>) Class
Scanline<(Of <(T>)>) Members


Scanline(T) Constructor (FIBITMAP)

[image]

FreeImage .NET Documentation
Scanline<(Of <(T>)>) Constructor (FIBITMAP)
Scanline<(Of <(T>)>) Class See Also Send Feedback
Initializes a new instance based on the specified FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Scanline(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
Scanline(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Scanline<(Of <(T>)>) Class
Scanline<(Of <(T>)>) Overload


Scanline(T) Constructor (FIBITMAP, Int32)

[image]

FreeImage .NET Documentation
Scanline<(Of <(T>)>) Constructor (FIBITMAP, Int32)
Scanline<(Of <(T>)>) Class See Also Send Feedback
Initializes a new instance based on the specified FreeImage bitmap.

Namespace: FreeImageAPI
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Scanline(
    FIBITMAP dib,
    int scanline
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP, _
    scanline As Integer _
)
Visual C++
public:
Scanline(
    FIBITMAP dib,
    int scanline
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
scanline
Type: System..::.Int32
Index of the zero based scanline.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Scanline<(Of <(T>)>) Class
Scanline<(Of <(T>)>) Overload


Scanline(T) Methods

[image] [image] [image]

FreeImage .NET Documentation
Scanline<(Of <(T>)>) Methods
Scanline<(Of <(T>)>) Class See Also Send Feedback

The Scanline<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Clone | Creates a shallow copy of the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
CopyFrom | Copies a range of elements from the array starting at the specified sourceIndex and pastes them to the unmanaged array starting at the specified destinationIndex. The length and the indexes are specified as 32-bit integers. (Inherited from MemoryArray<(Of <(T>)>).)
CopyTo | Overloaded.
Dispose | Releases all ressources. (Inherited from MemoryArray<(Of <(T>)>).)
Equals | Overloaded.
GetEnumerator | Retrieves an object that can iterate through the individual elements in this MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from MemoryArray<(Of <(T>)>).)
GetValue | Gets the value at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
GetValues | Gets the values at the specified position and length. (Inherited from MemoryArray<(Of <(T>)>).)
SetValue | Sets a value to the element at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
SetValues | Sets the values at the specified position. (Inherited from MemoryArray<(Of <(T>)>).)
ToByteArray | Returns the represented block of memory as an array of Byte. (Inherited from MemoryArray<(Of <(T>)>).)

See Also

Scanline<(Of <(T>)>) Class


CopyTo Method

[image] [image] [image]

FreeImage .NET Documentation
Scanline<(Of <(T>)>)..::.CopyTo Method
Scanline<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
CopyTo(Array, Int32) | Copies the entire array to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from MemoryArray<(Of <(T>)>).)
CopyTo(array<T>[]()[], Int32, Int32, Int32) | Copies a range of elements from the unmanaged array starting at the specified sourceIndex and pastes them to array starting at the specified destinationIndex. The length and the indexes are specified as 32-bit integers. (Inherited from MemoryArray<(Of <(T>)>).)

See Also

Scanline<(Of <(T>)>) Class
Scanline<(Of <(T>)>) Members


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
Scanline<(Of <(T>)>)..::.Equals Method
Scanline<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Equals(MemoryArray<(Of <(T>)>)) | Tests whether the specified MemoryArray<(Of <(T>)>) structure is equivalent to this MemoryArray<(Of <(T>)>) structure. (Inherited from MemoryArray<(Of <(T>)>).)
Equals(Object) | Tests whether the specified MemoryArray<(Of <(T>)>) structure is equivalent to this MemoryArray<(Of <(T>)>) structure. (Inherited from MemoryArray<(Of <(T>)>).)

See Also

Scanline<(Of <(T>)>) Class
Scanline<(Of <(T>)>) Members


Scanline(T) Properties

[image] [image] [image]

FreeImage .NET Documentation
Scanline<(Of <(T>)>) Properties
Scanline<(Of <(T>)>) Class See Also Send Feedback

The Scanline<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
BaseAddress | Gets the base address of the represented memory block. (Inherited from MemoryArray<(Of <(T>)>).)
Count | Gets a 32-bit integer that represents the total number of elements in the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)
Data | Gets or sets the values of the unmanaged array. (Inherited from MemoryArray<(Of <(T>)>).)
IsSynchronized | Gets a value indicating whether access to the MemoryArray<(Of <(T>)>) is synchronized (thread safe). (Inherited from MemoryArray<(Of <(T>)>).)
Item | Gets or sets the value at the specified position in the array. (Inherited from MemoryArray<(Of <(T>)>).)
Length | Gets the length of the unmanaged array. (Inherited from MemoryArray<(Of <(T>)>).)
SyncRoot | Gets an object that can be used to synchronize access to the MemoryArray<(Of <(T>)>). (Inherited from MemoryArray<(Of <(T>)>).)

See Also

Scanline<(Of <(T>)>) Class


FreeImageAPI.IO Namespace

[image]

FreeImage .NET Documentation
FreeImageAPI.IO Namespace
Send Feedback

Structures

Structure | Description
fi_handle | Wrapper for a custom handle.
FreeImageIO | Structure for implementing access to custom handles.

Delegates

Delegate | Description
ReadProc | Delegate to the C++ function fread.
SeekProc | Delegate to the C++ function fseek.
TellProc | Delegate to the C++ function ftell.
WriteProc | Delegate to the C++ function fwrite.


fi_handle Structure

[image]

FreeImage .NET Documentation
fi_handle Structure
Members See Also Send Feedback
Wrapper for a custom handle.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct fi_handle : IComparable, IComparable<fi_handle>,
    IEquatable<fi_handle>, IDisposable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure fi_handle _
    Implements IComparable, IComparable(Of fi_handle),  _
    IEquatable(Of fi_handle), IDisposable
Visual C++
[SerializableAttribute]
public value class fi_handle : IComparable,
    IComparable<fi_handle>, IEquatable<fi_handle>, IDisposable

Remarks

The fi_handle of FreeImage in C++ is a simple pointer, but in .NET it's not that simple. This wrapper uses fi_handle in two different ways. We implement a new plugin and FreeImage gives us a handle (pointer) that we can simply pass through to the given functions in a 'FreeImageIO' structure. But when we want to use LoadFromhandle or SaveToHandle we need a fi_handle (that we receive again in our own functions). This handle is for example a stream (see LoadFromStream / SaveToStream) that we want to work with. To know which stream a read/write is meant for we could use a hash value that the wrapper itself handles or we can go the unmanaged way of using a handle. Therefor we use a GCHandle to receive a unique pointer that we can convert back into a .NET object. When the fi_handle instance is no longer needed the instance must be disposed by the creater manually! It is recommended to use the using statement to be sure the instance is always disposed:
CopyC#
using (fi_handle handle = new fi_handle(object))
{
    callSomeFunctions(handle);
}
 What does that mean? If we get a fi_handle from unmanaged code we get a pointer to unmanaged memory that we do not have to care about, and just pass ist back to FreeImage. If we have to create a handle our own we use the standard constructur that fills the IntPtr with an pointer that represents the given object. With calling GetObject()()() the IntPtr is used to retrieve the original object we passed through the constructor. This way we can implement a fi_handle that works with managed an unmanaged code.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Members
FreeImageAPI.IO Namespace


fi_handle Members

[image] [image] [image]

FreeImage .NET Documentation
fi_handle Members
fi_handle Structure Constructors Methods Fields Properties See Also Send Feedback

The fi_handle type exposes the following members.

Constructors

Name | Description
fi_handle | Initializes a new instance wrapping a managed object.

Methods

Name | Description
CompareTo | Overloaded.
Dispose | Releases all resources used by the instance.
Equals | Overloaded.
GetHashCode | Returns a hash code for this fi_handle structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the fi_handle object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified fi_handle structures are equivalent.
Inequality | Tests whether two specified fi_handle structures are different.

Fields

Name | Description
handle | The handle to wrap.

Properties

Name | Description
IsNull | Gets whether the pointer is a null pointer.

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


fi_handle Constructor

[image]

FreeImage .NET Documentation
fi_handle Constructor
fi_handle Structure See Also Send Feedback
Initializes a new instance wrapping a managed object.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public fi_handle(
    Object obj
)
Visual Basic (Declaration)
Public Sub New ( _
    obj As Object _
)
Visual C++
public:
fi_handle(
    Object^ obj
)

Parameters

obj
Type: System..::.Object
The object to wrap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | obj is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


fi_handle Fields

[image] [image] [image]

FreeImage .NET Documentation
fi_handle Fields
fi_handle Structure See Also Send Feedback

The fi_handle type exposes the following members.

Fields

Name | Description
handle | The handle to wrap.

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


handle Field

[image]

FreeImage .NET Documentation
fi_handle..::.handle Field
fi_handle Structure See Also Send Feedback
The handle to wrap.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IntPtr handle
Visual Basic (Declaration)
Public handle As IntPtr
Visual C++
public:
IntPtr handle

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


fi_handle Methods

[image] [image] [image]

FreeImage .NET Documentation
fi_handle Methods
fi_handle Structure See Also Send Feedback

The fi_handle type exposes the following members.

Methods

Name | Description
CompareTo | Overloaded.
Dispose | Releases all resources used by the instance.
Equals | Overloaded.
GetHashCode | Returns a hash code for this fi_handle structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Converts the numeric value of the fi_handle object to its equivalent string representation. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality | Tests whether two specified fi_handle structures are equivalent.
Inequality | Tests whether two specified fi_handle structures are different.

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
fi_handle..::.CompareTo Method
fi_handle Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(fi_handle) | Compares this instance with a specified fi_handle object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

fi_handle Structure
fi_handle Members
FreeImageAPI.IO Namespace


CompareTo Method (fi_handle)

[image]

FreeImage .NET Documentation
fi_handle..::.CompareTo Method (fi_handle)
fi_handle Structure See Also Send Feedback
Compares this instance with a specified fi_handle object.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    fi_handle other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As fi_handle _
) As Integer
Visual C++
public:
virtual int CompareTo(
    fi_handle other
) sealed

Parameters

other
Type: FreeImageAPI.IO..::.fi_handle
A fi_handle to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
CompareTo Overload
FreeImageAPI.IO Namespace


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
fi_handle..::.CompareTo Method (Object)
fi_handle Structure See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a fi_handle.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
CompareTo Overload
FreeImageAPI.IO Namespace


Dispose Method

[image]

FreeImage .NET Documentation
fi_handle..::.Dispose Method
fi_handle Structure See Also Send Feedback
Releases all resources used by the instance.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


Equality Operator

[image]

FreeImage .NET Documentation
fi_handle..::.Equality Operator
fi_handle Structure See Also Send Feedback
Tests whether two specified fi_handle structures are equivalent.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    fi_handle left,
    fi_handle right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As fi_handle, _
    right As fi_handle _
) As Boolean
Visual C++
public:
static bool operator ==(
    fi_handle left,
    fi_handle right
)

Parameters

left
Type: FreeImageAPI.IO..::.fi_handle
The fi_handle that is to the left of the equality operator.
right
Type: FreeImageAPI.IO..::.fi_handle
The fi_handle that is to the right of the equality operator.

Return Value

true if the two fi_handle structures are equal; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
fi_handle..::.Equals Method
fi_handle Structure See Also Send Feedback

Overload List

Name | Description
Equals(fi_handle) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Tests whether the specified object is a fi_handle structure and is equivalent to this fi_handle structure. (Overrides ValueType..::.Equals(Object).)

See Also

fi_handle Structure
fi_handle Members
FreeImageAPI.IO Namespace


Equals Method (fi_handle)

[image]

FreeImage .NET Documentation
fi_handle..::.Equals Method (fi_handle)
fi_handle Structure See Also Send Feedback
Indicates whether the current object is equal to another object of the same type.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    fi_handle other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As fi_handle _
) As Boolean
Visual C++
public:
virtual bool Equals(
    fi_handle other
) sealed

Parameters

other
Type: FreeImageAPI.IO..::.fi_handle
An object to compare with this object.

Return Value

True if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
Equals Overload
FreeImageAPI.IO Namespace


Equals Method (Object)

[image]

FreeImage .NET Documentation
fi_handle..::.Equals Method (Object)
fi_handle Structure See Also Send Feedback
Tests whether the specified object is a fi_handle structure and is equivalent to this fi_handle structure.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a fi_handle structure equivalent to this fi_handle structure; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
Equals Overload
FreeImageAPI.IO Namespace


GetHashCode Method

[image]

FreeImage .NET Documentation
fi_handle..::.GetHashCode Method
fi_handle Structure See Also Send Feedback
Returns a hash code for this fi_handle structure.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this fi_handle.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


Inequality Operator

[image]

FreeImage .NET Documentation
fi_handle..::.Inequality Operator
fi_handle Structure See Also Send Feedback
Tests whether two specified fi_handle structures are different.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    fi_handle left,
    fi_handle right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As fi_handle, _
    right As fi_handle _
) As Boolean
Visual C++
public:
static bool operator !=(
    fi_handle left,
    fi_handle right
)

Parameters

left
Type: FreeImageAPI.IO..::.fi_handle
The fi_handle that is to the left of the inequality operator.
right
Type: FreeImageAPI.IO..::.fi_handle
The fi_handle that is to the right of the inequality operator.

Return Value

true if the two fi_handle structures are different; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


ToString Method

[image]

FreeImage .NET Documentation
fi_handle..::.ToString Method
fi_handle Structure See Also Send Feedback
Converts the numeric value of the fi_handle object to its equivalent string representation.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


fi_handle Properties

[image] [image] [image]

FreeImage .NET Documentation
fi_handle Properties
fi_handle Structure See Also Send Feedback

The fi_handle type exposes the following members.

Properties

Name | Description
IsNull | Gets whether the pointer is a null pointer.

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


IsNull Property

[image]

FreeImage .NET Documentation
fi_handle..::.IsNull Property
fi_handle Structure See Also Send Feedback
Gets whether the pointer is a null pointer.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool IsNull { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
Visual C++
public:
property bool IsNull {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

fi_handle Structure
FreeImageAPI.IO Namespace


FreeImageIO Structure

[image]

FreeImage .NET Documentation
FreeImageIO Structure
Members See Also Send Feedback
Structure for implementing access to custom handles.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public struct FreeImageIO
Visual Basic (Declaration)
Public Structure FreeImageIO
Visual C++
public value class FreeImageIO

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageIO Members
FreeImageAPI.IO Namespace


FreeImageIO Members

[image] [image] [image]

FreeImage .NET Documentation
FreeImageIO Members
FreeImageIO Structure Fields See Also Send Feedback

The FreeImageIO type exposes the following members.

Fields

Name | Description
readProc | Delegate to the C++ function fread.
seekProc | Delegate to the C++ function fseek.
tellProc | Delegate to the C++ function ftell.
writeProc | Delegate to the C++ function fwrite.

See Also

FreeImageIO Structure
FreeImageAPI.IO Namespace


FreeImageIO Fields

[image] [image] [image]

FreeImage .NET Documentation
FreeImageIO Fields
FreeImageIO Structure See Also Send Feedback

The FreeImageIO type exposes the following members.

Fields

Name | Description
readProc | Delegate to the C++ function fread.
seekProc | Delegate to the C++ function fseek.
tellProc | Delegate to the C++ function ftell.
writeProc | Delegate to the C++ function fwrite.

See Also

FreeImageIO Structure
FreeImageAPI.IO Namespace


readProc Field

[image]

FreeImage .NET Documentation
FreeImageIO..::.readProc Field
FreeImageIO Structure See Also Send Feedback
Delegate to the C++ function fread.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ReadProc readProc
Visual Basic (Declaration)
Public readProc As ReadProc
Visual C++
public:
ReadProc^ readProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageIO Structure
FreeImageAPI.IO Namespace


seekProc Field

[image]

FreeImage .NET Documentation
FreeImageIO..::.seekProc Field
FreeImageIO Structure See Also Send Feedback
Delegate to the C++ function fseek.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public SeekProc seekProc
Visual Basic (Declaration)
Public seekProc As SeekProc
Visual C++
public:
SeekProc^ seekProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageIO Structure
FreeImageAPI.IO Namespace


tellProc Field

[image]

FreeImage .NET Documentation
FreeImageIO..::.tellProc Field
FreeImageIO Structure See Also Send Feedback
Delegate to the C++ function ftell.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public TellProc tellProc
Visual Basic (Declaration)
Public tellProc As TellProc
Visual C++
public:
TellProc^ tellProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageIO Structure
FreeImageAPI.IO Namespace


writeProc Field

[image]

FreeImage .NET Documentation
FreeImageIO..::.writeProc Field
FreeImageIO Structure See Also Send Feedback
Delegate to the C++ function fwrite.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public WriteProc writeProc
Visual Basic (Declaration)
Public writeProc As WriteProc
Visual C++
public:
WriteProc^ writeProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageIO Structure
FreeImageAPI.IO Namespace


ReadProc Delegate

[image]

FreeImage .NET Documentation
ReadProc Delegate
See Also Send Feedback
Delegate to the C++ function fread.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate uint ReadProc(
    IntPtr buffer,
    uint size,
    uint count,
    fi_handle handle
)
Visual Basic (Declaration)
Public Delegate Function ReadProc ( _
    buffer As IntPtr, _
    size As UInteger, _
    count As UInteger, _
    handle As fi_handle _
) As UInteger
Visual C++
public delegate unsigned int ReadProc(
    IntPtr buffer,
    unsigned int size,
    unsigned int count,
    fi_handle handle
)

Parameters

buffer
Type: System..::.IntPtr
Pointer to read from.
size
Type: System..::.UInt32
Item size in bytes.
count
Type: System..::.UInt32
Maximum number of items to be read.
handle
Type: FreeImageAPI.IO..::.fi_handle
Handle/stream to read from.

Return Value

Number of full items actually read, which may be less than count if an error occurs or if the end of the file is encountered before reaching count.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.IO Namespace


SeekProc Delegate

[image]

FreeImage .NET Documentation
SeekProc Delegate
See Also Send Feedback
Delegate to the C++ function fseek.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate int SeekProc(
    fi_handle handle,
    int offset,
    SeekOrigin origin
)
Visual Basic (Declaration)
Public Delegate Function SeekProc ( _
    handle As fi_handle, _
    offset As Integer, _
    origin As SeekOrigin _
) As Integer
Visual C++
public delegate int SeekProc(
    fi_handle handle,
    int offset,
    SeekOrigin origin
)

Parameters

handle
Type: FreeImageAPI.IO..::.fi_handle
Handle/stream to seek in.
offset
Type: System..::.Int32
Number of bytes from origin.
origin
Type: System.IO..::.SeekOrigin
Initial position.

Return Value

If successful 0 is returned; otherwise a nonzero value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.IO Namespace


TellProc Delegate

[image]

FreeImage .NET Documentation
TellProc Delegate
See Also Send Feedback
Delegate to the C++ function ftell.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate int TellProc(
    fi_handle handle
)
Visual Basic (Declaration)
Public Delegate Function TellProc ( _
    handle As fi_handle _
) As Integer
Visual C++
public delegate int TellProc(
    fi_handle handle
)

Parameters

handle
Type: FreeImageAPI.IO..::.fi_handle
Handle/stream to retrieve its currents position from.

Return Value

The current position.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.IO Namespace


WriteProc Delegate

[image]

FreeImage .NET Documentation
WriteProc Delegate
See Also Send Feedback
Delegate to the C++ function fwrite.

Namespace: FreeImageAPI.IO
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate uint WriteProc(
    IntPtr buffer,
    uint size,
    uint count,
    fi_handle handle
)
Visual Basic (Declaration)
Public Delegate Function WriteProc ( _
    buffer As IntPtr, _
    size As UInteger, _
    count As UInteger, _
    handle As fi_handle _
) As UInteger
Visual C++
public delegate unsigned int WriteProc(
    IntPtr buffer,
    unsigned int size,
    unsigned int count,
    fi_handle handle
)

Parameters

buffer
Type: System..::.IntPtr
Pointer to data to be written.
size
Type: System..::.UInt32
Item size in bytes.
count
Type: System..::.UInt32
Maximum number of items to be written.
handle
Type: FreeImageAPI.IO..::.fi_handle
Handle/stream to write to.

Return Value

Number of full items actually written, which may be less than count if an error occurs. Also, if an error occurs, the file-position indicator cannot be determined.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.IO Namespace


FreeImageAPI.Metadata Namespace

[image]

FreeImage .NET Documentation
FreeImageAPI.Metadata Namespace
Send Feedback

Classes

Class | Description
GifInformation | Provides additional information specific for GIF files. This class cannot be inherited.
ImageMetadata | Class handling metadata of a FreeImage bitmap.
MDM_ANIMATION | Represents a collection of all tags contained in the metadata model FIMD_ANIMATION.
MDM_COMMENTS | Represents a collection of all tags contained in the metadata model FIMD_COMMENTS.
MDM_CUSTOM | Represents a collection of all tags contained in the metadata model FIMD_CUSTOM.
MDM_EXIF_EXIF | Represents a collection of all tags contained in the metadata model FIMD_EXIF_EXIF.
MDM_EXIF_GPS | Represents a collection of all tags contained in the metadata model FIMD_EXIF_GPS.
MDM_EXIF_MAIN | Represents a collection of all tags contained in the metadata model FIMD_EXIF_MAIN.
MDM_GEOTIFF | Represents a collection of all tags contained in the metadata model FIMD_GEOTIFF.
MDM_INTEROP | Represents a collection of all tags contained in the metadata model FIMD_EXIF_INTEROP.
MDM_IPTC | Represents a collection of all tags contained in the metadata model FIMD_IPTC.
MDM_MAIN | Represents a collection of all tags contained in the metadata model FIMD_EXIF_MAIN. This class is obsolete. Use class MDM_EXIF_MAIN instead.
MDM_MAKERNOTE | Represents a collection of all tags contained in the metadata model FIMD_EXIF_MAKERNOTE.
MDM_NODATA | Represents a collection of all tags contained in the metadata model FIMD_NODATA.
MDM_XMP | Represents a collection of all tags contained in the metadata model FIMD_XMP.
MetadataModel | Base class that represents a collection of all tags contained in a metadata model.
MetadataTag | Manages metadata objects and operations.

Enumerations

Enumeration | Description
DisposalMethodType | Specifies how a single frame will be handled after being displayed.
MetadataModel..::.AltitudeType | Specifies different altitude types.
MetadataModel..::.DirectionReference | Specifies different direction types.
MetadataModel..::.ExifImageOrientation | Specifies orientation of images.
MetadataModel..::.InteroperabilityMode | Specifies interoperability types.
MetadataModel..::.LatitudeType | Specifies the type of a latitude value.
MetadataModel..::.LongitudeType | Specifies the type of a longitude value.
MetadataModel..::.VelocityUnit | Specified different unit types.


DisposalMethodType Enumeration

[image]

FreeImage .NET Documentation
DisposalMethodType Enumeration
See Also Send Feedback
Specifies how a single frame will be handled after being displayed.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum DisposalMethodType
Visual Basic (Declaration)
Public Enumeration DisposalMethodType
Visual C++
public enum class DisposalMethodType

Members

Member name | Description
Unspecified | Same behavior as Leave but should not be used.
Leave | The image is left in place and will be overdrawn by the next image.
Background | The area of the image will be blanked out by its background.
Previous | Restores the the area of the image to the state it was before it has been dawn.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Metadata Namespace


GifInformation Class

[image]

FreeImage .NET Documentation
GifInformation Class
Members See Also Send Feedback
Provides additional information specific for GIF files. This class cannot be inherited.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public class GifInformation : MDM_ANIMATION
Visual Basic (Declaration)
Public Class GifInformation _
    Inherits MDM_ANIMATION
Visual C++
public ref class GifInformation : public MDM_ANIMATION

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_ANIMATION
FreeImageAPI.Metadata..::.GifInformation

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

GifInformation Members
FreeImageAPI.Metadata Namespace


GifInformation Members

[image] [image] [image]

FreeImage .NET Documentation
GifInformation Members
GifInformation Class Constructors Methods Fields Properties See Also Send Feedback

The GifInformation type exposes the following members.

Constructors

Name | Description
GifInformation | Initializes a new instance of the GifInformation class with the specified FreeImageBitmap.

Methods

Name | Description
AddTag | Overloaded.
CreateGlobalPalette | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
DisposalMethod | Gets or sets this frame's disposal method. Generally, this method defines, how to remove or replace a frame when the next frame has to be drawn. (Inherited from MDM_ANIMATION.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
FrameLeft | Gets or sets the horizontal offset within the logical canvas area, this frame is to be displayed at. (Inherited from MDM_ANIMATION.)
FrameTime | Gets or sets the amout of time in milliseconds this frame is to be displayed. (Inherited from MDM_ANIMATION.)
FrameTop | Gets or sets the vertical offset within the logical canvas area, this frame is to be displayed at. (Inherited from MDM_ANIMATION.)
GlobalPalette | Gets or sets the global palette of the GIF image. (Inherited from MDM_ANIMATION.)
Interlaced | Gets or sets a value indicating whether the image is interlaced. (Inherited from MDM_ANIMATION.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
LogicalHeight | Gets or sets the height of the entire canvas area, that each page is displayed in. (Inherited from MDM_ANIMATION.)
LogicalWidth | Gets or sets the width of the entire canvas area, that each page is displayed in. (Inherited from MDM_ANIMATION.)
LoopCount | Gets or sets the number of replays for the animation. Use 0 (zero) to specify an infinte number of replays. (Inherited from MDM_ANIMATION.)
Model | Retrieves the datamodel that this instance represents. (Inherited from MDM_ANIMATION.)
NoLocalPalette | Gets or sets a flag to supress saving the dib's attached palette (making it use the global palette). The local palette is the palette used by a page. (Inherited from MDM_ANIMATION.)
UseGlobalPalette | Gets or sets a value indicating whether this frame uses the GIF image's global palette. If set to false, this frame uses its local palette.

See Also

GifInformation Class
FreeImageAPI.Metadata Namespace


GifInformation Constructor

[image]

FreeImage .NET Documentation
GifInformation Constructor
GifInformation Class See Also Send Feedback
Initializes a new instance of the GifInformation class with the specified FreeImageBitmap.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public GifInformation(
    FreeImageBitmap bitmap
)
Visual Basic (Declaration)
Public Sub New ( _
    bitmap As FreeImageBitmap _
)
Visual C++
public:
GifInformation(
    FreeImageBitmap^ bitmap
)

Parameters

bitmap
Type: FreeImageAPI..::.FreeImageBitmap
A reference to a FreeImageBitmap instance.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

GifInformation Class
FreeImageAPI.Metadata Namespace


GifInformation Fields

[image] [image] [image]

FreeImage .NET Documentation
GifInformation Fields
GifInformation Class See Also Send Feedback

The GifInformation type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

GifInformation Class
FreeImageAPI.Metadata Namespace


GifInformation Methods

[image] [image] [image]

FreeImage .NET Documentation
GifInformation Methods
GifInformation Class See Also Send Feedback

The GifInformation type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
CreateGlobalPalette | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

GifInformation Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
GifInformation..::.AddTag Method
GifInformation Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

GifInformation Class
GifInformation Members
FreeImageAPI.Metadata Namespace


CreateGlobalPalette Method

[image] [image] [image]

FreeImage .NET Documentation
GifInformation..::.CreateGlobalPalette Method
GifInformation Class See Also Send Feedback

Overload List

Name | Description
CreateGlobalPalette()()() | Creates a global palette for the GIF image, intialized with all entries of the current local palette. The property UseGlobalPalette will be set to true when invoking this method. This effectively enables the newly created global palette.
CreateGlobalPalette(Palette) | Creates a global palette for the GIF image, intialized with the entries of the specified palette. The property UseGlobalPalette will be set to true when invoking this method. This effectively enables the newly created global palette.
CreateGlobalPalette(Int32) | Creates a global palette for the GIF image with the specified size, intialized with the first size entries of the current local palette. The property UseGlobalPalette will be set to true when invoking this method. This effectively enables the newly created global palette.
CreateGlobalPalette(Palette, Int32) | Creates a global palette for the GIF image with the specified size, intialized with the first size entries of the specified palette. The property UseGlobalPalette will be set to true when invoking this method. This effectively enables the newly created global palette.

See Also

GifInformation Class
GifInformation Members
FreeImageAPI.Metadata Namespace


CreateGlobalPalette Method

[image]

FreeImage .NET Documentation
GifInformation..::.CreateGlobalPalette Method
GifInformation Class See Also Send Feedback
Creates a global palette for the GIF image, intialized with all entries of the current local palette. The property UseGlobalPalette will be set to true when invoking this method. This effectively enables the newly created global palette.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CreateGlobalPalette()
Visual Basic (Declaration)
Public Sub CreateGlobalPalette
Visual C++
public:
void CreateGlobalPalette()

Exceptions

Exception | Condition
System..::.InvalidOperationException | The image does not have a palette.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

GifInformation Class
CreateGlobalPalette Overload
FreeImageAPI.Metadata Namespace


CreateGlobalPalette Method (Palette)

[image]

FreeImage .NET Documentation
GifInformation..::.CreateGlobalPalette Method (Palette)
GifInformation Class See Also Send Feedback
Creates a global palette for the GIF image, intialized with the entries of the specified palette. The property UseGlobalPalette will be set to true when invoking this method. This effectively enables the newly created global palette.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CreateGlobalPalette(
    Palette palette
)
Visual Basic (Declaration)
Public Sub CreateGlobalPalette ( _
    palette As Palette _
)
Visual C++
public:
void CreateGlobalPalette(
    Palette^ palette
)

Parameters

palette
Type: FreeImageAPI..::.Palette
The palette that contains the initial values for the newly created global palette.

Exceptions

Exception | Condition
System..::.ArgumentNullException | palette is a null reference.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

GifInformation Class
CreateGlobalPalette Overload
FreeImageAPI.Metadata Namespace


CreateGlobalPalette Method (Int32)

[image]

FreeImage .NET Documentation
GifInformation..::.CreateGlobalPalette Method (Int32)
GifInformation Class See Also Send Feedback
Creates a global palette for the GIF image with the specified size, intialized with the first size entries of the current local palette. The property UseGlobalPalette will be set to true when invoking this method. This effectively enables the newly created global palette.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CreateGlobalPalette(
    int size
)
Visual Basic (Declaration)
Public Sub CreateGlobalPalette ( _
    size As Integer _
)
Visual C++
public:
void CreateGlobalPalette(
    int size
)

Parameters

size
Type: System..::.Int32
The size of the newly created global palette.

Exceptions

Exception | Condition
System..::.ArgumentNullException | palette is a null reference.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

GifInformation Class
CreateGlobalPalette Overload
FreeImageAPI.Metadata Namespace


CreateGlobalPalette Method (Palette, Int32)

[image]

FreeImage .NET Documentation
GifInformation..::.CreateGlobalPalette Method (Palette, Int32)
GifInformation Class See Also Send Feedback
Creates a global palette for the GIF image with the specified size, intialized with the first size entries of the specified palette. The property UseGlobalPalette will be set to true when invoking this method. This effectively enables the newly created global palette.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void CreateGlobalPalette(
    Palette palette,
    int size
)
Visual Basic (Declaration)
Public Sub CreateGlobalPalette ( _
    palette As Palette, _
    size As Integer _
)
Visual C++
public:
void CreateGlobalPalette(
    Palette^ palette,
    int size
)

Parameters

palette
Type: FreeImageAPI..::.Palette
The palette that contains the initial values for the newly created global palette.
size
Type: System..::.Int32
The size of the newly created global palette.

Exceptions

Exception | Condition
System..::.ArgumentNullException | palette is a null reference.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

GifInformation Class
CreateGlobalPalette Overload
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
GifInformation..::.SetTagValue Method
GifInformation Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

GifInformation Class
GifInformation Members
FreeImageAPI.Metadata Namespace


GifInformation Properties

[image] [image] [image]

FreeImage .NET Documentation
GifInformation Properties
GifInformation Class See Also Send Feedback

The GifInformation type exposes the following members.

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
DisposalMethod | Gets or sets this frame's disposal method. Generally, this method defines, how to remove or replace a frame when the next frame has to be drawn. (Inherited from MDM_ANIMATION.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
FrameLeft | Gets or sets the horizontal offset within the logical canvas area, this frame is to be displayed at. (Inherited from MDM_ANIMATION.)
FrameTime | Gets or sets the amout of time in milliseconds this frame is to be displayed. (Inherited from MDM_ANIMATION.)
FrameTop | Gets or sets the vertical offset within the logical canvas area, this frame is to be displayed at. (Inherited from MDM_ANIMATION.)
GlobalPalette | Gets or sets the global palette of the GIF image. (Inherited from MDM_ANIMATION.)
Interlaced | Gets or sets a value indicating whether the image is interlaced. (Inherited from MDM_ANIMATION.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
LogicalHeight | Gets or sets the height of the entire canvas area, that each page is displayed in. (Inherited from MDM_ANIMATION.)
LogicalWidth | Gets or sets the width of the entire canvas area, that each page is displayed in. (Inherited from MDM_ANIMATION.)
LoopCount | Gets or sets the number of replays for the animation. Use 0 (zero) to specify an infinte number of replays. (Inherited from MDM_ANIMATION.)
Model | Retrieves the datamodel that this instance represents. (Inherited from MDM_ANIMATION.)
NoLocalPalette | Gets or sets a flag to supress saving the dib's attached palette (making it use the global palette). The local palette is the palette used by a page. (Inherited from MDM_ANIMATION.)
UseGlobalPalette | Gets or sets a value indicating whether this frame uses the GIF image's global palette. If set to false, this frame uses its local palette.

See Also

GifInformation Class
FreeImageAPI.Metadata Namespace


UseGlobalPalette Property

[image]

FreeImage .NET Documentation
GifInformation..::.UseGlobalPalette Property
GifInformation Class See Also Send Feedback
Gets or sets a value indicating whether this frame uses the GIF image's global palette. If set to false, this frame uses its local palette.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<bool> UseGlobalPalette { get; set; }
Visual Basic (Declaration)
Public Property UseGlobalPalette As Nullable(Of Boolean)
Visual C++
public:
property Nullable<bool> UseGlobalPalette {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

GifInformation Class
FreeImageAPI.Metadata Namespace


ImageMetadata Class

[image]

FreeImage .NET Documentation
ImageMetadata Class
Members See Also Send Feedback
Class handling metadata of a FreeImage bitmap.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public class ImageMetadata : IEnumerable,
    IComparable, IComparable<ImageMetadata>
Visual Basic (Declaration)
Public Class ImageMetadata _
    Implements IEnumerable, IComparable, IComparable(Of ImageMetadata)
Visual C++
public ref class ImageMetadata : IEnumerable,
    IComparable, IComparable<ImageMetadata^>

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.ImageMetadata

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Members
FreeImageAPI.Metadata Namespace


ImageMetadata Members

[image] [image] [image]

FreeImage .NET Documentation
ImageMetadata Members
ImageMetadata Class Constructors Methods Properties See Also Send Feedback

The ImageMetadata type exposes the following members.

Constructors

Name | Description
ImageMetadata | Overloaded.

Methods

Name | Description
AddTag | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key.
CompareTo | Overloaded.
GetEnumerator | Retrieves an object that can iterate through the individual MetadataModels in this ImageMetadata.

Properties

Name | Description
Count | Returns the number of visible MetadataModels.
HideEmptyModels | Gets or sets whether empty MetadataModels are hidden.
Item | Overloaded.
List | Returns a list of all visible MetadataModels.

See Also

ImageMetadata Class
FreeImageAPI.Metadata Namespace


ImageMetadata Constructor

[image] [image] [image]

FreeImage .NET Documentation
ImageMetadata Constructor
ImageMetadata Class See Also Send Feedback

Overload List

Name | Description
ImageMetadata(FIBITMAP) | Initializes a new instance based on the specified FIBITMAP, showing all known models.
ImageMetadata(FIBITMAP, Boolean) | Initializes a new instance based on the specified FIBITMAP, showing or hiding empry models.

See Also

ImageMetadata Class
ImageMetadata Members
FreeImageAPI.Metadata Namespace


ImageMetadata Constructor (FIBITMAP)

[image]

FreeImage .NET Documentation
ImageMetadata Constructor (FIBITMAP)
ImageMetadata Class See Also Send Feedback
Initializes a new instance based on the specified FIBITMAP, showing all known models.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ImageMetadata(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
ImageMetadata(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Class
ImageMetadata Overload
FreeImageAPI.Metadata Namespace


ImageMetadata Constructor (FIBITMAP, Boolean)

[image]

FreeImage .NET Documentation
ImageMetadata Constructor (FIBITMAP, Boolean)
ImageMetadata Class See Also Send Feedback
Initializes a new instance based on the specified FIBITMAP, showing or hiding empry models.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ImageMetadata(
    FIBITMAP dib,
    bool hideEmptyModels
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP, _
    hideEmptyModels As Boolean _
)
Visual C++
public:
ImageMetadata(
    FIBITMAP dib,
    bool hideEmptyModels
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.
hideEmptyModels
Type: System..::.Boolean
When true, empty metadata models will be hidden until a tag to this model is added.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Class
ImageMetadata Overload
FreeImageAPI.Metadata Namespace


ImageMetadata Methods

[image] [image] [image]

FreeImage .NET Documentation
ImageMetadata Methods
ImageMetadata Class See Also Send Feedback

The ImageMetadata type exposes the following members.

Methods

Name | Description
AddTag | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key.
CompareTo | Overloaded.
GetEnumerator | Retrieves an object that can iterate through the individual MetadataModels in this ImageMetadata.

See Also

ImageMetadata Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image]

FreeImage .NET Documentation
ImageMetadata..::.AddTag Method
ImageMetadata Class See Also Send Feedback
Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool AddTag(
    MetadataTag tag
)
Visual Basic (Declaration)
Public Function AddTag ( _
    tag As MetadataTag _
) As Boolean
Visual C++
public:
bool AddTag(
    MetadataTag^ tag
)

Parameters

tag
Type: FreeImageAPI.Metadata..::.MetadataTag
The tag to add or update.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | tag is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Class
FreeImageAPI.Metadata Namespace


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
ImageMetadata..::.CompareTo Method
ImageMetadata Class See Also Send Feedback

Overload List

Name | Description
CompareTo(ImageMetadata) | Compares this instance with a specified ImageMetadata object.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

ImageMetadata Class
ImageMetadata Members
FreeImageAPI.Metadata Namespace


CompareTo Method (ImageMetadata)

[image]

FreeImage .NET Documentation
ImageMetadata..::.CompareTo Method (ImageMetadata)
ImageMetadata Class See Also Send Feedback
Compares this instance with a specified ImageMetadata object.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    ImageMetadata other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As ImageMetadata _
) As Integer
Visual C++
public:
virtual int CompareTo(
    ImageMetadata^ other
) sealed

Parameters

other
Type: FreeImageAPI.Metadata..::.ImageMetadata
A ImageMetadata to compare.

Return Value

A signed number indicating the relative values of this instance and other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Class
CompareTo Overload
FreeImageAPI.Metadata Namespace


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
ImageMetadata..::.CompareTo Method (Object)
ImageMetadata Class See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a ImageMetadata.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Class
CompareTo Overload
FreeImageAPI.Metadata Namespace


GetEnumerator Method

[image]

FreeImage .NET Documentation
ImageMetadata..::.GetEnumerator Method
ImageMetadata Class See Also Send Feedback
Retrieves an object that can iterate through the individual MetadataModels in this ImageMetadata.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator for this ImageMetadata.

Implements

IEnumerable..::.GetEnumerator()()()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Class
FreeImageAPI.Metadata Namespace


ImageMetadata Properties

[image] [image] [image]

FreeImage .NET Documentation
ImageMetadata Properties
ImageMetadata Class See Also Send Feedback

The ImageMetadata type exposes the following members.

Properties

Name | Description
Count | Returns the number of visible MetadataModels.
HideEmptyModels | Gets or sets whether empty MetadataModels are hidden.
Item | Overloaded.
List | Returns a list of all visible MetadataModels.

See Also

ImageMetadata Class
FreeImageAPI.Metadata Namespace


Count Property

[image]

FreeImage .NET Documentation
ImageMetadata..::.Count Property
ImageMetadata Class See Also Send Feedback
Returns the number of visible MetadataModels.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Class
FreeImageAPI.Metadata Namespace


HideEmptyModels Property

[image]

FreeImage .NET Documentation
ImageMetadata..::.HideEmptyModels Property
ImageMetadata Class See Also Send Feedback
Gets or sets whether empty MetadataModels are hidden.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool HideEmptyModels { get; set; }
Visual Basic (Declaration)
Public Property HideEmptyModels As Boolean
Visual C++
public:
property bool HideEmptyModels {
    bool get ();
    void set (bool value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Class
FreeImageAPI.Metadata Namespace


Item Property

[image] [image] [image]

FreeImage .NET Documentation
ImageMetadata..::.Item Property
ImageMetadata Class See Also Send Feedback

Overload List

Name | Description
Item[([(FREE_IMAGE_MDMODEL])]) | Gets or sets the MetadataModel of the specified type. In case the getter returns null the model is not contained by the list. null can be used calling the setter to destroy the model.
Item[([(Int32])]) | Gets or sets the MetadataModel at the specified index. In case the getter returns null the model is not contained by the list. null can be used calling the setter to destroy the model.

See Also

ImageMetadata Class
ImageMetadata Members
FreeImageAPI.Metadata Namespace


Item Property (FREE_IMAGE_MDMODEL)

[image]

FreeImage .NET Documentation
ImageMetadata..::.Item Property (FREE_IMAGE_MDMODEL)
ImageMetadata Class See Also Send Feedback
Gets or sets the MetadataModel of the specified type.

In case the getter returns null the model is not contained by the list.

null can be used calling the setter to destroy the model.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MetadataModel this[
    FREE_IMAGE_MDMODEL model
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    model As FREE_IMAGE_MDMODEL _
) As MetadataModel
Visual C++
public:
property MetadataModel^ default[FREE_IMAGE_MDMODEL model] {
    MetadataModel^ get (FREE_IMAGE_MDMODEL model);
}

Parameters

model
Type: FreeImageAPI..::.FREE_IMAGE_MDMODEL
Type of the model.

Return Value

The MetadataModel object of the specified type.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Class
Item Overload
FreeImageAPI.Metadata Namespace


Item Property (Int32)

[image]

FreeImage .NET Documentation
ImageMetadata..::.Item Property (Int32)
ImageMetadata Class See Also Send Feedback
Gets or sets the MetadataModel at the specified index.

In case the getter returns null the model is not contained by the list.

null can be used calling the setter to destroy the model.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MetadataModel this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As MetadataModel
Visual C++
public:
property MetadataModel^ default[int index] {
    MetadataModel^ get (int index);
}

Parameters

index
Type: System..::.Int32
Index of the MetadataModel within this instance.

Return Value

The MetadataModel object at the specified index.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Class
Item Overload
FreeImageAPI.Metadata Namespace


List Property

[image]

FreeImage .NET Documentation
ImageMetadata..::.List Property
ImageMetadata Class See Also Send Feedback
Returns a list of all visible MetadataModels.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public List<MetadataModel> List { get; }
Visual Basic (Declaration)
Public ReadOnly Property List As List(Of MetadataModel)
Visual C++
public:
property List<MetadataModel^>^ List {
    List<MetadataModel^>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

ImageMetadata Class
FreeImageAPI.Metadata Namespace


MDM_ANIMATION Class

[image]

FreeImage .NET Documentation
MDM_ANIMATION Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_ANIMATION.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MDM_ANIMATION : MetadataModel
Visual Basic (Declaration)
Public NotInheritable Class MDM_ANIMATION _
    Inherits MetadataModel
Visual C++
public ref class MDM_ANIMATION sealed : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_ANIMATION

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Members
FreeImageAPI.Metadata Namespace


MDM_ANIMATION Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_ANIMATION Members
MDM_ANIMATION Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_ANIMATION type exposes the following members.

Constructors

Name | Description
MDM_ANIMATION | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
DisposalMethod | Gets or sets this frame's disposal method. Generally, this method defines, how to remove or replace a frame when the next frame has to be drawn.
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
FrameLeft | Gets or sets the horizontal offset within the logical canvas area, this frame is to be displayed at.
FrameTime | Gets or sets the amout of time in milliseconds this frame is to be displayed.
FrameTop | Gets or sets the vertical offset within the logical canvas area, this frame is to be displayed at.
GlobalPalette | Gets or sets the global palette of the GIF image.
Interlaced | Gets or sets a value indicating whether the image is interlaced.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
LogicalHeight | Gets or sets the height of the entire canvas area, that each page is displayed in.
LogicalWidth | Gets or sets the width of the entire canvas area, that each page is displayed in.
LoopCount | Gets or sets the number of replays for the animation. Use 0 (zero) to specify an infinte number of replays.
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
NoLocalPalette | Gets or sets a flag to supress saving the dib's attached palette (making it use the global palette). The local palette is the palette used by a page.

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


MDM_ANIMATION Constructor

[image]

FreeImage .NET Documentation
MDM_ANIMATION Constructor
MDM_ANIMATION Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_ANIMATION(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_ANIMATION(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


MDM_ANIMATION Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_ANIMATION Fields
MDM_ANIMATION Class See Also Send Feedback

The MDM_ANIMATION type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


MDM_ANIMATION Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_ANIMATION Methods
MDM_ANIMATION Class See Also Send Feedback

The MDM_ANIMATION type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_ANIMATION..::.AddTag Method
MDM_ANIMATION Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_ANIMATION Class
MDM_ANIMATION Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_ANIMATION..::.SetTagValue Method
MDM_ANIMATION Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_ANIMATION Class
MDM_ANIMATION Members
FreeImageAPI.Metadata Namespace


MDM_ANIMATION Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_ANIMATION Properties
MDM_ANIMATION Class See Also Send Feedback

The MDM_ANIMATION type exposes the following members.

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
DisposalMethod | Gets or sets this frame's disposal method. Generally, this method defines, how to remove or replace a frame when the next frame has to be drawn.
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
FrameLeft | Gets or sets the horizontal offset within the logical canvas area, this frame is to be displayed at.
FrameTime | Gets or sets the amout of time in milliseconds this frame is to be displayed.
FrameTop | Gets or sets the vertical offset within the logical canvas area, this frame is to be displayed at.
GlobalPalette | Gets or sets the global palette of the GIF image.
Interlaced | Gets or sets a value indicating whether the image is interlaced.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
LogicalHeight | Gets or sets the height of the entire canvas area, that each page is displayed in.
LogicalWidth | Gets or sets the width of the entire canvas area, that each page is displayed in.
LoopCount | Gets or sets the number of replays for the animation. Use 0 (zero) to specify an infinte number of replays.
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
NoLocalPalette | Gets or sets a flag to supress saving the dib's attached palette (making it use the global palette). The local palette is the palette used by a page.

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


DisposalMethod Property

[image]

FreeImage .NET Documentation
MDM_ANIMATION..::.DisposalMethod Property
MDM_ANIMATION Class See Also Send Feedback
Gets or sets this frame's disposal method. Generally, this method defines, how to remove or replace a frame when the next frame has to be drawn.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<DisposalMethodType> DisposalMethod { get; set; }
Visual Basic (Declaration)
Public Property DisposalMethod As Nullable(Of DisposalMethodType)
Visual C++
public:
property Nullable<DisposalMethodType> DisposalMethod {
    Nullable<DisposalMethodType> get ();
    void set (Nullable<DisposalMethodType> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


FrameLeft Property

[image]

FreeImage .NET Documentation
MDM_ANIMATION..::.FrameLeft Property
MDM_ANIMATION Class See Also Send Feedback
Gets or sets the horizontal offset within the logical canvas area, this frame is to be displayed at.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> FrameLeft { get; set; }
Visual Basic (Declaration)
Public Property FrameLeft As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> FrameLeft {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


FrameTime Property

[image]

FreeImage .NET Documentation
MDM_ANIMATION..::.FrameTime Property
MDM_ANIMATION Class See Also Send Feedback
Gets or sets the amout of time in milliseconds this frame is to be displayed.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<uint> FrameTime { get; set; }
Visual Basic (Declaration)
Public Property FrameTime As Nullable(Of UInteger)
Visual C++
public:
property Nullable<unsigned int> FrameTime {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


FrameTop Property

[image]

FreeImage .NET Documentation
MDM_ANIMATION..::.FrameTop Property
MDM_ANIMATION Class See Also Send Feedback
Gets or sets the vertical offset within the logical canvas area, this frame is to be displayed at.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> FrameTop { get; set; }
Visual Basic (Declaration)
Public Property FrameTop As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> FrameTop {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


GlobalPalette Property

[image]

FreeImage .NET Documentation
MDM_ANIMATION..::.GlobalPalette Property
MDM_ANIMATION Class See Also Send Feedback
Gets or sets the global palette of the GIF image.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Palette GlobalPalette { get; set; }
Visual Basic (Declaration)
Public Property GlobalPalette As Palette
Visual C++
public:
property Palette^ GlobalPalette {
    Palette^ get ();
    void set (Palette^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


Interlaced Property

[image]

FreeImage .NET Documentation
MDM_ANIMATION..::.Interlaced Property
MDM_ANIMATION Class See Also Send Feedback
Gets or sets a value indicating whether the image is interlaced.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<bool> Interlaced { get; set; }
Visual Basic (Declaration)
Public Property Interlaced As Nullable(Of Boolean)
Visual C++
public:
property Nullable<bool> Interlaced {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


LogicalHeight Property

[image]

FreeImage .NET Documentation
MDM_ANIMATION..::.LogicalHeight Property
MDM_ANIMATION Class See Also Send Feedback
Gets or sets the height of the entire canvas area, that each page is displayed in.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> LogicalHeight { get; set; }
Visual Basic (Declaration)
Public Property LogicalHeight As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> LogicalHeight {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


LogicalWidth Property

[image]

FreeImage .NET Documentation
MDM_ANIMATION..::.LogicalWidth Property
MDM_ANIMATION Class See Also Send Feedback
Gets or sets the width of the entire canvas area, that each page is displayed in.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> LogicalWidth { get; set; }
Visual Basic (Declaration)
Public Property LogicalWidth As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> LogicalWidth {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


LoopCount Property

[image]

FreeImage .NET Documentation
MDM_ANIMATION..::.LoopCount Property
MDM_ANIMATION Class See Also Send Feedback
Gets or sets the number of replays for the animation. Use 0 (zero) to specify an infinte number of replays.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<uint> LoopCount { get; set; }
Visual Basic (Declaration)
Public Property LoopCount As Nullable(Of UInteger)
Visual C++
public:
property Nullable<unsigned int> LoopCount {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_ANIMATION..::.Model Property
MDM_ANIMATION Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


NoLocalPalette Property

[image]

FreeImage .NET Documentation
MDM_ANIMATION..::.NoLocalPalette Property
MDM_ANIMATION Class See Also Send Feedback
Gets or sets a flag to supress saving the dib's attached palette (making it use the global palette). The local palette is the palette used by a page.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<bool> NoLocalPalette { get; set; }
Visual Basic (Declaration)
Public Property NoLocalPalette As Nullable(Of Boolean)
Visual C++
public:
property Nullable<bool> NoLocalPalette {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_ANIMATION Class
FreeImageAPI.Metadata Namespace


MDM_COMMENTS Class

[image]

FreeImage .NET Documentation
MDM_COMMENTS Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_COMMENTS.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MDM_COMMENTS : MetadataModel
Visual Basic (Declaration)
Public NotInheritable Class MDM_COMMENTS _
    Inherits MetadataModel
Visual C++
public ref class MDM_COMMENTS sealed : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_COMMENTS

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_COMMENTS Members
FreeImageAPI.Metadata Namespace


MDM_COMMENTS Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_COMMENTS Members
MDM_COMMENTS Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_COMMENTS type exposes the following members.

Constructors

Name | Description
MDM_COMMENTS | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Comment | Gets or sets the comment of the image. Supported formats are JPEG, PNG and GIF.
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)

See Also

MDM_COMMENTS Class
FreeImageAPI.Metadata Namespace


MDM_COMMENTS Constructor

[image]

FreeImage .NET Documentation
MDM_COMMENTS Constructor
MDM_COMMENTS Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_COMMENTS(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_COMMENTS(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_COMMENTS Class
FreeImageAPI.Metadata Namespace


MDM_COMMENTS Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_COMMENTS Fields
MDM_COMMENTS Class See Also Send Feedback

The MDM_COMMENTS type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_COMMENTS Class
FreeImageAPI.Metadata Namespace


MDM_COMMENTS Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_COMMENTS Methods
MDM_COMMENTS Class See Also Send Feedback

The MDM_COMMENTS type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_COMMENTS Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_COMMENTS..::.AddTag Method
MDM_COMMENTS Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_COMMENTS Class
MDM_COMMENTS Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_COMMENTS..::.SetTagValue Method
MDM_COMMENTS Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_COMMENTS Class
MDM_COMMENTS Members
FreeImageAPI.Metadata Namespace


MDM_COMMENTS Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_COMMENTS Properties
MDM_COMMENTS Class See Also Send Feedback

The MDM_COMMENTS type exposes the following members.

Properties

Name | Description
Comment | Gets or sets the comment of the image. Supported formats are JPEG, PNG and GIF.
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)

See Also

MDM_COMMENTS Class
FreeImageAPI.Metadata Namespace


Comment Property

[image]

FreeImage .NET Documentation
MDM_COMMENTS..::.Comment Property
MDM_COMMENTS Class See Also Send Feedback
Gets or sets the comment of the image. Supported formats are JPEG, PNG and GIF.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Comment { get; set; }
Visual Basic (Declaration)
Public Property Comment As String
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_COMMENTS Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_COMMENTS..::.Model Property
MDM_COMMENTS Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_COMMENTS Class
FreeImageAPI.Metadata Namespace


MDM_CUSTOM Class

[image]

FreeImage .NET Documentation
MDM_CUSTOM Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_CUSTOM.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MDM_CUSTOM : MetadataModel
Visual Basic (Declaration)
Public NotInheritable Class MDM_CUSTOM _
    Inherits MetadataModel
Visual C++
public ref class MDM_CUSTOM sealed : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_CUSTOM

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_CUSTOM Members
FreeImageAPI.Metadata Namespace


MDM_CUSTOM Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_CUSTOM Members
MDM_CUSTOM Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_CUSTOM type exposes the following members.

Constructors

Name | Description
MDM_CUSTOM | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)

See Also

MDM_CUSTOM Class
FreeImageAPI.Metadata Namespace


MDM_CUSTOM Constructor

[image]

FreeImage .NET Documentation
MDM_CUSTOM Constructor
MDM_CUSTOM Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_CUSTOM(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_CUSTOM(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_CUSTOM Class
FreeImageAPI.Metadata Namespace


MDM_CUSTOM Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_CUSTOM Fields
MDM_CUSTOM Class See Also Send Feedback

The MDM_CUSTOM type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_CUSTOM Class
FreeImageAPI.Metadata Namespace


MDM_CUSTOM Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_CUSTOM Methods
MDM_CUSTOM Class See Also Send Feedback

The MDM_CUSTOM type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_CUSTOM Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_CUSTOM..::.AddTag Method
MDM_CUSTOM Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_CUSTOM Class
MDM_CUSTOM Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_CUSTOM..::.SetTagValue Method
MDM_CUSTOM Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_CUSTOM Class
MDM_CUSTOM Members
FreeImageAPI.Metadata Namespace


MDM_CUSTOM Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_CUSTOM Properties
MDM_CUSTOM Class See Also Send Feedback

The MDM_CUSTOM type exposes the following members.

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)

See Also

MDM_CUSTOM Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_CUSTOM..::.Model Property
MDM_CUSTOM Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_CUSTOM Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_EXIF Class

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_EXIF_EXIF.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MDM_EXIF_EXIF : MetadataModel
Visual Basic (Declaration)
Public NotInheritable Class MDM_EXIF_EXIF _
    Inherits MetadataModel
Visual C++
public ref class MDM_EXIF_EXIF sealed : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_EXIF_EXIF

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Members
FreeImageAPI.Metadata Namespace


MDM_EXIF_EXIF Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_EXIF Members
MDM_EXIF_EXIF Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_EXIF_EXIF type exposes the following members.

Constructors

Name | Description
MDM_EXIF_EXIF | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
ApertureValue | Gets or sets the lens aperture. The unit is the APEX value.
BrightnessValue | Gets or sets the value of brightness. The unit is the APEX value. Ordinarily it is given in the range of -99.99 to 99.99.
CFAPattern | Gets or sets the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.
ColorSpace | Gets or sets the color space information tag. See remarks for further information.
ComponentsConfiguration | Gets or sets components configuration. See remarks for further information. Constant length of 4.
CompressedBitsPerPixel | Gets or sets compression mode used for a compressed image is indicated in unit bits per pixel.
Contrast | Gets or sets the direction of contrast processing applied by the camera when the image was shot. See remarks for further information.
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
CustomRendered | Gets or sets the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing. See remarks for further information.
DateTimeDigitized | Gets or sets the date and time when the image was stored as digital data.
DateTimeOriginal | Gets or sets the date and time when the original image data was generated.
DeviceSettingDescription | Gets or sets information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader.
DigitalZoomRatio | Gets or sets the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.
ExifVersion | Gets or sets the version of this standard supported. Constant length or 4.
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
ExposureBiasValue | Gets or sets the exposure bias. The unit is the APEX value. Ordinarily it is given in the range of –99.99 to 99.99.
ExposureIndex | Gets or sets the exposure index selected on the camera or input device at the time the image was captured.
ExposureMode | Gets or sets the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings. See remarks for further information.
ExposureProgram | Gets or sets the class of the program used by the camera to set exposure when the picture is taken. See remarks for further information.
ExposureTime | Gets or the exposure time, given in seconds (sec).
FileSource | Gets or sets the image source. If a DSC recorded the image, this tag value of this tag always be set to 3, indicating that the image was recorded on a DSC.
Flash | Gets or sets a value indicating the status of flash when the image was shot. Bit 0 indicates the flash firing status, bits 1 and 2 indicate the flash return status, bits 3 and 4 indicate the flash mode, bit 5 indicates whether the flash function is present, and bit 6 indicates "red eye" mode.
FlashEnergy | Gets or sets the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).
FlashpixVersion | Gets or sets the Flashpix format version supported by a FPXR file. Constant length or 4.
FNumber | Gets or the F number.
FocalLength | Gets or sets the actual focal length of the lens, in mm. Conversion is not made to the focal length of a 35 mm film camera.
FocalLengthIn35mmFilm | Gets or sets the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
FocalPlaneResolutionUnit | Gets or sets the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution. This value is the same as the ResolutionUnit.
FocalPlaneXResolution | Gets or sets the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.
FocalPlaneYResolution | Gets or sets the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.
GainControl | Gets or sets the degree of overall image gain adjustment. See remarks for further information.
ImageUniqueID | Gets or sets an identifier assigned uniquely to each image. It is recorded as an ASCII string equivalent to hexadecimal notation and 128-bit fixed length. Constant length of 32.
ISOSpeedRatings | Gets or sets the the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
LightSource | Gets or sets the kind of light source. See remarks for further information.
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
MakerNote | Gets or sets a tag for manufacturers of Exif writers to record any desired information. The contents are up to the manufacturer, but this tag should not be used for any other than its intended purpose.
MaxApertureValue | Gets or sets the smallest F number of the lens. The unit is the APEX value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.
MeteringMode | Gets or sets the metering mode. See remarks for further information.
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
OECF | Gets or sets the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.
PixelXDimension | Gets or sets the valid width of a compressed image.
PixelYDimension | Gets or sets the valid height of a compressed image.
RelatedSoundFile | Gets or sets the name of an audio file related to the image data. The format is 8.3. Constant length of 12
Saturation | Gets or sets the direction of saturation processing applied by the camera when the image was shot. See remarks for further information.
SceneCaptureType | Gets or sets the type of scene that was shot. It can also be used to record the mode in which the image was shot. See remarks for further information.
SceneType | Gets or sets the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.
SensingMethod | Gets or sets the image sensor type on the camera or input device. See remarks for further information.
Sharpness | Gets or sets the direction of sharpness processing applied by the camera when the image was shot. See remarks for further information.
ShutterSpeedValue | Gets or sets the shutter speed. The unit is the APEX (Additive System of Photographic Exposure).
SpatialFrequencyResponse | Gets or sets the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.
SpectralSensitivity | Gets or sets the spectral sensitivity of each channel of the camera used.
SubjectArea | Gets or sets a value indicating the location and area of the main subject in the overall scene. Variable length between 2 and 4.
SubjectDistance | Gets or sets distance to the subject, given in meters. Note that if the numerator of the recorded value is FFFFFFFF, infinity shall be indicated; and if the numerator is 0, distance unknown shall be indicated.
SubjectDistanceRange | Gets or sets the distance to the subject. See remarks for further information.
SubjectLocation | Gets or sets the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. The first value indicates the X column number and second indicates the Y row number.
SubsecTime | Gets or sets a tag used to record fractions of seconds for the DateTime tag.
SubsecTimeDigitized | Gets or sets a tag used to record fractions of seconds for the DateTimeDigitized tag.
SubsecTimeOriginal | Gets or sets a tag used to record fractions of seconds for the DateTimeOriginal tag.
UserComment | Gets or sets a tag for Exif users to write keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag. Minimum length of 8. See remarks for further information.
WhiteBalance | Gets or sets the white balance mode set when the image was shot. See remarks for further information.

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_EXIF Constructor

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF Constructor
MDM_EXIF_EXIF Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_EXIF_EXIF(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_EXIF_EXIF(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_EXIF Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_EXIF Fields
MDM_EXIF_EXIF Class See Also Send Feedback

The MDM_EXIF_EXIF type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_EXIF Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_EXIF Methods
MDM_EXIF_EXIF Class See Also Send Feedback

The MDM_EXIF_EXIF type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.AddTag Method
MDM_EXIF_EXIF Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_EXIF_EXIF Class
MDM_EXIF_EXIF Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SetTagValue Method
MDM_EXIF_EXIF Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_EXIF_EXIF Class
MDM_EXIF_EXIF Members
FreeImageAPI.Metadata Namespace


MDM_EXIF_EXIF Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_EXIF Properties
MDM_EXIF_EXIF Class See Also Send Feedback

The MDM_EXIF_EXIF type exposes the following members.

Properties

Name | Description
ApertureValue | Gets or sets the lens aperture. The unit is the APEX value.
BrightnessValue | Gets or sets the value of brightness. The unit is the APEX value. Ordinarily it is given in the range of -99.99 to 99.99.
CFAPattern | Gets or sets the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.
ColorSpace | Gets or sets the color space information tag. See remarks for further information.
ComponentsConfiguration | Gets or sets components configuration. See remarks for further information. Constant length of 4.
CompressedBitsPerPixel | Gets or sets compression mode used for a compressed image is indicated in unit bits per pixel.
Contrast | Gets or sets the direction of contrast processing applied by the camera when the image was shot. See remarks for further information.
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
CustomRendered | Gets or sets the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing. See remarks for further information.
DateTimeDigitized | Gets or sets the date and time when the image was stored as digital data.
DateTimeOriginal | Gets or sets the date and time when the original image data was generated.
DeviceSettingDescription | Gets or sets information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader.
DigitalZoomRatio | Gets or sets the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.
ExifVersion | Gets or sets the version of this standard supported. Constant length or 4.
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
ExposureBiasValue | Gets or sets the exposure bias. The unit is the APEX value. Ordinarily it is given in the range of –99.99 to 99.99.
ExposureIndex | Gets or sets the exposure index selected on the camera or input device at the time the image was captured.
ExposureMode | Gets or sets the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings. See remarks for further information.
ExposureProgram | Gets or sets the class of the program used by the camera to set exposure when the picture is taken. See remarks for further information.
ExposureTime | Gets or the exposure time, given in seconds (sec).
FileSource | Gets or sets the image source. If a DSC recorded the image, this tag value of this tag always be set to 3, indicating that the image was recorded on a DSC.
Flash | Gets or sets a value indicating the status of flash when the image was shot. Bit 0 indicates the flash firing status, bits 1 and 2 indicate the flash return status, bits 3 and 4 indicate the flash mode, bit 5 indicates whether the flash function is present, and bit 6 indicates "red eye" mode.
FlashEnergy | Gets or sets the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).
FlashpixVersion | Gets or sets the Flashpix format version supported by a FPXR file. Constant length or 4.
FNumber | Gets or the F number.
FocalLength | Gets or sets the actual focal length of the lens, in mm. Conversion is not made to the focal length of a 35 mm film camera.
FocalLengthIn35mmFilm | Gets or sets the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
FocalPlaneResolutionUnit | Gets or sets the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution. This value is the same as the ResolutionUnit.
FocalPlaneXResolution | Gets or sets the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.
FocalPlaneYResolution | Gets or sets the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.
GainControl | Gets or sets the degree of overall image gain adjustment. See remarks for further information.
ImageUniqueID | Gets or sets an identifier assigned uniquely to each image. It is recorded as an ASCII string equivalent to hexadecimal notation and 128-bit fixed length. Constant length of 32.
ISOSpeedRatings | Gets or sets the the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
LightSource | Gets or sets the kind of light source. See remarks for further information.
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
MakerNote | Gets or sets a tag for manufacturers of Exif writers to record any desired information. The contents are up to the manufacturer, but this tag should not be used for any other than its intended purpose.
MaxApertureValue | Gets or sets the smallest F number of the lens. The unit is the APEX value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.
MeteringMode | Gets or sets the metering mode. See remarks for further information.
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
OECF | Gets or sets the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.
PixelXDimension | Gets or sets the valid width of a compressed image.
PixelYDimension | Gets or sets the valid height of a compressed image.
RelatedSoundFile | Gets or sets the name of an audio file related to the image data. The format is 8.3. Constant length of 12
Saturation | Gets or sets the direction of saturation processing applied by the camera when the image was shot. See remarks for further information.
SceneCaptureType | Gets or sets the type of scene that was shot. It can also be used to record the mode in which the image was shot. See remarks for further information.
SceneType | Gets or sets the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.
SensingMethod | Gets or sets the image sensor type on the camera or input device. See remarks for further information.
Sharpness | Gets or sets the direction of sharpness processing applied by the camera when the image was shot. See remarks for further information.
ShutterSpeedValue | Gets or sets the shutter speed. The unit is the APEX (Additive System of Photographic Exposure).
SpatialFrequencyResponse | Gets or sets the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.
SpectralSensitivity | Gets or sets the spectral sensitivity of each channel of the camera used.
SubjectArea | Gets or sets a value indicating the location and area of the main subject in the overall scene. Variable length between 2 and 4.
SubjectDistance | Gets or sets distance to the subject, given in meters. Note that if the numerator of the recorded value is FFFFFFFF, infinity shall be indicated; and if the numerator is 0, distance unknown shall be indicated.
SubjectDistanceRange | Gets or sets the distance to the subject. See remarks for further information.
SubjectLocation | Gets or sets the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. The first value indicates the X column number and second indicates the Y row number.
SubsecTime | Gets or sets a tag used to record fractions of seconds for the DateTime tag.
SubsecTimeDigitized | Gets or sets a tag used to record fractions of seconds for the DateTimeDigitized tag.
SubsecTimeOriginal | Gets or sets a tag used to record fractions of seconds for the DateTimeOriginal tag.
UserComment | Gets or sets a tag for Exif users to write keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag. Minimum length of 8. See remarks for further information.
WhiteBalance | Gets or sets the white balance mode set when the image was shot. See remarks for further information.

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ApertureValue Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ApertureValue Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the lens aperture. The unit is the APEX value.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> ApertureValue { get; set; }
Visual Basic (Declaration)
Public Property ApertureValue As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> ApertureValue {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


BrightnessValue Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.BrightnessValue Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the value of brightness. The unit is the APEX value. Ordinarily it is given in the range of -99.99 to 99.99.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIRational> BrightnessValue { get; set; }
Visual Basic (Declaration)
Public Property BrightnessValue As Nullable(Of FIRational)
Visual C++
public:
property Nullable<FIRational> BrightnessValue {
    Nullable<FIRational> get ();
    void set (Nullable<FIRational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


CFAPattern Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.CFAPattern Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] CFAPattern { get; set; }
Visual Basic (Declaration)
Public Property CFAPattern As Byte()
Visual C++
public:
property array<unsigned char>^ CFAPattern {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ColorSpace Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ColorSpace Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the color space information tag. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> ColorSpace { get; set; }
Visual Basic (Declaration)
Public Property ColorSpace As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> ColorSpace {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are defined:

ID | Description
1 | sRGB (default)
0xFFFF | uncalibrated
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ComponentsConfiguration Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ComponentsConfiguration Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets components configuration. See remarks for further information. Constant length of 4.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] ComponentsConfiguration { get; set; }
Visual Basic (Declaration)
Public Property ComponentsConfiguration As Byte()
Visual C++
public:
property array<unsigned char>^ ComponentsConfiguration {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

The channels of each component are arranged in order from the 1st component to the 4th. For uncompressed data the data arrangement is given in the PhotometricInterpretation tag. However, since PhotometricInterpretation can only express the order of Y,Cb and Cr, this tag is provided for cases when compressed data uses components other than Y, Cb, and Cr and to enable support of other sequences.

Default = 4 5 6 0 (if RGB uncompressed)

The following values are defined:

ID | Description
0 | does not exist
1 | Y
2 | Cb
3 | Cr
4 | R
5 | R
6 | R
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


CompressedBitsPerPixel Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.CompressedBitsPerPixel Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets compression mode used for a compressed image is indicated in unit bits per pixel.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> CompressedBitsPerPixel { get; set; }
Visual Basic (Declaration)
Public Property CompressedBitsPerPixel As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> CompressedBitsPerPixel {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


Contrast Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.Contrast Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the direction of contrast processing applied by the camera when the image was shot. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> Contrast { get; set; }
Visual Basic (Declaration)
Public Property Contrast As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> Contrast {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
0 | normal
1 | soft
2 | hard
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


CustomRendered Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.CustomRendered Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> CustomRendered { get; set; }
Visual Basic (Declaration)
Public Property CustomRendered As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> CustomRendered {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
0 | normal process
1 | custom process
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


DateTimeDigitized Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.DateTimeDigitized Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the date and time when the image was stored as digital data.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<DateTime> DateTimeDigitized { get; set; }
Visual Basic (Declaration)
Public Property DateTimeDigitized As Nullable(Of DateTime)
Visual C++
public:
property Nullable<DateTime> DateTimeDigitized {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


DateTimeOriginal Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.DateTimeOriginal Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the date and time when the original image data was generated.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<DateTime> DateTimeOriginal { get; set; }
Visual Basic (Declaration)
Public Property DateTimeOriginal As Nullable(Of DateTime)
Visual C++
public:
property Nullable<DateTime> DateTimeOriginal {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


DeviceSettingDescription Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.DeviceSettingDescription Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] DeviceSettingDescription { get; set; }
Visual Basic (Declaration)
Public Property DeviceSettingDescription As Byte()
Visual C++
public:
property array<unsigned char>^ DeviceSettingDescription {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


DigitalZoomRatio Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.DigitalZoomRatio Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> DigitalZoomRatio { get; set; }
Visual Basic (Declaration)
Public Property DigitalZoomRatio As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> DigitalZoomRatio {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ExifVersion Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ExifVersion Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the version of this standard supported. Constant length or 4.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] ExifVersion { get; set; }
Visual Basic (Declaration)
Public Property ExifVersion As Byte()
Visual C++
public:
property array<unsigned char>^ ExifVersion {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ExposureBiasValue Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ExposureBiasValue Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the exposure bias. The unit is the APEX value. Ordinarily it is given in the range of –99.99 to 99.99.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIRational> ExposureBiasValue { get; set; }
Visual Basic (Declaration)
Public Property ExposureBiasValue As Nullable(Of FIRational)
Visual C++
public:
property Nullable<FIRational> ExposureBiasValue {
    Nullable<FIRational> get ();
    void set (Nullable<FIRational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ExposureIndex Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ExposureIndex Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the exposure index selected on the camera or input device at the time the image was captured.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> ExposureIndex { get; set; }
Visual Basic (Declaration)
Public Property ExposureIndex As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> ExposureIndex {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ExposureMode Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ExposureMode Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> ExposureMode { get; set; }
Visual Basic (Declaration)
Public Property ExposureMode As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> ExposureMode {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
0 | auto exposure
1 | manual exposure
2 | auto bracket
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ExposureProgram Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ExposureProgram Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the class of the program used by the camera to set exposure when the picture is taken. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> ExposureProgram { get; set; }
Visual Basic (Declaration)
Public Property ExposureProgram As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> ExposureProgram {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are defined:

ID | Description
0 | not defined
1 | manual
2 | normal program
3 | aperture priority
4 | shutter priority
5 | create program
6 | action program
7 | portrait mode
8 | landscape mode
others | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ExposureTime Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ExposureTime Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or the exposure time, given in seconds (sec).

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> ExposureTime { get; set; }
Visual Basic (Declaration)
Public Property ExposureTime As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> ExposureTime {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


FileSource Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.FileSource Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the image source. If a DSC recorded the image, this tag value of this tag always be set to 3, indicating that the image was recorded on a DSC.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<byte> FileSource { get; set; }
Visual Basic (Declaration)
Public Property FileSource As Nullable(Of Byte)
Visual C++
public:
property Nullable<unsigned char> FileSource {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


Flash Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.Flash Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets a value indicating the status of flash when the image was shot. Bit 0 indicates the flash firing status, bits 1 and 2 indicate the flash return status, bits 3 and 4 indicate the flash mode, bit 5 indicates whether the flash function is present, and bit 6 indicates "red eye" mode.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> Flash { get; set; }
Visual Basic (Declaration)
Public Property Flash As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> Flash {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


FlashEnergy Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.FlashEnergy Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> FlashEnergy { get; set; }
Visual Basic (Declaration)
Public Property FlashEnergy As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> FlashEnergy {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


FlashpixVersion Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.FlashpixVersion Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the Flashpix format version supported by a FPXR file. Constant length or 4.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] FlashpixVersion { get; set; }
Visual Basic (Declaration)
Public Property FlashpixVersion As Byte()
Visual C++
public:
property array<unsigned char>^ FlashpixVersion {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


FNumber Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.FNumber Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or the F number.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> FNumber { get; set; }
Visual Basic (Declaration)
Public Property FNumber As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> FNumber {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


FocalLength Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.FocalLength Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the actual focal length of the lens, in mm. Conversion is not made to the focal length of a 35 mm film camera.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> FocalLength { get; set; }
Visual Basic (Declaration)
Public Property FocalLength As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> FocalLength {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


FocalLengthIn35mmFilm Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.FocalLengthIn35mmFilm Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> FocalLengthIn35mmFilm { get; set; }
Visual Basic (Declaration)
Public Property FocalLengthIn35mmFilm As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> FocalLengthIn35mmFilm {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


FocalPlaneResolutionUnit Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.FocalPlaneResolutionUnit Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution. This value is the same as the ResolutionUnit.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> FocalPlaneResolutionUnit { get; set; }
Visual Basic (Declaration)
Public Property FocalPlaneResolutionUnit As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> FocalPlaneResolutionUnit {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


FocalPlaneXResolution Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.FocalPlaneXResolution Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> FocalPlaneXResolution { get; set; }
Visual Basic (Declaration)
Public Property FocalPlaneXResolution As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> FocalPlaneXResolution {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


FocalPlaneYResolution Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.FocalPlaneYResolution Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> FocalPlaneYResolution { get; set; }
Visual Basic (Declaration)
Public Property FocalPlaneYResolution As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> FocalPlaneYResolution {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


GainControl Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.GainControl Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the degree of overall image gain adjustment. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> GainControl { get; set; }
Visual Basic (Declaration)
Public Property GainControl As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> GainControl {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
0 | none
1 | low gain up
2 | high gain up
3 | low gain down
4 | high gain down
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ImageUniqueID Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ImageUniqueID Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets an identifier assigned uniquely to each image. It is recorded as an ASCII string equivalent to hexadecimal notation and 128-bit fixed length. Constant length of 32.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ImageUniqueID { get; set; }
Visual Basic (Declaration)
Public Property ImageUniqueID As String
Visual C++
public:
property String^ ImageUniqueID {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ISOSpeedRatings Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ISOSpeedRatings Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort[] ISOSpeedRatings { get; set; }
Visual Basic (Declaration)
Public Property ISOSpeedRatings As UShort()
Visual C++
public:
property array<unsigned short>^ ISOSpeedRatings {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


LightSource Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.LightSource Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the kind of light source. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> LightSource { get; set; }
Visual Basic (Declaration)
Public Property LightSource As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> LightSource {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are defined:

ID | Description
0 | unknown
1 | daylight
2 | fluorescent
3 | tungsten
4 | flash
9 | fine weather
10 | cloudy weather
11 | shade
12 | daylight fluorecent (D 5700 - 7100K)
13 | day white fluorescent (N 4600 - 5400K)
14 | cool white fluorescent (W 3900 - 4500K)
15 | white fluorescent (WW 3200 - 3700K)
17 | standard light A
18 | standard light B
19 | standard light C
20 | D55
21 | D65
22 | D75
23 | D50
24 | ISO studio tungsten
255 | other light source
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


MakerNote Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.MakerNote Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets a tag for manufacturers of Exif writers to record any desired information. The contents are up to the manufacturer, but this tag should not be used for any other than its intended purpose.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] MakerNote { get; set; }
Visual Basic (Declaration)
Public Property MakerNote As Byte()
Visual C++
public:
property array<unsigned char>^ MakerNote {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


MaxApertureValue Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.MaxApertureValue Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the smallest F number of the lens. The unit is the APEX value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> MaxApertureValue { get; set; }
Visual Basic (Declaration)
Public Property MaxApertureValue As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> MaxApertureValue {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


MeteringMode Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.MeteringMode Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the metering mode. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> MeteringMode { get; set; }
Visual Basic (Declaration)
Public Property MeteringMode As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> MeteringMode {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are defined:

ID | Description
0 | unknown
1 | average
2 | center-weighted-average
3 | spot
4 | multi-spot
5 | pattern
6 | partial
other | reserved
255 | other

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.Model Property
MDM_EXIF_EXIF Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


OECF Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.OECF Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] OECF { get; set; }
Visual Basic (Declaration)
Public Property OECF As Byte()
Visual C++
public:
property array<unsigned char>^ OECF {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


PixelXDimension Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.PixelXDimension Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the valid width of a compressed image.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<uint> PixelXDimension { get; set; }
Visual Basic (Declaration)
Public Property PixelXDimension As Nullable(Of UInteger)
Visual C++
public:
property Nullable<unsigned int> PixelXDimension {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


PixelYDimension Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.PixelYDimension Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the valid height of a compressed image.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<uint> PixelYDimension { get; set; }
Visual Basic (Declaration)
Public Property PixelYDimension As Nullable(Of UInteger)
Visual C++
public:
property Nullable<unsigned int> PixelYDimension {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


RelatedSoundFile Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.RelatedSoundFile Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the name of an audio file related to the image data. The format is 8.3. Constant length of 12

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string RelatedSoundFile { get; set; }
Visual Basic (Declaration)
Public Property RelatedSoundFile As String
Visual C++
public:
property String^ RelatedSoundFile {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


Saturation Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.Saturation Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the direction of saturation processing applied by the camera when the image was shot. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> Saturation { get; set; }
Visual Basic (Declaration)
Public Property Saturation As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> Saturation {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
0 | normal
1 | low saturation
2 | high saturation
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SceneCaptureType Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SceneCaptureType Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the type of scene that was shot. It can also be used to record the mode in which the image was shot. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> SceneCaptureType { get; set; }
Visual Basic (Declaration)
Public Property SceneCaptureType As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> SceneCaptureType {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
0 | standard
1 | landscape
2 | portrait
3 | night scene
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SceneType Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SceneType Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<byte> SceneType { get; set; }
Visual Basic (Declaration)
Public Property SceneType As Nullable(Of Byte)
Visual C++
public:
property Nullable<unsigned char> SceneType {
    Nullable<unsigned char> get ();
    void set (Nullable<unsigned char> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SensingMethod Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SensingMethod Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the image sensor type on the camera or input device. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> SensingMethod { get; set; }
Visual Basic (Declaration)
Public Property SensingMethod As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> SensingMethod {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are defined:

ID | Description
1 | not defined
2 | one-chip color area sensor
3 | two-chip color area sensor
4 | three-chip color area sensor
5 | color sequential area sensor
7 | trilinear sensor
8 | color sequential linear sensor
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


Sharpness Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.Sharpness Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the direction of sharpness processing applied by the camera when the image was shot. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> Sharpness { get; set; }
Visual Basic (Declaration)
Public Property Sharpness As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> Sharpness {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
0 | normal
1 | soft
2 | hard
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


ShutterSpeedValue Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.ShutterSpeedValue Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the shutter speed. The unit is the APEX (Additive System of Photographic Exposure).

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIRational> ShutterSpeedValue { get; set; }
Visual Basic (Declaration)
Public Property ShutterSpeedValue As Nullable(Of FIRational)
Visual C++
public:
property Nullable<FIRational> ShutterSpeedValue {
    Nullable<FIRational> get ();
    void set (Nullable<FIRational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SpatialFrequencyResponse Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SpatialFrequencyResponse Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] SpatialFrequencyResponse { get; set; }
Visual Basic (Declaration)
Public Property SpatialFrequencyResponse As Byte()
Visual C++
public:
property array<unsigned char>^ SpatialFrequencyResponse {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SpectralSensitivity Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SpectralSensitivity Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the spectral sensitivity of each channel of the camera used.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string SpectralSensitivity { get; set; }
Visual Basic (Declaration)
Public Property SpectralSensitivity As String
Visual C++
public:
property String^ SpectralSensitivity {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SubjectArea Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SubjectArea Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets a value indicating the location and area of the main subject in the overall scene. Variable length between 2 and 4.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort[] SubjectArea { get; set; }
Visual Basic (Declaration)
Public Property SubjectArea As UShort()
Visual C++
public:
property array<unsigned short>^ SubjectArea {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SubjectDistance Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SubjectDistance Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets distance to the subject, given in meters. Note that if the numerator of the recorded value is FFFFFFFF, infinity shall be indicated; and if the numerator is 0, distance unknown shall be indicated.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> SubjectDistance { get; set; }
Visual Basic (Declaration)
Public Property SubjectDistance As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> SubjectDistance {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SubjectDistanceRange Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SubjectDistanceRange Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the distance to the subject. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> SubjectDistanceRange { get; set; }
Visual Basic (Declaration)
Public Property SubjectDistanceRange As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> SubjectDistanceRange {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
0 | unknown
1 | macro
2 | close view
3 | distant view
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SubjectLocation Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SubjectLocation Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. The first value indicates the X column number and second indicates the Y row number.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> SubjectLocation { get; set; }
Visual Basic (Declaration)
Public Property SubjectLocation As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> SubjectLocation {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SubsecTime Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SubsecTime Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets a tag used to record fractions of seconds for the DateTime tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string SubsecTime { get; set; }
Visual Basic (Declaration)
Public Property SubsecTime As String
Visual C++
public:
property String^ SubsecTime {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SubsecTimeDigitized Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SubsecTimeDigitized Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets a tag used to record fractions of seconds for the DateTimeDigitized tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string SubsecTimeDigitized { get; set; }
Visual Basic (Declaration)
Public Property SubsecTimeDigitized As String
Visual C++
public:
property String^ SubsecTimeDigitized {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


SubsecTimeOriginal Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.SubsecTimeOriginal Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets a tag used to record fractions of seconds for the DateTimeOriginal tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string SubsecTimeOriginal { get; set; }
Visual Basic (Declaration)
Public Property SubsecTimeOriginal As String
Visual C++
public:
property String^ SubsecTimeOriginal {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


UserComment Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.UserComment Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets a tag for Exif users to write keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag. Minimum length of 8. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] UserComment { get; set; }
Visual Basic (Declaration)
Public Property UserComment As Byte()
Visual C++
public:
property array<unsigned char>^ UserComment {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

The character code used in the UserComment tag is identified based on an ID code in a fixed 8-byte area at the start of the tag data area. The unused portion of the area is padded with NULL. The ID code for the UserComment area may be a Defined code such as JIS or ASCII, or may be Undefined.

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


WhiteBalance Property

[image]

FreeImage .NET Documentation
MDM_EXIF_EXIF..::.WhiteBalance Property
MDM_EXIF_EXIF Class See Also Send Feedback
Gets or sets the white balance mode set when the image was shot. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> WhiteBalance { get; set; }
Visual Basic (Declaration)
Public Property WhiteBalance As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> WhiteBalance {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
0 | auto white balance
1 | manual white balance
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_EXIF Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_GPS Class

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_EXIF_GPS.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MDM_EXIF_GPS : MetadataModel
Visual Basic (Declaration)
Public NotInheritable Class MDM_EXIF_GPS _
    Inherits MetadataModel
Visual C++
public ref class MDM_EXIF_GPS sealed : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_EXIF_GPS

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Members
FreeImageAPI.Metadata Namespace


MDM_EXIF_GPS Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_GPS Members
MDM_EXIF_GPS Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_EXIF_GPS type exposes the following members.

Constructors

Name | Description
MDM_EXIF_GPS | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Altitude | Gets or sets the altitude based on the reference in AltitudeDirection. Altitude is expressed as one rational value. The reference unit is meters.
AltitudeDirection | Gets a value indicating whether Altitude is sea level and the altitude is above sea level. If the altitude is below sea level Altitude is indicated as an absolute value.
AltitudeSign | Gets or sets the sign of the SignedAltitude.
AreaInformation | Gets or sets a character string recording the name of the GPS area. The first byte indicates the character code used, and this is followed by the name of the GPS area. Since the Type is not ASCII, NULL termination is not necessary.
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
DateStamp | Gets or sets date information relative to UTC (Coordinated Universal Time).
DateTimeStamp | Gets or sets date and time information relative to UTC (Coordinated Universal Time).
DestinationBearing | Gets or sets the bearing to the destination point. The range of values is from 0.00 to 359.99.
DestinationDirectionReference | Gets or sets the reference used for giving the bearing to the destination point.
DestinationLatitude | Gets or sets the latitude of the destination point. The latitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.
DestinationLatitudeDirection | Gets or sets a value indicating whether the destination point is north or south latitude.
DestinationLongitude | Gets or sets the longitude of the destination point. The longitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.
DestinationLongitudeDirection | Gets or sets a value indicating whether the destination point is east or west longitude.
DestinationUnit | Gets or sets the unit used to express the distance to the destination point.
DOP | Gets or sets the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
ImageDirection | Gets or sets the direction of the image when it was captured. The range of values is from 0.00 to 359.99.
ImageDirectionReference | Gets or sets the reference for giving the direction of GPS receiver movement.
IsDifferential | Gets or sets a value indicating whether differential correction was applied to the GPS receiver.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
Latitude | Gets or sets the latitude of the image. The latitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.
LatitudeDirection | Gets or sets a value indicating whether the Latitude is north or south latitude.
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Longitude | Gets or sets the longitude of the image. The longitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.
LongitudeDirection | Gets or sets a value indicating whether Longitude is east or west longitude.
MapDatum | Gets or sets the geodetic survey data used by the GPS receiver. If the survey data is restricted to Japan, the value of this tag is 'TOKYO' or 'WGS-84'.
MeasureMode3D | Gets or sets a value indicating the GPS measurement mode. true indicates three-dimensional measurement; false indicated two-dimensional measurement was in progress.
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
ProcessingMethod | Gets or sets a character string recording the name of the method used for location finding. The first byte indicates the character code used, and this is followed by the name of the method. Since the Type is not ASCII, NULL termination is not necessary.
Satellites | Gets or sets the GPS satellites used for measurements. This tag can be used to describe the number of satellites, their ID number, angle of elevation, azimuth, SNR and other information in ASCII notation. The format is not specified.
SignedAltitude | Gets or sets the signed altitude. Altitude is expressed as one rational value. The reference unit is meters.
Speed | Gets or sets the speed of GPS receiver movement.
SpeedUnit | Gets or sets the unit used to express the GPS receiver Speed of movement.
Status | Gets or sets a value indicating the status of the GPS receiver when the image was recorded. true indicates measurement was in progress; false indicates measurement was Interoperability.
TimeStamp | Gets or sets the time as UTC (Coordinated Universal Time). Constant length of 3.
Track | Gets or sets the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.
TrackDirectionReference | Gets or sets the reference for giving the direction of GPS receiver movement.
VersionID | Gets or sets the GPS version ID. Constant length of 4.

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_GPS Constructor

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS Constructor
MDM_EXIF_GPS Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_EXIF_GPS(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_EXIF_GPS(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_GPS Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_GPS Fields
MDM_EXIF_GPS Class See Also Send Feedback

The MDM_EXIF_GPS type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_GPS Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_GPS Methods
MDM_EXIF_GPS Class See Also Send Feedback

The MDM_EXIF_GPS type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.AddTag Method
MDM_EXIF_GPS Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_EXIF_GPS Class
MDM_EXIF_GPS Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.SetTagValue Method
MDM_EXIF_GPS Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_EXIF_GPS Class
MDM_EXIF_GPS Members
FreeImageAPI.Metadata Namespace


MDM_EXIF_GPS Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_GPS Properties
MDM_EXIF_GPS Class See Also Send Feedback

The MDM_EXIF_GPS type exposes the following members.

Properties

Name | Description
Altitude | Gets or sets the altitude based on the reference in AltitudeDirection. Altitude is expressed as one rational value. The reference unit is meters.
AltitudeDirection | Gets a value indicating whether Altitude is sea level and the altitude is above sea level. If the altitude is below sea level Altitude is indicated as an absolute value.
AltitudeSign | Gets or sets the sign of the SignedAltitude.
AreaInformation | Gets or sets a character string recording the name of the GPS area. The first byte indicates the character code used, and this is followed by the name of the GPS area. Since the Type is not ASCII, NULL termination is not necessary.
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
DateStamp | Gets or sets date information relative to UTC (Coordinated Universal Time).
DateTimeStamp | Gets or sets date and time information relative to UTC (Coordinated Universal Time).
DestinationBearing | Gets or sets the bearing to the destination point. The range of values is from 0.00 to 359.99.
DestinationDirectionReference | Gets or sets the reference used for giving the bearing to the destination point.
DestinationLatitude | Gets or sets the latitude of the destination point. The latitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.
DestinationLatitudeDirection | Gets or sets a value indicating whether the destination point is north or south latitude.
DestinationLongitude | Gets or sets the longitude of the destination point. The longitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.
DestinationLongitudeDirection | Gets or sets a value indicating whether the destination point is east or west longitude.
DestinationUnit | Gets or sets the unit used to express the distance to the destination point.
DOP | Gets or sets the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
ImageDirection | Gets or sets the direction of the image when it was captured. The range of values is from 0.00 to 359.99.
ImageDirectionReference | Gets or sets the reference for giving the direction of GPS receiver movement.
IsDifferential | Gets or sets a value indicating whether differential correction was applied to the GPS receiver.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
Latitude | Gets or sets the latitude of the image. The latitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.
LatitudeDirection | Gets or sets a value indicating whether the Latitude is north or south latitude.
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Longitude | Gets or sets the longitude of the image. The longitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.
LongitudeDirection | Gets or sets a value indicating whether Longitude is east or west longitude.
MapDatum | Gets or sets the geodetic survey data used by the GPS receiver. If the survey data is restricted to Japan, the value of this tag is 'TOKYO' or 'WGS-84'.
MeasureMode3D | Gets or sets a value indicating the GPS measurement mode. true indicates three-dimensional measurement; false indicated two-dimensional measurement was in progress.
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
ProcessingMethod | Gets or sets a character string recording the name of the method used for location finding. The first byte indicates the character code used, and this is followed by the name of the method. Since the Type is not ASCII, NULL termination is not necessary.
Satellites | Gets or sets the GPS satellites used for measurements. This tag can be used to describe the number of satellites, their ID number, angle of elevation, azimuth, SNR and other information in ASCII notation. The format is not specified.
SignedAltitude | Gets or sets the signed altitude. Altitude is expressed as one rational value. The reference unit is meters.
Speed | Gets or sets the speed of GPS receiver movement.
SpeedUnit | Gets or sets the unit used to express the GPS receiver Speed of movement.
Status | Gets or sets a value indicating the status of the GPS receiver when the image was recorded. true indicates measurement was in progress; false indicates measurement was Interoperability.
TimeStamp | Gets or sets the time as UTC (Coordinated Universal Time). Constant length of 3.
Track | Gets or sets the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.
TrackDirectionReference | Gets or sets the reference for giving the direction of GPS receiver movement.
VersionID | Gets or sets the GPS version ID. Constant length of 4.

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


Altitude Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.Altitude Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the altitude based on the reference in AltitudeDirection. Altitude is expressed as one rational value. The reference unit is meters.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> Altitude { get; set; }
Visual Basic (Declaration)
Public Property Altitude As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> Altitude {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


AltitudeDirection Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.AltitudeDirection Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets a value indicating whether Altitude is sea level and the altitude is above sea level. If the altitude is below sea level Altitude is indicated as an absolute value.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.AltitudeType> AltitudeDirection { get; set; }
Visual Basic (Declaration)
Public Property AltitudeDirection As Nullable(Of MetadataModel..::.AltitudeType)
Visual C++
public:
property Nullable<MetadataModel..::.AltitudeType> AltitudeDirection {
    Nullable<MetadataModel..::.AltitudeType> get ();
    void set (Nullable<MetadataModel..::.AltitudeType> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


AltitudeSign Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.AltitudeSign Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the sign of the SignedAltitude.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<int> AltitudeSign { get; set; }
Visual Basic (Declaration)
Public Property AltitudeSign As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> AltitudeSign {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Remarks

This is a derived property. There is no metadata tag directly associated with this property value.

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


AreaInformation Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.AreaInformation Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets a character string recording the name of the GPS area. The first byte indicates the character code used, and this is followed by the name of the GPS area. Since the Type is not ASCII, NULL termination is not necessary.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] AreaInformation { get; set; }
Visual Basic (Declaration)
Public Property AreaInformation As Byte()
Visual C++
public:
property array<unsigned char>^ AreaInformation {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


DateStamp Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.DateStamp Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets date information relative to UTC (Coordinated Universal Time).

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<DateTime> DateStamp { get; set; }
Visual Basic (Declaration)
Public Property DateStamp As Nullable(Of DateTime)
Visual C++
public:
property Nullable<DateTime> DateStamp {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


DateTimeStamp Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.DateTimeStamp Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets date and time information relative to UTC (Coordinated Universal Time).

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<DateTime> DateTimeStamp { get; set; }
Visual Basic (Declaration)
Public Property DateTimeStamp As Nullable(Of DateTime)
Visual C++
public:
property Nullable<DateTime> DateTimeStamp {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Remarks

This is a derived property. There is no metadata tag directly associated with this property value.

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


DestinationBearing Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.DestinationBearing Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the bearing to the destination point. The range of values is from 0.00 to 359.99.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> DestinationBearing { get; set; }
Visual Basic (Declaration)
Public Property DestinationBearing As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> DestinationBearing {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.DestinationDirectionReference


DestinationDirectionReference Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.DestinationDirectionReference Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the reference used for giving the bearing to the destination point.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.DirectionReference> DestinationDirectionReference { get; set; }
Visual Basic (Declaration)
Public Property DestinationDirectionReference As Nullable(Of MetadataModel..::.DirectionReference)
Visual C++
public:
property Nullable<MetadataModel..::.DirectionReference> DestinationDirectionReference {
    Nullable<MetadataModel..::.DirectionReference> get ();
    void set (Nullable<MetadataModel..::.DirectionReference> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.DestinationBearing


DestinationLatitude Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.DestinationLatitude Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the latitude of the destination point. The latitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational[] DestinationLatitude { get; set; }
Visual Basic (Declaration)
Public Property DestinationLatitude As FIURational()
Visual C++
public:
property array<FIURational>^ DestinationLatitude {
    array<FIURational>^ get ();
    void set (array<FIURational>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.DestinationLatitudeDirection


DestinationLatitudeDirection Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.DestinationLatitudeDirection Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets a value indicating whether the destination point is north or south latitude.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.LatitudeType> DestinationLatitudeDirection { get; set; }
Visual Basic (Declaration)
Public Property DestinationLatitudeDirection As Nullable(Of MetadataModel..::.LatitudeType)
Visual C++
public:
property Nullable<MetadataModel..::.LatitudeType> DestinationLatitudeDirection {
    Nullable<MetadataModel..::.LatitudeType> get ();
    void set (Nullable<MetadataModel..::.LatitudeType> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.Latitude


DestinationLongitude Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.DestinationLongitude Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the longitude of the destination point. The longitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational[] DestinationLongitude { get; set; }
Visual Basic (Declaration)
Public Property DestinationLongitude As FIURational()
Visual C++
public:
property array<FIURational>^ DestinationLongitude {
    array<FIURational>^ get ();
    void set (array<FIURational>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


DestinationLongitudeDirection Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.DestinationLongitudeDirection Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets a value indicating whether the destination point is east or west longitude.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.LongitudeType> DestinationLongitudeDirection { get; set; }
Visual Basic (Declaration)
Public Property DestinationLongitudeDirection As Nullable(Of MetadataModel..::.LongitudeType)
Visual C++
public:
property Nullable<MetadataModel..::.LongitudeType> DestinationLongitudeDirection {
    Nullable<MetadataModel..::.LongitudeType> get ();
    void set (Nullable<MetadataModel..::.LongitudeType> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.Latitude


DestinationUnit Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.DestinationUnit Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the unit used to express the distance to the destination point.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.VelocityUnit> DestinationUnit { get; set; }
Visual Basic (Declaration)
Public Property DestinationUnit As Nullable(Of MetadataModel..::.VelocityUnit)
Visual C++
public:
property Nullable<MetadataModel..::.VelocityUnit> DestinationUnit {
    Nullable<MetadataModel..::.VelocityUnit> get ();
    void set (Nullable<MetadataModel..::.VelocityUnit> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.DestinationBearing


DOP Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.DOP Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> DOP { get; set; }
Visual Basic (Declaration)
Public Property DOP As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> DOP {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


ImageDirection Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.ImageDirection Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the direction of the image when it was captured. The range of values is from 0.00 to 359.99.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> ImageDirection { get; set; }
Visual Basic (Declaration)
Public Property ImageDirection As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> ImageDirection {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.ImageDirectionReference


ImageDirectionReference Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.ImageDirectionReference Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the reference for giving the direction of GPS receiver movement.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.DirectionReference> ImageDirectionReference { get; set; }
Visual Basic (Declaration)
Public Property ImageDirectionReference As Nullable(Of MetadataModel..::.DirectionReference)
Visual C++
public:
property Nullable<MetadataModel..::.DirectionReference> ImageDirectionReference {
    Nullable<MetadataModel..::.DirectionReference> get ();
    void set (Nullable<MetadataModel..::.DirectionReference> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.ImageDirection


IsDifferential Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.IsDifferential Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets a value indicating whether differential correction was applied to the GPS receiver.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<bool> IsDifferential { get; set; }
Visual Basic (Declaration)
Public Property IsDifferential As Nullable(Of Boolean)
Visual C++
public:
property Nullable<bool> IsDifferential {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


Latitude Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.Latitude Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the latitude of the image. The latitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational[] Latitude { get; set; }
Visual Basic (Declaration)
Public Property Latitude As FIURational()
Visual C++
public:
property array<FIURational>^ Latitude {
    array<FIURational>^ get ();
    void set (array<FIURational>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.LatitudeDirection


LatitudeDirection Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.LatitudeDirection Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets a value indicating whether the Latitude is north or south latitude.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.LatitudeType> LatitudeDirection { get; set; }
Visual Basic (Declaration)
Public Property LatitudeDirection As Nullable(Of MetadataModel..::.LatitudeType)
Visual C++
public:
property Nullable<MetadataModel..::.LatitudeType> LatitudeDirection {
    Nullable<MetadataModel..::.LatitudeType> get ();
    void set (Nullable<MetadataModel..::.LatitudeType> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


Longitude Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.Longitude Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the longitude of the image. The longitude is expressed as three rational values giving the degrees, minutes, and seconds, respectively. Constant length of 3.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational[] Longitude { get; set; }
Visual Basic (Declaration)
Public Property Longitude As FIURational()
Visual C++
public:
property array<FIURational>^ Longitude {
    array<FIURational>^ get ();
    void set (array<FIURational>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.LongitudeDirection


LongitudeDirection Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.LongitudeDirection Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets a value indicating whether Longitude is east or west longitude.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.LongitudeType> LongitudeDirection { get; set; }
Visual Basic (Declaration)
Public Property LongitudeDirection As Nullable(Of MetadataModel..::.LongitudeType)
Visual C++
public:
property Nullable<MetadataModel..::.LongitudeType> LongitudeDirection {
    Nullable<MetadataModel..::.LongitudeType> get ();
    void set (Nullable<MetadataModel..::.LongitudeType> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


MapDatum Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.MapDatum Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the geodetic survey data used by the GPS receiver. If the survey data is restricted to Japan, the value of this tag is 'TOKYO' or 'WGS-84'.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string MapDatum { get; set; }
Visual Basic (Declaration)
Public Property MapDatum As String
Visual C++
public:
property String^ MapDatum {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


MeasureMode3D Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.MeasureMode3D Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets a value indicating the GPS measurement mode. true indicates three-dimensional measurement; false indicated two-dimensional measurement was in progress.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<bool> MeasureMode3D { get; set; }
Visual Basic (Declaration)
Public Property MeasureMode3D As Nullable(Of Boolean)
Visual C++
public:
property Nullable<bool> MeasureMode3D {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.Model Property
MDM_EXIF_GPS Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


ProcessingMethod Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.ProcessingMethod Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets a character string recording the name of the method used for location finding. The first byte indicates the character code used, and this is followed by the name of the method. Since the Type is not ASCII, NULL termination is not necessary.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] ProcessingMethod { get; set; }
Visual Basic (Declaration)
Public Property ProcessingMethod As Byte()
Visual C++
public:
property array<unsigned char>^ ProcessingMethod {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


Satellites Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.Satellites Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the GPS satellites used for measurements. This tag can be used to describe the number of satellites, their ID number, angle of elevation, azimuth, SNR and other information in ASCII notation. The format is not specified.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Satellites { get; set; }
Visual Basic (Declaration)
Public Property Satellites As String
Visual C++
public:
property String^ Satellites {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


SignedAltitude Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.SignedAltitude Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the signed altitude. Altitude is expressed as one rational value. The reference unit is meters.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIRational> SignedAltitude { get; set; }
Visual Basic (Declaration)
Public Property SignedAltitude As Nullable(Of FIRational)
Visual C++
public:
property Nullable<FIRational> SignedAltitude {
    Nullable<FIRational> get ();
    void set (Nullable<FIRational> value);
}

Remarks

This is a derived property. There is no metadata tag directly associated with this property value.

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Exceptions

Exception | Condition
System..::.OverflowException | Altitude is too large to fit into a FIRational.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


Speed Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.Speed Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the speed of GPS receiver movement.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> Speed { get; set; }
Visual Basic (Declaration)
Public Property Speed As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> Speed {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.SpeedUnit


SpeedUnit Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.SpeedUnit Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the unit used to express the GPS receiver Speed of movement.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.VelocityUnit> SpeedUnit { get; set; }
Visual Basic (Declaration)
Public Property SpeedUnit As Nullable(Of MetadataModel..::.VelocityUnit)
Visual C++
public:
property Nullable<MetadataModel..::.VelocityUnit> SpeedUnit {
    Nullable<MetadataModel..::.VelocityUnit> get ();
    void set (Nullable<MetadataModel..::.VelocityUnit> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.Speed


Status Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.Status Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets a value indicating the status of the GPS receiver when the image was recorded. true indicates measurement was in progress; false indicates measurement was Interoperability.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic (Declaration)
Public Property Status As Nullable(Of Boolean)
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


TimeStamp Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.TimeStamp Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the time as UTC (Coordinated Universal Time). Constant length of 3.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<TimeSpan> TimeStamp { get; set; }
Visual Basic (Declaration)
Public Property TimeStamp As Nullable(Of TimeSpan)
Visual C++
public:
property Nullable<TimeSpan> TimeStamp {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


Track Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.Track Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> Track { get; set; }
Visual Basic (Declaration)
Public Property Track As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> Track {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.TrackDirectionReference


TrackDirectionReference Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.TrackDirectionReference Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the reference for giving the direction of GPS receiver movement.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.DirectionReference> TrackDirectionReference { get; set; }
Visual Basic (Declaration)
Public Property TrackDirectionReference As Nullable(Of MetadataModel..::.DirectionReference)
Visual C++
public:
property Nullable<MetadataModel..::.DirectionReference> TrackDirectionReference {
    Nullable<MetadataModel..::.DirectionReference> get ();
    void set (Nullable<MetadataModel..::.DirectionReference> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_GPS..::.Track


VersionID Property

[image]

FreeImage .NET Documentation
MDM_EXIF_GPS..::.VersionID Property
MDM_EXIF_GPS Class See Also Send Feedback
Gets or sets the GPS version ID. Constant length of 4.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public byte[] VersionID { get; set; }
Visual Basic (Declaration)
Public Property VersionID As Byte()
Visual C++
public:
property array<unsigned char>^ VersionID {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_GPS Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_MAIN Class

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_EXIF_MAIN.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public class MDM_EXIF_MAIN : MetadataModel
Visual Basic (Declaration)
Public Class MDM_EXIF_MAIN _
    Inherits MetadataModel
Visual C++
public ref class MDM_EXIF_MAIN : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_EXIF_MAIN
FreeImageAPI.Metadata..::.MDM_MAIN

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Members
FreeImageAPI.Metadata Namespace


MDM_EXIF_MAIN Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_MAIN Members
MDM_EXIF_MAIN Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_EXIF_MAIN type exposes the following members.

Constructors

Name | Description
MDM_EXIF_MAIN | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Artist | Gets or sets the name of the camera owner, photographer or image creator.
BitsPerSample | Gets or sets number of bits per image component. In this standard each component of the image is 8 bits, so the value for this tag is 8. Constant length of 3.
Compression | Gets or sets compression scheme used for the image data. When a primary image is JPEG compressed, this designation is not necessary and is omitted. When thumbnails use JPEG compression, this tag value is set to 6.
Copyright | Gets or sets the photographer and editor copyrights. Constant length of 1-2.
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
DateTime | Gets or sets the date and time of image creation.
EquipmentModel | Gets or sets the model name or model number of the equipment.
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
ImageDescription | Gets or sets a string giving the title of the image.
ImageHeight | Gets or sets number of rows of image data. In JPEG compressed data a JPEG marker is used instead of this tag.
ImageWidth | Gets or sets the number of columns of image data, equal to the number of pixels per row. In JPEG compressed data a JPEG marker is used instead of this tag.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
JPEGInterchangeFormat | Gets or sets the offset to the start byte (SOI) of JPEG compressed thumbnail data. This is not used for primary image JPEG data.
JPEGInterchangeFormatLength | Gets or sets the number of bytes of JPEG compressed thumbnail data.
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Make | Gets or sets the manufacturer of the recording equipment.
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
Orientation | Gets or sets the image orientation viewed in terms of rows and columns.
PhotometricInterpretation | Gets or sets pixel composition. In JPEG compressed data a JPEG marker is used instead of this tag. See remarks for further information.
PlanarConfiguration | Gets or sets a value that indicates whether pixel components are recorded in chunky or planar format. In JPEG compressed files a JPEG marker is used instead of this tag. If this field does not exist, the TIFF default of 1 (chunky) is assumed. See remarks for further information.
PrimaryChromaticities | Gets or sets the chromaticity of the three primary colors of the image. Constant length of 6.
ReferenceBlackWhite | Gets or sets the reference black point value and reference white point value. Constant length of 6.
ResolutionUnit | Gets or sets the unit for measuring XResolution and YResolution. The same unit is used for both XResolution and YResolution. If the image resolution in unknown, 2 (inches) is designated. See remarks for further information.
RowsPerStrip | Gets or sets number of rows per strip. This is the number of rows in the image of one strip when an image is divided into strips. With JPEG compressed data this designation is not needed and is omitted.
SamplesPerPixel | Gets or sets the number of components per pixel. Since this standard applies to RGB and YCbCr images, the value set for this tag is 3. In JPEG compressed data a JPEG marker is used instead of this tag.
Software | Gets or sets the name and version of the software or firmware of the camera or image input device used to generate the image.
StripByteCounts | Gets or sets the total number of bytes in each strip. With JPEG compressed data this designation is not needed and is omitted. Constant length of SamplesPerPixel * StripsPerImage.
StripOffsets | Gets or sets the byte offset of that strip. It is recommended that this be selected so the number of strip bytes does not exceed 64 Kbytes. With JPEG compressed data this designation is not needed and is omitted. Constant length of SamplesPerPixel * StripsPerImage.
TransferFunction | Gets or sets a transfer function for the image, described in tabular style. Constant length of 3 * 256.
WhitePoint | Gets or sets the chromaticity of the white point of the image. Constant length of 2.
XResolution | Gets or sets the number of pixels per ResolutionUnit in the ImageWidth direction. When the image resolution is unknown, 72 [dpi] is designated.
YCbCrCoefficients | Gets or sets the matrix coefficients for transformation from RGB to YCbCr image data. Constant length of 3.
YCbCrPositioning | Gets or sets position of chrominance components in relation to the luminance component. See remarks for further information.
YCbCrSubSampling | Gets or sets the sampling ratio of chrominance components in relation to the luminance component. In JPEG compressed dat a JPEG marker is used instead of this tag. See remarks for further information.
YResolution | Gets or sets the number of pixels per ResolutionUnit in the ImageHeight direction. When the image resolution is unknown, 72 [dpi] is designated.

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_MAIN Constructor

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN Constructor
MDM_EXIF_MAIN Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_EXIF_MAIN(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_EXIF_MAIN(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_MAIN Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_MAIN Fields
MDM_EXIF_MAIN Class See Also Send Feedback

The MDM_EXIF_MAIN type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


MDM_EXIF_MAIN Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_MAIN Methods
MDM_EXIF_MAIN Class See Also Send Feedback

The MDM_EXIF_MAIN type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.AddTag Method
MDM_EXIF_MAIN Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_EXIF_MAIN Class
MDM_EXIF_MAIN Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.SetTagValue Method
MDM_EXIF_MAIN Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_EXIF_MAIN Class
MDM_EXIF_MAIN Members
FreeImageAPI.Metadata Namespace


MDM_EXIF_MAIN Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_EXIF_MAIN Properties
MDM_EXIF_MAIN Class See Also Send Feedback

The MDM_EXIF_MAIN type exposes the following members.

Properties

Name | Description
Artist | Gets or sets the name of the camera owner, photographer or image creator.
BitsPerSample | Gets or sets number of bits per image component. In this standard each component of the image is 8 bits, so the value for this tag is 8. Constant length of 3.
Compression | Gets or sets compression scheme used for the image data. When a primary image is JPEG compressed, this designation is not necessary and is omitted. When thumbnails use JPEG compression, this tag value is set to 6.
Copyright | Gets or sets the photographer and editor copyrights. Constant length of 1-2.
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
DateTime | Gets or sets the date and time of image creation.
EquipmentModel | Gets or sets the model name or model number of the equipment.
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
ImageDescription | Gets or sets a string giving the title of the image.
ImageHeight | Gets or sets number of rows of image data. In JPEG compressed data a JPEG marker is used instead of this tag.
ImageWidth | Gets or sets the number of columns of image data, equal to the number of pixels per row. In JPEG compressed data a JPEG marker is used instead of this tag.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
JPEGInterchangeFormat | Gets or sets the offset to the start byte (SOI) of JPEG compressed thumbnail data. This is not used for primary image JPEG data.
JPEGInterchangeFormatLength | Gets or sets the number of bytes of JPEG compressed thumbnail data.
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Make | Gets or sets the manufacturer of the recording equipment.
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
Orientation | Gets or sets the image orientation viewed in terms of rows and columns.
PhotometricInterpretation | Gets or sets pixel composition. In JPEG compressed data a JPEG marker is used instead of this tag. See remarks for further information.
PlanarConfiguration | Gets or sets a value that indicates whether pixel components are recorded in chunky or planar format. In JPEG compressed files a JPEG marker is used instead of this tag. If this field does not exist, the TIFF default of 1 (chunky) is assumed. See remarks for further information.
PrimaryChromaticities | Gets or sets the chromaticity of the three primary colors of the image. Constant length of 6.
ReferenceBlackWhite | Gets or sets the reference black point value and reference white point value. Constant length of 6.
ResolutionUnit | Gets or sets the unit for measuring XResolution and YResolution. The same unit is used for both XResolution and YResolution. If the image resolution in unknown, 2 (inches) is designated. See remarks for further information.
RowsPerStrip | Gets or sets number of rows per strip. This is the number of rows in the image of one strip when an image is divided into strips. With JPEG compressed data this designation is not needed and is omitted.
SamplesPerPixel | Gets or sets the number of components per pixel. Since this standard applies to RGB and YCbCr images, the value set for this tag is 3. In JPEG compressed data a JPEG marker is used instead of this tag.
Software | Gets or sets the name and version of the software or firmware of the camera or image input device used to generate the image.
StripByteCounts | Gets or sets the total number of bytes in each strip. With JPEG compressed data this designation is not needed and is omitted. Constant length of SamplesPerPixel * StripsPerImage.
StripOffsets | Gets or sets the byte offset of that strip. It is recommended that this be selected so the number of strip bytes does not exceed 64 Kbytes. With JPEG compressed data this designation is not needed and is omitted. Constant length of SamplesPerPixel * StripsPerImage.
TransferFunction | Gets or sets a transfer function for the image, described in tabular style. Constant length of 3 * 256.
WhitePoint | Gets or sets the chromaticity of the white point of the image. Constant length of 2.
XResolution | Gets or sets the number of pixels per ResolutionUnit in the ImageWidth direction. When the image resolution is unknown, 72 [dpi] is designated.
YCbCrCoefficients | Gets or sets the matrix coefficients for transformation from RGB to YCbCr image data. Constant length of 3.
YCbCrPositioning | Gets or sets position of chrominance components in relation to the luminance component. See remarks for further information.
YCbCrSubSampling | Gets or sets the sampling ratio of chrominance components in relation to the luminance component. In JPEG compressed dat a JPEG marker is used instead of this tag. See remarks for further information.
YResolution | Gets or sets the number of pixels per ResolutionUnit in the ImageHeight direction. When the image resolution is unknown, 72 [dpi] is designated.

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


Artist Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.Artist Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the name of the camera owner, photographer or image creator.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Artist { get; set; }
Visual Basic (Declaration)
Public Property Artist As String
Visual C++
public:
property String^ Artist {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


BitsPerSample Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.BitsPerSample Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets number of bits per image component. In this standard each component of the image is 8 bits, so the value for this tag is 8. Constant length of 3.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort[] BitsPerSample { get; set; }
Visual Basic (Declaration)
Public Property BitsPerSample As UShort()
Visual C++
public:
property array<unsigned short>^ BitsPerSample {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


Compression Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.Compression Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets compression scheme used for the image data. When a primary image is JPEG compressed, this designation is not necessary and is omitted. When thumbnails use JPEG compression, this tag value is set to 6.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> Compression { get; set; }
Visual Basic (Declaration)
Public Property Compression As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> Compression {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


Copyright Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.Copyright Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the photographer and editor copyrights. Constant length of 1-2.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string[] Copyright { get; set; }
Visual Basic (Declaration)
Public Property Copyright As String()
Visual C++
public:
property array<String^>^ Copyright {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


DateTime Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.DateTime Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the date and time of image creation.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<DateTime> DateTime { get; set; }
Visual Basic (Declaration)
Public Property DateTime As Nullable(Of DateTime)
Visual C++
public:
property Nullable<DateTime> DateTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


EquipmentModel Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.EquipmentModel Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the model name or model number of the equipment.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string EquipmentModel { get; set; }
Visual Basic (Declaration)
Public Property EquipmentModel As String
Visual C++
public:
property String^ EquipmentModel {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


ImageDescription Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.ImageDescription Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets a string giving the title of the image.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ImageDescription { get; set; }
Visual Basic (Declaration)
Public Property ImageDescription As String
Visual C++
public:
property String^ ImageDescription {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


ImageHeight Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.ImageHeight Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets number of rows of image data. In JPEG compressed data a JPEG marker is used instead of this tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<uint> ImageHeight { get; set; }
Visual Basic (Declaration)
Public Property ImageHeight As Nullable(Of UInteger)
Visual C++
public:
property Nullable<unsigned int> ImageHeight {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


ImageWidth Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.ImageWidth Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the number of columns of image data, equal to the number of pixels per row. In JPEG compressed data a JPEG marker is used instead of this tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<uint> ImageWidth { get; set; }
Visual Basic (Declaration)
Public Property ImageWidth As Nullable(Of UInteger)
Visual C++
public:
property Nullable<unsigned int> ImageWidth {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


JPEGInterchangeFormat Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.JPEGInterchangeFormat Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the offset to the start byte (SOI) of JPEG compressed thumbnail data. This is not used for primary image JPEG data.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<uint> JPEGInterchangeFormat { get; set; }
Visual Basic (Declaration)
Public Property JPEGInterchangeFormat As Nullable(Of UInteger)
Visual C++
public:
property Nullable<unsigned int> JPEGInterchangeFormat {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


JPEGInterchangeFormatLength Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.JPEGInterchangeFormatLength Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the number of bytes of JPEG compressed thumbnail data.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<uint> JPEGInterchangeFormatLength { get; set; }
Visual Basic (Declaration)
Public Property JPEGInterchangeFormatLength As Nullable(Of UInteger)
Visual C++
public:
property Nullable<unsigned int> JPEGInterchangeFormatLength {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Remarks

This is not used for primary image JPEG data. JPEG thumbnails are not divided but are recorded as a continuous JPEG bitstream from SOI to EOI. APPn and COM markers should not be recorded. Compressed thumbnails shall be recorded in no more than 64 Kbytes, including all other data to be recorded in APP1.

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


Make Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.Make Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the manufacturer of the recording equipment.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Make { get; set; }
Visual Basic (Declaration)
Public Property Make As String
Visual C++
public:
property String^ Make {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.Model Property
MDM_EXIF_MAIN Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


Orientation Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.Orientation Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the image orientation viewed in terms of rows and columns.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.ExifImageOrientation> Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Nullable(Of MetadataModel..::.ExifImageOrientation)
Visual C++
public:
property Nullable<MetadataModel..::.ExifImageOrientation> Orientation {
    Nullable<MetadataModel..::.ExifImageOrientation> get ();
    void set (Nullable<MetadataModel..::.ExifImageOrientation> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


PhotometricInterpretation Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.PhotometricInterpretation Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets pixel composition. In JPEG compressed data a JPEG marker is used instead of this tag. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> PhotometricInterpretation { get; set; }
Visual Basic (Declaration)
Public Property PhotometricInterpretation As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> PhotometricInterpretation {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
2 | RGB
6 | YCbCr
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


PlanarConfiguration Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.PlanarConfiguration Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets a value that indicates whether pixel components are recorded in chunky or planar format. In JPEG compressed files a JPEG marker is used instead of this tag. If this field does not exist, the TIFF default of 1 (chunky) is assumed. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> PlanarConfiguration { get; set; }
Visual Basic (Declaration)
Public Property PlanarConfiguration As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> PlanarConfiguration {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
1 | chunky format
2 | planar format
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


PrimaryChromaticities Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.PrimaryChromaticities Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the chromaticity of the three primary colors of the image. Constant length of 6.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational[] PrimaryChromaticities { get; set; }
Visual Basic (Declaration)
Public Property PrimaryChromaticities As FIURational()
Visual C++
public:
property array<FIURational>^ PrimaryChromaticities {
    array<FIURational>^ get ();
    void set (array<FIURational>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


ReferenceBlackWhite Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.ReferenceBlackWhite Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the reference black point value and reference white point value. Constant length of 6.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational[] ReferenceBlackWhite { get; set; }
Visual Basic (Declaration)
Public Property ReferenceBlackWhite As FIURational()
Visual C++
public:
property array<FIURational>^ ReferenceBlackWhite {
    array<FIURational>^ get ();
    void set (array<FIURational>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


ResolutionUnit Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.ResolutionUnit Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the unit for measuring XResolution and YResolution. The same unit is used for both XResolution and YResolution. If the image resolution in unknown, 2 (inches) is designated. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> ResolutionUnit { get; set; }
Visual Basic (Declaration)
Public Property ResolutionUnit As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> ResolutionUnit {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

The following values are definied:

ID | Description
2 | inches
3 | YCbCr4:2:0
other | centimeters

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


RowsPerStrip Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.RowsPerStrip Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets number of rows per strip. This is the number of rows in the image of one strip when an image is divided into strips. With JPEG compressed data this designation is not needed and is omitted.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<uint> RowsPerStrip { get; set; }
Visual Basic (Declaration)
Public Property RowsPerStrip As Nullable(Of UInteger)
Visual C++
public:
property Nullable<unsigned int> RowsPerStrip {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_MAIN..::.StripByteCounts


SamplesPerPixel Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.SamplesPerPixel Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the number of components per pixel. Since this standard applies to RGB and YCbCr images, the value set for this tag is 3. In JPEG compressed data a JPEG marker is used instead of this tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> SamplesPerPixel { get; set; }
Visual Basic (Declaration)
Public Property SamplesPerPixel As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> SamplesPerPixel {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


Software Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.Software Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the name and version of the software or firmware of the camera or image input device used to generate the image.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Software { get; set; }
Visual Basic (Declaration)
Public Property Software As String
Visual C++
public:
property String^ Software {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


StripByteCounts Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.StripByteCounts Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the total number of bytes in each strip. With JPEG compressed data this designation is not needed and is omitted. Constant length of SamplesPerPixel * StripsPerImage.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint[] StripByteCounts { get; set; }
Visual Basic (Declaration)
Public Property StripByteCounts As UInteger()
Visual C++
public:
property array<unsigned int>^ StripByteCounts {
    array<unsigned int>^ get ();
    void set (array<unsigned int>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


StripOffsets Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.StripOffsets Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the byte offset of that strip. It is recommended that this be selected so the number of strip bytes does not exceed 64 Kbytes. With JPEG compressed data this designation is not needed and is omitted. Constant length of SamplesPerPixel * StripsPerImage.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint[] StripOffsets { get; set; }
Visual Basic (Declaration)
Public Property StripOffsets As UInteger()
Visual C++
public:
property array<unsigned int>^ StripOffsets {
    array<unsigned int>^ get ();
    void set (array<unsigned int>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace
MDM_EXIF_MAIN..::.RowsPerStrip


TransferFunction Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.TransferFunction Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets a transfer function for the image, described in tabular style. Constant length of 3 * 256.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort[] TransferFunction { get; set; }
Visual Basic (Declaration)
Public Property TransferFunction As UShort()
Visual C++
public:
property array<unsigned short>^ TransferFunction {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


WhitePoint Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.WhitePoint Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the chromaticity of the white point of the image. Constant length of 2.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational[] WhitePoint { get; set; }
Visual Basic (Declaration)
Public Property WhitePoint As FIURational()
Visual C++
public:
property array<FIURational>^ WhitePoint {
    array<FIURational>^ get ();
    void set (array<FIURational>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


XResolution Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.XResolution Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the number of pixels per ResolutionUnit in the ImageWidth direction. When the image resolution is unknown, 72 [dpi] is designated.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> XResolution { get; set; }
Visual Basic (Declaration)
Public Property XResolution As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> XResolution {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


YCbCrCoefficients Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.YCbCrCoefficients Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the matrix coefficients for transformation from RGB to YCbCr image data. Constant length of 3.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FIURational[] YCbCrCoefficients { get; set; }
Visual Basic (Declaration)
Public Property YCbCrCoefficients As FIURational()
Visual C++
public:
property array<FIURational>^ YCbCrCoefficients {
    array<FIURational>^ get ();
    void set (array<FIURational>^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


YCbCrPositioning Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.YCbCrPositioning Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets position of chrominance components in relation to the luminance component. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<ushort> YCbCrPositioning { get; set; }
Visual Basic (Declaration)
Public Property YCbCrPositioning As Nullable(Of UShort)
Visual C++
public:
property Nullable<unsigned short> YCbCrPositioning {
    Nullable<unsigned short> get ();
    void set (Nullable<unsigned short> value);
}

Remarks

This field is designated only for JPEG compressed data or uncompressed YCbCr data. The TIFF default is 1 (centered); but when Y:Cb:Cr = 4:2:2 it is recommended in this standard that 2 (co-sited) be used to record data, in order to improve the image quality when viewed on TV systems.

When this field does not exist, the reader shall assume the TIFF default. In the case of Y:Cb:Cr = 4:2:0, the TIFF default (centered) is recommended. If the reader does not have the capability of supporting both kinds of YCbCrPositioning, it shall follow the TIFF default regardless of the value in this field. It is preferable that readers be able to support both centered and co-sited positioning.

The following values are definied:

ID | Description
1 | centered
2 | co-sited
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


YCbCrSubSampling Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.YCbCrSubSampling Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the sampling ratio of chrominance components in relation to the luminance component. In JPEG compressed dat a JPEG marker is used instead of this tag. See remarks for further information.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort[] YCbCrSubSampling { get; set; }
Visual Basic (Declaration)
Public Property YCbCrSubSampling As UShort()
Visual C++
public:
property array<unsigned short>^ YCbCrSubSampling {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}

Remarks

The following values are definied:

ID | Description
[2,1] | YCbCr4:2:2
[2,2] | YCbCr4:2:0
other | reserved

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


YResolution Property

[image]

FreeImage .NET Documentation
MDM_EXIF_MAIN..::.YResolution Property
MDM_EXIF_MAIN Class See Also Send Feedback
Gets or sets the number of pixels per ResolutionUnit in the ImageHeight direction. When the image resolution is unknown, 72 [dpi] is designated.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<FIURational> YResolution { get; set; }
Visual Basic (Declaration)
Public Property YResolution As Nullable(Of FIURational)
Visual C++
public:
property Nullable<FIURational> YResolution {
    Nullable<FIURational> get ();
    void set (Nullable<FIURational> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_EXIF_MAIN Class
FreeImageAPI.Metadata Namespace


MDM_GEOTIFF Class

[image]

FreeImage .NET Documentation
MDM_GEOTIFF Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_GEOTIFF.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MDM_GEOTIFF : MetadataModel
Visual Basic (Declaration)
Public NotInheritable Class MDM_GEOTIFF _
    Inherits MetadataModel
Visual C++
public ref class MDM_GEOTIFF sealed : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_GEOTIFF

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_GEOTIFF Members
FreeImageAPI.Metadata Namespace


MDM_GEOTIFF Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_GEOTIFF Members
MDM_GEOTIFF Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_GEOTIFF type exposes the following members.

Constructors

Name | Description
MDM_GEOTIFF | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
GeoASCIIParams | Gets or sets the value of the GeoTIFF GeoASCIIParamsTag.
GeoDoubleParams | Gets or sets the value of the GeoTIFF GeoDoubleParamsTag.
GeoKeyDirectory | Gets or sets the value of the GeoTIFF GeoKeyDirectoryTag.
IntergraphTransformationMatrix | Gets or sets the value of the GeoTIFF IntergraphTransformationMatrixTag.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
JPLCartoIFDOffset | Gets or sets the value of the GeoTIFF JPLCartoIFDOffsetTag.
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
ModelPixelScale | Gets or sets the value of the GeoTIFF ModelPixelScaleTag.
ModelTiePoints | Gets or sets the value of the GeoTIFF GeoTiePointsTag.
ModelTransformationMatrix | Gets or sets the value of the GeoTIFF ModelTransformationMatrixTag.

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


MDM_GEOTIFF Constructor

[image]

FreeImage .NET Documentation
MDM_GEOTIFF Constructor
MDM_GEOTIFF Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_GEOTIFF(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_GEOTIFF(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


MDM_GEOTIFF Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_GEOTIFF Fields
MDM_GEOTIFF Class See Also Send Feedback

The MDM_GEOTIFF type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


MDM_GEOTIFF Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_GEOTIFF Methods
MDM_GEOTIFF Class See Also Send Feedback

The MDM_GEOTIFF type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_GEOTIFF..::.AddTag Method
MDM_GEOTIFF Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_GEOTIFF Class
MDM_GEOTIFF Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_GEOTIFF..::.SetTagValue Method
MDM_GEOTIFF Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_GEOTIFF Class
MDM_GEOTIFF Members
FreeImageAPI.Metadata Namespace


MDM_GEOTIFF Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_GEOTIFF Properties
MDM_GEOTIFF Class See Also Send Feedback

The MDM_GEOTIFF type exposes the following members.

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
GeoASCIIParams | Gets or sets the value of the GeoTIFF GeoASCIIParamsTag.
GeoDoubleParams | Gets or sets the value of the GeoTIFF GeoDoubleParamsTag.
GeoKeyDirectory | Gets or sets the value of the GeoTIFF GeoKeyDirectoryTag.
IntergraphTransformationMatrix | Gets or sets the value of the GeoTIFF IntergraphTransformationMatrixTag.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
JPLCartoIFDOffset | Gets or sets the value of the GeoTIFF JPLCartoIFDOffsetTag.
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
ModelPixelScale | Gets or sets the value of the GeoTIFF ModelPixelScaleTag.
ModelTiePoints | Gets or sets the value of the GeoTIFF GeoTiePointsTag.
ModelTransformationMatrix | Gets or sets the value of the GeoTIFF ModelTransformationMatrixTag.

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


GeoASCIIParams Property

[image]

FreeImage .NET Documentation
MDM_GEOTIFF..::.GeoASCIIParams Property
MDM_GEOTIFF Class See Also Send Feedback
Gets or sets the value of the GeoTIFF GeoASCIIParamsTag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string GeoASCIIParams { get; set; }
Visual Basic (Declaration)
Public Property GeoASCIIParams As String
Visual C++
public:
property String^ GeoASCIIParams {
    String^ get ();
    void set (String^ value);
}

Remarks

The GeoASCIIParamsTag is used to store all of the String valued GeoKeys, referenced by the GeoKeyDirectory property. Since keys defined in the GeoKeyDirectoryTag use offsets into this tag, any special comments may be placed at the beginning of this tag. For the most part, the only keys that are String valued are Citation keys, giving documentation and references for obscure projections, datums, etc.

Special handling is required for String-valued keys. While it is true that TIFF 6.0 permits multiple NULL-delimited strings within a single ASCII tag, the secondary strings might not appear in the output of naive tiffdump programs. For this reason, the NULL delimiter of each ASCII key value shall be converted to a "|" (pipe) character before being installed back into the String holding tag, so that a dump of the tag will look like this.

AsciiTag="first_value|second_value|etc...last_value|"

A baseline GeoTIFF-reader must check for and convert the final "|" pipe character of a key back into a NULL before returning it to the client software.

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


GeoDoubleParams Property

[image]

FreeImage .NET Documentation
MDM_GEOTIFF..::.GeoDoubleParams Property
MDM_GEOTIFF Class See Also Send Feedback
Gets or sets the value of the GeoTIFF GeoDoubleParamsTag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public double[] GeoDoubleParams { get; set; }
Visual Basic (Declaration)
Public Property GeoDoubleParams As Double()
Visual C++
public:
property array<double>^ GeoDoubleParams {
    array<double>^ get ();
    void set (array<double>^ value);
}

Remarks

The GeoDoubleParamsTag is used to store all of the Double valued GeoKeys, referenced by the GeoKeyDirectory property. The meaning of any value of this double array is determined from the GeoKeyDirectoryTag reference pointing to it. Single values should first be converted to Double and stored here.

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


GeoKeyDirectory Property

[image]

FreeImage .NET Documentation
MDM_GEOTIFF..::.GeoKeyDirectory Property
MDM_GEOTIFF Class See Also Send Feedback
Gets or sets the value of the GeoTIFF GeoKeyDirectoryTag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort[] GeoKeyDirectory { get; set; }
Visual Basic (Declaration)
Public Property GeoKeyDirectory As UShort()
Visual C++
public:
property array<unsigned short>^ GeoKeyDirectory {
    array<unsigned short>^ get ();
    void set (array<unsigned short>^ value);
}

Remarks

The GeoKeyDirectoryTag may be used to store the GeoKey Directory, which defines and references the GeoKeys.

The tag is an array of unsigned UInt16 values, which are primarily grouped into blocks of 4. The first 4 values are special, and contain GeoKey directory header information. The header values consist of the following information, in order:

Header={KeyDirectoryVersion, KeyRevision, MinorRevision, NumberOfKeys}

where

KeyDirectoryVersion indicates the current version of Key implementation, and will only change if this Tag's Key structure is changed. (Similar to the TIFFVersion (42)). The current DirectoryVersion number is 1. This value will most likely never change, and may be used to ensure that this is a valid Key-implementation.

KeyRevision indicates what revision of Key-Sets are used.

MinorRevision indicates what set of Key-Codes are used. The complete revision number is denoted <KeyRevision>.<MinorRevision>.

NumberOfKeys indicates how many Keys are defined by the rest of this Tag.

This header is immediately followed by a collection of <NumberOfKeys> KeyEntry sets, each of which is also 4-UInt16 long. Each KeyEntry is modeled on the TIFFEntry format of the TIFF directory header, and is of the form:

KeyEntry = { KeyID, TIFFTagLocation, Count, Value_Offset }

where

KeyID gives the Key-ID value of the Key (identical in function to TIFF tag ID, but completely independent of TIFF tag-space),

TIFFTagLocation indicates which TIFF tag contains the value(s) of the Key: if TIFFTagLocation is 0, then the value is UInt16, and is contained in the Value_Offset entry. Otherwise, the type (format) of the value is implied by the TIFF-Type of the tag containing the value.

Count indicates the number of values in this key.

Value_Offset Value_Offset indicates the index-offset into the TagArray indicated by TIFFTagLocation, if it is nonzero. If TIFFTagLocation is 0 (zero) , then Value_Offset contains the actual (UInt16) value of the Key, and Count=1 is implied. Note that the offset is not a byte-offset, but rather an index based on the natural data type of the specified tag array.

Following the KeyEntry definitions, the KeyDirectory tag may also contain additional values. For example, if a key requires multiple UInt16 values, they shall be placed at the end of this tag, and the KeyEntry will set TIFFTagLocation=GeoKeyDirectoryTag, with the Value_Offset pointing to the location of the value(s).

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


IntergraphTransformationMatrix Property

[image]

FreeImage .NET Documentation
MDM_GEOTIFF..::.IntergraphTransformationMatrix Property
MDM_GEOTIFF Class See Also Send Feedback
Gets or sets the value of the GeoTIFF IntergraphTransformationMatrixTag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public double[] IntergraphTransformationMatrix { get; set; }
Visual Basic (Declaration)
Public Property IntergraphTransformationMatrix As Double()
Visual C++
public:
property array<double>^ IntergraphTransformationMatrix {
    array<double>^ get ();
    void set (array<double>^ value);
}

Remarks

The IntergraphTransformationMatrixTag conflicts with an internal software implementation at Intergraph, and so its use is no longer encouraged. A GeoTIFF reader should look first for the new tag, and only if it is not found should it check for this older tag. If found, it should only consider it to be contain valid GeoTIFF matrix information if the tag-count is 16; the Intergraph version uses 17 values.

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


JPLCartoIFDOffset Property

[image]

FreeImage .NET Documentation
MDM_GEOTIFF..::.JPLCartoIFDOffset Property
MDM_GEOTIFF Class See Also Send Feedback
Gets or sets the value of the GeoTIFF JPLCartoIFDOffsetTag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<uint> JPLCartoIFDOffset { get; set; }
Visual Basic (Declaration)
Public Property JPLCartoIFDOffset As Nullable(Of UInteger)
Visual C++
public:
property Nullable<unsigned int> JPLCartoIFDOffset {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_GEOTIFF..::.Model Property
MDM_GEOTIFF Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


ModelPixelScale Property

[image]

FreeImage .NET Documentation
MDM_GEOTIFF..::.ModelPixelScale Property
MDM_GEOTIFF Class See Also Send Feedback
Gets or sets the value of the GeoTIFF ModelPixelScaleTag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public double[] ModelPixelScale { get; set; }
Visual Basic (Declaration)
Public Property ModelPixelScale As Double()
Visual C++
public:
property array<double>^ ModelPixelScale {
    array<double>^ get ();
    void set (array<double>^ value);
}

Remarks

The ModelPixelScaleTag tag may be used to specify the size of raster pixel spacing in the model space units, when the raster space can be embedded in the model space coordinate system without rotation, and consists of the following 3 values:

ModelPixelScaleTag = (ScaleX, ScaleY, ScaleZ)

where ScaleX and ScaleY give the horizontal and vertical spacing of raster pixels. The ScaleZ is primarily used to map the pixel value of a digital elevation model into the correct Z-scale, and so for most other purposes this value should be zero (since most model spaces are 2-D, with Z=0).

A single tiepoint in the ModelTiePoints tag, together with this tag, completely determine the relationship between raster and model space; thus they comprise the two tags which Baseline GeoTIFF files most often will use to place a raster image into a "standard position" in model space.

Like the ModelTiePoints tag, this tag information is independent of the XPosition, YPosition, Resolution and Orientation tags of the standard TIFF 6.0 spec. However, simple reversals of orientation between raster and model space (e.g. horizontal or vertical flips) may be indicated by reversal of sign in the corresponding component of the ModelPixelScaleTag. GeoTIFF compliant readers must honor this signreversal convention.

This tag must not be used if the raster image requires rotation or shearing to place it into the standard model space. In such cases the transformation shall be defined with the more general ModelTransformationMatrix.

Naming differences

In the native FreeImage library and thus, in the FreeImage API documentation, this property's key is named GeoPixelScale. Since the GeoTIFF specification as well as Java's EXIFTIFFTagSet class call this tag ModelPixelScale, this property was renamed accordingly. However, when accessing this property's tag by its MetadataTag object, the native FreeImage tag key GeoPixelScale must be used.

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


ModelTiePoints Property

[image]

FreeImage .NET Documentation
MDM_GEOTIFF..::.ModelTiePoints Property
MDM_GEOTIFF Class See Also Send Feedback
Gets or sets the value of the GeoTIFF GeoTiePointsTag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public double[] ModelTiePoints { get; set; }
Visual Basic (Declaration)
Public Property ModelTiePoints As Double()
Visual C++
public:
property array<double>^ ModelTiePoints {
    array<double>^ get ();
    void set (array<double>^ value);
}

Remarks

The GeoTiePointsTag stores raster -> model tiepoint pairs in the order

ModelTiePoints = (...,I,J,K, X,Y,Z...),

where (I,J,K) is the point at location (I,J) in raster space with pixel-value K, and (X,Y,Z) is a vector in model space. In most cases the model space is only two-dimensional, in which case both K and Z should be set to zero; this third dimension is provided in anticipation of future support for 3D digital elevation models and vertical coordinate systems.

A raster image may be georeferenced simply by specifying its location, size and orientation in the model coordinate space M. This may be done by specifying the location of three of the four bounding corner points. However, tiepoints are only to be considered exact at the points specified; thus defining such a set of bounding tiepoints does not imply that the model space locations of the interior of the image may be exactly computed by a linear interpolation of these tiepoints.

However, since the relationship between the Raster space and the model space will often be an exact, affine transformation, this relationship can be defined using one set of tiepoints and the ModelPixelScale, described below, which gives the vertical and horizontal raster grid cell size, specified in model units.

If possible, the first tiepoint placed in this tag shall be the one establishing the location of the point (0,0) in raster space. However, if this is not possible (for example, if (0,0) is goes to a part of model space in which the projection is ill-defined), then there is no particular order in which the tiepoints need be listed.

For orthorectification or mosaicking applications a large number of tiepoints may be specified on a mesh over the raster image. However, the definition of associated grid interpolation methods is not in the scope of the current GeoTIFF spec.

Naming differences

In the native FreeImage library and thus, in the FreeImage API documentation, this property's key is named GeoTiePoints. Since the GeoTIFF specification as well as Java's EXIFTIFFTagSet class call this tag ModelTiePoints, this property was renamed accordingly. However, when accessing this property's tag by its MetadataTag object, the native FreeImage tag key GeoTiePoints must be used.

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


ModelTransformationMatrix Property

[image]

FreeImage .NET Documentation
MDM_GEOTIFF..::.ModelTransformationMatrix Property
MDM_GEOTIFF Class See Also Send Feedback
Gets or sets the value of the GeoTIFF ModelTransformationMatrixTag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public double[] ModelTransformationMatrix { get; set; }
Visual Basic (Declaration)
Public Property ModelTransformationMatrix As Double()
Visual C++
public:
property array<double>^ ModelTransformationMatrix {
    array<double>^ get ();
    void set (array<double>^ value);
}

Remarks

This tag may be used to specify the transformation matrix between the raster space (and its dependent pixel-value space) and the (possibly 3D) model space.

Naming differences

In the native FreeImage library and thus, in the FreeImage API documentation, this property's key is named GeoTransformationMatrix. Since the GeoTIFF specification as well as Java's EXIFTIFFTagSet class call this tag ModelTransformationMatrix, this property was renamed accordingly. However, when accessing this property's tag by its MetadataTag object, the native FreeImage tag key GeoTransformationMatrix must be used.

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_GEOTIFF Class
FreeImageAPI.Metadata Namespace


MDM_INTEROP Class

[image]

FreeImage .NET Documentation
MDM_INTEROP Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_EXIF_INTEROP.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MDM_INTEROP : MetadataModel
Visual Basic (Declaration)
Public NotInheritable Class MDM_INTEROP _
    Inherits MetadataModel
Visual C++
public ref class MDM_INTEROP sealed : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_INTEROP

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_INTEROP Members
FreeImageAPI.Metadata Namespace


MDM_INTEROP Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_INTEROP Members
MDM_INTEROP Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_INTEROP type exposes the following members.

Constructors

Name | Description
MDM_INTEROP | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Identification | Gets or sets the identification of the Interoperability rule.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)

See Also

MDM_INTEROP Class
FreeImageAPI.Metadata Namespace


MDM_INTEROP Constructor

[image]

FreeImage .NET Documentation
MDM_INTEROP Constructor
MDM_INTEROP Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_INTEROP(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_INTEROP(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_INTEROP Class
FreeImageAPI.Metadata Namespace


MDM_INTEROP Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_INTEROP Fields
MDM_INTEROP Class See Also Send Feedback

The MDM_INTEROP type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_INTEROP Class
FreeImageAPI.Metadata Namespace


MDM_INTEROP Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_INTEROP Methods
MDM_INTEROP Class See Also Send Feedback

The MDM_INTEROP type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_INTEROP Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_INTEROP..::.AddTag Method
MDM_INTEROP Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_INTEROP Class
MDM_INTEROP Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_INTEROP..::.SetTagValue Method
MDM_INTEROP Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_INTEROP Class
MDM_INTEROP Members
FreeImageAPI.Metadata Namespace


MDM_INTEROP Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_INTEROP Properties
MDM_INTEROP Class See Also Send Feedback

The MDM_INTEROP type exposes the following members.

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Identification | Gets or sets the identification of the Interoperability rule.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)

See Also

MDM_INTEROP Class
FreeImageAPI.Metadata Namespace


Identification Property

[image]

FreeImage .NET Documentation
MDM_INTEROP..::.Identification Property
MDM_INTEROP Class See Also Send Feedback
Gets or sets the identification of the Interoperability rule.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<MetadataModel..::.InteroperabilityMode> Identification { get; set; }
Visual Basic (Declaration)
Public Property Identification As Nullable(Of MetadataModel..::.InteroperabilityMode)
Visual C++
public:
property Nullable<MetadataModel..::.InteroperabilityMode> Identification {
    Nullable<MetadataModel..::.InteroperabilityMode> get ();
    void set (Nullable<MetadataModel..::.InteroperabilityMode> value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_INTEROP Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_INTEROP..::.Model Property
MDM_INTEROP Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_INTEROP Class
FreeImageAPI.Metadata Namespace


MDM_IPTC Class

[image]

FreeImage .NET Documentation
MDM_IPTC Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_IPTC.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MDM_IPTC : MetadataModel
Visual Basic (Declaration)
Public NotInheritable Class MDM_IPTC _
    Inherits MetadataModel
Visual C++
public ref class MDM_IPTC sealed : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_IPTC

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Members
FreeImageAPI.Metadata Namespace


MDM_IPTC Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_IPTC Members
MDM_IPTC Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_IPTC type exposes the following members.

Constructors

Name | Description
MDM_IPTC | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
ActionAdvised | Gets or sets the value of the IPTC/NAA tag Action Advised.
ApplicationRecordVersion | Gets the Application Record Version.
AudioDuration | Gets or sets the value of the IPTC/NAA tag Audio Duration.
AudioOutcue | Gets or sets the value of the IPTC/NAA tag Audio Outcue.
AudioSamplingRate | Gets or sets the value of the IPTC/NAA tag Audio Sampling Rate.
AudioSamplingResolution | Gets or sets the value of the IPTC/NAA tag Audio Sampling Resolution.
AudioType | Gets or sets the value of the IPTC/NAA tag Audio Type.
ByLine | Gets or sets the value of the IPTC/NAA tag By Line. This is the author's name.
ByLineTitle | Gets or sets the value of the IPTC/NAA tag By Line Title. This is the author's position.
CaptionAbstract | Gets or sets the value of the IPTC/NAA tag Caption Abstract.
Category | Gets or sets the value of the IPTC/NAA tag Category.
City | Gets or sets the value of the IPTC/NAA tag City.
ClassifyState | Gets or sets the value of the IPTC/NAA tag Classify State.
Contact | Gets or sets the value of the IPTC/NAA tag Contact.
ContentLocationCode | Gets or sets the value of the IPTC/NAA tag Content Location Code.
ContentLocationName | Gets or sets the value of the IPTC/NAA tag Content Location Name.
CopyrightNotice | Gets or sets the value of the IPTC/NAA tag Copyright Notice.
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
CountryPrimaryLocationCode | Gets or sets the value of the IPTC/NAA tag Country Primary Location Code.
CountryPrimaryLocationName | Gets or sets the value of the IPTC/NAA tag Country Primary Location Name.
Credit | Gets or sets the value of the IPTC/NAA tag Credit.
DateCreated | Gets or sets the value of the IPTC/NAA tag Date Created.
DigitalCreationDate | Gets or sets the value of the IPTC/NAA tag Digital Creation Date.
DigitalCreationTime | Gets or sets the value of the IPTC/NAA tag Digital Creation Time.
DocumentHistory | Gets or sets the value of the IPTC/NAA tag Document History.
DocumentNotes | Gets or sets the value of the IPTC/NAA tag Document Notes.
EditorialUpdate | Gets or sets the value of the IPTC/NAA tag Editorial Update.
EditStatus | Gets or sets the value of the IPTC/NAA tag Edit Status.
ExifCameraInfo | Gets or sets the value of the IPTC/NAA tag Exif Camera Info.
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
ExpirationDate | Gets or sets the value of the IPTC/NAA tag Expiration Date.
ExpirationTime | Gets or sets the value of the IPTC/NAA tag Expiration Time.
FixtureIdentifier | Gets or sets the value of the IPTC/NAA tag Fixture Identifier.
Headline | Gets or sets the value of the IPTC/NAA tag Headline.
ImageOrientation | Gets or sets the value of the IPTC/NAA tag Image Orientation.
ImageType | Gets or sets the value of the IPTC/NAA tag Image Type.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
JobID | Gets or sets the value of the IPTC/NAA tag Job I D.
Keywords | Gets or sets the value of the IPTC/NAA tag Keywords.
LanguageIdentifier | Gets or sets the value of the IPTC/NAA tag Language Identifier.
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
MasterDocumentID | Gets or sets the value of the IPTC/NAA tag Master Document I D.
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
ObjectAttributeReference | Gets or sets the value of the IPTC/NAA tag Object Attribute Reference.
ObjectCycle | Gets or sets the value of the IPTC/NAA tag Object Cycle.
ObjectName | Gets or sets the value of the IPTC/NAA tag Object Name. This is also referred to as Title.
ObjectPreviewData | Gets or sets the value of the IPTC/NAA tag Object Preview Data. This is also referred to as Audio Outcue.
ObjectPreviewFileFormat | Gets or sets the value of the IPTC/NAA tag Object Preview File Format.
ObjectPreviewFileVersion | Gets or sets the value of the IPTC/NAA tag Object Preview File Version.
ObjectTypeReference | Gets or sets the value of the IPTC/NAA tag Object Type Reference.
OriginalTransmissionReference | Gets or sets the value of the IPTC/NAA tag Original Transmission Reference.
OriginatingProgram | Gets or sets the value of the IPTC/NAA tag Originating Program.
OwnerID | Gets or sets the value of the IPTC/NAA tag Owner I D.
Prefs | Gets or sets the value of the IPTC/NAA tag Prefs. This is also referred to as photo-mechanic preferences.
ProgramVersion | Gets or sets the value of the IPTC/NAA tag Program Version.
ProvinceState | Gets or sets the value of the IPTC/NAA tag Province State.
RasterizedCaption | Gets or sets the value of the IPTC/NAA tag Rasterized Caption.
ReferenceDate | Gets or sets the value of the IPTC/NAA tag Reference Date.
ReferenceNumber | Gets or sets the value of the IPTC/NAA tag Reference Number.
ReferenceService | Gets or sets the value of the IPTC/NAA tag Reference Service.
ReleaseDate | Gets or sets the value of the IPTC/NAA tag Release Date.
ReleaseTime | Gets or sets the value of the IPTC/NAA tag Release Time.
ShortDocumentID | Gets or sets the value of the IPTC/NAA tag Short Document I D.
SimilarityIndex | Gets or sets the value of the IPTC/NAA tag Similarity Index.
Source | Gets or sets the value of the IPTC/NAA tag Source.
SpecialInstructions | Gets or sets the value of the IPTC/NAA tag Special Instructions.
SubjectReference | Gets or sets the value of the IPTC/NAA tag Subject Reference.
SubLocation | Gets or sets the value of the IPTC/NAA tag Sub Location.
SupplementalCategories | Gets or sets the value of the IPTC/NAA tag Supplemental Categories.
TimeCreated | Gets or sets the value of the IPTC/NAA tag Time Created.
UniqueDocumentID | Gets or sets the value of the IPTC/NAA tag Unique Document I D.
Urgency | Gets or sets the value of the IPTC/NAA tag Urgency.
WriterEditor | Gets or sets the value of the IPTC/NAA tag Writer Editor. This is also referred to as Caption Writer.

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


MDM_IPTC Constructor

[image]

FreeImage .NET Documentation
MDM_IPTC Constructor
MDM_IPTC Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_IPTC(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_IPTC(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


MDM_IPTC Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_IPTC Fields
MDM_IPTC Class See Also Send Feedback

The MDM_IPTC type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


MDM_IPTC Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_IPTC Methods
MDM_IPTC Class See Also Send Feedback

The MDM_IPTC type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_IPTC..::.AddTag Method
MDM_IPTC Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_IPTC Class
MDM_IPTC Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_IPTC..::.SetTagValue Method
MDM_IPTC Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_IPTC Class
MDM_IPTC Members
FreeImageAPI.Metadata Namespace


MDM_IPTC Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_IPTC Properties
MDM_IPTC Class See Also Send Feedback

The MDM_IPTC type exposes the following members.

Properties

Name | Description
ActionAdvised | Gets or sets the value of the IPTC/NAA tag Action Advised.
ApplicationRecordVersion | Gets the Application Record Version.
AudioDuration | Gets or sets the value of the IPTC/NAA tag Audio Duration.
AudioOutcue | Gets or sets the value of the IPTC/NAA tag Audio Outcue.
AudioSamplingRate | Gets or sets the value of the IPTC/NAA tag Audio Sampling Rate.
AudioSamplingResolution | Gets or sets the value of the IPTC/NAA tag Audio Sampling Resolution.
AudioType | Gets or sets the value of the IPTC/NAA tag Audio Type.
ByLine | Gets or sets the value of the IPTC/NAA tag By Line. This is the author's name.
ByLineTitle | Gets or sets the value of the IPTC/NAA tag By Line Title. This is the author's position.
CaptionAbstract | Gets or sets the value of the IPTC/NAA tag Caption Abstract.
Category | Gets or sets the value of the IPTC/NAA tag Category.
City | Gets or sets the value of the IPTC/NAA tag City.
ClassifyState | Gets or sets the value of the IPTC/NAA tag Classify State.
Contact | Gets or sets the value of the IPTC/NAA tag Contact.
ContentLocationCode | Gets or sets the value of the IPTC/NAA tag Content Location Code.
ContentLocationName | Gets or sets the value of the IPTC/NAA tag Content Location Name.
CopyrightNotice | Gets or sets the value of the IPTC/NAA tag Copyright Notice.
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
CountryPrimaryLocationCode | Gets or sets the value of the IPTC/NAA tag Country Primary Location Code.
CountryPrimaryLocationName | Gets or sets the value of the IPTC/NAA tag Country Primary Location Name.
Credit | Gets or sets the value of the IPTC/NAA tag Credit.
DateCreated | Gets or sets the value of the IPTC/NAA tag Date Created.
DigitalCreationDate | Gets or sets the value of the IPTC/NAA tag Digital Creation Date.
DigitalCreationTime | Gets or sets the value of the IPTC/NAA tag Digital Creation Time.
DocumentHistory | Gets or sets the value of the IPTC/NAA tag Document History.
DocumentNotes | Gets or sets the value of the IPTC/NAA tag Document Notes.
EditorialUpdate | Gets or sets the value of the IPTC/NAA tag Editorial Update.
EditStatus | Gets or sets the value of the IPTC/NAA tag Edit Status.
ExifCameraInfo | Gets or sets the value of the IPTC/NAA tag Exif Camera Info.
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
ExpirationDate | Gets or sets the value of the IPTC/NAA tag Expiration Date.
ExpirationTime | Gets or sets the value of the IPTC/NAA tag Expiration Time.
FixtureIdentifier | Gets or sets the value of the IPTC/NAA tag Fixture Identifier.
Headline | Gets or sets the value of the IPTC/NAA tag Headline.
ImageOrientation | Gets or sets the value of the IPTC/NAA tag Image Orientation.
ImageType | Gets or sets the value of the IPTC/NAA tag Image Type.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
JobID | Gets or sets the value of the IPTC/NAA tag Job I D.
Keywords | Gets or sets the value of the IPTC/NAA tag Keywords.
LanguageIdentifier | Gets or sets the value of the IPTC/NAA tag Language Identifier.
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
MasterDocumentID | Gets or sets the value of the IPTC/NAA tag Master Document I D.
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
ObjectAttributeReference | Gets or sets the value of the IPTC/NAA tag Object Attribute Reference.
ObjectCycle | Gets or sets the value of the IPTC/NAA tag Object Cycle.
ObjectName | Gets or sets the value of the IPTC/NAA tag Object Name. This is also referred to as Title.
ObjectPreviewData | Gets or sets the value of the IPTC/NAA tag Object Preview Data. This is also referred to as Audio Outcue.
ObjectPreviewFileFormat | Gets or sets the value of the IPTC/NAA tag Object Preview File Format.
ObjectPreviewFileVersion | Gets or sets the value of the IPTC/NAA tag Object Preview File Version.
ObjectTypeReference | Gets or sets the value of the IPTC/NAA tag Object Type Reference.
OriginalTransmissionReference | Gets or sets the value of the IPTC/NAA tag Original Transmission Reference.
OriginatingProgram | Gets or sets the value of the IPTC/NAA tag Originating Program.
OwnerID | Gets or sets the value of the IPTC/NAA tag Owner I D.
Prefs | Gets or sets the value of the IPTC/NAA tag Prefs. This is also referred to as photo-mechanic preferences.
ProgramVersion | Gets or sets the value of the IPTC/NAA tag Program Version.
ProvinceState | Gets or sets the value of the IPTC/NAA tag Province State.
RasterizedCaption | Gets or sets the value of the IPTC/NAA tag Rasterized Caption.
ReferenceDate | Gets or sets the value of the IPTC/NAA tag Reference Date.
ReferenceNumber | Gets or sets the value of the IPTC/NAA tag Reference Number.
ReferenceService | Gets or sets the value of the IPTC/NAA tag Reference Service.
ReleaseDate | Gets or sets the value of the IPTC/NAA tag Release Date.
ReleaseTime | Gets or sets the value of the IPTC/NAA tag Release Time.
ShortDocumentID | Gets or sets the value of the IPTC/NAA tag Short Document I D.
SimilarityIndex | Gets or sets the value of the IPTC/NAA tag Similarity Index.
Source | Gets or sets the value of the IPTC/NAA tag Source.
SpecialInstructions | Gets or sets the value of the IPTC/NAA tag Special Instructions.
SubjectReference | Gets or sets the value of the IPTC/NAA tag Subject Reference.
SubLocation | Gets or sets the value of the IPTC/NAA tag Sub Location.
SupplementalCategories | Gets or sets the value of the IPTC/NAA tag Supplemental Categories.
TimeCreated | Gets or sets the value of the IPTC/NAA tag Time Created.
UniqueDocumentID | Gets or sets the value of the IPTC/NAA tag Unique Document I D.
Urgency | Gets or sets the value of the IPTC/NAA tag Urgency.
WriterEditor | Gets or sets the value of the IPTC/NAA tag Writer Editor. This is also referred to as Caption Writer.

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ActionAdvised Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ActionAdvised Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Action Advised.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ActionAdvised { get; set; }
Visual Basic (Declaration)
Public Property ActionAdvised As String
Visual C++
public:
property String^ ActionAdvised {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ApplicationRecordVersion Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ApplicationRecordVersion Property
MDM_IPTC Class See Also Send Feedback
Gets the Application Record Version.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Nullable<short> ApplicationRecordVersion { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationRecordVersion As Nullable(Of Short)
Visual C++
public:
property Nullable<short> ApplicationRecordVersion {
    Nullable<short> get ();
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


AudioDuration Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.AudioDuration Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Audio Duration.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string AudioDuration { get; set; }
Visual Basic (Declaration)
Public Property AudioDuration As String
Visual C++
public:
property String^ AudioDuration {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


AudioOutcue Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.AudioOutcue Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Audio Outcue.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string AudioOutcue { get; set; }
Visual Basic (Declaration)
Public Property AudioOutcue As String
Visual C++
public:
property String^ AudioOutcue {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


AudioSamplingRate Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.AudioSamplingRate Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Audio Sampling Rate.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string AudioSamplingRate { get; set; }
Visual Basic (Declaration)
Public Property AudioSamplingRate As String
Visual C++
public:
property String^ AudioSamplingRate {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


AudioSamplingResolution Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.AudioSamplingResolution Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Audio Sampling Resolution.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string AudioSamplingResolution { get; set; }
Visual Basic (Declaration)
Public Property AudioSamplingResolution As String
Visual C++
public:
property String^ AudioSamplingResolution {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


AudioType Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.AudioType Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Audio Type.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string AudioType { get; set; }
Visual Basic (Declaration)
Public Property AudioType As String
Visual C++
public:
property String^ AudioType {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ByLine Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ByLine Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag By Line. This is the author's name.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ByLine { get; set; }
Visual Basic (Declaration)
Public Property ByLine As String
Visual C++
public:
property String^ ByLine {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ByLineTitle Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ByLineTitle Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag By Line Title. This is the author's position.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ByLineTitle { get; set; }
Visual Basic (Declaration)
Public Property ByLineTitle As String
Visual C++
public:
property String^ ByLineTitle {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


CaptionAbstract Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.CaptionAbstract Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Caption Abstract.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string CaptionAbstract { get; set; }
Visual Basic (Declaration)
Public Property CaptionAbstract As String
Visual C++
public:
property String^ CaptionAbstract {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


Category Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.Category Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Category.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Category { get; set; }
Visual Basic (Declaration)
Public Property Category As String
Visual C++
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


City Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.City Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag City.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string City { get; set; }
Visual Basic (Declaration)
Public Property City As String
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ClassifyState Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ClassifyState Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Classify State.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ClassifyState { get; set; }
Visual Basic (Declaration)
Public Property ClassifyState As String
Visual C++
public:
property String^ ClassifyState {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


Contact Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.Contact Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Contact.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Contact { get; set; }
Visual Basic (Declaration)
Public Property Contact As String
Visual C++
public:
property String^ Contact {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ContentLocationCode Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ContentLocationCode Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Content Location Code.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ContentLocationCode { get; set; }
Visual Basic (Declaration)
Public Property ContentLocationCode As String
Visual C++
public:
property String^ ContentLocationCode {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ContentLocationName Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ContentLocationName Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Content Location Name.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ContentLocationName { get; set; }
Visual Basic (Declaration)
Public Property ContentLocationName As String
Visual C++
public:
property String^ ContentLocationName {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


CopyrightNotice Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.CopyrightNotice Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Copyright Notice.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string CopyrightNotice { get; set; }
Visual Basic (Declaration)
Public Property CopyrightNotice As String
Visual C++
public:
property String^ CopyrightNotice {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


CountryPrimaryLocationCode Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.CountryPrimaryLocationCode Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Country Primary Location Code.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string CountryPrimaryLocationCode { get; set; }
Visual Basic (Declaration)
Public Property CountryPrimaryLocationCode As String
Visual C++
public:
property String^ CountryPrimaryLocationCode {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


CountryPrimaryLocationName Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.CountryPrimaryLocationName Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Country Primary Location Name.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string CountryPrimaryLocationName { get; set; }
Visual Basic (Declaration)
Public Property CountryPrimaryLocationName As String
Visual C++
public:
property String^ CountryPrimaryLocationName {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


Credit Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.Credit Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Credit.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Credit { get; set; }
Visual Basic (Declaration)
Public Property Credit As String
Visual C++
public:
property String^ Credit {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


DateCreated Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.DateCreated Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Date Created.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string DateCreated { get; set; }
Visual Basic (Declaration)
Public Property DateCreated As String
Visual C++
public:
property String^ DateCreated {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


DigitalCreationDate Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.DigitalCreationDate Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Digital Creation Date.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string DigitalCreationDate { get; set; }
Visual Basic (Declaration)
Public Property DigitalCreationDate As String
Visual C++
public:
property String^ DigitalCreationDate {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


DigitalCreationTime Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.DigitalCreationTime Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Digital Creation Time.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string DigitalCreationTime { get; set; }
Visual Basic (Declaration)
Public Property DigitalCreationTime As String
Visual C++
public:
property String^ DigitalCreationTime {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


DocumentHistory Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.DocumentHistory Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Document History.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string DocumentHistory { get; set; }
Visual Basic (Declaration)
Public Property DocumentHistory As String
Visual C++
public:
property String^ DocumentHistory {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


DocumentNotes Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.DocumentNotes Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Document Notes.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string DocumentNotes { get; set; }
Visual Basic (Declaration)
Public Property DocumentNotes As String
Visual C++
public:
property String^ DocumentNotes {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


EditorialUpdate Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.EditorialUpdate Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Editorial Update.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string EditorialUpdate { get; set; }
Visual Basic (Declaration)
Public Property EditorialUpdate As String
Visual C++
public:
property String^ EditorialUpdate {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


EditStatus Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.EditStatus Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Edit Status.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string EditStatus { get; set; }
Visual Basic (Declaration)
Public Property EditStatus As String
Visual C++
public:
property String^ EditStatus {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ExifCameraInfo Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ExifCameraInfo Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Exif Camera Info.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ExifCameraInfo { get; set; }
Visual Basic (Declaration)
Public Property ExifCameraInfo As String
Visual C++
public:
property String^ ExifCameraInfo {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ExpirationDate Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ExpirationDate Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Expiration Date.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ExpirationDate { get; set; }
Visual Basic (Declaration)
Public Property ExpirationDate As String
Visual C++
public:
property String^ ExpirationDate {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ExpirationTime Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ExpirationTime Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Expiration Time.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ExpirationTime { get; set; }
Visual Basic (Declaration)
Public Property ExpirationTime As String
Visual C++
public:
property String^ ExpirationTime {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


FixtureIdentifier Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.FixtureIdentifier Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Fixture Identifier.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string FixtureIdentifier { get; set; }
Visual Basic (Declaration)
Public Property FixtureIdentifier As String
Visual C++
public:
property String^ FixtureIdentifier {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


Headline Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.Headline Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Headline.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Headline { get; set; }
Visual Basic (Declaration)
Public Property Headline As String
Visual C++
public:
property String^ Headline {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ImageOrientation Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ImageOrientation Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Image Orientation.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ImageOrientation { get; set; }
Visual Basic (Declaration)
Public Property ImageOrientation As String
Visual C++
public:
property String^ ImageOrientation {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ImageType Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ImageType Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Image Type.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ImageType { get; set; }
Visual Basic (Declaration)
Public Property ImageType As String
Visual C++
public:
property String^ ImageType {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


JobID Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.JobID Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Job I D.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string JobID { get; set; }
Visual Basic (Declaration)
Public Property JobID As String
Visual C++
public:
property String^ JobID {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


Keywords Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.Keywords Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Keywords.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Keywords { get; set; }
Visual Basic (Declaration)
Public Property Keywords As String
Visual C++
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


LanguageIdentifier Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.LanguageIdentifier Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Language Identifier.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string LanguageIdentifier { get; set; }
Visual Basic (Declaration)
Public Property LanguageIdentifier As String
Visual C++
public:
property String^ LanguageIdentifier {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


MasterDocumentID Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.MasterDocumentID Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Master Document I D.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string MasterDocumentID { get; set; }
Visual Basic (Declaration)
Public Property MasterDocumentID As String
Visual C++
public:
property String^ MasterDocumentID {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.Model Property
MDM_IPTC Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ObjectAttributeReference Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ObjectAttributeReference Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Object Attribute Reference.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ObjectAttributeReference { get; set; }
Visual Basic (Declaration)
Public Property ObjectAttributeReference As String
Visual C++
public:
property String^ ObjectAttributeReference {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ObjectCycle Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ObjectCycle Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Object Cycle.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ObjectCycle { get; set; }
Visual Basic (Declaration)
Public Property ObjectCycle As String
Visual C++
public:
property String^ ObjectCycle {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ObjectName Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ObjectName Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Object Name. This is also referred to as Title.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ObjectName { get; set; }
Visual Basic (Declaration)
Public Property ObjectName As String
Visual C++
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ObjectPreviewData Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ObjectPreviewData Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Object Preview Data. This is also referred to as Audio Outcue.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ObjectPreviewData { get; set; }
Visual Basic (Declaration)
Public Property ObjectPreviewData As String
Visual C++
public:
property String^ ObjectPreviewData {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ObjectPreviewFileFormat Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ObjectPreviewFileFormat Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Object Preview File Format.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ObjectPreviewFileFormat { get; set; }
Visual Basic (Declaration)
Public Property ObjectPreviewFileFormat As String
Visual C++
public:
property String^ ObjectPreviewFileFormat {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ObjectPreviewFileVersion Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ObjectPreviewFileVersion Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Object Preview File Version.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ObjectPreviewFileVersion { get; set; }
Visual Basic (Declaration)
Public Property ObjectPreviewFileVersion As String
Visual C++
public:
property String^ ObjectPreviewFileVersion {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ObjectTypeReference Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ObjectTypeReference Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Object Type Reference.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ObjectTypeReference { get; set; }
Visual Basic (Declaration)
Public Property ObjectTypeReference As String
Visual C++
public:
property String^ ObjectTypeReference {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


OriginalTransmissionReference Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.OriginalTransmissionReference Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Original Transmission Reference.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string OriginalTransmissionReference { get; set; }
Visual Basic (Declaration)
Public Property OriginalTransmissionReference As String
Visual C++
public:
property String^ OriginalTransmissionReference {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


OriginatingProgram Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.OriginatingProgram Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Originating Program.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string OriginatingProgram { get; set; }
Visual Basic (Declaration)
Public Property OriginatingProgram As String
Visual C++
public:
property String^ OriginatingProgram {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


OwnerID Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.OwnerID Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Owner I D.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string OwnerID { get; set; }
Visual Basic (Declaration)
Public Property OwnerID As String
Visual C++
public:
property String^ OwnerID {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


Prefs Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.Prefs Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Prefs. This is also referred to as photo-mechanic preferences.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Prefs { get; set; }
Visual Basic (Declaration)
Public Property Prefs As String
Visual C++
public:
property String^ Prefs {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ProgramVersion Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ProgramVersion Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Program Version.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ProgramVersion { get; set; }
Visual Basic (Declaration)
Public Property ProgramVersion As String
Visual C++
public:
property String^ ProgramVersion {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ProvinceState Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ProvinceState Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Province State.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ProvinceState { get; set; }
Visual Basic (Declaration)
Public Property ProvinceState As String
Visual C++
public:
property String^ ProvinceState {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


RasterizedCaption Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.RasterizedCaption Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Rasterized Caption.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string RasterizedCaption { get; set; }
Visual Basic (Declaration)
Public Property RasterizedCaption As String
Visual C++
public:
property String^ RasterizedCaption {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ReferenceDate Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ReferenceDate Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Reference Date.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ReferenceDate { get; set; }
Visual Basic (Declaration)
Public Property ReferenceDate As String
Visual C++
public:
property String^ ReferenceDate {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ReferenceNumber Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ReferenceNumber Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Reference Number.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ReferenceNumber { get; set; }
Visual Basic (Declaration)
Public Property ReferenceNumber As String
Visual C++
public:
property String^ ReferenceNumber {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ReferenceService Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ReferenceService Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Reference Service.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ReferenceService { get; set; }
Visual Basic (Declaration)
Public Property ReferenceService As String
Visual C++
public:
property String^ ReferenceService {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ReleaseDate Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ReleaseDate Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Release Date.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ReleaseDate { get; set; }
Visual Basic (Declaration)
Public Property ReleaseDate As String
Visual C++
public:
property String^ ReleaseDate {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ReleaseTime Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ReleaseTime Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Release Time.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ReleaseTime { get; set; }
Visual Basic (Declaration)
Public Property ReleaseTime As String
Visual C++
public:
property String^ ReleaseTime {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


ShortDocumentID Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.ShortDocumentID Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Short Document I D.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ShortDocumentID { get; set; }
Visual Basic (Declaration)
Public Property ShortDocumentID As String
Visual C++
public:
property String^ ShortDocumentID {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


SimilarityIndex Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.SimilarityIndex Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Similarity Index.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string SimilarityIndex { get; set; }
Visual Basic (Declaration)
Public Property SimilarityIndex As String
Visual C++
public:
property String^ SimilarityIndex {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


Source Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.Source Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Source.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Source { get; set; }
Visual Basic (Declaration)
Public Property Source As String
Visual C++
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


SpecialInstructions Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.SpecialInstructions Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Special Instructions.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string SpecialInstructions { get; set; }
Visual Basic (Declaration)
Public Property SpecialInstructions As String
Visual C++
public:
property String^ SpecialInstructions {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


SubjectReference Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.SubjectReference Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Subject Reference.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string SubjectReference { get; set; }
Visual Basic (Declaration)
Public Property SubjectReference As String
Visual C++
public:
property String^ SubjectReference {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


SubLocation Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.SubLocation Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Sub Location.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string SubLocation { get; set; }
Visual Basic (Declaration)
Public Property SubLocation As String
Visual C++
public:
property String^ SubLocation {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


SupplementalCategories Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.SupplementalCategories Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Supplemental Categories.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string SupplementalCategories { get; set; }
Visual Basic (Declaration)
Public Property SupplementalCategories As String
Visual C++
public:
property String^ SupplementalCategories {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


TimeCreated Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.TimeCreated Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Time Created.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string TimeCreated { get; set; }
Visual Basic (Declaration)
Public Property TimeCreated As String
Visual C++
public:
property String^ TimeCreated {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


UniqueDocumentID Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.UniqueDocumentID Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Unique Document I D.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string UniqueDocumentID { get; set; }
Visual Basic (Declaration)
Public Property UniqueDocumentID As String
Visual C++
public:
property String^ UniqueDocumentID {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


Urgency Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.Urgency Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Urgency.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Urgency { get; set; }
Visual Basic (Declaration)
Public Property Urgency As String
Visual C++
public:
property String^ Urgency {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


WriterEditor Property

[image]

FreeImage .NET Documentation
MDM_IPTC..::.WriterEditor Property
MDM_IPTC Class See Also Send Feedback
Gets or sets the value of the IPTC/NAA tag Writer Editor. This is also referred to as Caption Writer.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string WriterEditor { get; set; }
Visual Basic (Declaration)
Public Property WriterEditor As String
Visual C++
public:
property String^ WriterEditor {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_IPTC Class
FreeImageAPI.Metadata Namespace


MDM_MAIN Class

[image]

FreeImage .NET Documentation
MDM_MAIN Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_EXIF_MAIN.

This class is obsolete. Use class MDM_EXIF_MAIN instead.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public class MDM_MAIN : MetadataModel
Visual Basic (Declaration)
Public Class MDM_MAIN _
    Inherits MetadataModel
Visual C++
public ref class MDM_MAIN : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_MAIN

Version Information

FreeImage.NET

Supported in: 3.11.0
Obsolete (compiler warning) in 3.12.0
Obsolete (compiler warning) in 3.13.0
Obsolete (compiler warning) in 3.13.1

See Also

MDM_MAIN Members
FreeImageAPI.Metadata Namespace


MDM_MAIN Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAIN Members
MDM_MAIN Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_MAIN type exposes the following members.

Constructors

Name | Description
MDM_MAIN | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Artist | Gets or sets the name of the camera owner, photographer or image creator. (Inherited from MDM_EXIF_MAIN.)
BitsPerSample | Gets or sets number of bits per image component. In this standard each component of the image is 8 bits, so the value for this tag is 8. Constant length of 3. (Inherited from MDM_EXIF_MAIN.)
Compression | Gets or sets compression scheme used for the image data. When a primary image is JPEG compressed, this designation is not necessary and is omitted. When thumbnails use JPEG compression, this tag value is set to 6. (Inherited from MDM_EXIF_MAIN.)
Copyright | Gets or sets the photographer and editor copyrights. Constant length of 1-2. (Inherited from MDM_EXIF_MAIN.)
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
DateTime | Gets or sets the date and time of image creation. (Inherited from MDM_EXIF_MAIN.)
EquipmentModel | Gets or sets the model name or model number of the equipment. (Inherited from MDM_EXIF_MAIN.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
ImageDescription | Gets or sets a string giving the title of the image. (Inherited from MDM_EXIF_MAIN.)
ImageHeight | Gets or sets number of rows of image data. In JPEG compressed data a JPEG marker is used instead of this tag. (Inherited from MDM_EXIF_MAIN.)
ImageWidth | Gets or sets the number of columns of image data, equal to the number of pixels per row. In JPEG compressed data a JPEG marker is used instead of this tag. (Inherited from MDM_EXIF_MAIN.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
JPEGInterchangeFormat | Gets or sets the offset to the start byte (SOI) of JPEG compressed thumbnail data. This is not used for primary image JPEG data. (Inherited from MDM_EXIF_MAIN.)
JPEGInterchangeFormatLength | Gets or sets the number of bytes of JPEG compressed thumbnail data. (Inherited from MDM_EXIF_MAIN.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Make | Gets or sets the manufacturer of the recording equipment. (Inherited from MDM_EXIF_MAIN.)
Model | Overloaded.
Orientation | Gets or sets the image orientation viewed in terms of rows and columns. (Inherited from MDM_EXIF_MAIN.)
PhotometricInterpretation | Gets or sets pixel composition. In JPEG compressed data a JPEG marker is used instead of this tag. See remarks for further information. (Inherited from MDM_EXIF_MAIN.)
PlanarConfiguration | Gets or sets a value that indicates whether pixel components are recorded in chunky or planar format. In JPEG compressed files a JPEG marker is used instead of this tag. If this field does not exist, the TIFF default of 1 (chunky) is assumed. See remarks for further information. (Inherited from MDM_EXIF_MAIN.)
PrimaryChromaticities | Gets or sets the chromaticity of the three primary colors of the image. Constant length of 6. (Inherited from MDM_EXIF_MAIN.)
ReferenceBlackWhite | Gets or sets the reference black point value and reference white point value. Constant length of 6. (Inherited from MDM_EXIF_MAIN.)
ResolutionUnit | Gets or sets the unit for measuring XResolution and YResolution. The same unit is used for both XResolution and YResolution. If the image resolution in unknown, 2 (inches) is designated. See remarks for further information. (Inherited from MDM_EXIF_MAIN.)
RowsPerStrip | Gets or sets number of rows per strip. This is the number of rows in the image of one strip when an image is divided into strips. With JPEG compressed data this designation is not needed and is omitted. (Inherited from MDM_EXIF_MAIN.)
SamplesPerPixel | Gets or sets the number of components per pixel. Since this standard applies to RGB and YCbCr images, the value set for this tag is 3. In JPEG compressed data a JPEG marker is used instead of this tag. (Inherited from MDM_EXIF_MAIN.)
Software | Gets or sets the name and version of the software or firmware of the camera or image input device used to generate the image. (Inherited from MDM_EXIF_MAIN.)
StripByteCounts | Gets or sets the total number of bytes in each strip. With JPEG compressed data this designation is not needed and is omitted. Constant length of SamplesPerPixel * StripsPerImage. (Inherited from MDM_EXIF_MAIN.)
StripOffsets | Gets or sets the byte offset of that strip. It is recommended that this be selected so the number of strip bytes does not exceed 64 Kbytes. With JPEG compressed data this designation is not needed and is omitted. Constant length of SamplesPerPixel * StripsPerImage. (Inherited from MDM_EXIF_MAIN.)
TransferFunction | Gets or sets a transfer function for the image, described in tabular style. Constant length of 3 * 256. (Inherited from MDM_EXIF_MAIN.)
WhitePoint | Gets or sets the chromaticity of the white point of the image. Constant length of 2. (Inherited from MDM_EXIF_MAIN.)
XResolution | Gets or sets the number of pixels per ResolutionUnit in the ImageWidth direction. When the image resolution is unknown, 72 [dpi] is designated. (Inherited from MDM_EXIF_MAIN.)
YCbCrCoefficients | Gets or sets the matrix coefficients for transformation from RGB to YCbCr image data. Constant length of 3. (Inherited from MDM_EXIF_MAIN.)
YCbCrPositioning | Gets or sets position of chrominance components in relation to the luminance component. See remarks for further information. (Inherited from MDM_EXIF_MAIN.)
YCbCrSubSampling | Gets or sets the sampling ratio of chrominance components in relation to the luminance component. In JPEG compressed dat a JPEG marker is used instead of this tag. See remarks for further information. (Inherited from MDM_EXIF_MAIN.)
YResolution | Gets or sets the number of pixels per ResolutionUnit in the ImageHeight direction. When the image resolution is unknown, 72 [dpi] is designated. (Inherited from MDM_EXIF_MAIN.)

See Also

MDM_MAIN Class
FreeImageAPI.Metadata Namespace


MDM_MAIN Constructor

[image]

FreeImage .NET Documentation
MDM_MAIN Constructor
MDM_MAIN Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_MAIN(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_MAIN(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_MAIN Class
FreeImageAPI.Metadata Namespace


MDM_MAIN Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAIN Fields
MDM_MAIN Class See Also Send Feedback

The MDM_MAIN type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_MAIN Class
FreeImageAPI.Metadata Namespace


MDM_MAIN Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAIN Methods
MDM_MAIN Class See Also Send Feedback

The MDM_MAIN type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_MAIN Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAIN..::.AddTag Method
MDM_MAIN Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_MAIN Class
MDM_MAIN Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAIN..::.SetTagValue Method
MDM_MAIN Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_MAIN Class
MDM_MAIN Members
FreeImageAPI.Metadata Namespace


MDM_MAIN Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAIN Properties
MDM_MAIN Class See Also Send Feedback

The MDM_MAIN type exposes the following members.

Properties

Name | Description
Artist | Gets or sets the name of the camera owner, photographer or image creator. (Inherited from MDM_EXIF_MAIN.)
BitsPerSample | Gets or sets number of bits per image component. In this standard each component of the image is 8 bits, so the value for this tag is 8. Constant length of 3. (Inherited from MDM_EXIF_MAIN.)
Compression | Gets or sets compression scheme used for the image data. When a primary image is JPEG compressed, this designation is not necessary and is omitted. When thumbnails use JPEG compression, this tag value is set to 6. (Inherited from MDM_EXIF_MAIN.)
Copyright | Gets or sets the photographer and editor copyrights. Constant length of 1-2. (Inherited from MDM_EXIF_MAIN.)
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
DateTime | Gets or sets the date and time of image creation. (Inherited from MDM_EXIF_MAIN.)
EquipmentModel | Gets or sets the model name or model number of the equipment. (Inherited from MDM_EXIF_MAIN.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
ImageDescription | Gets or sets a string giving the title of the image. (Inherited from MDM_EXIF_MAIN.)
ImageHeight | Gets or sets number of rows of image data. In JPEG compressed data a JPEG marker is used instead of this tag. (Inherited from MDM_EXIF_MAIN.)
ImageWidth | Gets or sets the number of columns of image data, equal to the number of pixels per row. In JPEG compressed data a JPEG marker is used instead of this tag. (Inherited from MDM_EXIF_MAIN.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
JPEGInterchangeFormat | Gets or sets the offset to the start byte (SOI) of JPEG compressed thumbnail data. This is not used for primary image JPEG data. (Inherited from MDM_EXIF_MAIN.)
JPEGInterchangeFormatLength | Gets or sets the number of bytes of JPEG compressed thumbnail data. (Inherited from MDM_EXIF_MAIN.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Make | Gets or sets the manufacturer of the recording equipment. (Inherited from MDM_EXIF_MAIN.)
Model | Overloaded.
Orientation | Gets or sets the image orientation viewed in terms of rows and columns. (Inherited from MDM_EXIF_MAIN.)
PhotometricInterpretation | Gets or sets pixel composition. In JPEG compressed data a JPEG marker is used instead of this tag. See remarks for further information. (Inherited from MDM_EXIF_MAIN.)
PlanarConfiguration | Gets or sets a value that indicates whether pixel components are recorded in chunky or planar format. In JPEG compressed files a JPEG marker is used instead of this tag. If this field does not exist, the TIFF default of 1 (chunky) is assumed. See remarks for further information. (Inherited from MDM_EXIF_MAIN.)
PrimaryChromaticities | Gets or sets the chromaticity of the three primary colors of the image. Constant length of 6. (Inherited from MDM_EXIF_MAIN.)
ReferenceBlackWhite | Gets or sets the reference black point value and reference white point value. Constant length of 6. (Inherited from MDM_EXIF_MAIN.)
ResolutionUnit | Gets or sets the unit for measuring XResolution and YResolution. The same unit is used for both XResolution and YResolution. If the image resolution in unknown, 2 (inches) is designated. See remarks for further information. (Inherited from MDM_EXIF_MAIN.)
RowsPerStrip | Gets or sets number of rows per strip. This is the number of rows in the image of one strip when an image is divided into strips. With JPEG compressed data this designation is not needed and is omitted. (Inherited from MDM_EXIF_MAIN.)
SamplesPerPixel | Gets or sets the number of components per pixel. Since this standard applies to RGB and YCbCr images, the value set for this tag is 3. In JPEG compressed data a JPEG marker is used instead of this tag. (Inherited from MDM_EXIF_MAIN.)
Software | Gets or sets the name and version of the software or firmware of the camera or image input device used to generate the image. (Inherited from MDM_EXIF_MAIN.)
StripByteCounts | Gets or sets the total number of bytes in each strip. With JPEG compressed data this designation is not needed and is omitted. Constant length of SamplesPerPixel * StripsPerImage. (Inherited from MDM_EXIF_MAIN.)
StripOffsets | Gets or sets the byte offset of that strip. It is recommended that this be selected so the number of strip bytes does not exceed 64 Kbytes. With JPEG compressed data this designation is not needed and is omitted. Constant length of SamplesPerPixel * StripsPerImage. (Inherited from MDM_EXIF_MAIN.)
TransferFunction | Gets or sets a transfer function for the image, described in tabular style. Constant length of 3 * 256. (Inherited from MDM_EXIF_MAIN.)
WhitePoint | Gets or sets the chromaticity of the white point of the image. Constant length of 2. (Inherited from MDM_EXIF_MAIN.)
XResolution | Gets or sets the number of pixels per ResolutionUnit in the ImageWidth direction. When the image resolution is unknown, 72 [dpi] is designated. (Inherited from MDM_EXIF_MAIN.)
YCbCrCoefficients | Gets or sets the matrix coefficients for transformation from RGB to YCbCr image data. Constant length of 3. (Inherited from MDM_EXIF_MAIN.)
YCbCrPositioning | Gets or sets position of chrominance components in relation to the luminance component. See remarks for further information. (Inherited from MDM_EXIF_MAIN.)
YCbCrSubSampling | Gets or sets the sampling ratio of chrominance components in relation to the luminance component. In JPEG compressed dat a JPEG marker is used instead of this tag. See remarks for further information. (Inherited from MDM_EXIF_MAIN.)
YResolution | Gets or sets the number of pixels per ResolutionUnit in the ImageHeight direction. When the image resolution is unknown, 72 [dpi] is designated. (Inherited from MDM_EXIF_MAIN.)

See Also

MDM_MAIN Class
FreeImageAPI.Metadata Namespace


Model Property

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAIN..::.Model Property
MDM_MAIN Class See Also Send Feedback

Overload List

Name | Description
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
Model | Retrieves the datamodel that this instance represents. (Inherited from MDM_EXIF_MAIN.)

See Also

MDM_MAIN Class
MDM_MAIN Members
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_MAIN..::.Model Property
MDM_MAIN Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.11.0

See Also

MDM_MAIN Class
Model Overload
FreeImageAPI.Metadata Namespace


MDM_MAKERNOTE Class

[image]

FreeImage .NET Documentation
MDM_MAKERNOTE Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_EXIF_MAKERNOTE.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MDM_MAKERNOTE : MetadataModel
Visual Basic (Declaration)
Public NotInheritable Class MDM_MAKERNOTE _
    Inherits MetadataModel
Visual C++
public ref class MDM_MAKERNOTE sealed : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_MAKERNOTE

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_MAKERNOTE Members
FreeImageAPI.Metadata Namespace


MDM_MAKERNOTE Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAKERNOTE Members
MDM_MAKERNOTE Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_MAKERNOTE type exposes the following members.

Constructors

Name | Description
MDM_MAKERNOTE | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)

See Also

MDM_MAKERNOTE Class
FreeImageAPI.Metadata Namespace


MDM_MAKERNOTE Constructor

[image]

FreeImage .NET Documentation
MDM_MAKERNOTE Constructor
MDM_MAKERNOTE Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_MAKERNOTE(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_MAKERNOTE(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_MAKERNOTE Class
FreeImageAPI.Metadata Namespace


MDM_MAKERNOTE Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAKERNOTE Fields
MDM_MAKERNOTE Class See Also Send Feedback

The MDM_MAKERNOTE type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_MAKERNOTE Class
FreeImageAPI.Metadata Namespace


MDM_MAKERNOTE Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAKERNOTE Methods
MDM_MAKERNOTE Class See Also Send Feedback

The MDM_MAKERNOTE type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_MAKERNOTE Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAKERNOTE..::.AddTag Method
MDM_MAKERNOTE Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_MAKERNOTE Class
MDM_MAKERNOTE Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAKERNOTE..::.SetTagValue Method
MDM_MAKERNOTE Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_MAKERNOTE Class
MDM_MAKERNOTE Members
FreeImageAPI.Metadata Namespace


MDM_MAKERNOTE Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_MAKERNOTE Properties
MDM_MAKERNOTE Class See Also Send Feedback

The MDM_MAKERNOTE type exposes the following members.

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)

See Also

MDM_MAKERNOTE Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_MAKERNOTE..::.Model Property
MDM_MAKERNOTE Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_MAKERNOTE Class
FreeImageAPI.Metadata Namespace


MDM_NODATA Class

[image]

FreeImage .NET Documentation
MDM_NODATA Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_NODATA.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MDM_NODATA : MetadataModel
Visual Basic (Declaration)
Public NotInheritable Class MDM_NODATA _
    Inherits MetadataModel
Visual C++
public ref class MDM_NODATA sealed : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_NODATA

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_NODATA Members
FreeImageAPI.Metadata Namespace


MDM_NODATA Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_NODATA Members
MDM_NODATA Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_NODATA type exposes the following members.

Constructors

Name | Description
MDM_NODATA | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)

See Also

MDM_NODATA Class
FreeImageAPI.Metadata Namespace


MDM_NODATA Constructor

[image]

FreeImage .NET Documentation
MDM_NODATA Constructor
MDM_NODATA Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_NODATA(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_NODATA(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_NODATA Class
FreeImageAPI.Metadata Namespace


MDM_NODATA Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_NODATA Fields
MDM_NODATA Class See Also Send Feedback

The MDM_NODATA type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_NODATA Class
FreeImageAPI.Metadata Namespace


MDM_NODATA Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_NODATA Methods
MDM_NODATA Class See Also Send Feedback

The MDM_NODATA type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_NODATA Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_NODATA..::.AddTag Method
MDM_NODATA Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_NODATA Class
MDM_NODATA Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_NODATA..::.SetTagValue Method
MDM_NODATA Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_NODATA Class
MDM_NODATA Members
FreeImageAPI.Metadata Namespace


MDM_NODATA Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_NODATA Properties
MDM_NODATA Class See Also Send Feedback

The MDM_NODATA type exposes the following members.

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)

See Also

MDM_NODATA Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_NODATA..::.Model Property
MDM_NODATA Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_NODATA Class
FreeImageAPI.Metadata Namespace


MDM_XMP Class

[image]

FreeImage .NET Documentation
MDM_XMP Class
Members See Also Send Feedback
Represents a collection of all tags contained in the metadata model FIMD_XMP.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MDM_XMP : MetadataModel
Visual Basic (Declaration)
Public NotInheritable Class MDM_XMP _
    Inherits MetadataModel
Visual C++
public ref class MDM_XMP sealed : public MetadataModel

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_XMP

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_XMP Members
FreeImageAPI.Metadata Namespace


MDM_XMP Members

[image] [image] [image]

FreeImage .NET Documentation
MDM_XMP Members
MDM_XMP Class Constructors Methods Fields Properties See Also Send Feedback

The MDM_XMP type exposes the following members.

Constructors

Name | Description
MDM_XMP | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
Xml | Gets or sets the XMP XML content.
XmlReader | Gets an XmlReader initialized to read the XMP XML content. Returns null, if the metadata tag XMLPacket is not present in this model.

See Also

MDM_XMP Class
FreeImageAPI.Metadata Namespace


MDM_XMP Constructor

[image]

FreeImage .NET Documentation
MDM_XMP Constructor
MDM_XMP Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MDM_XMP(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    dib As FIBITMAP _
)
Visual C++
public:
MDM_XMP(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_XMP Class
FreeImageAPI.Metadata Namespace


MDM_XMP Fields

[image] [image] [image]

FreeImage .NET Documentation
MDM_XMP Fields
MDM_XMP Class See Also Send Feedback

The MDM_XMP type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap. (Inherited from MetadataModel.)

See Also

MDM_XMP Class
FreeImageAPI.Metadata Namespace


MDM_XMP Methods

[image] [image] [image]

FreeImage .NET Documentation
MDM_XMP Methods
MDM_XMP Class See Also Send Feedback

The MDM_XMP type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap. (Inherited from MetadataModel.)
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel. (Inherited from MetadataModel.)
GetTag | Returns the specified metadata tag. (Inherited from MetadataModel.)
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag. (Inherited from MetadataModel.)
GetTagFromIndex | Returns the tag at the given index. (Inherited from MetadataModel.)
GetTagText | Returns the string contained by the specified tag. (Inherited from MetadataModel.)
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag. (Inherited from MetadataModel.)
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer. (Inherited from MetadataModel.)
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer. (Inherited from MetadataModel.)
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list. (Inherited from MetadataModel.)
RemoveTag | Removes the specified tag from the bitmap. (Inherited from MetadataModel.)
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined. (Inherited from MetadataModel.)
TagExists | Returns whether the specified tag exists. (Inherited from MetadataModel.)
ToString | Converts the model of the MetadataModel object to its equivalent string representation. (Inherited from MetadataModel.)

See Also

MDM_XMP Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_XMP..::.AddTag Method
MDM_XMP Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key. (Inherited from MetadataModel.)
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key. (Inherited from MetadataModel.)

See Also

MDM_XMP Class
MDM_XMP Members
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MDM_XMP..::.SetTagValue Method
MDM_XMP Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag. (Inherited from MetadataModel.)
SetTagValue(String, Object) | Sets the value of the specified tag. (Inherited from MetadataModel.)

See Also

MDM_XMP Class
MDM_XMP Members
FreeImageAPI.Metadata Namespace


MDM_XMP Properties

[image] [image] [image]

FreeImage .NET Documentation
MDM_XMP Properties
MDM_XMP Class See Also Send Feedback

The MDM_XMP type exposes the following members.

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents. (Inherited from MetadataModel.)
Exists | Returns whether this model exists in the bitmaps metadata structure. (Inherited from MetadataModel.)
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags. (Inherited from MetadataModel.)
List | Returns a list of all metadata tags this instance represents. (Inherited from MetadataModel.)
Model | Retrieves the datamodel that this instance represents. (Overrides MetadataModel..::.Model.)
Xml | Gets or sets the XMP XML content.
XmlReader | Gets an XmlReader initialized to read the XMP XML content. Returns null, if the metadata tag XMLPacket is not present in this model.

See Also

MDM_XMP Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MDM_XMP..::.Model Property
MDM_XMP Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () override;
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MDM_XMP Class
FreeImageAPI.Metadata Namespace


Xml Property

[image]

FreeImage .NET Documentation
MDM_XMP..::.Xml Property
MDM_XMP Class See Also Send Feedback
Gets or sets the XMP XML content.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Xml { get; set; }
Visual Basic (Declaration)
Public Property Xml As String
Visual C++
public:
property String^ Xml {
    String^ get ();
    void set (String^ value);
}

Remarks

Handling of null values

A null value indicates, that the corresponding metadata tag is not present in the metadata model. Setting this property's value to a non-null reference creates the metadata tag if necessary. Setting this property's value to a null reference deletes the metadata tag from the metadata model.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_XMP Class
FreeImageAPI.Metadata Namespace


XmlReader Property

[image]

FreeImage .NET Documentation
MDM_XMP..::.XmlReader Property
MDM_XMP Class See Also Send Feedback
Gets an XmlReader initialized to read the XMP XML content. Returns null, if the metadata tag XMLPacket is not present in this model.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public XmlReader XmlReader { get; }
Visual Basic (Declaration)
Public ReadOnly Property XmlReader As XmlReader
Visual C++
public:
property XmlReader^ XmlReader {
    XmlReader^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MDM_XMP Class
FreeImageAPI.Metadata Namespace


MetadataModel Class

[image]

FreeImage .NET Documentation
MetadataModel Class
Members See Also Send Feedback
Base class that represents a collection of all tags contained in a metadata model.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public abstract class MetadataModel : IEnumerable
Visual Basic (Declaration)
Public MustInherit Class MetadataModel _
    Implements IEnumerable
Visual C++
public ref class MetadataModel abstract : IEnumerable

Remarks

The MetedataModel class is an abstract base class, which is inherited by several derived classes, one for each existing metadata model.

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataModel
FreeImageAPI.Metadata..::.MDM_ANIMATION
FreeImageAPI.Metadata..::.MDM_COMMENTS
FreeImageAPI.Metadata..::.MDM_CUSTOM
FreeImageAPI.Metadata..::.MDM_EXIF_EXIF
FreeImageAPI.Metadata..::.MDM_EXIF_GPS
FreeImageAPI.Metadata..::.MDM_GEOTIFF
FreeImageAPI.Metadata..::.MDM_INTEROP
FreeImageAPI.Metadata..::.MDM_IPTC
FreeImageAPI.Metadata..::.MDM_MAIN
FreeImageAPI.Metadata..::.MDM_MAKERNOTE
FreeImageAPI.Metadata..::.MDM_NODATA
FreeImageAPI.Metadata..::.MDM_XMP

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Members
FreeImageAPI.Metadata Namespace


MetadataModel Members

[image] [image] [image]

FreeImage .NET Documentation
MetadataModel Members
MetadataModel Class Constructors Methods Fields Properties See Also Send Feedback

The MetadataModel type exposes the following members.

Constructors

Name | Description
MetadataModel | Initializes a new instance of this class.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap.
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel.
GetTag | Returns the specified metadata tag.
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag.
GetTagFromIndex | Returns the tag at the given index.
GetTagText | Returns the string contained by the specified tag.
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag.
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer.
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer.
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list.
RemoveTag | Removes the specified tag from the bitmap.
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined.
TagExists | Returns whether the specified tag exists.
ToDirectionType | Returns the equivalent MetadataModel..::.DirectionReference for the specified String.
ToInteroperabilityType | Returns the equivalent MetadataModel..::.InteroperabilityMode for the specified String.
ToLatitudeType | Returns the equivalent MetadataModel..::.LatitudeType for the specified String.
ToLongitudeType | Returns the equivalent MetadataModel..::.LongitudeType for the specified String.
ToString | Overloaded.
ToUnitType | Returns the equivalent MetadataModel..::.VelocityUnit for the specified String.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap.

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents.
Exists | Returns whether this model exists in the bitmaps metadata structure.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags.
List | Returns a list of all metadata tags this instance represents.
Model | Retrieves the datamodel that this instance represents.

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


MetadataModel Constructor

[image]

FreeImage .NET Documentation
MetadataModel Constructor
MetadataModel Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected MetadataModel(
    FIBITMAP dib
)
Visual Basic (Declaration)
Protected Sub New ( _
    dib As FIBITMAP _
)
Visual C++
protected:
MetadataModel(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Exceptions

Exception | Condition
System..::.ArgumentNullException | dib is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


MetadataModel Fields

[image] [image] [image]

FreeImage .NET Documentation
MetadataModel Fields
MetadataModel Class See Also Send Feedback

The MetadataModel type exposes the following members.

Fields

Name | Description
dib | Handle to the encapsulated FreeImage-bitmap.

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


dib Field

[image]

FreeImage .NET Documentation
MetadataModel..::.dib Field
MetadataModel Class See Also Send Feedback
Handle to the encapsulated FreeImage-bitmap.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected readonly FIBITMAP dib
Visual Basic (Declaration)
Protected ReadOnly dib As FIBITMAP
Visual C++
protected:
initonly FIBITMAP dib

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


MetadataModel Methods

[image] [image] [image]

FreeImage .NET Documentation
MetadataModel Methods
MetadataModel Class See Also Send Feedback

The MetadataModel type exposes the following members.

Methods

Name | Description
AddTag | Overloaded.
DestoryModel | Destroys the metadata model which will remove all tags of this model from the bitmap.
GetEnumerator | Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel.
GetTag | Returns the specified metadata tag.
GetTagArray<(Of <(T>)>) | Returns an array containing the data of the specified tag.
GetTagFromIndex | Returns the tag at the given index.
GetTagText | Returns the string contained by the specified tag.
GetTagValue<(Of <(T>)>) | Returns the value of the specified tag.
GetUInt32Array | Returns an array containg the data of the specified tag as unsigned 32bit integer.
GetUInt32Value | Returns the value of the tag as unsigned 32bit integer.
RegexSearch | Searches for a pattern in each metadata tag and returns the result as a list.
RemoveTag | Removes the specified tag from the bitmap.
SetTagValue | Overloaded.
SetTagValueUndefined | Sets the value of the specified tag as undefined.
TagExists | Returns whether the specified tag exists.
ToDirectionType | Returns the equivalent MetadataModel..::.DirectionReference for the specified String.
ToInteroperabilityType | Returns the equivalent MetadataModel..::.InteroperabilityMode for the specified String.
ToLatitudeType | Returns the equivalent MetadataModel..::.LatitudeType for the specified String.
ToLongitudeType | Returns the equivalent MetadataModel..::.LongitudeType for the specified String.
ToString | Overloaded.
ToUnitType | Returns the equivalent MetadataModel..::.VelocityUnit for the specified String.

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


AddTag Method

[image] [image] [image]

FreeImage .NET Documentation
MetadataModel..::.AddTag Method
MetadataModel Class See Also Send Feedback

Overload List

Name | Description
AddTag(MetadataTag) | Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key.
AddTag(IEnumerable<(Of <(MetadataTag>)>)) | Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key.

See Also

MetadataModel Class
MetadataModel Members
FreeImageAPI.Metadata Namespace


AddTag Method (MetadataTag)

[image]

FreeImage .NET Documentation
MetadataModel..::.AddTag Method (MetadataTag)
MetadataModel Class See Also Send Feedback
Adds new tag to the bitmap or updates its value in case it already exists. Key will be used as key.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool AddTag(
    MetadataTag tag
)
Visual Basic (Declaration)
Public Function AddTag ( _
    tag As MetadataTag _
) As Boolean
Visual C++
public:
bool AddTag(
    MetadataTag^ tag
)

Parameters

tag
Type: FreeImageAPI.Metadata..::.MetadataTag
The tag to add or update.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | tag is null.
System..::.ArgumentException | The tags model differs from this instances model.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
AddTag Overload
FreeImageAPI.Metadata Namespace


AddTag Method (IEnumerable(MetadataTag))

[image]

FreeImage .NET Documentation
MetadataModel..::.AddTag Method (IEnumerable<(Of <(MetadataTag>)>))
MetadataModel Class See Also Send Feedback
Adds a list of tags to the bitmap or updates their values in case they already exist. Key will be used as key.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int AddTag(
    IEnumerable<MetadataTag> list
)
Visual Basic (Declaration)
Public Function AddTag ( _
    list As IEnumerable(Of MetadataTag) _
) As Integer
Visual C++
public:
int AddTag(
    IEnumerable<MetadataTag^>^ list
)

Parameters

list
Type: System.Collections.Generic..::.IEnumerable <(Of <( MetadataTag >)>)
A list of tags to add or update.

Return Value

Returns the number of successfully added tags.

Exceptions

Exception | Condition
System..::.ArgumentNullException | list is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
AddTag Overload
FreeImageAPI.Metadata Namespace


DestoryModel Method

[image]

FreeImage .NET Documentation
MetadataModel..::.DestoryModel Method
MetadataModel Class See Also Send Feedback
Destroys the metadata model which will remove all tags of this model from the bitmap.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool DestoryModel()
Visual Basic (Declaration)
Public Function DestoryModel As Boolean
Visual C++
public:
bool DestoryModel()

Return Value

Returns true on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


GetEnumerator Method

[image]

FreeImage .NET Documentation
MetadataModel..::.GetEnumerator Method
MetadataModel Class See Also Send Feedback
Retrieves an object that can iterate through the individual MetadataTags in this MetadataModel.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

An IEnumerator for the MetadataModel.

Implements

IEnumerable..::.GetEnumerator()()()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


GetTag Method

[image]

FreeImage .NET Documentation
MetadataModel..::.GetTag Method
MetadataModel Class See Also Send Feedback
Returns the specified metadata tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MetadataTag GetTag(
    string key
)
Visual Basic (Declaration)
Public Function GetTag ( _
    key As String _
) As MetadataTag
Visual C++
public:
MetadataTag^ GetTag(
    String^ key
)

Parameters

key
Type: System..::.String
The key of the tag.

Return Value

The metadata tag.

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


GetTagArray(T) Method

[image]

FreeImage .NET Documentation
MetadataModel..::.GetTagArray<(Of <(T>)>) Method
MetadataModel Class See Also Send Feedback
Returns an array containing the data of the specified tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected T[] GetTagArray<T>(
    string key
)
where T : struct, new()
Visual Basic (Declaration)
Protected Function GetTagArray(Of T As {Structure, New}) ( _
    key As String _
) As T()
Visual C++
protected:
generic<typename T>
where T : value class, gcnew()
array<T>^ GetTagArray(
    String^ key
)

Parameters

key
Type: System..::.String
The key of the tag.

Type Parameters

T
The type of the tag's data.

Return Value

An array containing the data of the specified tag.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


GetTagFromIndex Method

[image]

FreeImage .NET Documentation
MetadataModel..::.GetTagFromIndex Method
MetadataModel Class See Also Send Feedback
Returns the tag at the given index.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected MetadataTag GetTagFromIndex(
    int index
)
Visual Basic (Declaration)
Protected Function GetTagFromIndex ( _
    index As Integer _
) As MetadataTag
Visual C++
protected:
MetadataTag^ GetTagFromIndex(
    int index
)

Parameters

index
Type: System..::.Int32
Index of the tag to return.

Return Value

The tag at the given index.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


GetTagText Method

[image]

FreeImage .NET Documentation
MetadataModel..::.GetTagText Method
MetadataModel Class See Also Send Feedback
Returns the string contained by the specified tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected string GetTagText(
    string key
)
Visual Basic (Declaration)
Protected Function GetTagText ( _
    key As String _
) As String
Visual C++
protected:
String^ GetTagText(
    String^ key
)

Parameters

key
Type: System..::.String
The key of the tag.

Return Value

The string contained by the specified tag.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


GetTagValue(T) Method

[image]

FreeImage .NET Documentation
MetadataModel..::.GetTagValue<(Of <(T>)>) Method
MetadataModel Class See Also Send Feedback
Returns the value of the specified tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected Nullable<T> GetTagValue<T>(
    string key
)
where T : struct, new()
Visual Basic (Declaration)
Protected Function GetTagValue(Of T As {Structure, New}) ( _
    key As String _
) As Nullable(Of T)
Visual C++
protected:
generic<typename T>
where T : value class, gcnew()
Nullable<T> GetTagValue(
    String^ key
)

Parameters

key
Type: System..::.String
The key of the tag.

Type Parameters

T
Type of the tag's data.

Return Value

The value of the specified tag.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


GetUInt32Array Method

[image]

FreeImage .NET Documentation
MetadataModel..::.GetUInt32Array Method
MetadataModel Class See Also Send Feedback
Returns an array containg the data of the specified tag as unsigned 32bit integer.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected uint[] GetUInt32Array(
    string key
)
Visual Basic (Declaration)
Protected Function GetUInt32Array ( _
    key As String _
) As UInteger()
Visual C++
protected:
array<unsigned int>^ GetUInt32Array(
    String^ key
)

Parameters

key
Type: System..::.String
The key of the tag.

Return Value

An array containg the data of the specified tag as unsigned 32bit integer.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


GetUInt32Value Method

[image]

FreeImage .NET Documentation
MetadataModel..::.GetUInt32Value Method
MetadataModel Class See Also Send Feedback
Returns the value of the tag as unsigned 32bit integer.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected Nullable<uint> GetUInt32Value(
    string key
)
Visual Basic (Declaration)
Protected Function GetUInt32Value ( _
    key As String _
) As Nullable(Of UInteger)
Visual C++
protected:
Nullable<unsigned int> GetUInt32Value(
    String^ key
)

Parameters

key
Type: System..::.String
The key of the tag.

Return Value

The value of the tag as unsigned 32bit integer.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


RegexSearch Method

[image]

FreeImage .NET Documentation
MetadataModel..::.RegexSearch Method
MetadataModel Class See Also Send Feedback
Searches for a pattern in each metadata tag and returns the result as a list.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public List<MetadataTag> RegexSearch(
    string searchPattern,
    MD_SEARCH_FLAGS flags
)
Visual Basic (Declaration)
Public Function RegexSearch ( _
    searchPattern As String, _
    flags As MD_SEARCH_FLAGS _
) As List(Of MetadataTag)
Visual C++
public:
List<MetadataTag^>^ RegexSearch(
    String^ searchPattern,
    MD_SEARCH_FLAGS flags
)

Parameters

searchPattern
Type: System..::.String
The regular expression to use for the search.
flags
Type: FreeImageAPI..::.MD_SEARCH_FLAGS
A bitfield that controls which fields should be searched in.

Return Value

A list containing all found metadata tags.

Exceptions

Exception | Condition
System..::.ArgumentNullException | searchPattern is null.
System..::.ArgumentException | searchPattern is empty.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


RemoveTag Method

[image]

FreeImage .NET Documentation
MetadataModel..::.RemoveTag Method
MetadataModel Class See Also Send Feedback
Removes the specified tag from the bitmap.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool RemoveTag(
    string key
)
Visual Basic (Declaration)
Public Function RemoveTag ( _
    key As String _
) As Boolean
Visual C++
public:
bool RemoveTag(
    String^ key
)

Parameters

key
Type: System..::.String
The key of the tag.

Return Value

Returns true on success, false on failure.

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


SetTagValue Method

[image] [image] [image]

FreeImage .NET Documentation
MetadataModel..::.SetTagValue Method
MetadataModel Class See Also Send Feedback

Overload List

Name | Description
SetTagValue<(Of <(T>)>)(String, Nullable<(Of <(T>)>)) | Sets the value of the specified tag.
SetTagValue(String, Object) | Sets the value of the specified tag.

See Also

MetadataModel Class
MetadataModel Members
FreeImageAPI.Metadata Namespace


SetTagValue(T) Method (String, Nullable(T))

[image]

FreeImage .NET Documentation
MetadataModel..::.SetTagValue<(Of <(T>)>) Method (String, Nullable<(Of <(T>)>))
MetadataModel Class See Also Send Feedback
Sets the value of the specified tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected void SetTagValue<T>(
    string key,
    Nullable<T> value
)
where T : struct, new()
Visual Basic (Declaration)
Protected Sub SetTagValue(Of T As {Structure, New}) ( _
    key As String, _
    value As Nullable(Of T) _
)
Visual C++
protected:
generic<typename T>
where T : value class, gcnew()
void SetTagValue(
    String^ key,
    Nullable<T> value
)

Parameters

key
Type: System..::.String
The key of the tag.
value
Type: System..::.Nullable <(Of <(T>)>)
The new value of the specified tag or null.

Type Parameters

T
The type of the tag's data.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
SetTagValue Overload
FreeImageAPI.Metadata Namespace


SetTagValue Method (String, Object)

[image]

FreeImage .NET Documentation
MetadataModel..::.SetTagValue Method (String, Object)
MetadataModel Class See Also Send Feedback
Sets the value of the specified tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected void SetTagValue(
    string key,
    Object value
)
Visual Basic (Declaration)
Protected Sub SetTagValue ( _
    key As String, _
    value As Object _
)
Visual C++
protected:
void SetTagValue(
    String^ key,
    Object^ value
)

Parameters

key
Type: System..::.String
The key of the tag.
value
Type: System..::.Object
The new value of the specified tag or null.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
SetTagValue Overload
FreeImageAPI.Metadata Namespace


SetTagValueUndefined Method

[image]

FreeImage .NET Documentation
MetadataModel..::.SetTagValueUndefined Method
MetadataModel Class See Also Send Feedback
Sets the value of the specified tag as undefined.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected void SetTagValueUndefined(
    string key,
    byte[] value
)
Visual Basic (Declaration)
Protected Sub SetTagValueUndefined ( _
    key As String, _
    value As Byte() _
)
Visual C++
protected:
void SetTagValueUndefined(
    String^ key,
    array<unsigned char>^ value
)

Parameters

key
Type: System..::.String
The key of the tag.
value
Type: array< System..::.Byte >[]()[]
The new value of the specified tag or null.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


TagExists Method

[image]

FreeImage .NET Documentation
MetadataModel..::.TagExists Method
MetadataModel Class See Also Send Feedback
Returns whether the specified tag exists.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool TagExists(
    string key
)
Visual Basic (Declaration)
Public Function TagExists ( _
    key As String _
) As Boolean
Visual C++
public:
bool TagExists(
    String^ key
)

Parameters

key
Type: System..::.String
The key of the tag.

Return Value

True in case the tag exists, else false.

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


ToDirectionType Method

[image]

FreeImage .NET Documentation
MetadataModel..::.ToDirectionType Method
MetadataModel Class See Also Send Feedback
Returns the equivalent MetadataModel..::.DirectionReference for the specified String.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected static Nullable<MetadataModel..::.DirectionReference> ToDirectionType(
    string s
)
Visual Basic (Declaration)
Protected Shared Function ToDirectionType ( _
    s As String _
) As Nullable(Of MetadataModel..::.DirectionReference)
Visual C++
protected:
static Nullable<MetadataModel..::.DirectionReference> ToDirectionType(
    String^ s
)

Parameters

s
Type: System..::.String
The string containing the MetadataModel..::.DirectionReference.

Return Value

The equivalent MetadataModel..::.DirectionReference for the specified String.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


ToInteroperabilityType Method

[image]

FreeImage .NET Documentation
MetadataModel..::.ToInteroperabilityType Method
MetadataModel Class See Also Send Feedback
Returns the equivalent MetadataModel..::.InteroperabilityMode for the specified String.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected static Nullable<MetadataModel..::.InteroperabilityMode> ToInteroperabilityType(
    string s
)
Visual Basic (Declaration)
Protected Shared Function ToInteroperabilityType ( _
    s As String _
) As Nullable(Of MetadataModel..::.InteroperabilityMode)
Visual C++
protected:
static Nullable<MetadataModel..::.InteroperabilityMode> ToInteroperabilityType(
    String^ s
)

Parameters

s
Type: System..::.String
The string containing the MetadataModel..::.InteroperabilityMode.

Return Value

The equivalent MetadataModel..::.InteroperabilityMode for the specified String.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


ToLatitudeType Method

[image]

FreeImage .NET Documentation
MetadataModel..::.ToLatitudeType Method
MetadataModel Class See Also Send Feedback
Returns the equivalent MetadataModel..::.LatitudeType for the specified String.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected static Nullable<MetadataModel..::.LatitudeType> ToLatitudeType(
    string s
)
Visual Basic (Declaration)
Protected Shared Function ToLatitudeType ( _
    s As String _
) As Nullable(Of MetadataModel..::.LatitudeType)
Visual C++
protected:
static Nullable<MetadataModel..::.LatitudeType> ToLatitudeType(
    String^ s
)

Parameters

s
Type: System..::.String
The string containing the MetadataModel..::.LatitudeType.

Return Value

The equivalent MetadataModel..::.LatitudeType for the specified String.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


ToLongitudeType Method

[image]

FreeImage .NET Documentation
MetadataModel..::.ToLongitudeType Method
MetadataModel Class See Also Send Feedback
Returns the equivalent MetadataModel..::.LongitudeType for the specified String.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected static Nullable<MetadataModel..::.LongitudeType> ToLongitudeType(
    string s
)
Visual Basic (Declaration)
Protected Shared Function ToLongitudeType ( _
    s As String _
) As Nullable(Of MetadataModel..::.LongitudeType)
Visual C++
protected:
static Nullable<MetadataModel..::.LongitudeType> ToLongitudeType(
    String^ s
)

Parameters

s
Type: System..::.String
The string containing the MetadataModel..::.LongitudeType.

Return Value

The equivalent MetadataModel..::.LongitudeType for the specified String.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


ToString Method

[image] [image] [image]

FreeImage .NET Documentation
MetadataModel..::.ToString Method
MetadataModel Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Converts the model of the MetadataModel object to its equivalent string representation. (Overrides Object..::.ToString()()().)
ToString(Nullable<(Of <(MetadataModel..::.DirectionReference>)>)) | Returns the equivalent String for the specified MetadataModel..::.DirectionReference.
ToString(Nullable<(Of <(MetadataModel..::.InteroperabilityMode>)>)) | Returns the equivalent String for the specified MetadataModel..::.InteroperabilityMode.
ToString(Nullable<(Of <(MetadataModel..::.LatitudeType>)>)) | Returns the equivalent String for the specified MetadataModel..::.LatitudeType.
ToString(Nullable<(Of <(MetadataModel..::.LongitudeType>)>)) | Returns the equivalent String for the specified MetadataModel..::.LongitudeType.
ToString(Nullable<(Of <(MetadataModel..::.VelocityUnit>)>)) | Returns the equivalent String for the specified MetadataModel..::.VelocityUnit.

See Also

MetadataModel Class
MetadataModel Members
FreeImageAPI.Metadata Namespace


ToString Method

[image]

FreeImage .NET Documentation
MetadataModel..::.ToString Method
MetadataModel Class See Also Send Feedback
Converts the model of the MetadataModel object to its equivalent string representation.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
ToString Overload
FreeImageAPI.Metadata Namespace


ToString Method (Nullable(MetadataModel.DirectionReference))

[image]

FreeImage .NET Documentation
MetadataModel..::.ToString Method (Nullable<(Of <(MetadataModel..::.DirectionReference>)>))
MetadataModel Class See Also Send Feedback
Returns the equivalent String for the specified MetadataModel..::.DirectionReference.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected static string ToString(
    Nullable<MetadataModel..::.DirectionReference> type
)
Visual Basic (Declaration)
Protected Shared Function ToString ( _
    type As Nullable(Of MetadataModel..::.DirectionReference) _
) As String
Visual C++
protected:
static String^ ToString(
    Nullable<MetadataModel..::.DirectionReference> type
)

Parameters

type
Type: System..::.Nullable <(Of <( MetadataModel..::.DirectionReference >)>)
The MetadataModel..::.DirectionReference to convert.

Return Value

The equivalent String for the specified MetadataModel..::.DirectionReference.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
ToString Overload
FreeImageAPI.Metadata Namespace


ToString Method (Nullable(MetadataModel.InteroperabilityMode))

[image]

FreeImage .NET Documentation
MetadataModel..::.ToString Method (Nullable<(Of <(MetadataModel..::.InteroperabilityMode>)>))
MetadataModel Class See Also Send Feedback
Returns the equivalent String for the specified MetadataModel..::.InteroperabilityMode.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected static string ToString(
    Nullable<MetadataModel..::.InteroperabilityMode> type
)
Visual Basic (Declaration)
Protected Shared Function ToString ( _
    type As Nullable(Of MetadataModel..::.InteroperabilityMode) _
) As String
Visual C++
protected:
static String^ ToString(
    Nullable<MetadataModel..::.InteroperabilityMode> type
)

Parameters

type
Type: System..::.Nullable <(Of <( MetadataModel..::.InteroperabilityMode >)>)
The MetadataModel..::.InteroperabilityMode to convert.

Return Value

The equivalent String for the specified MetadataModel..::.InteroperabilityMode.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
ToString Overload
FreeImageAPI.Metadata Namespace


ToString Method (Nullable(MetadataModel.LatitudeType))

[image]

FreeImage .NET Documentation
MetadataModel..::.ToString Method (Nullable<(Of <(MetadataModel..::.LatitudeType>)>))
MetadataModel Class See Also Send Feedback
Returns the equivalent String for the specified MetadataModel..::.LatitudeType.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected static string ToString(
    Nullable<MetadataModel..::.LatitudeType> type
)
Visual Basic (Declaration)
Protected Shared Function ToString ( _
    type As Nullable(Of MetadataModel..::.LatitudeType) _
) As String
Visual C++
protected:
static String^ ToString(
    Nullable<MetadataModel..::.LatitudeType> type
)

Parameters

type
Type: System..::.Nullable <(Of <( MetadataModel..::.LatitudeType >)>)
The MetadataModel..::.LatitudeType to convert.

Return Value

The equivalent String for the specified MetadataModel..::.LatitudeType.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
ToString Overload
FreeImageAPI.Metadata Namespace


ToString Method (Nullable(MetadataModel.LongitudeType))

[image]

FreeImage .NET Documentation
MetadataModel..::.ToString Method (Nullable<(Of <(MetadataModel..::.LongitudeType>)>))
MetadataModel Class See Also Send Feedback
Returns the equivalent String for the specified MetadataModel..::.LongitudeType.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected static string ToString(
    Nullable<MetadataModel..::.LongitudeType> type
)
Visual Basic (Declaration)
Protected Shared Function ToString ( _
    type As Nullable(Of MetadataModel..::.LongitudeType) _
) As String
Visual C++
protected:
static String^ ToString(
    Nullable<MetadataModel..::.LongitudeType> type
)

Parameters

type
Type: System..::.Nullable <(Of <( MetadataModel..::.LongitudeType >)>)
The MetadataModel..::.LongitudeType to convert.

Return Value

The equivalent String for the specified MetadataModel..::.LongitudeType.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
ToString Overload
FreeImageAPI.Metadata Namespace


ToString Method (Nullable(MetadataModel.VelocityUnit))

[image]

FreeImage .NET Documentation
MetadataModel..::.ToString Method (Nullable<(Of <(MetadataModel..::.VelocityUnit>)>))
MetadataModel Class See Also Send Feedback
Returns the equivalent String for the specified MetadataModel..::.VelocityUnit.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected static string ToString(
    Nullable<MetadataModel..::.VelocityUnit> type
)
Visual Basic (Declaration)
Protected Shared Function ToString ( _
    type As Nullable(Of MetadataModel..::.VelocityUnit) _
) As String
Visual C++
protected:
static String^ ToString(
    Nullable<MetadataModel..::.VelocityUnit> type
)

Parameters

type
Type: System..::.Nullable <(Of <( MetadataModel..::.VelocityUnit >)>)
The MetadataModel..::.VelocityUnit to convert.

Return Value

The equivalent String for the specified MetadataModel..::.VelocityUnit.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
ToString Overload
FreeImageAPI.Metadata Namespace


ToUnitType Method

[image]

FreeImage .NET Documentation
MetadataModel..::.ToUnitType Method
MetadataModel Class See Also Send Feedback
Returns the equivalent MetadataModel..::.VelocityUnit for the specified String.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected static Nullable<MetadataModel..::.VelocityUnit> ToUnitType(
    string s
)
Visual Basic (Declaration)
Protected Shared Function ToUnitType ( _
    s As String _
) As Nullable(Of MetadataModel..::.VelocityUnit)
Visual C++
protected:
static Nullable<MetadataModel..::.VelocityUnit> ToUnitType(
    String^ s
)

Parameters

s
Type: System..::.String
The string containing the MetadataModel..::.VelocityUnit.

Return Value

The equivalent MetadataModel..::.VelocityUnit for the specified String.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


MetadataModel Properties

[image] [image] [image]

FreeImage .NET Documentation
MetadataModel Properties
MetadataModel Class See Also Send Feedback

The MetadataModel type exposes the following members.

Properties

Name | Description
Count | Returns the number of metadata tags this instance represents.
Exists | Returns whether this model exists in the bitmaps metadata structure.
Item | Returns the metadata tag at the given index. This operation is slow when accessing all tags.
List | Returns a list of all metadata tags this instance represents.
Model | Retrieves the datamodel that this instance represents.

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


Count Property

[image]

FreeImage .NET Documentation
MetadataModel..::.Count Property
MetadataModel Class See Also Send Feedback
Returns the number of metadata tags this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


Exists Property

[image]

FreeImage .NET Documentation
MetadataModel..::.Exists Property
MetadataModel Class See Also Send Feedback
Returns whether this model exists in the bitmaps metadata structure.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Exists { get; }
Visual Basic (Declaration)
Public ReadOnly Property Exists As Boolean
Visual C++
public:
property bool Exists {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


Item Property

[image]

FreeImage .NET Documentation
MetadataModel..::.Item Property
MetadataModel Class See Also Send Feedback
Returns the metadata tag at the given index. This operation is slow when accessing all tags.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MetadataTag this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As MetadataTag
Visual C++
public:
property MetadataTag^ default[int index] {
    MetadataTag^ get (int index);
}

Parameters

index
Type: System..::.Int32
Index of the tag.

Return Value

The metadata tag.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | index is greater or equal Count or index is less than zero.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


List Property

[image]

FreeImage .NET Documentation
MetadataModel..::.List Property
MetadataModel Class See Also Send Feedback
Returns a list of all metadata tags this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public List<MetadataTag> List { get; }
Visual Basic (Declaration)
Public ReadOnly Property List As List(Of MetadataTag)
Visual C++
public:
property List<MetadataTag^>^ List {
    List<MetadataTag^>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MetadataModel..::.Model Property
MetadataModel Class See Also Send Feedback
Retrieves the datamodel that this instance represents.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public abstract FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
virtual property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get () abstract;
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataModel Class
FreeImageAPI.Metadata Namespace


MetadataModel.AltitudeType Enumeration

[image]

FreeImage .NET Documentation
MetadataModel..::.AltitudeType Enumeration
MetadataModel Class See Also Send Feedback
Specifies different altitude types.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum AltitudeType
Visual Basic (Declaration)
Public Enumeration AltitudeType
Visual C++
public enum class AltitudeType

Members

Member name | Description
Undefined | No or unknown type.
AboveSeaLevel | East.
BelowSeaLevel | West.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Metadata Namespace


MetadataModel.DirectionReference Enumeration

[image]

FreeImage .NET Documentation
MetadataModel..::.DirectionReference Enumeration
MetadataModel Class See Also Send Feedback
Specifies different direction types.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum DirectionReference
Visual Basic (Declaration)
Public Enumeration DirectionReference
Visual C++
public enum class DirectionReference

Members

Member name | Description
Undefined | No or unknown direction type.
TrueDirection | True direction.
MagneticDirection | Magnatic direction.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Metadata Namespace


MetadataModel.ExifImageOrientation Enumeration

[image]

FreeImage .NET Documentation
MetadataModel..::.ExifImageOrientation Enumeration
MetadataModel Class See Also Send Feedback
Specifies orientation of images.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum ExifImageOrientation
Visual Basic (Declaration)
Public Enumeration ExifImageOrientation
Visual C++
public enum class ExifImageOrientation

Members

Member name | Description
Undefined | Undefinied orientation.
TopLeft | TopLeft.
TopRight | TopRight.
BottomRight | BottomRight.
BottomLeft | BottomLeft.
LeftTop | LeftTop.
RightTop | RightTop.
RightBottom | RightBottom.
LeftBottom | LeftBottom.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Metadata Namespace


MetadataModel.InteroperabilityMode Enumeration

[image]

FreeImage .NET Documentation
MetadataModel..::.InteroperabilityMode Enumeration
MetadataModel Class See Also Send Feedback
Specifies interoperability types.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum InteroperabilityMode
Visual Basic (Declaration)
Public Enumeration InteroperabilityMode
Visual C++
public enum class InteroperabilityMode

Members

Member name | Description
Undefined | No or unknown type.
R98 | Indicates a file conforming to R98 file specification of Recommended Exif Interoperability Rules (ExifR98) or to DCF basic file stipulated by Design Rule for Camera File System.
THM | Indicates a file conforming to DCF thumbnail file stipulated by Design rule for Camera File System.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Metadata Namespace


MetadataModel.LatitudeType Enumeration

[image]

FreeImage .NET Documentation
MetadataModel..::.LatitudeType Enumeration
MetadataModel Class See Also Send Feedback
Specifies the type of a latitude value.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum LatitudeType
Visual Basic (Declaration)
Public Enumeration LatitudeType
Visual C++
public enum class LatitudeType

Members

Member name | Description
Undefined | No or unknown type.
North | North.
South | South.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Metadata Namespace


MetadataModel.LongitudeType Enumeration

[image]

FreeImage .NET Documentation
MetadataModel..::.LongitudeType Enumeration
MetadataModel Class See Also Send Feedback
Specifies the type of a longitude value.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum LongitudeType
Visual Basic (Declaration)
Public Enumeration LongitudeType
Visual C++
public enum class LongitudeType

Members

Member name | Description
Undefined | No or unknown type.
East | East.
West | West.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Metadata Namespace


MetadataModel.VelocityUnit Enumeration

[image]

FreeImage .NET Documentation
MetadataModel..::.VelocityUnit Enumeration
MetadataModel Class See Also Send Feedback
Specified different unit types.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public enum VelocityUnit
Visual Basic (Declaration)
Public Enumeration VelocityUnit
Visual C++
public enum class VelocityUnit

Members

Member name | Description
Undefinied | No or unknown type.
Kilometers | Kilometers per hour.
Miles | Miles per hour.
Knots | Knots.

Version Information

FreeImage.NET

Supported in: 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Metadata Namespace


MetadataTag Class

[image]

FreeImage .NET Documentation
MetadataTag Class
Members See Also Send Feedback
Manages metadata objects and operations.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class MetadataTag : IComparable,
    IComparable<MetadataTag>, ICloneable, IEquatable<MetadataTag>,
    IDisposable
Visual Basic (Declaration)
Public NotInheritable Class MetadataTag _
    Implements IComparable, IComparable(Of MetadataTag),  _
    ICloneable, IEquatable(Of MetadataTag), IDisposable
Visual C++
public ref class MetadataTag sealed : IComparable,
    IComparable<MetadataTag^>, ICloneable, IEquatable<MetadataTag^>,
    IDisposable

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Metadata..::.MetadataTag

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Members
FreeImageAPI.Metadata Namespace


MetadataTag Members

[image] [image] [image]

FreeImage .NET Documentation
MetadataTag Members
MetadataTag Class Constructors Methods Properties See Also Send Feedback

The MetadataTag type exposes the following members.

Constructors

Name | Description
MetadataTag | Overloaded.

Methods

Name | Description
AddToImage | Add this metadata to an image.
Clone | Creates a deep copy of this MetadataTag.
CompareTo | Overloaded.
Dispose | Releases all resources used by the instance.
Equals | Overloaded.
GetHashCode | Returns a hash code for this MetadataTag structure. (Overrides Object..::.GetHashCode()()().)
GetPropertyItem | Gets a .NET PropertyItem for this metadata tag.
SetValue | Overloaded.
ToString | Converts the value of the MetadataTag object to its equivalent string representation. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Determines whether two specified MetadataTag objects have the same value.
Implicit | Extracts the value of a MetadataTag instance to a FITAG handle.
Inequality | Determines whether two specified MetadataTag objects have different values.

Properties

Name | Description
Count | Gets the number of elements the metadata object contains.
Description | Gets or sets the description of the metadata.
Disposed | Gets whether this instance has already been disposed.
ID | Gets or sets the ID of the metadata.
Key | Gets or sets the key of the metadata.
Length | Gets the length of the value in bytes.
Model | Gets the model of the metadata.
Type | Gets the type of the metadata.
Value | Gets or sets the value of the metadata.

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


MetadataTag Constructor

[image] [image] [image]

FreeImage .NET Documentation
MetadataTag Constructor
MetadataTag Class See Also Send Feedback

Overload List

Name | Description
MetadataTag(FREE_IMAGE_MDMODEL) | Initializes a new instance of this class.
MetadataTag(FITAG, FIBITMAP) | Initializes a new instance of this class.
MetadataTag(FITAG, FREE_IMAGE_MDMODEL) | Initializes a new instance of this class.

See Also

MetadataTag Class
MetadataTag Members
FreeImageAPI.Metadata Namespace


MetadataTag Constructor (FREE_IMAGE_MDMODEL)

[image]

FreeImage .NET Documentation
MetadataTag Constructor (FREE_IMAGE_MDMODEL)
MetadataTag Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MetadataTag(
    FREE_IMAGE_MDMODEL model
)
Visual Basic (Declaration)
Public Sub New ( _
    model As FREE_IMAGE_MDMODEL _
)
Visual C++
public:
MetadataTag(
    FREE_IMAGE_MDMODEL model
)

Parameters

model
Type: FreeImageAPI..::.FREE_IMAGE_MDMODEL
The new model the tag should be of.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
MetadataTag Overload
FreeImageAPI.Metadata Namespace


MetadataTag Constructor (FITAG, FIBITMAP)

[image]

FreeImage .NET Documentation
MetadataTag Constructor (FITAG, FIBITMAP)
MetadataTag Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MetadataTag(
    FITAG tag,
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Sub New ( _
    tag As FITAG, _
    dib As FIBITMAP _
)
Visual C++
public:
MetadataTag(
    FITAG tag,
    FIBITMAP dib
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The FITAG to represent.
dib
Type: FreeImageAPI..::.FIBITMAP
The bitmap tag was extracted from.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
MetadataTag Overload
FreeImageAPI.Metadata Namespace


MetadataTag Constructor (FITAG, FREE_IMAGE_MDMODEL)

[image]

FreeImage .NET Documentation
MetadataTag Constructor (FITAG, FREE_IMAGE_MDMODEL)
MetadataTag Class See Also Send Feedback
Initializes a new instance of this class.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MetadataTag(
    FITAG tag,
    FREE_IMAGE_MDMODEL model
)
Visual Basic (Declaration)
Public Sub New ( _
    tag As FITAG, _
    model As FREE_IMAGE_MDMODEL _
)
Visual C++
public:
MetadataTag(
    FITAG tag,
    FREE_IMAGE_MDMODEL model
)

Parameters

tag
Type: FreeImageAPI..::.FITAG
The FITAG to represent.
model
Type: FreeImageAPI..::.FREE_IMAGE_MDMODEL
The model of tag.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
MetadataTag Overload
FreeImageAPI.Metadata Namespace


MetadataTag Methods

[image] [image] [image]

FreeImage .NET Documentation
MetadataTag Methods
MetadataTag Class See Also Send Feedback

The MetadataTag type exposes the following members.

Methods

Name | Description
AddToImage | Add this metadata to an image.
Clone | Creates a deep copy of this MetadataTag.
CompareTo | Overloaded.
Dispose | Releases all resources used by the instance.
Equals | Overloaded.
GetHashCode | Returns a hash code for this MetadataTag structure. (Overrides Object..::.GetHashCode()()().)
GetPropertyItem | Gets a .NET PropertyItem for this metadata tag.
SetValue | Overloaded.
ToString | Converts the value of the MetadataTag object to its equivalent string representation. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | Determines whether two specified MetadataTag objects have the same value.
Implicit | Extracts the value of a MetadataTag instance to a FITAG handle.
Inequality | Determines whether two specified MetadataTag objects have different values.

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


AddToImage Method

[image]

FreeImage .NET Documentation
MetadataTag..::.AddToImage Method
MetadataTag Class See Also Send Feedback
Add this metadata to an image.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool AddToImage(
    FIBITMAP dib
)
Visual Basic (Declaration)
Public Function AddToImage ( _
    dib As FIBITMAP _
) As Boolean
Visual C++
public:
bool AddToImage(
    FIBITMAP dib
)

Parameters

dib
Type: FreeImageAPI..::.FIBITMAP
Handle to a FreeImage bitmap.

Return Value

True on success, false on failure.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Clone Method

[image]

FreeImage .NET Documentation
MetadataTag..::.Clone Method
MetadataTag Class See Also Send Feedback
Creates a deep copy of this MetadataTag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

A deep copy of this MetadataTag.

Implements

ICloneable..::.Clone()()()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


CompareTo Method

[image] [image] [image]

FreeImage .NET Documentation
MetadataTag..::.CompareTo Method
MetadataTag Class See Also Send Feedback

Overload List

Name | Description
CompareTo(MetadataTag) | Compares the current instance with another object of the same type.
CompareTo(Object) | Compares this instance with a specified Object.

See Also

MetadataTag Class
MetadataTag Members
FreeImageAPI.Metadata Namespace


CompareTo Method (MetadataTag)

[image]

FreeImage .NET Documentation
MetadataTag..::.CompareTo Method (MetadataTag)
MetadataTag Class See Also Send Feedback
Compares the current instance with another object of the same type.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    MetadataTag other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As MetadataTag _
) As Integer
Visual C++
public:
virtual int CompareTo(
    MetadataTag^ other
) sealed

Parameters

other
Type: FreeImageAPI.Metadata..::.MetadataTag
An object to compare with this instance.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
CompareTo Overload
FreeImageAPI.Metadata Namespace


CompareTo Method (Object)

[image]

FreeImage .NET Documentation
MetadataTag..::.CompareTo Method (Object)
MetadataTag Class See Also Send Feedback
Compares this instance with a specified Object.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
An object to compare with this instance.

Return Value

A 32-bit signed integer indicating the lexical relationship between the two comparands.

Implements

IComparable..::.CompareTo(Object)

Exceptions

Exception | Condition
System..::.ArgumentException | obj is not a MetadataTag.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
CompareTo Overload
FreeImageAPI.Metadata Namespace


Dispose Method

[image]

FreeImage .NET Documentation
MetadataTag..::.Dispose Method
MetadataTag Class See Also Send Feedback
Releases all resources used by the instance.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Equality Operator

[image]

FreeImage .NET Documentation
MetadataTag..::.Equality Operator
MetadataTag Class See Also Send Feedback
Determines whether two specified MetadataTag objects have the same value.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator ==(
    MetadataTag left,
    MetadataTag right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As MetadataTag, _
    right As MetadataTag _
) As Boolean
Visual C++
public:
static bool operator ==(
    MetadataTag^ left,
    MetadataTag^ right
)

Parameters

left
Type: FreeImageAPI.Metadata..::.MetadataTag
A MetadataTag or a null reference (Nothing in Visual Basic).
right
Type: FreeImageAPI.Metadata..::.MetadataTag
A MetadataTag or a null reference (Nothing in Visual Basic).

Return Value

true if the value of left is the same as the value of right; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Equals Method

[image] [image] [image]

FreeImage .NET Documentation
MetadataTag..::.Equals Method
MetadataTag Class See Also Send Feedback

Overload List

Name | Description
Equals(MetadataTag) | Tests whether the specified MetadataTag instance is equivalent to this MetadataTag instance.
Equals(Object) | Tests whether the specified object is a MetadataTag instance and is equivalent to this MetadataTag instance. (Overrides Object..::.Equals(Object).)

See Also

MetadataTag Class
MetadataTag Members
FreeImageAPI.Metadata Namespace


Equals Method (MetadataTag)

[image]

FreeImage .NET Documentation
MetadataTag..::.Equals Method (MetadataTag)
MetadataTag Class See Also Send Feedback
Tests whether the specified MetadataTag instance is equivalent to this MetadataTag instance.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Equals(
    MetadataTag other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As MetadataTag _
) As Boolean
Visual C++
public:
virtual bool Equals(
    MetadataTag^ other
) sealed

Parameters

other
Type: FreeImageAPI.Metadata..::.MetadataTag
A MetadataTag instance to compare to this instance.

Return Value

true if obj equivalent to this MetadataTag instance; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
Equals Overload
FreeImageAPI.Metadata Namespace


Equals Method (Object)

[image]

FreeImage .NET Documentation
MetadataTag..::.Equals Method (Object)
MetadataTag Class See Also Send Feedback
Tests whether the specified object is a MetadataTag instance and is equivalent to this MetadataTag instance.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to test.

Return Value

true if obj is a MetadataTag instance equivalent to this MetadataTag instance; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
Equals Overload
FreeImageAPI.Metadata Namespace


GetHashCode Method

[image]

FreeImage .NET Documentation
MetadataTag..::.GetHashCode Method
MetadataTag Class See Also Send Feedback
Returns a hash code for this MetadataTag structure.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

An integer value that specifies the hash code for this MetadataTag.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


GetPropertyItem Method

[image]

FreeImage .NET Documentation
MetadataTag..::.GetPropertyItem Method
MetadataTag Class See Also Send Feedback
Gets a .NET PropertyItem for this metadata tag.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public PropertyItem GetPropertyItem()
Visual Basic (Declaration)
Public Function GetPropertyItem As PropertyItem
Visual C++
public:
PropertyItem^ GetPropertyItem()

Return Value

The .NET PropertyItem.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Implicit Operator

[image]

FreeImage .NET Documentation
MetadataTag..::.Implicit Operator
MetadataTag Class See Also Send Feedback
Extracts the value of a MetadataTag instance to a FITAG handle.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static implicit operator FITAG (
    MetadataTag value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As MetadataTag _
) As FITAG
Visual C++
static implicit operator FITAG (
    MetadataTag^ value
)

Parameters

value
Type: FreeImageAPI.Metadata..::.MetadataTag
A MetadataTag instance.

Return Value

A new instance of FITAG initialized to value.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Inequality Operator

[image]

FreeImage .NET Documentation
MetadataTag..::.Inequality Operator
MetadataTag Class See Also Send Feedback
Determines whether two specified MetadataTag objects have different values.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static bool operator !=(
    MetadataTag left,
    MetadataTag right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As MetadataTag, _
    right As MetadataTag _
) As Boolean
Visual C++
public:
static bool operator !=(
    MetadataTag^ left,
    MetadataTag^ right
)

Parameters

left
Type: FreeImageAPI.Metadata..::.MetadataTag
A MetadataTag or a null reference (Nothing in Visual Basic).
right
Type: FreeImageAPI.Metadata..::.MetadataTag
A MetadataTag or a null reference (Nothing in Visual Basic).

Return Value

true if the value of left is different from the value of right; otherwise, false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


SetValue Method

[image] [image] [image]

FreeImage .NET Documentation
MetadataTag..::.SetValue Method
MetadataTag Class See Also Send Feedback

Overload List

Name | Description
SetValue(Object) | Sets the value of the metadata. In case value is of byte or byte[] FIDT_UNDEFINED is assumed. In case value is of uint or uint[] FIDT_LONG is assumed.
SetValue(Object, FREE_IMAGE_MDTYPE) | Sets the value of the metadata.

See Also

MetadataTag Class
MetadataTag Members
FreeImageAPI.Metadata Namespace


SetValue Method (Object)

[image]

FreeImage .NET Documentation
MetadataTag..::.SetValue Method (Object)
MetadataTag Class See Also Send Feedback
Sets the value of the metadata.

In case value is of byte or byte[] FIDT_UNDEFINED is assumed.

In case value is of uint or uint[] FIDT_LONG is assumed.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool SetValue(
    Object value
)
Visual Basic (Declaration)
Public Function SetValue ( _
    value As Object _
) As Boolean
Visual C++
public:
bool SetValue(
    Object^ value
)

Parameters

value
Type: System..::.Object
New data of the metadata.

Return Value

True on success, false on failure.

Exceptions

Exception | Condition
System..::.NotSupportedException | The data format is not supported.
System..::.ArgumentNullException | value is null.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
SetValue Overload
FreeImageAPI.Metadata Namespace


SetValue Method (Object, FREE_IMAGE_MDTYPE)

[image]

FreeImage .NET Documentation
MetadataTag..::.SetValue Method (Object, FREE_IMAGE_MDTYPE)
MetadataTag Class See Also Send Feedback
Sets the value of the metadata.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool SetValue(
    Object value,
    FREE_IMAGE_MDTYPE type
)
Visual Basic (Declaration)
Public Function SetValue ( _
    value As Object, _
    type As FREE_IMAGE_MDTYPE _
) As Boolean
Visual C++
public:
bool SetValue(
    Object^ value,
    FREE_IMAGE_MDTYPE type
)

Parameters

value
Type: System..::.Object
New data of the metadata.
type
Type: FreeImageAPI..::.FREE_IMAGE_MDTYPE
Type of the data.

Return Value

True on success, false on failure.

Exceptions

Exception | Condition
System..::.NotSupportedException | The data type is not supported.
System..::.ArgumentNullException | value is null.
System..::.ArgumentException | value and type to not fit.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
SetValue Overload
FreeImageAPI.Metadata Namespace


ToString Method

[image]

FreeImage .NET Documentation
MetadataTag..::.ToString Method
MetadataTag Class See Also Send Feedback
Converts the value of the MetadataTag object to its equivalent string representation.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the value of this instance.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


MetadataTag Properties

[image] [image] [image]

FreeImage .NET Documentation
MetadataTag Properties
MetadataTag Class See Also Send Feedback

The MetadataTag type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements the metadata object contains.
Description | Gets or sets the description of the metadata.
Disposed | Gets whether this instance has already been disposed.
ID | Gets or sets the ID of the metadata.
Key | Gets or sets the key of the metadata.
Length | Gets the length of the value in bytes.
Model | Gets the model of the metadata.
Type | Gets the type of the metadata.
Value | Gets or sets the value of the metadata.

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Count Property

[image]

FreeImage .NET Documentation
MetadataTag..::.Count Property
MetadataTag Class See Also Send Feedback
Gets the number of elements the metadata object contains.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint Count { get; private set; }
Visual Basic (Declaration)
Public Property Count As UInteger
Visual C++
public:
property unsigned int Count {
    unsigned int get ();
    void set (unsigned int value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Description Property

[image]

FreeImage .NET Documentation
MetadataTag..::.Description Property
MetadataTag Class See Also Send Feedback
Gets or sets the description of the metadata.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Disposed Property

[image]

FreeImage .NET Documentation
MetadataTag..::.Disposed Property
MetadataTag Class See Also Send Feedback
Gets whether this instance has already been disposed.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Disposed { get; }
Visual Basic (Declaration)
Public ReadOnly Property Disposed As Boolean
Visual C++
public:
property bool Disposed {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


ID Property

[image]

FreeImage .NET Documentation
MetadataTag..::.ID Property
MetadataTag Class See Also Send Feedback
Gets or sets the ID of the metadata.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ushort ID { get; set; }
Visual Basic (Declaration)
Public Property ID As UShort
Visual C++
public:
property unsigned short ID {
    unsigned short get ();
    void set (unsigned short value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Key Property

[image]

FreeImage .NET Documentation
MetadataTag..::.Key Property
MetadataTag Class See Also Send Feedback
Gets or sets the key of the metadata.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Key { get; set; }
Visual Basic (Declaration)
Public Property Key As String
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Length Property

[image]

FreeImage .NET Documentation
MetadataTag..::.Length Property
MetadataTag Class See Also Send Feedback
Gets the length of the value in bytes.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public uint Length { get; private set; }
Visual Basic (Declaration)
Public Property Length As UInteger
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
    void set (unsigned int value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Model Property

[image]

FreeImage .NET Documentation
MetadataTag..::.Model Property
MetadataTag Class See Also Send Feedback
Gets the model of the metadata.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FREE_IMAGE_MDMODEL Model { get; }
Visual Basic (Declaration)
Public ReadOnly Property Model As FREE_IMAGE_MDMODEL
Visual C++
public:
property FREE_IMAGE_MDMODEL Model {
    FREE_IMAGE_MDMODEL get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Type Property

[image]

FreeImage .NET Documentation
MetadataTag..::.Type Property
MetadataTag Class See Also Send Feedback
Gets the type of the metadata.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FREE_IMAGE_MDTYPE Type { get; private set; }
Visual Basic (Declaration)
Public Property Type As FREE_IMAGE_MDTYPE
Visual C++
public:
property FREE_IMAGE_MDTYPE Type {
    FREE_IMAGE_MDTYPE get ();
    void set (FREE_IMAGE_MDTYPE value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


Value Property

[image]

FreeImage .NET Documentation
MetadataTag..::.Value Property
MetadataTag Class See Also Send Feedback
Gets or sets the value of the metadata.

Namespace: FreeImageAPI.Metadata
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

MetadataTag Class
FreeImageAPI.Metadata Namespace


FreeImageAPI.Plugins Namespace

[image]

FreeImage .NET Documentation
FreeImageAPI.Plugins Namespace
Send Feedback

Classes

Class | Description
FreeImagePlugin | Class representing a FreeImage format.
LocalPlugin | Class representing own FreeImage-Plugins.
PluginRepository | Class representing all registered FreeImagePlugin in FreeImage.

Structures

Structure | Description
Plugin | The structure contains functionpointers that make up a FreeImage plugin.

Delegates

Delegate | Description
CloseProc | Delegate to a function that closes a previosly opened file.
DescriptionProc | Delegate to a function that returns a string which contains a more detailed description.
ExtensionListProc | Delegate to a function that returns a comma seperated list of file extensions the plugin can read or write.
FormatProc | Delegate to a function that returns a string which describes the plugins format.
InitProc | Callback function used by FreeImage to register plugins.
LoadProc | Delegate to a function that loads and decodes a bitmap into memory.
MimeProc | Delegate to a function that returns a string which contains the plugin's mime type.
OpenProc | Delegate to a function that opens a file.
PageCapabilityProc | UNKNOWN
PageCountProc | Delegate to a function that returns the number of pages of a multipage bitmap if the plugin is capable of handling multipage bitmaps.
RegExprProc | Delegate to a function that returns a regular expression that can be used to idientify whether a file can be handled by the plugin.
SaveProc | Delegate to a function that saves a bitmap.
SupportsExportBPPProc | Delegate to a function that returns whether the plugin can handle the specified color depth.
SupportsExportTypeProc | Delegate to a function that returns whether the plugin can handle the specified image type.
SupportsICCProfilesProc | Delegate to a function that returns whether the plugin can handle ICC-Profiles.
ValidateProc | Delegate to a function that determines whether the source defined by and is a valid image.

Enumerations

Enumeration | Description
LocalPlugin..::.MethodFlags | MethodFlags defines values to fill a bitfield telling which functions have been implemented by a plugin.


CloseProc Delegate

[image]

FreeImage .NET Documentation
CloseProc Delegate
See Also Send Feedback
Delegate to a function that closes a previosly opened file.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate void CloseProc(
    ref FreeImageIO io,
    fi_handle handle,
    IntPtr data
)
Visual Basic (Declaration)
Public Delegate Sub CloseProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    data As IntPtr _
)
Visual C++
public delegate void CloseProc(
    FreeImageIO% io,
    fi_handle handle,
    IntPtr data
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle
data
Type: System..::.IntPtr

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


DescriptionProc Delegate

[image]

FreeImage .NET Documentation
DescriptionProc Delegate
See Also Send Feedback
Delegate to a function that returns a string which contains a more detailed description.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate string DescriptionProc()
Visual Basic (Declaration)
Public Delegate Function DescriptionProc As String
Visual C++
public delegate String^ DescriptionProc()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


ExtensionListProc Delegate

[image]

FreeImage .NET Documentation
ExtensionListProc Delegate
See Also Send Feedback
Delegate to a function that returns a comma seperated list of file extensions the plugin can read or write.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate string ExtensionListProc()
Visual Basic (Declaration)
Public Delegate Function ExtensionListProc As String
Visual C++
public delegate String^ ExtensionListProc()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


FormatProc Delegate

[image]

FreeImage .NET Documentation
FormatProc Delegate
See Also Send Feedback
Delegate to a function that returns a string which describes the plugins format.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate string FormatProc()
Visual Basic (Declaration)
Public Delegate Function FormatProc As String
Visual C++
public delegate String^ FormatProc()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


FreeImagePlugin Class

[image]

FreeImage .NET Documentation
FreeImagePlugin Class
Members See Also Send Feedback
Class representing a FreeImage format.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public sealed class FreeImagePlugin
Visual Basic (Declaration)
Public NotInheritable Class FreeImagePlugin
Visual C++
public ref class FreeImagePlugin sealed

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Plugins..::.FreeImagePlugin

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Members
FreeImageAPI.Plugins Namespace


FreeImagePlugin Members

[image] [image] [image]

FreeImage .NET Documentation
FreeImagePlugin Members
FreeImagePlugin Class Methods Properties See Also Send Feedback

The FreeImagePlugin type exposes the following members.

Methods

Name | Description
SupportsExportBPP | Checks whether this plugin can save bitmaps in the desired bit depth.
SupportsExportType | Checks whether this plugin can save a bitmap in the desired data type.
ToString | Gets a descriptive string that describes the bitmap formats this plugin can read and/or write. (Overrides Object..::.ToString()()().)
ValidExtension | Overloaded.
ValidFilename | Overloaded.

Properties

Name | Description
Description | Gets a descriptive string that describes the bitmap formats this plugin can read and/or write.
Enabled | Gets or sets whether this plugin is enabled.
ExtentsionList | Gets a comma-delimited file extension list describing the bitmap formats this plugin can read and/or write.
FIFormat | Gets the format of this instance.
Format | Gets a string describing the format.
RegExpr | Returns a regular expression string that can be used by a regular expression engine to identify the bitmap. FreeImageQt makes use of this function.
SupportsICCProfiles | Gets whether this plugin can load or save an ICC profile.
SupportsReading | Gets whether this plugin can load bitmaps.
SupportsWriting | Gets whether this plugin can save bitmaps.

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


FreeImagePlugin Methods

[image] [image] [image]

FreeImage .NET Documentation
FreeImagePlugin Methods
FreeImagePlugin Class See Also Send Feedback

The FreeImagePlugin type exposes the following members.

Methods

Name | Description
SupportsExportBPP | Checks whether this plugin can save bitmaps in the desired bit depth.
SupportsExportType | Checks whether this plugin can save a bitmap in the desired data type.
ToString | Gets a descriptive string that describes the bitmap formats this plugin can read and/or write. (Overrides Object..::.ToString()()().)
ValidExtension | Overloaded.
ValidFilename | Overloaded.

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


SupportsExportBPP Method

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.SupportsExportBPP Method
FreeImagePlugin Class See Also Send Feedback
Checks whether this plugin can save bitmaps in the desired bit depth.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool SupportsExportBPP(
    int bpp
)
Visual Basic (Declaration)
Public Function SupportsExportBPP ( _
    bpp As Integer _
) As Boolean
Visual C++
public:
bool SupportsExportBPP(
    int bpp
)

Parameters

bpp
Type: System..::.Int32
The desired bit depth.

Return Value

True if this plugin can save bitmaps in the desired bit depth, else false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


SupportsExportType Method

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.SupportsExportType Method
FreeImagePlugin Class See Also Send Feedback
Checks whether this plugin can save a bitmap in the desired data type.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool SupportsExportType(
    FREE_IMAGE_TYPE type
)
Visual Basic (Declaration)
Public Function SupportsExportType ( _
    type As FREE_IMAGE_TYPE _
) As Boolean
Visual C++
public:
bool SupportsExportType(
    FREE_IMAGE_TYPE type
)

Parameters

type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE
The desired image type.

Return Value

True if this plugin can save bitmaps as the desired type, else false.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


ToString Method

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.ToString Method
FreeImagePlugin Class See Also Send Feedback
Gets a descriptive string that describes the bitmap formats this plugin can read and/or write.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A descriptive string that describes the bitmap formats.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


ValidExtension Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImagePlugin..::.ValidExtension Method
FreeImagePlugin Class See Also Send Feedback

Overload List

Name | Description
ValidExtension(String) | Checks whether an extension is valid for this format.
ValidExtension(String, StringComparison) | Checks whether an extension is valid for this format.

See Also

FreeImagePlugin Class
FreeImagePlugin Members
FreeImageAPI.Plugins Namespace


ValidExtension Method (String)

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.ValidExtension Method (String)
FreeImagePlugin Class See Also Send Feedback
Checks whether an extension is valid for this format.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool ValidExtension(
    string extension
)
Visual Basic (Declaration)
Public Function ValidExtension ( _
    extension As String _
) As Boolean
Visual C++
public:
bool ValidExtension(
    String^ extension
)

Parameters

extension
Type: System..::.String
The desired extension.

Return Value

True if the extension is valid for this format, false otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
ValidExtension Overload
FreeImageAPI.Plugins Namespace


ValidExtension Method (String, StringComparison)

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.ValidExtension Method (String, StringComparison)
FreeImagePlugin Class See Also Send Feedback
Checks whether an extension is valid for this format.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool ValidExtension(
    string extension,
    StringComparison comparisonType
)
Visual Basic (Declaration)
Public Function ValidExtension ( _
    extension As String, _
    comparisonType As StringComparison _
) As Boolean
Visual C++
public:
bool ValidExtension(
    String^ extension,
    StringComparison comparisonType
)

Parameters

extension
Type: System..::.String
The desired extension.
comparisonType
Type: System..::.StringComparison
The string comparison type.

Return Value

True if the extension is valid for this format, false otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
ValidExtension Overload
FreeImageAPI.Plugins Namespace


ValidFilename Method

[image] [image] [image]

FreeImage .NET Documentation
FreeImagePlugin..::.ValidFilename Method
FreeImagePlugin Class See Also Send Feedback

Overload List

Name | Description
ValidFilename(String) | Checks whether a filename is valid for this format.
ValidFilename(String, StringComparison) | Checks whether a filename is valid for this format.

See Also

FreeImagePlugin Class
FreeImagePlugin Members
FreeImageAPI.Plugins Namespace


ValidFilename Method (String)

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.ValidFilename Method (String)
FreeImagePlugin Class See Also Send Feedback
Checks whether a filename is valid for this format.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool ValidFilename(
    string filename
)
Visual Basic (Declaration)
Public Function ValidFilename ( _
    filename As String _
) As Boolean
Visual C++
public:
bool ValidFilename(
    String^ filename
)

Parameters

filename
Type: System..::.String
The desired filename.

Return Value

True if the filename is valid for this format, false otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
ValidFilename Overload
FreeImageAPI.Plugins Namespace


ValidFilename Method (String, StringComparison)

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.ValidFilename Method (String, StringComparison)
FreeImagePlugin Class See Also Send Feedback
Checks whether a filename is valid for this format.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool ValidFilename(
    string filename,
    StringComparison comparisonType
)
Visual Basic (Declaration)
Public Function ValidFilename ( _
    filename As String, _
    comparisonType As StringComparison _
) As Boolean
Visual C++
public:
bool ValidFilename(
    String^ filename,
    StringComparison comparisonType
)

Parameters

filename
Type: System..::.String
The desired filename.
comparisonType
Type: System..::.StringComparison
The string comparison type.

Return Value

True if the filename is valid for this format, false otherwise.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
ValidFilename Overload
FreeImageAPI.Plugins Namespace


FreeImagePlugin Properties

[image] [image] [image]

FreeImage .NET Documentation
FreeImagePlugin Properties
FreeImagePlugin Class See Also Send Feedback

The FreeImagePlugin type exposes the following members.

Properties

Name | Description
Description | Gets a descriptive string that describes the bitmap formats this plugin can read and/or write.
Enabled | Gets or sets whether this plugin is enabled.
ExtentsionList | Gets a comma-delimited file extension list describing the bitmap formats this plugin can read and/or write.
FIFormat | Gets the format of this instance.
Format | Gets a string describing the format.
RegExpr | Returns a regular expression string that can be used by a regular expression engine to identify the bitmap. FreeImageQt makes use of this function.
SupportsICCProfiles | Gets whether this plugin can load or save an ICC profile.
SupportsReading | Gets whether this plugin can load bitmaps.
SupportsWriting | Gets whether this plugin can save bitmaps.

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


Description Property

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.Description Property
FreeImagePlugin Class See Also Send Feedback
Gets a descriptive string that describes the bitmap formats this plugin can read and/or write.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


Enabled Property

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.Enabled Property
FreeImagePlugin Class See Also Send Feedback
Gets or sets whether this plugin is enabled.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


ExtentsionList Property

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.ExtentsionList Property
FreeImagePlugin Class See Also Send Feedback
Gets a comma-delimited file extension list describing the bitmap formats this plugin can read and/or write.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string ExtentsionList { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtentsionList As String
Visual C++
public:
property String^ ExtentsionList {
    String^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


FIFormat Property

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.FIFormat Property
FreeImagePlugin Class See Also Send Feedback
Gets the format of this instance.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FREE_IMAGE_FORMAT FIFormat { get; }
Visual Basic (Declaration)
Public ReadOnly Property FIFormat As FREE_IMAGE_FORMAT
Visual C++
public:
property FREE_IMAGE_FORMAT FIFormat {
    FREE_IMAGE_FORMAT get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


Format Property

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.Format Property
FreeImagePlugin Class See Also Send Feedback
Gets a string describing the format.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As String
Visual C++
public:
property String^ Format {
    String^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


RegExpr Property

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.RegExpr Property
FreeImagePlugin Class See Also Send Feedback
Returns a regular expression string that can be used by a regular expression engine to identify the bitmap. FreeImageQt makes use of this function.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public string RegExpr { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegExpr As String
Visual C++
public:
property String^ RegExpr {
    String^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


SupportsICCProfiles Property

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.SupportsICCProfiles Property
FreeImagePlugin Class See Also Send Feedback
Gets whether this plugin can load or save an ICC profile.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool SupportsICCProfiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property SupportsICCProfiles As Boolean
Visual C++
public:
property bool SupportsICCProfiles {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


SupportsReading Property

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.SupportsReading Property
FreeImagePlugin Class See Also Send Feedback
Gets whether this plugin can load bitmaps.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool SupportsReading { get; }
Visual Basic (Declaration)
Public ReadOnly Property SupportsReading As Boolean
Visual C++
public:
property bool SupportsReading {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


SupportsWriting Property

[image]

FreeImage .NET Documentation
FreeImagePlugin..::.SupportsWriting Property
FreeImagePlugin Class See Also Send Feedback
Gets whether this plugin can save bitmaps.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool SupportsWriting { get; }
Visual Basic (Declaration)
Public ReadOnly Property SupportsWriting As Boolean
Visual C++
public:
property bool SupportsWriting {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImagePlugin Class
FreeImageAPI.Plugins Namespace


InitProc Delegate

[image]

FreeImage .NET Documentation
InitProc Delegate
See Also Send Feedback
Callback function used by FreeImage to register plugins.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate void InitProc(
    ref Plugin plugin,
    int format_id
)
Visual Basic (Declaration)
Public Delegate Sub InitProc ( _
    ByRef plugin As Plugin, _
    format_id As Integer _
)
Visual C++
public delegate void InitProc(
    Plugin% plugin,
    int format_id
)

Parameters

plugin
Type: FreeImageAPI.Plugins..::.Plugin %
format_id
Type: System..::.Int32

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


LoadProc Delegate

[image]

FreeImage .NET Documentation
LoadProc Delegate
See Also Send Feedback
Delegate to a function that loads and decodes a bitmap into memory.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate FIBITMAP LoadProc(
    ref FreeImageIO io,
    fi_handle handle,
    int page,
    int flags,
    IntPtr data
)
Visual Basic (Declaration)
Public Delegate Function LoadProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    page As Integer, _
    flags As Integer, _
    data As IntPtr _
) As FIBITMAP
Visual C++
public delegate FIBITMAP LoadProc(
    FreeImageIO% io,
    fi_handle handle,
    int page,
    int flags,
    IntPtr data
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle
page
Type: System..::.Int32
flags
Type: System..::.Int32
data
Type: System..::.IntPtr

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


LocalPlugin Class

[image]

FreeImage .NET Documentation
LocalPlugin Class
Members See Also Send Feedback
Class representing own FreeImage-Plugins.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public abstract class LocalPlugin
Visual Basic (Declaration)
Public MustInherit Class LocalPlugin
Visual C++
public ref class LocalPlugin abstract

Remarks

FreeImages itself is plugin based. Each supported format is integrated by a seperat plugin, that handles loading, saving, descriptions, identifing ect. And of course the user can create own plugins and use them in FreeImage. To do that the above mentioned predefined methodes need to be implemented.

The class below handles the creation of such a plugin. The class itself is abstract as well as some core functions that need to be implemented. The class can be used to enable or disable the plugin in FreeImage after regististration or retrieve the formatid, assigned by FreeImage. The class handles the callback functions, garbage collector and pointer operation to make the implementation as user friendly as possible.

How to: There are two functions that need to be implemented: GetImplementedMethods()()() and FormatProc()()(). GetImplementedMethods()()() is used by the constructor of the abstract class. FreeImage wants a list of the implemented functions. Each function is represented by a function pointer (a .NET Delegate). In case a function is not implemented FreeImage receives an empty delegate). To tell the constructor which functions have been implemented the information is represented by a disjunction of LocalPlugin..::.MethodFlags.

For example: return MethodFlags.LoadProc | MethodFlags.SaveProc;

The above statement means that LoadProc and SaveProc have been implemented by the user. Keep in mind, that each function has a standard implementation that has static return values that may cause errors if listed in GetImplementedMethods()()() without a real implementation.

FormatProc()()() is used by some checks of FreeImage and must be implemented. LoadProc(FreeImageIO%, fi_handle, Int32, Int32, IntPtr) for example can be implemented if the plugin supports reading, but it doesn't have to, the plugin could only be used to save an already loaded bitmap in a special format.

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Plugins..::.LocalPlugin

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Members
FreeImageAPI.Plugins Namespace


LocalPlugin Members

[image] [image] [image]

FreeImage .NET Documentation
LocalPlugin Members
LocalPlugin Class Constructors Methods Fields Properties See Also Send Feedback

The LocalPlugin type exposes the following members.

Constructors

Name | Description
LocalPlugin | The constructor automatically registeres the plugin in FreeImage. To do this it prepares a FreeImage defined structure with function pointers to the implemented functions or null if not implemented. Before registing the functions they are pinned in memory so the garbage collector can't move them around in memory after we passed there addresses to FreeImage.

Methods

Name | Description
CloseProc | Function that can be implemented.
DescriptionProc | Function that can be implemented.
ExtensionListProc | Function that can be implemented.
Finalize | Releases all resources used by the instance. (Overrides Object..::.Finalize()()().)
FormatProc | Implementation of FormatProc
GetImplementedMethods | Function that returns a bitfield containing the implemented methods.
LoadProc | Function that can be implemented.
MimeProc | Function that can be implemented.
OpenProc | Function that can be implemented.
PageCapabilityProc | Function that can be implemented.
PageCountProc | Function that can be implemented.
Read | Reads from an unmanaged stream.
ReadByte | Reads a single byte from an unmanaged stream.
RegExprProc | Function that can be implemented.
SaveProc | Function that can be implemented.
Seek | Seeks in an unmanaged stream.
SupportsExportBPPProc | Function that can be implemented.
SupportsExportTypeProc | Function that can be implemented.
SupportsICCProfilesProc | Function that can be implemented.
Tell | Retrieves the position of an unmanaged stream.
ValidateProc | Function that can be implemented.
Write | Writes to an unmanaged stream.
WriteByte | Writes a single byte to an unmanaged stream.

Fields

Name | Description
format | The format id assiged to the plugin.
implementedMethods | A copy of the functions used to register.
registered | When true the plugin was registered successfully else false.

Properties

Name | Description
Enabled | Gets or sets if the plugin is enabled.
Format | Gets the FREE_IMAGE_FORMAT FreeImage assigned to this plugin.
Registered | Gets if the plugin was registered successfully.

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


LocalPlugin Constructor

[image]

FreeImage .NET Documentation
LocalPlugin Constructor
LocalPlugin Class See Also Send Feedback
The constructor automatically registeres the plugin in FreeImage. To do this it prepares a FreeImage defined structure with function pointers to the implemented functions or null if not implemented. Before registing the functions they are pinned in memory so the garbage collector can't move them around in memory after we passed there addresses to FreeImage.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public LocalPlugin()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LocalPlugin()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


LocalPlugin Fields

[image] [image] [image]

FreeImage .NET Documentation
LocalPlugin Fields
LocalPlugin Class See Also Send Feedback

The LocalPlugin type exposes the following members.

Fields

Name | Description
format | The format id assiged to the plugin.
implementedMethods | A copy of the functions used to register.
registered | When true the plugin was registered successfully else false.

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


format Field

[image]

FreeImage .NET Documentation
LocalPlugin..::.format Field
LocalPlugin Class See Also Send Feedback
The format id assiged to the plugin.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected FREE_IMAGE_FORMAT format
Visual Basic (Declaration)
Protected format As FREE_IMAGE_FORMAT
Visual C++
protected:
FREE_IMAGE_FORMAT format

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


implementedMethods Field

[image]

FreeImage .NET Documentation
LocalPlugin..::.implementedMethods Field
LocalPlugin Class See Also Send Feedback
A copy of the functions used to register.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected readonly LocalPlugin..::.MethodFlags implementedMethods
Visual Basic (Declaration)
Protected ReadOnly implementedMethods As LocalPlugin..::.MethodFlags
Visual C++
protected:
initonly LocalPlugin..::.MethodFlags implementedMethods

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


registered Field

[image]

FreeImage .NET Documentation
LocalPlugin..::.registered Field
LocalPlugin Class See Also Send Feedback
When true the plugin was registered successfully else false.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected readonly bool registered
Visual Basic (Declaration)
Protected ReadOnly registered As Boolean
Visual C++
protected:
initonly bool registered

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


LocalPlugin Methods

[image] [image] [image]

FreeImage .NET Documentation
LocalPlugin Methods
LocalPlugin Class See Also Send Feedback

The LocalPlugin type exposes the following members.

Methods

Name | Description
CloseProc | Function that can be implemented.
DescriptionProc | Function that can be implemented.
ExtensionListProc | Function that can be implemented.
Finalize | Releases all resources used by the instance. (Overrides Object..::.Finalize()()().)
FormatProc | Implementation of FormatProc
GetImplementedMethods | Function that returns a bitfield containing the implemented methods.
LoadProc | Function that can be implemented.
MimeProc | Function that can be implemented.
OpenProc | Function that can be implemented.
PageCapabilityProc | Function that can be implemented.
PageCountProc | Function that can be implemented.
Read | Reads from an unmanaged stream.
ReadByte | Reads a single byte from an unmanaged stream.
RegExprProc | Function that can be implemented.
SaveProc | Function that can be implemented.
Seek | Seeks in an unmanaged stream.
SupportsExportBPPProc | Function that can be implemented.
SupportsExportTypeProc | Function that can be implemented.
SupportsICCProfilesProc | Function that can be implemented.
Tell | Retrieves the position of an unmanaged stream.
ValidateProc | Function that can be implemented.
Write | Writes to an unmanaged stream.
WriteByte | Writes a single byte to an unmanaged stream.

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


CloseProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.CloseProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual void CloseProc(
    ref FreeImageIO io,
    fi_handle handle,
    IntPtr data
)
Visual Basic (Declaration)
Protected Overridable Sub CloseProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    data As IntPtr _
)
Visual C++
protected:
virtual void CloseProc(
    FreeImageIO% io,
    fi_handle handle,
    IntPtr data
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle
data
Type: System..::.IntPtr

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


DescriptionProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.DescriptionProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual string DescriptionProc()
Visual Basic (Declaration)
Protected Overridable Function DescriptionProc As String
Visual C++
protected:
virtual String^ DescriptionProc()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


ExtensionListProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.ExtensionListProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual string ExtensionListProc()
Visual Basic (Declaration)
Protected Overridable Function ExtensionListProc As String
Visual C++
protected:
virtual String^ ExtensionListProc()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


Finalize Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.Finalize Method
LocalPlugin Class See Also Send Feedback
Releases all resources used by the instance.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


FormatProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.FormatProc Method
LocalPlugin Class See Also Send Feedback
Implementation of FormatProc

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected abstract string FormatProc()
Visual Basic (Declaration)
Protected MustOverride Function FormatProc As String
Visual C++
protected:
virtual String^ FormatProc() abstract

Return Value

A string containing the plugins format.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


GetImplementedMethods Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.GetImplementedMethods Method
LocalPlugin Class See Also Send Feedback
Function that returns a bitfield containing the implemented methods.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected abstract LocalPlugin..::.MethodFlags GetImplementedMethods()
Visual Basic (Declaration)
Protected MustOverride Function GetImplementedMethods As LocalPlugin..::.MethodFlags
Visual C++
protected:
virtual LocalPlugin..::.MethodFlags GetImplementedMethods() abstract

Return Value

Bitfield of the implemented methods.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


LoadProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.LoadProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual FIBITMAP LoadProc(
    ref FreeImageIO io,
    fi_handle handle,
    int page,
    int flags,
    IntPtr data
)
Visual Basic (Declaration)
Protected Overridable Function LoadProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    page As Integer, _
    flags As Integer, _
    data As IntPtr _
) As FIBITMAP
Visual C++
protected:
virtual FIBITMAP LoadProc(
    FreeImageIO% io,
    fi_handle handle,
    int page,
    int flags,
    IntPtr data
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle
page
Type: System..::.Int32
flags
Type: System..::.Int32
data
Type: System..::.IntPtr

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


MimeProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.MimeProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual string MimeProc()
Visual Basic (Declaration)
Protected Overridable Function MimeProc As String
Visual C++
protected:
virtual String^ MimeProc()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


OpenProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.OpenProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual IntPtr OpenProc(
    ref FreeImageIO io,
    fi_handle handle,
    bool read
)
Visual Basic (Declaration)
Protected Overridable Function OpenProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    read As Boolean _
) As IntPtr
Visual C++
protected:
virtual IntPtr OpenProc(
    FreeImageIO% io,
    fi_handle handle,
    bool read
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle
read
Type: System..::.Boolean

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


PageCapabilityProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.PageCapabilityProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual int PageCapabilityProc(
    ref FreeImageIO io,
    fi_handle handle,
    IntPtr data
)
Visual Basic (Declaration)
Protected Overridable Function PageCapabilityProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    data As IntPtr _
) As Integer
Visual C++
protected:
virtual int PageCapabilityProc(
    FreeImageIO% io,
    fi_handle handle,
    IntPtr data
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle
data
Type: System..::.IntPtr

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


PageCountProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.PageCountProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual int PageCountProc(
    ref FreeImageIO io,
    fi_handle handle,
    IntPtr data
)
Visual Basic (Declaration)
Protected Overridable Function PageCountProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    data As IntPtr _
) As Integer
Visual C++
protected:
virtual int PageCountProc(
    FreeImageIO% io,
    fi_handle handle,
    IntPtr data
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle
data
Type: System..::.IntPtr

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


Read Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.Read Method
LocalPlugin Class See Also Send Feedback
Reads from an unmanaged stream.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected int Read(
    FreeImageIO io,
    fi_handle handle,
    uint size,
    uint count,
    ref byte[] buffer
)
Visual Basic (Declaration)
Protected Function Read ( _
    io As FreeImageIO, _
    handle As fi_handle, _
    size As UInteger, _
    count As UInteger, _
    ByRef buffer As Byte() _
) As Integer
Visual C++
protected:
int Read(
    FreeImageIO io,
    fi_handle handle,
    unsigned int size,
    unsigned int count,
    array<unsigned char>^% buffer
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO
handle
Type: FreeImageAPI.IO..::.fi_handle
size
Type: System..::.UInt32
count
Type: System..::.UInt32
buffer
Type: array< System..::.Byte >[]()[] %

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


ReadByte Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.ReadByte Method
LocalPlugin Class See Also Send Feedback
Reads a single byte from an unmanaged stream.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected int ReadByte(
    FreeImageIO io,
    fi_handle handle
)
Visual Basic (Declaration)
Protected Function ReadByte ( _
    io As FreeImageIO, _
    handle As fi_handle _
) As Integer
Visual C++
protected:
int ReadByte(
    FreeImageIO io,
    fi_handle handle
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO
handle
Type: FreeImageAPI.IO..::.fi_handle

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


RegExprProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.RegExprProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual string RegExprProc()
Visual Basic (Declaration)
Protected Overridable Function RegExprProc As String
Visual C++
protected:
virtual String^ RegExprProc()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


SaveProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.SaveProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual bool SaveProc(
    ref FreeImageIO io,
    FIBITMAP dib,
    fi_handle handle,
    int page,
    int flags,
    IntPtr data
)
Visual Basic (Declaration)
Protected Overridable Function SaveProc ( _
    ByRef io As FreeImageIO, _
    dib As FIBITMAP, _
    handle As fi_handle, _
    page As Integer, _
    flags As Integer, _
    data As IntPtr _
) As Boolean
Visual C++
protected:
virtual bool SaveProc(
    FreeImageIO% io,
    FIBITMAP dib,
    fi_handle handle,
    int page,
    int flags,
    IntPtr data
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
dib
Type: FreeImageAPI..::.FIBITMAP
handle
Type: FreeImageAPI.IO..::.fi_handle
page
Type: System..::.Int32
flags
Type: System..::.Int32
data
Type: System..::.IntPtr

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


Seek Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.Seek Method
LocalPlugin Class See Also Send Feedback
Seeks in an unmanaged stream.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected int Seek(
    FreeImageIO io,
    fi_handle handle,
    int offset,
    SeekOrigin origin
)
Visual Basic (Declaration)
Protected Function Seek ( _
    io As FreeImageIO, _
    handle As fi_handle, _
    offset As Integer, _
    origin As SeekOrigin _
) As Integer
Visual C++
protected:
int Seek(
    FreeImageIO io,
    fi_handle handle,
    int offset,
    SeekOrigin origin
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO
handle
Type: FreeImageAPI.IO..::.fi_handle
offset
Type: System..::.Int32
origin
Type: System.IO..::.SeekOrigin

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


SupportsExportBPPProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.SupportsExportBPPProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual bool SupportsExportBPPProc(
    int bpp
)
Visual Basic (Declaration)
Protected Overridable Function SupportsExportBPPProc ( _
    bpp As Integer _
) As Boolean
Visual C++
protected:
virtual bool SupportsExportBPPProc(
    int bpp
)

Parameters

bpp
Type: System..::.Int32

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


SupportsExportTypeProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.SupportsExportTypeProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual bool SupportsExportTypeProc(
    FREE_IMAGE_TYPE type
)
Visual Basic (Declaration)
Protected Overridable Function SupportsExportTypeProc ( _
    type As FREE_IMAGE_TYPE _
) As Boolean
Visual C++
protected:
virtual bool SupportsExportTypeProc(
    FREE_IMAGE_TYPE type
)

Parameters

type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


SupportsICCProfilesProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.SupportsICCProfilesProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual bool SupportsICCProfilesProc()
Visual Basic (Declaration)
Protected Overridable Function SupportsICCProfilesProc As Boolean
Visual C++
protected:
virtual bool SupportsICCProfilesProc()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


Tell Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.Tell Method
LocalPlugin Class See Also Send Feedback
Retrieves the position of an unmanaged stream.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected int Tell(
    FreeImageIO io,
    fi_handle handle
)
Visual Basic (Declaration)
Protected Function Tell ( _
    io As FreeImageIO, _
    handle As fi_handle _
) As Integer
Visual C++
protected:
int Tell(
    FreeImageIO io,
    fi_handle handle
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO
handle
Type: FreeImageAPI.IO..::.fi_handle

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


ValidateProc Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.ValidateProc Method
LocalPlugin Class See Also Send Feedback
Function that can be implemented.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected virtual bool ValidateProc(
    ref FreeImageIO io,
    fi_handle handle
)
Visual Basic (Declaration)
Protected Overridable Function ValidateProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle _
) As Boolean
Visual C++
protected:
virtual bool ValidateProc(
    FreeImageIO% io,
    fi_handle handle
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


Write Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.Write Method
LocalPlugin Class See Also Send Feedback
Writes to an unmanaged stream.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected int Write(
    FreeImageIO io,
    fi_handle handle,
    uint size,
    uint count,
    ref byte[] buffer
)
Visual Basic (Declaration)
Protected Function Write ( _
    io As FreeImageIO, _
    handle As fi_handle, _
    size As UInteger, _
    count As UInteger, _
    ByRef buffer As Byte() _
) As Integer
Visual C++
protected:
int Write(
    FreeImageIO io,
    fi_handle handle,
    unsigned int size,
    unsigned int count,
    array<unsigned char>^% buffer
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO
handle
Type: FreeImageAPI.IO..::.fi_handle
size
Type: System..::.UInt32
count
Type: System..::.UInt32
buffer
Type: array< System..::.Byte >[]()[] %

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


WriteByte Method

[image]

FreeImage .NET Documentation
LocalPlugin..::.WriteByte Method
LocalPlugin Class See Also Send Feedback
Writes a single byte to an unmanaged stream.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
protected int WriteByte(
    FreeImageIO io,
    fi_handle handle,
    byte value
)
Visual Basic (Declaration)
Protected Function WriteByte ( _
    io As FreeImageIO, _
    handle As fi_handle, _
    value As Byte _
) As Integer
Visual C++
protected:
int WriteByte(
    FreeImageIO io,
    fi_handle handle,
    unsigned char value
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO
handle
Type: FreeImageAPI.IO..::.fi_handle
value
Type: System..::.Byte

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


LocalPlugin Properties

[image] [image] [image]

FreeImage .NET Documentation
LocalPlugin Properties
LocalPlugin Class See Also Send Feedback

The LocalPlugin type exposes the following members.

Properties

Name | Description
Enabled | Gets or sets if the plugin is enabled.
Format | Gets the FREE_IMAGE_FORMAT FreeImage assigned to this plugin.
Registered | Gets if the plugin was registered successfully.

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


Enabled Property

[image]

FreeImage .NET Documentation
LocalPlugin..::.Enabled Property
LocalPlugin Class See Also Send Feedback
Gets or sets if the plugin is enabled.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


Format Property

[image]

FreeImage .NET Documentation
LocalPlugin..::.Format Property
LocalPlugin Class See Also Send Feedback
Gets the FREE_IMAGE_FORMAT FreeImage assigned to this plugin.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FREE_IMAGE_FORMAT Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As FREE_IMAGE_FORMAT
Visual C++
public:
property FREE_IMAGE_FORMAT Format {
    FREE_IMAGE_FORMAT get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


Registered Property

[image]

FreeImage .NET Documentation
LocalPlugin..::.Registered Property
LocalPlugin Class See Also Send Feedback
Gets if the plugin was registered successfully.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public bool Registered { get; }
Visual Basic (Declaration)
Public ReadOnly Property Registered As Boolean
Visual C++
public:
property bool Registered {
    bool get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

LocalPlugin Class
FreeImageAPI.Plugins Namespace


LocalPlugin.MethodFlags Enumeration

[image]

FreeImage .NET Documentation
LocalPlugin..::.MethodFlags Enumeration
LocalPlugin Class See Also Send Feedback
MethodFlags defines values to fill a bitfield telling which functions have been implemented by a plugin.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[FlagsAttribute]
protected enum MethodFlags
Visual Basic (Declaration)
<FlagsAttribute> _
Protected Enumeration MethodFlags
Visual C++
[FlagsAttribute]
protected enum class MethodFlags

Members

Member name | Description
None | No mothods implemented.
DescriptionProc | DescriptionProc has been implemented.
ExtensionListProc | ExtensionListProc has been implemented.
RegExprProc | RegExprProc has been implemented.
OpenProc | OpenProc has been implemented.
CloseProc | CloseProc has been implemented.
PageCountProc | PageCountProc has been implemented.
PageCapabilityProc | PageCapabilityProc has been implemented.
LoadProc | LoadProc has been implemented.
SaveProc | SaveProc has been implemented.
ValidateProc | ValidateProc has been implemented.
MimeProc | MimeProc has been implemented.
SupportsExportBPPProc | SupportsExportBPPProc has been implemented.
SupportsExportTypeProc | SupportsExportTypeProc has been implemented.
SupportsICCProfilesProc | SupportsICCProfilesProc has been implemented.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


MimeProc Delegate

[image]

FreeImage .NET Documentation
MimeProc Delegate
See Also Send Feedback
Delegate to a function that returns a string which contains the plugin's mime type.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate string MimeProc()
Visual Basic (Declaration)
Public Delegate Function MimeProc As String
Visual C++
public delegate String^ MimeProc()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


OpenProc Delegate

[image]

FreeImage .NET Documentation
OpenProc Delegate
See Also Send Feedback
Delegate to a function that opens a file.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate IntPtr OpenProc(
    ref FreeImageIO io,
    fi_handle handle,
    bool read
)
Visual Basic (Declaration)
Public Delegate Function OpenProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    read As Boolean _
) As IntPtr
Visual C++
public delegate IntPtr OpenProc(
    FreeImageIO% io,
    fi_handle handle,
    bool read
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle
read
Type: System..::.Boolean

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


PageCapabilityProc Delegate

[image]

FreeImage .NET Documentation
PageCapabilityProc Delegate
See Also Send Feedback
UNKNOWN

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate int PageCapabilityProc(
    ref FreeImageIO io,
    fi_handle handle,
    IntPtr data
)
Visual Basic (Declaration)
Public Delegate Function PageCapabilityProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    data As IntPtr _
) As Integer
Visual C++
public delegate int PageCapabilityProc(
    FreeImageIO% io,
    fi_handle handle,
    IntPtr data
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle
data
Type: System..::.IntPtr

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


PageCountProc Delegate

[image]

FreeImage .NET Documentation
PageCountProc Delegate
See Also Send Feedback
Delegate to a function that returns the number of pages of a multipage bitmap if the plugin is capable of handling multipage bitmaps.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate int PageCountProc(
    ref FreeImageIO io,
    fi_handle handle,
    IntPtr data
)
Visual Basic (Declaration)
Public Delegate Function PageCountProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle, _
    data As IntPtr _
) As Integer
Visual C++
public delegate int PageCountProc(
    FreeImageIO% io,
    fi_handle handle,
    IntPtr data
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle
data
Type: System..::.IntPtr

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


Plugin Structure

[image]

FreeImage .NET Documentation
Plugin Structure
Members See Also Send Feedback
The structure contains functionpointers that make up a FreeImage plugin.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
[SerializableAttribute]
public struct Plugin
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure Plugin
Visual C++
[SerializableAttribute]
public value class Plugin

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Members
FreeImageAPI.Plugins Namespace


Plugin Members

[image] [image] [image]

FreeImage .NET Documentation
Plugin Members
Plugin Structure Fields See Also Send Feedback

The Plugin type exposes the following members.

Fields

Name | Description
closeProc | Delegate to a function that closes a previosly opened file.
descriptionProc | Delegate to a function that returns a string which contains a more detailed description.
extensionListProc | Delegate to a function that returns a comma seperated list of file extensions the plugin can read or write.
formatProc | Delegate to a function that returns a string which describes the plugins format.
loadProc | Delegate to a function that loads and decodes a bitmap into memory.
mimeProc | Delegate to a function that returns a string which contains the plugin's mime type.
openProc | Delegate to a function that opens a file.
pageCapabilityProc | UNKNOWN
pageCountProc | Delegate to a function that returns the number of pages of a multipage bitmap if the plugin is capable of handling multipage bitmaps.
regExprProc | Delegate to a function that returns a regular expression that can be used to idientify whether a file can be handled by the plugin.
saveProc | Delegate to a function that saves a bitmap.
supportsExportBPPProc | Delegate to a function that returns whether the plugin can handle the specified color depth.
supportsExportTypeProc | Delegate to a function that returns whether the plugin can handle the specified image type.
supportsICCProfilesProc | Delegate to a function that returns whether the plugin can handle ICC-Profiles.
validateProc | Delegate to a function that determines whether the source is a valid image.

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


Plugin Fields

[image] [image] [image]

FreeImage .NET Documentation
Plugin Fields
Plugin Structure See Also Send Feedback

The Plugin type exposes the following members.

Fields

Name | Description
closeProc | Delegate to a function that closes a previosly opened file.
descriptionProc | Delegate to a function that returns a string which contains a more detailed description.
extensionListProc | Delegate to a function that returns a comma seperated list of file extensions the plugin can read or write.
formatProc | Delegate to a function that returns a string which describes the plugins format.
loadProc | Delegate to a function that loads and decodes a bitmap into memory.
mimeProc | Delegate to a function that returns a string which contains the plugin's mime type.
openProc | Delegate to a function that opens a file.
pageCapabilityProc | UNKNOWN
pageCountProc | Delegate to a function that returns the number of pages of a multipage bitmap if the plugin is capable of handling multipage bitmaps.
regExprProc | Delegate to a function that returns a regular expression that can be used to idientify whether a file can be handled by the plugin.
saveProc | Delegate to a function that saves a bitmap.
supportsExportBPPProc | Delegate to a function that returns whether the plugin can handle the specified color depth.
supportsExportTypeProc | Delegate to a function that returns whether the plugin can handle the specified image type.
supportsICCProfilesProc | Delegate to a function that returns whether the plugin can handle ICC-Profiles.
validateProc | Delegate to a function that determines whether the source is a valid image.

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


closeProc Field

[image]

FreeImage .NET Documentation
Plugin..::.closeProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that closes a previosly opened file.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public CloseProc closeProc
Visual Basic (Declaration)
Public closeProc As CloseProc
Visual C++
public:
CloseProc^ closeProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


descriptionProc Field

[image]

FreeImage .NET Documentation
Plugin..::.descriptionProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that returns a string which contains a more detailed description.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public DescriptionProc descriptionProc
Visual Basic (Declaration)
Public descriptionProc As DescriptionProc
Visual C++
public:
DescriptionProc^ descriptionProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


extensionListProc Field

[image]

FreeImage .NET Documentation
Plugin..::.extensionListProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that returns a comma seperated list of file extensions the plugin can read or write.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ExtensionListProc extensionListProc
Visual Basic (Declaration)
Public extensionListProc As ExtensionListProc
Visual C++
public:
ExtensionListProc^ extensionListProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


formatProc Field

[image]

FreeImage .NET Documentation
Plugin..::.formatProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that returns a string which describes the plugins format.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public FormatProc formatProc
Visual Basic (Declaration)
Public formatProc As FormatProc
Visual C++
public:
FormatProc^ formatProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


loadProc Field

[image]

FreeImage .NET Documentation
Plugin..::.loadProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that loads and decodes a bitmap into memory.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public LoadProc loadProc
Visual Basic (Declaration)
Public loadProc As LoadProc
Visual C++
public:
LoadProc^ loadProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


mimeProc Field

[image]

FreeImage .NET Documentation
Plugin..::.mimeProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that returns a string which contains the plugin's mime type.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public MimeProc mimeProc
Visual Basic (Declaration)
Public mimeProc As MimeProc
Visual C++
public:
MimeProc^ mimeProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


openProc Field

[image]

FreeImage .NET Documentation
Plugin..::.openProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that opens a file.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public OpenProc openProc
Visual Basic (Declaration)
Public openProc As OpenProc
Visual C++
public:
OpenProc^ openProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


pageCapabilityProc Field

[image]

FreeImage .NET Documentation
Plugin..::.pageCapabilityProc Field
Plugin Structure See Also Send Feedback
UNKNOWN

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public PageCapabilityProc pageCapabilityProc
Visual Basic (Declaration)
Public pageCapabilityProc As PageCapabilityProc
Visual C++
public:
PageCapabilityProc^ pageCapabilityProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


pageCountProc Field

[image]

FreeImage .NET Documentation
Plugin..::.pageCountProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that returns the number of pages of a multipage bitmap if the plugin is capable of handling multipage bitmaps.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public PageCountProc pageCountProc
Visual Basic (Declaration)
Public pageCountProc As PageCountProc
Visual C++
public:
PageCountProc^ pageCountProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


regExprProc Field

[image]

FreeImage .NET Documentation
Plugin..::.regExprProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that returns a regular expression that can be used to idientify whether a file can be handled by the plugin.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public RegExprProc regExprProc
Visual Basic (Declaration)
Public regExprProc As RegExprProc
Visual C++
public:
RegExprProc^ regExprProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


saveProc Field

[image]

FreeImage .NET Documentation
Plugin..::.saveProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that saves a bitmap.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public SaveProc saveProc
Visual Basic (Declaration)
Public saveProc As SaveProc
Visual C++
public:
SaveProc^ saveProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


supportsExportBPPProc Field

[image]

FreeImage .NET Documentation
Plugin..::.supportsExportBPPProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that returns whether the plugin can handle the specified color depth.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public SupportsExportBPPProc supportsExportBPPProc
Visual Basic (Declaration)
Public supportsExportBPPProc As SupportsExportBPPProc
Visual C++
public:
SupportsExportBPPProc^ supportsExportBPPProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


supportsExportTypeProc Field

[image]

FreeImage .NET Documentation
Plugin..::.supportsExportTypeProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that returns whether the plugin can handle the specified image type.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public SupportsExportTypeProc supportsExportTypeProc
Visual Basic (Declaration)
Public supportsExportTypeProc As SupportsExportTypeProc
Visual C++
public:
SupportsExportTypeProc^ supportsExportTypeProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


supportsICCProfilesProc Field

[image]

FreeImage .NET Documentation
Plugin..::.supportsICCProfilesProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that returns whether the plugin can handle ICC-Profiles.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public SupportsICCProfilesProc supportsICCProfilesProc
Visual Basic (Declaration)
Public supportsICCProfilesProc As SupportsICCProfilesProc
Visual C++
public:
SupportsICCProfilesProc^ supportsICCProfilesProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


validateProc Field

[image]

FreeImage .NET Documentation
Plugin..::.validateProc Field
Plugin Structure See Also Send Feedback
Delegate to a function that determines whether the source is a valid image.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public ValidateProc validateProc
Visual Basic (Declaration)
Public validateProc As ValidateProc
Visual C++
public:
ValidateProc^ validateProc

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

Plugin Structure
FreeImageAPI.Plugins Namespace


PluginRepository Class

[image]

FreeImage .NET Documentation
PluginRepository Class
Members See Also Send Feedback
Class representing all registered FreeImagePlugin in FreeImage.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static class PluginRepository
Visual Basic (Declaration)
Public NotInheritable Class PluginRepository
Visual C++
public ref class PluginRepository abstract sealed

Inheritance Hierarchy

System..::.Object
FreeImageAPI.Plugins..::.PluginRepository

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Members
FreeImageAPI.Plugins Namespace


PluginRepository Members

[image] [image] [image]

FreeImage .NET Documentation
PluginRepository Members
PluginRepository Class Methods Properties See Also Send Feedback

The PluginRepository type exposes the following members.

Methods

Name | Description
Plugin | Overloaded.
PluginFromFilename | Returns an instance of FreeImagePlugin for the given filename.
PluginFromFormat | Returns an instance of FreeImagePlugin for the given format.
PluginFromMime | Returns an instance of FreeImagePlugin for the given mime.

Properties

Name | Description
BMP | Windows or OS/2 Bitmap File (*.BMP)
BuiltInPlugins | Gets a list of built-in plugins.
CUT | Dr. Halo (*.CUT)
DDS | DirectDraw Surface (*.DDS)
EXR | OpenEXR format (*.EXR)
FAXG3 | Raw Fax format CCITT G3 (*.G3)
FIFCount | Gets the number of registered plugins.
GIF | Graphics Interchange Format (*.GIF)
HDR | High Dynamic Range (*.HDR)
ICO | Independent JPEG Group (*.JPG, *.JIF, *.JPEG, *.JPE)
IFF | Amiga IFF (*.IFF, *.LBM)
J2K | JPEG-2000 format (*.J2K, *.J2C)
JNG | JPEG Network Graphics (*.JNG)
JP2 | JPEG-2000 format (*.JP2)
JPEG | Independent JPEG Group (*.JPG, *.JIF, *.JPEG, *.JPE)
KOALA | Commodore 64 Koala format (*.KOA)
LBM | Amiga IFF (*.IFF, *.LBM)
LocalPlugins | Gets a list of local plugins.
MNG | Multiple Network Graphics (*.MNG)
PBM | Portable Bitmap (ASCII) (*.PBM)
PBMRAW | Portable Bitmap (BINARY) (*.PBM)
PCD | Kodak PhotoCD (*.PCD)
PCX | Zsoft Paintbrush PCX bitmap format (*.PCX)
PFM | Portable FloatMap (*.PFM)
PGM | Portable Graymap (ASCII) (*.PGM)
PGMRAW | Portable Graymap (BINARY) (*.PGM)
PICT | Macintosh PICT (*.PICT)
PluginList | Gets a readonly collection of all plugins.
PNG | Portable Network Graphics (*.PNG)
PPM | Portable Pixelmap (ASCII) (*.PPM)
PPMRAW | Portable Pixelmap (BINARY) (*.PPM)
PSD | Adobe Photoshop (*.PSD)
RAS | Sun Rasterfile (*.RAS)
RAW | RAW camera image (*.*)
ReadablePlugins | Gets a list of plugins that are able to read.
ReadOnlyPlugins | Gets a list of plugins that are only able to read but not to write.
SGI | Silicon Graphics SGI image format (*.SGI)
StupidPlugins | Gets a list of plugins that are not able to read or write.
TARGA | truevision Targa files (*.TGA, *.TARGA)
TIFF | Tagged Image File Format (*.TIF, *.TIFF)
WBMP | Wireless Bitmap (*.WBMP)
WriteablePlugins | Gets a list of plugins that are able to write.
WriteOnlyPlugins | Gets a list of plugins that are only able to write but not to read.
XBM | X11 Bitmap Format (*.XBM)
XPM | X11 Pixmap Format (*.XPM)

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PluginRepository Methods

[image] [image] [image]

FreeImage .NET Documentation
PluginRepository Methods
PluginRepository Class See Also Send Feedback

The PluginRepository type exposes the following members.

Methods

Name | Description
Plugin | Overloaded.
PluginFromFilename | Returns an instance of FreeImagePlugin for the given filename.
PluginFromFormat | Returns an instance of FreeImagePlugin for the given format.
PluginFromMime | Returns an instance of FreeImagePlugin for the given mime.

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


Plugin Method

[image] [image] [image]

FreeImage .NET Documentation
PluginRepository..::.Plugin Method
PluginRepository Class See Also Send Feedback

Overload List

Name | Description
Plugin(FREE_IMAGE_FORMAT) | Returns an instance of FreeImagePlugin, representing the given format.
Plugin(Int32) | Returns an instance of FreeImagePlugin, representing the format at the given index.
Plugin(String) | Returns an instance of FreeImagePlugin. expression is searched in: Format, RegExpr, ValidExtension and ValidFilename.

See Also

PluginRepository Class
PluginRepository Members
FreeImageAPI.Plugins Namespace


Plugin Method (FREE_IMAGE_FORMAT)

[image]

FreeImage .NET Documentation
PluginRepository..::.Plugin Method (FREE_IMAGE_FORMAT)
PluginRepository Class See Also Send Feedback
Returns an instance of FreeImagePlugin, representing the given format.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin Plugin(
    FREE_IMAGE_FORMAT fif
)
Visual Basic (Declaration)
Public Shared Function Plugin ( _
    fif As FREE_IMAGE_FORMAT _
) As FreeImagePlugin
Visual C++
public:
static FreeImagePlugin^ Plugin(
    FREE_IMAGE_FORMAT fif
)

Parameters

fif
Type: FreeImageAPI..::.FREE_IMAGE_FORMAT
The representing format.

Return Value

An instance of FreeImagePlugin.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
Plugin Overload
FreeImageAPI.Plugins Namespace


Plugin Method (Int32)

[image]

FreeImage .NET Documentation
PluginRepository..::.Plugin Method (Int32)
PluginRepository Class See Also Send Feedback
Returns an instance of FreeImagePlugin, representing the format at the given index.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin Plugin(
    int index
)
Visual Basic (Declaration)
Public Shared Function Plugin ( _
    index As Integer _
) As FreeImagePlugin
Visual C++
public:
static FreeImagePlugin^ Plugin(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the representing format.

Return Value

An instance of FreeImagePlugin.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
Plugin Overload
FreeImageAPI.Plugins Namespace


Plugin Method (String)

[image]

FreeImage .NET Documentation
PluginRepository..::.Plugin Method (String)
PluginRepository Class See Also Send Feedback
Returns an instance of FreeImagePlugin. expression is searched in: Format, RegExpr, ValidExtension and ValidFilename.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin Plugin(
    string expression
)
Visual Basic (Declaration)
Public Shared Function Plugin ( _
    expression As String _
) As FreeImagePlugin
Visual C++
public:
static FreeImagePlugin^ Plugin(
    String^ expression
)

Parameters

expression
Type: System..::.String
The expression to search for.

Return Value

An instance of FreeImagePlugin.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
Plugin Overload
FreeImageAPI.Plugins Namespace


PluginFromFilename Method

[image]

FreeImage .NET Documentation
PluginRepository..::.PluginFromFilename Method
PluginRepository Class See Also Send Feedback
Returns an instance of FreeImagePlugin for the given filename.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PluginFromFilename(
    string filename
)
Visual Basic (Declaration)
Public Shared Function PluginFromFilename ( _
    filename As String _
) As FreeImagePlugin
Visual C++
public:
static FreeImagePlugin^ PluginFromFilename(
    String^ filename
)

Parameters

filename
Type: System..::.String
The valid filename for the plugin.

Return Value

An instance of FreeImagePlugin.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PluginFromFormat Method

[image]

FreeImage .NET Documentation
PluginRepository..::.PluginFromFormat Method
PluginRepository Class See Also Send Feedback
Returns an instance of FreeImagePlugin for the given format.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PluginFromFormat(
    string format
)
Visual Basic (Declaration)
Public Shared Function PluginFromFormat ( _
    format As String _
) As FreeImagePlugin
Visual C++
public:
static FreeImagePlugin^ PluginFromFormat(
    String^ format
)

Parameters

format
Type: System..::.String
The format of the Plugin.

Return Value

An instance of FreeImagePlugin.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PluginFromMime Method

[image]

FreeImage .NET Documentation
PluginRepository..::.PluginFromMime Method
PluginRepository Class See Also Send Feedback
Returns an instance of FreeImagePlugin for the given mime.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PluginFromMime(
    string mime
)
Visual Basic (Declaration)
Public Shared Function PluginFromMime ( _
    mime As String _
) As FreeImagePlugin
Visual C++
public:
static FreeImagePlugin^ PluginFromMime(
    String^ mime
)

Parameters

mime
Type: System..::.String
The valid mime for the plugin.

Return Value

An instance of FreeImagePlugin.

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PluginRepository Properties

[image] [image] [image]

FreeImage .NET Documentation
PluginRepository Properties
PluginRepository Class See Also Send Feedback

The PluginRepository type exposes the following members.

Properties

Name | Description
BMP | Windows or OS/2 Bitmap File (*.BMP)
BuiltInPlugins | Gets a list of built-in plugins.
CUT | Dr. Halo (*.CUT)
DDS | DirectDraw Surface (*.DDS)
EXR | OpenEXR format (*.EXR)
FAXG3 | Raw Fax format CCITT G3 (*.G3)
FIFCount | Gets the number of registered plugins.
GIF | Graphics Interchange Format (*.GIF)
HDR | High Dynamic Range (*.HDR)
ICO | Independent JPEG Group (*.JPG, *.JIF, *.JPEG, *.JPE)
IFF | Amiga IFF (*.IFF, *.LBM)
J2K | JPEG-2000 format (*.J2K, *.J2C)
JNG | JPEG Network Graphics (*.JNG)
JP2 | JPEG-2000 format (*.JP2)
JPEG | Independent JPEG Group (*.JPG, *.JIF, *.JPEG, *.JPE)
KOALA | Commodore 64 Koala format (*.KOA)
LBM | Amiga IFF (*.IFF, *.LBM)
LocalPlugins | Gets a list of local plugins.
MNG | Multiple Network Graphics (*.MNG)
PBM | Portable Bitmap (ASCII) (*.PBM)
PBMRAW | Portable Bitmap (BINARY) (*.PBM)
PCD | Kodak PhotoCD (*.PCD)
PCX | Zsoft Paintbrush PCX bitmap format (*.PCX)
PFM | Portable FloatMap (*.PFM)
PGM | Portable Graymap (ASCII) (*.PGM)
PGMRAW | Portable Graymap (BINARY) (*.PGM)
PICT | Macintosh PICT (*.PICT)
PluginList | Gets a readonly collection of all plugins.
PNG | Portable Network Graphics (*.PNG)
PPM | Portable Pixelmap (ASCII) (*.PPM)
PPMRAW | Portable Pixelmap (BINARY) (*.PPM)
PSD | Adobe Photoshop (*.PSD)
RAS | Sun Rasterfile (*.RAS)
RAW | RAW camera image (*.*)
ReadablePlugins | Gets a list of plugins that are able to read.
ReadOnlyPlugins | Gets a list of plugins that are only able to read but not to write.
SGI | Silicon Graphics SGI image format (*.SGI)
StupidPlugins | Gets a list of plugins that are not able to read or write.
TARGA | truevision Targa files (*.TGA, *.TARGA)
TIFF | Tagged Image File Format (*.TIF, *.TIFF)
WBMP | Wireless Bitmap (*.WBMP)
WriteablePlugins | Gets a list of plugins that are able to write.
WriteOnlyPlugins | Gets a list of plugins that are only able to write but not to read.
XBM | X11 Bitmap Format (*.XBM)
XPM | X11 Pixmap Format (*.XPM)

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


BMP Property

[image]

FreeImage .NET Documentation
PluginRepository..::.BMP Property
PluginRepository Class See Also Send Feedback
Windows or OS/2 Bitmap File (*.BMP)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin BMP { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BMP As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ BMP {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


BuiltInPlugins Property

[image]

FreeImage .NET Documentation
PluginRepository..::.BuiltInPlugins Property
PluginRepository Class See Also Send Feedback
Gets a list of built-in plugins.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static List<FreeImagePlugin> BuiltInPlugins { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BuiltInPlugins As List(Of FreeImagePlugin)
Visual C++
public:
static property List<FreeImagePlugin^>^ BuiltInPlugins {
    List<FreeImagePlugin^>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


CUT Property

[image]

FreeImage .NET Documentation
PluginRepository..::.CUT Property
PluginRepository Class See Also Send Feedback
Dr. Halo (*.CUT)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin CUT { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CUT As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ CUT {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


DDS Property

[image]

FreeImage .NET Documentation
PluginRepository..::.DDS Property
PluginRepository Class See Also Send Feedback
DirectDraw Surface (*.DDS)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin DDS { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DDS As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ DDS {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


EXR Property

[image]

FreeImage .NET Documentation
PluginRepository..::.EXR Property
PluginRepository Class See Also Send Feedback
OpenEXR format (*.EXR)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin EXR { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EXR As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ EXR {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


FAXG3 Property

[image]

FreeImage .NET Documentation
PluginRepository..::.FAXG3 Property
PluginRepository Class See Also Send Feedback
Raw Fax format CCITT G3 (*.G3)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin FAXG3 { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FAXG3 As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ FAXG3 {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


FIFCount Property

[image]

FreeImage .NET Documentation
PluginRepository..::.FIFCount Property
PluginRepository Class See Also Send Feedback
Gets the number of registered plugins.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static int FIFCount { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property FIFCount As Integer
Visual C++
public:
static property int FIFCount {
    int get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


GIF Property

[image]

FreeImage .NET Documentation
PluginRepository..::.GIF Property
PluginRepository Class See Also Send Feedback
Graphics Interchange Format (*.GIF)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin GIF { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GIF As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ GIF {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


HDR Property

[image]

FreeImage .NET Documentation
PluginRepository..::.HDR Property
PluginRepository Class See Also Send Feedback
High Dynamic Range (*.HDR)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin HDR { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HDR As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ HDR {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


ICO Property

[image]

FreeImage .NET Documentation
PluginRepository..::.ICO Property
PluginRepository Class See Also Send Feedback
Independent JPEG Group (*.JPG, *.JIF, *.JPEG, *.JPE)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin ICO { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ICO As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ ICO {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


IFF Property

[image]

FreeImage .NET Documentation
PluginRepository..::.IFF Property
PluginRepository Class See Also Send Feedback
Amiga IFF (*.IFF, *.LBM)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin IFF { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IFF As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ IFF {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


J2K Property

[image]

FreeImage .NET Documentation
PluginRepository..::.J2K Property
PluginRepository Class See Also Send Feedback
JPEG-2000 format (*.J2K, *.J2C)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin J2K { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property J2K As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ J2K {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


JNG Property

[image]

FreeImage .NET Documentation
PluginRepository..::.JNG Property
PluginRepository Class See Also Send Feedback
JPEG Network Graphics (*.JNG)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin JNG { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property JNG As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ JNG {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


JP2 Property

[image]

FreeImage .NET Documentation
PluginRepository..::.JP2 Property
PluginRepository Class See Also Send Feedback
JPEG-2000 format (*.JP2)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin JP2 { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property JP2 As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ JP2 {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


JPEG Property

[image]

FreeImage .NET Documentation
PluginRepository..::.JPEG Property
PluginRepository Class See Also Send Feedback
Independent JPEG Group (*.JPG, *.JIF, *.JPEG, *.JPE)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin JPEG { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property JPEG As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ JPEG {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


KOALA Property

[image]

FreeImage .NET Documentation
PluginRepository..::.KOALA Property
PluginRepository Class See Also Send Feedback
Commodore 64 Koala format (*.KOA)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin KOALA { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property KOALA As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ KOALA {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


LBM Property

[image]

FreeImage .NET Documentation
PluginRepository..::.LBM Property
PluginRepository Class See Also Send Feedback
Amiga IFF (*.IFF, *.LBM)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin LBM { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LBM As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ LBM {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


LocalPlugins Property

[image]

FreeImage .NET Documentation
PluginRepository..::.LocalPlugins Property
PluginRepository Class See Also Send Feedback
Gets a list of local plugins.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static ReadOnlyCollection<FreeImagePlugin> LocalPlugins { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LocalPlugins As ReadOnlyCollection(Of FreeImagePlugin)
Visual C++
public:
static property ReadOnlyCollection<FreeImagePlugin^>^ LocalPlugins {
    ReadOnlyCollection<FreeImagePlugin^>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


MNG Property

[image]

FreeImage .NET Documentation
PluginRepository..::.MNG Property
PluginRepository Class See Also Send Feedback
Multiple Network Graphics (*.MNG)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin MNG { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MNG As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ MNG {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PBM Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PBM Property
PluginRepository Class See Also Send Feedback
Portable Bitmap (ASCII) (*.PBM)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PBM { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PBM As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PBM {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PBMRAW Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PBMRAW Property
PluginRepository Class See Also Send Feedback
Portable Bitmap (BINARY) (*.PBM)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PBMRAW { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PBMRAW As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PBMRAW {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PCD Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PCD Property
PluginRepository Class See Also Send Feedback
Kodak PhotoCD (*.PCD)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PCD { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PCD As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PCD {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PCX Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PCX Property
PluginRepository Class See Also Send Feedback
Zsoft Paintbrush PCX bitmap format (*.PCX)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PCX { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PCX As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PCX {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PFM Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PFM Property
PluginRepository Class See Also Send Feedback
Portable FloatMap (*.PFM)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PFM { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PFM As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PFM {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PGM Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PGM Property
PluginRepository Class See Also Send Feedback
Portable Graymap (ASCII) (*.PGM)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PGM { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PGM As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PGM {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PGMRAW Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PGMRAW Property
PluginRepository Class See Also Send Feedback
Portable Graymap (BINARY) (*.PGM)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PGMRAW { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PGMRAW As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PGMRAW {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PICT Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PICT Property
PluginRepository Class See Also Send Feedback
Macintosh PICT (*.PICT)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PICT { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PICT As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PICT {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PluginList Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PluginList Property
PluginRepository Class See Also Send Feedback
Gets a readonly collection of all plugins.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static ReadOnlyCollection<FreeImagePlugin> PluginList { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PluginList As ReadOnlyCollection(Of FreeImagePlugin)
Visual C++
public:
static property ReadOnlyCollection<FreeImagePlugin^>^ PluginList {
    ReadOnlyCollection<FreeImagePlugin^>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PNG Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PNG Property
PluginRepository Class See Also Send Feedback
Portable Network Graphics (*.PNG)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PNG { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PNG As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PNG {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PPM Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PPM Property
PluginRepository Class See Also Send Feedback
Portable Pixelmap (ASCII) (*.PPM)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PPM { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PPM As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PPM {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PPMRAW Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PPMRAW Property
PluginRepository Class See Also Send Feedback
Portable Pixelmap (BINARY) (*.PPM)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PPMRAW { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PPMRAW As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PPMRAW {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


PSD Property

[image]

FreeImage .NET Documentation
PluginRepository..::.PSD Property
PluginRepository Class See Also Send Feedback
Adobe Photoshop (*.PSD)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin PSD { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PSD As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ PSD {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


RAS Property

[image]

FreeImage .NET Documentation
PluginRepository..::.RAS Property
PluginRepository Class See Also Send Feedback
Sun Rasterfile (*.RAS)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin RAS { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RAS As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ RAS {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


RAW Property

[image]

FreeImage .NET Documentation
PluginRepository..::.RAW Property
PluginRepository Class See Also Send Feedback
RAW camera image (*.*)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin RAW { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RAW As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ RAW {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


ReadablePlugins Property

[image]

FreeImage .NET Documentation
PluginRepository..::.ReadablePlugins Property
PluginRepository Class See Also Send Feedback
Gets a list of plugins that are able to read.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static List<FreeImagePlugin> ReadablePlugins { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ReadablePlugins As List(Of FreeImagePlugin)
Visual C++
public:
static property List<FreeImagePlugin^>^ ReadablePlugins {
    List<FreeImagePlugin^>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


ReadOnlyPlugins Property

[image]

FreeImage .NET Documentation
PluginRepository..::.ReadOnlyPlugins Property
PluginRepository Class See Also Send Feedback
Gets a list of plugins that are only able to read but not to write.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static List<FreeImagePlugin> ReadOnlyPlugins { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ReadOnlyPlugins As List(Of FreeImagePlugin)
Visual C++
public:
static property List<FreeImagePlugin^>^ ReadOnlyPlugins {
    List<FreeImagePlugin^>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


SGI Property

[image]

FreeImage .NET Documentation
PluginRepository..::.SGI Property
PluginRepository Class See Also Send Feedback
Silicon Graphics SGI image format (*.SGI)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin SGI { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SGI As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ SGI {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


StupidPlugins Property

[image]

FreeImage .NET Documentation
PluginRepository..::.StupidPlugins Property
PluginRepository Class See Also Send Feedback
Gets a list of plugins that are not able to read or write.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static List<FreeImagePlugin> StupidPlugins { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StupidPlugins As List(Of FreeImagePlugin)
Visual C++
public:
static property List<FreeImagePlugin^>^ StupidPlugins {
    List<FreeImagePlugin^>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


TARGA Property

[image]

FreeImage .NET Documentation
PluginRepository..::.TARGA Property
PluginRepository Class See Also Send Feedback
truevision Targa files (*.TGA, *.TARGA)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin TARGA { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TARGA As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ TARGA {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


TIFF Property

[image]

FreeImage .NET Documentation
PluginRepository..::.TIFF Property
PluginRepository Class See Also Send Feedback
Tagged Image File Format (*.TIF, *.TIFF)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin TIFF { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TIFF As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ TIFF {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


WBMP Property

[image]

FreeImage .NET Documentation
PluginRepository..::.WBMP Property
PluginRepository Class See Also Send Feedback
Wireless Bitmap (*.WBMP)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin WBMP { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WBMP As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ WBMP {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


WriteablePlugins Property

[image]

FreeImage .NET Documentation
PluginRepository..::.WriteablePlugins Property
PluginRepository Class See Also Send Feedback
Gets a list of plugins that are able to write.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static List<FreeImagePlugin> WriteablePlugins { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WriteablePlugins As List(Of FreeImagePlugin)
Visual C++
public:
static property List<FreeImagePlugin^>^ WriteablePlugins {
    List<FreeImagePlugin^>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


WriteOnlyPlugins Property

[image]

FreeImage .NET Documentation
PluginRepository..::.WriteOnlyPlugins Property
PluginRepository Class See Also Send Feedback
Gets a list of plugins that are only able to write but not to read.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static List<FreeImagePlugin> WriteOnlyPlugins { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WriteOnlyPlugins As List(Of FreeImagePlugin)
Visual C++
public:
static property List<FreeImagePlugin^>^ WriteOnlyPlugins {
    List<FreeImagePlugin^>^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


XBM Property

[image]

FreeImage .NET Documentation
PluginRepository..::.XBM Property
PluginRepository Class See Also Send Feedback
X11 Bitmap Format (*.XBM)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin XBM { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property XBM As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ XBM {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


XPM Property

[image]

FreeImage .NET Documentation
PluginRepository..::.XPM Property
PluginRepository Class See Also Send Feedback
X11 Pixmap Format (*.XPM)

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public static FreeImagePlugin XPM { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property XPM As FreeImagePlugin
Visual C++
public:
static property FreeImagePlugin^ XPM {
    FreeImagePlugin^ get ();
}

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

PluginRepository Class
FreeImageAPI.Plugins Namespace


RegExprProc Delegate

[image]

FreeImage .NET Documentation
RegExprProc Delegate
See Also Send Feedback
Delegate to a function that returns a regular expression that can be used to idientify whether a file can be handled by the plugin.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate string RegExprProc()
Visual Basic (Declaration)
Public Delegate Function RegExprProc As String
Visual C++
public delegate String^ RegExprProc()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


SaveProc Delegate

[image]

FreeImage .NET Documentation
SaveProc Delegate
See Also Send Feedback
Delegate to a function that saves a bitmap.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate bool SaveProc(
    ref FreeImageIO io,
    FIBITMAP dib,
    fi_handle handle,
    int page,
    int flags,
    IntPtr data
)
Visual Basic (Declaration)
Public Delegate Function SaveProc ( _
    ByRef io As FreeImageIO, _
    dib As FIBITMAP, _
    handle As fi_handle, _
    page As Integer, _
    flags As Integer, _
    data As IntPtr _
) As Boolean
Visual C++
public delegate bool SaveProc(
    FreeImageIO% io,
    FIBITMAP dib,
    fi_handle handle,
    int page,
    int flags,
    IntPtr data
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
dib
Type: FreeImageAPI..::.FIBITMAP
handle
Type: FreeImageAPI.IO..::.fi_handle
page
Type: System..::.Int32
flags
Type: System..::.Int32
data
Type: System..::.IntPtr

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


SupportsExportBPPProc Delegate

[image]

FreeImage .NET Documentation
SupportsExportBPPProc Delegate
See Also Send Feedback
Delegate to a function that returns whether the plugin can handle the specified color depth.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate bool SupportsExportBPPProc(
    int bpp
)
Visual Basic (Declaration)
Public Delegate Function SupportsExportBPPProc ( _
    bpp As Integer _
) As Boolean
Visual C++
public delegate bool SupportsExportBPPProc(
    int bpp
)

Parameters

bpp
Type: System..::.Int32

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


SupportsExportTypeProc Delegate

[image]

FreeImage .NET Documentation
SupportsExportTypeProc Delegate
See Also Send Feedback
Delegate to a function that returns whether the plugin can handle the specified image type.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate bool SupportsExportTypeProc(
    FREE_IMAGE_TYPE type
)
Visual Basic (Declaration)
Public Delegate Function SupportsExportTypeProc ( _
    type As FREE_IMAGE_TYPE _
) As Boolean
Visual C++
public delegate bool SupportsExportTypeProc(
    FREE_IMAGE_TYPE type
)

Parameters

type
Type: FreeImageAPI..::.FREE_IMAGE_TYPE

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


SupportsICCProfilesProc Delegate

[image]

FreeImage .NET Documentation
SupportsICCProfilesProc Delegate
See Also Send Feedback
Delegate to a function that returns whether the plugin can handle ICC-Profiles.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate bool SupportsICCProfilesProc()
Visual Basic (Declaration)
Public Delegate Function SupportsICCProfilesProc As Boolean
Visual C++
public delegate bool SupportsICCProfilesProc()

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace


ValidateProc Delegate

[image]

FreeImage .NET Documentation
ValidateProc Delegate
See Also Send Feedback
Delegate to a function that determines whether the source defined by and is a valid image.

Namespace: FreeImageAPI.Plugins
Assembly: FreeImageNET (in FreeImageNET.dll)

Syntax

C#
public delegate bool ValidateProc(
    ref FreeImageIO io,
    fi_handle handle
)
Visual Basic (Declaration)
Public Delegate Function ValidateProc ( _
    ByRef io As FreeImageIO, _
    handle As fi_handle _
) As Boolean
Visual C++
public delegate bool ValidateProc(
    FreeImageIO% io,
    fi_handle handle
)

Parameters

io
Type: FreeImageAPI.IO..::.FreeImageIO %
handle
Type: FreeImageAPI.IO..::.fi_handle

Version Information

FreeImage.NET

Supported in: 3.11.0, 3.12.0, 3.13.0, 3.13.1

See Also

FreeImageAPI.Plugins Namespace